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Important Information
Except as otherwise expressly stated in the License that accompanies a 
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implied, including but not limited to any implied warranties of 
merchantability and fitness for a particular purpose, regarding any 
programs or book materials and makes such materials available solely on 
an "as-is" basis. In no event shall Texas Instruments be liable to anyone 
for special, collateral, incidental, or consequential damages in connection 
with or arising out of the purchase or use of these materials, and the sole 
and exclusive liability of Texas Instruments, regardless of the form of 
action, shall not exceed the amount set forth in the license for the 
program. Moreover, Texas Instruments shall not be liable for any claim of 
any kind whatsoever against the use of these materials by any other 
party.

License
Please see the complete license installed in 
C:\Program Files\TI Education\<TI-Nspire™ Product Name>\license.
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Setting up the TI-Nspire™ Navigator™ 
Teacher Software

The TI-Nspire™ Navigator™ classroom learning system provides the 
hardware and software tools you need to set up a wireless classroom 
network. 

The hardware creates a wireless communications network so that your 
computer can communicate with student handhelds. The hardware 
includes TI-Nspire™ CX Wireless Network Adapters, TI-Nspire™ 
Navigator™ Cradles, and the TI-Nspire™ Navigator™ Access Point. 

The wireless adapters are used to communicate between the TI-Nspire™ 
CX or TI-Nspire™ CX-C handhelds and the access point. The cradles are 
used to communicate between any of the TI-Nspire™ handhelds and the 
access point.

The TI-Nspire™ Navigator™ Access Point is the communication link used 
in all wireless classroom setups. The TINAVAP2 access point supports the 
following wireless clients:

• TI-Nspire™ CX Wireless Network Adapters

• TI-Nspire™ Navigator™ Cradles with FCC or IC numbers ending in 
TINAVWC2

The software contains a number of tools to enhance your classroom, 
including: 

• Quick Poll. Lets you send polls to students, receive student 
responses to the polls, and review the poll results with your students.

• Screen Capture. Lets you capture screens from the students’ 
handhelds or computers automatically or at specific time intervals. 
You can collect a stack, or history, of screens.

• Live Presenter. Lets you display work as it is being performed on 
your handheld screen or on student handheld screens.

• Review. Lets you collect and review student assignments, watch 
results in real time as students answer questions, and analyze data 
for the entire class or for individual students.

You can obtain educational content at TI’s Activities Exchange: 
education.ti.com/activities. 

http://otresources.ti.com
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Unpacking the Boxes
The TI-Nspire™ Navigator™ System product consists of TI-Nspire™ 
Navigator™ Teacher Software, an access point, and either 15 or 30 
cradles or wireless adapters, depending on your specific order. If 
necessary, you can purchase additional kits to accommodate as many as 
60 students.

Identify each item, and check the items against the following lists to 
make sure your order is complete.

Each TI-Nspire™ Navigator™ System comes with the following items.

• One TI-Nspire™ Navigator™ Access Point

• Two USB computer cables: One 18 inch and one 60 inch

• One DVD containing TI-Nspire™ Navigator™ Teacher Software

• The Getting Started with the TI-Nspire™ Navigator™ Teacher 
Software guide

One access point Two USB cables

One DVD Getting Started Guide
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If you purchased the TI-Nspire™ Navigator™ System for use with the 
TI-Nspire™ CX, TI-Nspire™ CX CAS, TI-Nspire™, or TI-Nspire™ CAS 
handhelds, contents include the following items:

• TI-Nspire™ Navigator™ Cradles

• AC9940 power adapter (includes power supply and power cord)

• TI-Nspire™ Navigator™ Cradle Charging Bay

If you purchased the TI-Nspire™ CX Navigator™ System for use with the 
TI-Nspire™ CX or TI-Nspire™ CX CAS handhelds exclusively, contents 
include the following items. Quantities will vary, depending on the 
system you purchased.

• TI-Nspire™ CX Wireless Network Adapters

• TI-Nspire™ CX Wireless Network Adapter storage cases

Charging the Cradles
The TI-Nspire™ Navigator™ Cradles contain rechargeable batteries. You 
must charge the batteries overnight before using them in class. When the 
cradles are fully charged, they will function all day under continuous use. 
You should recharge them each night.

Cradles AC9940 power adapter (for the 
charging bay)

Cradle charging bay

Wireless network adapter Storage case for the 
TI-Nspire™ CX Wireless 
Network Adapters
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The TI-Nspire™ Navigator™ Cradle Charging Bay can hold from one to 
five cradles. After you place the cradles in the charging bay, they are 
charged simultaneously until all are fully charged. If the batteries are 
fully discharged, it may take up to 12 hours to fully charge the batteries.

Note: You cannot damage the batteries by leaving them in the charging 
bay beyond the time needed to fully charge them. Also, it is not 
necessary to fully discharge the batteries before recharging them. 

Make sure you have enough (3 to 4) power outlets for the equipment 
you received. If necessary, obtain a power strip so that you have plenty of 
grounded outlets.

1. Insert the small end of the AC9940 power adapter cord into the 
charging bay’s power jack.

2. Plug the other end of the adapter into a power outlet.

3. Insert each TI-Nspire™ Navigator™ Cradle into the TI-Nspire™ 
Navigator™ Cradle Charging Bay. Make sure the LED is amber.

Note: You can charge a single wireless cradle using an AC9926 adapter 
(sold separately).

Checking the LEDs
Two LEDs (small lights) at the top of each TI-Nspire™ Navigator™ 
wireless cradle blink or change colors to indicate various operations or 
status.

LEDs
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The  LED indicates network activity. The  LED indicates battery-
charging status.

When the cradles are still in the TI-Nspire™ Navigator™ Cradle Charging 
Bay:

• A solid amber  LED means the wireless cradle is currently 
recharging.

• A solid red  LED means the wireless cradle does not have good 
contact with the charging bay. Reposition the cradle to establish 
good contact and the LED turns amber.

• A solid green  LED means the wireless cradle is fully charged.

Installing the Handheld Software
Before you use the TI-Nspire™ Navigator™ Teacher Software with 
handhelds, make sure you have the latest operating system installed on 
all of the handhelds for the software to work properly.

You can use the TI-Nspire™ Navigator™ Teacher Software to update the 
handheld operating system. 

Note: After you install the latest OS on one handheld, you can use that 
handheld to install the OS on other handhelds.

1. Connect a TI-Nspire™ handheld to your computer.

2. Show all connected handhelds.

• In the Content Workspace, click Connected Handhelds in the 
Resources pane.

• In the Documents Workspace, open the Content Explorer and 
click Connected Handhelds.

3. Click the handheld you want to update.

4. Click Help > Check for Handheld/Lab Cradle OS Update.

The Check for Handheld/Lab Cradle OS Update dialog box opens.
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5. Click Install OS on my handheld.

You can also save a copy of the OS file on your computer by clicking 
the Save a copy of the OS to check box. Click Browse to navigate to 
the location wherer you want to save the handheld OS if different 
from the default location. 

6. Click Continue.

7. Accept the license agreement and click Continue.

TI-Nspire™ Navigator™ Teacher Software displays a message box 
warning you that any unsaved data will be lost. Click Yes to 
continue.

The Installing OS dialog box opens, showing the status of the 
installation.
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8. When the operating system software has transferred to your 
TI-Nspire™ handheld, click OK. You may now disconnect the 
handheld from the computer, and the operating system software 
will install itself onto the handheld.

Connecting the Handhelds to the Wireless 
Adapters
The TI-Nspire™ CX wireless network adapters work with the TI-Nspire™ 
CX and TI-Nspire™ CX CAS handhelds. To connect the handheld to the 
wireless adapter, follow these steps.

1. Position the wireless adapter on top of the handheld so the 
connector on the adapter lines up with the connector on top of the 
handheld. 

2. Slide the adapter into position, making sure the guides on the sides 
of the adapter slide into the grooves on the sides of the handheld.

3. Firmly press the adapter into place.

À Connector

Á Guides for aligning with 
handheld

Â Grooves to align wireless 
adapter
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Connecting the Handhelds to Cradles
The cradles work with the TI-Nspire™, TI-Nspire™ CAS, TI-Nspire™ CX 
and TI-Nspire™ CX CAS handhelds. To connect the handheld to a cradle, 
follow these steps.

1. Slide the lock on the back of the cradle to the OFF position.

2. To attach the handheld, face the screen upward and slide the 
handheld onto the top of the TI-Nspire™ Navigator™ wireless 
cradle. Be sure that both sides of the handheld are inserted into both 
of the side guides.

Lock in OFF 
position.
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3. Press firmly to make a good connection. When properly connected, 
the TI-Nspire™ handheld appears to be sitting on top of the cradle.

4. Lock the handheld in place by sliding the lock on the back of the 
cradle to the ON position.

5. Insert each cradle into the charging bay. Make sure the LED is amber.

At the end of the school day, return the wireless cradle to the charging 
bay and charge them overnight. The cradles are charged when all the 

(power status) LEDs are solid green or amber.

Connecting the Access Point to the Computer
The TI-Nspire™ Navigator™ Access Point is powered by your computer. 
When you connect the access point to your computer, it is powered on 
and ready to communicate with wireless network adapters and cradles.

1. Connect the small end of the USB cable to the access point.

Lock in ON 
position.
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2. Connect the other end of the cable to the USB port on your 
computer.

3. Make sure the access point power light is on.

The power light indicates that the access point is receiving power from 
the computer. The signal light indicates wireless link activity.

The software may display a message saying the access point firmware 
needs to be updated. 

Note: You must update the firmware for the networked classroom 
system to work properly.

8 Click Yes to update the access point firmware. 

TI-Nspire™ Network Manager sends signals to the access point to add it 
to the network.

After the access point is found, the wizard displays a message.

4. Click OK.

Setting up a Network the First Time
The first time you use the software, a Network Setup wizard helps you 
associate the access point and wireless adapters and cradles for wireless 
communication. You only have to set up a network one time. After you 
set up a network the first time, you can simply open the software and 
start a class.

Before you begin, make sure the following steps have been completed.

• You have installed and activated the TI-Nspire™ Navigator™ Teacher 
Software on your computer.

À USB connection

Á Power light

Â Signal light
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• If you are using TI-Nspire™ Navigator™ Cradles, make sure each 

cradle is charged (  LED is solid amber or solid green).

Note: If you are using TI-Nspire™ Wireless Network Adapters, you 
do not need to charge them. The wireless network adapters are 
powered by the TI-Nspire™ CX or TI-Nspire™ CX CAS handheld.

• All handhelds are fully charged, and have the latest operating 
system installed.

• A cradle or network adapter is attached to each handheld.

The setup wizard helps you through the next steps.

Note: You can run the setup wizard later by opening Network Manager 
and clicking Actions > Network Setup Wizard.

1. Make sure the access point is connected to the computer with the 
USB cable.

2. Click Setup Now to proceed with the wizard.

The Identify Handheld OS Version dialog box opens.

3. Select the checkbox if handhelds have OS Version 3.2 or later, and 
then click Continue.

Click Cancel if the OS version on any handheld needs to be updated. 
Update the OS on all handhelds, and then start the wizard again.

Note: See the previous section Installing the Handheld Software for 
information on installing the latest OS on all of the handhelds.

The Navigator Network Name dialog box opens. 

4. Type a network name and click Next.

Notes: 

• Students will see all available network names when they log in to 
class, so name the network something unique that describes the 
location of your class. For example: Room 215.
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• The network name can be from 1 to 22 characters long, and can 
include letters, spaces, characters, and numbers. Some special 
characters that cannot be used are ? " % \ +.

The next step is to configure the access point.

Configuring the Access Point
After you name a network, the setup wizard opens the Select Channel 
dialog box.

The operating channel is automatically set to a default setting. You can 
change it later if necessary. The available channels are 1 through 11.

8 Click OK.

The wizard opens the Adding Wireless Clients dialog box.

Adding Wireless Clients to the Network
The next step in setting up a network is to associate the TI-Nspire™ CX 
Wireless Network Adapters and TI-Nspire™ Navigator™ Cradles with 
your classroom network. Associating wireless clients requires you to 
perform tasks on the TI-Nspire™ software and on TI-Nspire™ handhelds. 
As you add wireless clients, the Adding Wireless Clients dialog box in the 
Network Manager updates to show the additions.

Note: Before you add wireless clients to the network, make sure the 
TI-Nspire™ Navigator™ Cradles are charged. 

1. Turn on each TI-Nspire™ handheld.
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2. Attach the wireless adapter or the wireless cradle to each handheld. 
(See the instructions for connecting wireless adapters or cradles to a 
TI-Nspire™ handheld.)

3. From the Home screen of the TI-Nspire™ handheld, select 
5:Settings > 6:Network.

The handheld lists the available networks that are within range.

4. Select the network you just created and click Connect.

In the Network Manager, the Adding Wireless Clients dialog box opens, 
listing all adapters and cradles that were found.

Note: To open the TI-Nspire™ Network Manager, click Tools > Network 
Manager.

5. Highlight each wireless adapter or wireless cradle you want to add, 
and then click Add.
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To add all of the wireless clients listed in the Available Wireless 
Clients column, click Add All.

Note: If the adapter or cradle does not appear in the Available 
Wireless Clients column after six minutes, try these tips:

• Check the ID numbers of the wireless adapters or cradles to see 
which ones are not connecting.

• Detach and reattach the wireless adapter or wireless cradle to 
the handheld.

• Verify that the cradle is locked. (The lock on the back of the 
cradle is in the ON position.)

6. When all of the adapters and cradles are added, click Finish.

The software asks if you want to save the network. It is a good idea 
to save the network information; the network can be reused on a 
different computer with a new installation of the software. If you 
decide not to save the network now, you can always save it later 
using the Actions menu.

7. To save the network, click Yes.

The Save dialog box opens. By default, the TI-Nspire™ Navigator 
software creates a file named Navigator Network mm_dd_yyyy 
in the Documents > TI-Nspire>Navigator Network path.

8. Click Save, or choose another folder or file name, and then click 
Save.

To view the status of the connected handhelds, click Actions > Refresh.

Adding Wireless Adapters or Cradles Manually
The Network Setup wizard automatically guides you through the process 
for adding wireless adapters or cradles. In addition, you can manually 
add wireless adapters or cradles at any time by following the procedures 
below.

When you add a wireless adapter or cradle manually, it immediately 
appears in the TI-Nspire™ Network Manager window. 

1. Click Tools > Network Manager.

The Network Manager window opens.

2. Click Manually Add Wireless Client(s).

The Add Wireless Clients by ID Number dialog box opens.
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3. For each wireless adapter or cradle you are adding, find the ID 
number on the back of the adapter or cradle, and type it in the 
Wireless Client ID box. The ID is the last six digits of the eight-digit 
number (ignore the first two zeros).

4. Enter a nickname in the Wireless Client Nickname box (optional).

Nicknames can consist of letters, spaces, and numbers. A nickname 
must contain a minimum of 1 character and can contain a maximum 
of 64 characters.

5. Click Add Next to add another adapter or cradle if you have more 
than one wireless client to add.

6. When you are finished adding all the adapters and cradles, click 
Finish.

After you manually add wireless clients, you need to associate them 
to the network using the handhelds.

7. Turn on each TI-Nspire™ handheld.

8. Attach the wireless adapter or the wireless cradle to each handheld. 
(See the instructions for connecting wireless adapters or cradles to a 
TI-Nspire™ handheld.)

9. From the Home screen of the TI-Nspire™ handheld, select 
5:Settings > 6:Network.

The handheld lists the available networks that are within range.
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10. Select the network you added the wireless clients to, and click 
Connect.

The wireless clients are now associated with the access point.

Removing Adapters or Cradles from an Existing 
Network
Even though a classroom network has been set up correctly, sometimes 
you may need to remove TI-Nspire™ Navigator™ Wireless Network 
Adapters or TI-Nspire™ Navigator™ Cradles from the network.

You might need to remove adapters or cradles because your access point 
has been associated with wireless clients that should belong to another 
classroom.

1. In the TI-Nspire™ Network Manager window, select the wireless 
adapters and cradles that you want to remove from the network.

2. Click Actions > Remove Selected or click .

3. Click Remove at the prompt.

The wireless client is no longer listed in the Network Manager 
window.

Saving a Network
After you have set up your network, you can save the setting so it can be 
used at a later time if necessary.

The saved network information includes the list of wireless clients, the 
network name, and the channel selected on the access point.

1. Click Tools > Network Manager.

The Network Manager window opens.

2. Click Actions > Save Network Setup.
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The save dialog box opens. By default, the TI-Nspire™ Navigator 
software creates a file named Navigator Network mm_dd_yyyy 
in the Documents > TI-Nspire > Navigator Network path.

3. Click Save, or choose another folder or file name, and then click 
Save.

4. Click Actions > Refresh.

Note: You must refresh the network status to complete the setup for 
the saved network.

Reusing a Saved Network
If you have to replace an access point or use a different access point, or if 
you reinstall the software, you can reuse a saved network. A saved 
network includes the list of wireless clients, the network name, and the 
channel selected on the access point. Reusing a saved network can save 
time because you do not have to set up the network again.

1. Connect the access point to the computer.

2. Click Tools > Network Manager.

The Network Manager window opens.

3. Click Actions >Apply Saved Network Setup.

The Apply a Network dialog box opens.

4. Find the network you want to reuse:

• Browse to the location the network was saved.

• Select the network from the list.

• Type the name of the network in the File Name box.

5. Click Apply.

The network settings are applied to the access point.

Checking the Network Status
You can check the status of the network at any time in the Network 
Manager window. 

8 Click Tools > Network Manager.

The status updates automatically when you open the Network 
Manager window. 

8 Click Actions > Refresh to manually refresh the status if the 
Network Manager window is already open.

The network status shows the following information:
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• Access Point. Shows whether the AP is connected or disconnected.

• Wireless Clients. The number of wireless clients currently 
connected to the network, and the number of wireless clients 
associated with the network.

• Network Name. The name you gave the network when you set it 
up.

• Channel. The access point operating channel for the current 
nework.

• Firmware. The version of the access point.

• MAC Address. The Media Access Control address that identifies the 
access point.

After you have set up the network, all of the adapters or cradles you 
added appear in the TI-Nspire™ Network Manager window. If the 
wireless adapter or cradle is charged and attached to a TI-Nspire™ 
handheld that is powered on, TI-Nspire™ Network Manager shows the 
status as connected. It may take up to 30 seconds to recognize the 
wireless client and show its status as connected. The status window also 
displays the battery status and signal strength.
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If the cradle is not charged, or the adapter or cradle is not connected to a 
TI-Nspire™ handheld that is powered on, TI-Nspire™ Network Manager 
displays the status as disconnected. TI-Nspire™ Network Manager 
remembers the adapter and cradle IDs you added, and the next time you 
turn on the TI-Nspire™ handheld that is connected to the adapter or 
cradle, TI-Nspire™ Network Manager recognizes it.

Identifying Selected Cradles
At times you may have a problem with one or two TI-Nspire™ 
Navigator™ Cradles in your network that aren’t responding. When you 
look at the list of cradles in the TI-Nspire™ Network Manager window, 
you can identify which ones are not responding by the Status message, 
and you can see the serial numbers.

You could match the serial numbers in the window with the ones printed 
on the back of each wireless cradle. However, TI-Nspire™ Network 
Manager gives you an easier way to physically locate them. You can use 
the Identify selected command to quickly tell which cradles are working 
properly in your classroom.

1. From the list of hardware components in the TI-Nspire™ Network 
Manager window, click to select all of the working cradles. To select 
more than one cradle, press and hold the Shift or Ctrl key 
(Mac®: “ key), and click the items you want to select.

2. Click Actions > Identify Selected.

3. Look around your classroom at the cradles in your network. Both 
LEDs on the cradles that you selected will blink rapidly with a green 
color. You can identify the cradles that are not working because their 
LEDs are not blinking.

Now that you know where the non-working cradles are, you can add the 
cradles to the network again.
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Cradle LEDs
The LEDs on each TI-Nspire™ Navigator™ Cradle use various colors and 
blink patterns to indicate data activity or power status. This can occur 
either when the cradles are seated in the charging bay or when they are 
outside the charging bay.

The LEDs indicate status as follows.

 Activity LED

 Battery (Power Status) LED

Creating and Managing Your Teacher Account
Create your teacher account in the Teacher Preferences section of the 
TI-Nspire™ Navigator™ Teacher Software. A teacher account lets you log 
in to the TI-Nspire™ Navigator™ network from your handheld. After you 
create a teacher account, you can later change your password or your 
user name.

Color and pattern Meaning

Blinking green Indicates data transfer to and from the 
access point.

Color and pattern Meaning

In the charging bay

Solid amber The battery is charging.

Solid green Power on; charged and powered by a 
charging bay or power adapter.

Solid red The battery is charging, but does not have 
good contact with the charging bay. 
Reposition the cradle so it has good contact. 
The LED should then turn amber to indicate 
it is recharging.

Outside the charging bay

Blinking green Power on; battery powered. The battery is 
30% to 99% charged.

Blinking amber Low battery (less than 30% charged).

Blinking red Battery is critically low (less than 8% 
charged).



Setting up the TI-Nspire™ Navigator™ Teacher Software 21

Creating Your Teacher Account 
1. Use the Workspace selector to choose the Class workspace.

2. Click File > Settings > Teacher Preferences .

The Teacher Preferences dialog box opens.

 

3. Type a username.

4. Type a password.

5. Select or clear the preference for the teacher icon to appear in the 
classroom view.

If you select this preference, the teacher icon will appear in the 
classroom view, and you will be included as a recipient in Send to 
Class, Collect from Class, and Delete from Class operations. The 
teacher handheld screen will be included in screen captures of the 
class.

6. Select or clear the options to randomize the order in Screen Capture, 
and to individualize the teacher handheld in Screen Capture. 

• Randomize order in Screen Capture. Selecting this option 
captures and displays student screens in a random order, not the 
order on the class listing. This enables students to concentrate 
on the assignment, not whose screen they are viewing.

• Individualize Teacher Handheld in Screen Capture. 
Selecting this option shows the teacher’s screen in the screen 
capture.

7. Click OK.
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Changing the Password of Your Teacher Account
1. Make sure you are not logged in to the TI-Nspire™ Navigator™ 

network on your handheld.

2. Click File > Settings > Teacher Preferences .

The Teacher Preferences dialog box opens.

3. Click Reset.

TI-Nspire™ Navigator™ software clears the current password.

4. Type a new password.

5. Click OK.
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Changing the User Name of Your Teacher Account
1. Make sure you are not logged in to the TI-Nspire™ Navigator™ 

network on your handheld.

2. Click File > Settings > Teacher Preferences .

The Teacher Preferences dialog box opens.

3. Enter a new user name.

4. Click OK.

Logging In to the TI-Nspire™ Navigator™ System 
from the Handheld
The TI-Nspire™ Navigator™ classroom learning system uses both your 
computer and student handhelds. For you and your students to 
communicate using the TI-Nspire™ Navigator™ network, students must 
log in to the network from their handhelds.

Note: You do not have to log in to communicate with student 
handhelds; you can use the Transfer Tool to delete files or send files and 
operating systems to student handhelds. However, if you plan to 
participate from your handheld during the TI-Nspire™ Navigator™ class 
session, then you must log in to the TI-Nspire™ Navigator™ network 
from your handheld.

For more information on using a handheld, refer to the handheld 
guidebooks available at education.ti.com/guides.

Before you log in, make sure these items are ready:

• You have created your teacher account in Teacher Preferences.



24 Setting up the TI-Nspire™ Navigator™ Teacher Software

• You have started a class session on your computer.

• The TI-Nspire™ handheld is ready for login. (The icon is 
blinking.)

Before your students log in, make sure you complete these items:

• Create student accounts.

• Provide students with the class network name, their usernames and, 
if necessary, their passwords.

Logging In to the TI-Nspire™ Navigator™ Network
1. To log in, do one of the following:

• From the Home screen of your TI-Nspire™ handheld, select 
5:Settings > 5:Login.

• From a screen other than the Home screen, press ~ > 8:Login.

The last network the wireless client was associated with appears on 
the handheld screen.

Note: If the handheld is connected to the computer with the USB 
cable, no network names appear on the screen, and you can 
continue logging in. 

2. If the name of the network that appears is correct, continue with 
login. If the network is not correct, click Network. 

The handheld screens displays all networks it has been connected to, 
and also displays other networks within range.
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3. Select the network from the list, and then click Connect.

The login screen shows the connection status and displays the 
network name when the connection is successful.

4. Type your username and password.

5. Select Login.

The Login Successful screen opens.

6. Click OK.

TI-Nspire™ Handheld Login Status Icons
The icons on the TI-Nspire™ CX, TI-Nspire™ CX CAS, TI-Nspire™, and 
TI-Nspire™ CAS handheld screens indicate the communication status 
between the handheld and the access point, wireless adapter, wireless 
cradle, or TI-Navigator™ network. The icons indicate status as follows.

Icon Status Meaning

No icon If no icon appears on the handheld, the 
handheld is not searching for an access 
point. Unattach and reattach the 
wireless adapter or cradle.

Blinking The handheld is searching for an access 
point.

Solid The handheld has found an access point.
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Storing the Wireless Adapters and Cradles
When you charge the handhelds overnight, you can leave the TI-Nspire™ 
Wireless Network Adapters attached to the handhelds before placing the 
handhelds in the TI-Nspire™ CX Docking Station. When you are ready to 
use the handhelds the next morning, the handheld should be fully 
charged, and the adapter is ready for use. 

You can remove the wireless adapter from the handheld, and store the 
adapters in the adapter storage case overnight.

If you need to store the wireless adapters for more than two weeks, 
remove the wireless adapter from the handheld, and store the adapters 
in the adapter storage case. Place the storage case in a cool, dry place.

If you need to store the TI-Nspire™ Navigator™ Cradles for more than 
two weeks, remove the handhelds from the cradles, and store the cradles 
in a cool, dry place. You cannot damage the batteries by leaving them in 
the charging bay beyond the time needed to fully charge them, or by 
leaving them in the charging bay while the charging bay is unplugged.

Solid The handheld is not communicating 
with the adapter or cradle. Remove the 
handheld from the adapter or cradle, 
wait for the icon to disappear, and then 
reattach the handheld to the adapter or 
cradle.

Blinking The handheld is connected to the 
network and is ready to login.

Solid The handheld is logged in to the 
network.

Icon Status Meaning



Getting Started with TI-Nspire™ Navigator™ Teacher Software 27

Getting Started with TI-Nspire™ 
Navigator™ Teacher Software

The DVD that comes with your classroom kit contains TI-Nspire™ 
Navigator™ Teacher Software and TI-Nspire™ CAS Navigator™ Teacher 
Software.

The software automatically opens upon installation, or you can start the 
software at any time by clicking the Start > Programs > TI Tools menu 
on a PC, or the Applications menu on a Mac®, and then choosing the 
software you purchased.

To help you get started quickly when you open the software, the 
Welcome Screen appears with some common task options.

To begin working with documents, click an icon or link, or close this 
screen manually. Any normal action that takes place automatically, such 
as upgrade prompts or the ability to begin using connected handhelds, 
appears after you close the Welcome Screen.
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Navigating Through the Welcome Screen Icons
8 Press Tab to navigate through the icons.

8 Press Shift + Tab to go backward through the icons.

À Name. Shows software name.

Á Quick Start icons. Click one of these icons to create a new 
document in the chosen application. The icon applications are 
Calculator, Graphs, Geometry, Lists & Spreadsheet, Data & Statistics, 
Question, Notes, and the Vernier DataQuest™ app. The Welcome 
Screen automatically closes and the chosen application opens.

Â Preview area. When your mouse is hovering over an application 
icon or a link in Teacher Tools, this area shows a preview of the 
application or tool. A brief description of the icon or link is also 
displayed at the top of the area.

Ã Always show this at startup. Clear this check box to skip this 
screen when you open the software.

Ä Close the Welcome Screen. Click here to close this screen and 
begin working in the software.

Å Teacher Tools. Click one of these links to close the Welcome Screen 
and open the software in the chosen tool.

• View content. Opens the Content Workspace, where you can 
find content on your computer, the web, or connected 
handhelds.

• Manage handhelds. Opens the Content Workspace where you 
can see every handheld connected to your computer as well as 
the status of each.

• Transfer documents. Opens the Transfer Tool application in 
the Content Workspace, where you can send documents, 
folders, or new handheld OS files to the connected handhelds.

• View classes and students. Opens the Class Workspace where 
you can see the students in a class, or add new classes and 
students.

• Open. Opens a dialog box where you can select an existing file 
on your computer to open.

Recent Documents. Lists the names of recently opened documents. 
As your mouse hovers over each document name, the first page of 
that document is displayed in the Preview pane. Click the name of a 
document in the list to open that document.
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8 Click to act on the selected icon. 

As you move through the icons, the Preview area shows a preview of the 
application.

Opening the Welcome Screen Manually
The Welcome Screen opens automatically when you open the software. 
To open the screen manually, do the following:

8 Click Help > Welcome Screen.

Exploring the TI-Nspire™ Navigator™ Teacher 
Software
When you close the Welcome Screen, the TI-Nspire™ Navigator™ 
Teacher Software is open to the last workspace you used. If this is your 
first time using the software, the Content Workspace is open by default. 
Workspaces are explained in more detail below.

The tools described below are available in all workspaces of the 
TI-Nspire™ Navigator™ Teacher Software. For more information on 
other areas of the software, see the chapter for each workspace.
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À Title bar. Shows the name of the current document and the name 
of the software. The minimize, maximize, and close buttons are 
located in the right corner.

Á Menu bar. Contains tools for working with documents in the 
current workspace, and for modifying system settings.

Â Workspace Selector. Use these tabs to switch between the 
Content, Class, Documents, Review, and Portfolio Workspaces.

Note: Some tasks you perform may prevent you from immediately 
changing workspaces. If a dialog box awaits a response from you, 
type your response and then change workspaces.

Ã Tools menu. Shows tools frequently used when working in each 
workspace. Every workspace has the Quick Poll, Screen Capture, 
and Student Name Format icons. Other tool menu options change 
depending on which workspace is open. Those tools are covered in 
their respective chapters.

• Student Name Format lets you choose how student names are 
displayed; either by Last Name, First Name, User Name, Display 
Name, Student ID, or hidden.

• The Screen Capture tool lets you take a picture of an active 
document on the computer, or capture the screen of one or all 
connected handhelds. You can take several pictures, and you 
can copy/paste and save the images. For more information, see 
Capturing Screens.

The Quick Poll tool lets you send a poll to students that they 
immediately receive on their handhelds, and receive student 
responses. For more information, see Polling Students.

Ä Class list. Lists classes that are currently available.

Å Class Actions button. Use this to begin, pause, resume, or end a 
class.
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Exploring Workspaces
The TI-Nspire™ Navigator™ Teacher Software uses workspaces to help 
you easily access the tasks you most commonly perform. The TI-Nspire™ 
Navigator™ Teacher Software has five predefined workspaces. Each 
workspace is explained in additional detail in their respective chapters.

• Content Workspace. Find and manage content on your computer, 
links to websites, connected handhelds, or Texas Instruments web 
content.

• Class Workspace. Manage classes and students, use the class record 
panel, and exchange files with students. You can use a mix of 
TI-Nspire™ CX, TI-Nspire™ CX CAS, TI-Nspire™, and TI-Nspire™ CAS 
handhelds in the same class.

• Documents Workspace. Author documents and demonstrate 
mathematical concepts.

• Review Workspace. Review a collected set of documents; mark, 
show, or hide student responses; switch data views; and organize 
data.

• Portfolio Workspace. Save, store, review, and manage class 
assignments from students.

Exploring the Status Bar
Some information in the status bar changes, depending on which 
workspace is open.

In all workspaces, the status bar gives you information about the 
network status and the student login status.

The network status shows how many TI-Nspire™ CX Wireless Network 
Adapters and TI-Nspire™ Navigator™ Cradles are currently connected to 
the system. You can click here to launch the Network Manager window.

The student login status shows how many students are currently logged 
into class, and how many students are assigned to the current class.

In the Documents Workspace, the status bar gives additional 
information.

Network status Student login status
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In the Review Workspace, the status bar information changes, depending 
on the view in the Page Sorter.

• If you are in the document view, the status bar provides the same 
information as the Documents Workspace status bar.

• If you are in the student response view, the status bar has Data View 
icons. Use the icons to change between bar chart, table, and graph 
views. See Using the Review Workspace for more information on the 
Data Views.

In the Class Workspace, the status bar has Student View icons. Use the 
icons to change between Seating Chart view or Student List view. See 
Using the Class Workspace for more information on the Student Views.

À Problem and page number. References the current document. In 
this example, 1.3 indicates problem 1, page 3 of the active 
document.

Á Settings. Click here to view or change Document settings. 

Â Document View. Toggle between Handheld mode and Computer 
mode.

Ã Zoom/Boldness. When working with a document in Handheld 
mode, use the Zoom scale to zoom the active document in or out 
from 10% to 500%. To set a zoom, type a specific number, use the + 
and - buttons to increase or decrease by increments of 10%, or use 
the drop-down box to choose preset percentages.

When working with a document in Computer mode, use the 
Boldness scale to increase or decrease the boldness of text and line 
thickness within applications. To set the boldness, type a specific 
number, use the + and - buttons to increase or decrease by 
increments of 10%, or use the drop-down box to choose preset 
percentages.

À Graph

Á Bar chart

Â Table
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Changing Language
Use this option to select a preferred language. You must restart the 
software for the language to take effect.

1. Click File > Settings > Change Language.

The Choose a Language dialog box opens.

2. Click ¤ to open the Choose language drop-down list.

3. Select the desired language.

4. Click Quit Now to close the software immediately. You will be 
prompted to save any open documents. When you restart the 
software, the language change is effective.

—or—

Click Quit Later to continue your work. The language change is not 
applied until you close and restart the software at a later time.

Note: If you select Simplified Chinese or Traditional Chinese as the 
language in the TI-Nspire™ software, you should see Chinese characters 
in the menus and dialogs. If your computer uses the Windows® XP 
operating system and you do not see Chinese characters, you may need 
to install the Windows® XP East Asian Language Support package.

À Seating chart

Á Student List
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Tracking and Reporting System Use

Schools participating in research-based programs or schools receiving 
money from funding initiatives must track student use of the TI-Nspire™ 
Navigator™ systems and provide reports for auditing purposes.

To automatically track student usage of the TI-Nspire™ Navigator™ 
systems, teachers must create a folder named "SessionLogs" within the 
appropriate TI-Nspire™ Navigator™ software folder on their computer. If 
the SessionLogs folder is present, the software generates the files needed 
for tracking activity types, attendance, class session information, and 
activities that take place during a class session. The files are dependent 
on each other and must be kept together in the SessionLogs folder so 
that usage information is tracked and reported accurately.

After the SessionLogs folder is created, the system automatically captures 
system usage data and appends the information for each new class 
session in the appropriate file. If the system does not find a SessionLogs 
folder, data is not tracked.

Creating the SessionLogs Folder
Using the Windows® Explorer (or Finder if using a Mac®), complete the 
following steps to create the SessionLogs folder.

1. Go to the My Documents (or Documents) folder on your computer.

2. Open the folder that corresponds to the software you installed. This 
is the default folder created when you installed your TI-Nspire™ 
Navigator™ software.

• My TI-Nspire™ Navigator™ Teacher Software

• My TI-Nspire™ CAS Navigator™ Teacher Software

• My TI-Nspire™ Navigator™ NC Teacher Software

• My TI-Nspire™ CAS Navigator™ NC Teacher Software

3. Create a folder named SessionLogs.

Note: The folder name is case sensitive and must be named as 
described.

When you start the TI-Nspire™ software, the system creates the 
session files and saves them in the SessionLogs folder.
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Managing Session Logs
The system automatically generates the following comma-separated 
variable (csv) files and stores them in the SessionLogs folder. Each time 
you start the TI-Nspire™ software, logs are appended to the previous 
day’s log to keep a complete record.

Note: Users are responsible for managing the size of the files.

• ActivityTypes.csv file. This file is the lookup table that the system 
references when generating a usage report.

• Attendance.csv file. Information for each student who logs into a 
session is recorded in this file.

• ClassSession.csv file. Information for all class sessions is recorded 
in this file.

• Activities.csv file. Activities that take place during class sessions are 
recorded in this file.

Using the ActivityTypes File
The ActivityTypes file is a look-up table that includes codes for 
identifying activity types and a short description of each activity.

Activity ID Description

SC Screen Capture

CF Collect File

DF Delete File

SF Send File

RD Redistribute

SP Save to Portfolio

CM Collect Missing
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Using the Attendance File
The system records information for each student who logged into a 
session in the Attendance file. Information includes:

• Class ID. The Class ID number unique to the funding program.

• Class Name. Name of the class as defined in the software.

• Last Name. Last name of the student.

• First Name. First name of the student.

• Date and Time. Date and time when student logged in. Used to 
identify students who logged in on time versus late.

Using the Class Session File
The system records information for each class session by Class ID. 
Information includes:

• Class ID. The Class ID number unique to the funding program.

• Class Name. Name of the class as defined in the software.

• Start. Time the class started as recorded when the teacher clicks 
Begin Class.

• End. Time the class ended as recorded when the teacher clicks End 
Class.

SM Send Missing

US Umprompted Send

LP Live Presenter

QP-MC Quick Poll - Multiple Choice

QP-OR Quick Poll - Open Response

QP-EQ Quick Poll - Equations

QP-CE Quick Poll - Chemical Expression

QP-EX Quick Poll - Expressions

QP-IL Quick Poll - Image with labels

QP-IP Quick Poll - Image with point(s)

QP-CP Quick Poll - Coordinate Points

QP-LS Quick Poll - Lists & Spreadsheet

Activity ID Description



38 Tracking and Reporting System Use

• NumStudent. Number of students who logged in during the class 
session.

Using the Activities File
The system records information about the activities that took place 
during the class session in this file. Information includes:

• Class Session ID. Class ID number unique to the funding program.

• Class Name. Name of the class as defined in the software.

• Activity Type ID. Type of activity that took place during the class. 
The ID correponds to the activity types defined in the Activity Type 
file.

• Activity Detail. Additional data about the activity type if available.

• Activity Start. Time the activity started.

• Activity End. Time the activity ended.

• NumStudent. Number of students who participated in this activity.

Packaging and Sending Session Logs
The district administrator must report usage to the funding source for 
auditing purposes at regular intervals. When files are requested, teachers 
can easily package the session files into a zip file and send the file to the 
administrator. The zip file preserves the format and dependencies of the 
activity files, and includes a default file name that identifies the zip file 
for the administrator. 

Complete the following steps to package the files in the SessionLogs 
folder into a zip file and send the file to the administrator.

1. From the Content Workspace, click File > Package Session Logs.

Note: This menu item is only available if the SessionLogs folder was 
created.

The software packages the files into a zip file and assigns a default 
name (TI_PKG_SessionLogs_MMDDYYYY). The Logs package dialog 
box opens.

2. Click Yes to go to the location where the zip file was saved.
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Windows® Explorer (or Finder) opens. The zip file is saved in the 
same location as the SessionLogs folder. For example, if you have 
TI-Nspire™ Navigator™ NC Teacher Software, the SessionLogs folder 
is stored in the following location:

PC:
...\My Documents\My TI-Nspire™ Navigator™ NC Teacher Software\

Mac®

.../Documents/My TI-Nspire™ Navigator™ NC Teacher Software/

3. Email the zip file to the administrator.

Data is appended to the existing file each time you start a new 
session. If you no longer need the information after the files are sent 
to the administrator, remove them from the SessionLogs folder and 
keep the zip file. The system will generate new files the next time 
you start a new session.
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Using the Content Workspace

The Content Workspace provides access and navigation to folders and 
files stored on your computer, network, and external drives, allowing you 
to open, copy, and transfer files to students.

Exploring the Content Workspace

À Resources pane. Select content here. You can select folders and 
shortcuts on your computer, network drives, external drives, or web 
content. If you are using software that supports TI-Nspire™ 
handhelds, the Connected Handhelds heading is visible when 
handhelds are connected.

Note: You can add new links to your favorite Web sites in the Links 
section. You can access these new links in the Content pane. New 
links may not be added to the Web content section.

Á Navigation bar. Navigate to any location on your computer by 
clicking an item in the breadcrumb trail. When you select a 
resource, the options shown are specific to that resource. 

Â Content pane. By default, the folders on your desktop are 
displayed. Use this space to locate and view files on your computer. 
You can locate and access files on a connected handheld if using 
software that supports handhelds. Use the top half of the space as 
you would a file manager. Select only one item at a time (selecting 
multiple items will cause an eror in the Preview pane).
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Exploring the Resources Pane
Use the Resources pane to locate documents on a computer, access web 
content, and communicate with connected handhelds if using TI-Nspire™ 
software that supports connected handhelds.

Ã  Preview pane. Shows details about the selected file or folder. 

À Computer Content. Enables navigation to all files on a computer, 
network drives, and external drives. Computer Content expands 
and collapses to provide access to the following default shortcuts:

• Local Disk

• External drives

• Network drives

• Desktop

• Documents or My Documents

When you select an item in Computer Content, the file structure 
appears in the Content pane. When you select a folder or 
supported file, the detail is displayed in the Preview pane. 
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Á Links. By default, links to Texas Instruments sites are listed. When 
you click Links, it shows a list of links in the Content pane. Then 
when you click a link there, it launches in your web browser. You 
can add your own links to this section. Links from the latest version 
of the TI-Nspire™ software are added when you upgrade. 

Users located in the United States can search U.S. standards or 
textbooks by selecting the search option from Links.

Â Web Content. Lists links to Texas Instruments sites that contain 
TI-Nspire™-supported activities. Web Content is available if you are 
connected to the Internet. You can save material you find on these 
sites to your computer and share items through the Computer 
Content pane or Connected Handhelds if using software that 
supports handhelds. You cannot save links to websites in the Web 
Content section.

Note: The web content that is available varies depending on 
region. If there is no online content, this section is not visible in the 
Resources pane.

When you select an item in Web Content, the list of activities is 
displayed in the Content pane, and a preview of the selected 
activity is displayed in the Preview pane.

Ã Connected Handhelds. Lists handhelds connected to your 
computer. Click the Connected Handhelds label to view 
information about each handheld in the Content pane. To see 
folders and files on a specific handheld, click the handheld name. 
Connected Handhelds are not shown if there are no handhelds 
connected or if you are using TI-Nspire™ Navigator™ NC Teacher 
Software.
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Using the Preview Pane

À A thumbnail preview of the selected folder, .tns file, file-type icon, 
or lesson bundle. Double-click a file-type icon to open the file in its 
associated application.

Note: If a lesson bundle is empty and this space is blank, you have 
the option to add files.

Á If a TI-Nspire™ document has multiple pages, use the forward 

arrow  to preview the next page. The backward arrow becomes 
active so you can move backward through the pages. If working 
with a lesson bundle, you can choose to preview a TI-Nspire™ 
document within the bundle by this method.

Â If a lesson bundle is selected, the Files dialog box opens above the 
Details window listing the files in the lesson bundle. Double-click 
any file in a lesson bundle to open the file in its associated 
application.
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Accessing Computer Content 
Computer Content provides access to all information stored on your 
computer, network, and external drives.

Using the Navigation bar
The Content pane Navigation bar provides tools needed to locate folders 
and files.

Ã If a folder is selected, the Details window shows the name of the 
folder, the path where the folder is located, and the date modified.

For document files and lesson bundle files, the Details window 
shows the name, the date the file was modified, the file size, and 
whether or not the file is read only.

À  Options. Click ¤ to open the menu to access options for 
working with files and folders.

Á Current path: Contains a clickable breadcrumb trail of the current 
location. Click a breadcrumb to navigate to any section in the path.

Â Search. Enter a search keyword and press Enter to find all files 
within the selected folder containing that word.
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Filtering Computer Content
Use this filtering option for easy access and selection of your teaching 
content. You can select show TI-Nspire™ content only or to show all 
content. 

1. Select a folder in Computer Content in the Resources pane.

2. From the Menu bar, select View > Filter by.

3. Choose one of the following options.

• Show TI-Nspire™ content only

• Show all content 

Mapping a Network Drive
Complete the following steps to map a network drive.

1. Select Computer Content from the Resources list.

2. Click , and then click Create Shortcut. 

The Add Shortcut location to Content dialog box opens.

3. Click Browse.

Note: You can also type the full path name for the network drive.

The Select Shortcut Folder dialog box opens.
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4. Navigate to the network drive.

5. Click Select.

6. Click Add Location.

The Please enter network drive credentials dialog box opens.

7. Type the username and password given to you by your system 
administrator.

8. Click Accept.

The network drive is added to the list of folders under the Computer 
Content heading in the Resources pane.

Accessing a Secured Network Drive
If access to a network drive requires authentication, complete the 
following steps to access secured network.

1. Click the drive you want to access in the Resources pane.

The Please enter network drive credentials dialog box opens.

2. Type your username and password.

3. Click Accept.

Using Shortcuts
Use this option to add folders or lesson bundles containing frequently 
used files to the Computer Content list. 

Adding a Shortcut
To add a shortcut to a folder containing files you access often:
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1. Navigate to the folder where the files are located.

2. Click , and then click Create Shortcut. 

The folder is added to the list of folders under Computer Content in 
the Resources pane.

Deleting a Shortcut
To delete a shortcut:

1. From the Computer Content list, select the folder to be deleted.

2. Right-click the selected folder, and then click Remove Shortcut.

The folder is removed from the list of shortcuts.

Note: You cannot remove default shortcuts.

Working with Links
By default, the Links list contains a list of links to Texas Instruments 
websites. Click a link to launch your web browser and access the website. 

Using the Links Toolbar
When you select Links in the Resources pane, the tools on the navigation 
bar are specific to working with links. Use these tools to add, edit, or 
delete links from the list. You can also move a link up or down in the list.

Options. Click ¤ to open the menu to access options for working 
with links.

Click this icon to add a link to the list.

Select an existing link, and then click this icon to edit the link’s 
attributes. You cannot edit a default link.

Click this icon to delete a link. You cannot delete a default link.

Select a link and click this icon to move the link up in the list.

Select a link and click this icon to move the link down in the list.
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Adding a Link
Complete the following steps to add a link to the list of Links in the 
Resource pane.

1. Click .

The Add Link dialog box opens.

2. Type the name of the link.

3. Type the URL in the Address field.

4. Click Add Link.

The link is added to the bottom of the list of existing links.

Editing an Existing Link
Complete the following steps to edit an existing link.

1. Select the link you want to change.

2. Click .

The Edit Link dialog box opens.

3. Make needed changes to the name of the link or to the URL.

4. Click Edit Link.

The changes are applied to the link.
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Removing a Link
Complete the following steps to delete a link.

1. Select the link you want to delete.

2. Click .

The confirmation dialog box opens.

3. Click Remove.

The link is removed from the list.

Note: You cannot delete a default link.

Moving Links Up or Down in the List
You can change the order of the links in the list to suit your needs.

8 Click  to move a selected link up one place in the list.

8 Click  to move a selected link down one place in the link.

8 Click , and then select Move to Top of List to relocate a selected 
link to the top of the list.

8 Click , and then select Move to Bottom of List to relocate a 
selected link to the bottom of the list.

Using Web Content
Web Content provides links to online materials on Texas Instruments 
websites. You can save material found on these websites to your 
computer and share them using the Computer Content pane and 
Connected Handhelds. 

Information provided for each activity includes the name of the activity, 
the author, the date the activity was posted, the size of the file, and the 
source.
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Note: An Internet connection is required to access Texas Instruments 
websites.

Sorting the List of Activities
Use the column headings to sort the information in the list of activities. 
By default the list is displayed in alphabetical order by Name. 

• Click the Name heading to list activities in reverse alphabetical order. 
Click the heading again to return to A to Z order.

• Click the Author heading to list the activities in alphabetical order by 
author name.

• Click the Date Posted heading to list the activities in order from 
newest to oldest or from oldest to newest.

• Click the Size heading to list the activities according to file size.

• Click the Source heading to list the activities in order by source.

À Navigation toolbar.

Á Column headings.

Â List of available activities.

Ã List of the files contained in the activity.

Ä Details about the selected activity. 
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• Right-click the column heading row to customize displayed column 
headings.

Filtering the List of Activities
By default, all available activities are listed in the Content pane. Options 
on the Navigation bar enable you to filter the activities by subject, topic, 
and category. You can also search for an activity using a keyword search. 

To find all activities related to a particular subject:

1. In the Subject field, click ¤ to open the drop-down list.

2. Select a subject.

All activities related to the selected subject are listed. 

3. To narrow the search, click ¤ in the Topic field to view and select a 
topic related to the subject selected. 

4. Use the Category field to narrow the search even further. Click ¤ to 
select a category related to the selected subject and topic.

Using Keywords to Search for an Activity
Complete the following steps to search for an activity using a keyword or 
phrase.

1. Type a keyword or phrase in the Filter by Keyword field.

2. Press Enter.

All activities that contain the keyword or phrase are listed.

Opening an Activity
1. Select the activity you want to open.

2. Click , and then select Open. 

The Open Activity dialog box opens with a list of all documents 
related to the selected activity.

You can open a .tns or .tsnp file in the TI-Nspire™ software. Other 
files such as Microsoft® Word and Adobe® PDF files open in their 
respective applications.
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3. Select the file and click ¢, and then select Open.

• The .tns file opens in the Documents Workspace.

• The .doc or .pdf file opens in its associated application.

Saving an Activity to Your Computer
Complete the following steps to save an activity to your computer. 

1. Select the activity you want to save. The file details are displayed in 
the bottom half of the window.

2. Click Save this Activity to Computer in Preview pane, above Files.

Note: You can also right-click on the selected activity and choose 
Save to Computer.

The Save Selected files dialog box opens.

3. Navigate to the folder where you want to save the file.

4. Click Save. 

The activity is saved to your computer as a lesson bundle.
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Copying an Activity
Complete the following steps to copy an activity. Once the activity is 
copied to the Clipboard, you can paste the activity into a folder on your 
computer, and then drag the activity to your list of shortcuts in the Local 
Content pane.

1. Click the activity you want to copy to select it.

2. Use one of the following methods to copy the activity to the 
Clipboard:

• Select the activity and drag it to a folder in the Local Content 
list.

• Click , and then click Copy. 

• Right-click on a file in the Files list, and then click Copy.

• Click  (Copy icon), which is located in the toolbar.

The activity is copied to the Clipboard.

3. Open a folder on your computer, and then click Edit > Paste to copy 
the activity to the selected folder.
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Sending Files to Class
You can send files and folders to your whole class, members of the class 
currently logged in, or to individual students. Class must be in session for 
you to send the files.

When you send a file to the whole class, all students currently logged in 
will receive the file immediately. Students not logged in will receive the 
file when they log in.

Notes:

• Only TI-Nspire™ (.tns), PublishView™ (.tnsp), LearningCheck™ (.edc), 
and CABRI™ (.fig) file types open in the TI-Nspire™ software.

• File types .edc and .fig are converted to .tns files when they are sent 
to the class.

• Other file types (if supported) such as images, word processing, or 
spreadsheet files, open in the application the operating system has 
associated with the file type.

Sending Files from the Content or Documents Workspaces
1. Select the file you want to send to the class.

• From the Content Workspace, click the file in the Content pane.

• From the Documents Workspace, click the file in the Content 
Explorer.

2. Click Send to Class , or click File >Send to > Send to Class.

The Select individual(s) dialog box opens.
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3. Select the student(s) to whom you want to send the file:

• To send the file to the whole class, click Class . To send the 
file only to class members who are currently logged in, select the 
Logged in only check box.

• To send the file to an individual student, click Individuals  
and then click the student.

Note: If you had any students selected in the classroom area, the 
software already has them selected.

• Use the Send to handheld folder drop-down list to choose from 
the current class folder, the top level folder on the handheld, or 
the last 10 folders that files were sent to. (Available only on 
TI-Nspire™ software that supports handhelds.)

4. Click Finish.

The file transfer appears in the Class Record in the Class Workspace.
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Working with Connected Handhelds

The TI-Nspire™ software enables you to view content, manage files, and 
install operating system updates on handhelds connected to the 
computer.

To use the features described in this chapter, handhelds must be turned 
on and connected by one of these means:

• TI-Nspire™ Docking Station

• TI-Nspire™ Navigator™ Cradle and access point

• TI-Nspire™ CX Wireless Network Adapter and access point

• A direct connection through a standard USB cable

Note: The tasks in this section can only be performed using TI-Nspire™ 
handhelds.

Viewing Content on Connected Handhelds
When you select a handheld in the Resources pane in the Content 
Workspace, all files and folders on the handheld appear in the Content 
pane. To preview the document contents, select Click here to preview 
document in the Preview pane.
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When you select a handheld, all files and folders on the handheld appear 
in the Content pane. When a file or folder is selected, the details are 
displayed in the Preview pane. Click the icon to preview the document.

À  Connected Handhelds - Lists all handhelds that are connected 
and turned on.

Á Options - Available options vary depending on the task you select 
under Resources.

Â Content pane - When Connected Handhelds is selected, the 
Content pane shows details about handhelds that are connected 
and turned on:

• Handheld Type: Names of handhelds.

• Product ID: Handheld product identification.

• Boot 1: Internal bootstrap that performs lower level operation 
for booting up device.

• Boot 2: External bootstrap that performs lower level operation 
for booting up device.

• Operating System: The operating system in use.

• Available Space: The amount of space left and available on 
the handheld.

• Battery (Li-ion): Li-ion (rechargeable) battery charge (Critical 
2%, 25%, 50%, 75%, 100%, or "--" to indicate no battery is 
present).

• Battery (AAA): AAA battery charge (Critical 2%, 25%, 50%, 
75%, 100%, or "--" to indicate no battery is present).

Ã Preview pane - Provides information on a handheld when you 
click Connected Handhelds in the Resources pane and then a 
handheld in the Content pane. If you select a TI-Nspire™ file in the 
Content pane, the Preview pane shows a preview available for that 
file.
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Details about the selected folder or file are shown in the Preview pane.

8 To view the files in a folder, double-click the folder name in the 
Content pane. The files in the folder are listed in the Content pane. 

8 To preview the contents of a .tns file, select Click here to preview 
document in the Preview pane.

Managing Files on a Connected Handheld
When working with files on connected handhelds in the Content 

Workspace, use the Options menu  or the context menu to manage 
files.

Note: If you select a file type that is not supported on the handheld, 
some selections in Options menu are not active.

Details for selected folder Details for selected file

Option How it Works

Open Open a file on a connected handheld:

• Click the file you want to open.

• Click Open. The document opens in the Documents 
Workspace.



60 Working with Connected Handhelds

Save to 
Computer

Save a copy of the selected file on your computer:

• Click the file you want to save.

• Click Save to Computer. The Save Selected Files 
dialog box opens.

• Navigate to the folder where you want to save the 
file.

• Click Save.

Copy/Paste Create a copy of a file:

• Click the file you want to copy.

• Click Options > Copy to copy the file to the 
Clipboard.

• To paste the file in another location, navigate to the 
new location, and then click Options > Paste. 

Note: If you don’t select a new location, the copied 
file is pasted with a new name "Copy of ..."

Delete Delete a file on a connected handheld:

• Click the file you want to delete.

• Click Delete.

• Click Yes when the Warning dialog box opens. Click 
No to cancel.

Refresh To refresh the list of files, click Options > Refresh.

Rename To rename a file on a connected handheld:

• Click the file you want to rename.

• Click Options > Rename.

• Type the new name and press Enter.

Up a Level Go up a level in the folder hierarchy. This option is 
available when you select a file inside a folder.

New Folder Create a new folder:

• Click New Folder.

• Type a name for the new folder.

• Press Enter.

Option How it Works
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Opening Documents on a Connected Handheld
To open a document on a connected handheld in the TI-Nspire™ 
software:

1. Ensure the handheld is connected to your computer.

2. Click  to open Content Explorer.

The connected handheld name is listed in the Connected Handhelds 
pane.

3. Double-click the handheld name.

The folders and documents on the handheld are listed.

4. Navigate to the document you want to open, and then double-click 
the file name.

The document opens in the Documents Workspace. 

Saving Files to a Connected Handheld
When you save a file from your computer to a handheld, files are 
converted to TI-Nspire™ documents (.tns files). To save a file on your 
computer to a connected handheld:

1. Ensure the handheld is connected to your computer.

2. Click  to open Content Explorer.

The folders and files on your computer are listed in the Computer 
pane.

3. Navigate to the folder or file you want to save to the handheld.

4. Click the file to select it.

5. Drag the file to a connected handheld listed in the Connected 
Handheld pane.

The file is saved to the connected handheld.

Note: To save the file in a folder on the handheld, double-click the 
handheld name to list the folders and files, and then drag the file to 
a folder on the handheld.

If the file already exists on the handheld, a dialog box opens asking 
if you want to replace the file. Click Replace to overwrite the 
existing file. Click No or Cancel to abandon the save.
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Sending Files to Handhelds
You can transfer activities, folders, lesson bundles, and supported files 
from a computer to connected handhelds, from one connected handheld 
to another, or from one connected handheld to all connected handhelds.

Items you can transfer include:

• Folders

• Supported files

Note: File types .edc and .fig are converted to .tns files when they are 
sent to the handheld.

Sending an Activity to a Connected Handheld
In the Content Workspace, you can send an activity from the Web 
Content link to connected handhelds.

1. Use the Workspace selector to select the Content Workspace.

2. Click Web Content in the Resources pane.

3. Click the activity you want to send to connected handhelds.

4. Use one of the following options to send the file to the selected 
handhelds:

• Drag the file to the Selected Handhelds label to transfer to the 
file to all connected handhelds. To transfer the file to a specific 
handheld, drag the file to a specific handheld name.

• To transfer the file using Transfer Tool:

Note: You cannot use the Transfer Tool to transfer files to 
handhelds while a class is in session.

– From the toolbar, click , and then select Send to 
Connected Handhelds.

—or—

– Click , and then select Send to Connected Handhelds.

The Transfer Tool opens.

.tns .edc .fig .tco

.tnc .tno .tilb .tcc



Working with Connected Handhelds 63

5. Select the file, and then click Start Transfer. 

The selected files and folders are transferred to the selected 
handhelds.

6. When the transfer is complete, close the Transfer Tool.

Sending Files to all Connected Handhelds
You can send a file to all connected handhelds when a class is not in 
session. To transfer files or folders from a connected handheld or from 
the computer to all connected handhelds, complete the following steps:

1. Use the Workspace selector to select the Content Workspace.

2. Select the files or folders you want to transfer from the Resources 
pane.

Note: You can choose files from Computer Content, Web Content, or 
Connected Handhelds.

3. Click , and then click Send to Connected Handhelds. 

The Transfer Tool window opens.
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4. Click Start Transfer. 

Note: To add additional files to the transfer list, click Add to 
Transfer List.

The selected files and folders are transferred to the connected 
handhelds. By default, the files are transferred to a folder on the 
handheld titled Transfers-m-d-yy.

Transferring Files Between Handhelds
If multiple handhelds are connected, you can send a folder or file from 
one handheld to another handheld in the Connected Handhelds list in 
the Resources pane.

1. Use the Workspace selector to select the Content Workspace.

2. In the Resources pane, click the handheld that contains the files you 
want to transfer. The files on the handheld are listed in the Content 
pane.

3. Click the folder or file you want to send.

4. Drag the file to another handheld in the Connected Handhelds list.

Note: You can also copy and paste a file from one handheld to another.

Checking for an OS Update
When handhelds are connected, you can check for OS updates from the 
Content Workspace or from the Documents Workspace.

Note: Your computer must be connected to the Internet.
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1. Show all connected handhelds.

• In the Content Workspace, click Connected Handhelds in the 
Resources pane.

• In the Documents Workspace, open the Content Explorer and 
click Connected Handhelds.

2. Click the handheld you want to check, and then click Help > Check 
for Handheld/Lab Cradle OS Update. 

• If the operating system is current, the Check for Handheld OS 
Update dialog box opens indicating that the operating system 
on the handheld is current. 

• If the operating system is not current, the TI-Nspire™ software 
prompts you to install the latest OS now, with the option to 
download the OS to your computer.

3. To turn off automatic notifications, clear the Automatically check 
for updates check box.

4. Click OK to close the dialog box, or click Continue and follow the 
prompts to install the OS on the handheld.
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Installing an OS Update
When handhelds are connected, you can install OS updates from the 
Content Workspace or from the Documents Workspace.

Note: Updating the operating system does not replace or remove 
documents.

Ensure you have downloaded the latest operating system file. Go to 
education.ti.com/latest to download the latest operating system files.

Updating the OS on a Single Handheld
1. Show all connected handhelds.

• In the Content Workspace, click Connected Handhelds in the 
Resources pane.

• In the Documents Workspace, open the Content Explorer and 
click Connected Handhelds.

2. Click the handheld you want to update, and then choose the install 
option.

• In the Content Workspace, right-click the handheld, and then 
click Install Handheld/Lab Cradle OS.

• In the Documents Workspace, click , and then click Install 
Handheld/Lab Cradle OS.

The Select Handheld OS File dialog box opens.

3. Navigate to the folder on your computer where the operating 
system file is located. 

Note: The TI-Nspire™ software automatically shows the OS type for 
the selected handheld.

4. Click Install OS.
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5. Click Yes to confirm you want to continue the update.

6. Wait while the software is downloaded to the selected handheld, 
and then follow prompts on the handheld to finish the OS update.

Updating the OS on Multiple Handhelds
1. In the Content Workspace, click Computer Content in the Resources 

pane.

2. Click Tools > Install Handheld/Lab Cradle OS.

The Select Handheld OS File dialog box opens.

3. Click Install OS for all connected handhelds/lab cradles.

Note: You can also update an individual OS by clicking the radio 
button next to the handheld name, and then clicking Continue.

The OS Installation dialog box opens.

4. Click Add OS File.
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The Add to Transfer List dialog displays.

5. Navigate to the folder on your computer where the operating 
system file is located. 

6. Select the applicable OS files.

• To upgrade a TI-Nspire™ CX handheld, select TI-Nspire.tco.

• To upgrade a TI-Nspire™ CX CAS handheld, select TI-Nspire.tcc.

• To upgrade a TI-Nspire™ handheld, select TI-Nspire.tno.

• To upgrade a TI-Nspire™ CAS handheld, select TI-Nspire.tnc.

7. Click Select.

The OS Installation redisplays with your selected OS files.

8. Click Install OS.

The OS version information updates, and the Select OS Handheld File 
dialog redisplays for further selection.

Renaming Handhelds
You can rename the handhelds from the Content Workspace.

Note: Renaming a handheld does not affect student login information.

1. Right-click the handheld name in the Content pane.

2. Click Rename.

3. Type the new name. 

4. Press Enter to go to the next name to change.
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5. To exit the Edit mode, click an area of the screen outside the 
handheld names. You will also leave the Edit mode after you press 
Enter on the last name you edit.

Using Identify Selected to Locate Handhelds
If you are using the TI-Nspire™ Docking Station or the TI-Nspire™ CX 
Docking Station, use this feature to locate handhelds.

1. Be sure that the handhelds are turned on and that the docking 
station is connected to your computer. 

2. Use the Workspace selector to select the Content Workspace.

3. Click Tools > Identify Selected Handheld/Lab Cradle or right-click 
the handheld name in the Content pane.

Both LED lights on the docking station under the slot where the 
handheld is located will blink for 30 seconds.
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Using the Transfer Tool

When a class is not in session, you can transfer files or folders containing 
files from your computer to connected TI-Nspire™ handhelds using the 
Transfer Tool. With the Transfer Tool, you can transfer one or more files 
or documents to one or more handhelds without requiring students to 
log in.

Notes:

• You can transfer more than one operating system file at a time; 
however, you can only transfer one operating system file with the 
same file extension at a time. For example, you can transfer a .tcc 
and a .tco file at the same time, but only one .tcc file at that time.

• When transferred, the TI-Nspire™ Navigator™ Teacher Software 
converts .edc and .fig file types into .tns file types.

Transfer Tool Interface
The Transfer Tool dialog box contains a Setup tab and a Status tab.

Setup Tab
The Setup tab allows you to select files to transfer and a destination 
folder.

The Setup tab includes the following features:
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Status Tab
The Status tab is only active when a transfer is in progress.

When you start a transfer, the Transfer Tool automatically switches to the 
Status tab. The Status tab allows you to view the progress and status of 
files as they transfer and provides the following information:

Feature Description

Add to Transfer List Click to add files or folders with files to the 
Transfer List. The Transfer List displays the 
File Name (or folder name), the Destination 
Folder, and the Size (in KB) of the file or 
folder you want to transfer.

Remove Selected Click to remove selected files and folders 
from the Transfer List. This option becomes 
active when you add files to the Transfer List.

Delete all files and 
folders before transfer

Select to clear all files and folders on a 
handheld before a file transfer.

Edit Destination Folder Select to change the destination folder for 
the files you want to transfer.

Information Description

File Name Indicates the file name and extension.
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Notes:

• If no transfers are active, the following message is displayed: “No 
transfers are active. Use the Setup tab to configure and start the 
transfer.”

• During a transfer, no options are available on the Setup tab.

Opening the Transfer Tool
Before you can use the Transfer Tool, you must end any running class 
sessions.

To open the Transfer Tool, use one of these methods:

8 Click Tools > Transfer Tool.

8 Click , and then select Send to Connected Handhelds.

The Transfer Tool opens the Setup tab.

Adding Files or Folders to the Transfer List
You must add files or folders to the Transfer List before you can start a 
transfer.

Note: You can only add a folder that contains files to the Transfer List.

To add files or folders to the Transfer List:

1. In the Transfer Tool dialog box, click Add to Transfer List.

The Add to Transfer List dialog box opens.

Folder/Handheld ID Indicates the destination folder and the handheld 
ID.

Status Indicates the completion status, the progress bar, 
or any error message. Error messages include:

• Low battery

• Wrong handheld type

• Memory full

• Lost connectivity

Information Description
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2. To add files to the Transfer List, navigate to the folder or folders that 
contain the files you want to transfer. 

3. Click Select to add highlighted files to the Transfer list.

• On the Files tab, you can see both files and folders, but you 
cannot select folders. You must drill down and select a file.

• To select multiple files within a folder, press and hold the Ctrl 
key (Mac®: “) while selecting files.

4. To add folders containing files, click the Folders tab and navigate to 
the folder you want to select. 

5. Click Select to add the highlighted folders.

Note: To select multiple folders, press and hold the Ctrl key 
(Mac®: “) while selecting folders.

Selected files and folders are displayed in the Transfer Tool dialog 
box.



Using the Transfer Tool 75

Note: You can only add one operating system file type to the 
Transfer List. If you attempt to add more than one operating system 
file type, the following error message is displayed.

Removing Files or Folders from the Transfer List
You can remove files or folders that you no longer want to transfer.

To remove files or folders from the Transfer List, complete the following 
steps:

1. In the Transfer Tool dialog box, select files or folders you want to 
remove.

Note: To select multiple files or folders, press and hold the Ctrl key 
(Mac®: “) while selecting each file or folder.
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2. Click Remove Selected.

The files or folders are removed from the Transfer List.

Editing the Destination Folder
Except for an operating system file, you can change the destination 
folder for any file or folder in the Transfer List.

By default, the Transfer Tool creates the destination folder “Transfer-
date.” The date format is based on the user’s preferred language setting 
and location. For example, the default date format for the United States 
is mm-dd-yy. If you change your preferred language setting, this default 
date format changes.

To change the destination folder:

1. Click a file or folder.

2. Complete one of the following actions:

• From the Edit Destination Folder drop-down list, select the top 
level folder for any available handheld or any available folder.

• In the Edit Destination Folder drop-down list, type a new 
destination folder name.
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Note: Folder names can contain alphanumeric characters and can 
include slashes ( / and \ ). You cannot use double slashes ( // and \\ ) 
and these special characters (? | : * " " < > | ).

3. Click Change.

The destination folder in the Transfer List changes for the files or 
folders you selected.

Deleting All Handheld Files and Folders
You can use the Transfer Tool to delete all files and folders on a 
connected handheld. Use this feature to delete existing files and folders 
to ensure that only the files you want students to work with are on the 
handhelds.

By default, the Transfer Tool disables this setting. If selected, the new 
setting becomes the default the next time you open Transfer Tool.

To delete all files and folders from a connected handheld: 

1. In the Transfer Tool dialog box, select Delete all files and folders 
before transfer.
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2. Click Start Transfer.

The Confirm dialog box opens.

3. Click Yes.

The Transfer Tools displays the Status tab. This tab displays the status 
and progress as files are deleted. 

Starting a Transfer
After you have added all files and folders to the Transfer List and selected 
other options as necessary, you can start the transfer. You can transfer 
operating system files and documents at the same time.

To start a transfer:

1. Connect one or more TI-Nspire™ handhelds.

If handhelds are not connected, the Status tab indicates “No Active 
Connected Handhelds” when you start a transfer.

2. From the Resources pane, complete one of the following actions:

• To transfer files to one or more TI-Nspire™ handhelds, select the 
individual handhelds.
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• To transfer files to all connected TI-Nspire™ handhelds, select 
Connected Handhelds (top level).

3. In the Transfer Tool dialog box, click Start Transfer.

The Transfer Tool dialog box switches to the Status tab and displays 
the transfer information.

• The progress bar disappears when a transfer is complete.

• During a transfer, the Transfer Tool indicates which handhelds 
are connected and successfully received files.

• If a handheld disconnects and then reconnects during a transfer, 
the Transfer Tool indicates the status of completed transfers, and 
resumes transferring other files as necessary.

Stopping File Transfers
You can stop a file transfer at any time.

To stop a file transfer:

1. In the Transfer Tool, click Stop Transfer. 

The Confirm dialog box opens.

2. Click Yes.

The Transfer Tool stops transferring and displays the Setup tab.

• If a connected handheld has already received files, those files 
remain on the handhelds.

• Files remain in the Setup tab until you close the Transfer Tool, or 
until you delete them.

Closing the Transfer Tool
When you have completed transferring files and folders, close the 
Transfer Tool.

8 To close the Transfer Tool, click Close.

• You cannot close the Transfer Tool if a transfer is active.
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• When closed, the Transfer Tool clears files and folders you added 
to the Transfer List.

• When closed, the Transfer Tool keeps the last Delete all files 
and folders before transfer setting.



Using the Documents Workspace 81

Using the Documents Workspace

Use this workspace to create, modify, and view TI-Nspire™ and 
PublishView™ documents, and to demonstrate mathematical concepts.

Exploring the Documents Workspace

À Documents Toolbox. Contains tools such as the Document Tools 
menu, Page Sorter, Content Explorer, Utilities, and TI-SmartView™ 
emulator. Click each icon to access the available tools. When you 
are working in a TI-Nspire™ document, the tools available are 
specific to that document. When you are working in a 
PublishView™ document, the tools are specific to that document 
type.

Á Toolbox pane. Options for the selected tool are displayed in this 
area. For example, click the Document Tools icon to access tools 
needed to work with the active application.

Note: In the TI-Nspire™ Teacher Software, the tool for configuring 
questions opens in this space when you insert a question. For more 
information, see Using Question in the TI-Nspire™ Teacher 
Software.

Â Work area. Shows the current document and enables you to 
perform calculations, add applications, and add pages and 
problems. Only one document at a time is active (selected). 
Multiple documents appear as tabs. 

Ã Document information. Shows the names of all open documents. 
When there too many open documents to list, click the forward 
and backward arrows to scroll through the open documents.
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Using the Documents Toolbox
The Documents Toolbox, located on the left side of the workspace, 
contains tools needed for working with both TI-Nspire™ documents and 
PublishView™ documents. When you click a toolbox icon, the associated 
tools appear in the Toolbox pane.

Exploring Document Tools
In the following example, the Document Tools menu is open showing the 
options for the Calculator application. In TI-Nspire™ documents, the 
Document Tools menu contains tools available for working with an 
application. The tools are specific to the active application. 

In PublishView™ documents, the Document Tools menu contains tools 
needed to insert TI-Nspire™ applications and TI-Nspire™ documents, as 
well as multimedia objects such as text boxes, images, and links to 
websites and files. For more information, see Working with 
PublishView™ Documents.

À The Documents Toolbox menu.

Á Tools available for the Calculator application. Click ¢ to open the 
submenu for each option.
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Exploring the Page Sorter
The following example shows the Documents Toolbox with the Page 
Sorter open. Use the Page Sorter to:

• See the number of problems in your document and where you are.

• Move from one page to another by clicking on the page you want.

• Add, cut, copy, and paste pages and problems within the same 
document or between documents.

Note: When working in a PublishView™ document, the Page Sorter is 
not available in the Documents Toolbox.

Â Click  to close and click  open Document Tools.

À The Documents Toolbox menu.

Á Click the minus sign to collapse the view. Click the + sign to open 
the view and show pages in the document.

Â Scroll bar. The scroll bar is only active when there are too many 
pages to show in the pane.



84 Using the Documents Workspace

Exploring the TI-SmartView™ Feature
The TI-SmartView™ feature emulates how a handheld works. In the 
teacher software, the emulated handheld facilitates classroom 
presentations. In the student software, the emulated keypad gives 
students the ability to drive the software as if using a handheld.

Note: Content is displayed on the TI-SmartView™ small screen only when 
the document is in Handheld view.

When working in a PublishView™ document, TI-SmartView™ emulator is 
not available.

Note: The following illustration shows the TI-SmartView™ panel in the 
teacher software. In the Student Software, only the keypad is shown. For 
more information, see Using the TI-SmartView™ Emulator.
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Exploring Content Explorer
Use Content Explorer to:

• See a list of files on your computer.

• Create and manage lesson bundles.

• If using software that supports connected handhelds, you can:

– See a list of files on any connected handheld.

– Update the OS on connected handhelds.

– Transfer files between a computer and connected handhelds.

À The Documents Toolbox menu.

Á Handheld Selector. Click ¤ to select which handheld to show in the 
pane:

• TI-Nspire™ CX

• TI-Nspire™ Touchpad

• TI-Nspire™ Clickpad

Then, select how to show the handheld:

• Normal

• High contrast

• Outline

Â View selector. In the teacher software, click ¤ to select the 
handheld view:

• Handheld only

• Keypad plus side screen

• Handheld plus sidescreen

Note: You can also change these options in the TI-SmartView™ 
Options window. Click File> Settings > TI-Smartview™ Options to 
open the window.

Note: The view selector is not available in the student software.

When the Handheld Only display is active, select Always in Front 
to keep the display in front of all other open applications. (Teacher 
software only.)
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Note: If you are using TI-Nspire™ software that does not support 
connected handhelds, the Connected Handheld heading is not shown in 
the Content Explorer pane.

À The Documents Toolbox menu.

Á Shows files on your computer and the name of the folder where 
the files are located. Click ¤ to navigate to another folder on the 
computer.

Â The list of folders and files within the folder named in the Look In: 
field. Right-click on a highlighted file or folder to open the context 
menu listing available actions for that file or folder.

Ã Click  to close the list of files. Click  to open the list of files.
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Exploring Utilities
Utilities provides access to the math templates and operators, special 
symbols, catalog items, and libraries that you need when working with 
documents. In the following example, the Math templates tab is open.

Ä Options menu. Click ¤ to open the menu of actions you can 
perform on a selected file:

• Open an existing file or folder.

• Move (navigate) up one level in the folder hierarchy.

• Create a new folder.

• Create a new lesson bundle. 

• Rename a file or folder.

• Copy selected file or folder.

• Paste file or folder copied to Clipboard.

• Delete selected file or folder.

• Select all files in a folder.

• Package lesson bundles.

• Refresh the view.

• Install OS.

Å Connected handhelds. Lists the connected handhelds. Multiple 
handhelds are listed if more than one handheld is connected to the 
computer or when using the TI-Nspire™ Docking Stations.

Æ The name of the connected handheld. To show the folders and files 
on a handheld, double-click the name.

Click ¤ to navigate to another folder on the handheld.
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À The Documents Toolbox menu.

Á Math Templates are open. Double-click a template to add it to a 
document. Click the Math Template tab to close the template view.

To open the Symbols, Catalog, Math Operators, and Libraries, click 
the tab. 

Â Wizards On check box. Select this option to use a wizard to enter 
function arguments. 

Ã Tabs for opening views where you can select and add symbols, 
catalog items, math operators, and library items to a document. 
Click the tab to open the view. 
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Using the Work Area
The space on the right side of the workspace provides an area for 
creating and working with TI-Nspire™ and PublishView™ documents. 
This work area provides a view of the document so that you can add 
pages, add applications, and perform all work. Only one document at a 
time is active. 

You can view documents in one of two views: computer mode or 
handheld mode. Either view will remember the last size and file location 
you used. 

• Handheld mode. View documents as they appear on the handheld 
screen. The screen size is limited as it would be on the handheld.

• Computer mode. This is the default view in the software.

For more information about working with documents, see Working with 
TI-Nspire™ Documents.

Changing Document Settings
Document settings control how all numbers, including elements or 
matrices and lists, are displayed in TI-Nspire™ and PublishView™ 
documents. You can change the default settings at anytime and you can 
specify settings for a specific document.

Changing Document Settings
Complete the following steps to customize the settings that are applied 
to your document.

1. Create a new document or open an existing document.

2. From the status bar, double-click Settings.

—or—

Click File > Settings > Document Settings.

The Document Settings dialog box opens.

When you open Document Settings the first time, the default 
settings are displayed.
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3. Press Tab or use your mouse to move through the list of settings. 
Click ¤ to open the drop-down list to view the available values for 
each setting.

Field Value

Display Digits • Float

• Float1 - Float12

• Fix0 - Fix12

Angle • Radian

• Degree

• Gradian

Exponential Format • Normal

• Scientific

• Engineering

Real or Complex 
Format

• Real

• Rectangular

• Polar
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4. Click the desired setting.

5. Choose one of the following options:

• To apply the customized settings to ALL documents, click Make 
Default.

• To apply the settings to the open document only, click OK.

• To restore default settings, click Restore.

• Click Cancel to close the dialog box without making changes.

Changing Graphs & Geometry Settings
Graphs & Geometry settings control how information is displayed in 
open problems and in subsequent new problems. When you change the 
Graphs & Geometry settings, the selections become the default settings 
for all work in these applications.

Complete the following steps to customize the application settings for 
graphs and geometry.

1. Create a new graphs and geometry document or open an existing 
document.

Calculation Mode • Auto

• CAS: Exact

• Approximate

Note: Auto mode shows an answer that is 
not a whole number as a fraction except 
when a decimal is used in the problem. 
Exact mode (CAS) shows an answer that is 
not a whole number as a fraction or in 
symbolic form, except when a decimal is 
used in the problem.

Vector Format • Rectangular

• Cylindrical

• Spherical

Base • Decimal

• Hex

• Binary

Unit System (CAS) • SI

• Eng/U.S.

Field Value



92 Using the Documents Workspace

2. In the Documents Toolbox, click  to open the Graphs & 
Geometry application menu.

3. Click Settings > Settings. 

The Graphs & Geometry Settings dialog box opens.

4. Press Tab or use your mouse to move through the list of settings. 
Click ¢ to open the drop-down list to view the available values for 
each setting.

Field Values

Display Digits • Auto

• Float

• Float1 - Float12

• Fix0 - Fix12

Graphing Angle • Auto

• Radian

• Degree

• Gradian

Geometry Angle • Auto

• Radian

• Degree

• Gradian
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5. Select the desired setting.

6. Select a check box to enable an option or clear a check box to disable 
an option.

7. Choose one of the following options:

• To apply the customized settings to ALL graphs and geometry 
documents, click Make Default.

• To apply the settings to the open document only, click OK.

• To restore default settings, click Restore.

• Click Cancel to close the dialog box without making changes.

Check box Operation when selected

Automatically hide plot 
labels

Plot labels are displayed only when 
selected, grabbed, or hovered.

Show axis end values A numeric label is displayed at the 
least and greatest values visible on 
an axis

Show tool tips for function 
manipulation

Shows helpful information as you 
manipulate function graphs

Automatically find a point 
of interest

Shows zeros, minima, and maxima 
for graphed functions and objects 
while tracing function graphs.
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Working with TI-Nspire™ Documents

This section describes how to work with TI-Nspire™ documents in the 
Documents Workspace. 

About Documents
All work that you create and save using TI-Nspire™ applications is stored 
as a document, which you can share with others using TI-Nspire™ 
software and with those using handhelds. There are two types of 
documents: 

• TI-Nspire™ document (.tns file)

• PublishView™ document (.tnsp file)

TI-Nspire™ Documents
A TI-Nspire™ document consists of one or more problems and each 
problem contains one or more pages. A single page is displayed in the 
work area. All work occurs in the applications within pages. Because the 
TI-Nspire™ software and handhelds share the same functionality, you can 
create TI-Nspire™ documents that can be transferred between the 
software and a handheld. 

PublishView™ Documents
PublishView™ documents can be printed on a standard piece of paper or 
published to a website or blog. PublishView™ documents can include 
formatted text, images, and hyperlinks as well as all TI-Nspire™ 
applications.

For more information, see Working with PublishView™ Documents.

Creating a New TI-Nspire™ Document
When you open the software, the Documents Workspace opens with a 
blank document containing one problem. You can add applications and 
content to this problem to create a document.

Note: The Welcome Screen is displayed when you open the software if 
the "always show this at startup" option is selected. Click an application 
icon to add a problem with an active application to a new document. 



96 Working with TI-Nspire™ Documents

To create a new document, complete the following steps:

1. Click File > New TI-Nspire™ Document.

—or—

Click .

2. Click New TI-Nspire™ Document.

The new document opens in the Documents Workspace and you are 
prompted to select an application. By default, new documents open 
in your current view: computer or handheld. To change the view, use 
the View menu or click the appropriate icon in the status bar.

3. Select an application to add a problem to the document.

The problem is added to the document.

Opening an Existing Document
To open an existing document:

1. Click File > Open Document.

—or—

Click . 

The Open dialog box opens.
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2. Use the file browser to locate the file you want to open and click the 
file to select it.

3. Click Open. 

The document opens in the work area.

Note: To select from your 10 most recent documents, click File > Recent 
Documents and select a document from the drop-down list.

Saving TI-Nspire™ Documents
To save a new document:

1. Click File > Save Document or click . 

The Save TI-Nspire™ Document dialog box opens.
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2. Navigate to the folder where you want to save the document or 
create a folder in which to store the document.

3. Type a name for the new document. 

4. Click Save to save the document.

The document closes and is saved with the extension .tns. 

Note: When you save a file, the software looks in the same folder the 
next time you open a file.

Saving a Document with a New Name
To save a previously saved document in a new folder and/or with a new 
name:

1. Click File > Save As.

The Save TI-Nspire™ Document dialog box opens. 

2. Navigate to the folder where you want to save the document or 
create a folder in which to store the document.

3. Type a new name for the document. 

4. Click Save to save the document with a new name.

Deleting Documents
File deletions on your computer are sent to the Recycle bin and can be 
retrieved if the Recycle bin has not been emptied.

Note: File deletions on the handheld are permanent and cannot be 
undone, so be sure that you want to delete the file that you select. 

1. Select the document you want to delete.

2. Click Edit > Delete or press Delete.

The Warning dialog box opens.

3. Click Yes to confirm the delete.

The document is deleted.

Closing Documents
8 To close a document, click File > Close or click the Close icon on the 

document tab at the bottom of the document.
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8 If working in tiled view, click the Close icon in the upper right corner 
of the document window.

Formatting Text in Documents
Use the text formatting tools to format text in TI-Nspire™ applications 
that allow text input, and to format text in PublishView™ documents. By 
default, the text formatting toolbar opens in the area above an active 
document. Options on the toolbar are enabled or disabled depending on 
the active application.

For example, the following image shows options available in an active 
Graphs & Geometry document.

Option Function

Click ¤ to open the menu for the active 
application. This tool enables you to open an 
application menu regardless of the option 
selected in the Documents Toolbox.

Click ¤ to select a background color for 
highlighting text or choose a fill color for a 
selected cell. 

Click ¤ to select the line color for an object. For 
example, in Graphs & Geometry, you can 
choose a color for a selected shape.

Click ¤ to select a color for selected text.

Use these tools to choose a font and set the size 
of the font. 

• Click ¤ to select a different font from the 
drop-down box. 

• To select as specific font size, click ¤ to 
select a size from the drop-down box.

• Click  to increase the font size or click 

 to decrease the font size incrementally.
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Hiding and Showing the Formatting Toolbar

8 When the formatting toolbar is visible, click £ (located under the 
toolbar) to hide the toolbar.

8 Click ¤ to show the toolbar when the formatting toolbar is hidden.

Using Colors in Documents
In the TI-Nspire™ applications that allow formatting, you can use color in 
filled areas of an object, or in lines or text, depending on the application 
you are using and how you have selected the item. If the icon or menu 
item that you want to use is not available (dimmed) after you have 
selected an item, color is not an option for the selected item.

Colors appear in documents opened on your computer and on the 
TI-Nspire™ CX handheld. If a document containing color is opened on a 
TI-Nspire™ handheld, colors are displayed in shades of gray. 

Note: For more information about using color in a TI-Nspire™ 
application, see the chapter for that application.

Adding Color from a List
To add color to a fill area, line, or text, complete the following steps:

1. Select the item.

2. Click Edit > Color or select where you want to add color (fill, line, or 
text).

3. Select the color from the list.

Click the appropriate tool to apply bolding, 
italics, or underlining; apply superscript or 
subscript; or strike out text. 

In a PublishView™ document, use these tools to 
position text within the header or footer, or in 

text box. Clicking  opens the Hyperlink 
dialog box.

For more information, see Working with 
PublishView™ Documents.

Option Function
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Adding Color from a Palette
To add color using the palette, complete the following steps:

1. Select the object.

2. Click the appropriate toolbar icon.

3. Select the color from the palette.

Working with Multiple Documents
When multiple documents are open, document names are listed in tabs 
at the bottom of the work area. Only one document is active at a time, 
and only the active document is affected by commands from menus or 
tools. 

To switch between documents:

Working with Multiple Documents in Tiled View
When multiple documents are open, you can view thumbnails of the 
documents in the work area. To change the view:

8 Click Window > Show Documents in Tiles. 

Open documents are shown as thumbnails in the work area and the 
scroll bar becomes active.

À Click the tab to show a document in the work area. This 
document becomes the active document. If the Show 
Documents in Tiles view is open, these tabs are not shown. 

Á Use the right and left arrows to scroll through the list of 
documents. These arrows are active only when there are too 
many documents to fit in the window.

Â Click the Show List icon to list all open documents. This is 
useful when you have a large number of documents open and 
documents names on the tabs may be truncated.
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The status bar remains available; however, document names now 
appear in the thumbnail view. Click Select Window > Show 
Documents in Tabs to view one document at a time in the work 
area.

Working with Applications
When you first open a new document or add a new problem to a 
document, select an application from the menu. 

The following illustration shows how a problem with the Lists & 
Spreadsheet application appears in the work area on the right side of the 
window when Handheld mode is selected.
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Working with Multiple Applications on a Page
You can add up to four applications to a page. When you have multiple 
applications on a page, the menu for the active application is displayed 
in the Documents Toolbox. Using multiple applications involves two 
steps:

• Changing the page layout to accommodate multiple applications.

À Document name. This tab contains the document name.

Á Problem/Page counter. The first value represents the problem 
number of the active page, while the second value tells you the 
page number within the problem. In the example, the counter 
reads 1.2, indicating Problem 1, Page 2.

Â Settings. Enables you to change the Document Settings and Graphs 
and Geometry Settings for the active document or change the 
default settings. For more information, see Using the Documents 
Workspace.

Ã Document View. Enables you to switch between Computer mode 
and Handheld mode.

Ä Zoom. In Handheld mode, enables you to increase or decrease the 
size of the document within the work area.

Å Boldness. When in Computer view, you can increase or decrease 
the boldness of the document.
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• Adding the applications.

You can add multiple applications to a page even if an application is 
already active.

Adding Multiple Applications to a Page
By default, each page contains space to add one application. To add 
additional applications to the page, complete the following steps.

1. Click Edit > Page Layout > Select Layout.

—or— 

Click .

The page layout menu opens.

There are eight page layout options available. If an option is already 
selected, it is dimmed.

2. Highlight the layout you want to add to the problem or page, and 
then click to select it. 

The new layout is displayed with the first application active.



Working with TI-Nspire™ Documents 105

3. In Handheld mode, click Press menu to select an application for each 
new section in the problem or page. In Computer view, select Click 
here to add an application.

Swapping Applications
To change the position of applications on a page with multiple 
applications, “swap“ the positions of two applications.

1. Click Edit > Page Layout > Swap Application.

Note: The last active application you worked on is automatically 
selected as the first application to be swapped. 

2. Click the second application to swap. 

This action performs the swap.

Note: When there are only two work areas, the selected application 
automatically swaps position with the other application in the work 
area.

To cancel a swap, press Esc.

Selecting and Moving Pages
To quickly move and rearrange pages in a document that contains 
multiple pages, use the Page Sorter to list thumbnail views of all pages in 
the document. 
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Selecting Pages
The Page Sorter always indicates the active page in the work area. 

• If you are working on a page in the work area, this page is indicated 
in the Page Sorter by a color border. 

• If you are actively using the Page Sorter, the active page displayed in 
the work area has a color border in the Page Sorter pane. 

• Clicking on any page in the Page Sorter makes it the active page, and 
it is displayed in the work area.

Rearranging Pages
Use the Page Sorter to change the order of pages within a problem.

1. Click to select the thumbnail view of the page in the Page Sorter.

À Page Sorter. Displays thumbnail sketches of all pages in all 
problems in the current document. Use the scroll bar to view pages 
off the screen. 

Á Active page. The page currently highlighted in the Page Sorter 
and active in the work area.

Â Problem/Page counter. Displays the problem number followed by 
the page number.



Working with TI-Nspire™ Documents 107

2. Drag the page to the desired position, and release to drop it in the 
new location.

Grouping Applications
To group up to four pages into a single page:

1. Click the first page in the series.

2. Click Edit > Page Layout > Group.

The next page is grouped with the first page. The page layout 
automatically adjusts to display all the pages in the group.

To ungroup pages:

1. Click the grouped page.

2. Click Edit > Page Layout > Ungroup.

The material becomes individual pages and applications.

Deleting an Application from a Page
1. Click the application you want to delete. 

2. Click Edit > Page Layout > Delete Application.

The application is deleted.

To undo the delete, press Ctrl-Z (Mac®: “+ Z).

Deleting Pages 

1. Select the page you want to delete.

2. Click Edit > Delete.

—or—

Click .

—or—

Right-click and click Delete.

Working with Problems and Pages
When you create a new document, a problem is added with one page. 
When a document has a problem with multiple pages or multiple 

problems, click  to open the page sorter view in the Documents 
Toolbox to view the problems and pages.
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Adding a Problem to a Document
A document can contain up to 30 problems. To add a new problem:

1. Click Insert > Problem.

—or—

Click . 

2. Click Problem.

A new problem with one new page is added to your document.

Adding a Page to a Problem
Each problem can contain up to 50 pages. To add a new page to a 
problem:

1. Click Insert > Page. 

—or—

Click . 

2. Click Page.

A new page is added to the problem. 

3. Select an application to add to the page.

Copying, Pasting, and Deleting Problems
You can copy and paste a single problem from one location to another 
within the same document or a different document. You can also delete 
a problem from the document.

Copying and Pasting a Problem
To copy and paste the problem:

1. Click  to open the Page Sorter.

2. Click a problem name to select it.

3. Click Edit > Copy or press Ctrl + C (Mac®: “ + C).

4. Go to the location where you want the problem to appear.

5. Click Edit > Paste or press Ctrl + V (Mac®: “ +V).

The problem is copied to the new location.
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Deleting a Problem
To delete a problem from the document:

1. Click a problem name to select it.

2. Click Edit > Delete or press Ctrl+X (Mac®: “ + X).

The problem is deleted from the document.

Renaming a Problem
To rename a problem:

1. Using the Page Sorter, select the problem name.

2. Right-click and click Rename.

The problem name box clears.

3. Type the new name and press Enter.

The new name appears in bold to indicate that it has been changed.

Printing Documents
If your computer is connected to a printer, you can print an open 
document.

1. Click File > Print. 

The Print dialog box opens.

2. Select the details of your print job.

The Print dialog box enables you to control the following in your 
print job:

• The printer

• Print What:

– Viewable Screen — prints what is visible in the active 
document.

– Print All — prints all data and pages in all open documents, 
including what is not currently visible on the screen.

• Paper size

• The range of TI-Nspire™ pages 

• The number of printed copies, up to 100

• Layout:

– Orientation (portrait or landscape)
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– The number of TI-Nspire™ pages to be printed on each 
sheet (1, 4, or 8) (available in Viewable Screen option only)

– Whether to allow space below each printed TI-Nspire™ 
page for comments (available in Viewable Screen option 
only)

• Margins (from .25 inches to 2 inches)

• The option to include documentation information on the 
printout:

– Problem and page labels

– Header (up to two lines)

– Document name in the footer

• The ability to group the pages by problem

• Print Preview

3. Click Print.

Note: To restore the Print defaults, click Reset.

Using Print Preview
You can also preview the document from the Print dialog box. 

1. Select the Preview check box.

2. Use the arrows at the top of the right pane to page through the 
pages in the preview.

Viewing Document Properties and Copyright 
Information

Viewing Copyright Information
If a teacher has added copyright information to a document, you can 
view that information. 

1. Click File > View Copyright Information.

The Copyright Information dialog box opens.
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2. Click OK to close the dialog box.

Protecting a Document (making a document read-only)
Note: This section applies only to the Teacher Software.

Teachers can protect documents to create a document for distribution to 
your students or for other use. A student who receives a read-only 
document and makes changes to it will be prompted to save the 
document as a new file.

To make a document read-only:

1. Open the document.

2. Click File > Document Properties.

The Document Properties dialog box opens with the Copyright tab 
visible.

3. Click the Protection tab.
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4. Select the Make this document Read Only check box.

5. Click OK.

Adding Copyright Information to a Document
Note: This section applies only to the Teacher Software.

You can add copyright information individually to documents you create 
or apply the same copyright information to all new documents.

To add copyright information to a document:

1. With the document open, click File > Document Properties.

The Document Properties dialog box opens with the Copyright tab 
visible. 
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2. Edit the following fields to define the copyright details:

• Author

• Copyright (Public Domain or Copyright) 

Note: If you select Public Domain, you cannot enter a year or 
owner.

• Year

• Owner

• Comments

3. To add the supplied information to all new documents from this 
point forward, select Apply this copyright to all new documents.

4. Click OK to apply the copyright information to the document.
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Working with PublishView™ Documents

Use the PublishView™ feature to create and share interactive documents 
with teachers and students. You can create documents that include 
formatted text, TI-Nspire™ applications, images, hyperlinks, links to 
videos, and embedded videos in a format that is suitable for printing on 
a standard piece of paper, publishing to a website or blog, or for use as 
an interactive worksheet.

PublishView™ features provide layout and editing features for 
presenting math and science concepts in a document where TI-Nspire™ 
applications can be interactively and dynamically linked with supporting 
media, enabling you to bring the document to life. Using the 
PublishView™ feature:

• Teachers can create interactive activities and assessments used on 
screen.

• Teachers can create printed materials to complement documents 
used on TI-Nspire™ handhelds.

• When working with lesson plans, teachers can:

– Create lesson plans from existing handheld documents or 
convert lesson plans to handheld documents.

– Link to related lesson plans or documents.

– Embed explanatory text, images, video, and links to web 
resources.

– Build or interact with TI-Nspire™ applications directly from the 
lesson plan.

• Students can create reports or projects such as lab reports containing 
data playback, curve fits, pictures, and video—all on the same sheet.

• Students can print and turn in assignments on a standard piece of 
paper. 

• Students taking exams can use one tool to create a document that 
contains: all problems on the exam, text, images, hyperlinks, or 
videos, interactive TI-Nspire™ applications, screen shots, and layout 
options needed to print a document.

Note: PublishView™ documents can be exchanged using the TI-Nspire™ 
Navigator™ NC system. PublishView™ documents can reside in the 
Portfolio Workspace, and TI-Nspire™ questions within a PublishView™ 
document can be automatically graded by the TI-Nspire™ Navigator™ 
system.
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Creating a New PublishView™ Document
1. From the Documents Workspace, click File > New PublishView™ 

Document.

—or—

Click , and then click New PublishView™ Document.

• A blank letter-size document opens in the Documents 
Workspace. The orientation is portrait, which cannot be 
changed.

• The default margin settings for the top and bottom margins are 
one-inch. There are no settings for side margins.

• By default, a problem is added to the document.

• By default, the document contains the page number in a # of # 
format at the bottom of the sheet.

• The scroll bars on the right side of the screen and at the bottom 
of the screen are active.

2. Add TI-Nspire™ applications and PublishView™ objects as needed to 
complete the document.

About PublishView™ Documents
When working with PublishView™ documents, it is important to keep 
the following points in mind:

• PublishView™ documents are saved as .tnsp files, which distinguishes 
them from TI-Nspire™ documents (.tns files). 
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• When inserting PublishView™ objects into a document, the text, 
image, hyperlink, or embedded video are contained in boxes that 
can be moved and resized.

• When you insert TI-Nspire™ applications, they work the same way as 
pages in a TI-Nspire™ document. 

• In a PublishView™ document, objects can overlap each other and 
you can control which object is on top or bottom.

• Objects can be placed and positioned in a PublishView™ document 
in a free-form fashion.

• You can convert an existing TI-Nspire™ document to a PublishView™ 
document (.tnsp file).

• When you convert a PublishView™ document to a TI-Nspire™ 
document (.tns file), TI-Nspire™ applications are converted. 
PublishView™ objects containing text, hyperlinks, videos, and 
images are not converted.

• You cannot create or open a PublishView™ document on a 
handheld. You must convert a PublishView™ document to a 
TI-Nspire™ document before sending it to a handheld. 

Exploring a PublishView™ Document
The following example shows how you might use TI-Nspire™ 
applications and PublishView™ objects to build a PublishView™ 
document. In this example, borders are turned on to show the 
boundaries around the objects. Showing borders enables you to work 
with objects easily while building a document. When you are ready to 
print or publish the document to the web, you can select to the hide 
borders.
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À Header. In this example, the header contains the title of the 
document. When the header area is active, you can type and 
format text as needed.

Á Problem break and name. In PublishView™ documents, use 
problem breaks to control the page layout. You can select to hide 
or show problem breaks. Deleting a problem removes the contents 
of the problem and removes the space between problems when 
there are multiple problems. Problem breaks also enable you to use 
variables in PublishView™ documents. Variables that have the 
same name are independent of one another if they are used in 
different problems.
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Using the Status Bar in a PublishView™ Document
When a PublishView™ document is open, options on the status bar are 
different than when working in a TI-Nspire™ document.

Â Text boxes. In this example, the introduction text and the text in 
boxes 1, 2, 3, and 4 is contained in text boxes. You can insert text 
and hyperlinks into a PublishView™ document using a text box. 
Text boxes can be resized and positioned as needed. PublishView™ 
text boxes are not retained when you convert a PublishView™ 
document to a TI-Nspire™ document. 

Ã TI-Nspire™ applications. In this example, the author uses Graphs & 
Geometry to show the math functions. When a TI-Nspire™ 
application is active in a PublishView™ document, the appropriate 
application menu opens in the Documents Toolbox. You can work 
in a TI-Nspire™ application just as you would in a TI-Nspire™ 
document. When you convert a PublishView™ document to a 
TI-Nspire™ document, applications are retained.

Ä Notes application. You can also use the TI-Nspire™ Notes 
application to add text to a PublishView™ document. Because 
Notes is a TI-Nspire™ application, it will be retained when you 
convert the PublishView™ document to a TI-Nspire™ document. 
Using the Notes application enables you to use an equation editor 
and can contain TI-Nspire™ math templates and symbols.

Å Video. This is an example of a video that is embedded in a 
PublishView™ document within a frame. Users can start and stop 
the video using the controls. Frames containing videos and images 
can be resized and positioned in the document as needed.

Æ Footer. By default, the footer area contains the page number, 
which cannot be edited. You can add other text above the page 
number if needed. Like the header, you can format text as needed.
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À Document names are displayed in tabs. If multiple documents are 
open, the document names are listed. You can have TI-Nspire™ and 
PublishView™ documents open at the same time. In this example, 

Document 1 is an inactive TI-Nspire™ document ( ). Document 2 is 

the active PublishView™ document ( ). Click the X to close a 
document.

Á Click Settings to change Document Settings. You can specify 
settings that are specific to an active document or set default 
settings for all PublishView™ documents. When you convert a 
TI-Nspire™ document into a PublishView™ document, the settings 
in the TI-Nspire™ document convert to the settings defined for 
PublishView™ documents.

Â Document View is not active in a PublishView™ document. You 
cannot switch between computer view and handheld view.

Ã Use the Zoom scale to zoom the active document in or out from 
10% to 500%. To set a zoom, type a specific number, use the + and 
- buttons to increase or decrease by increments of 10%, or use the 
drop-down box to choose preset percentages.

Ä  In TI-Nspire™ applications, use the Boldness scale to increase or 
decrease the boldness of text and line thickness within applications. 
To set the boldness, type a specific number, use the + and - buttons 
to increase or decrease by increments of 10%, or use the drop-
down box to choose preset percentages.

For PublishView™ objects, boldness is used to match text within 
TI-Nspire™ applications to other text on the PublishView™ sheet. It 
can also be used to increase the visibility of TI-Nspire™ applications 
when presenting a document to a class.

Å When there are too many open document names to show in the 
status bar, click the forward and backward arrows ( ) to move 
through the documents.

Æ Click  to see a list of all open documents.
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Saving PublishView™ Documents

Saving a New Document
1. Click File > Save Document.

—or— 

Click . 

The Save TI-Nspire™ Document dialog box opens.

2. Navigate to the folder in which you want to save the document.

—or—

Create a folder in which to store the document.

3. Type a name for the new document. 

4. Click Save.

The document closes and is saved with the extension .tnsp. 

Note: When you save a file, the software first looks in the same folder 
the next time you open a file.

Saving a Document with a New Name
To save a previously saved document in a new folder and/or with a new 
name:

1. Click File > Save As from the menu.

The Save TI-Nspire™ Document dialog box opens. 

2. Navigate to the folder in which you want to save the document.

—or—

Create a folder in which to store the document.
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3. Type a new name for the document. 

4. Click Save to save the document with a new name.

Note: You can also use the Save As option to convert documents from 
TI-Nspire™ files to PublishView™ files or convert PublishView™ files to 
TI-Nspire™ files.

Exploring the Documents Workspace
When you create or open a PublishView™ document, it opens in the 
Documents Workspace. Use the menu options and the toolbar just as you 
would when working with a TI-Nspire™ document to: 

• Navigate to existing folders and documents using Content Explorer

• Open existing documents

• Save documents

• Use the copy, paste, undo, and redo options

• Delete documents

• Access TI-Nspire™ application-specific menus

• Open the Variables menu in TI-Nspire™ applications that allow 
variables

• Access and insert math templates, symbols, catalog items, and library 
items into a PublishView™ document

Note: For more information, see Using the Documents Workspace.

Exploring the Documents Toolbox
When a PublishView™ document is active, the Documents Toolbox 
contains tools needed for working with PublishView™ documents. You 
can add TI-Nspire™ applications to a problem, insert parts of existing 
TI-Nspire™ documents into a problem, and add PublishView™ objects.

The Documents Toolbox opens when you create a new PublishView™ 
document or open an existing PublishView™ document. When working 
in a PublishView™ document, Page Sorter and TI-SmartView™ emulator 
are not available.
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À In a PublishView™ document:

• Click  to open the application menu and tools needed to 
work with TI-Nspire™ applications and PublishView™ objects.

• Click  to open the Utilities panel where you can access Math 
Templates, Symbols, the Catalog, Math Operators, and 
Libraries.

• Click  to open Content Explorer.

Note: For more information, see Using the Documents Workspace.

Á Click  to collapse a pane containing a menu. Click  to expand 
a pane. 
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Using Menus and the Toolbar
When working in a PublishView™ document, select options from the 
menus or the toolbar in the Documents Workspace to work with content 
and objects. When you insert an object into a PublishView™ document, 
you can manipulate it using the same tools as you would when working 
with a TI-Nspire™ document. In PublishView™ documents, you can:

• Right-click on an object to open a context menu, which displays the 
actions that can be performed on that object.

Â TI-Nspire™ applications. Move an icon to a problem to insert an 
application:

•  Calculator

•  Graph

•  Geometry

•  Lists & Spreadsheet

•  Data & Statistics

•  Notes

•  Vernier DataQuest™

•  Question (Available in TI-Nspire™ Teacher Software, 
TI-Nspire™ Navigator™ Teacher Software, and TI-Nspire™ 
Navigator™ NC Teacher Software).

Ã TI-Nspire™ Documents. Use this tool to locate and insert existing 
TI-Nspire™ documents (.tns files) into a problem. 

Ä PublishView™ Objects. Use this tool to move the following objects 
into a problem:

•  Image

•  Video

•  Text box

•  Hyperlink
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• Use add, insert, and paste to add objects to a PublishView™ 
document.

• Use delete and cut to remove objects from a PublishView™ 
document.

• Move objects from one place to another within a PublishView™ 
document.

• Copy objects from one document and paste them into another 
PublishView™ document.

• Resize and scale objects such as text boxes and images.

• Change the font face and size and apply formatting such as italics, 
bold, underline, and color to text.

Note: For more information, see Using the Documents Workspace.

Using Context Menus
In TI-Nspire™ applications and in PublishView™ documents, context 
menus provide a list of options specific to the task you are working on. 
For example, when you right-click a cell while working in the TI-Nspire™ 
Lists & Spreadsheet application, a context menu opens providing a list of 
actions that you can perform on that cell. When you right-click the 
border of a text box in a PublishView™ document, the context menu 
provides actions that can be performed on the text box.

Context Menus in TI-Nspire™ Applications
When you insert a TI-Nspire™ application into a PublishView™ 
document, the application menu and the context menus associated with 
that application are available and work the same way they work in a 
TI-Nspire™ document.

Context Menus in PublishView™ Documents
In PublishView™ documents, context menus provide shortcuts to 
frequently performed tasks. Context menus are specific to an object or 
area:

• The Sheet context menu provides options for working with the 
layout of the sheet and document.

• Object context menus provide options for manipulating the object.

• Content-sensitive context menus provide options for working with 
the content inside the object such as text or a video.
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Working with PublishView™ Objects
In a PublishView™ document, text, hyperlinks, images, and videos are 
contained in PublishView™ objects. You can move, resize, copy and 
paste, and delete an object within a PublishView™ document. Objects 
can also be positioned so that one overlaps the other.

Within a document, PublishView™ objects can exist in three states: 
unselected, selected, and interactive.

State Description

Unselected When unselected, an object 
does not have handles for 
repositioning and sizing. To 
deselect an object, left-click 
or right-click outside the 
object.

In this example, borders 
around the object are 
showing.

Selected When selected, an object 
will have eight square 
handles framing the object. 
To select an object, click the 
object’s border. When 
selected, objects can be 
moved and resized.

• To move an object, 
click a border and drag 
the object to its new 
location. 

• To resize an object, 
grab a handle. 

• Right-click the border 
to open a context 
menu with options for 
manipulating the 
object.
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Inserting an Object
1. In the Documents Toolbox, ensure the PublishView™ Objects menu is 

open.

2. Use your mouse to click an icon and drag it to the document.

3. Release the mouse button to drop the object into the document.

Interactive An interactive state is 
indicated by a blue frame 
around the object. To enter 
interactive state, left-click 
or right-click anywhere in 
the body of the object. 
When in an interactive 
state, you can work with 
the contents of the object. 
For example, you can add 
or edit text in a text box or 
complete math functions in 
a TI-Nspire™ application. 
When in an interactive 
state, context menus 
contain options specific to 
the contents of an object.

State Description
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4. Using the mouse, grab the handles to resize the object and drag it to 
position the object in the document as needed.

Opening Object Context Menus
8 Right-click the border of any object in a PublishView™ document.

The context menu opens to provide access to delete, copy/paste, cut, 
and bring to front/send to back actions.

Selected text boxes 
and frames can be 
resized, moved, 
copied, pasted, and 
deleted.
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Resizing an Object
1. Click any border around the object to select it. The border becomes a 

bold blue line and the handles are active.

2. Move your mouse over one of the handles to activate the resizing 
tool.

3. Grab one of the handles and drag in the direction needed to make 
the object larger or smaller.

4. Click outside the object to save the new size.

Moving an Object
To move an object to another location on the page:

1. Click any border around the object to select it. The border becomes a 
bold blue line and the handles are active.

2. Move your cursor over one of the borders to activate the positioning 
tool.

3. Click to grab the object. The horizontal and vertical alignment 
guides are activated at the top and bottom of the object. Use the 
grid lines to position the object on the page.

4. Drag the object to a new location on the page.

5. Release the mouse button to drop the object in its new location.

À vertical alignment guide

Á horizontal alignment guide



130 Working with PublishView™ Documents

Overlapping Objects
You can position objects so that one is on top of another. You can control 
the stacking order to specify which object is positioned in front or behind 
the other. Overlapping objects have many practical uses when presenting 
information in the classroom. For example, you can create a "curtain 
control" by placing an empty text box over other objects. Then, you can 
move the text box to reveal the items below it one at a time.

To change the position of an object in the stacking order:

1. Click the border of the object you want to position to select it, and 
then right-click to open the context menu.

2. Click Send to back or Bring to front to move the selected object to 
the desired position.
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Deleting an Object
To delete an object from a sheet:

1. Click any border of the object to select it. When an object is selected, 
the border is blue and the handles are active.

2. Press the Delete key to delete the text box.

—or—

Right-click a border, and then click Delete from the context menu.

Choosing a Working Folder for PublishView™ Objects
Use the Choose Your Working Folder field in the PublishView™ Objects 
pane to select a folder for storing PublishView™ documents and related 
files.

1. Ensure the PublishView™ Objects pane is open.

2. Click . 

The Choose Your Working Folder dialog box opens.

3. Navigate to the folder where you want to store video and image 
files.
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4. Click Open to choose the working folder.

The selected folder becomes the working folder and the folder name 
is displayed in the Choose your working folder field. Previews of 
supported images and video files in the folder are shown in the 
PublishView™ objects pane.

5. To add an image or video file to a PublishView™ document, select 
the file and move it onto the active sheet.

Working with TI-Nspire™ Applications
Note: For more information, see the appropriate chapter in this 
guidebook.

Adding an Application to a Problem
To add a TI-Nspire™ application to a problem in a PublishView™ 
document:

1. Choose one of the following actions to select an application:

• From the TI-Nspire™ Applications pane in the Documents 
Toolbox, use the mouse pointer to point to the application and 
drag it to the problem.

• From the menu bar, click Insert and choose an application from 
the drop-down menu.

• Right-click inside the sheet to open the context menu, click 
Insert and choose an application from the menu.

The application is added to the sheet. 
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2. Using your mouse, grab the handles to resize or position the 
application object as needed.

3. Click outside the application frame to accept the dimensions.

4. To open the menu for the active TI-Nspire™ application, click inside 
the application. 

The menu opens in the Documents Toolbox above the TI-Nspire™ 
Applications pane. 

Right-click on an application element, such as a cell or function to 
open the context menu for that item.

5. To work in the application, click an option from the application 

menu. Click  to collapse the application menu pane.
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Adding Existing TI-Nspire™ Documents
Use the TI-Nspire™ Documents pane to open an existing TI-Nspire™ 
document to add to a PublishView™ document. When you open an 
existing TI-Nspire™ document, all pages of the document appear in the 
preview pane. You can move complete problems or individual pages onto 
the PublishView™ sheet.

Choosing a Working TI-Nspire™ Document
To choose a working document:

1. In the Documents Toolbox, ensure the TI-Nspire™ Documents pane is 
open.

2. Click .

The Choose Your Working Document dialog box opens.

3. Navigate to the folder in which the TI-Nspire™ document is stored:

• Click ¤ in the Look in: field to use a file browser to locate a 
folder.

• From an open folder, click  to move up a level in the folder 
hierarchy
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• Click  to return to the default home folder 

• Click  to add a new folder to open folder on your 
computer. 

• Click  to list folders and files. To show details, click .

4. Select the file, and then click Open.

The TI-Nspire™ document opens in the TI-Nspire™ Documents pane.

5. To add the TI-Nspire™ document to the PublishView™ document, 
move one page at a time or one problem at a time to the 
PublishView™ sheet.

If you are adding a problem with multiple pages, the pages are 
stacked on top of each other on the PublishView™ sheet. Move the 
top page to see the other pages.
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Working with Problems
Like a TI-Nspire™ document, a PublishView™ document consists of one 
or more problems.

Problems are used to control the layout of a PublishView™ document so 
that you can isolate variables. When variables with the same name are 
used in multiple problems, variables can have different values. To add 
problems to PublishView™ documents, open the Sheet context menu or 
use the options on the Insert menu in the Documents Workspace. When 
adding problems, keep the following guidelines in mind:

• By default, a new PublishView™ document contains one problem.

• You can insert a problem after any existing problem. 

• You cannot insert a problem in the middle of an existing problem.

• A new problem break is always inserted after the selected problem.

• Inserting a problem break adds empty space below the break. 

• Any object between two problem breaks is part of the problem 
above the break.

• The last problem includes all sheets and objects below the last 
problem break.

• Problem breaks are not relative to any object, which lets you move 
objects within a problem without affecting the problem break 
location.

Adding a Problem
To add a problem to an open PublishView™ document:

1. Right-click anywhere on the sheet, and then click Insert > Problem. 

The problem is added to the document below any existing problems. 
The problem break provides a visible divider between problems. 

2. To name the problem, highlight the default text, type a name, and 
then click outside the text box to save the name.

The problem break is saved.

If a document has multiple problems, use the scroll bar on the right 
side of the document to move up and down through the problems.
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Managing Problem Breaks
Problem breaks are used to separate problems and variable sets. 

• Every problem has a problem break.

• A problem break becomes visible when a problem is added to a 
document.

• A problem break is represented by a dashed line with the name of 
the problem positioned on the left side of the sheet.

• By default, the problem name is shown as <Name of problem>. 
Highlight the default text to type a new name for the problem.

• Problem names do not have be unique. Two problems can have the 
same name.

Hiding and Showing Problem Breaks
You can select to hide or show problem breaks in a PublishView™ 
document. By default, problem breaks are shown.

1. Right-click in any blank area of the document (outside of any object) 
to open the sheet context menu.

2. Click Layout Options.

The Show/Hide Options dialog box opens.

Note: You can also click View > PublishView™ Layout Options.

3. Clear the Show problem breaks option to hide problem breaks in 
the document. Select the option to return to the default setting and 
show the problem breaks.

4. Click OK to close the dialog box.

Renaming a Problem
1. Click the existing problem name on the problem break line.

2. Type a new name for the problem.

3. Click outside the text box to save the new name.
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Deleting a Problem
To delete a problem, complete one of the following actions:

8 Select the problem break and click  on the right side of the break.

8 Click Edit > Delete.

8 Right-click the problem break and click Delete.

8 Select the problem break and press the Delete or Backspace key.

When you delete a problem, all objects contained in the problem are 
removed and the space between the selected problem break and the 
next problem break is removed.

Organizing PublishView™ Sheets
A PublishView™ document can have multiple sheets. A single sheet is 
displayed in the workspace on your screen. All work occurs in the 
PublishView™ objects and TI-Nspire™ applications within sheets.

Adding Sheets to a Document
To add a sheet to a document:

8 Click Insert > Sheet.

The sheet is added to the document and the numbering increments 
by one.

Opening the Sheet Context Menu
8 Right-click in any blank area (outside of any object) in a 

PublishView™ sheet.

A context menu opens with options for inserting problems, pages, 
applications, and PublishView™ objects, edit options for removing 
space or deleting a page, and options for hiding and showing 
problem breaks and object borders.
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Page Numbering
In a PublishView™ document, page numbering is displayed in the 
bottom margin (footer). By default, numbering is placed in the center of 
the PublishView™ sheet in a # of # format. You cannot edit or delete 
page numbering.

Working with Headers and Footers
PublishView™ documents contain space at the top and bottom of a sheet 
to add a header or a footer. Headers and footers can contain the date, 
the document name, the lesson plan name, the class name, your school’s 
name, or any other information needed to identify a document.

By default, headers and footers do not contain content and boundaries 
for the header and footer are hidden. To activate a header or footer for 
editing, click inside the top or bottom margin. When activated, a text 
box with a light gray border is displayed.

Inserting and Editing Text in Headers and Footers
1. Click inside the top or bottom margin.

The text box borders in the margin become visible and the object 
space is disabled. The cursor is placed in the header or footer space 
and the formatting toolbar becomes active.

2. Type the text.

• The default font is TI-Nspire™ true type, 12 pt, normal.

• By default, text is centered horizontally and vertically.

• Text can be aligned: left, center, right, or justified.

• Text that does not fit within the text box horizontally will wrap 
to the next line.

• Text that does not fit within the text box vertically will not be 
shown, but text is retained. (If you delete text, the hidden text 
will appear.)

3. Complete one of the following actions to save the text:

• Single-click anywhere outside the header or footer text box to 
save the text.
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• Press Esc to save the text. 

The PublishView™ sheet becomes active and the formatting 
menu closes.

Showing and Hiding Borders
By default, borders are displayed when you insert an object into a 
problem. When you select to hide borders, the selection applies to all 
objects in the document and to objects that you add to the document. To 
hide the border:

1. Right-click in any blank area of the sheet (outside of any object) to 
open the context menu.

2. Click Layout Options. 

The Layout Options dialog box opens.

Note: You can also click View > PublishView™ Layout Options.

3. Clear the Show object borders option to hide the borders around 
the objects in the problem. Select the option to return to the default 
setting and show borders.

4. Click OK to close the dialog box.

Adding and Removing Space
To manage how PublishView™ objects appear on a sheet, you may need 
to add or delete space between objects.

Note: You can add and remove vertical space between objects using this 
method. To add or remove horizontal space between objects, move the 
object. 

Adding Space
1. Right-click in the area outside of any object where you want to add 

space. The context menu opens.

2. Click Edit > Add/Remove Space. The Add/Remove Space tool 
becomes active.
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3. Use your mouse to position the tool to the exact place where you 
want to add space.

4. Click the tool, and then drag down to select the amount of space 
you want to add. As you select the amount of space to be added, it is 
indicated in green.

Add/Remove 
Space tool



142 Working with PublishView™ Documents

5. Press the Enter key to add the space in between the objects. You can 
adjust the amount of space by dragging up and down before you 
press Enter.

Removing Space
1. Right-click in the area outside of any object where you want to 

remove space. 

The context menu opens.

2. Click Edit > Add/Remove Space. 

The Add/Remove Space tool becomes active.

3. Use your mouse to position the tool to the exact place where you 
want to remove space.

4. Click the tool, and then drag up to select the amount of space you 
want to remove. As you select the amount of space to be removed, it 
is indicated in red.

Add/Remove 
Space tool
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5. Press the Enter key to remove the space in between the objects. You 
can adjust the amount of space by dragging up and down before 
you press Enter.

Note: If there is not enough space on the sheet to accommodate the 
objects, the objects won’t be moved when space is removed.

Deleting Blank Sheets from Problems
You can delete a sheet that does not contain any TI-Nspire™ applications 
or PublishView™ objects from a problem. To delete a blank sheet from a 
problem:

1. Delete any TI-Nspire™ applications, PublishView™ objects, move or 
delete any problem breaks from the sheet.

2. Place your cursor inside the sheet you want to delete.

3. Right-click inside the blank sheet to open the context menu.

4. Click Edit > Delete Sheet.

The blank sheet is removed from the problem.

Using Zoom
The zoom feature lets you zoom in on any object or area on the 
PublishView™ document for discussion, and zoom out to see an overview 
of the lesson. The zoom uses the center point of the viewable area to 
zoom in.

The default zoom setting is 100%.

8 To change the zoom percentage, do one of the following:

• Type the number in the box and press Enter.



144 Working with PublishView™ Documents

• Use the - and + buttons to decrease or increase the percentage 
in 10% increments.

• Use the drop-down arrow to choose a preset percentage.

The zoom settings are retained when you save the document.

Adding Text to a PublishView™ Document
In a PublishView™ document, there are three ways to add text:

• Insert a PublishView™ text box to enter free-form text or copy text 
from other sources into the document. For example, you can place a 
PublishView™ text box next to an image and type a description in a 
text box. You can also copy and paste text from .doc, .txt, and .rtf 
files. Use PublishView™ text boxes when you need options for 
emphasizing and formatting text. PublishView™ text boxes are not 
converted when you convert a PublishView™ document to a 
TI-Nspire™ document. You may want to use a PublishView™ text box 
to add text that you don’t want handheld users to see.

• Use the TI-Nspire™ Notes application. You should use the Notes 
application when you need an advanced equation editor and when 
you need to use TI-Nspire™ math templates and symbols. Superscript 
and subscript are also easier to use in the Notes application. You 
should also use Notes when you are planning to convert the 
PublishView™ document to a TI-Nspire™ document for use on a 
handheld and you want handheld users to see the text. 

• Add text in TI-Nspire™ applications that allow text just as you would 
in a TI-Nspire™ document.

Inserting Text into a Text Box
1. Ensure the PublishView™ Objects pane is open.

2. Use your mouse to click  and drag it to the problem.

3. Release the mouse button to drop the text box into the problem.
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4. Using the mouse, grab the handles to resize the text box or position 
in the problem as needed.

5. Click outside the text box to save the size and position.

6. Click "Type your text here." 

The formatting toolbar becomes active. The text box is in an 
interactive state for adding or editing text.

7. Type the new text.

—or—

Copy and paste text from another file. 

8. Apply formatting as needed.

9. Click outside the text box to save the text.

Formatting and Editing Text
The options for editing and formatting text are located on a formatting 
toolbar at the top of the active document. Formatting options for editing 
text include:

• Changing the font, font size, and font color.

• Applying bold, italics, and underline formatting.

• Applying the following text horizontal alignment options: left, right, 
centered, and justified.

• Inserting hyperlinks.
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Launching Edit Mode
8 Click inside a text box to launch edit mode. 

• The formatting menu opens.

• The text is selectable for editing. 

Opening the Content Context Menu
8 Right-click inside a text box containing text or a hyperlink.

The formatting menu and context menu open providing shortcuts to 
cut, copy, and paste.

Using Hyperlinks in PublishView™ Documents
In PublishView™ documents, use hyperlinks to:

• Link to a file

• Link to a website on the Internet

You can add a hyperlink to an open document or you can convert any 
text within a text box to a hyperlink. When a hyperlink is added, the 
formatting of the text is underlined and the font color is blue. You can 
change the formatting of the hyperlinked text without losing the 
hyperlink.

If a link is broken, an error message is displayed when you click the link:

• Cannot open the specified file

• Cannot open the specified web page

PublishView™ text boxes support both absolute and relative links.

Absolute links contain the complete location of the linked file and do not 
depend on the location of the main document.

Relative links contain the location of the linked file relative to the main 
document. If you have multiple lessons in a single folder and they are all 
linked using relative addressing, you can move the folder to any other 
location (another local folder, datashare, flash drive, online) without 
breaking the links. The links also stay intact if you bundle the documents 
into a lesson bundle or zip them into a zip file and share them.

Note: The PublishView™ document must be saved before you can insert 
a relative hyperlink.



Working with PublishView™ Documents 147

Linking to a File
You can link to any file on your computer. If the file type is associated 
with an application on your computer, it will launch when you click the 
link. There are two ways to link to a file; by typing or pasting a file 
address into the Address field, or by browsing to a file.

Linking to a File by Using an Address
1. Ensure the PublishView™ Objects pane is open.

2. Drag the hyperlink icon  onto the document.

The Hyperlink dialog box opens.

3. Type the name of the link in the Text field. For example, this can be 
the name of the document.

4. Copy the location of the file path you want to link to, and paste it in 
the Address field.

—or—

Type the location of the file in the Address field.

Note: Type ../ to designate parent directories. For example: 
../../lessons/mathlesson2.tns

5. Click OK to insert the link.
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A text box containing the hyperlink is added to the PublishView™ 
document.

Linking to a File by Browsing
1. Ensure the PublishView™ Objects pane is open.

2. Drag the hyperlink icon  onto the document.

The Hyperlink dialog box opens.

3. Type the name of the link in the Text field. For example, this can be 
the name of the document.

4. Click  to select Link to a file on your computer or network 
drive.

The Select file to insert as hyperlink dialog box opens.
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5. Navigate to and select the file you want to link to, and then click 
Insert.

The path name is inserted into the Address field in the Hyperlink 
dialog box.

If the software is unable to determine if the link is a relative or 
absolute address, the Hyperlink dialog box opens with an option to 
change the type of link.

To change the link, click the appropriate option:

• Change to absolute address.

• Change to relative address.

6. Click OK to insert the link. 

—or—

Click Start Over to go back to the Hyperlink dialog box and choose a 
different file to link, or to edit the Text or Address fields.

A text box containing the hyperlink is added to the PublishView™ 
document.
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7. Using the mouse, grab the handles to resize the text box.

—or—

Grab any border to position the text box in the document as needed.

Linking to a Website
There are two ways to link to a website; by typing or pasting the URL into 
the Address field, or by browsing to a file.

Linking to a Website by Using an Address
1. Ensure the PublishView™ Objects menu is open.

2. Drag the hyperlink icon  onto the document  to open the 
Hyperlink dialog box.

3. Type or paste the URL you want to link to in the Address field.

4. Click OK. 

A text box containing the hyperlink is added to the PublishView™ 
document.

Linking to a Website by Browsing
1. Ensure the PublishView™ Objects menu is open.

2. Drag the hyperlink icon  onto the document  to open the 
Hyperlink dialog box.

3. Click  to select Link to an Internet resource. 

The browser opens to your default website.

4. Navigate to the website or file on a website that you want to link to.
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5. Copy the URL, and then paste it in the Address field in the Hyperlink 
dialog box.

—or—

Type the URL in the Address field.

6. Click OK.

A text box containing the hyperlink is added to the PublishView™ 
document.

7. Using the mouse, grab the handles to resize the text box.

—or—

Grab any border to position the text box in the document as needed.

Editing a Hyperlink
To change the name of a hyperlink, change the path, or change the URL, 
complete the following steps.

1. Using your mouse, right-click the hyperlink text, and then click Edit 
hyperlink.

The Hyperlink dialog box opens.

2. Make corrections as needed:

• Type corrections to the hyperlink name in the Text field.
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• Click  to open the Select a file to add as a hyperlink dialog 
box and use the file browser to navigate to the folder where the 
file is located.

• Click  to open a browser and navigate to a website to copy 
and paste the correct the URL in the Address field.

3. Click OK to save the changes.

Converting Existing Text to a Hyperlink
1. Click inside the text box to activate edit mode and open the 

formatting menu.

2. Select the text you want to convert to a hyperlink.

3. Click . 

The Hyperlink dialog box opens with the selected text in the Text 
field.

4. Click  to create a link to a file.

—or—

Click  to create a link to page on a website.

Removing a Hyperlink
Use this process to remove a link from text inside a text box. The text 
remains in the document.

1. Using your mouse, right-click the hyperlink text.

2. Click Remove hyperlink.

The hyperlink formatting is removed from the text and the text is no 
longer clickable.

Note: To remove both the text and hyperlink, delete the text. If a text 
box contains only the linked text, delete the text box.

Working with Images
Images can be added to PublishView™ documents as PublishView™ 
objects or can be added inside TI-Nspire™ applications that support 
images. Supported files types are .bmp, .jpg, and .png files. 
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Note: If a TI-Nspire™ application is active in the PublishView™ 
document, the image is added to the TI-Nspire™ page if you click 
Insert > Image from the menu bar or context menu. If there is no 
TI-Nspire™ document active, the image is added as a PublishView™ 
object. Only images inside TI-Nspire™ applications convert to TI-Nspire™ 
documents (.tns files).

Inserting an Image
1. Ensure the PublishView™ Objects pane is open.

2. Click , and then drag the icon to the document.

The Choose an image to insert into PublishView™ dialog box 
opens.

Note: By default, the Texas Instruments preloaded images folder is 
displayed.

3. Navigate to the folder where the image file you want to insert is 
located, and then highlight the file name.

4. Click Insert image.
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The image is added to the PublishView™ sheet.

5. Using the mouse, grab the handles to resize the text box,

—or—

Grab any border to position the text box in the document as needed. 

Moving Images
1. Click the frame containing the image to select it.

2. Move your cursor over the edge of the image to activate the 

positioning tool.  

3. Move the image to its new location on the PublishView™ sheet.

Note: Objects can overlap each other on a PublishView™ sheet.

Resizing Images
1. Click the frame containing the image to select it.

2. Move your cursor over one of the blue handles to activate the 

resizing tool. 

3. Drag the handle to make the image smaller or bigger.

Deleting Images
8 Click the image to select it, and then press the Delete key.

—or—

8 Right-click a handle to open the context menu, and then click 
Delete.
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Working with Video Files
You can embed a Flash (.flv) video file in a PublishView™ document and 
play the video directly from the PublishView™ document. 

Note: You can also insert a link to a video that will launch in a new 
browser window or media player window. For more information, see 
Working with Hyperlinks.

Inserting a Video
1. Ensure the PublishView™ Objects pane is open.

2. Click , and then drag the icon to the document.

The Choose a video to insert into PublishView™ dialog box opens.

3. Navigate to the folder where the video file you want to insert is 
located, and then highlight the file name.

4. Click Insert video.

An object containing the embedded video is added to the 
PublishView™ sheet. By default, the resizing and positioning handles 
are active.
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5. Using the mouse, grab the handles to resize the object or grab any 
border to position the object in the document as needed. For 
example, you may want to position the object containing the video 
above or below a text box that contains text introducing the video.

6. To play the video, click the forward arrow, or click anywhere in the 
viewing window.

Using the Video Console
The video console enables users to control when to start and stop the 
video. 

The console contains the following controls:

Converting Documents
You can convert PublishView™ documents (.tnsp files) to TI-Nspire™ 
documents (.tns files) for display on handhelds. You can also convert 
TI-Nspire™ documents to PublishView™ documents.

À Click  to start the video. When playing, click  to stop the 
video.

Á As the video plays, the time elapsed is shown in minutes and 
seconds. 

Â When the video starts, the length of the video is shown in minutes 
and seconds.

Ã Use the volume control to increase, decrease, mute, or unmute the 
volume.
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Converting a document creates a new document—the original document 
remains intact and is not linked to the new document. If you make 
changes to one document, the changes are not reflected in the other 
document.

Converting PublishView™ Documents to TI-Nspire™ 
Documents
You cannot open a PublishView™ document (.tnsp file) on a handheld. 
However, you can convert the PublishView™ document to a TI-Nspire™ 
document that can be transferred to and opened on a handheld. When 
you convert a PublishView™ document to a TI-Nspire™ document:

• Only the TI-Nspire™ applications become part of the TI-Nspire™ 
document. 

• PublishView™ objects such as text boxes, images, hyperlinks, and 
videos are not converted.

• Text contained in PublishView™ text boxes is not converted; 
however, text in a TI-Nspire™ Notes application is converted.

• If images are contained in a TI-Nspire™ application, they are 
converted; however, images contained in PublishView™ objects are 
not converted.

Complete the following steps to convert a PublishView™ document 
(.tnsp file) to a TI-Nspire™ document (.tns file).

1. Open the PublishView™ document to be converted.

2. Click File > Convert to > TI-Nspire™ Document.

• The new TI-Nspire™ document opens in the Documents 
Workspace. 

• All supported TI-Nspire™ applications are part of the new 
TI-Nspire™ document. 

• Starting from top to bottom, and then left to right, the layout of 
the TI-Nspire™ document is based on the order of the 
TI-Nspire™ applications in the PublishView™ document. 

– Every TI-Nspire™ application in a PublishView™ document 
will appear as a page in the converted TI-Nspire™ 
document. The order of the pages in the TI-Nspire™ 
document is based on the layout of the TI-Nspire™ 
applications in the PublishView™ document.

– If two or more problems are at the same level, the order is 
left to right.

• Problem breaks are maintained.
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• The new TI-Nspire™ document is not linked to the 
PublishView™ document. 

3. When work in the document is complete, click  to save the 
document in the current folder.

—or— 

Click File > Save As to save the document in a different folder. 

Note: If the document has never been saved, both the Save and 
Save as options allow saving in a different folder.

Note: You can also use the Save as option to convert a 
PublishView™ document to a TI-Nspire™ document.

Note: If you try to convert a PublishView™ document that does not 
contain TI-Nspire™ pages or applications, an error message is displayed.

Converting TI-Nspire™ Documents to PublishView™ 
Documents
You can convert existing TI-Nspire™ documents to PublishView™ 
documents, which enables you to take advantage of the richer layout 
and editing features for printing, generating student reports, creating 
worksheets and assessments, and publishing documents to a website or 
blog.

Complete the following steps to convert a TI-Nspire™ document to a 
PublishView™ document:

1. Open the TI-Nspire™ document you want to convert.

2. Click File > Convert to > PublishView™ Document.

• The new PublishView™ document opens in the Documents 
Workspace. 

• By default, there are six objects per page. 

• When converted, each problem from the TI-Nspire™ document 
will start a new sheet in the PublishView™ document.

• Problem breaks are maintained. 
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3. When work in the document is complete, click  to save the 
document in the current folder.

—or—

Click File > Save As to save the document in a different folder.

Note: You can also use the Save as option to save a TI-Nspire™ 
document as a PublishView™ document.

Printing PublishView™ Documents
You can print reports, worksheets, and assessments created using the 
PublishView™ feature. To print a document:

1. Click File > Print.

The Print dialog box opens. A preview of the document is shown on 
the right side of the dialog box.

2. Select a printer from the menu.

Note: The Print what field is disabled. 

3. Select Paper Size from the menu. Options are:

• Letter (8.5 x 11 inches)

• Legal (8.5 x 14 inches)

• A4 (210 x 297 mm)
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4. Select the number of Copies you want to print.

5. In the Print Range area, select to print all pages in the document, a 
range of pages, or the current page only.

Note: By default, top and bottom margins are set to one-inch and 
are maintained when printing a PublishView™ document. There are 
no side margins. PublishView™ sheets print just as they appear in the 
workspace.

6. If needed, select or clear the boxes to:

• Print Problem Breaks and Names. 

• Print Headers

• Print Footers

• Show object borders

7. Click Print.
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Working with Lesson Bundles

Many lessons or activities contain multiple files. For example, teachers 
usually have a teacher version of a file, a student version, assessments, 
and sometimes supporting files. A lesson bundle is a container that 
enables teachers to group all files needed for a lesson together. Lesson 
bundles are used to:

• Add any type of file (.tns, .tnsp, .doc, .pdf, .ppt) to a lesson bundle. 

• Send lesson bundles to connected handhelds or laptops; however, 
only the .tns files are sent to the handheld.

• View all the files in a lesson bundle using the TI-Nspire™ software.

• Group all files associated with one lesson in one place.

• Email one lesson bundle file to teachers or students instead of 
looking for and attaching multiple files.

Creating a New Lesson Bundle
Teachers and students can create new lesson bundles in the Documents 
Workspace. Teachers can also create new lesson bundles in the Content 
Workspace.

Creating a Lesson Bundle in the Documents Workspace
Complete the following steps to create a new lesson bundle. By default, 
the new lesson bundle does not contain files.

1. Click  in the Documents Toolbox to open the Content Explorer.

2. Navigate to the folder where you want to save the lesson bundle 
file.

3. Click  to open the menu, and then click New Lesson Bundle.

The new lesson bundle file is created with a default name and placed 
in your list of files.

4. Type a name for your lesson bundle.

5. Press Enter to save the file.
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Creating Lesson Bundles in the Content Workspace
In the Content Workspace, teachers have two options for creating lesson 
bundles:

• When files needed for a lesson bundle are located in different 
folders, create an empty lesson bundle, and then add files to the 
lesson bundle.

• If all needed files are located in the same folder, create a lesson 
bundle with selected files.

Creating an Empty Lesson Bundle
Complete the following steps to create a lesson bundle that does not 
contain files. 

1. Navigate to the folder on your computer where you want to save the 
lesson bundle.

Note: If you are using the software for the first time, you may need 
to create a folder on your computer before creating a lesson bundle.

2. Click  or click File > New Lesson Bundle.

The new lesson bundle file is created with a default name and placed 
in the list of files.

3. Type a name for the lesson bundle and press Enter.

The lesson bundle is saved with the new name and details are shown 
in the Preview pane.

Creating a Lesson Bundle Containing Files
You can select multiple files within a folder, and then create the lesson 
bundle. You cannot add a folder to a lesson bundle.

1. Navigate to the folder that contains the files you want to bundle.

2. Select the files. To select multiple files, select the first file then hold 
down Shift and click the last file in the list. To select random files, 
select the first file, and then hold down Ctrl and click the other files 
to select them.

3. Click , and then click Lesson Bundles > Create New Lesson 
Bundle from selected.

A new lesson bundle is created and placed in the open folder. The 
lesson bundle contains copies of the selected files.
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4. Type a name for the lesson bundle and press Enter.

The lesson bundle is saved in the open folder and the details are 
shown in the Preview pane.

Adding Files to a Lesson Bundle
Use any of the following methods to add files to a lesson bundle:

• Drag any file into a selected lesson bundle. This method moves the 
file to the lesson bundle. If you delete the lesson bundle, the file is 
deleted from your computer. You can recover the file from the 
Recycle Bin.

• Copy and paste any file into a selected lesson bundle.

• Use the "Add files to lesson bundle" option. This method copies the 
selected files into the lesson bundle. The file is not moved from its 
original location.

Using the Add Files to Lesson Bundle Option
Use this option to add files to an empty lesson bundle or add more files 
to an existing lesson bundle.

1. Use one of the following options to select the lesson bundle file.

• When working in the Documents Workspace, open the Content 
Explorer, and then double-click the lesson bundle file name.

• When working in the Content Workspace, double-click the 
lesson bundle name. 

Note: In the Content Workspace, you can also click the lesson 
bundle name to open the Files dialog box in the Preview pane. 
The Add Files to Lesson Bundle option is available from the Files 
dialog box. If the lesson bundle already contains files, the first 
file in bundle is shown in the Files dialog box.

The lesson bundle dialog box opens. The name reflects the name of 
the lesson bundle.
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2. Click Add Files to Lesson Bundle. 

The Add dialog box opens.

3. Navigate to and select the file you want to add to the lesson bundle.

• You can select multiple files at one time if they are located in the 
same folder.

• If files are located in different folders, you can add them one at 
a time.

• You cannot create a folder within a lesson bundle or add a 
folder to a lesson bundle.

4. Click Add to add the file to the bundle. 

The file is added to the bundle and is now listed in the lesson bundle 
dialog box.

5. Repeat this process until all needed files are added to the lesson 
bundle.

Opening a Lesson Bundle
To view and work with files within a lesson bundle, complete one of the 
following steps to open the lesson bundle file.

8 Double-click the lesson bundle name.

8 Select the lesson bundle, and then right-click and click Open.

8 Select the lesson bundle, click , and then click Open.

8 Select the lesson bundle, and then press Ctrl + O. (Mac®: “ + O).
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When you open a lesson bundle, the files in the bundle are displayed in a 
separate dialog box.

Note: You cannot open a lesson bundle outside of the TI-Nspire™ 
software. For example, if you open the folder using the file manager on 
your computer and double-click the lesson bundle name, it does not 
automatically launch the TI-Nspire™ software.

Opening Files Within a Lesson Bundle
You can open any file within a lesson bundle on your computer if you 
have the program associated with the file type. 

• When you open a .tns or .tnsp file, the file opens in the Documents 
Workspace in the TI-Nspire™ software.

• When you open another file type, it launches the application or 
program associated with that file. For example, if you open a .doc 
file, it opens in Microsoft® Word.

Use one of the following options to open a file within a lesson bundle:

8 Double-click the lesson bundle, and then double-click a file within 
the lesson bundle.

8 Within a lesson bundle, select the file, and then click ¢ or right-click 
the file name and select Open.

Managing Files in a Lesson Bundle
You can open, copy/paste, delete, and rename files in an existing lesson 
bundle. To locate and work with files in an existing lesson bundle:

1. Choose one of the following options to locate an existing lesson 
bundle.

• When working in the Documents Workspace, open the Content 

Explorer (click  in the Documents Toolbox), and then 
navigate to the folder where the lesson bundle is located.

• When working in the Content Workspace, navigate to the folder 
where the lesson bundle is located in Content pane.
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Note: When you click a lesson bundle name in the Content 
pane, the Files dialog box opens in the Preview pane. Select a 
file and right-click to open the context menu.

2. Double-click the lesson bundle name to open the Lesson Bundle 
dialog box.

3. Select the file you want to work with and click ¢ to open the context 
menu.

4. Click the action you want to perform:

• Click Open. TI-Nspire™ and PublishView™ documents open in 
the Documents Workspace. When you open another file type, it 
launches the application or program associated with that file.

• Click Copy to place the file in the Clipboard. 
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• Navigate to a folder on your computer or select a connected 
handheld or laptop, and then right-click and click Paste to place 
the copied file in a new location.

• Click Delete to delete a file from the lesson bundle. Use caution 
when deleting a file from a lesson bundle. You should ensure 
files contained in the bundle are backed up if you need the files 
for future use.

• Click Rename to give the file a new name. To cancel this action, 
press Esc.

• Click Add Files to Lesson Bundle to select and add files to the 
bundle.

• Click Refresh to update the list of files in the bundle.

• Click Package Lesson Bundle to create a .tilb file

• Click Send to Connected Handhelds to open the Transfer Tool 
and send the selected file to connected handhelds. You can send 
.tns files, .edc files, .fig files and OS files. When you send .edc 
and .fig files to handhelds, they are converted to .tns files. 

Note: This option is not available in the TI-Nspire™ Navigator™ 
NC Teacher Software.

5. When finished, click Close to close the dialog box.

Managing Lesson Bundles
Use the options menu or the context menu to copy, delete, rename, or 
send a lesson bundle to connected handhelds or laptops. You cannot add 
a folder to a lesson bundle.

Managing Lesson Bundles in the Documents Workspace
1. Open the Content Explorer, and then right-click the lesson bundle 

name or click  to open the context menu.
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2. Click the action you want to perform. If an action is not available, it 
is dimmed.

• Click Open to open the lesson bundle.

• Click Up One Level to navigate up a level in the folder hierarchy.

• You cannot add a folder to a lesson bundle. If you click New 
Folder, a new folder is added to the folder where the lesson 
bundle is stored.

• Click New Lesson Bundle to create a new lesson bundle. The 
new lesson bundle is not added to the existing lesson bundle—it 
is created in the same folder as the existing lesson bundle.

• Click Rename to change the name of the lesson bundle. Press 
Esc to cancel this action.

• Click Copy to copy the lesson bundle to the Clipboard.

• Navigate to another folder, and then click Paste to copy the 
lesson bundle in another location.

• Click Delete to delete the lesson bundle. Use caution when 
deleting a lesson bundle. You should ensure files contained in 
the bundle are backed up if you need the files for future use.

• Select All highlights all files in the open folder. This action does 
not apply to lesson bundles.
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• Click Package Lesson to create a .tilb file.

• Click Refresh to update the list of files in the open folder.

Managing Lesson Bundles in the Content Workspace
1. Click Computer Content in the Resources pane.

2. In the Content pane, navigate to the lesson bundle you want to 

work with, and then right-click to open the context menu or click  
to open the menu of options.

3. Select the action you want to perform:

• Click Open to open the lesson bundle.

• Click Copy to place the lesson bundle file in the Clipboard. 

• Navigate to a folder on your computer or select a connected 
handheld, and then right-click and click Paste to place the 
copied file in a new location.

• Click Delete to delete the lesson bundle. Use caution when 
deleting a lesson bundle. You should ensure files contained in 
the bundle are backed up if you need the files for future use.

• Click Refresh to update the list of files in the bundle.

• Click Rename to give the lesson bundle a new name. To cancel 
this action, press Esc.

• To move up a level in the folder hierarchy, click Up a Level.

• To add the lesson bundle to the list of shortcuts in Local Content, 
click Create Shortcut.

• To add more files to the lesson bundle, click Lesson Bundles > 
Add Files to Lesson Bundle.
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• Click Lesson Bundles > Package Lesson Bundle to create a .tilb 
file.

• Click Send to Connected Handhelds to open the Transfer Tool 
and send the lesson bundle to connected handhelds. (This 
option is not available in the TI-Nspire™ Navigator™ NC Teacher 
Software software.)

Packaging Lesson Bundles
Packaging lesson bundles creates a "package" folder with a .tilb file. This 
file contains all files contained in the lesson bundle. You must package 
the lesson before you can email the lesson bundle (.tilb file) to colleagues 
or students. By default, the lesson bundle is saved in the following folder:
...\TI-Nspire\New Lesson Bundle1.tilb\package\...

Packaging a Lesson in the Documents Workspace
1. Open the Content Explorer.

2. Navigate to the folder where the lesson bundle is saved.

3. Select the lesson bundle you want to package.

4. Right-click to open the context menu, and then click Package 
Lesson.

The Lesson Bundle dialog box opens confirming that the .tilb file was 
created and the lesson bundle was successfully packaged.

5. Click Yes to open the folder where the lesson package is stored. Click 
No to close the dialog box.

Packaging a Lesson in the Contents Workspace
1. In Computer Content, navigate to the folder that contains the 

lesson bundle you want to package.

2. Click the lesson bundle in the Content pane. The Lesson Bundle 
details are displayed in the Preview pane.

3. Use one of the following methods to create the package:

• From the Preview pane, click ¢ in the Files dialog box, and then 
click Package Lesson Bundle.
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• From the Content pane, right-click the lesson bundle name, and 
then click Lesson Bundles > Package Lesson Bundle.

The Lesson Bundle dialog box opens confirming that the lesson 
bundle was created.

4. Click Yes to open the folder where the lesson package is stored. Click 
No to close the dialog box.

Emailing a Lesson Bundle
After a lesson bundle is packaged, you can email the .tilb file to other 
teachers or students. To attach the lesson bundle to an email:

1. In your email client, select the option needed to attach a file, and 
then navigate to the .tilb folder.

2. Make sure you open the folder and select the .tilb file to attach to 
the email. You cannot email the .tilb folder.

Sending Lesson Bundles to Connected Handhelds
Note: This option is not available in TI-Nspire™ Navigator™ NC Teacher 
Software.

1. Complete one of the following actions to select a lesson bundle:

• In the Documents Workspace, open the Content Explorer, and 
then select the lesson bundle you want to send.

• In the Content Workspace, navigate to the lesson you want to 
send in the Content pane.

2. Drag the lesson bundle file to a connected handheld. You can also 
copy the lesson bundle, and then paste it to a connected handheld.

The lesson bundle is transferred to the handheld as a folder with the 
same name. Only .tns files are transferred to the handheld.
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Capturing Screens

Screen Capture enables you to:

• Capture Class

– View and monitor all student screens at one time, which allows 
you to ensure all students are on track with an assignment. 

– Capture one or several student screens for discussion in the 
classroom. You can hide student names to focus the discussion 
on the lesson or concept, and not on individuals. 

– Select and display an individual student screen and view work as 
a live presentation.

– Capture screen stacks that enable you to check student progress 
or collect student assignments for later review.

– Save captured images as .jpg, .gif, or .png files, which can be 
inserted into TI-Nspire™ applications that allow images.

• Capture Page

– Capture the active page in a TI-Nspire™ document from the 
software or from the TI-SmartView™ emulator as an image. 

– Save captured images as .jpg, .gif, .png, or .tif files, which can be 
inserted into TI-Nspire™ applications that allow images.

– Copy and paste images into another application such as 
Microsoft® Word.

• Capture Selected Handheld

– Capture the current screen on a connected handheld as an 
image.

– Save captured images as .jpg, .gif, .png, or .tif files, which can be 
inserted into TI-Nspire™ applications that allow images.

– Copy and paste images into another application such as 
Microsoft® Word.

• Capture Images in Handheld Mode

– In the Documents Workspace, use the DragScreen feature to 
capture the emulator screen or side screen when the 
TI-SmartView™ Emulator is active.

– Teachers can use this feature to drag and paste an image to 
presentation tools such as SMART® Notebook, Promethean’s 
Flipchart, and Microsoft® Office applications including Word 
and PowerPoint®.
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Accessing Screen Capture
The Screen Capture tool is available from all workspaces. To access Screen 
Capture:

8 From the menu bar, click Tools > Screen Capture.

8 From the toolbar, click .

Using Capture Class
In the classroom, use the Screen Capture tool to view and capture 
student screens. You can capture the screen of one selected student, of 
multiple selected students, or of all the students in the class.

If using TI-Nspire™ Navigator™ NC Teacher Software, you can select to 
view only the work area of the student software on the student screens, 
or the entire computer screen, which may include all applications the 
student as open at the time.

Note: To view and capture student screens, they must be logged into 
class.

Capturing Student Screens
1. If you have not already done so, begin the class session and ask your 

students to log in.

2. Click , and then click Capture Class.

The Select Individual(s) dialog box opens. If you selected students in 
Class Workspace, those student names are highlighted. If no students 
were selected, all student names in the class are selected. 
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3. To change the selected student or add more students:

• Click  to display the screens of all students in the class. If a 
student is not logged in, the handheld display indicates "Not 
Logged In." As students log in, click refresh to update your 
screen.

• Click , and then click the name of each student to display 
the screens of individual students. To select multiple students, 
hold down the Shift key. To select students in random order, 
hold down the Ctrl key (Mac®: “) and click each student name.

• Select the Logged in only check box under the left pane to 
display screens from only those students currently logged in. 
When you refresh your screen, any students who log in after the 
initial screen capture will be listed at the end of the Class Screen 
Capture window.

4. Click OK.

To view only the work area and not the entire student screen, select 
Show TI-Nspire Work Area Only.

The screens of the selected students are displayed in the Class Screen 
Capture window.

Note: The following example shows the screens from two selected 
students who are logged in. The default view is Tiled, which shows 
all screens captured in the window.
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5. Decide if you want to display or hide the student names. To hide or 
show student names, select the check box on the toolbar to toggle 
between hide and show or click View > Show Student Names. 

Note: Your selection to show or hide student names remains in 
effect until you change it. For example, if you select to hide student 
names, the student names will remain hidden when you close the 
Class Screen Capture window and return to the Class Workspace. If 
you select to hide student names in the Class Workspace, they will be 
hidden when the Class Screen Capture window opens.

Setting Teacher Preferences for Capture Class
Use the Teacher Preferences option to set preferences for using the 
randomize screen option and for displaying the teacher handheld. 
Creating a user name and password enables teachers to log in to an 
active class. You can also select to individualize the view of your 
handheld screen when it is displayed. For more information, see the 
handheld guidebooks oneducation.ti.com/guides.

1. From the TI-Nspire™ Navigator™ Teacher Software window, click 
File > Settings > Teacher Preferences.

The Teacher Preferences dialog box opens.

2. If you haven’t already done so, create a Username and Password. 

3. Select "Add teacher to classroom view" to show your handheld in 
the Class Screen Capture window.

4. To randomize the order in which screens are captured, select 
"Randomize order in Screen Capture."
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5. Select the "Individualize Teacher Handheld in Screen Capture" 
option so that a captured screen from the teacher handheld appears 
differently in the Class Screen Capture window than screens 
captured from student handhelds.

6. Click OK to save the settings.

Setting View Options in Capture Class
When working with captured screens in the Class Screen Capture 
window, you have several options for optimizing the view of the screens 
for presentation to a classroom, including:

• Toggling between a tiled view and a gallery view.

• Comparing selected screens in a side-by-side view.

• Refreshing the view as needed or setting the auto-refresh feature to 
automatically refresh the view at timed intervals.

• Zooming in or out to increase or decrease the size of the captured 
screens in the window. You can also select the percentage at which 
the size of the screen will be increased or decreased.

• Showing or hiding student names.

• Accessing Live Presenter options. For more information, see Using 
Live Presenter.

Toggling Between Tiled and Gallery Views
When you capture student screens, the default view for the Class Screen 
Capture window is Tiled. Switch to Gallery view to show an enlarged 
view of a selected screen. Thumbnail views of all the captured screens are 
shown in the left pane, enabling you to find and select screens.

To toggle between Tiled and Gallery views:

8 Click , and then click Gallery or Tiled.

—or—

8 Select View > Gallery or select View > Tiled.

—or—

8 For Gallery view, press Ctrl + G. (Mac®: “ + G). For Tiled view, press 
Ctrl + T (Mac®: “ + T).

In Gallery view, thumbnail images of captured screens are displayed in a 
column in the left pane of this view. An enlarged view of a selected 
screen is displayed in the right pane.
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• Captured screens appear in the same order as in Tiled View. 

• If you select multiple thumbnails to view in the left pane, they are 
displayed in the right pane. 

• If you select more than four thumbnails, view the additional screens 
by scrolling down the right pane. 

• If you selected to show student names, names are centered under 
each student’s captured screen. 

• Zoom functions are disabled in Gallery View.

• You can change the order of the screens in the Gallery View.

• The width of the thumbnail pane cannot be changed.

Rearranging Captured Screens
Complete the following steps to change the order of the captured 
screens within the Class Screen Capture window.

1. Click the desired screen to select it.

2. Holding the left mouse button down, drag the screen to the desired 
location and release.

Refreshing Captured Screens
As students log in to class and work on their screens, you can update the 
view of the captured screens. When you refresh the view in the Class 
Screen Capture window, the latest student screens are displayed. You can 
refresh the view as needed, or you can set the auto-refresh option to 
refresh the view automatically at timed intervals.
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Refreshing the View as Needed

8 Click .

The latest screens from the connected handhelds are captured and 
displayed in the Class Screen Capture window.

Note: If a student has lost connection and a screen cannot be 
refreshed, it is outlined in yellow.

Enabling the Auto-Refresh Screen Capture Feature
The auto-refresh feature is useful for monitoring class performance. This 
feature enables you to automatically refresh the view of captured 
screens at timed intervals. The default setting for the auto-refresh 
feature is Off. To enable auto-refresh:

1. Click View > Auto Refresh or select  on the 
toolbar. 

2. Click one of the available time interval options.

Note: Auto-refresh is available when using either the Tiled or Gallery 
view. It is not available in Live Presenter mode.

The border color changes if a screen cannot be refreshed.
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Using Zoom in and Zoom out
In the Class Screen Capture window, use the zoom in and zoom out 
options to increase or decrease the size of the captured screens. 

8 From the toolbar, click  to increase the size of the screens in the 
view. You can also select View > Zoom In from the menu.

8 From the toolbar, click  to decrease the size of the screens in the 
view. You can also select View > Zoom Out from the menu.

Setting a Zoom Percentage
The Zoom Percentage option enables you to select the percentage by 
which the screen image is increased or decreased when zooming in or 
out. To select a percentage:

1. From the Class Screen Capture window, click View > Zoom 
Percentage.

The drop-down list of available percentages opens.

2. Click one of the available percentages.
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Creating Stacks of Student Screens
This feature enables you to collect a history of one or more students’ 
screens captured in the Capture Class option. These collections are called 
stacks, and you can add or remove screens from each student’s stack, as 
well as navigate within and through student stacks. Using stacks is a 
convenient way to check progress in a lesson, collect student 
presentations or assignments to review and grade later, or to show 
performance and progress in parent/teacher meetings.

You add, remove, navigate, and save stacks from the Class Capture 
window, which becomes available when you use the Capture Class 
option.

8 To open the Class Capture window, click Window > Class Capture 
Window.

Adding Screens to a Stack
8 In the Class Capture window, click View > Stacks > Add to Stack, 

or click .

8 To add another set of screens, first click Refresh  and then add 
the stack.

When the first set of screens is added to a new stack, it is labeled Frame1. 
Each subsequent addition increases the number by one; for example, 
Frame2, Frame3, and so forth.

Removing Frames from a Stack
1. Select the frame you want to remove.

2. Click View > Stacks > Remove from Stack, or click .

As frames are removed from a stack, their names are adjusted to remain 
sequential and reflect the deletion. For example, if Frame6 is deleted, 
Frame7 is renamed to Frame6 and all subsequent frame numbers are 
adjusted downward by one digit.

Navigating Through Stacks
You can navigate a stack of frames from either the tiled or gallery view.

8 To view different frames in a stack, use one of these options:

• Click the drop-down arrow, and then click the desired frame 
from the list.
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• View > Stacks > Next Frame, or click .

• View > Stacks > Previous Frame, or click .

Note: These options are available only if there is a next or previous frame 
to view.

Saving Stacks
When you close the Class Capture window, the software asks if you want 
to save the stacks. 

1. Click Yes to save the stacks.

The Select or Create Folder to Save Stacks dialog box opens.

2. Click Save to save the stacks in the default folder, or create or 
navigate to another folder and then click Save.

The stacks are saved as individual screen captures with the student’s 
name, image number, date, and time. For example:

Laxmi Chopra_image1_10-21-2011_11-50 

Laxmi Chopra_image2_10-21-2011_11-57 

Use the Content Workspace or your computer’s file management system 
to locate and open the saved screens.

The screens open in the default photo viewer on your computer.

Comparing Selected Screens
This feature enables you to compare student screens side-by-side. 
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1. Select the student screens you want to compare. To select multiple 
consecutive screens, hold down the Shift key. To select screens in 
random order, hold down the Ctrl key (Mac®: “) and click each 
image you want to save. When you select each screen, the border 
changes color. 

Note: If you select more than four screens, scroll down the viewing 
pane to see them.

2. Click Edit > Compare Selected. 

If you are in Tiled view, the view switches to Gallery view and the 
selected screens are listed in the order selected.

Note: This option is disabled when in Gallery view.

3. To exit comparison mode, click outside the screen in the left pane of 
the Gallery view.

Using Make Presenter
Select a captured screen from the Class Screen Capture window, and then 
click the Make Presenter option on the toolbar to launch Live Presenter 
and present a student screen to the class. You can only choose one 
student at a time to be the Live Presenter. For more information, see 
Using Live Presenter.

Saving Screens When Using Capture Class
You can save captured screens for use in other TI-Nspire™ documents 
that allow images or for use in other application such as Microsoft® 
Word. You can save images in the following formats: .jpg, .png, or .gif. 
You can save one image at a time, select multiple images to save, or save 
all captured images.

Saving Screen Images
To save screen images captured when using Capture Class, complete the 
following steps.

1. In the Class Screen Capture window, select the screen or screens you 
want to save as image files.

• To select multiple consecutive screens, click the first image, and 
then hold down the Shift key and click the additional images. To 
select screens in random order, hold down the Ctrl key (Mac®: 
“) and click each image you want to save.

• To select all captured screens, click Edit > Select All.

2. Click File > Save Selected Screen(s) or press Ctrl + S (Mac®: “ + S).
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The Save dialog box opens.

3. Navigate to the folder on your computer where you want to save the 
file(s).

4. Type a name for the file or files in the File Name field. 

The default file name is Image. 

5. In the Files of Type field, click ¤, and then select the file type: .png, 
.jpg, or .gif. The default file type is .jpg.

6. Click Save.

The file or files are saved in the designated folder.

• If you saved one image, the file is saved with the name as 
specified in the File Name field.

• If you saved multiple images, the files are saved with the name 
specified in the File Name field with a number appended to the 
file name to make each file name unique. For example, Image1, 
Image 2, and so on.

Printing Captured Screens
You can print screens captured using the Capture Class option. You can 
print one, multiple, or all captured screens. For each printed page, the 
class name is printed in the page header, and the date and page number 
are printed in the page footer.

Note: The print option is not available when using the Capture Page or 
Capture Selected Handheld options.

To print a captured screen:

1. Select the screen you want to print.
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2. Click File > Print.

The Print dialog box opens.

3. If you selected more than one screen, click Print Options to select 
the number of screen captures that you want per page. 

The Print Options dialog box opens.

4. Select options as needed. You can select to print one screen per 
page, six screens per page, or all screens on the page. You can also 
select whether to print student names.

5. Click OK to return to the Print dialog box.

6. Select the individual printer options for your printer.

7. Select the number of copies you want to print.

8. Click Print to send the print job to the selected printer.
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Using Capture Page
Use the Capture Page option to capture an image of an active page in a 
TI-Nspire™ document. You can save images in the following file formats: 
.jpg, .gif, .png, and .tif. Saved images can be inserted into TI-Nspire™ 
applications that allow images. The image is also copied to the Clipboard 
and can be pasted into other applications such as Microsoft® Word or 
PowerPoint.

Capturing a Page
Complete the following steps to capture an image of an active page.

1. In the Documents Workspace, open a document and navigate to the 
page you want to capture to make it active.

2. Click , and then click Capture Page.

The image of the active page is copied to the Clipboard and to the 

Screen Capture window. The  dialog box 
opens in the lower right corner of your desktop when the screen 
capture is complete.

3. Click View it.

The Screen Capture window opens.

You can also click Window > Screen Capture Window to open the 
Screen Capture window.
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4. To capture additional pages, move to another page in the current 
document or open a new document to select a page. 

As you capture additional pages, the images are copied to the Screen 
Capture window, which holds multiple images. The last page 
captured replaces the contents of the Clipboard.

Using Capture Selected Handheld
Use the Capture Selected Handheld option to capture the active screen 
on a connected handheld.

1. On a connected handheld, navigate to the menu or to a page in a 
document you want to capture.

2. In the software, select the connected handheld:

• In the Content Workspace, select the handheld from the list of 
Connected Handhelds in the Resources pane.

• In the Documents Workspace, open Content Explorer from the 
Documents Toolbox, and then select the handheld from the list 
of Connected Handhelds.

• In the Class Workspace, select a logged in student. 

3. Click , and then click Capture Selected Handheld.

—or—
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Click , and then click Capture Selected Handheld.

The screen is copied to the Clipboard and to the TI-Nspire™ Screen 

Capture window. The  dialog box opens 
in the lower right corner of your desktop when the screen capture is 
complete.

4. Click View it.

The Screen Capture window opens.

You can capture additional screens from an open document on a 
connected handheld or open another document on a connected 
handheld to capture screens from that document. 

As you capture additional screens, the images are copied to the 
Screen Capture window, which holds multiple images. The last screen 
captured replaces the contents of the Clipboard.

Viewing Captured Screens
When you capture a page or screen, it is copied to the Screen Capture 
window. 

Zooming the View of Captured Screens
In the Screen Capture window, use the zoom in and zoom out options to 
increase or decrease the size of the captured screens. 
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8 From the toolbar, click  to increase the size of the screens in the 
view. You can also click View > Zoom In from the menu.

8 From the toolbar, click  to decrease the size of the screens in the 
view. You can also click View > Zoom Out from the menu.

Saving Captured Pages and Screens
You can save captured pages and screens captured as images for use in 
other TI-Nspire™ documents that allow images or for use in other 
applications such as Microsoft® Word. You can save one image at a time, 
select multiple images to save, or save all captured images.

Saving Selected Screens
1. In the Screen Capture window, select the screen image you want to 

save.

2. Click File > Save Selected Screen(s).

Note: From the Screen Capture window, you can also click .

The Save as dialog box opens.

3. Navigate to the folder on your computer where you want to save the 
file.

4. Type a name for the file. 

Note: The default file name is MM-DD-YYYY Image ###.

5. Select the file type for the image file. The default format is .jpg. 
Click ¤ to select another format: .gif, .tif, or .png.
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6. Click Save.

The file is saved in the designated folder.

Saving Multiple Screens
1. In the Screen Capture window, select the screens you want to save.

To select multiple consecutive screens, click the first image, and then 
hold down the Shift key and click the additional images. To select 
screens in random order, press Ctrl (Mac®: “) and click each image 
you want to save.

2. Click  or select File > Save Selected Screen(s). To save all 
captured screens, select File > Save All Screens.

Note: The "Save All Screens" option is not available when using 
Capture Class.

The Save as dialog box opens.

3. In the Save In field, navigate to the folder where you want to save 
the images.

4. In the File Name field, type a new folder name. The default folder 
name is MM-DD-YYYY Image, where MM-DD-YYYY is the current 
date.

5. Select the file type for the image files. The default format is .jpg. 
Click ¤ to select another format: .gif, .tif, or .png.

6. Click Save. 

The images are saved in the specified folder with system-assigned 
names reflecting the current date and a sequence number. For 
example, MM-DD-YYYY Image 001.jpg, MM-DD-YYYY Image 002.jpg 
and so on.

Copying and Pasting a Screen
You can select a captured screen and copy it to the Clipboard for 
inclusion into other documents or applications. You can also print copied 
screens. Copied screens are captured at 100% zoom level, and they are 
copied in the order of selection. 

Copying a Screen
1. Select the screen to copy.

2. Click  or Edit > Copy.

The selected screen is copied to the Clipboard.
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Pasting a Screen
Depending on the application you are pasting to, click Edit > Paste.

Note: You can also drag a screen capture to another application. This 
functions as a copy and paste.

Capturing Images in Handheld Mode
In the Documents Workspace, use the DragScreen feature to capture the 
emulator screen or side screen when the TI-SmartView™ Emulator is 
active. 

Teachers can use this feature to drag and paste an image to presentation 
tools such as SMART® Notebook, Promethean’s Flipchart, and Microsoft® 
Office applications including Word and PowerPoint®.

Capturing Images Using the DragScreen Feature
Complete the following steps to capture an image and copy it to a third-
party application.

1. From the Documents Workspace, click , which is located in the 
Documents Toolbox.

The TI-SmartView™ Emulator opens. 

• If the display selected is Handheld + SideScreen, the current 
document is shown in the emulator and in the side screen.

• If the display selected is Keypad + SideScreen, the current 
document is shown in the side screen.
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2. To start the screen capture, click the area above the emulator screen 
or above the keypad. In the Handheld + Sidescreen display, you can 
also click the area around the emulator screen. 

Do not release the mouse button. If the cursor is active or if you click 
inside the emulator window, the screen capture is not started.

3. Without releasing the mouse, drag the image.

A ghost image of the captured screen opens. The ghost image 
remains visible until you release the mouse button. 

The  in the corner of the ghost image indicates you cannot paste 
the image in that location.

In Handheld + SideScreen view, click 
the area above the emulator, click the 
area around the emulator, or click the 
border of the emulator screen to start 
the screen capture.

In Keypad + SideScreen view, click the 
area above the keypad to start the 
screen capture.
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4. Drag the image to an open third-party application. When the image 

is on top of the third-party application, the  indicates you can 
drop the image.

5. Release the mouse button to drop the image into the selected 
application.

The image is also copied to the Clipboard and to the TI-Nspire™ 
Screen Capture window. 

To view captured images in the Screen Capture window, click 
Window > Screen Capture Window.

You can capture additional screens as needed. As you capture 
additional screens, the images are copied to the Screen Capture 
window, which holds multiple images. The last screen captured 
replaces the contents of the Clipboard.

ghost 
image
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Working with Images

Images can be used in TI-Nspire™ applications for reference, assessment, 
and instructional purposes. You can add images to the following 
TI-Nspire™ applications:

• Graphs & Geometry

• Data & Statistics

• Notes

• Question, including Quick Poll

In the Graphs & Geometry and Data & Statistics applications, images are 
set in the background behind the axis and other objects. In the Notes and 
Question applications, the image is set at the cursor location inline with 
the text (in the foreground).

You can insert the following image file types: .jpg, .png, or .bmp. 

Note: The transparency feature of a .png file type is not supported. 
Transparent backgrounds are displayed as white.

Working with Images in the Software
When working in the TI-Nspire™ software, you can insert, copy, move, 
and delete images.

Inserting Images
In the Notes and Question applications, and in Quick Poll, you can insert 
more than one image on a page. You can only insert one image on a 
page in the Graphs & Geometry and Data & Statistics applications.

1. Open the document where you want to add an image.

2. Click Insert > Image.

The Insert Image dialog box opens.
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3. Navigate to the folder where the image is located and select the 
image.

4. Click Open.

• In the Graphs & Geometry and Data & Statistics applications, the 
image is inserted in the background behind the axis.

• In Notes, Question, and Quick Poll, the image is inserted at the 
cursor location. You can type text above or below the image, 
and you can move the image up or down on the page.

Note: You can also insert images by copying an image to the Clipboard 
and pasting it into the application.

Moving Images
In applications such as Notes and Question where the image is set at the 
cursor location, you can reposition the image by moving the image to a 
new line or blank space, or by placing the image within a line of text. In 
the Graphs & Geometry and Data & Statistics applications, images can be 
moved to any position on the page.

1. Select the image.

• In the Notes and Question applications, click the image to select 
it.

• In the Graphs & Geometry and Data & Statistics applications, 
right-click the image, and then click Select > Image.

2. Click the selected image and hold the mouse button.

• If an image is in the foreground, the cursor changes to .



Working with Images 197

• If an image is in the background, the cursor changes to .

3. Drag the image to the new location and release the mouse button to 
place the image.

If an image is in the foreground, the cursor changes to  when 
you hover your mouse pointer over a location where there is a new 
line or space. Images in the background can be moved and placed 
anywhere on the page.

Resizing Images
To retain the aspect ratio of an image, resize by grabbing the image at 
one of the four corners. 

1. Select the image.

• In the Notes and Question applications, click the image to select 
it.

• In the Graphs & Geometry and Data & Statistics applications, 
right-click the image, and then click Select > Image.

2. Move the cursor to one of the corners of the image.

The cursor changes to  (a four-sided directional arrow). 

Note: If you drag the cursor to an edge of the image, the cursor 

changes to  (a two-sided directional arrow). If you drag an image 
from one of its edges to resize it, the image becomes distorted.

3. Click the corner or edge of the image.

The  tool is enabled.

4. Drag in to make the image smaller or drag out to make the image 
larger.

5. Release the mouse when the image size is correct.

Deleting Images
To delete an image from an open document, complete the following 
steps.

1. Select the image.

• If an image is in the foreground, click the image to select it.

• If an image is in the background, right-click the image, and then 
click Select > Image.
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2. Press Delete.

The image is removed.
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Using the Class Workspace

Use this workspace to add and manage classes and students, and to 
exchange files with students.

Adding Classes
When you start using the TI-Nspire™ software, one of the first things you 
should do is create your classes. Make sure you create a class for each of 
the class periods you plan to teach.

If this is your first time using the TI-Nspire™ software, the classroom area 
may be empty. You can complete the following steps at any time.

À Class Record. Document actions are shown here. You can open a 
document in the Review Workspace; save a document to the 
Portfolio Workspace; collect files from the Class Record Workspace; 
send and delete files using the toolbar, and view document 
properties in Record Item Properties.

Á Classroom area. Shows the students in your class, which ones are 
logged in, and the status of file transfers for selected files in the 
Class Record. You can view the students by Seating Chart or by 
Student List.

Â Student View. Lets you show the students in the classroom area in 
Seating Chart view or Student List view.
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The Add Classes Wizard guides you through the process of setting up 
classes. The software prompts you to add a class, and to add students to 
the class. You can choose to add classes manually or using a CSV file.

Adding Classes Manually
1. Use the Workspace selector to select the Class Workspace.

2. Click Class > Add Classes or click .

The Add Classes dialog box opens.

3. Select Manually from the Add Classes dialog box.

4. Click Next.

The Add Classes Manually dialog box opens.
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5. Type a Class Name. If needed, you can also provide a Section.

Note: It is a good idea to append a unique identifier such as the 
course ID or the teacher name to the class name. This helps the 
student select the correct class if there are, for example, multiple 
Algebra I classes running.

6. Click Add.

The Add Classes Manually dialog box shows the class listed.

7. Continue adding classes, and click Next when you are done.

A dialog box displays showing successful class creation and asking if 
you want to add students.

8. Click Add Student.

Note: Click Finish to Add Students later.

Adding Classes with a CSV Upload
You can add classes with a CSV upload, and import a list of students into 
the class. Use the CSV upload option to import student information from 
a comma-separated values (CSV) file or a text (.txt) file. 

The CSV or .txt file should have this information:

Class Name
Section Name (optional)
Student First Name
Student Last Name
Student User Name
Student ID (optional)
Password (optional)

1. Use the Workspace selector to select the Class Workspace.
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2. Click Class > Add Classes or click .

The Add Classes dialog box opens.

3. Select Upload a CSV file from the Add Classes dialog box.

4. Click Next.

The Add Classes by Uploading a CSV File dialog box opens.

5. Click Browse to navigate to the file on your computer.

6. Select the file that contains the students you want to import.

7. Click Open.

The Add Classes by Uploading a CSV File dialog box shows the file.

8. Click Next.

The Mapping fields dialog box opens.
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9. Click ¤ and select a field from the drop-down lists to map the 
headings in your comma-delimited file.

10. Click Next.

A dialog box opens showing completion status.

11. Click OK to close

Note: If some students did not import successfully, click View Details 
to determine the problem.

Adding Students to Classes
After you create classes, you need to add students to the classes. You can 
add students to an active class session, or you can add students to any 
class at any time.

Note: These instructions explain how to add students after you create a 
class. 
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1. Select the class to which you want to add students.

• If class is in session, the student will be added to the current 
class. You have the option of adding the student to other classes.

• If class is not in session, use the Class Session controls to select 
the class to which you want to add the student.

2. Click Class > Add Student or click .

The Add Student dialog box opens.

3. Type the student’s first name and last name.

4. Type a user name.

Note: The user name you choose must be unique. It cannot exist in 
the current class or any other class.

5. If you want your student to create their own password, select 
Student Chooses.

—or—

If you want to create a password for your student, select the blank 
password entry box and type a new password.

6. (Optional) Type a display name.

Note: If you leave the display name blank, the software uses the 
student’s first name as the display name.

7. (Optional) Type a student ID.
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8. (Optional) Assign the student to other classes:

• Click Assign Classes.

The Assign Classes dialog box opens.

• Select the check boxes of the student’s classes.

• Clear the check boxes of the classes to which the student does 
not belong.

• Click OK.

The Add Student dialog box opens.

9. If you need to add another student, click Add Next Student and 
repeat steps 3 – 8.

10. When all students are added, click Finish.

Removing Students from Classes
As necessary, you can remove students from your classes. When you 
remove students, the TI-Nspire™ software only removes them from the 
selected class. If the students are in other classes, they remain in those 
classes until you remove them.

Notes: 

• You cannot remove students who are logged in to the TI-Nspire™ 
Navigator™ network.

• You cannot undo the removal of students.

• You can access many of the student account items by right-clicking 
the student icon in the classroom area and choosing an action from 
the menu.
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To remove a student from a class:

1. Click the student you want to remove.

2. Click Class > Remove Student, or click .

The software asks if you are sure you want to remove the student.

3. Click Yes.

The software removes the student.

Updating Class Rosters
You can update a single or multiple class rosters with new student 
information by importing a CSV file with updates.

Note: You cannot change existing student information or remove 
students already in the TI-Nspire™ Navigator™ database.

You can import a comma-separated value (CSV) file or a *.txt file. The 
CSV or .txt file should have this information:

Class Name
Section Name (optional)
Student First Name
Student Last Name
Student User Name
Student ID (optional)
Password (optional)

1. Use the Workspace selector to select the Class Workspace.

2. Select the class for which you want to update the roster.

Note: Class cannot be started.

3. Click Class > Update Class Roster.

The Update Class Roster dialog box opens.
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4. Click Browse to navigate to the file on your computer.

5. Select the file that contains the new students you want to import.

6. Click Open.

The Update Class Roster dialog box shows the file.

7. Click Next.

The Mapping fields dialog box opens.

8. Click ¤ and select a field from the drop-down lists to map the 
headings in your comma-delimited file.

9. Click Next.

A dialog box displays showing completion status.
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10. Click OK to close.

Note: If some students did not import successfully, click View Details 
to determine the problem.

Managing Classes
You can delete classes and remove all class information from the 
TI-Nspire™ Navigator™ database. You can also choose to hide or show 
classes in menus and views. 

Deleting a Class
When you delete a class, the software removes the class and removes the 
files on the hard drive that correspond to that class. If you have students 
who are not part of any other classes, the software removes those 
students as well.

Note: You cannot undo the removal of a class.

1. If you have a class session running, end it. 

2. Click Class > Manage Classes.

The Manage Classes dialog box opens.
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3. From the Class list, select the class you want to remove.

4. Select Delete from the Actions list.

5. Click Apply.

The software asks if you are sure you want to remove the class.

6. Click OK.

Hiding a Class
When you hide a class, the class is removed from all workspace views and 
menus except for the Manage Classes dialog box.

Note: Hidden classes are not deleted from the TI-Nspire™ Navigator™ 
database.

1. Click Class > Manage Classes.

The Manage Classes dialog box opens.

2. From the Class list, select the class you want to hide.

3. Select Hide from the Actions list.
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4. Click Apply.

The software asks if you are sure you want to hide the class.

5. Click OK.

Note: Select Show from the Actions list when you want the class to 
show again.

Beginning and Ending a Class Session
A class session is the period of time the TI-Nspire™ software is active for a 
specific class. While a class session is running, you can perform 
communication functions with the selected class. You cannot use 
software to interact with your class until you begin a class session, and 
you cannot begin another class until you end the current one.

Beginning a Class Session
1. Click Class > Select Class, or click the Classroom Session list. 

A list of available classes opens.

2. Select the class you want to begin.

3. Click Begin Class.

Ending a Class Session
When class is over, or before you start another class, you need to end the 
current class session. Ending a class stops all communication between 
your computer and the students. When you end a class, students receive 
a message saying class is ended, and students are automatically logged 
off.

8 To end a current class session, select End Class from the Class Actions 
dropdown list.

Pausing a Class Session
This function is available only on TI-Nspire™ software that supports 
handhelds. There are times you may want to pause a class. If using 
TI-Nspire™ software that supports handhelds, pausing a class suspends 
all activity on student handhelds, and they receive a message telling 
them class is paused. When you resume class, the message clears and 
students are able to use their handhelds. The students remain logged in 
when you pause a class. 

1. To pause a class in session, click Pause Class.
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2. To resume the class, click Resume Class.

Changing the Student View
In the classroom area, you can view the students in the selected class in 
either the Student List view or the Seating Chart view. The Student List 
view shows students in a table that contains their display names, first 
name, last name, user name, and student ID. The Seating Chart view 
shows students as student icons with display names. You can change the 
class view at any time.

Changing the Class View to Student List

8 Click View > Student List or click  in the status bar.

The view changes to Student List.

Changing the Class View to Seating Chart

8 Click View > Seating Chart or click  in the status bar.

The view changes to Seating Chart view.
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Arranging the Seating Chart
Initially, students are arranged in the Seating Chart view in the order that 
you added them. However, you can rearrange the students so that they 
have the same seating arrangement in the classroom area as they do in 
your actual classroom. You can rearrange the seating chart at any time.

Arranging Students in the Seating Chart
1. Select the class from the Class Session list.

2. Click View > Seating Chart.

The classroom area shows your class in the Seating Chart view.

3. Within the classroom area, drag each student icon to the location 
that you want.

The software moves the student icons to the new locations.

The software remembers the student positions the next time you 
start the same class.

Note: Do not place one student icon on top of another student icon. 
If you do this, you will only be able to see one of the student’s icons.

Checking Student Login Status
You can view the students’ login status from the Seating Chart view. The 
color of the icon by the student display names indicates their login status 
as well as the class status: 

Icon Class status Student status Color

Class session not started. N/A Grey

Class session started. Student not logged 
in.

Light blue

Class session started. Student logged in. Dark blue
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Sorting Student Information
The Student List view in the classroom area shows the information for 
students in the selected class. It includes display names, first names, last 
names, user names, and student IDs. In the Student List view, you can sort 
student information by each of these categories. Information is sorted 
alphabetically from A-Z or Z-A and numerically from 1-9 or 9-1. You can 
sort student information at any time.

Sorting Student Information
1. Select the class that contains the student information you want to 

sort. 

Note: If you have a class session running, you must end it to select 
the class. 

2. In the menu, click View > Student List.

3. Click the column title of the list you want to sort.

The software sorts the selected list.

4. To sort the selected information in the opposite order, click the 
column title again.

Changing the Classes Assigned to a Student
Occasionally your students may move to a different class, or they may 
take more than one of your classes. You can change student classes when 
necessary.

Note: You cannot change the classes of students who are logged in to 
the TI-Nspire™ Navigator™ network.

Changing a Student’s Class
1. Select a class to which the student belongs. 

2. Click the student you want to edit.

3. Click Class > Edit Student, or click .

The Student Properties dialog box opens.
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4. Click Assign Classes.

The Assign Classes dialog box opens.

5. Select the check boxes of the student’s classes.

6. Clear the check boxes of the classes to which the student does not 
belong.

7. Click OK.

8. In the Student Properties dialog box, click OK.
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Changing Student Names and Identifiers
After you add students, you may find that you need to change one of 
their names or identifiers. There are five different names and identifiers 
associated with your students, including:

• First name

• Last name

• User name

• Display name

• Student ID

This section covers how to change any of these types of names and 
identifiers.

Note: You cannot change the account information of students who are 
logged in to the TI-Nspire™ Navigator™ network.

Note: You can access many of the student account items by right-clicking 
the student and choosing an action from the menu.

Changing Student Names or Identifiers
1. Select a class to which the student belongs. 

Note: If you have a class session running, you must end it to select 
the class. 

2. Click the student you want to edit.

3. Click Class > Edit Student, or click .

The Student Properties dialog box opens.
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4. Click the field of the name or identifier you want to change.

5. Make the necessary changes.

6. Repeat steps 4 and 5 for any other names or identifiers you want to 
change.

7. Click OK.

Moving Students to Another Class
If any of your students move to a different class, you can move them 
within the TI-Nspire™ software as well.

Note: You cannot move students who are logged in to the TI-Nspire™ 
Navigator™ network.

Note: You can access many of the student account items by right-clicking 
the student and choosing an action from the menu.

Moving a Student to Another Class
1. Select a class to which the student belongs. 

Note: If you have a class session running, you must end it to move 
the student. 

2. Click the student you want to move. 

3. Click Edit > Cut or click .

The software removes the student from the class and moves the 
student account information to the Clipboard.
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4. From the Class Session list, select the class where you want to move 
the student.

5. Click Edit > Paste or click .

The software moves the student to the selected class.

Copying Students to Another Class
When you have students in more than one of your classes, you may find 
it convenient to copy them from one class to another. Copying students 
saves you the time of entering all of their information again.

Note: You cannot copy students who are logged in to the TI-Nspire™ 
Navigator™ network.

Note: You can access many of the student account items by right-clicking 
the student and choosing an action from the menu.

Copying a Student to Another Class
1. Select a class to which the student belongs. 

Note: If you have a class session running, you must end it to select 
the class. 

2. Click the student you want to copy.

3. Click Edit > Copy or click .

The software copies the student to the Clipboard.

4. From the Current Class dropdown list, select the class to which you 
want to copy the student.

5. Click Edit > Paste or click .

The software copies the student to the selected class.

Exploring the Class Record
From the Class Record, you can open a document in the Review 
Workspace; save a document to the Portfolio Workspace; collect files 
from the Class Record Workspace; send and delete files using the toolbar; 
and view document properties in Record Item Properties for all 
TI-Nspire™ documents, except Quick Poll files.
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À File action. The icons indicate the status of a file.

•  Sent to class

•  Collected from class

•  Saved to portfolio

•  Redistributed to class

•  Quick Poll

•  Unprompted

•  Deleted

Á File name. The names of files used in this class.
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Sending Files to a Class
You can send files and folders to your whole class, members of the class 
currently logged in, or to individual students. Class must be in session for 
you to send the files. 

When you send a file to the whole class, all students currently logged in 
will receive the file immediately. Students not logged in will receive the 
file when they log in.

Notes:

• Only TI-Nspire™ (.tns), PublishView™ (.tnsp), LearningCheck™ (.edc), 
and CABRI™ (.fig) file types open in the TI-Nspire™ software.

• File types .edc and .fig are converted to .tns files when they are sent 
to the class.

• Other file types (if supported) such as images, word processing, or 
spreadsheet files, open in the application the operating system has 
associated with the file type.

1. Click Tools > Send to class or click .

The Select file(s) to send dialog box opens.

Â Status. The progress of an action. For example, "23 of 25" 
indicates that 23 out of 25 students have received a file.

Ã
Menu options. Click  for quick access to certain menu items. 
This icon gives you the same options as a right-click.
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2. Click the Files tab to choose files, or click the Folders tab to choose 
folders.

Note: You can send only files or folders, not a combination of files 
and folders. 

• TI-Nspire™ Navigator™ Teacher Software for handhelds 
transfers only .tns files.

• TI-Nspire™ Navigator™ Teacher Software for network 
computers transfers all files.

3. To choose the files or folders you want to send, do one of the 
following:

• Navigate to the file or folder you want to send and click it. To 
select multiple files or folders, press and hold the Ctrl key 
(Mac®: “) while clicking each file name.

• Type the name of the file or folder in the File name or Folder 
name box. Folder names may use alphanumeric characters. You 
can enter slashes ( / and \ ), but double slashes ( // and \\ ) and 
some special characters (? | : * " " < > | ) are not allowed. 

Note: You can also drag files from a file browser window to the Class 
Record to send files.

4. Click Next.

The Select individual(s) dialog box opens.
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5. Select the student(s) to whom you want to send the file:

• To send the file to the whole class, click Class . To send the 
file only to class members who are currently logged in, select the 
Logged in only check box.

• To send the file to an individual student, click Individuals , 
and then click the student.

Note: If you had any students selected in the classroom area, the 
software already has them selected.

• Use the Send to handheld folder drop-down list to choose from 
the current class folder, the top level folder on the handheld, or 
the last 10 folders that files were sent to. (Available only on 
TI-Nspire™ software that supports handhelds.)

– You can also enter a folder name path in the drop-down list.

6. Click Finish.

The file transfer appears in the Class Record.

Sending Missing Files
The Send Missing function becomes active after you have completed the 
original transfer. This function resends files to only those students who 
were not logged in or targeted for the original transfer.
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1. From the Class Record, select the send action of file that was sent to 
class.

Note: The send action cannot be active.

2. Click File > Send Missing.

Redistributing Selected Files to Class
The Redistribute Selected to Class function allows you to review, modify 
and send selected assignments back to your students.

1. From the Class Record, select the collect action of the modified 
original file or files.

2. Click File > Redistribute Selected to Class.

Note: It will only send files back to student’s collected from.

Collecting Files from Students
You can collect any previously sent files located in student class folders by 
using the Class Record. You can also collect new files from students by 
typing the full file name.

When you collect files from the menu or icon, you have the option of 
deleting the collected files from student class folders.

Note: If a student deleted a file, renamed a file, or stored it in another 
location, the file cannot be collected.

To collect files, class must be in session. If any students are not logged in, 
files you collect are automatically transferred when they log in.

Collecting Files from the Class Record
1. From the Class Record, choose the file or files that have been sent to 

class.
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2. Click  next to any of the highlighted files and choose Collect 
Selected from Class.

The file transfer appears in the Class Record.

Collecting Files from the Menu or Icon

1. Click Tools > Collect from Class or click .

The Select file(s) to collect dialog box opens.

2. To choose the files or folders you want to collect, do one of the 
following:

• Click Recent Files and navigate to the file you want to collect 
and click it. To select multiple files or folders, press and hold the 
Ctrl key (Mac®: “) while clicking each file name.

• Click Enter Filename and type the name of the file in the File 
name box, and then click Add.

3. Click Next.

The Select individual(s) dialog box opens.
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4. Select the student(s) from whom you want to collect the file:

• To collect the file from the whole class, click Class . To collect 
the file only from class members who are currently logged in, 
select the Logged in only check box.

• To collect the file from an individual student, click 

Individuals , and then click the student.

Note: If you had any students selected in the classroom area, the 
software already has them selected.

5. If you want to remove the file from student handhelds after you 
collect it, select the check box next to the option to delete the file 
after it is collected. (Available only on TI-Nspire™ software that 
supports handhelds.)

6. Click Finish.

The collected file appears in the Class Record.

Collecting Missing Files
The Collect Missing function becomes active for files that have not been 
received from students.

1. From the Class Record, select the collect action of file that was sent 
to class.
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2. Click File > Collect Missing.

Note: The collection action cannot be active.

Managing Unprompted Actions
When a student logged into a class session sends you a file outside of a 
collection, an Unprompted action is created.

These files, which are stored in a database, are shown in the Class Record 
until they are removed. 

Reviewing and Opening Unprompted Actions
Unprompted actions are named "Unprompted" followed by the month 
and date. Each class session contains all .tns and .tnsp files sent from 
students in one Unprompted folder. 

The latest Unprompted action appears at the top of the Class Record for 
the most recent files sent by a student during a class session. During the 
next class session, more recent Unprompted actions appear in the Class 
Record above the previous action.

To open the Unprompted action:

1. Double-click the action or right-click and choose Record Item 
Properties.

The Unprompted dialog box opens. By default, no items in the 
Unprompted action are selected.

2. In the Unprompted dialog box, you can view one or more items, save 
the items to the Portfolio Workspace, remove the items, export the 
items to another file location, or do nothing.

Viewing Items in an Unprompted Action
1. From the Unprompted dialog box, select the check box to the left of 

the item(s) you want to view.

Note: You can also click the View icon beside an item to quickly 
access the item.

2. Click View.

The items open as read-only files.
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Removing Individual Items from an Unprompted Action
Unprompted actions remain in the Class Record until you remove them. 
Even if you have exported or saved items, its Unprompted action 
continues to show until you remove it. To remove items from an 
Unprompted action:

1. In the Class Record, double-click the Unprompted action to open it.

2. From the Unprompted dialog box, select the check box to the left of 
the item(s) you want to remove.

3. Click Remove.

Exporting Unprompted Action Items
You can export items from the database to the file system. To export 
items from an Unprompted action:

1. In the Class Record, double-click the Unprompted action to open it.

2. Select the files you want to export.

3. Click Export.

A file browser opens. 

4. Select the location for the export.

5. Click Select Folder.

Saving Files to a Portfolio Record
You can save collected and unprompted files to a Portfolio record.

1. From the Class Record, select the files.

2. Click  and select Save selected to Portfolio. 

The Save to Portfolio dialog box opens.

3. Select to save the files to a new Portfolio column or add them to an 
existing Portfolio column.

• To add the files to a new Portfolio column, click Add as new 
portfolio column and type the name for the new Portfolio 
column.

• To save the files to an existing Portfolio column, click Add to 
existing portfolio column and select the column name you 
want from the drop-down list.
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4. Click Save.

Note: The files you saved in the Portfolio Workspace are shown in 
the Class Record until you remove them using the Remove command.

Deleting Files from Class Folders
When necessary, you can delete files from student class folders. You can 
delete files that were sent to the class or collected from the class. Class 
must be in session for you to delete files.

Note: Deleting a file only removes the specified file from the class folder. 
If the student saved a copy with another name, or copied the file to 
another location, the student still has access to the file.

1. Click Tools > Delete from class or click .

The Select file(s) to delete dialog box opens.

2. To choose the files you want to delete, do one of the following:

• Click Recent Files and navigate to the file you want to delete 
and click it. To select multiple files or folders, press and hold the 
Ctrl key (Mac®: “) while clicking each file name.

• Click Enter Filename and type the name of the file in the File 
name box, and then click Add.

3. Click Next.

The Select individual(s) dialog box opens.
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4. Select the student(s) whose files you want to delete.

• To delete the file from the whole class, click Class . To delete 
the file only from class members who are currently logged in, 
select the Logged in only check box.

• To delete the file from an individual student, click 

Individuals , and then click the student name.

Note: If you had any students selected in the classroom area, the 
software already has them selected.

5. Click Finish.

The file deletion appears in the Class Record.

Checking the Status of File Transfers
When you send, collect, or delete files, you may want to check to see 
which of your students have received or sent their files.

8 In the Class Record, click the file whose status you want to check.

In the classroom area, the software indicates the status of students as 
follows:

•  A green background indicates that students have 
sent/received/deleted the file.

•  A yellow background indicates that students received the 
collect or delete action, but they do not have the file in their 
class folder.

•  A red background indicates that students have not yet 
sent/received/deleted the file.

Note: You can also see the file transfer status in the file’s Properties 
dialog box. 

Canceling File Transfers
If you change your mind about a file transfer, you can cancel the transfer 
in the Class Record. Canceling file transfers stops the software from 
transferring more files. Any files that transfer before you cancel remain 
in student class folders.

1. In the Class Record, click the file whose transfer you want to cancel.
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2. Click Edit > Remove from Class Record.

The software asks if you are sure you want to remove the action.

3. Click Remove.

The software stops the file transfer and removes the file from the 
Class Record list.

Viewing File Properties
Each file that you send or collect has a set of properties that you can 
view, except for Quick Poll files. File properties include name, size, date 
sent, and status. You can view the file properties at any time.

1. Select the file in the Class Record. 

2. Right-click the file name and select Record Item Properties.

The Statistics Properties dialog box opens showing the file 
properties.

 

Resetting Student Passwords
Because the TI-Nspire™ software maintains the privacy of student 
passwords, you cannot retrieve passwords for your students if they forget 
them. However, you can reset student passwords. You can reset 
passwords for all of the students in a class or for individual students.

Note: You cannot reset the passwords of students who are currently 
logged in to the TI-Nspire™ Navigator™ network.
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Resetting Passwords for all Students in a Class
1. Select the class. 

Note: Student(s) must be selected to perform a successful reset of 
the password.

2. Click Class > Reset Student Password(s).

The Confirm Reset Student Passwords dialog box opens.

3. Click OK.

4. The next time students log in, instruct them to type a new password.

Resetting Passwords for Individual Students
1. Click the student you want to edit.

2. Click Class > Edit Student, or click , or right-click the student 
name and choose Edit Student from the menu.

The Student Properties dialog box opens.

3. Click the Reset button next to Password.
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4. If you want a student to create their own password, select Student 
Chooses.

—or—

If you want to create a specific password for the student, select the 
blank password entry box and type a new password.

5. Click OK.

The software resets the student’s password.

6. The next time the student logs in:

• If you selected Student Chooses, instruct the student to type a 
password.

• If you created a password for the student, tell the student the 
new password.
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Using Live Presenter

In the TI-Nspire™ Navigator™ Teacher Software, Live Presenter enables 
teachers to project and present actions on a selected handheld in real-
time. Teachers can choose to project their own handheld screen or any 
student’s handheld screen to show work as it is being performed and 
discuss the step-by-step process with the class. During the live 
presentation, you can show the TI-Nspire™ handheld being displayed 
and show the keys as they are pressed by the presenter.

Teachers can also control what appears on the presentation screen: 
student’s name, handheld display, or keypress history. Teachers can also 
record the Live Presenter session and save the file as a movie for later 
use.

While Live Presenter is active, all other student handhelds are unaffected 
by the presentation and can be used.

Before Starting Live Presenter
Live Presenter is accessible from the Class Workspace. To use Live 
Presenter:

• Ensure student handhelds are connected.

• Begin a class.

• Ensure students are logged in.

Starting Live Presenter
Make sure the student selected to be the presenter is logged into an 
active class session. Although only one person can present at a time, you 
can select anyone to present as long as they are logged in and the class 
session is active.

8 From the Class Workspace, select a student in the class, and then click 
Tools > Live Presenter.

8 To present the teacher handheld, ensure you are logged in, and then 
click Tools > Live Presenter.

Note: If you have not set teacher preferences, go to File > Teacher 
Preferences. For more information, see the handheld guidebooks on 
education.ti.com/guides.

Starting Live Presenter from Class Screen Capture Window
You can also start Live Presenter from the Class Screen Capture window:
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1. From the Class Workspace, click , and then click Capture Class.

The Select Individual(s) dialog box opens.

2. Check Logged in only to display all students currently logged in.

Note: If you selected a logged in student in the Class Workspace, 
that student’s name is highlighted in the Select Individual(s) dialog 

box. To select all students in the class, click .

3. Click OK.

The Class Screen Capture dialog box opens.

4. Select a student who is logged in, and then click .

The Class Screen Capture window opens in Live Presenter mode. By 
default, the window opens in full-screen view. Use the minimize and 
maximize buttons in the upper right corner to adjust the size of the 
window.
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À Menu bar. Only options applicable to Live Presenter are available 
from the File menu and the View menu:

• Click File > Close to close Live Presenter.

• Click Edit > Copy to copy the keys in the Keypress History pane. 

—or—

Press Ctrl + C.

Mac®: “ + C

• Click View > Show Student Names to hide student names if 
they are showing or show student names if they are hidden.

• Click View > Live Presenter to access options for working with 
Live Presenter.

Note: Other menu options are enabled when viewing captured 
screens.

Á Toolbar. Only tools applicable to Live Presenter are selectable. In 
Live Presenter you can:

• Click  to stop Live Presenter.

• Select  to show student names or clear to hide 
student names.
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Hiding and Showing Student Names
If showing, the student name is shown under the handheld screen in Live 
Presenter. 

Â Handheld pane. Displays the presenter’s handheld type. As the 
presenter presses keys on their handheld, the keys in the display 
turn red so viewers can follow along. The last key pressed remains 
highlighted until a different key is pressed.

Note: In Live Presenter, the handheld pane does not function like 
the TI-SmartView™ emulator. You cannot use a mouse to click or 
press keys—the presenter must press the keys on their handheld.

Ã Display pane. Displays the presenter’s handheld screen. If you 
selected to show the student name, the name is shown under the 
screen.

Ä View options: 

• Click  to record the session. Click  to stop the recording.

• Select  to show the handheld pane. Clear to hide 
the handheld pane. When you hide the handheld, the Keypress 
History is shown in this pane.

• Select  to show the Keypress History pane. 
Clear to hide the Keypress History pane.

Note: To view only the handheld screen, clear  and 

.

Å Keypress History pane. As the presenter presses keys on their 
handheld, the keypress sequence is shown left to right.

Note: If the handheld is hidden, the keys pressed are shown in the 
left pane and this pane closes.
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The student name is shown in the same format selected in Capture Class. 
If you select to show or hide student names in Capture Class, the student 
name will be shown or hidden when you start Live Presenter.

To hide the student name in Live Presenter:

8 Clear . 

The student name is hidden. 

Hiding and Showing the Presenter Handheld
By default, the handheld is shown when you start Live Presenter. 
Showing the handheld enables the class to see which keys are pressed 
during the presentation. When the handheld is shown:

• The key turns red in the display so that the class can follow along 
when the presenter presses a key.

• The last key pressed remains highlighted until a different key is 
pressed.

• The keys on the handheld display cannot be pressed or clicked. This 
visual display only shows what the presenter presses on their 
handheld.

Hiding the Handheld Display
8 To hide the handheld, clear Show Handheld in the View Options bar.

student name is 
shown here
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The handheld is hidden and the Keypress History is shown in the left 
pane. 

Showing the Handheld
8 If the handheld is hidden, click Show Handheld to show the 

presenter’s handheld in the left pane.

The handheld is displayed in the left pane and the Keypress History 
pane opens under the handheld screen if selected.

Viewing Keypress History
By default, the Keypress History pane is open under the handheld screen 
when you start Live Presenter. 

• As keys are pressed during the live presentation, they appear in the 
Keypress History pane. 

• As keys are pressed, they are displayed from left-to-right, and then 
top-to-bottom.

• If the presenter presses the same key more than once, each repeated 
key press is shown in the Keypress History pane. If the presenter 
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presses and holds one key (as when moving the cursor), the key is 
recorded only one time. 

• You can copy the keys captured in the Keypress History pane to the 
Clipboard, and then paste the images into another document. You 
can also clear the Keypress History pane. (Students are not able to do 
this.) 

• During lengthy live presentation sessions, the keys pressed may 
expand beyond the display area. When this happens, a scroll bar 
appears so you can review all keys pressed during the session.

Hiding Keypress History
8 To hide the Keypress History pane, clear Show Keypress History. 

The Keypress History pane closes.

Showing Keypress History
8 If the Keypress History pane is hidden, check Show Keypress 

History.

• If the handheld is shown, the Keypress History pane opens 
below the presenter’s handheld screen.
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• If the handheld is hidden, the Keypress History is displayed in the 
pane to the left of the presenter’s handheld screen.

Copying Keypress History
You can copy the keys captured in the Keypress History pane to the 
Clipboard then paste the images of the keys into a Microsoft® Word 
document or PowerPoint presentation.

1. In the Keypress History pane, select the keys you want to copy.

2. Click Edit > Copy.

—or—

Press Ctrl + C.

Mac®: “ + C

Images of the keys are copied to the Clipboard.

Clearing Keypress History
To clear the Keypress History pane:

8 Click View > Live Presenter > Clear Keypress History.

The keys displayed in the Keypress History pane are removed.

Showing the Handheld Screen Only
To show only the presenter’s handheld screen during the Live Presenter 
session:

8 Clear the Show Handheld and the Show Keypress History options. 

The Handheld and Keypress History panes close and the handheld 
screen is displayed in the window.
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Recording the Live Presentation
You can record and save the live presentation as a movie (.avi file). 
Movies are a useful way to present demonstrations to a class, provide 
additional tutoring for difficult concepts, or provide a way for students 
who missed the class to review the lesson. When you record the 
presentation, only the handheld screen is captured. The handheld display 
and the keys pressed are not recorded. When you save a recorded 
presentation, the file is saved with the Audio Video Interleave (.avi) file 
extension.

Starting the Recording

8 Click .

—or—

Click View > Live Presenter > Start Recording.

Recording begins. When clicked, the button changes to Stop 
Recording. All of the presenter’s work on the handheld screen is 
recorded until you stop the recording.

Stopping and Saving the Recording
Complete the following steps to stop the recording and save the movie 
file.

1. Click . 
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—or—

Click View > Live Presenter > Stop Recording.

The Save dialog box opens. The default name for the movie is 
“presentation” and the default save location is the class folder for 
the class that is active. You can change both the file name and the 
storage location.

Note: If you don’t want to save the recording, click Cancel.

2. Navigate to the folder where you want to save the .avi file if 
different from the default folder.

3. Type a new name for the file.

4. Click Save.

The file is saved in the designated folder.

Playing and Sharing the Recording
Once the recording is saved as an .avi file, you can play it on your 
computer. You can also send the file to others as an email attachment.

To play the recording on your computer:

1. Using your file browser, navigate to the folder where you saved the 
presentation (.avi) file.

2. Double-click the .avi file name.

Your default media player opens and the movie plays. 

Note: If the .avi file format is not compatible with your default 
player, an error message is displayed.
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Stopping Live Presenter

8 To stop Live Presenter, click .

—or—

Click View > Live Presenter > Stop Presenter. 

The presentation window closes and the Class Workspace is 
displayed. The class is still active. When you are ready to end the 

class, click .
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Using Question in the Teacher Software

The Question application in the Teacher Software allows you to author 
multiple choice, open response, equation, expression, coordinate points, 
lists, image, and chemistry questions.

Although students cannot author questions, they can open documents 
containing questions, answer these questions, and, in Self-Check mode, 
check their work.

The Question application is located on the Insert menu in the Documents 
Workspace.

À Insert menu. Click Insert and select Question to add a question, 
or select Image to add an image to a question.

Á Document Tools. Click this icon to open the toolbox pane.

Â Question tool. Provides a menu of tools available for working 
with the Question application.

Ã Configuration tool. Allows you to set certain properties for each 
question you insert.

Ä Question area. This is where you type questions and view student 
responses.
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Understanding the Question Tools
When you add a question, the Question application opens. If necessary, 

click Document Tools  to open the tools menu.

Note: The Teacher Tool Palette is not available to students.

Using the Insert Menu
The Insert menu in the Document Tools lets you add math expression 

boxes  and chemical equation boxes  to the Question area, 
Suggested Response area, or Correct Answer area of some question 
types. When you are in question types that allow math expressions or 
chemical equations, place your cursor where you want to insert the box, 
and then follow these steps.

1. Open the Question tool.

2. Click Insert > Expression Box or Chem Box.

The software inserts a blank box where your cursor is positioned.

Å Formatting toolbar. Allows you to apply formatting to text.

Tool name Tool function

Clear Answers Lets teachers or students clear the 
answers in the current question or in the 
document.

Check Answer If you select Self-Check as the document 
type in the Question Properties dialog 
box, students can check their answer to 
the question. 

Insert Lets teachers or students insert an 
expression box or chemical equation box 
into the question or answer.

Format Lets teachers or students format the 
selected text as subscript or superscript. 
(The chemical equation box uses its own 
formatting tool, so this Format tool does 
not work in the chemical equation box.)

Teacher Tool Palette Lets you add copyright information and 
set the document type as Self-Check or 
Exam.
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3. Type the desired math expression or chemical equation, and then 
click outside of the box to continue typing text.

Using the Teacher Tool Palette
The Teacher Tool Palette allows you to add copyright information and set 
the document type as Self-Check or Exam.

Adding Copyright Information
Use the Question Properties dialog box to add copyright information to 
the current question.

1. Click the Teacher Tool Palette icon  > Question Properties.

The Question Properties dialog box opens.

2. Type the author’s name and move to the Copyright field.

Note: TI-Nspire™ software allows you to use questions from more 
than one author in the same document. Therefore, the information 
that you enter about the author and copyright is not global. You 
must enter the relevant information for each different question.

3. Select whether the question is public domain or has a copyright 
assigned to it and move to the Year field.

4. Type the year the question was copyrighted and move to the Owner 
field. If you are copyrighting a new question, type the current year 
(example: 2012).

5. Type the name of the person or entity that owns the copyright.

6. Click OK.
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Setting Self-Check and Exam Document Types
When you define a document as Self-Check or Exam, all of the questions 
in that document will be either Self-Check or Exam.

• When you define the document type as Self-Check, students can 
check the answers against the answers provided by the teacher.

• In Exam mode, when you enter a suggested response to a question, 
students cannot check the answers. You can use Exam mode to 
automatically grade student responses.

1. Click the Teacher Tool Palette icon  > Question Properties.

2. In the Document Type field, click Exam or Self-Check.

3. Click OK.

Understanding the Configuration Tool
The Configuration tool allows you to set properties specific to each 
question type you insert. Properties include the response type, the 
number of responses (if applicable), the correct answer, and other 
options.

For example, you can specify the correct answer to a question, and set 
the scale, axes, and grid on a graph. You can add a 2D math expression 
on the question types that contain a Correct Answer field. 

Each question type has a unique set of options. The options are 
explained for each question type in the Adding Questions section.

The configuration settings are retained when you copy and paste a 
question from one document to another.

Adding Configuration Options
1. Click the down arrow on the Configuration bar in the Documents 

Toolbox to open the Configuration tool.

À Click to open the Configuration tool.
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2. Click the down arrow next to the choices you want to edit, and type 
the applicable text.

3. Close the Configuration panel. The options you chose are saved 
when you save the document.

Formatting Text and Objects
Use the text formatting tools to format text in sections of questions that 
allow text input.

The formatting toolbar also contains the Document Tools  icon to 
provide easy access to the Question and Configuration tools.

For more information on formatting text and objects, see Working with 
TI-Nspire™ Documents.

Adding Images to Questions
You can add images to the Question Text Area of most questions. On 
some question types, you can add an image in the Student Answer or 
Suggested Response Area of a question.

Adding images provides a visual aid to help explain the context of the 
question, or as a background on a graph. 

Choose the image from a set of images on your computer, or copy and 
paste an image from a different application into the Question Text Area. 
For more information, see Working with Images. 

Image Types Available
The following file types can be used in the Question application:

• .jpg
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• .jpeg

• .bmp

• .png

Note: The transparency feature of .png is not supported. Any 
transparent .png backgrounds will appear as white.

Adding Images Using the Insert Command
1. Click Insert > Image.

The Insert Image dialog box opens.

2. Navigate to the location of the image and select it.

3. Click Open.

The image appears in the question. 

Adding Images Using the Clipboard
To copy an image to the Clipboard from a TI-Nspire™ document, image 
file, or another program, press Ctrl + C (Mac®: “ + C).

To paste the image into the question, press Ctrl + V (Mac®: “ + V).

Adding Questions
You can add the following types of questions:

• Multiple Choice

– Custom

– ABCD

– True/False

– Yes/No

– Always/Sometimes/Never

– Agree/Disagree

– Strongly Agree...Strongly Disagree

• Open response

– Explanation (not auto-graded)

– Text Match (auto-graded)

• Equations and Expressions

– y=

– f(x)=



Using Question in the Teacher Software 251

– Expression

• Coordinate Points and Lists

– (x,y) numerical input

– Drop Point(s)

– List(s)

• Image

– Label 

– Point on

• Chemistry

When you select a question type, a brief explanation of the question is 
displayed at the bottom of the Choose Question Type dialog box.

When you open a question template, the cursor is in the Question text 
area. 
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Adding a Multiple Choice Question
This example shows how to add a custom multiple choice question. A 
custom multiple choice question allows you to specify answers your 
students can select. You can then select one or more responses as correct 
to help you when grading or to help students check questions that are in 
Self-Check mode.

To add a custom multiple-choice question:

1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Click Custom Choice under the Multiple Choice heading.

3. Click Insert.

The Custom Choice template opens with the cursor in the Question 
text area.

Two response options exist in the template by default.

4. Type the question. 

• You can type any combination of text, math expressions, and 
chemical equations in the Question Area and Suggested 
Response area.

• You can add an image in the question text area.

5. Press Enter to add another question line, or press Tab to go to the 
first Correct Answer button.

6. Type the response options. Add an image, if desired.

7. Press Enter to add other response options, and add the response 
text.

• Press Delete to clear or delete a response.
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• Press Backspace to delete an empty response line.

8. Click the option next to a suggested response, if desired.

Note: In Self-Check mode, the student can check their answer 
against the suggested response.

9. Open the Configuration tool. Choose the response type, and click 
the option that corresponds to the correct answer.

Adding an Open Response Question
An open response question prompts the student to write a response. An 
explanation question type allows students to respond without any 
predefined answers. A text match question type allows the teacher to 
specify an answer for the student response. Text match questions are 
automatically graded; open response questions are not automatically 
graded.

This example shows how to add an explanation question.

1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Click Explanation under Open Response.

3. Click Insert.

The Open Response template opens with the cursor in the Question 
text area.

4. Type the question.

• You can type any combination of text, math expressions, and 
chemical equations in the Question Area and Suggested 
Response area.

• You can add an image in the question text area.
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• Press Tab or use the mouse pointer to navigate between fields.

5. Open the Configuration tool. Select the response type as Explanation 
or Text Match, and type the correct answer.

• The Explanation response type allows students to give answers 
that closely match your suggested response.

• The Text Match response type requires students to exactly match 
your suggested response. Select the Ignore Case check box if 
capitalization is not important.

• You can type any combination of text, math expressions, and 
chemical equations in the Correct Answer area.

Adding an Equation Question
An equation question prompts the student to write an equation in the 
form of y= or f(x)=, or to respond with a number or expression.

This example shows how to add a y= question.

1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Select y= under Equations and Expressions.

3. Click Insert.

The equation template opens with the cursor in the Question text 
area.

4. Type the question. 

• You can type any combination of text, math expressions, and 
chemical equations in the Question Area.

• You can add an image in the question text area.

• Press Tab or use the mouse pointer to navigate between fields.
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5. Enter a suggested response, if desired.

6. Press Enter to add other response options, and add the response 
text.

• Press Delete to clear or delete a response.

• Press Backspace to delete an empty response line.

7. Open the Configuration tool to set the number of responses, the 
correct answer, and whether the students should show their work. 
You can also add a graph that will show in the Question area.

• The number of responses can range from 1 to 5.

• The Show your work option includes areas for the students to 
write their starting point, their steps, and their final answer. The 
option to show work is disabled if multiple responses are 
allowed.

• To add a graph in the Question area, check Include a Graph 
Preview. The Question text area splits to show a graph on the 
right.

• When you are in the graph, the Graphs & Geometry toolbox is 
available to allow you to add functions.

Note: Only the teacher can edit the graph. Students can only 
view and zoom the graph.

• Click  to add additional fields for multiple correct answers. 
For example, you might want to accept both y=(x+1)(x+2) and 
y=(x+2)(x+1) as correct answers.
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• Select whether or not to accept equivalent responses as correct.

– If you do not check Accept equivalent responses as 
correct, the student response is marked correct if it is an 
exact text match to one of the accepted responses you 
entered.

– If you do check Accept equivalent responses as correct, 
the student response is marked correct if it is equivalent to 
any accepted response you entered. For example, if you 
typed x+2 as the correct answer, and the student submits 
2+x, this response is equivalent to the accepted response 
and is automatically graded as correct. Spaces, case 
differences, and extra parentheses are ignored when the 
software evaluates student answers. For example, y=2x+1 is 
evaluated the same as Y = 2X + 1.

Adding an Expression Question
An expression question prompts the student to respond with a number 
value or an expression.

1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Click Expression under Equations and Expressions. 

3. Click Insert.

The expression template opens with the cursor in the Question text 
area.

4. Type the question.

• You can type any combination of text, math expressions, and 
chemical equations in the Question area.
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• You can add an image in the Question area.

5. In the Expression type response, enter a starting expression, if 
desired. The student sees the starting expression.

6. Enter a suggested response, if desired.

• If you set the response type as Number, the response fields are 
math boxes and accept only number values such as 1/3.

• If you set the response type as Expression, the response fields are 
expression boxes and accept only expression inputs such as 
2(3+5).

7. Open the Configuration tool to set the response type as Number or 
Expression, set whether or not the students should show their work, 
and enter a correct answer. You can also set a tolerance for Number 
types, or equivalent responses for Expression types.

• The Show your work option includes areas for the students to 
write their starting point, their steps, and their final answer.

• In the Number type response, enter the accepted numerical 
response and the tolerance. Student responses are marked 
correct if they fall within the tolerance interval you specify.

• Specifying a tolerance of zero indicates you are looking for the 
exact number answer. Not specifying a tolerance is the same as 
specifying a tolerance of zero.

• Student answers are considered correct if they are numerically 
equivalent to the correct answer. Spaces, case differences, and 
extra parentheses are ignored when the software evaluates 
student answers.
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• In the Expression type response, you can add additional fields 
(up to 10) for multiple correct answers.

• In the Expression type response, click  to open the Templates 
and Symbols catalog that allows you to enter 2D math 
expressions.

• In the Expression type response, you can select whether or not to 
accept equivalent responses as correct.

– If you do not check Accept equivalent responses as 
correct, the student response is marked correct if it is an 
exact text match to one of the accepted responses you 
entered.

– If you do check Accept equivalent responses as correct, 
the student response is marked correct if it is equivalent to 
any accepted response you entered. For example, if you 
typed x+2 as the correct answer, and the student submits 
2+x, this response is equivalent to the accepted response 
and is automatically graded as correct. Spaces, case 
differences, and extra parentheses are ignored when the 
software evaluates student answers. For example, x+2 is 
evaluated the same as X + 2.

Important: Students can enter the starting expression you 
supply and have this response automatically graded as 

correct. For example, if you ask students to factor x2-7x+12 
and stipulate the correct answer is (x-3)(x-4), the student can 

submit a response of x2-7x+12. This response is 
automatically graded as correct because it is equivalent to 
the accepted answer. You must manually mark this student 
response as incorrect in either the Review or Portfolio 
Workspaces. See the chapters for those workspaces for more 
information on marking and grading responses.

Adding an (x,y) Numerical Input Question
An (x,y) numerical input question prompts the student to respond with a 
coordinate.
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1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Click (x,y) Numerical Input under Coordinate Points & Lists. 

3. Click Insert.

The template opens with the cursor in the Question text area.

4. Type the question.

• You can type any combination of text, math expressions, and 
chemical equations in the Question area.

• You can add an image in the Question area.

• Press Tab or use the mouse pointer to navigate between fields.

5. Enter a suggested response, if desired.

• The response fields are expression boxes and accept only 
expression inputs.

6. Press Enter to add other response options (up to five), and add the 
response text.

• Press Delete to clear or delete a response.

• Press Backspace to delete an empty response line.

7. Open the Configuration tool to set the number of points, add a 
graph preview, enter a correct answer, and set equivalent responses 
as correct.
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• The number of points can range from 1 to 5.

• Click  to add additional fields for multiple correct answers. 
You can type any combination of text, math expressions, and 
chemical equations in the correct answer fields.

• Click  to open the Templates and Symbols catalog that allows 
you to enter 2D math expressions.

• To add a graph in the Question area, select Include a Graph 
Preview. The Question text area splits to show a graph on the 
right and the student prompt area on the left. To change the 
location of the graph, click the down arrow next to Prompt 
Location and choose the desired location for the graph in the 
student prompt area.

• When you are in the graph, the Graphs & Geometry tools are 
available to allow you to add functions.

Note: Only the teacher can edit the graph. Students can only 
view and zoom the graph.

• Select whether or not to accept equivalent responses as correct.

– If you do not check Accept equivalent responses as 
correct, the student response is marked correct if it is an 
exact text match to one of the accepted responses you 
entered.
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– If you do check Accept equivalent responses as correct, 
the student response is marked correct if it is equivalent to 
any accepted response you entered. For example, if you 
typed (-0.5, .75) as the correct answer, and the student 
submits (-.5, .75) or (-1/2, 3/4), and so forth, the student 
response is equivalent to the accepted response and is 
automatically graded as correct.

Adding a Drop Points Question
A drop points question inserts a graph and prompts the student to drop 
points on the graph in response to your question.

1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Select Drop Points under Coordinate Points & Lists.

3. Click Insert.

The drop points template opens with the cursor in the Question text 
area.

The graph is in the Student answer area.

• When you are in the graph, the Graphs & Geometry tools are 
available to allow you to add functions.

Note: Only the teacher can edit the graph. Students can only 
view, zoom, or place points on the graph.

4. Type the question.

• You can type any combination of text, math expressions, and 
chemical equations in the Question area.

• You can add an image in the Question Area.
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• Press Tab or use the mouse pointer to navigate between fields.

5. Open the Configuration tool to set the number of points, hide or 
show coordinates, and enter a correct answer.

• The number of points can range from 1 to 5.

• Showing coordinates is turned off by default. Select the check 
box to display coordinate labels on the graph.

• Click  to add additional fields for multiple correct answers. 
You can type any combination of text, math expressions, and 
chemical equations in the correct answer fields.

• Click  to open the Templates and Symbols catalog that allows 
you to enter 2D math expressions.

Adding a Lists Question
A Lists question inserts a list and prompts students to enter data in the 
lists in response to your question.

1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Select List(s) under the Coordinate Points & Lists question from the 
Choose Question Type dialog box.

3. Click Insert.

The List template opens with the cursor in the Question text area.

4. Type the question.
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• You can add columns or rows, change the name of the lists, and 
input data in the lists, using the same functions allowed in the 
Lists & Spreadsheet application.

5. Enter initial data in the lists, if desired.

6. Open the Configuration tool to set the number of lists for the 
student responses.

• The number of lists can range from 1 to 5. 

• Lists must have names. The default names are List1, List2, and 
so forth. 

Adding an Image: Label Question
An Image: Label question inserts an image. You can add blank fields to 
the image and have students fill in the blanks in response to your 
question.

1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Select Label under Image.

3. Click Insert.

The Image: Label template opens with a blank background and one 
label. This is where the image for the question is inserted.

4. Type the question.

• You can type any combination of text, math expressions, and 
chemical equations in the Question area.

• Press Tab or use the mouse pointer to navigate between fields.

5. Insert an image in the bottom portion of the question template.
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6. Open the Configuration tool to set the number of responses and to 
enter answers for each label.

• The number of responses determines the number of labels on 
the image. Each new response gives the label a unique identifier, 
such as A, B, C, and so forth. Drag the labels to the desired 
location on the image.

Note: If you set more than 26 responses, the labels are identified 
with numbers, starting with 1. You can insert a maximum of 35 
labels.

• In the answers area, click  to open the Templates and 
Symbols catalog that allows you to enter 2D math expressions.

• If the label text is too large to fit in the default label size, grab 
and drag the borders of the label to resize it.

7. Type a suggested response in the labels, if desired. Select the Ignore 
case check box if capitalization is not important.

• You can type any combination of text, math expressions, and 
chemical equations in the response area.

• As you type the suggested response, a ghosted image of your 
answer appears in the respective label on the image. If the 
suggested response is too large for the default label size, grab 
and drag the borders of the label to resize it.
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Adding an Image: Point on Question
An Image: Point on question inserts an image. Add check boxes to the 
image and have students place a check mark in the correct boxes in 
response to your question.

1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Select Point on under Image.

3. Click Insert.

The Image: Point on template opens with a blank background and 
one point. This is where the image for the question is inserted.

4. Type the question.

• You can type any combination of text, math expressions, and 
chemical equations in the Question area.

• Press Tab or use the mouse pointer to navigate between fields.

5. Open the Configuration tool to set the response type, number of 
responses, and correct answer.

• The Response Type makes the point a circle for Single Reponse 
and changes to a square for Multiple Responses to indicate 
students can select more than one box.

• The number of responses determines the number of points on 
the image. Each new response gives the point a unique 
identifier, such as A, B, C, and so forth. Drag the points to the 
desired location on the image.

Note: If you set more than 26 responses, the points are 
identified with numbers, starting with 1. You can insert a 
maximum of 35 points.
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6. Click a point or points as a suggested response, if desired.

Adding a Chemistry Question
When you add a Chemistry question, students respond with a chemical 
formula or equation.

1. Click Insert > Question.

The Choose Question Type dialog box opens.

2. Click Chemistry.

3. Click Insert.

The Chemistry template opens with the cursor in the Question text 
area.

4. Type the question.

• You can type any combination of text, math expressions, and 
chemical equations in the Question area.

• You can add an image in the Question area.

5. Enter a suggested response, if desired.

6. Open the Configuration tool to enter a correct answer.

Click  to add additional fields for multiple correct answers. You 
should enter all possible answers. The software does not evaluate 
equivalency for Chemistry answers.
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Responding to Questions

The teacher may send you several different question types. This section 
shows you how to answer the different question types.

Understanding the Question Toolbar
When you open a document with a question, a toolbar is available with 
four options. Access the toolbar using the following method.

8 In the Documents Toolbox, click .

Handheld: press b.

Types of Questions
There are several types of questions you may be asked. There may be 
variations in a type, but how you answer the question is basically the 
same for each type. 

• Multiple Choice

– Custom

– ABCD

– True/False

– Yes/No

Tool name Tool function

Clear Answers Lets you clear the answers in the current 
question or in the document.

Check Answer If the teacher enabled Self-Check mode for the 
question, click here to view the correct answer. 

Insert Lets you insert a math expression box or 
chemical equation box in your answer.

Format Click this tool to format the selected text in 
your answer as subscript or superscript. (The 
chemical equation box uses its own formatting 
tool, so this Format tool does not work in the 
chemical equation box.)
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– Always/Sometimes/Never

– Agree/Disagree

– Strongly Agree...Strongly Disagree

• Open response

– Explanation (not auto-graded)

– Text Match (auto-graded)

• Equations and Expressions

– y=

– f(x)=

– Expression

• Coordinate Points and Lists

– (x,y) numerical input

– Drop Point(s)

– List(s)

• Image

– Label 

– Point on

• Chemistry

Responding to Quick Poll Questions
When teachers send quick polls during class, the question opens as a new 
document on top of any document you may currently have open. You 
can access other applications to perform calculations, and check or clear 
answers before submitting your answer to the question or quick poll.

Note: On TI-Nspire™ CX or TI-Nspire™ CX CAS handhelds, questions 
appear in color if the teacher applied color when writing the question. 
Although you can see color in the questions you receive, you cannot add 
color to the responses you submit. If you are using a TI-Nspire™ or 
TI-Nspire™ CAS handheld, questions are shown in black and white.
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Accessing Other Applications
If the teacher gives permission, the Quick Poll tool allows you to 
temporarily exit the question to perform calculations or access other 
documents to determine the answer to the question. For example, you 
can access the Scratchpad to perform a calculation, or you can access the 
Lists & Spreadsheet application and copy data from there to a List 
question type. In a List question, you can link to variables from the 
Vernier DataQuest™ or Lists & Spreadsheet applications.

To access other applications while in the Quick Poll screen:

1. Open a new document.

Handheld: Press c to open the Home screen. 

2. Choose an application.

Handheld: To return to the Quick Poll without accessing any 
documents, choose C: Quick Poll.

3. When you are finished, click the Quick Poll icon.

When you respond to a poll, your response is immediately sent to the 
teacher’s computer and teachers can track student responses in real time.

Showing Your Work
The teacher may request you to show work for your response. If so, the 
response area has sections for you to write your starting point, your 
steps, and the final answer.

Responding to Different Question Types
8 For Multiple Choice questions, press Tab to navigate to a response. 

Press Enter to mark a response.

8 For Open Response questions, type a response.

8 For Equation questions, type a response. If a graph is included in a 
question, the graph updates when you press Enter. Any functions 
entered show up on the graph, and the cursor remains in the answer 
box. You cannot manipulate the graph itself.

8 For Expression questions, type a response. If the response type is 
Number, your response must be in the form of a number. If the 
response type is Expression, your response must be in the form of an 
expression. For example, x+1.

8 For Coordinate Points: (x,y) questions, type an answer in the x-field 
box, and press Tab to move to the y-field box. Type an answer. 

If a graph is included with the question, the graph is updated when 
you enter a function and press Enter.
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You can access the Window and Zoom functions while you are 
working on the graph.

8 For Coordinate Points: Drop Points questions, press Tab to move the 
cursor to a point on the graph. Press Enter to drop a point at that 
location.

To delete a point, press Ctrl + Z to undo the action.

8 For Lists questions, press Tab if necessary to move the cursor to the 
first cell of the list. Type an answer, and press Tab to move to the 
next cell. Type an answer.

To link a column to an existing variable, select the column and then 
click var. Click Link To, and then click the variable you want to link 
to.

The behavior in a Lists question closely matches the behavior of the 
Lists & Spreadsheet application, with the following exceptions. In a 
Lists question, you cannot:

• Add, insert, or delete columns.

• Change the header row.

• Enter formulas.

• Switch to Table.

• Create plots.

8 For Chemistry questions, type a response.

8 For Image: Label questions, press Tab to move the cursor to a label 
on the image. Type a response in the label field.

8 For Image: Point on questions, press Tab to move the cursor to a 
point on the image. Press Enter to mark a response.

Checking Answers
If the teacher enables self-check on the question, the Check Answer 
option is available.

1. Click .

Handheld: Press b.

2. Click Check Answer.

Clearing Answers
After you answer a quick poll, you may decide you want to change the 
answer before you submit it. 
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8 Click Menu > Clear Answers > Current Question or Document.

• Current Question clears answers for the active question.

• Document clears answers for all questions contained in the 
active document.

—or—

If you answered the question, you still have time to clear the answer 
before you submit it to your teacher. 

8 Click Clear Answer to clear your answer and try again.

Handheld: Press ~ and choose Clear Answer.

Submitting Responses
To send a final answer to the teacher:

8 Click Submit Response. 

Handheld: Press ~ and choose Submit.

The response is sent to the teacher and the last screen you used is 
displayed. 

Your response appears on the teacher’s computer. Your teacher may have 
set the poll to allow you to submit more than one answer. If so, you can 
continue to respond to the poll and submit answers until the teacher 
stops the poll.
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Polling Students

The Quick Poll tool lets you “poll” your students. A poll is a survey you 
send to students that they immediately receive on their handhelds or 
laptops. After students receive the poll, they can send responses back to 
your computer. Quick Poll is available from all workspaces. As you receive 
student responses, use the Review Workspace to review the responses.

When you click the Quick Poll icon  from any workspace, the 
Documents Workspace opens, and you can start the Quick Poll. Starting 
the Quick Poll opens the Review Workspace. You can switch to any 
workspace while a poll is in progress, but you can only stop the poll from 
the Documents or Review Workspaces.

You can send the following types of questions:

• Multiple Choice

– Custom Choice

– ABCD

– True/False

– Yes/No

– Always/Sometimes/Never

– Agree/Disagree

– Strongly Agree...Strongly Disagree
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• Open response

– Explanation (not auto-graded)

– Text Match (auto-graded)

• Equations and Expressions

– y=

– f(x)=

– Expression

• Coordinate Points and Lists

– (x,y) Numerical Input

– Drop Points

– List(s)

• Image

– Label

– Point on

• Chemistry

When you select a question type, a brief explanation of the question is 
displayed at the bottom of the Choose Question Type dialog box.

Opening the Quick Poll Tool
You can open the Quick Poll tool from any workspace. You can send a 
poll from an existing document, or open a new document to start a poll.

Before you begin, make sure a class is in session. 

1. Click Tools > Quick Poll or click .

The Choose Question Type dialog box opens.



Polling Students 275

2. Select a question type and click Insert.

A new document opens with the question template open and the 
cursor in the Question text area. 

Quick Poll documents are named <Class name, Quick Poll Set#, 
mm-dd.tns>. For example: Algebra1 - Mrs. Smith QP2 10-26.tns. You 
can rename the poll when you save it.
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Note: All Quick Polls for one class session are contained in one tab in 
the Documents Workspace. A new tab is started when the number of 
questions in the poll exceeds 30, or when you start a new class 
session.

Note: For more information about question types and about 
creating and configuring questions, see Using Question in the 
Teacher Software.

Sending a Quick Poll
After you have selected the Quick Poll question, entered the 
information, and selected options, you are ready to send the poll to your 
students.

8 To send the Quick Poll question, click Start Poll .

The poll is immediately sent to students. The Quick Poll interrupts the 
active TI-Nspire™ document, and the poll becomes the active document.

You can stop a poll and restart it at any time.

Using Quick Poll Options
When Quick Poll is active, the Tools > Quick Poll Options menu is 
enabled. Available options differ depending on whether you are using 
software that supports connected handhelds or connected laptops. The 
Allow Document Access option is not available in the TI-Nspire™ 
Navigator™ NC Teacher Software.

• Allow Document Access. Allows you to grant or deny students 
access to the Scratchpad and any documents on their handheld. The 
students may access a document, do some math, and copy the results 
back into the poll. 

Note: If a data collection sensor is attached to the computer or 
handheld during a Quick Poll that does not have Allow Document 
Access turned on, the Quick Poll is dismissed and the data collection 
console becomes active.

• Allow Resubmit. Allows the students to submit their responses 
several times. 

Stopping Polls
You can stop polls at any time. Your students do not need to do anything 
on their handhelds or computers to stop the poll. When you stop a poll, 
the students can no longer submit answers.
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8 To stop a poll, click Stop Poll  .

Note: If you pause a class while a Quick Poll is running, the Quick Poll 
remains on the students’ handhelds, but students are not able to answer 
or submit the poll until you resume the class. Pausing class is not available 
in TI-Nspire™ Navigator™ NC Teacher Software.

Resending Polls
You can resend a poll from the Review Workspace, without switching 
workspaces or starting a new question. 

The software treats the resent poll like a new poll. Students receive a 
new poll on top of the open document on their handheld or laptop.

The data from the poll is treated as new data, and does not overwrite 
any data from the original poll.

8 To resend the same poll you just sent, click Start Poll .

8 To resend a previous poll, click the poll in the page sorter and then 

click Start Poll .

The poll is added to the page sorter in the order it was sent. The page 
sorter indicates it was resent.

Sending Polls to Missing Students
You can send the most recent poll to students who were not logged in 
before the poll was stopped.

Note: The Send to Missing option can only be used with the last poll that 
was sent.
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1. In the page sorter, click the last poll that was sent.

2. Click File > Send to Missing.

The poll is immediately sent to students who were not logged in when 
the poll was sent previously, but are currently logged in.

The data gathered from the missing students is added to the data from 
the last poll.

Saving Polls
You can save Quick Poll results to the Portfolio Workspace while the poll 
is still in progress, or you can save a completed set of Quick Poll 
documents as a .tns file.

You can save to the Portfolio Workspace from either the Class Workspace 
or the Review Workspace.

When you save the results to the Portfolio Workspace, the polls sent in 
one class session are saved in one column.

A new column is started when a poll exceeds 30 questions, or when you 
start a new class session.

8 To save a Quick Poll to the Portfolio Workspace, click File > Save to 
Portfolio.

Note: After the first save, subsequent changes to the poll are 
automatically updated in the Portfolio Workspace until you stop the 
poll.

You can also save a set of Quick Polls as a Master Document (.tns file). A 
Master Document contains information that can be used as the answer 
key for evaluating responses collected from students.

8 To save a Quick Poll as a Master Document, click File > Save Quick 
Poll Set as Document.

Note: After you save as a .tns file, any subsequent changes to the 
poll are not updated in the .tns document.

Viewing Poll Results 
Review Quick Poll results in the Review Workspace. 

Polls sent in one class session are contained in a Quick Poll tab in the 
Review Workspace. Each new question is added as a new problem in the 
page sorter, and the software automatically opens to the last question 
that was sent. A new tab is started when a poll exceeds 30 questions.
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You can view the results as a bar chart, graph, or table. The results 
automatically update as students send their responses, until you stop the 
poll.

The following example shows the poll results listed in a table.

For more information about viewing and sorting poll results, see Using 
the Review Workspace.
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Using the Review Workspace

Use this workspace to review a collected set of documents, manage 
student responses, run live activities, and organize data.

Using the Review Toolbox
The Review toolbox contains tools needed for working with collected 
documents, Question results, and Quick Poll results.

À Review toolbox. Contains the Review Tools, Page Sorter, and 
Student Response tools. Click each icon to access the available tools. 
Options for the selected tool are displayed in the toolbox pane.

Á Data View pane. Shows the data and options from the poll or 
document you have selected in the Review Toolbox. You can switch 
the data view between bar chart, table, and graph (if available). 

The software retains the data view that was set for each question 
when you close and reopen the Review Workspace. All hidden and 
unhidden data, settings in graph view, table view, bar chart view, 
and Show Your Work are retained when you close the Review 
Workspace.

Icon What you can do

Review tools

The Review tools let you organize the response data, 
use graph tools, hide or show responses, and mark 
Question and Quick Poll responses as correct or 
incorrect.
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Exploring the Review Tools

Page sorter

Displays all the problems in a document or Quick Poll, 
all the pages in each problem, and the student 
responses for each question in the document. 

Student pane

Displays the student names and responses in the Data 
View pane.

À Organize. Click ¢ to organize the data in different views.

Á Graph Tools. Click ¢ to access the graph tools when you are in 
coordinate graph view. 

Â Show Selected. Shows selected responses for review in the Data 
View pane.

Ã Hide Selected. Hides selected responses in the Data View pane.

Ä Mark Selected Correct. Select a response from the Data View 
pane and click Mark Selected Correct to mark that response as the 
correct answer. You can mark more than one answer as a correct 
answer.

Å Mark Selected Incorrect. Select a response from the Data View 
pane and click Mark Selected Incorrect to mark that response as an 
incorrect answer. You can mark more than one answer as an 
incorrect answer.

Icon What you can do
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Exploring the Page Sorter
Use the Page Sorter to view student responses to any question in a 
document.

À Click the minus sign (–) to collapse the view. Click the plus sign (+) to 
expand the view and show all the pages in a problem, and all the 
problems in a document.

Á The pages in a problem. Click a page to open it in the Data View 
pane.
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Exploring the Student Pane
Use the Student pane to:

• Display the students to whom the file was sent

• View the students who responded

• View student responses

• Mark responses as correct or incorrect

• Sort the responses by student or response, or by time in Quick Polls

Â Student responses. A student data icon follows each question in 
the document. Click the icon to view the student responses for the 
question in the Data View pane. 

In Quick Polls, the icon shows the number of students who were 
logged in when the poll was started, the number who have 
responded, and the number who have submitted their answer. In 
the example below, nine students received the poll, seven students 
responded to the poll, and no students have submitted their 
answer.

Note: If you send a poll to students who were missing, the numbers 
may change.

Ã Scroll bar. The scroll bar is active when there are too many pages 
to show in the panel.

Ä Page numbers. Click a page number to open the page in the Data 
View pane.
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À Display Student Responses. Select this check box to show the 
responses of each student. Clear the check box to hide the student 
responses.

Á Student, Response, and Time columns. The Time column is 
available only in Quick Poll reviews.

• Click the Student column to list the students in alphabetical 
order. Click again to list in reverse alphabetical order. 

• Click the Response column to list the responses in alphabetical 
or numerical order. Click again to list the responses in reverse 
order.

• To add the Time column in Quick Poll reviews, click the Options 

menu , and then click Time.

• Click the Time column to list the responses in order of the time 
they were answered (first response on top). Click again to list 
the responses with the first response on the bottom.

Â Student names. Lists all students in the class associated with the 
document currently opened for review. The student names are 
displayed as chosen in the Class >Student Name Format menu. 

Student names in red text indicate students who did not receive the 
file or respond to the Quick Poll.
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Ã Responses. Lists all responses next to the student’s name. A 
student may be listed several times if they gave multiple responses. 
The Response column may change if the review document is an 
active Quick Poll or a question document that has not been saved 
yet.

• A response is shown if the student responded.

• The response area is blank if the student did not respond.

• "Responded" is displayed if the student responded and the 
responses are hidden.

• "No Response" is displayed if the student has not yet 
responded to the open question or active Quick Poll.

• "Working" is displayed if the student has modified their 
response to a Quick Poll, but has not submitted it.

Ä Options menu. Click ¤ to open the menu of options you can 
perform on the student responses:

• Display student responses.

• Display student names only.

• Display responses only.

• Display a Time column for Quick Poll results.

• Select all items in the list.

• Show the selected item.

• Hide the selected item.

• Mark one or more responses as correct.

• Mark one or more responses as incorrect.
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Exploring the Data View Pane

Understanding the Data View
The Data View pane displays the question in the open document, as well 
as the responses to that question. You can view live results in the Data 
View pane. The data is updated in real time as students respond to Quick 
Poll and Open Response questions, graph functions, or move points on a 
graph.

The Data View icons allow you to view responses in the Data View pane 
as a bar chart, graph, or table. Each view shows the student responses 
and the frequency of each response.

À Show Correct Answer. Select this check box to display the answer 
you marked as the correct answer in the Data View pane. The 
correct answer is highlighted in green.

Á Responses. Shows the information chosen in the Page Sorter. This 
example shows the responses from a selected Student Response 
icon. You can show or hide responses, and mark responses as correct 
or incorrect.

Â Data View. Click an icon to view the data in different formats: bar 
chart, graph, or table. A "Show Your Work" option is available for 
expression and equation questions.
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The bar chart and table views are available for all question types and 
Quick Poll documents. The graph view is available in equation, 
coordinate points, and list questions. 

Expression and equation questions have an additional "Show Your 
Work" data view available, if you marked the question for students to 
show their work. The "Show Your Work" data view is retained when you 
close and reopen the Review Workspace.

The following examples show the same data displayed in different data 
views.

Click  to view the data in bar chart form.

Click  to view the data in graph form.

When you are in graph view, the Graph Tools are available to allow you 
to work with the graph. The settings in the graph are retained when you 
close and reopen the Review Workspace.
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In the bar chart and graph views, hover your mouse pointer over a 
response to see a list of students who gave that response.

Click  to view the data in table form. 

The table view is available as a frequency table or as a student table.

8 To view data in different table views, click the Organize tool in the 
Review toolbox, and then click Frequency Table or Student Table.

A frequency table shows the responses with the number of times the 
response occurred. Click the Response heading to sort the responses in 
ascending order, descending order, or question order. Click the Frequency 
heading to sort by frequency of response.
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A student table shows the student names with their responses. Click the 
Student heading to sort the responses in ascending or descending 
alphabetical order. Click the Response heading to sort the responses in 
ascending order, descending order, or question order.

The settings for sorting and sizing columns are retained for each 
document when you close and reopen the Review Workspace.

Opening Documents for Review
You can review a document that has been collected from the class, a 
Quick Poll in progress, or a saved Quick Poll. You cannot review a 
document that does not have questions.

When you start a Quick Poll, the software automatically switches to the 
Review Workspace, and you can review the data as the students are 
responding. When you stop and save the poll, you can open it in the 
Review Workspace to review the saved responses.

If this is your first time using the software, the Data View pane may be 
empty. Complete the following steps to open a document for review.

Opening a Document from the Class Workspace
To open a document for review from the Class Workspace:

1. Use the Workspace selector to select the Class Workspace.

2. Right-click a file from the Class Record, and then click Open in 
Review workspace.

The software automatically switches to the Review Workspace with 
the selected document open.

Note: You can open collected documents  that contain 

questions and Quick Polls  for review in the Class Record.
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Opening a Document from the Portfolio Workspace
To open a document for review from the Portfolio Workspace, follow 
these steps:

1. Use the Workspace selector to select the Portfolio Workspace.

2. Right-click a column cell or a cell in a student row, and then click 
Open in Review workspace.

The software automatically switches to the Review Workspace with 
the selected document open.
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Viewing Data
You can view data in the Student pane or in the Data View pane. You can 
choose a student to view their answer, or you can choose an answer to 
view which students gave that answer.

Viewing Data from the Student Pane
8 Click a student name in the Student pane to view that answer in the 

Data View pane. You can select more than one student at a time.

The software highlights the selected student’s answer in blue.

If you switch between bar chart, table, and graph views, the software 
retains the selected information and highlights the responses from the 
selected students.

Note: Since student responses can vary for List questions, the software 
does not show List answers for selected students in the Data View pane.

Viewing Data from the Data View Pane
8 Click a response in the Data View pane to view the students who 

gave that response in the Student pane. You can select more than 
one response at a time.

The software highlights the corresponding student names in blue. 
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If you switch between bar chart, table, and graph views, the software 
retains the selected information and highlights the students who 
answered the selected response.

Note: If Multiple Choice questions have multiple responses, a blue area is 
displayed next to all responses from the selected student. 

Note: For List questions, right-click anywhere in the table view, and then 
click Show Student Column to show student names next to their 
responses.
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Changing the Aspect Ratio
The Review Workspace displays graphs in a question application as they 
appear on the students’ handhelds or computers. At times, the graphs 
may appear stretched, since the graph may have changed the aspect 
ratio to fit on the handheld.

You can select to view the graphs as they come in from students, or you 
can preserve the aspect ratio of the graph as it appeared when it was 
inserted in the question application.

By default, the Review Workspace displays graphs in a question 
application as they appear when the students submit them.

To preserve the aspect ratio of a graph as it appeared when it was 
inserted in the question, follow these steps:

1. View the data in graph view.

2. Right-click on the graph in the Data View pane, and then click Graph 
Tools > Aspect Ratio.

— or —

3. Click  in the Review Toolbox and then click Graph Tools > 
Aspect Ratio.

When the Aspect Ratio box is checked, the aspect ratio is preserved. 
When the box is not checked, the aspect ratio may change.

Organizing Responses 
You can configure a plot list for List questions, organize bar chart data 
and table views, individualize student responses, and organize Multiple 
Choice questions that have multiple responses into separate, group, or 
equivalent responses. 

Configuring a Plot List
The plot list settings let you set different shapes for the different plots to 
help you follow separate lines or responses on a graph.

To set the plot list settings, follow these steps.

1. While in graph view, click Graph Tools in the Review toolbox.
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2. Click Plot List Settings.

The Configure Plot(s) dialog box opens.

3. Click the down arrow next to a shape to choose which list to 
represent (list1, list2, and so forth) for the xList and yList.

Note: You can choose more than one shape for each list.

4. Click OK.

The graph view is updated with the shapes you selected.
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When you change plot list settings in the graph view, and then 
change to bar chart view, the software asks you to choose which lists 
to show in the bar chart. You can choose an individual list, or a list 
for the Category and Frequency.

5. Select the applicable options and click OK.

If you click Cancel, the software shows the bar chart as an individual 
list, using list1 as the default. 

You can configure the plot list at any time while in bar chart view.

Note: To configure the plot list from the bar chart view, click 
Organize in the Review toolbox and click Plot List Settings.

Individualizing Student Responses
You can change the colors of each student response in a graph so you can 
identify the separate responses. This is useful when you are running a live 
activity; you can view the progress of individual students as they graph 
functions, move points on a graph, or respond to Quick Poll questions.

8 To change the color of student responses, click Graph Tools in the 
Review toolbox, and then click Individualize Student Responses.
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The responses are displayed in different colors in the Data View 
pane.

Organizing List Data
In bar chart view, you can organize list data by Frequency, Numeric Value, 
or Alphabetically. 

To organize list data, follow these steps.

1. In bar chart view, click Graph Tools.

2. Select to sort the bars by Frequency, Numeric Value, or 
Alphabetically.

The bar chart view is updated in the Data View pane.

Organizing Bar Chart Data
Organizing by separate responses shows the results for each individual 
response. For example, all of the A responses, all of the Bs, all of the Cs, 
and so forth. Organizing by group responses shows all multiple responses 
from the students. For example, all of the A plus B responses, all of the A 
plus C responses, and so forth.

Organizing by equivalency combines similar results into one bar. For 
example, y=4Mx, y= Mx+4, and y= M(xM4) would all be combined into one 
bar or table row.

By default, Multiple Response questions are displayed as separate 
responses in the bar chart view.
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Settings for organizing by separate or group responses and for 
organizing by equivalency are retained when you close and reopen the 
Review Workspace.

To organize by grouped responses, follow these steps.

1. Click the Organize tool in the Review toolbox.

2. Click Show Student Responses Grouped Together.

The Data View pane shows the grouped responses.

3. To return to the default view, click the Organize tool, and then click 
Show Student Responses Separated. 

The Data View pane shows the data as separate responses.
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Organizing by Equivalency
Organizing by equivalency groups all similar responses together in one 
bar or row. In bar chart view, you can still see separate responses by 
clicking on the bar.

To organize by equivalency, follow these steps.

1. Click the Organize tool in the Review toolbox.

2. Click Group Responses by Equivalence.

The Data View pane shows the grouped responses.

3. To return to the default view, click the Organize tool, and then click 
Group Responses by Exact Matches. 

The Data View pane shows the data as separate responses.

Hiding and Showing Responses
You can hide one or more student responses in the Student pane or in 
the Data View pane. When you hide a response, the corresponding data 
updates, and the Data View pane does not show the hidden data. 
Settings for hiding or showing data are retained when you close and 
reopen the Review Workspace.
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When you hide responses, the following actions occur in the different 
views.

• Bar chart view. The bar chart is updated and re-sorted using the 
current data.

• Table view. The table is updated and re-sorted using the current 
data.

• Graph view. The graph is updated using the current data. Any 
regression that was added is automatically recalculated and the new 
values are displayed.

• Show your work. The selected student’s work is hidden from view.

Hiding Responses from the Student Pane
To hide responses, follow these steps.

1. In the Student pane, select the students whose responses you want 
to hide.

The selected student responses are highlighted in blue in the Data 
View pane.

2. Click the Options menu , and then click Hide Selected, or clear 
the check box next to the student name.

The Data View pane hides the responses of the students you 
selected, and shows the responses of the remaining students.

The student names you selected are displayed in gray text.
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Note: If a response is hidden, click a student name to show the 
response. The response is displayed in blue in the Data View pane. 
All bar chart, table, and graph views are updated with the selected 
data. The response stays in view until you select a different student.

Hiding Responses from the Data View Pane
You can hide responses in the bar chart, graph, or table views. When you 
hide responses, the Data View pane updates the data and does not show 
the hidden responses. In the Student View, student names are displayed 
in gray. In Page Sorter view, the software does not change the documents 
or icons.

To hide responses, follow these steps.

1. In the Data View pane, select the responses you want to hide.

The selected students are highlighted in blue in the Student pane.
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2. Right-click the response and click Hide Selected.

The Data View pane hides the responses you selected, and shows the 
responses of the remaining students.

The student names that correspond with the responses you selected 
are displayed in gray text.

Showing Responses
To show the hidden responses, follow these steps.

1. In the Student pane, select the students whose responses you want 
to show.

2. Click the Options menu , and then click Show Selected.

The student names are displayed in black and student responses are 
shown in the Data View pane.
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Marking Responses as Correct or Incorrect
You can use the Review Workspace to mark selected answers as correct or 
incorrect. If you are reviewing a document with a correct answer already 
marked, you can change the correct answer. In a Multiple Choice 
question with multiple responses, you can add additional correct 
answers.

If the Show Correct Answer box is checked, answers marked as correct 
are highlighted in green.

The software reevaluates the data based on the correct responses, and 
the Data View pane updates the view to reflect the changes.

To mark a response as correct:

8 In the Student pane, right-click a student and click Mark as Correct.

8 In the Data View pane, right-click a response and click Mark 
Selected Correct.

8 In the Data View pane, click a response and click Mark Selected 
Correct in the Review Tools pane.

In Multiple Choice questions with multiple answers, check marks are 
displayed next to the responses. 

8 Click a check mark to mark a response as correct. 

When you mark a response as incorrect, the software removes the green 
highlight.

To mark a response as incorrect:

8 In the Student pane, right-click a student and click Remove as 
Correct.

8 In the Data View pane, right-click a response and click Mark 
Selected Incorrect.

8 In Multiple Choice questions with multiple answers, click the green 
check mark.

Note: If you change an answer to correct or incorrect, any points you 
already manually awarded students for correct or incorrect answers will 
not be changed.

When you mark responses, the following actions occur in the different 
question types.
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The following examples show answers marked as correct in different 
data views.

Question Types Action

Multiple Choice, Single Response

Image: Label, Single Response

Image: Point on, Single Response

Adding a new answer replaces 
the current answer. Removing 
an answer leaves the question 
with no correct answers.

Multiple Choice, Multiple Responses

Image: Label, Multiple Responses

Image: Point on, Multiple Responses

Adding a new answer increases 
the correct answer set. For 
example, an answer of "A and 
B" becomes "A and B and C." 
Removing an answer decreases 
the correct answer set.

Open Response: Explanation

Open Response: Text Match

Equation: f(x) and y=

Coordinate Points

Expression: Variable

Chemical

Adding a new answer increases 
the correct answer set. 
Removing an answer leaves the 
question with no correct 
answers.

Expression: Numerical Adding a new answer, with or 
without tolerance, replaces the 
current answer. Removing an 
answer leaves the question with 
no correct answers.
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Bar chart view, Multiple Choice question with multiple responses and two correct 
answers, organized by Show Student Responses Separate, and no student selected in 
the Student pane.

Bar chart view, Multiple Choice question with multiple responses and two correct 
answers, organized by Show Student Responses Separate, and one student selected in 
the Student pane.

Bar chart view, Multiple Choice question with multiple responses and two correct 
answers, organized by Show Student Responses Grouped Together, and no students 
selected in the Student pane.
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Bar chart view, Multiple Choice question with multiple responses and two correct 
answers, organized by Show Student Responses Grouped Together, and one student 
selected in the Student pane.

Frequency table view, Multiple Choice question with one correct answer, and no 
student selected in the Student pane.

Student table view, Multiple Choice question with one correct answer, and one 
student selected in the Student pane.
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Adding Teacher Data
There may be times you want to add your own data to a graph you are 
reviewing in class. The Graph Tools allow you to add teacher points and 
teacher equations to a graph, and to set the plot list settings and 
individualize student responses.

Teacher data is displayed larger than student data, and in a different 
color.

Graph view, Equation y= question with one correct answer, and no student selected in 
the Student pane.

Graph view, Equation y= question with one correct answer, and one student selected 
in the Student pane.
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When you add teacher data, the software reevaluates the data, and the 
Data View pane updates the view to reflect the changes.

You can hide and show teacher data, but you cannot mark a teacher 
response as correct or incorrect.

Adding Teacher Points
1. Click Graph Tools in the Review toolbox.

2. Click Add Teacher Point.

The Add Teacher Point dialog box opens. 

3. Type your information in the fields. 

Click  to open math templates and symbols that you can add to 
the fields.

4. Click OK.

Your point is displayed on the graph, and the name Teacher is added 
to the list of names in the Student pane.

Note: The teacher may have multiple entries.
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Adding Teacher Equations
1. Click Graph Tools in the Review toolbox.

2. Click Add Teacher Equation.

The Add Teacher Equation dialog box opens. 

3. Type your information in the field. 

Click  to open math templates and symbols that you can add to 
the fields.
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4. Click OK.

Your line is displayed on the graph, and the name Teacher is added 
to the list of names in the Student pane.

Note: The teacher may have multiple entries.

Saving to the Portfolio Workspace
You can save documents that contain questions and Quick Polls to the 
Portfolio Workspace, where you can review and analyze individual 
responses, and assign or change a student’s grade.

When you save Quick Polls to Portfolio, students can continue to submit 
answers to the Quick Poll until you stop the poll. The saved Quick Poll in 
Portfolio automatically updates without you having to save it again.

Note: If you opened the file from the Portfolio Workspace, or if you have 
already saved the file to Portfolio, the software does not ask you for a 
file name. The software saves the file to the Portfolio Workspace with 
the existing file name, and updates any grades you had given students. 
You can go to the Portfolio Workspace and change a grade at any time.

To save a file to the Portfolio Workspace:

1. Click File > Save to Portfolio, or click .

The Save to Portfolio dialog box opens. By default, the name of the 
file is shown in the Portfolio name box. If the file is a Quick Poll you 
have not saved yet, the default name is <Class name, Quick Poll Set#, 
mm-dd.tns>. For example: Algebra1 - Mrs. Smith, QP Set 2, 10-26.tns.

• To add a new Portfolio column, select Add as new portfolio 
column. You can use the existing name or type a new name.
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• To add the file to an existing portfolio column, select Add to 
existing portfolio column. Click the down arrow to select the 
column.

Note: Quick Polls cannot be added to existing columns.

2. Click Save.

The file is saved in the Portfolio Workspace.

Saving Data as a New Document
You can take data collected from students, view it in table form, and save 
it as a Lists & Spreadsheet document. This document can be used as an 
instructional aid or sent to the students for further analysis.

Note: If the data comes from a Lists question, the column titles in the 
Table View are used as the names for the list variables. If the variable 
names are not usable, the software renames them. For instance, if the 
name has a space, the software replaces it with an underscore.

1. To save data to a new Lists & Spreadsheet document, make sure you 
are viewing the data in table view.

2. Right-click anywhere in the table, and then click Send Table to New 
Document.

Note: Hidden data is not sent. If data is sorted, the sort order is 
retained in the new document.

The Lists & Spreadsheet document opens in the Documents 
Workspace.



312 Using the Review Workspace



Using the Portfolio Workspace 313

Using the Portfolio Workspace

Use this workspace to save, review, modify grades, and manage class 
assignments from students.

Exploring the Assignments Pane

À  Assignments pane. Select assignments to view student 
information and scores. You can redistribute, rename, or remove an 
assignment.

Á Work area. Lists the students in the selected class and shows the 
scores received for each assignment. Enables you to view class or 
student assignments; sort by assignment, score, or student; and edit 
assignment scores.
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Exploring the Workspace Views
The appearance of the workspace changes depending on what you 
selected in the Assignments pane.

Assignments Summary View
This work area opens when you select Assignments Summary in the 
Assignments pane.

À  Assignments Summary. Lists the names of the assignments that 
you saved to the Portfolio Workspace. Shows a class and student 
average in the workspace.

• Click the minus sign (–) to collapse the list of individual 
assignments and view only the Assignments Summary.

• Click the plus sign (+) to show the list of individual assignments.

Á Individual assignments. Click an assignment to see the student 
scores for that assignment.

Â Options menu. Available when you select an individual 

assignment. Click  to open a menu that allows you to:

• Open the document in the Review Workspace.

• Redistribute the assignment to the current class.

• Remove the assignment from the Portfolio Workspace. The 
assignment still exists in other workspaces.

• Rename the assignment.
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À  Column Actions. Lets you perform certain actions on a column. 
Click a file icon anywhere in this row to: 

• Open an assessment for review in the Review Workspace.

• Sort assignments in ascending or descending order by student.

• Open the Master in the Review Workspace.

• Remove from Portfolio.

• Rename the assignment. 

Á Class Average. Shows the average score of the class for the 
assignment in that column.

Â Date. Shows the date the file was collected. The date the last file 
was collected is shown in the first column on the left.

Ã Students. Lists all students in the class.

Ä Column Header. Shows the name of the assignment saved to the 
Portfolio Workspace. You can perform the same actions on the 
column header as you can on the column actions. Right-click the 
column header to open the menu. 

The column header Mean Score shows the mean score for all 
assignments and the mean score for all assignments per student. 
Right-click the Mean Score column to sort by ascending or 
descending scores.

Å File icon. Shows the type of file. The file types shown are:

 Quick Poll

 PublishView™ file

(Shown only in the TI-Nspire™ Navigator™ NC Teacher Software)

 TI-Nspire™ file

Other file types

(Shown only in the TI-Nspire™ Navigator™ NC Teacher Software)

Æ Student scores. If questions are automatically graded, the scores 
are shown. You can change a student’s score for an assignment.



316 Using the Portfolio Workspace

Individual Assignment View
This work area opens when you select a single assignment in the 
Assignments pane. To view this work area, the assignment you select 
must be a .tns file that contains one or more questions.

Note: In the TI-Nspire™ Navigator™ NC Teacher Software, you can also 
open .tnsp files.

À Name of the selected assignment.

Á Total Possible. This row shows the points for these categories: 

• Total possible points for each question in the assignment. You 
can edit this number.

• Total number of extra points possible for the assignment. You 
can edit this number.

• Total points for the assignment.

• Raw score based on the number of points the student received 
divided by total possible points.

• Final percentage. This number updates when you edit possible 
points or extra points. You can edit this score. The final score is 
the same as the raw score, unless you change it.

If you edit the final score, it no longer updates if the other 
points change.

Â Student names. All students who received the selected 
assignment. Right-click to open and edit the document in the 
Documents Workspace, or to open the document for review in the 
Review Workspace.
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Saving an Item to the Portfolio Workspace
If you are using the TI-Nspire™ software for the first time, the Portfolio 
Workspace may be empty. You need to save files to the Portfolio 
Workspace to view and edit scores, and perform other work on the files.

You can save collected, unprompted, and Quick Poll files to the Portfolio 
Workspace. You can save to the Portfolio Workspace from the Class and 
Review Workspaces.

When you save Quick Polls to Portfolio, students can continue to submit 
answers to the Quick Poll until you stop the poll. The saved Quick Poll 
automatically updates without you having to save it again.

Note: If you opened the file from the Portfolio Workspace, or if you have 
already saved the file to the Portfolio Workspace, the software does not 
ask you for a file name. The software saves the file to the Portfolio 
Workspace with the existing file name, and updates any grades you had 
given students. You can change a grade in the Portfolio Workspace at 
any time.

To save a file to the Portfolio Workspace, follow these steps.

1. Select the files you want to save.

• From the Class Record in the Class Workspace, click , and then 
click Save selected to Portfolio.

• From an open file in the Review Workspace, click File > Save to 

Portfolio, or click .

The Save to Portfolio dialog box opens.

Ã Average. Shows the average score for all students, as well as 
average total points, raw score, and final score.

Ä Questions in the assignment. If the document contained 
multiple questions, each question is displayed here, along with the 
total possible score for that question.

Å Scores. Lists the score each student received for the selected 
assignment. Each page in an assignment may have a separate 
score. Right-click to edit the score, open the assignment in the 
Documents Workspace, or open the document in the Review 
Workspace.

Æ Scroll bar. Appears when there are more questions in the 
assignment to view, or more students to view.
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2. Save the files to a new Portfolio column or add them to an existing 
Portfolio column.

• To add the files to a new Portfolio column, select Add as new 
portfolio column. You can use the existing name, or type a new 
name.

• To save the files to an existing Portfolio column, select Add to 
existing portfolio column. Click the down arrow to select the 
desired column from the drop-down list.

Note: Quick Polls cannot be added to existing columns.

3. Click Save.

The file is saved in the Portfolio Workspace.

Note: The files you saved in the Portfolio Workspace remain in the Class 
Record until you remove them using the Remove command. 

If a file is deleted from the Class Record, that delete action does not 
affect the file copy in the Portfolio Workspace. The copy remains in the 
Portfolio Workspace until it is deleted.

Importing an Item to the Portfolio Workspace
You can import a .tns file from your computer to a student’s Portfolio 
entry.

1. Click Assignments Summary.

2. Highlight a cell in the student row where you want to import the 
file.

Note: You can import a file for only one student at a time.

3. Click File > Import Item.

The Open dialog box is displayed.

4. Navigate to the file you want to import and click it.
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5. Click Import.

If a file already exists in that cell, you are prompted to confirm the 
file replacement. 

• Click Replace to save your imported file over the existing file.

• Click Keep Existing to keep the existing file and cancel the 
import file function.

Editing Scores
There may be times when you want to edit a student’s score. For 
example, an Open Response assignment contains a question that requires 
the word “Autumn” as the correct answer. One student has entered 
“Fall.” If you want to give the student full or partial credit, you can do so 
by changing the student’s score for the question.

In addition to editing an individual student score, you can edit the total 
possible points for each question, the extra points, and the final 
percentage.

8 Use whole numbers to edit the scores. For example, type 75 to give a 
score of 75%, type 100 to give a score of 100%, and so forth.

Note: If you type a score and do not press Enter, the change is not made, 
and the previous score remains in place.

Previewing a Student’s Answer
You can preview a student’s answer to an individual assignment question 
in the Preview Pane. This provides a quick, easy, and efficient method for 
the review of questions, answers, and the modification of scores.

Note: The assignment must contain at least one question to be 
previewed.

1. Click an individual assignment in the Assignments Summary list.

2. Select the question cell you want to preview.



320 Using the Portfolio Workspace

The following information is shown in the Preview Pane.

• Q# Question. Original question with icon showing correct or 
incorrect response

• Student’s Answer. Student’s response

• Correct Response. Teacher’s correct response (blank if there is 
no correct response)

Note: Depending on the question posted, additional information 
may be displayed.

Modifying a Student’s Score for an Assignment
You can edit the score for an assignment from the Assignments Summary 
view, or you can edit the score for individual questions in an assignment 
from the Individual Assignments view. These steps describe how to 
change a score from either view.

1. In the student row, select the score you want to edit.

2. Right-click the cell and click Edit Score.

3. Type the replacement score, and press Enter. To cancel, press Esc.

Changing the Total Possible Points for a Question
You can edit the total possible score for individual questions or extra 
points.

1. Select a cell in the Total Possible row.

2. Right-click the cell and click Edit Score.

3. Type the points for the question or for extra points, and press Enter. 

The software asks if you want to keep the student scores for the 
question, or reassess the scores for each student. The default setting is 
to reassess the scores for each student.

• To keep the student scores without making changes, select 
Leave student assigned credit for this question intact.
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• To reassess the score for each student, select Reassess question 
for each student.

4. Click OK.

Changing the Final Percentage Score
1. In the Individual Assignments view, select the student whose score 

you want to edit.

2. Right-click the cell in the Final column, and click Edit Score.

3. Type the replacement score and press Enter. To cancel, press Esc.

Note: If you edit the final score, it retains the edited value and no longer 
updates if you edit other values in the row.

Exporting Results
If you or your school district use electronic gradebook software and 
reporting, you may want to export scores to these programs. You can 
export scores from Portfolio Workspace as a .csv formatted file. The 
export action includes all scores for all students on the selected 
assignment, or for all assignments.

The .csv file contains all the columns and rows in the workspace except 
for the Column Actions row. If a student had an empty cell with no score, 
the .cvs file displays a cell that is empty.

Exporting the Current View
This allows you to export all data shown in the Portfolio Workspace for a 
single assignment.

1. Choose an assignment from the list.

2. Click File > Export Data or click .

3. Select Export Current View.

The Export Data dialog box opens. 

• The default location is the My Documents folder.

• The default name is the name of the assignment.
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4. Navigate to the location where you want to save the file.

5. Click Save.

Customizing an Export
Custom Export allows you to export the final scores for one or more 
assignments. This is useful for reporting scores over a date range with 
only the student name and final score exporting.

1. Click File > Export Data or click .

2. Select Custom Export.

The Custom Export dialog box opens. 

3. Choose the assignments you want to export.

• Select the check box by assignment name.
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• Click Select All to select all assignments.

• Click Clear All to clear selections.

4. Click Export.

The Export Data dialog box opens. 

• The default location is the My Documents folder. 

• The default name is the name of the assignment.

5. Navigate to the location where you want to save the file.

6. Click Save.

Sorting Information in the Portfolio Workspace
1. Click the column header of the list you want to sort.

The selected list can be sorted in ascending, descending, or student 
name order.

2. Click the column header again to sort in another order.

Opening a Portfolio Item in Another Workspace
You can open a .tns file in the Documents Workspace to edit it; or you 
can open a .tns or Quick Poll file in the Review Workspace to view 
student responses in bar chart, table, or graph views.

Note: In the TI-Nspire™ Navigator™ NC Teacher Software, you can also 
open .tnsp files.

Opening an Item in the Documents Workspace
1. Click the file you want to open.

To open a file for all students: 

• From the Assignments Summary list, click the file.

• From the Assignments Summary view, click the icon in the 
Column Actions row, or click the Column Header.

To open a file for selected students: 

• From the Assignments Summary view, select a cell in a selected 
student’s row. You can open more than one file in a column, but 
you cannot open multiple files from different columns.

• From the Individual Assignments view, select a cell in the 
selected student’s row.
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2. Click File > Open for Editing or right-click and click Open for 
Editing.

The file opens in the Documents Workspace.

Opening an Item in the Review Workspace
1. Click the file you want to open using one of these methods:

• From the Assignments Summary list, select the file.

• From the Assignments Summary view, click the icon in the 
Column Actions row, or click the Column Header.

• From the Assignments Summary view, click a cell in a selected 
student’s row. You can open more than one file in a column, but 
you cannot open multiple files from different columns.

• From the Individual Assignments view, click a cell in the selected 
student’s row.

Note: Any method you choose in the Review Workspace opens the 
file with all student responses. You cannot open a file for just one 
student. However, you can select review responses for an individual 
student in the Review Workspace.

2. Click File > Open in Review Workspace or right-click and click Open 
in Review Workspace.

The file opens in the Review Workspace.

Opening a Master Document
A Master Document is the original document that was sent to students, 
and it contains the answer key for evaluating the responses collected 
from students. When you save a document to a column in the Portfolio 
Workspace, there is usually a Master Document associated with that file.

You can open the Master Document from the Portfolio Workspace in the 
Assignments Summary view. When you open the Master Document, it 
opens in the Documents Workspace as a read-only file.

1. In the Column Actions row, click the icon corresponding to the file 
you want to open.

2. Right-click the icon and click Open Master Document.

The document opens in the Documents Workspace as a read-only 
file.
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Adding a Master Document
There may be times when you want to replace an existing Master 
Document, or add a Master Document to an assignment that does not 
have one. For example, a question was marked with an incorrect answer 
and students did not receive credit for that answer. You can give students 
credit by changing the answer to that question, and retain the Master 
Document as a permanent record of the correct answer key.

Note: You can add or replace a Master Document for a .tns file, but not 
for a Quick Poll file.

The new Master Document is used to evaluate student scores. The 
evaluation works as follows:

• If a question changed, student answers are evaluated for the new 
question.

• If the new Master Document has questions that were not in the old 
Master Document, those questions are evaluated. Students may 
receive zero credit for those questions if they have not seen them.

To add or replace a Master Document, follow these steps:

1. In the Column Actions row, click the icon corresponding to the .tns 
file you want to open.

2. Click File > Add Master Document.

A dialog box opens where you can select a file.

3. Navigate to the .tns file you want to use as the new Master 
Document and click Open.

The software displays a message warning that replacing the Master 
Document will cause the software to reevaluate the student scores.

4. Click Add/Replace Master to assign the new Master Document, or 
click Cancel to cancel the action.

Redistributing a Portfolio Item
Redistributing a file to the class is a useful way to return graded 
assignments or to return assignments for additional work. Class must be 
in session to redistribute a file.

Note: You cannot redistribute a Quick Poll file.

1. Right-click the item you want to redistribute.
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2. Click Redistribute to Class, or click . 

The system sends the file to each student logged onto the 
TI-Nspire™ Navigator™ network. 

Collecting Missing Files from Students
There may be times when you store a set of student files to the Portfolio 
Workspace and the collection is incomplete because not all students were 
present, had the file ready for collection, or were not logged on. Class 
must be in session to collect a file.

1. Select an individual file, or click a file icon on the Column Actions 
row to select all files in that column.

Note: You can collect only one column of files at a time.

2. Click Collect Missing.

Missing files are collected from those students who are logged onto 
the network and whose files were not initially collected.

Sending Missing Files to Students
There may be times when you send a set of files to students and the send 
is incomplete because not all students were present, or logged on, or a 
new student was added to the class. Class must be in session to send a 
missing file.

1. Select an individual file, or click a file icon on the Column Actions 
row to select all files in that column.

Note: You can only send files contained in one column at a time.

2. Click Send Missing.

Missing files are sent to those students who are logged onto the 
network and who did not initially receive the files. 

Renaming a Portfolio Item
You can rename an assignment from the Assignments pane or from the 
column header.

1. Click the assignment name or column header you want to rename. 

2. Right-click and click Rename.

The Rename Portfolio Column dialog box opens.

3. Type the new name. 
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4. Click Rename. Click Cancel to cancel the request.

The column appears in the column header and in the Assignments 
pane with the new name. 

Removing Columns from Portfolio
There may be times you want to delete files from Portfolio. For example, 
an incorrect file was sent to or collected from a class. You can remove an 
assignment from the Assignments pane or from the column header.

1. Click the assignment name or column header you want to remove. 

2. Right-click and click Remove From Portfolio.

The Remove from Portfolio dialog box opens.

3. Click Remove to delete the file. Click Cancel to cancel the request. 

Note: If a file is saved to the Portfolio Workspace and later deleted from 
the Class Record, that delete action does not affect the file copy in the 
Portfolio. The copy remains in the Portfolio Workspace until it is deleted.

Removing Individual Files from Portfolio
There may be times you want to delete a single file or a few files from a 
column list, but not all of the files. For example, an incorrect file was 
collected from a student. Remove individual files from the work area in 
the Assignments Summary view.

1. Click the file or files within a single column that you want to delete.

2. Press Delete.

The Remove Selected Document(s) dialog box opens.

3. Click Remove to delete the files. Click Don’t Remove to cancel the 
request.
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Summary of File Type Options

.tns .tns with 
questions

.tnsp Quick 
Poll

Other file 
types

Save to Portfolio Ÿ Ÿ Ÿ Ÿ Ÿ

Save Selected to 
Portfolio

Ÿ Ÿ Ÿ Ÿ Ÿ

Edit Score Ÿ Ÿ Ÿ Ÿ

Open in Review 
Workspace

Ÿ Ÿ

Open for Editing Ÿ Ÿ Ÿ Ÿ*

Redistribute to class Ÿ Ÿ Ÿ Ÿ

Open Master 
Document

Ÿ Ÿ Ÿ Ÿ Ÿ

Add Master 
Document

Ÿ Ÿ

Export Data Ÿ** Ÿ** Ÿ** Ÿ** Ÿ**

Send/Collect 
Missing

Ÿ Ÿ Ÿ Ÿ

Rename Portfolio 
Column of files

Ÿ Ÿ Ÿ Ÿ Ÿ

Remove Portfolio 
Column of Files

Ÿ Ÿ Ÿ Ÿ Ÿ

 Ÿ* The file opens in the program the operating 
system has associated with the file type.

Ÿ** Empty, non-graded, and “Other file types” show 
“No score” in the cell when exported.
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Calculator

Getting Started with the Calculator Application
The Calculator application gives you a place to enter and evaluate math 
expressions. You can also use it to define variables, functions, and 
programs. When you define or edit a variable, function, or program, it 
becomes available to any TI-Nspire™ math and science learning 
technology application—such as Graphs & Geometry—that resides in the 
same problem.

You can also use Calculator to define library objects, such as variables, 
functions, and programs, which are accessible from any problem of any 
document. For information on creating library objects, see Libraries.

À Calculator menu. This menu is available anytime you are in the 
Calculator work area using the Normal view mode. The menu in this 
screen snapshot may not exactly match the menu on your screen.

Á Calculator work area

• Enter a math expression on the entry line, and then press · 
to evaluate the expression.

• Expressions are displayed in standard mathematical notation as 
you enter them.

• Entered expressions and results show in the Calculator history. 

Â Example of Calculator variables used in another application.
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Entering and Evaluating Math Expressions

Entering Simple Math Expressions

Note: To enter a negative number on the handheld, press v. To enter a 
negative number on a computer keyboard, press the hyphen key (-).

Suppose you want to evaluate  

1. Select the entry line in the Calculator work area.

2. Type 2^8 to begin the expression.

3. Press ¢ to return the cursor to the baseline.

4. Complete the expression:

Type *43/12.

Handheld: Type r 43 p 12.

5. Press · to evaluate the expression.

The expression is displayed in standard mathematical notation, and 
the result is displayed on the right side of the Calculator.

Note: If a result does not fit on the same line with the expression, it is 
displayed on the next line.

Controlling the Form of a Result
You might expect to see a decimal result instead of 2752/3 in the 
preceding example. A close decimal equivalent is 917.33333..., but that’s 
only an approximation.

By default, Calculator retains the more precise form: 2752/3. Any result 
that is not a whole number is shown in a fractional or (CAS) symbolic 
form. This reduces rounding errors that could be introduced by 
intermediate results in chained calculations.

You can force a decimal approximation in a result:
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• By pressing shortcut keys.

Windows®: Press Ctrl + Enter to evaluate the expression.

Mac®: Press “ + Enter to evaluate the expression.

Handheld: Press / · instead of · to evaluate the 
expression.

• By including a decimal in the expression (for example, 43. instead of 
43).

• By wrapping the expression in the approx() function.

• By changing the document’s Auto or Approximate mode setting to 
Approximate.

From the File menu, click Settings > Document Settings.

Handheld: Press ~ 1 7.

Note that this method forces all results in all of the document’s 
problems to approximate.

IInserting Items from the Catalog
You can use the Catalog to insert system functions and commands, 
symbols, and expression templates into the Calculator entry line.

1. Click the Utilities tab, and then click  to open the Catalog.

Handheld: Press k 1.

Pressing / · forces the approximate result.
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Note: Some functions have a wizard that prompts you for each 
argument. Those functions are shown with an indicator. To receive 
the prompts, select Wizards On.

2. If the item you are inserting is visible in the list, select it and press 
· to insert it.

3. If the item is not visible:

a) Click inside the list of functions, and then press a letter key to 
jump to the entries that begin with that letter.

b) Press ¤ or £ as necessary to highlight the item you are 
inserting.

Help, such as syntax information or a short description of the 
selected item, appears at the bottom of the Catalog.

c) Press · to insert the item into the entry line.
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Using an Expression Template
The Calculator has templates for entering matrices, piecewise functions, 
systems of equations, integrals, derivatives, products, and other math 
expressions.

For example, suppose you want to evaluate 

1. On the Utilities tab, click  to open the templates. 

Handheld: Press t.

2. Click  to insert the algebraic sum template.

The template appears on the entry line with small blocks 
representing elements that you can enter. A cursor appears next to 
one of the elements to show that you can type a value for that 
element.

3. Use the arrow keys to move the cursor to each element’s position, 
and type a value or expression for each element.

4. Press · to evaluate the expression.
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Creating Matrices

1. On the Utilities tab, click  to open the templates.

Handheld: Press t.

2. Click .

The Create a Matrix dialog box opens.

3. Type the Number of rows.

4. Type the Number of columns, and then click OK.

Calculator opens a template with spaces for the rows and columns.

Note: If you create a matrix with a large number of rows and 
columns, it may take a few moments to appear.

5. Type the matrix values into the template, and then press · to 
define the matrix.

Inserting a Row or Column into a Matrix
8 To insert a new row, hold down Alt and press Enter.

8 To insert a new column, hold down Shift and press Enter.

Handheld:

8 To insert a new row, press @.

8 To insert a new column, press g ·.

Inserting Expressions Using a Wizard
You can use a wizard to simplify entering some expressions. The wizard 
contains labeled boxes to help you enter the arguments in the 
expression.
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For example, suppose you want to fit a y = mx + b linear regression 
model to the following two lists:

{1,2,3,4,5}
{5,8,11,14,17}

1. On the Utilities tab, click  to open the Catalog.

Handheld: Press k 1.

2. Click an entry in the Catalog, and then press L to jump to the entries 
that begin with “L.”

Handheld: Press L.

3. Press ¤ as necessary to highlight LinRegMx.

4. Select the Wizards On option, if it is not already selected:

Handheld: Press e e to highlight Wizards On, press · to 

change the setting, and then press e e to highlight LinRegMx 
again.

5. Press ·.

A wizard opens, giving you a labeled box to type each argument.

6. Type {1,2,3,4,5} as X List.

7. Press e to move to the Y List box.

8. Type {5,8,11,14,17} as Y List.

9. If you want to store the regression equation in a specific variable, 
press e, and then replace Save RegEqn To with the name of the 
variable.



336 Calculator

10. Click OK to close the wizard and insert the expression into the entry 
line.

Calculator inserts the expression and adds statements to copy the 
regression equation and show the variable stat.results, which will 
contain the results.

LinRegMx {1,2,3,4,5},{5,8,11,14,17},1: CopyVar stat.RegEqn,f2: 
stat.results

Calculator then shows the stat.results variables.

Note: You can copy values from the stat.results variables and paste 
them into the entry line.

Creating a Piecewise Function
1. Begin the function definition. For example, type the following 

expression:

Define f(x,y)=

2. On the Utilities tab, click  to open the templates.

Handheld: Press t.

3. Click .

The Create Piecewise Function dialog box opens.

4. Type the Number of Function Pieces, and click OK.
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Calculator opens a template with spaces for the pieces.

5. Type the expressions into the template, and press · to define the 
function.

6. Enter an expression to evaluate or graph the function. For example, 
type the expression f(1,2) on the Calculator entry line.

Creating a System of Equations

1. On the Utilities tab, click  to open the templates.

Handheld: Press t.

2. Click .

The Create a System of Equations dialog box opens.

3. Type the Number of Equations, and click OK.

Calculator opens a template with spaces for the equations.

4. Type the equations into the template, and press · to define the 
system of equations.

Deferring Evaluation
You don’t have to complete and evaluate an expression as soon as you 
begin typing it. You can type part of an expression, leave to check some 
work you did on another page, and then come back to complete the 
expression later.

Working with Variables
When you first store a value in a variable, you give the variable a name.

• If the variable does not already exist, Calculator creates it.

• If the variable already exists, Calculator updates it.
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Variables within a problem are shared by TI-Nspire™ math and science 
learning technology applications. For example, you can create a variable 
in Calculator and then use or modify it in Graphs & Geometry or Lists & 
Spreadsheet within the same problem.

For more information, see Using Variables.

CAS: Working with Measurement Units
A list of pre-defined constants and measurement units is available in the 
Catalog. You can also create your own units.

Note: If you know a unit’s name, you can type the unit directly. For 
example, you can type _qt to specify quarts. To type the underscore 
symbol on the handheld, press / _.

CAS: Converting Between Measurement Units
You can convert a value between any two units within the same category 
(such as length). 

Example: Using the Catalog, convert 12 meters to feet. The desired 
expression is 12·_m¢_ft.

1. Type 12 on the entry line.

2. On the Utilities tab, click  to show the unit conversions.

Handheld: Press k 3.

3. Click the Length category to expand the list of pre-defined length 
units.
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Handheld: Scroll to the Length category, and press ·.

4. Scroll to meter.

Handheld: Scroll to _m (noting the meter hint in the Help window).

5. Press · to paste _m to the entry line.

6. Click the Conversion Operator (¢) at the top of the Units list, and 

press · to paste it to the entry line.

7. Select _ft from the Length category, and press ·.

8. Press · to evaluate the expression. 

CAS: Creating a User-defined Unit
As with the pre-defined units, user-defined unit names must begin with 
an underscore symbol.

Example: Using the pre-defined units _ft and _min, define a unit named 
_fpm that lets you enter velocity values in feet per minute and convert 
velocity results to feet per minute.
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Now you can use the new velocity unit _fpm.

Creating User-defined Functions and Programs
You can use the Define command to create your own functions and 
programs. You can create them in the Calculator application or in the 
Program Editor and then use them in other TI-Nspire™ applications.

For more information, see the Programming and Libraries chapters.

Defining a Single-line Function
Suppose you want to define a function named cube() that calculates the 
cube of a number or variable.

1. On the Calculator entry line, type Define cube(x)=x^3 and press 
·.

The message “Done” confirms that the function has been defined.

2. Type cube(2) and press · to test the function.

Defining a Multiple-line Function Using Templates
You can define a function consisting of multiple statements entered on 
separate lines. A multiple-line function may be easier to read than one 
with multiple statements separated by colons.

Note: You can create multiple-line functions only by using the Define 
command. You cannot use the := or & operators to create multiple-line 
definitions. The Func...EndFunc template serves as a container for the 
statements.
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As an example, define a function named g(x,y) that compares two 
arguments x and y. If argument x > argument y, the function should 
return the value of x. Otherwise, it should return the value of y.

1. On the Calculator entry line, type Define g(x,y)=. Do not press · 
yet.

2. Insert the Func...EndFunc template.

From the Functions & Programs menu, select Func...EndFunc.

Calculator inserts the template.

3. Insert the If...Then...Else...EndIf template.

From the Functions & Programs menu, select Control, and then 
select If...Then...Else...EndIf.

Calculator inserts the template.

4. Type the remaining parts of the function, using the arrow keys to 
move the cursor from line to line.

5. Press · to complete the definition.

6. Evaluate g(3,-7) to test the function.
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Defining a Multiple-line Function Manually
8 To start each new line without completing the function definition, 

hold down Alt and press Enter

Handheld: Press @ instead of pressing ·.

As an example, define a function sumIntegers(x) that calculates the 
cumulative sum of integers from 1 through x.

1. On the Calculator entry line, type Define sumIntegers(x)=. Do not 
press · yet.

2. Insert the Func...EndFunc template.

From the Functions & Programs menu, select Func...EndFunc.

Calculator inserts the template.

3. Type the following lines, pressing @ or Alt + Enter at the end of 
each line.

4. After typing Return tmpsum, press · to complete the definition.

5. Evaluate sumIntegers(5) to test the function.
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Defining a Program
Defining a program is similar to defining a multiple-line function. The 
Prgm...EndPrgm template serves as a container for the program 
statements.

As an example, create a program named g(x,y) that compares two 
arguments. Based on the comparison, the program should show the text 
“x > y” or “x  y” (showing the values of x and y in the text).

1. On the Calculator entry line, type Define prog1(x,y)=. Do not press 
· yet.

2. Insert the Prgm...EndPrgm template.

From the Functions & Programs menu, select Prgm...EndPrgm.

3. Insert the If...Then...Else...EndIf template.

From the Functions & Programs menu, select Control, and then 
select If...Then...Else...EndIf.

4. Type the remaining parts of the function, using the arrow keys to 
move the cursor from line to line. Use the Symbol Palette to select 
the ““ symbol.
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5. Press · to complete the definition.

6. Execute prog1(3,-7) to test the program.

s

Recalling a Function or Program Definition
You might want to reuse or modify a function or program that you have 
defined.

1. Show the list of defined functions.

From the Actions menu, select Recall Definition.

2. Select the name from the list.

The definition (for example, Define f(x)=1/x+3) is pasted into the 
entry line for editing.

Editing Calculator Expressions
Although you cannot edit an expression in the Calculator history, you can 
copy all or part of an expression from the history and paste it to the entry 
line. You can then edit the entry line.

Positioning the Cursor in an Expression

8 Press e, ¡, ¢, £, or ¤ to move the cursor through the expression. 
The cursor moves to the closest valid position in the direction that 
you press.

Note: An expression template may force the cursor to move through its 
parameters, even though some parameters may not be exactly in the 
path of the cursor movement. For example, moving upward from the 
main argument of an integral always moves the cursor to the top limit.
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Inserting into an Expression in the Entry Line
1. Position the cursor at the point where you want to insert additional 

elements.

2. Type the elements that you want to insert.

Note: When you insert an open parenthesis, Calculator adds a temporary 
close parenthesis, displayed in gray. You can override the temporary 
parenthesis by typing the same parenthesis manually or by entering 
something past the temporary parenthesis (thereby implicitly validating 
its position in the expression). After you override the temporary gray 
parenthesis, it is replaced with a black parenthesis.

Selecting Part of an Expression
1. Position the cursor at the starting point in the expression.

Handheld: Press ¡, ¢, £, or ¤ to move the cursor.

2. Press and hold g, and then press ¡, ¢, £, or ¤ to select.

Deleting all or part of an expression on the entry line
1. Select the part of the expression to delete.

2. Press ..

Financial Calculations
Several TI-Nspire™ functions provide financial calculations, such as time 
value of money, amortization calculations, and return on investment 
calculations.

The Calculator application also includes a Finance Solver. It lets you 
dynamically solve several types of problems, such as loans and 
investments.

Using the Finance Solver
1. Open the Finance Solver.

From the Finance menu, click Finance Solver.

The Finance Solver displays its default values (or previous values, if 
you have already used the solver in the current problem).
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2. Enter each known value, using e to cycle through the items.

• The help information at the bottom of the Finance Solver 
describes each item.

• You might need to temporarily skip the value that you want to 
calculate.

• Make sure to set PpY, CpY, and PmtAt to the correct settings (12, 
12, and END in this example).

3. Press e as necessary to select the item that you want to calculate, 

and then press ·.

The Finance Solver calculates the value and stores all the values in 
“tvm.” variables, such as tvm.n and tvm.pmt. These variables are 
accessible to all TI-Nspire™ applications within the same problem.
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Finance Functions Included
In addition to the Finance Solver, TI-Nspire™ built-in finance functions 
include:

• TVM functions for calculating future value, present value, number of 
payments, interest rate, and payment amount.

• Amortization information such as amortization tables, balance, sum 
of interest payments, and sum of principal payments.

• Net present value, internal rate of return, and modified rate of 
return.

• Conversions between nominal and effective interest rates, and 
calculation of days between dates.

Notes: 

• Finance functions do not automatically store their argument values 
or results to the TVM variables.

• For a complete list of TI-Nspire™ functions, see the Reference Guide.

Working with the Calculator History
As you enter and evaluate expressions in the Calculator application, each 
entry/result pair is saved in the Calculator history. The history gives you a 
way to review your calculations, repeat a set of calculations, and copy 
expressions for reuse in other pages or documents.

Viewing the Calculator History
The history of the expressions you have entered accumulates above the 
entry line, with the most recent expression at the bottom. If the history 
does not fit in the Calculator work area, you can scroll through the 
history.

Note: You may notice a processing slowdown when the history contains 
a large number of entries.

8 Press £ or ¤ to scroll through the history.
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Copying a Calculator History Item to the Entry Line
You can quickly copy an expression, subexpression, or result from the 
history into the entry line.

1. Press £ or ¤ to move through the history and select the item that 
you want to copy.

—or—

Select part of the expression or result by using Shift in combination 
with the arrow keys.

Note: The float setting for the current document may limit the 
number of decimal places displayed in a result. To capture the result 
in its full precision, select it either by scrolling with the up and down 
arrow keys or by triple-clicking it.

2. Press · to copy the selection and insert it into the entry line.

Copying a History Item to Another Application

1. Press £ or ¤ to move through the history and select the item that 
you want to copy.

2. Optionally, select part of the expression or result by pressing Shift in 
combination with the arrow keys.

3. Use the standard key shortcut for copying a selection.

Windows®: Press Ctrl + C.

Mac®: Press “ + C.

À Current entry/total entries
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Handheld: Press / C.

4. Place the cursor at the location where you want the copy.

5. Paste the copy.

Windows®: Press Ctrl + V.

Mac®: Press “ + V.

Handheld: Press / V.

Note: If you copy an expression that uses variables into a different 
problem, the values of those variables are not copied. You must define 
the variables in the problem where you paste the expression.

Deleting an Expression from the History
When you delete an expression, all variables and functions defined in the 
expression retain their current values.

1. Drag or use the arrow keys to select the expression.

Handheld: Use the arrow keys.

2. Press ..

The expression and its result are removed.

Clearing the Calculator History
When you clear the history, all variables and functions defined in the 
history retain their current values. If you clear the history by mistake, use 
the undo feature.

8 To clear the history:

From the Actions menu, select Clear History.

All expressions and results are removed from the history.
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Using Variables

A variable is a defined value that can be used multiple times in a 
problem. You can define a value or function as a variable within each 
application. Within a problem, variables are shared by 
TI-Nspire™ applications. For example, you can create a variable in 
Calculator, and then use or modify it in Graphs & Geometry or Lists & 
Spreadsheet within the same problem. 

Each variable has a name and a definition and the definition can be 
changed. When you change the definition, all occurrences of the variable 
in the problem are updated to use the new definition. In the TI-Nspire™ 
software, a variable has four attributes:

• Name - User-defined name assigned when the variable is created.

• Location - Variables are stored in memory.

• Value - Number, text, mathematical expression, or function.

• Type - Type of data that can be stored as a variable.

Note: Variables created with the Local command within a user-defined 
function or program are not accessible outside that function or program.

Linking Values on Pages
Values and functions created or defined in one application can interact 
with other applications (within the same problem) to share data. 

When using linked items, keep in mind:

• Values can be linked between applications on one page or between 
different pages of the same problem. 

• All applications are linked to the same data.

• If the linked value is changed in the original application, the change 
is reflected in all linked usages.

Defining a variable is the first step in linking values.

Creating Variables
Any portion or attribute of an object or function created within an 
application can be stored as a variable. Examples of attributes that can 
become variables are the area of a rectangle, the radius of a circle, the 
value contained in a spreadsheet cell or the contents of a row or column, 
or a function expression. When you create a variable, it is stored in 
memory. 
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Types of Variables
You can store the following data types as variables:

When you click  or press h on a handheld to open the list of stored 
variables, a symbol indicates the type.

Creating a Variable from a Calculator Value 
This example shows how to create a variable using a handheld. Complete 
the following steps to create a variable named num and store the result of 

the expression 5+83 in that variable.

1. On the Calculator entry line, type the expression 5+8^3.

2. Press ¢ to expand the cursor to the baseline.

Data type Examples

Expression

2.54 1.25E6 2p xmin/10 2+3i (xN2)2

List {2, 4, 6, 8} {1, 1, 2} {"red", "blue", "green"}

Matrix

 This can be entered as:  [1,2,3;3,6,9]

Character string “Hello” “xmin/10” “The answer is:”

Function, 
program

myfunc( arg ) ellipse( x, y, r1, r2 )

Measurement area, perimeter, length, slope, angle
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3. Press / h and then type the variable name num.

This means: Calculate 5+83 and store the result as a variable named 
num.

4. Press ·.

Calculator creates the variable num and stores the result there.

Creating a Variable in the Computer Software
When creating a variable in the computer software, use the following 
conventions. As alternatives to using & (store), you can use “:=” or the 
Define command. All of the following statements are equivalent.

5+83 & num

num := 5+83

Define num=5+83

Checking a Variable’s Value
You can check the value of an existing variable by entering its name on 
the Calculator entry line. When you type the name of a stored variable, it 
appears in bold type.

8 On the Calculator entry line, type the variable name num and press 
·. 

The value most recently stored in num is displayed as the result.

Automatically Creating Variables in Graphs & Geometry
In the Graphs and Geometry applications, functions defined on the entry 
line are automatically stored as variables.
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In this example, f1(x)=x3 is a variable definition, which allows it to be 
displayed in other applications including a table in the Lists & 
Spreadsheet application.

Creating a Variable from a Graphs & Geometry Value
1. Click the value to store as a variable.

2. Click .
Handheld: Press h.

The Variables options are displayed with Store Var highlighted.

3. Press ·. VAR := appears before the selected value. This is the 
default name.
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4. Replace the default name VAR with the variable name you want to 
give the value. 

5. When the variable name is typed, press ·. 

The value is saved to that variable name, and the stored value or its 
name appears in bold text to indicate it is a stored value. 

Note: You can also share a Graphs & Geometry axis end value with other 
applications. If necessary, click Actions, Show/Hide Axes End Values to 
display the end values on the horizontal and vertical axes. Click the 
number for an end value to highlight it in the entry field. Name the 
variable and store it for use with other applications by using any method 
described in Step 2.

Automatically Creating Variables in Lists & Spreadsheet
Naming a list at the top of a Lists & Spreadsheet column automatically 
stores that value as a list variable. This variable can be used in other 
applications including Data & Statistics.
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Creating a Variable from a Lists & Spreadsheet Cell Value 
You can share a cell value with other applications. When defining or 
referring to a shared cell in Lists & Spreadsheet, precede the name with 
an apostrophe (‘).

1. Click the cell that you want to share.

2. Click  to open the Variables menu.
Handheld: Press h. 

3. Click Store Var.

A formula is inserted into the cell with var as a placeholder for a 
variable name.

4. Replace the letters “var” with a name for the variable, and press 
·.

The value is now available as a variable to other applications within 
the same problem.

Note: If a variable with the name you specified already exists in the 
current problem space, Lists & Spreadsheet displays an error message.
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Using (Linking) Variables
Sharing, or linking, the variables you create is a powerful tool for math 
exploration. The display of linked variables is automatically updated 
when the variable’s value changes. 

Linking to Shared Variables
To use a stored variable:

1. Display the page and select the location or object to which you want 
to link a variable. 

2. Select the Variables tool h.

The Variables options are displayed. The software knows which types 
of variables will work in the location or with the object selected and 
will only display those variables.

3. Use 9 and : to scroll the list.

—or—

Type part of the variable name. 

As you type, the system displays a list of variables that begin with the 
letters you typed. Typing part of the name enables you to locate a 
variable more quickly if the list is long. 

4. When you locate and highlight the name of the variable you want to 
use, click the name.

—or—

Press ·. 

The selected variable value is linked. 

Linking a Lists & Spreadsheet Cell to a Variable
When you link a cell to a variable, Lists & Spreadsheet keeps the cell 
value updated to reflect the current value of the variable. The variable 
can be any variable in the current problem and can be defined in Graphs 
& Geometry, Calculator, or any instance of Lists & Spreadsheet.

Note: Do not link to a system variable. Doing so could prevent the 
variable from being updated by the system. System variables include ans, 
StatMatrix, and statistics results (such as RegEqn, dfError, and Resid).

1. Click the cell that you want to link to the variable.

2. Open the VarLink menu:

– Click , and then click Cell.
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– Handheld: Press h.

The VarLink menu is displayed.

3. Under Link To, scroll to the name of the variable and click it.

The cell shows the value of the variable.

Using a Variable in a Calculation
After storing a value in a variable, you can use the variable name in an 
expression as a substitute for the stored value.

1. Enter the expression:

– Type 4*25*num^2 on the entry line, and press Enter. 

– Handheld: Type 4 r 25 r num^2 on the entry line, and press 

·. 

Calculator substitutes 517, the value currently assigned to num, and 
evaluates the expression.

2. Enter the expression:

– Type 4*25*nonum^2, and press Enter. 

– Handheld: Type 4 r 25 r nonum^2 on the entry line, and press 

·.

CAS: Because the variable nonum has not been defined, it is treated 
algebraically in the result.

Because the variable nonum has not been defined, the expression 
returns an error message.
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Entering Multiple Statements on the Entry Line
To enter several statements on a single line, separate them with a colon 
(“:”). Only the result of the last expression is shown.

Setting Variable Values with a Slider
In the Graphs and Geometry applications, a slider control lets you adjust 
or animate the assignment of values for a numeric variable. Use a slider 
to represent multiple variable values in a continuous range. 

1. From the Document Tools menu, click Actions > Insert Slider.
Handheld: Press b 1 A to insert a slider.

The slider is displayed on the work area. If you need to adjust or 
animate value selection for more than one variable, you can repeat 
this step and insert multiple sliders. 

Note: You can access the context menu to Pin a slider to its location 
and prevent unintentional movement.

2. Click the slider to activate it and press e to move between the 
slider scale and the variable’s value.

3. Use ¡ and ¢ to move the slider on the scale.

4. Press Enter to select the value.

Access the context menu and choose Settings to view or change the 
default slider settings.

Naming Variables
Variable and function names that you create must meet the following 
naming rules.

Note: In the unlikely event that you create a variable with the same 
name as one used for statistical analysis or by the Finance Solver, an error 
condition could occur. If you begin entering a variable name that is 
already in use in the current problem, the software shows the entry in 
bold to let you know.
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• Variable names must be in one of the forms xxx or xxx.yyy. The xxx 
part can have 1 to 16 characters. The yyy part, if used, can have 1 to 
15 characters. If you use the xxx.yyy form, both xxx and yyy are 
required; you cannot start or end a variable name with a period “.”.

• Characters can consist of letters, digits, and the underscore character 
(_). Letters can be U.S. or Greek letters (but not Π or p), accented 
letters, and international letters.

• Do not use c or n from the symbol palette to construct a variable 
name such as c1 or n12. These may appear to be letters, but they are 
treated internally as special symbols.

• You can use uppercase or lowercase letters. The names AB22, Ab22, 
aB22, and ab22 all refer to the same variable.

• You cannot use a digit as the first character of xxx or yyy.

• You can use digits 0 through 9, U.S. letters, a - z, Latin and Greek 
letters (but not p) as subscripts (for example, a2, qa, or h2o). To enter a 

subscript while typing a variable name, select  in the Math 
Templates or on the formatting toolbar.

• Do not use spaces.

• If you want a variable to be treated as a complex number, use an 
underscore as the last character of the name.

• CAS: If you want a variable to be treated as a type of unit (such as _m 
or _ft), use an underscore as the first character of the name. You 
cannot use subsequent underscores in the name.

• You cannot use an underscore as the first character of the name.

• You cannot use a preassigned variable, function, or command name, 
such as Ans, min, or tan.

Note: For more information about TI-Nspire™ functions, see the 
Reference Guide.

• Library documents and library objects are subject to additional 
naming restrictions. For more information, see Libraries.

Here are some examples:

Variable names Valid?

Myvar, my.var Yes

My var, list 1 No. Contains a space.

a, b, b12, b12, c, d Yes. Note that variables b12 and b12 are distinct.

Log, Ans No. Preassigned to a system function or variable.
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Locking and Unlocking Variables
Locking lets you protect variables from modification or deletion. Locking 
prevents unintended changes to a variable.

Variables you Cannot Lock
• System variable Ans

• stat. and tvm. variable groups

Important Information About Locked Variables
• To lock variables, use the Lock command.

• To modify or delete a locked variable, you must first unlock the item.

• Locked variables display a lock icon on the variable menu list.

• The Lock command clears the Redo/Undo history when applied to 
unlocked variables.

Log1, list1.a, list1.b Yes

3rdTotal, list1.1 No. xxx or yyy starts with a digit.

Time and altitude lists can be locked to 
ensure problem fidelity

Reference function f1 can be locked to 
prevent unintended change

Variable names Valid?
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Examples of Locking

For more information, see the Reference Guide.

Updating a Variable
If you want to update a variable with the result of a calculation, you 
must store the result explicitly.

Reusing the Last Answer
Each instance of Calculator automatically stores the last calculated result 
as a variable named Ans. You can use Ans to create a chain of 
calculations.

Note: Do not link to Ans or any system variable. Doing so could prevent 
the variable from being updated by the system. System variables include 
statistics results (such as Stat.RegEqn, Stat.dfError, and Stat.Resid) and 
Finance Solver variables (such as tvm.n, tvm.pmt, and tvm.fv).

As an example of using Ans, calculate the area of a garden plot that is 1.7 
meters by 4.2 meters. Then use the area to calculate the yield per square 
meter if the plot produces a total of 147 tomatoes.

1. Calculate the area:

Lock a,b,c Locks variables a, b, and c from the Calculator 
application.

Lock mystats. Locks all members of variable group mystats.

UnLock func2 Unlocks variable func2.

lm:=getLockInfo(var2) Retrieves the current lock status of var2 and 
assigns that value to lm in the Calculator 
application.

Entry Result Comment

a := 2 2

a3 8 Result not stored in variable a.

a 2

a := a3 8 Variable a updated with result.

a 8

a2 & a 64 Variable a updated with result.

a 64
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– On the Calculator entry line, type 1.7*4.2, and press Enter.

– Handheld: On the Calculator entry line, type 1.7 r 4.2, and 

press ·.

2. Reuse the last answer to calculate the yield per square meter:

– Type 147/ans, and press Enter to find the yield.

– Handheld: Type 147 p ans, and press · to find the yield.

3. As a second example, calculate  and then add 2*log(45).

– Type 3.76/(-7.9+sqrt(5)), and press Enter.

– Handheld: Type 3.76 p (v7.9+sqrt(5)), and press ·.

4. Reuse the last answer:

– Type ans+2*log(45), and press Enter.

– Handheld: Type ans+2 r log(45), and press ·.

Temporarily Substituting a Value for a Variable
Use the “|” (such that) operator to assign a value to a variable for just a 
single execution of the expression.
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Removing a Linked Variable
1. Select the linked variable. 

2. Press h.

The Variables options are displayed.

3. Select Unlink. 

The link is removed from the value, and the value is displayed 
without any bold formatting.
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Graphs & Geometry

The Graphs & Geometry application lets you perform the following tasks:

• Graph and explore functions and other relations, such as 
inequalities, parametrics, polars, sequences, differential equation 
solutions, conics, 3D functions, and 3D parametrics.

• Create and explore geometric shapes.

• Animate points on objects or graphs and explore their behavior.

• Graph data collected by the Data Collection tool.

• Explore graphical and geometric transformations.

• Explore and investigate concepts of calculus.

• Link to data created by other applications and use it in 
Graphs & Geometry.

Getting Started with Graphs & Geometry

À Graphs & Geometry tool menu

Á Graphs & Geometry work area in Graphing View

Â Function graph (from function expression on the entry line)

Ã Entry line for defining functions. Press / G to show/hide.
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Graphs & Geometry Menu
The Graphs & Geometry menu appears immediately above the work 
area. To display the menu on the Handheld, press b.

Note: In the 3D Graphing view, the menu shows commands for working 
with 3D graphs specifically.

When you select a tool from the menu, the tool’s icon displays in the 
upper left corner of the Graphs & Geometry work area. You can hover 
over the tool icon to view tooltips. 

Ä Expand/Collapse button. Click to show/hide history of graphed 
relations of the current type.

À Sample Graphs & Geometry work area in Plane Geometry View

Á Sample tool icon (Regular Polygon tool) shows tooltip on hover

Â Sample shape (regular polygon)
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Using Keystroke Shortcuts
Use keystroke shortcuts to simplify tasks that you can perform in the 
Graphs & Geometry application.
 

Keystrokes: Task accomplished:

. Removes a selected object from the work area.

g Constrains certain objects as you draw. Press while 
drawing a circle with the Circle tool, or while drawing 
objects with linear components. For example, you can 
constrain a line to multiples of 15 degrees, or constrain 
a circle to integer radius values.

+ (+) - (-) When a number is under the pointer, the + and - keys 
enable you to change the number of displayed digits.

< > When a number is under the pointer, the < and > keys 
decrease or increase a value.

/μ Displays application hints on the TI-Nspire™ handheld.

e Move to functional areas of the application in the 
following order: the entry line, Entry Line Expansion 
button, Slider, Animation panel, or Data Collection 
Console (when present), and then to the work area. 
Edits (if any) are committed when you e out of a 

field. Press g e to move through the tab stop 

areas in reverse order, or press d to jump to a graph 
on the work area.

£ ¤ Moves up and down among menu options and 
through functions in the function history list. When 
using the Trace tool, enables you to move to a 
different graph when more than one graph is on the 
page.

¡ ¢ Moves along the entry line, one space or one button at 
a time. When using the Trace tool, moves the trace 
cursor along the graph, either left or right. When 
viewing an attribute list, steps through the options for 
one attribute. 

Note: When using the TI-Nspire™ software, you can 
press Alt while pressing an arrow key to move selected 
objects one pixel on the work area.
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Using the Context Menu
The context menu provides access to the tools most commonly used with 
the selected objects. Different options can appear on the context menu 
depending on the active object or the task you are performing.

You can display the context menu for an object in one of the following 
ways.

8 Handheld: Move the pointer to the object, and then press / b. 

8 Windows®: Right-click the object.

8 Mac®: Hold “ and click the object.

Many of the options that appear on the context menu provide 
convenient access to functionality that is also available from menus. The 
context menu can include the following options that are not available on 
the application menus.

• Click Recent to view and access the nine most recently used tools. 
Recent shows tools used for any Graphs & Geometry application, 
regardless of the document in which they were used.

• The Label option lets you show a persistent label near a selected 
object. 

• The Color option lets you change the line color or fill color of 
selected objects (such as a function graph, shape, or point).

Note: On TI-Nspire™ handhelds that do not support color, colors are 
displayed as shades of gray.

• The Edit Relation option moves the focus to the entry line for 
editing the selected function. 

• The Convert to Analytic and Convert to Geometric options change 
text created in one view to text that is displayed in the other. For 
example, select the text box and click Convert to Geometric on the 
context menu to change text you created in Graphing View to text 
that is displayed in Plane Geometry view. 

• The Attach option lets you create a text chain, constraining the 
relative horizontal or vertical position of one text object with respect 
to another text object of the same type (analytic or geometric).

• The Group option lets you move, color, and apply other changes to 
multiple objects simultaneously. Each group of objects is identified 
by a single label to reduce screen clutter.

• The Pin option lets you pin objects to prevent accidental moves as 
you make other changes on the work area. You can pin points, 
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shapes, angles, values, text, graphed functions, the axes, and the 
work area background. 

Other options that are appropriate for various objects are also displayed 
on the context menu. For more information about using color in 
documents and changing the Graphs & Geometry application’s settings 
for the default plot label display, see Working with Documents in the 
TI-Nspire™ Software.

Changing Graphs & Geometry Settings
1. On the Graphs & Geometry menu, click Settings.

2. Select the settings that you want.

Note: If you want Display Digits, Graphing Angle, or Geometry 
Angle to use the current Document Settings instead of specific digit 
or angle settings, set it to Auto.

Using the Work Area
The work area provides a space for drawing and working with objects 
such as graphed functions, shapes, or points and lines. 

When you select a graph or position the mouse over a graphed function, 
the expression for the corresponding graph is displayed on the work 
area. You can select multiple graphs to display their expressions. 

The top left corner of the work area displays a tool icon when you 
activate most tools. You can hover over the tool icon to display tips to 
help you use the tool. 
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Grabbing and Dragging Items in the Work Area
Dragging lets you move and manipulate items. For example, you can 
drag a text label to move it or drag a circle’s perimeter to resize it.

1. Point to the item.

The pointer changes to show that you can grab or manipulate the 
item.

2. Use the mouse to grab and drag the item.

Handheld: Hold down x to grab the item, use the Touchpad or 

Clickpad to drag it, and then press x again to release it. 

Panning the Work Area
To see different portions of the work area, click and hold on an empty 
region until the pointer changes to ù, and then drag. 

Adding Text
You can add text to the work area to label objects, or to summarize the 
results of your analysis of a graph. Use the Text tool to type numerical 
values, formulas, or other information in the work area.

1. From the Actions menu, select Text. 

2. On the work area, click the location for adding text. You can attach 
text to an object by clicking the object.

A text box with a blinking cursor appears at the location you 
selected. 

3. Type the text. 

4. Press · to anchor the text on the work area. 

You can create a text chain by using the Attach tool on the context 
menu to connect text objects of the same type to each other. Detach 
disassociates chained text from a text chain. Spacing, alignment, and 
updating of calculated value text is handled automatically for 
chained text.
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Note: You cannot include pinned text, text hidden using the 
Show/Hide tool, or geometric scale values in a text chain. 

5. You can customize text objects to suit your needs.

• Use context menu options to change text objects.

– Convert text created in Graphing View to geometric text.

– Convert text created in Plane Geometry View (outside of the 
analytic window) to analytic text. 

– Attach analytic or geometric text to text of the same type.

• Use the Text tool to enter numerical values that the 
Graphs & Geometry application can interpret as numbers. You 
can use these numeric text entries for calculations, or for 
specifying measurements.

6. Press d.

—or—

Choose another tool to exit the Text tool.

Working with Multiple Objects
You can select multiple objects with the Pointer tool or Select tool, and 
then use other tools to perform certain actions on several objects at 
once. As you move around and over objects, helpful details are displayed, 
such as information about the object type or object state (for example, 
pinned, locked, or grouped). 

Notes: 

• You cannot move selected objects together if one or more of the 
objects is pinned.

• The e tooltip is displayed when you hover over a component 

object. This indicates that you can press e to move among the 
component objects and select them individually.

• Read the object labels to ensure you do not select unintended 
objects.

Selecting Objects Using the Pointer Tool
1. Click the first object that you want to select. 



372 Graphs & Geometry

The object flashes to indicate selection, and is displayed with a 
thicker line style (bold) when you hover over it. 

2. Click the second object. 

You can continue clicking objects to select all of the objects that 
interest you. As each object is selected, it flashes with the others in 
the selection. You can deselect an individual object by clicking that 
object again, or deselect the entire selection by pressing d or 
clicking on a part of the work area that contains no object.

Selecting Objects with the Select Tool
1. From the Actions menu, click Select > Region.

2. Click a point near the boundary of the part of the work area 
containing objects that you want to select. 

3. Move the pointer across the desired selection region. 

A dotted box outline appears around the selection area as you move.

4. Click the point on the opposite boundary to complete selection. 

The objects in the selection box flash. You can double-click the work 
area to begin marking another selection, or press d to exit the 
Select tool.

Canceling Selection
Cancel the selection of objects in a selection box in the following ways.

• Cancel selection of all objects by pressing d or by clicking on a 
space with no objects. 

• Cancel selection for one object by clicking the object a second time. 

Deleting Selections

8 To delete one or more selected objects, press .. 

You cannot delete the origin, the axes, or locked points and values, 
even if they are selected. Objects that are pinned and/or grouped 
can be deleted.
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Moving Selections
1. Hover over one of the flashing objects in a selection of multiple 

objects. 

2. Grab and drag the object. All objects in the selection move together.

3. Click at the location of your choice to complete the move.

Notes: 

• If an unmovable object is included in a selection, you must move the 
objects individually. You cannot move the origin, the axes, or a 
pinned object as part of a multiple-object selection. 

• Specific movements are supported for certain objects. For example, 
you can press an arrow key to move an object attached to the grid 
one point at a time. 

Working with Color
Color changes made in the software are displayed in shades of gray when 
you work on documents using a TI-Nspire™ handheld that does not 
support color. Color is preserved when you move documents back to the 
software. 

Changing the Color of a Function or the Axes
1. Select the axes or the function.

2. Access the context menu and click Color > Line Color.

3. Select the color to apply.

Changing the Line or Fill Color of Objects
1. Select the object or objects.

2. Display the object’s context menu, click Color, and then click 
Line Color or Fill Color.

3. Select the color to apply to the objects.

Understanding Attributes
The following table lists the attributes available for objects. The list of 
available attributes depends upon the object you select. To view 
attributes, select the Attributes tool. When an object is selected, a list of 
the attributes available for that object are displayed on the work area. 
You can choose an attribute and select an option to change the 
appearance of the selected object. Attributes indicated with an asterisk 
support entering a number to indicate a value for the attribute.
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Name Icon(s) Options Available for use on

Line Weight

  

Thin, Medium, 
Thick

Line, Tangent, Segment, 
Ray, Vector, Circle, Circle 
arc, Triangle, Polygon, 
Regular Polygon, 
Rectangle, Graphed 
Functions, Integrals

Line Style

  

Continuous, 
Dotted, Dashed

Line, Tangent, Segment, 
Ray, Vector, Circle, Circle 
arc, Triangle, Polygon, 
Regular Polygon, 
Rectangle, Graphed 
Functions, Polar 
Equations, Integrals, 
Parametric Plots

Animation

  

Unidirectional 
Animation 
Speed*, 
Alternating 
Animation 
Speed*

Point, Point On

Lock/ 
Unlock  

Object is 
unlocked, Object 
is locked

Point, Point On, 
Intersection Point, 
Length, Area, Angle, 
Circle Arc

Custom 
Precision

Current value: n* Length, Area, Angle, 
Slope

Point Style

  

  

  

   

Circle, Empty 
circle, Square, 
Empty square, 
Cross, Plus, Thin 
(small circle), 
Large, Empty 
Large

Point, Point On, 
Intersection Point, Circle 
Arc

Activation

 

Point is activated, 
Point is 
unactivated

Scatter Plot elements
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Graph 
Appearance   

 

Graph is 
continuous, 
Graph is discrete, 
Number of 
Points*, Step 
Size*, T 
Minimum*, T 
Maximum*, q 
Minimum*, q 
Maximum*

Graphed Functions, 
Parametric and Polar 
graphs

Axes 
Settings

 

Axes user 
settings, Axes 
quadrant 1 
settings, Axes trig 
settings, Axes stat 
settings, Axes 
standard settings, 
Axes decimal 
settings

Axes

Axes End 
Style   

No arrows, 
Positive arrows, 
All arrows

Axes

Axes Tic 
Labels

Tic labels are 
shown, Tic labels 
are hidden

Axes

End Values 
of Axes   

End values are 
shown, End 
values are hidden

Axes

Line 
Equation 
Type

  

Cartesian (y=_), 

Canonical (_=0)

Line, Tangent, Segment, 
Ray, Vector

Equation 
Type  

Canonical (...=0),

Cartesian (...=r2)

Circle 

Plot Points

 

Points are not 
connected, Points 
are connected 

Scatter Plots

Name Icon(s) Options Available for use on
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Changing an Attribute of an Object
You can change attributes to change the appearance of objects such as 
shapes, lines, graphed functions, and axes. 

1. From the Actions menu, click the Attributes tool.

2. Select the object that you want to change. 

The list of the attributes for the selected object are displayed. 

3. Use 9 and : to move through the list of icons for attributes. 

4. Highlight the icon for the attribute you want to change and use 
7 or 8 to move through the options. For example, highlight the Line 
Weight option, and use 7 or 8 to move to Thick, Thin, or Medium.

As you move through the options, you can review the changes on 
the work area. For example, you can see the line weight for the 
selected object change from Thin to Medium as you preview the line 
weight options.

Note: You can enter a numeric value instead of selecting an option 
to change an animation speed attribute for a supported object, or to 
set the step size, number of points, minimum values, or maximum 
values for supported graph types.

5. Press · to apply the option to the attribute.

Conditional Attributes
You can cause objects to hide, show, and change color dynamically, based 
on specified conditions such as "r1<r2" or "sin(a1)>=cos(a2)." 

For example, you might want to hide an object based on a changing 
measurement that you have assigned to a variable, or you might want an 
object’s color to change based on a "Calculate" result assigned to a 
variable.

Labels

  

  

 

f, f( ), f( )=, 
y=f( ), y=,

Graphed Functions 

Sequence 
Type   

Time plot, Web 
plot

Sequence plots 

Name Icon(s) Options Available for use on
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Conditional behaviors can be assigned to objects or groups in the 
Graphing, Plane Geometry, and 3D Graphing views.

Setting Conditional Attributes of an Object
You can set conditions of a selected object either by using its context 
menu or by activating the Set Conditions tool from the Actions menu 
and then selecting the object. These instructions describe using the 
context menu.

1. Select the object or group.

2. Display the object’s context menu, and click Conditions.

The conditional attributes are displayed.

3. (Optional) In the Show When field, enter an expression specifying 
the conditions during which the object will be shown. Anytime the 
condition is not satisfied, the object will be hidden.

You can specify tolerance by using compound conditionals in the 
Show When input field. For example, area>=4 and area<=6.

Note: If you need to see conditionally hidden objects temporarily, 
click Actions > Hide/Show. To return to normal viewing, press d.

For 2D objects For 3D objects
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4. (Optional) Enter numbers or expressions that evaluate to numbers in 
the applicable color fields, such as Line Color or Mesh Color. To see a 
map of color values, click the Colors button.

5. Click OK in the Conditional Attributes dialog box to apply the 
conditions.

Locking Measured Values and Points
Locking measured values and points can be useful when you need to 
prevent inadvertent change, or for explorations in which object 
manipulations are constrained such that the locked measurement 
remains constant. 

1. From the Actions menu, click Attributes.

2. Select the value or point that you want to lock. 

3. Use 9 and : to locate the Lock attribute. 

4. Use 7 or 8 to select Lock.

5. Press · to lock the value or point. 

Map of conditional color values

Initial rectangle with locked perimeter
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A lock icon appears near the locked value or point. 

In this case, a rectangle is created with the desired perimeter, and 
then both the perimeter and area values are displayed. The 
perimeter value is locked. As you manipulate the rectangle, the 
perimeter remains unchanged but the area changes. When the 
optimum area is displayed, you can measure the sides to obtain the 
necessary dimensions. 

Graphs & Geometry Views
The Graphs & Geometry application has three separate views. Each is 
tailored to specific types of explorations:

• In Graphing view, the work area contains axes for graphing 2D 
functions. The view includes an entry line where you can type and 
edit the expressions to be graphed.

• In Plane Geometry view, you can explore geometric objects. You can 
optionally use the Plane Geometry view in modeling mode (that is, 
Plane Geometry view with an analytic window added for working 
with objects in an axis system).

• In 3D Graphing view, the menu and work area change to let you 
graph and explore 3D functions and 3D parametric equations. The 
section 3D Graphing in this chapter discusses 3D features.

When you add a new document, problem, or page, you can choose 
Graphs or Geometry separately. The software adds a 
Graphs & Geometry application in the selected view.

Summary of View Differences
The following table describes some work area differences between the 
Plane Geometry view and the Graphing View.

Feature Graph Area Plane Geometry Area

Aspect Ratio Adjustable; initially 1:1 Always 1:1 (static)

Units of Measure Generic (displayed as u) User-defined (per scale)

Area Graph Type Cartesian (default) or 
Polar

Euclidian
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Using the Graphing View
The following items are displayed initially when you launch Graphing 
View.

• Cartesian axes in the Zoom Standard format (1:1 scale)

• Entry line from which you can graph up to 100 functions

The axes, axis labels, and entry line can all be displayed or hidden. You 
can show a dotted or lined grid, or no grid at all. All objects created in 
Graphing View are analytic objects, so no scale is displayed for shapes 
you draw (such as a circle or triangle). The Show Scale tool has no effect.

Uses • Define , graph, and 
manipulate 
functions to:

– Graph 
functions of 
the form f (x)

– Create scatter 
plots

– Graph polar 
equations

– Graph 
parametric 
equations

– Graph 
sequences

• Construct, 
manipulate, and 
measure analytic 
objects

• Display 
coordinates, 
equations, labels, 
and informative 
text 

• Construct, 
manipulate, 
transform, and 
measure Euclidean 
objects

• Display labels and 
informative text

Behavior Analytic objects must 
remain in the analytic 
area.

Geometric objects can 
be displayed as a layer 
behind the analytic 
area, but they remain 
geometric in nature.

Feature Graph Area Plane Geometry Area
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Creating an Object in the Graphing View
When you create an object in the Graphing View, it is an analytic object, 
and all points of the object reside on the graph plane. When you change 
the axes scale, you automatically affect the appearance of the object. If 
you calculate a value associated with the object such as the area, only 
generic units are assigned (u for unit). These objects remain associated 
with the coordinate plane until you delete them or redefine them to the 
plane geometry area. 

Note: When working with a modeling view work area (Plane Geometry 
view with analytic window), you cannot move an analytic object onto the 
plane geometry area.

Customizing the Work Area

Panning views
Panning lets you explore nearby objects, parts of graphs, or plots. 

8 Grab any empty space in the work area, and drag it.

The pointer changes to ù as you pan.

Note: Panning works in both the Graphing View and the Plane Geometry 
View. In Plane Geometry View with the Analytic Window shown, you can 
pan each view independently.

Showing/Hiding the Axes and Other Elements
In the Graphing View or in the Analytic Window in Plane Geometry View, 
You can selectively show or hide the axes, grid, entry line, and end values 
of the axes. You can show or hide the Scale indicator in any view.

Note: You can also hide or show the entry line by pressing / G.

8 From the View menu, select the elements that you want to show or 
hide. In this example, the lined grid is shown and the axes and entry 
line are hidden.
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Changing the Appearance of the Axes
The axes attributes tool lets you change display attributes such as end 
arrows, end values, tic mark labels, and zoom settings.

1. From the Actions menu, click Attributes.

2. Click either axis.

3. Press 9 and : to move to the desired attribute, and then press 
7 and 8 to choose the option to apply.

Zooming/Rescaling the Work Area
Use one of the following methods to change the scale of the Graphing 
View or the Analytic Window in Plane Geometry View.

8 From the Window/Zoom menu, select one of the Zoom tools 
(Zoom - Box, Zoom - In, or Zoom - Out), or select one of the 
predefined Zoom settings. The initial setting is Zoom - Standard.

8 Select an axis end value, press · to edit it, and type a new value.

8 Grab any tic mark on an axis, and drag it to rescale the view.

The aspect ratio of the axes is retained as you drag. To modify the 
scale of only one axis, hold g as you drag.

8 From the Window/Zoom menu, click Window Settings. In the 
Window Settings tool, type the end values XMin, XMax, YMin, or 
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YMax. To set custom spacing of the tic marks and grid, click the 
down arrow for XScale or YScale, and type a value.

Note: You can store an axis end value as a variable, and then access it 
outside of the Graphs & Geometry application. Select the end value in 

the work area, and then click  (or press h) to store the value. 

Inserting a Background Image
You can insert an image as a background for a Graphs & Geometry page. 
The file format of the image can be .bmp, .jpg, or .png.

1. From the Insert menu, click Image.

2. Navigate to the image you want to insert, select it, and then click 
Open.

The image is inserted as a background.

For more information, see Working with Images.

Default range and domain

Extended domain
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Adjusting Variable Values with a Slider
A slider lets you easily explore the effects of adjusting a numeric variable 
through a range of values. You can control a slider's location and visual 
appearance, and its adjustment range and step size.

Inserting a Slider
You can insert sliders on a Graphs page, a Geometry page, or a 
Data & Statistics page.

1. From the Actions menu, click Insert Slider. 

A gray image of a horizontal slider with default settings attaches 
itself to the pointer.

2. Drag to position the slider, and click to release it.

À Horizontal slider showing variable name, current value, and range

Á Vertical slider

Â Slider “thumb” that you can drag to adjust the current value of the 
variable

Ã Slider track

Ä Minimized sliders with arrows to adjust the variable’s current value
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3. Press · to accept the default name (such as V1), or type the name 

of a numeric variable that you want to assign, and then press ·.

Setting up the Slider
You can change many slider settings, such as Minimum and Maximum, by 
clicking parts of the slider. Some settings, such as Step Size, are accessible 
only through the Slider Settings dialog box.

1. Right-click in the slider to display its context menu, and click 
Settings to display the Slider Settings dialog box. 

Handheld: Point to the slider, press / b, and select Settings. 

2. Use the Slider Settings dialog box to enter settings for the slider. 
Each setting is described below. Settings that accept a numeric value 
also accept an expression that evaluates to a numeric value.

Variable — Specifies which variable is assigned to the slider. Type an 
available numeric variable name, or click the drop-down arrow and 
select a name from the list.

Value — Sets the current value of the variable.

Minimum — Sets the lowest value in the slider range (left or bottom 
end point on the track).

Maximum — Sets the highest value in the slider range (right or top 
end point on the track).

Step Size — Sets the size of the increment between values. The 
default setting is Automatic. To enter a specific size, click the drop-
down arrow, select Enter Size, and type a positive numeric value.

Style — Click the drop-down arrow to choose Horizontal or Vertical.

Display Digits — Specifies the display format of the variable’s 
current value. Choose Auto to display the value according to the 
Document Settings option. Click the drop-down arrow to choose 
from floating-point or fixed formats.

Show Variable — Shows or hides the variable name in the slider.
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Show Scale — Shows or hides the scale in a maximized slider.

Adjusting a Slider Variable’s Current Value
After setting up a slider, use one of these methods to adjust the current 
value:

• Grab the slider thumb ( or ) and drag it.

• Click the slider thumb, and then press 9, :, 7, or 8.

Tips:

– If you have a single horizontal slider on the Graphs & Geometry 
application having focus, you can press 7 or 8 anytime without 
first clicking the slider thumb.

– If you have a single vertical slider on the Graphs & Geometry 
application having focus, you can press 9 or : anytime without 
first clicking the slider thumb.

• Click after the “=” or press e as necessary to select the current 
value, and type a numeric value.

• Click a new position on the track.

Note: Any time the variable’s current value is outside the slider’s 
defined range, the thumb is not displayed. To bring the value inside 
the slider’s range, click the slider track or arrows.

Repositioning a Slider on the Page
1. Grab and drag any empty space in the slider’s selection rectangle.

—or—

Click an empty space in the slider.

2. Press 9, :, 7, or 8.

Minimizing a Slider
8 To minimize a slider and display only the variable name, current 

value, and direction arrows, access the slider’s context menu and 
select Minimize.

8 To further minimize a slider and show only the arrows, access its 
context menu and clear Show Variable.



Graphs & Geometry 387

Stretching a Slider
8 Grab the Minimum or Maximum end point on the track, and drag it.

Note: Stretching or shrinking a slider affects only the length of the 
track. The Minimum and Maximum values do not change.

Animating a Slider
An animated slider steps repeatedly through its range, using the slider’s 
Step Size.

8 Access the slider’s context menu and click Animate.

Note: To stop the animation, click Stop Animate. Animation also 
stops if you lock the slider’s associated variable.

Removing a Slider
Removing a slider does not delete the variable associated with the slider.

1. Click in the slider’s selection rectangle to select it.

2. Press ..

Tips for Using Sliders

Use Multiple Sliders for a Variable
• You can assign the same variable to multiple sliders. This lets you see 

the effect of adjusting a variable by different step sizes or through 
different ranges. 

Deselect a Slider

• To deselect a slider, click another part of the work area, press d, or 

press e e to move to another element in the work area.

Associate a Different Variable with a Slider
• Click the text box for the variable name and type the name of the 

numeric variable to use. 

• With the slider active, click  (or press h) to select a variable 
from the list.

Using the Trace Tools
Graphs & Geometry provides two trace tools:
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• Graph Trace - point-to-point trace of the graph for a function, 
parametric or polar equation, scatter plot, or sequence.

• Geometry Trace - trail of functions or objects.

For more information about using the Geometry Trace tool, see Using the 
Plane Geometry View.

Tracing a Graph or Plot
Graph Trace moves over the points of a graph or plot and displays value 
information. 

1. From the Trace menu, click Graph Trace:

2. (Optional) From the Trace menu, click Trace Step to change the step 
increment.

3. Use Graph Trace to explore a graph or plot in the following ways: 

– Move to a point and hover to move the trace cursor to that 
point.

– Press 7 or 8 to move the trace cursor from point to point and 
display the coordinates or values of each point.

– Press 9 or : to move from one graph to another. The point’s 
coordinates update to reflect the new location of the trace. The 
trace cursor is positioned on the point of the new graph or plot 
with the closest x value to the last point identified on the 
previously traced graph. You can trace multiple functions as 
described in Tracing All Graphs.

– Type a number and press · to move the trace cursor to that 
independent value on the graph or plot. 

– Create a persistent point that remains on the graph while in 
Graph Trace mode by pressing · when the trace point 
reaches the point you want to label.
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– Trace through and identify the points at which the graph has no 
defined value (a discontinuity) for a coordinate. The coordinate 
pair (x, undef) is displayed when you trace a point with an 
undefined x coordinate.

Notes: 

– When you select or trace a graph or plot on the work area, that 
relation is displayed on the entry line.

– When you trace beyond the initially visible graph, the screen 
pans to show the area being traced.

4. Exit Graph Trace by pressing d or by choosing another tool.

Tracing All Graphs
The Trace All tool works like Graph Trace, but allows tracing multiple 
functions simultaneously. With several functions graphed on the work 
area, perform the following steps:

Note: The Trace All tool traces only function graphs, not plots of other 
relations (polar, parametric, scatter, sequence).

1. Click Trace All from the Trace menu.

A vertical line indicates the x value of the trace and a trace point 
appears on each function graphed on the work area. 

2. Press 7 or 8 to move the trace point along each graph on the work 
area simultaneously. 

3. Exit Trace All by pressing d or by choosing another tool.

Working with Relations
The Graphs & Geometry entry line resides at the bottom of the work 
area. You can use it to specify multiple relations for each of several graph 
types. The default graph type is Function, so the form f1(x)= is displayed 
initially.

Note: The entry line is automatically hidden when you are not entering 
or editing relations. To show or hide it anytime, press / G.

Graphing a Relation
1. Select the type of relation you want to graph.
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– To graph a function, click Function on the Graph Entry/Edit 
menu.

The work area and entry line change to function mode. Type an 
expression for the function after the equal sign. 

– To graph an equation, click Equation on the Graph Entry/Edit 
menu, and select the type of equation (Line, Parabola, Circle, 
Ellipse, Hyperbola, or Conic).

Type the coefficients into the equation template.

– To graph a parametric equation, click Parametric on the 
Graph Entry/Edit menu. 

Type expressions for xn(t) and yn(t). Specifying alternate values 
for the default t-min, t-max, and t-step displayed is optional.

– To graph a polar equation, click Polar on the Graph Entry/Edit 
menu.

Type an expression for rn(q). Specifying alternate values for the 
default q-minimum and q-maximum, and q-step displayed is 
optional.

Function mode entry line

Entry line for y=ax2+bx+c parabola

Parametric mode entry line

Polar mode entry line
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– To graph a scatter plot, click Scatter Plot on the 
Graph Entry/Edit menu.

The work area and entry line change to scatter plot mode. Click 
var to choose a variable to plot as x and y for sn. You can also 
type the name of a variable that already exists, or define a list as 
comma-separated elements enclosed within brackets, for 
example: {1,2,3}.

– To plot a sequence, choose the type of sequence.

To plot a web plot or time plot of a sequence, click Sequence on 
the Graph Entry/Edit menu, and then click Sequence.

To plot a phase plot of a sequence, click Sequence on the 
Graph Entry/Edit menu and click Custom.

The work area and entry line change to show parameters 
needed for the selected sequence mode. Specify the parameters 
required for the plot type. You can use the Attributes tool to 
change between the Time plot and Web plot of a sequence.

2. Press · to graph the relation. 

When you press · to graph the expression, Graphs & Geometry 
hides the entry line and shows an uncluttered view of the graph. 

After you graph f1(x) and redisplay the entry line, the entry line displays 
f2(x)= to enable you to enter another function. If you select or trace a 
function, that function is displayed on the entry line.

Scatter Plot mode entry line

Sequence mode entry line

Sequence mode - Custom entry line
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As you graph multiple relations on the graph axes, Graphs & Geometry 
labels each, unless the Graphs & Geometry setting "Automatically hide 
plot labels" is checked. You can define and graph a maximum of 99 of 
each type. For example, you use function mode to specify functions 
(f1(x) - f99(x) ). You can rename relations using custom names, for 
example, g1(x). 

Displaying the Relation History
The relation history lets you view, edit, and delete graphed relations. 

For each problem, the history automatically stores relations, such as 
functions f1 through f99 and sequences u1 through u99. The relations 
can be defined:

• From the Graphs & Geometry entry line.

• From elsewhere in the problem, such as on a Calculator page.

• From expressions graphed using the Text tool.

To view the relation history:

1. Show the entry line (/ G), and then click the Expand Entry Line 

button  at the right of the line.

The history lists the relations in the order of entry (top to bottom). 

Note: The history also shows each relation’s line color along with 
buttons for showing/hiding the object  and changing its display 

attributes .

2. Use 9 and : to move up and down the list.

3. Press d to hide the history.
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Finding Points of Interest
You can use the tools on the Analyze Graph menu to find a point of 
interest in a specified range of a function graph. Choose a tool to find 
zeros, minimums, maximums, intersections, derivatives (dy/dx), or 
integrals. For Graphs defined as conic sections, you can also find foci, 
directrix, and other points.

Note (CAS): You can also find the point of inflection.

1. Click the point of interest on the Analyze Graph menu. For example, 
select Minimum to find the minimum point.

The icon for the selected tool is displayed at the top left on the work 
area. Point to the icon to view a tooltip about using the selected 
tool. 

2. Click the graph you want to search for the point of interest.

When you point to the plot, a dotted line is displayed for marking 
the part of the graph to search for the point of interest.

Notes:

– If you are finding the derivative, click the graph at the point at 
which you want to find the derivative.

– You can choose tools for finding points of interest from the 
context menu. If you select the Integral tool or the Derivative 
tool from the context menu with a function graph selected, that 
function is used for finding the point of interest.

3. Press 3 or 4 to move the dotted line to the lower bound of the search 
region. 

Note: You can also type a number to use as the lower bound for the 
search region and press ·. 

4. Press · to mark the lower bound for the search region. 

The tool shades the range. 

5. Repeat steps 3 and 4 to set the upper bound of the search region.

If the search region you specified includes the point of interest, a 
label for the point is displayed. If you change a graph that has points 
of interest identified, check for changes in points of interest. For 
example, if you edit the function on the entry line or manipulate a 
plot, the point where the graph intersects the y axis can change. 

You can exit the tool by pressing d or choosing another tool. The 
labeled points of interest remain visible on the graph.
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Specifying a Function with Domain Restrictions 
You can use the entry line or the Calculator application to specify a 
function with domain restrictions. For multiple domain restrictions on a 
function, use the piecewise function, piecewise().

In the following example, a function with a domain that is less than 2 
and greater than -2 is specified on the entry line:

1. Press / G to display the entry line.

2. Type piecewise(3, x > -2 and x < 2) on the entry line.

3. Press · to graph the function. 

Graphs & Geometry reformats the expression on the entry line and 
graphs the expression:

Graphing a Family of Functions
A family of functions differ by one or more parameters and can be 
specified with a single expression. To graph a family of functions: 

1. Type an expression for a family of functions on the entry line. To 
specify a family of functions:

– Specify the parameters as one expression for multiple functions 
using the format 
f1(x) = {-1,0,1,2} * x + {2,4,6,8} 
—or— 
f1(x) = m*x | m = {1,2,3}

– Enclose the lists of numbers or lists of variables in curly brackets. 
Specify parameters to graph a family of up to 16 functions. 
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For example, four functions are denoted with the expression: 
f1(x) = {-1,0,1,2} * x + {2,4,6,8}.

The first function to be evaluated is y = -1 * x + 2 and the second is 
0 * x + 4.

2. Press · to graph the family of functions specified. 

Graphs & Geometry creates and displays a separate graph object for 
each member of the family of functions. 

Each function is labeled (f1_1, f1_2) to indicate its sequence in the 
expression. You can select, analyze, or trace the graphs to explore 
them.

Note: Editing a single function graph to change it to a family of 
functions is not supported.

Creating a Time Plot or Web Plot Sequence
You can use the Sequence graphing mode to plot a time plot or web plot 
from the entry line.

• A Time plot plots n on the horizontal axis against the value of the 
sequence at each term, u1(n), on the vertical axis. A time plot is 
useful for identifying patterns in sequence values.

• A Web plot plots the sequence value for a preceding index, such as 
u1(n-1), on the horizontal axis against the value of the sequence for 
the current index, such as u1(n), on the vertical axis. A web plot is 
useful for analyzing the long-term behavior of a recursive sequence 
(as with a convergence or oscillation).

1. Specify the parameters required for the type of sequence plot you 
want:

– The u1(n)= expression field is where you enter or edit the 
sequence. Type the expression that defines the sequence. The 
term index, n is a series of consecutive integers that starts with 
zero or any positive integer. The sequence name can include 
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letters, numbers, and parentheses in the formats: u1, u1(n), u1(), 
myseq, myseq(n), or myseq(). If you type the sequence name in 
the format u1() or myseq(), the application automatically adds 
the n.

– The expression you type for a sequence can reference a variable 
assigned to work with a slider.

– The Initial Terms parameter is the first term to evaluate for a 
recursive sequence. If the sequence expression references more 
than one prior term, such as u1(n-1) and u1(n-2), you must type 
additional initial terms. Separate multiple terms with commas.

– The nStep range is the minimum index, maximum index, and the 
increment used for graphing.

For example, in the u1(n) field, type the expression 2*u1(n-1) + 1. No 
initial term or step range entry is required in this case.

2. After entering the parameters, press · to graph the sequence 
specified. 

The sequence plot includes a point for each term of the sequence. 

Note: If you plot a sequence and the variable used to specify it is 
later changed to another type (such as to a Function), the plotted 
sequence is automatically deleted.

3. Click the sequence graph and use Graphs & Geometry tools to 
explore the graphed sequence. 

– Click the sequence graph to see its expression and the label for 
the graph. 

– Animate a slider assigned to use a variable included in a 
sequence expression to observe changes in the plot. 

– Right-click the work area and click Graph Trace on the context 
menu to move through and highlight values for the sequence.
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Handheld: Press / b and select Graph Trace to move 
through and highlight values on the sequence graph.

– Press / T to display or hide a table of the values found while 
evaluating the sequences at consecutive integer values.

– Grab and drag the point that represents an initial term. As you 
drag the term, its value changes. The sequence definition on the 
entry line is updated automatically with the changes you make 
by manipulating a term. 

Creating a Custom Plot for a Sequence
A custom plot lets you show the relationship between two sequences by 
plotting one sequence on the x axis and the other on the y axis.

When you define a custom plot, you specify the variable names of two 
defined sequences (from the Graphs & Geometry application) and assign 
each to an axis. This section demonstrates how to create a custom plot 
using the Predator-Prey model from biology to determine the numbers 
of rabbits and foxes that maintain population equilibrium.

rabbit(n) = rabbit(n-1) * (1 +.05-.001 * fox(n-1))

fox(n) = fox(n-1) * (1 +.0002* rabbit(n-1) -.03), where:
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.05 = the growth rate of rabbits if there are no foxes,

.001 = the rate at which foxes can kill rabbits,

.0002 = the growth rate of foxes if there are rabbits,

.03 = and the death rate of foxes if there are no rabbits.

1. On the Graph Entry/Edit menu, click Sequence and click Sequence. 
Use the model equation to define rabbit and fox sequences over a 
cycle of 400 generations. Assume that there are 200 rabbits and 50 
foxes initially. 

Note: For a less cluttered view, click Hide/Show on the Actions 
menu to hide the rabbit(n) and fox(n) sequences on the work area.

2. On the Graph Type menu, click Sequence and click Custom.

3. Type rabbit(n) as the x-axis sequence, and then press e and type 
fox(n)as the y-axis sequence. 

Note: You can also click  (or press h) to choose the name of a 
previously defined sequence, or specify the name of a new sequence 
that you can define later.

4. Press e to move to the next line, and set the nstep and the range 
for n. For this example, n is set between 1 and 400 and the nstep is 
the default value, 1.

5. Press · to create the custom plot. 

Note: Click Zoom - Fit on the Window/Zoom menu to adjust the 
window settings.
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6. Explore the custom plot by grabbing and dragging the point that 
represents the initial term. 

As you drag the point, its value changes and the rabbit and fox initial 
terms are automatically updated.

 

In this example, manipulating the initial term demonstrates that the 
point of equilibrium in the rabbit and fox populations over the cycle 
of 400 generations = (150, 50).

Graphing Differential Equations
You can study linear and non-linear differential equations and systems of 
ordinary differential equations (ODEs), including logistic models and  
Lotka-Volterra equations (predator-prey models). You can also plot slope 
and direction fields with interactive implementations of Euler and 
Runge-Kutta methods.
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To Graph a Differential Equation:
1. On the Graph Entry/Edit menu, click Diff Eq.

The entry line displays an ODE edit field for defining the next 
available ODE. The ODE is automatically assigned an identifier, such 
as “y1.”

Note: You can type a replacement identifier and then use that 
identifier in the relation on the right side of the “=” symbol.

À Slope field

Á A solution curve passing through the intitial condition

Â ODE editor:

• Check box for designating this ODE as active or inactive

• y1 ODE identifier

• Expression k·y1 defines the relation

• Fields (1,1) for specifying initial condition

• Buttons for adding initial conditions and setting plot 
parameters

Ã Slider to control coefficient k of the ODE
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2. Move to the relation field and enter the expression that defines the 
relation. For example, you might enter -y1+0.1*y1*y2.

3. Enter the initial condition for the independent value x0 and for y10.

Notes: 

– The x0 value(s) are common to all the ODEs in a problem but can 
be entered or modified only in the first ODE. They are displayed 
as non-editable for the other ODEs.

– You can delete an existing initial condition by clearing its x0 and 
y0 fields.

4. If you want to study multiple initial conditions for the current ODE, 

click the Add Initial Condition button  and enter the conditions.

5. Click the Edit Parameters button  to view or set the plot 
parameters.

6. See the summary of settings following this procedure. Select a 
numerical Solution Method and any additional plot parameters. You 
can change these parameters as needed.



402 Graphs & Geometry

7. Click OK.

8. To enter additional ODEs, press the down arrow to display the next 
ODE edit field.

When you press · or press the up or down arrow keys to move 
among ODEs that you have defined, the graph is updated to reflect 
any changes. One solution to the ODE is graphed for each IC 
specified for each active ODE (selected by check box).

Summary of Differential Equation Settings

Solution Method Selects Euler or Runge-Kutta as the numerical 
solution method.

Iterations Between 
Plot Step

Computational accuracy for Euler solution 
method only. Must be an integer value >0. To 
restore the default, select the down-arrow and 
select Default.

Error Tolerance Computational accuracy for Runge-Kutta 
solution method only. Must be a floating-point 

value |1×10-14. To restore the default, select 
the down-arrow and select Default.

Field None - No field is plotted. Available for any 
number of ODEs, but required if three or more 
1st-order ODEs are active. Graphs a 
combination of the solution and/or values of 
one or more ODEs (according to user-
configured Axes settings).

Slope - Plots a field representing the family of 
solutions to a single 1st-order ODE. Exactly one 
ODE must be active. Sets Axes to 
Default (x and y). Sets Horizontal axis to x (the 
independent variable). Sets Vertical axis to y 
(the solution to the ODE).

Direction - Graphs a field in the phase plane 
representing the relationship between a 
solution and/or values of a system of two 
1st-order ODEs (as specified by the Custom 
Axes setting). Exactly two ODEs must be active.
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Graphing Conic Sections
The Graphing view lets you graph and explore linear and conic equations 
analytically in a two-dimensional coordinate system. You can create and 
analyze lines, circles, ellipses, parabolas, hyperbolas, and general conic 
equations.

The entry line makes it easy to enter the equation by displaying a 
template for the type of equation you choose. 

Example: Exploring an ellipse
1. On the Graph Entry/Edit menu, click Equation > Ellipse, and click 

the equation.

The entry line displays the template.

Axes Default (x and y) - Plots x on the x axis and y 
(the solutions to the active differential 
equations) on the y axis.

Custom - Lets you select the values to be 
plotted on the x and y axes respectively. Valid 
entries include:

• x (the independent variable)

• y1, y2, and any identifiers defined in the 
ODE editor

• y1’, y2’, and any derivatives defined in the 
ODE editor

Plot Start Sets the independent variable value at which 
the solution plot starts.

Plot End Sets the independent variable value at which 
the solution plot stops.

Plot Step Sets the increment of the independent variable 
at which values are plotted.

Field Resolution Sets the number of columns of field rendering 
elements (line segments) used to draw a slope 
or direction field. You can change this 
parameter only if Field = Direction or Slope.

Direction Field at x= Sets the independent variable value at which a 
direction field is drawn when plotting non-
autonomous equations (those that refer to x). 
Ignored when plotting autonomous equations. 
You can change this parameter only if Field = 
Direction.
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2. Type initial values for the coefficents in the provided spaces. Use the 
arrow keys to move among the coefficients.

3. Press · to graph the equation.

4. Drag the ellipse from its center to explore the effect of translation 
on the equation.

5. Use the analysis tools, such as Analyze Graph > 
Analyze Conics > Foci to further explore the graph.

Note: The type of conic determines which analysis tools you can use. 
In the case of the ellipse, you can obtain its center, vertices, foci, axes 
of symmetry, directrices, eccentricity, and latera recta.
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6. To explore both translation and dilation, define an ellipse that uses 
variables for the h, k, a, and b coefficients. Insert sliders to vary the 
parameters.

Using the Text Tool to Graph Equations
You can graph an "x=" or "y=" equation by typing it into a text box and 
dragging the text to an axis.

When you drop the text, Graphs & Geometry graphs the equation and 
adds it to the top of the function history. You can edit the equation (for 
example, change it to an inequality), but you cannot change it between 
x= and y=.

Graphing a Trigonometry Function from Text
1. From the Actions menu, click Text.

2. Click the work area to place the text box, and then type the equation 
you want to graph. 
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3. Drag the text, and drop it on an axis.

Graphing a Vertical or Horizontal Line from Text
1. Create a text box, and type an equation for a vertical line, such as 

x=4, or a horizontal line, such as y=3. 

2. Drag the text to an axis. 

After plotting a line, you can drag to translate or rotate it, or pin it 
to use it as a fixed reference.

Graphing an Inequality from Text
You can graph inequalities that use the >, <, {, or | operators. Areas that 
satisfy the inequality are shown with shading. If the shaded areas of two 
or more inequalities overlap, the area of overlap is shaded darker.
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1. Create a text box, and type the inequality expression, such as 
x<2*sin(y).

Note: To express { or |, you can type <= or >=, or select the operator 
from the Symbol Palette.

2. Drag the text to an axis. 

Renaming f(x)
The default naming convention for functions is fn(x). (The number 
represented by n increases as you specify more functions.) You can 
replace the default name with a name of your choice.

1. Place your cursor to the right of the = sign in the entry line.

2. Select the default characters.

3. Type the letters/numbers for the system you want to use, and then 
type the function that you want to graph. 

4. Press · to graph the function. 

Notice that the label shown next to the graph is identical to what 
you entered.
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Note: To continue the custom naming convention, you must 
manually rename each function as you enter it.

Editing Relations
1. From the Graph Entry/Edit menu, click the graph’s type, such as 

Function.

The entry line for the selected graph type appears.

2. Use the up/down arrow keys to step through the relation history and 
select the graph.

3. Modify the expression as needed.

4. Press · to graph the revised function.
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Hiding a Function on the Work Area
1. From the Actions menu, click Hide/Show.

The Hide/Show tool icon is displayed at the top of the work area.

2. Click the graph of any functions that you want to hide. You can also 
click any other type of object that you want to hide.

Objects you click while the tool is active appear dimmed.

3. Press d to exit the Hide/Show tool. 

The hidden function disappears. To redisplay hidden objects, repeat 
these steps. 
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Deleting a Function
1. Select the function by clicking its graph. 

2. Delete the function by pressing Backspace or ..

The function is removed from the work area and from the list of 
graphed functions. 

Manipulating Functions
Some functions allow you to translate, stretch, and/or rotate them by 
grabbing and manipulating the graph.

8 From the Actions menu, click Pointer, and then move to the graph 
that you want to manipulate. 

The pointer changes to indicate supported manipulation (for 
example, to õ , ö, or é) when you hover on a graphed function that 
you can grab and manipulate. 

As you change the graph, the expression for the graph updates to 
reflect changes. You can manipulate the following types of 
functions:

• Linear function; y=b, x=b

• Linear function; y=ax+b, x=ay+b

• Quadratic function; y=a(x-b)2+c, x=a(y-b)2+c

• Quadratic function; y=ax2+bx+c, x=ay2+by+c

• Exponential function; y=exp(ax+b)+c, x=exp(ay+b)+c

• Exponential function; y=b*exp(ax)+c, x=b*exp(ay)+c

• Exponential function; y=d*exp(ax+b)+c, x=d*exp(ay+b)+c

• Logarithmic function; y=a*ln(cx+b)+d, x=a*ln(cy+b)+d

• Sinusoidal function; y=a*sin(cx+b)+d, x=a*sin(cy+b)+d

• Cosinusoidal function; y=a*cos(cx+b)+d, x=a*cos(cy+b)+d

Manipulating a Linear Function 
8 To translate, grab near the middle of the graph, and then drag.
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8 To rotate, grab near the ends of the graph, and then drag.

Manipulating a Quadratic Function 
8 To translate, grab near the vertex of the graph, and then drag.

8 To stretch, grab away from the vertex of the graph, and then drag.
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Manipulating a Sine or Cosine Function 
8 To translate, grab near the axis of vertical symmetry of the graph, 

and then drag.

8 To stretch, grab away from the axis of vertical symmetry of the 
graph, and then drag.

Finding the Derivative at a Point (the Slope)
This method uses the Analyze Graph menu. Alternatively, you could 
create a tangent on the graph to help visualize the slope and then use 
the Measurement menu to measure it.

1. From the Analyze Graph menu, click dy/dx. 
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2. Click the point on the graph at which you want to find the 
derivative.

The value of the derivative at the selected point is displayed on the 
graph.

Note: To find the derivative at a specific value of x or y, use the 
context menu of the point to show its coordinates, and then edit the 
x or y coordinate.

Viewing Function Tables
You can show a table of function values for any function in the current 
problem. 

While viewing the table, you can change the settings for the table, 
delete columns, add values for multiple functions, and edit the 
expression that defines a function. For more information, see Using Lists 
& Spreadsheet.

Showing the Table
8 From the Table menu, click Split-screen Table.

The table is displayed with columns of values for the currently 
defined functions.

At the top of each column, you can choose the function to display in 
the column.
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Hiding the Table
8 From the Table menu, click Remove Table.

Using the Plane Geometry View
The plane geometry view includes a scale by default, but includes no axes 
or entry line on the work area. 

8 Change to Plane Geometry View from the View menu by selecting 
Plane Geometry.

The work area refreshes to clear the axes and entry line and display a 
default scale. Any graphs or drawings created in Graphing View are 
not displayed on the plane geometry area. 

Note: To show geometric constructions created in the Plane 
Geometry View together with previously created graphs, select 
View > Show Analytic Window or switch to the Graphing View 
(View > Graphing).

Creating an Object in Plane Geometry View
You can choose Geometry on an empty page of a document to work in 
Plane Geometry View. The shapes, points, and lines you create while in 
this view are geometric objects. Geometric objects can have an assigned 
scale, such as centimeters, instead of u for units (as used with Graphing 
View). 

When working in modeling mode (that is, in Plane Geometry View with 
an analytic window), you can move a geometric object into the graphing 
work area. The object remains a geometric object, and is not associated 
with the axes. For example, you can move a vertex of a triangle, but 
because the object is not tied to a coordinate plane, no coordinates are 
displayed for the vertex.

The examples below show a modeling work area and the two types of 
objects: A is an analytic object while B is a geometric object.
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Although the two circles appear to be identical, they do not behave in 
the same way. Analytic objects are affected when the graph area is 
altered. In the next example, the axes were altered. Notice that only 
Circle A’s appearance is affected by the change. 

If you create an object with the axis hidden, the object is a geometric 
object. However, if you create an analytic object and later hide the axis, 
the object remains an analytical one.

Triangle as it appears in Graphing View. The unlabeled vertex 
remains a geometric point.
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Using the Analytic Window
The analytic (graphing) window is available in the Plane Geometry View. 
It adds an analytic (graphing) window on top of a portion of the plane 
geometry work area. This provides a combination work area that enables 
you to use both work area types without having to change the view. 

1. Confirm that the work area is in Plane Geometry View. 

2. From the View menu, click Show Analytic Window.

A small graphing window opens on the lower left corner of the 
plane geometry work area. For more information, see Working with 
Relations.

3. Use the modeling view to work with analytic and geometric objects. 
You can perform the following actions:

– Use the View menu to show or hide the axes, axes end values, 
and scale.

– Use the View menu to hide the grid or to show it as a dotted or 
lined grid.

– Rescale the axes by using the Window > Zoom tools or by 
dragging tic marks.

– Grab an empty area of the screen and drag it to pan through the 
work area.

4. Select Hide Analytic Window to remove the analytic window from 
the work area.

Working with Cabri™ II Plus Files
You can open Cabri™ II Plus Figures (.fig) files in the Graphs & Geometry 
application. Each .fig file converts to one Graphs & Geometry page with 
converted figures and one Notes page with conversion messages.

Modeling view - shows the previous two views and 
the work done on both.

Graphing area

Plane Geometry 
area
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Opening a Cabri™ II Plus File
To open a Cabri™ II Plus figures (.fig) file:

1. From the File menu, click Open Document. 

2. On the Open TI Nspire Document dialog box, click Files of Type 
and choose Cabri™ II Plus Figures (*.fig). 

3. Click the .fig file that you want to open, and click Open. 

Using Geometry Trace
The Geometry Trace tool enables you to leave a visible trail of an object 
when it is moved on the work area. The movement can be done manually 
or by using the Animation tool. 

Note: The trace trail cannot be selected or manipulated.

1. Create an object or function. 

2. From the Trace menu, click Geometry Trace.

3. Click the object or function and manually grab and move the object, 
or select a point and use the Attributes tool to set animation. 

If you use animation, the point must be selected for Geometry Trace 
as well as animation. For more information, see Changing an 
Attribute of an Object.

4. Observe the Geometry Trace results. 

In the following example, a line segment was drawn and selected for 
Geometry Trace. Movement of the segment was done manually. 

The amount of trace track displayed on the work area depends upon 
the amount of movement. 

• If the object moves very little, the entire track remains displayed 
until you erase it. 
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• If the object moves a lot, the track can obscure a significant 
portion of the work area. In this case, the older portions of the 
track fade out to prevent the work area from becoming 
obscured by the track. 

Erasing Geometry Trace
The easiest way to remove the trace tracks from the work area is to select 
the Erase Geometry Trace tool.

8 From the Trace menu, click Erase Geometry Trace.

When selected, this tool removes immediately all trace tracks from 
the work area. 

Grouping Objects

You can group objects on the work area to maintain the positioning of 
the objects and to perform certain actions on all of the objects in the 
group. You can drag and move the objects in a group. 

1. Select the objects to group. 

Note: Do not include pinned objects if you plan to move the group. 
Including a pinned object in a group creates a pinned group.

For more information, see Selecting Objects with the Pointer Tool or 
Selecting Objects with the Select Tool.

2. With selected objects flashing, click Group from the context menu. 

Handheld: Press / b.

Windows®: Right-click a selected object in the group.

Mac®: Press and hold “ and click the group.

The objects are grouped on the work area. When you hover over or 
click an object in the group of objects, the label “group” is displayed. 
You can ungroup the objects by clicking any object in the group and 
selecting Ungroup from the context menu.

Pinning Objects
You can pin points, shapes, angles, values, text, graphed functions, the 
axes, and the work area background to prevent accidental moves as you 
manipulate other objects on the work area. 

1. Select one or more objects to pin. 

For more information, see Selecting Objects with the Pointer tool or 
Selecting Objects with the Select tool.

2. Click Pin on the context menu. 
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Handheld: Press / b.

Windows®: Right-click the object.

Mac®: Press and hold “ and click the object.

Pinned objects are labeled with the object type (“circle” or “axes”) 
and display a pin  icon. You can select the object and click Unpin 
from the context menu to return the object to its original state. 

Notes:

– The work area does not display a label when pinned. You cannot 
grab the work area to pan the view if the work area is pinned. 

– Pinning an object to another object does not prevent 
manipulation of the “pinned-to” object. For example, a point 
pinned to a graphed function does not prevent manipulation of 
the graphed function.

– You can still edit a pinned object in some cases. For example, you 
can edit the x and y coordinates of a pinned point. The point can 
move to reflect an edit of values, but not in response to 
manipulation.

– For an object that includes a Lock attribute, locking is disabled 
after you pin the object. 

– When you point to a pinned object, the pointer does not change 
to one that allows translation or grab-and-drag actions.

Working with Points and Lines
Use the Points & Lines tools on the Geometry menu to draw the 
following types of points and lines. Point and line tools also let you 
name, label, or redefine points. 

• Points: Point, Point on, Intersection point(s)

• Lines

• Segments

• Rays

• Tangent

• Vectors

• Circle arcs

Working with Points
There are three tools for creating points:

• Point
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• Point On

• Intersection Point

Creating a Point
You can create a point using the Point tool. Create a point on the work 
area, or on an object such as a graph or shape.

1. From the Points and Lines menu, click Point.

2. Move to the work area, and click to create a point. 

3. Work with the point using the Pointer tool from the Actions menu. 

For example, click the point using the Pointer tool and drag it to 
move it. 

Notes:

• A point that is pinned displays the pin icon and is not movable.

• You can also create a point by typing an opening parenthesis and 
comma-separated coordinates. For example, activate the Point tool, 
type (3,5), and then press · to create a point with abscissa 3 and 
ordinate 5.

Creating a Point on an Object 
1. From the Points and Lines menu, click Point On.

2. Click on the object you want to create a specific point on, and then 
click to place the point. 
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3. Work with the point using the Pointer tool from the Actions menu. 

For example, use the Attributes tool from the Actions menu to 
animate the point on the object.

Defining Points of Intersection 
Use this tool to find points at which two objects intersect. 

1. From the Points and Lines menu, click Intersection Point(s).

2. Click each object to find points of intersection. 

Graphs & Geometry adds a point at each intersection.

Labeling (Identifying) the Coordinates of a Point
You can identify the coordinates of any analytic point using the 
Coordinates and Equations tool. 

Note: An analytic point is one created in the Graphing View, or within 
the analytic window of the Plane Geometry View.

1. Create a point. 

You can also create a point on an object using the Point On tool.

2. From the Actions menu, click Coordinates and Equations. 

3. Move the pointer toward the point’s location. The coordinates are 
displayed. 

4. Click to select the point. The point blinks to indicate selection.

5. Move to the place where you want to anchor the point coordinates 
and press ·. 
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If you move the point to a different location, the new coordinates 
are updated to the new position. 

Naming a Point 
You can name points and vertices in either the Graphing or Plane 
Geometry view. Because they are not tied to a specific coordinate, names 
remain unchanged if you alter the location of any portion of an object. 

1. Right-click the item to display its context menu, and click Label. 

Handheld: Hover over the point, press / b, and select Label. 

2. Type the name for the point in the text box.

(Optional) You can name a point as you create it by typing a letter or 
name immediately after you define the point. For example, when 
creating a triangle, type the letter “x” after creating the first vertex. 
Type “y” and “z”for the remaining two vertices as you create them.
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Redefining a Point
You can redefine a point from a point on the work area to an object, 
from one object to another, or from the analytic window to the Plane 
Geometry View work area (or from the geometric work area to the 
analytic window). 

1. Create a point, or decide which existing point you want to redefine. 

2. From the Actions menu, click the Redefine tool. 

3. Click the point you want to redefine, and then click the object or 
work area at the location for the redefinition.

The point moves to the object or new location. 

 

Working with Linear Objects
The linear objects you can create and explore are located on the 
Geometry > Points & Lines menu. Graphs & Geometry creates “smart” 
lines and rays. This means that only a portion of the line or ray is 
displayed. This feature reduces clutter on the work area. 

Creating a Line 
1. From the Points and Lines menu, click Line. 

2. Click a location to start the line. 

This click defines one point on the line. 

Note: If you press and hold g while creating the line, you limit its 
orientation (relative to the x-axis or the horizontal aspect of the 
screen), by 15- increments. 
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3. Move and click again to define the direction and second point of the 
line. 

Graphs & Geometry draws the line.

Creating a Ray
1. From the Points and Lines menu, click Ray. 

2. Click to define the endpoint of the ray. 

Note: If you press and hold g while while creating the ray, you 
limit its orientation, relative to the x-axis or the horizontal aspect of 
the screen, by 15- increments.

3. Move the pointer and click again to define the direction of the ray.

Graphs & Geometry draws the ray. 

Lengthening the Visible Part of a Line or Ray
1. On the Actions  menu, click Pointer.

2. Grab the end of the visible line or ray, and drag to lengthen or 
shorten it.

Creating a Segment
1. From the Points and Lines menu, click Segment.
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2. Click to define the first endpoint of the segment. 

Note: If you press and hold g while creating the segment, you 
limit its orientation (relative to the x-axis or the horizontal aspect of 
the screen), by 15- increments. 

3. Move the pointer and click again to define the second endpoint of 
the segment. 

Graphs & Geometry draws the segment on the page.

Creating a Segment with a Defined Midpoint
With the Midpoint tool, you can define a midpoint on an existing line 
segment, between two specified points on a line, or between two points 
as you create the points. When you select the second point, the midpoint 
is created.

1. From the Construction menu, click Midpoint.

2. Click at the location to start the segment. 

As you move the pointer, a second point, the midpoint, appears. 

3. You can move the segment in any direction until you click on the 
work area a second time. 

With the second click, the segment is anchored and the midpoint 
remains identified. 

4. If you are defining the midpoint of a segment that already exists, 
click the segment. 

The midpoint is created.

Modifying Segments with Midpoints
1. On the Actions  menu, click Pointer.

2. Select the segment and drag it to a new location without changing 
its orientation or length, or select one endpoint and drag it to a new 
location. 

If just an endpoint is moved and if the length of the segment 
changes, the midpoint is repositioned to remain at the middle of the 
segment.

Creating a Parallel Line
You can create a parallel line with respect to any existing line on the 
work area including the axes, and the side of any triangle, square, 
rectangle and polygon. 

1. From the Construction menu, click Parallel.

2. On the work area, click once on an existing line, segment, or axis.
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This click identifies the reference line for the new parallel line you 
are creating.

3. Move the pointer away from the reference line, axis, or segment.

Notice that a dotted line is displayed, representing the parallel line.

4. When the dotted line is in the desired position, click again to anchor 
it on the work area.

Note: You can also click first on the work area, and then select the 
reference line to create the parallel line.

Creating a Perpendicular Line
You can create a perpendicular line with respect to any existing line or 
segment in the work area including the axes, and the side of any 
triangle, square, rectangle, or polygon. 

1. From the Construction menu, click Perpendicular.

Parallel line following the pointer

Anchored parallel line
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2. Click a point on the work area through which the perpendicular line 
should pass. A dotted line shows the position for the perpendicular 
line.

3. Click again to anchor the perpendicular line. The dotted line changes 
to a solid line.

Note: Alternatively, you can double-click the line or segment to 
create at the point where you want the perpendicular line to 
intersect.

4. (Optional) On the Actions menu, click the Pointer for moving the 
perpendicular line to a different location on the reference line.

5. (Optional) Click the intersection point and drag the point and 
perpendicular line to the new location. 

Creating a Vector
1. From the Points and Lines menu, click Vector.

2. On the work area, click the spot from which the vector originates.

3. Move the pointer in the direction of the vector. 

Perpendicular line before anchoring to 
page

Anchored perpendicular line
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A dotted line follows the pointer.

4. When the vector is in the correct position, click to anchor the vector 
on the work area. 

The dotted line changes to a solid line. 

Moving a Vector 
1. From the Actions menu, click Pointer.

2. Click on any point other than the endpoint and drag the vector to 
the desired location. 

Resizing a Vector
8 Select an end point and drag it to increase or decrease the 

magnitude of the vector. 

Note: If the endpoint is located on an axis or another object, you can 
only move the endpoint of the vector along that object. 

Creating a Tangent
You can create a tangent by identifying a specific point on an existing 
object or function. To create a tangent line:

1. From the Points and Lines menu, click Tangent.

2. On the work area, select the point at which you want the tangent 
drawn. 

A dotted tangent line blinks on the work area.

Vector following the pointer after identification of 
the endpoint
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3. Press · to anchor the tangent on the work area.

Creating a Circle Arc
1. Click once on the work area to establish the first point of the arc.

2. Move in the direction you want the arc to take, and click the work 
area again to establish the second point.

3. Move away from the second point to establish the length of the 
circle arc, and click the work area a third time.

The arc is displayed. 

Creating and Working with Shapes
You can use the Shape tools to construct many different geometric 
shapes, including geometric conics.

• Circles

• Triangles

• Rectangles

• Polygons

• Regular Polygons

• Ellipse

• Parabola

• Hyperbola

• Conic by Five Points

When you use a shape tool, the pointer becomes a pencil. As you create 
any shape that includes a linear portion (for example a ray, segment, or 
triangle), you can enable custom alignment.

Tangent of an object
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• Align a linear portion of the shape to either the horizontal or the 
vertical axis. 

• Press g to orient the linear portion of a shape in 15 degree 
increments relative to the x axis.

For precise shape definition, you can type the coordinates of a shape’s 
defining points in parentheses instead of clicking. For example, to create 
a circle with a center point at (-1,4) type (-1,4) when prompted for the 
center point.

Creating a Shape
1. From the Shapes menu, click the tool for the shape you want to 

draw. 

The pointer is displayed as a pencil to indicate that the Shape tool is 
active. You can hover over the icon for the tool to view tips for 
drawing a shape.

2. Move the pointer to the location of your choice on the work area. 

3. Click once to establish the first point of the shape.

Note: You can press the keys to affect the sizing of some shapes as 
you draw them. For example, if you press and hold g while 
creating a circle, the radius is limited in length to integers. 

4. Move the pointer away from the first point as required to position 
the second point of the shape. 

The direction and movement of the pointer can establish height, 
orientation, or angles for a shape. A dimmed representation of the 
shape or a partial shape is displayed to guide you.

5. Click the work area again to establish the second point or complete 
the shape. You will need to move and position the pointer as many 
times as required for the shape you are drawing. 

You can move the pointer to the shape tool icon at the top of the 
work area to read tips for creating a shape.

6. When all points or angles are in position, press · to complete the 

shape. When you have finished using the shape tool, press d to 
close it.

You can perform actions to explore the shapes you draw. For 
example, you can move a shape around the work area, resize it, 
change its attributes, and pin it to the work area or an axis. You can 
explore and analyze shapes using tools such as the measurement or 
transformation tools.
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Circle
1. Click the work area to position the circle’s center point. 

2. Move outward from the center point to size the circle.

A dotted circumference is displayed.

3. Click the work area to complete the circle.

Triangle
1. On the work area, click once to establish the first vertex of the 

triangle. 

2. Move to the location for the second vertex and click the work area a 
second time.

The side of the triangle is displayed as a dotted line.

3. Move to the location for the last vertex. As you move, all sides of the 
triangle are shown as dotted lines. 

4. Click the work area a third time to create the final vertex and 
complete the triangle.

The sides are defined by solid lines.

Rectangle 
1. Click once to establish the first corner of the rectangle. 

2. Move to the location for the second corner, and click again.

One side of the rectangle is displayed.

3. Move away from the side of the rectangle. Move in the direction 
that corresponds to the rectangle orientation of your choice.

The outline of the rectangle appears on the work area. 

4. When the rectangle is the correct size, click again to anchor the 
rectangle to the work area.

Polygon
1. On the work area, click once to establish the first point of the 

polygon. 

2. Move to the location for the second point and click the work area a 
second time.

The side of the polygon is shown as a dotted line.

3. Move to the location of the next point. As you move the pointer, the 
polygon’s sides are displayed as dotted lines.

4. Continue to move and click the work area to create as many sides as 
needed.
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5. Click twice to create the last side and complete the polygon.

The sides are displayed as solid lines.

Regular Polygon
1. Click once on the work area to establish the center point of the 

regular polygon.

2. Move the pointer away from the center point and click on the work 
area again to establish the first vertex and radius.

A 16-sided regular polygon is formed. The number of sides is 
displayed near the center point in brackets; for example, {16}. 

– To reduce the number of sides, select a vertex and move the 
pointer in a clockwise motion around the perimeter of the 
polygon.

– To increase the number, select a vertex and move the pointer in 
a counter-clockwise motion. 

The number of sides of the polygon is displayed as you move the 
pointer. 

3. Press ·.

Ellipse
1. On the work area, click a location to establish the first focus.

2. Click another location to establish the second focus.

3. Move the pointer away from the foci.

As you move the pointer, the ellipse is displayed as a dotted line.

4. Click to complete the ellipse.

Parabola (from focus and vertex)
1. On the work area, click a location to establish the focus.

2. Move the pointer away from the focus.

As you move the pointer, the parabola is displayed as a dotted line.
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3. Click to anchor the vertex and complete the parabola.

Parabola (from focus and directrix)
1. From the Geometry Points and Lines menu, select Line, and create a 

line to serve as the directrix.

2. From the Geometry Shapes menu, select Parabola.

3. On the work area, click a location to establish the focus.

4. Move the pointer to the directrix.

5. Click to complete the parabola.

Hyperbola
1. On the work area, click a location to establish the first focus.

2. Click another location to establish the second focus.

3. Move the pointer away from the foci.

As you move the pointer, the hyperbola is displayed as a dotted line.

4. Click to complete the hyperbola.

Conic by Five Points
1. On the work area, click four locations to establish each of the first 

four points on the shape.

2. Move the pointer away from the points.
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As you move the pointer, the shape is displayed as a dotted line. 
Depending on the pattern of the points, the shape can be a 
hyperbola or an ellipse.

3. Click to add the fifth point and complete the shape.

Sizing and Positioning Shapes
1. From the Actions menu, click Pointer.

2. Hover over a shape to change the pointer to ÷. You can drag a 
circle’s perimeter to resize it, or drag a point to resize a polygon, 
rectangle, or triangle. 

3. Click and hold the selected area to change the pointer to { . 

4. Drag to resize the selection. 

5. Move a shape by grabbing and dragging the center point (circle) or a 
side (triangle, rectangle, or polygon).

Displaying the Equation of a Geometric Object
You can display the equation of a line, tangent line, circle shape, or 
geometric conic, provided the object was constructed in the Graphing 
View or within the Analytic Window of the Plane Geometry View. 

Note: Due to differences in the numerical representations of analytic 
and geometric conics,  the capability to convert a geometric conic to an 
analytic template may sometimes be unavailable. This is done in order to 
avoid a situation where the template-based conic would be different 
from the geometric one.

1. From the Actions menu, click Coordinates and Equations. 

2. Move the pointer to the object.

The equation for the object appears.

Note: If you approach a defined point on the line or the center point 
of a circle, the coordinates of that point are displayed instead of the 
equation. Move the pointer away from the defined point to obtain 
the equation of the object.

3. Click to attach the equation to the pointer. 

4. Move the equation to the desired location, and click to anchor it.
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5. Press d to exit the tool.

Transferring an Equation to the Entry Line
After displaying the equation of a circle or a geometric conic, you can 
transfer the equation to a conic template on the entry line. From there, 
you can copy the equation to the Clipboard or create an analytic object 
based on the equation.

1. If necessary, use the Coordinates and Equations tool to display the 
object’s equation.

2. On the context menu for the equation text, click Transfer Equation 
to Conic Template.

The entry line appears, showing the applicable conic template 
populated with coefficients from the equation.
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3. Select the text and copy it to the Clipboard, or edit the equation and 
press · to create an analytic object.

Measuring Objects 
You can obtain various measurements from the objects you draw. These 
measurements include finding areas, lengths, angles, and slopes.

Measurement values are dynamic. If you measure sides and angles of a 
triangle, for example, and then alter the triangle, the measurement 
values update automatically.

To change the displayed precision of an area, length, angle, or slope 
measurement, point to it and then press + or -.

Measuring Length
You can use the Length tool to measure the length of a segment, circle 
arc, or vector. The length tool can also measure the side or perimeter of a 
polygon, the circumference of a circle, the distance between two points, 
the distance from a point to a line, ray, segment, or vector, and the 
distance from a point to a circle. 

Note: Measurements made on Graphing View objects and lines have 
generic units, u. Measurements made on Plane Geometry View objects 
and lines have the unit value you create. The default unit value is 
centimeters (cm).

Measuring Length of a Segment, Circle Arc, or Vector
1. From the Measurement menu, click Length.

2. Click the object to select it.

The object blinks.

3. Press · to anchor the measurement on the work area. Note that a 
line segment can be part of a triangle, rectangle, or polygon.



Graphs & Geometry 437

Measuring Distance Between Two Points, a Point and a 
Line, or a Point and a Circle 
1. From the Measurement menu, click Length.

2. Select the first point. 

3. Select the second point or a point on the line or circle. 

The selected length blinks. 

4. Click or press · to anchor the value on the work area.

Finding the Circumference of a Circle or Ellipse or the 
Perimeter of a Polygon, Rectangle, or Triangle
1. From the Measurement menu, click Length.

2. Click the object to measure its circumference or perimeter.

In this example, length is measured from 
the center of the circle to the upper left 
vertex of the polygon.
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3. Press · to anchor the measured value on the work area.

Measuring One Side of a Triangle, Rectangle, or Polygon 
1. From the Measurement menu, click Length.

2. Point to the side that you want to measure.

Initially, the perimeter of the object is displayed, along with a visual 
reminder that you can use e to measure the side instead.

3. Press e to display the length of the side, and click to attach it to 
the pointer.

4. Position the measurement, and press · to anchor it on the work 
area. 

Finding the Area of a Circle, Ellipse, Polygon, Rectangle, or 
Triangle
1. From the Measurement menu, click Area.

2. Click the object to measure its area.

3. Press · to anchor the measured value on the work area.

Measured circumference and perimeter

Areas of a circle and a polygon
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Finding the Measure of an Angle
1. From the Measurement menu, click Angle.

2. Click a point on one side of the angle to be measured.

3. Click the vertex of the angle you want to measure. 

When you move the pointer, the measure of the angle is displayed 
near the second point clicked. 

4. Click on a point on the second side of the angle to be measured to 
anchor the value on the work area.

Defining an Angle with Three Points
You can define and measure an angle by selecting three points on the 
work area.

1. From the Measurement menu, click Angle.

2. Click once on the work area and move to the next point. 

The first click represents one side of the angle. As you move to the 
next point, a dotted line shows the path used for angle 
measurement.

3. Click the work area a second time. 

The second click represents the vertex. As you move to the next 
point, Graphs & Geometry calculates the measurement of the angle 
and displays it on the work area. 

If you are defining an angle with a specific measurement, you can 
change the path to adjust the angle size.

4. Click the work area a third time, or press ·. 

The third click represents the second side of the angle and anchors 
the three points. 
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The measurement remains visible and close to the angle even if you 
change the size of the angle. If you alter the angle, the 
measurement updates to reflect the new value. 

Notes:

– The value of any angle will always be between 0- and 180- in 
degree mode or between 0- and p in radian mode.

– The default angle measure is in radians for measurements within 
Graphing View or an Analytic Window, and in degrees for 
measurements within Plane Geometry View. To change it, 
change the document settings.

Repositioning a Measured Value
1. From the Actions menu, click Pointer. 

2. Select and drag the measurement to the desired location.

Finding the Slope of a Line, Ray, Segment, or Vector
1. From the Measurement menu, click Slope.

2. On the work area, press · to select the object. 

3. Press · to anchor the value on the work area. 

The slope remains visible and close to the object even if you alter the 
slope. Note that the value changes as the object is moved. 
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Note: If the object is vertical, the slope value is -% or +%. If the object is 
horizontal, the slope value is zero.

Transferring Measurements
The Measurement Transfer tool lets you transfer a numeric value to an 
object. The transferred value remains linked to the original value. If you 
adjust the length of the initial measurement, all objects created with that 
measurement are adjusted automatically to reflect the change.

The tool can use any measured value or numerical text entry as the value 
to transfer.

You can transfer the value to:

• An axis -This creates a point on the axis at a distance equal to the 
transferred value.

• A new circle - This creates a circle with a radius equal to the 
transferred value. If you later delete the original value, the circle is 
also deleted.

• An existing circle - This defines an arc on the circle. You set the 
starting point, and the transferred value is used to create the ending 
point.

• A ray or vector - This creates a second point on the ray or vector at 
the transferred value, as measured from the object’s endpoint.

Example: Transferring a Numerical Text Entry to an Axis
1. From the Actions  menu, click Text, and then click to create a text 

box on the work area.

2. Type the number that you want to transfer, and press · to anchor 
it.

3. Press d to exit the Text tool.

4. From the Construction menu, click Measurement transfer.
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5. Click the number to transfer, and then click the desired axis.

The value is marked by the addition of a point on the axis. In this 
example, the point has been labeled to show its coordinates. 

 

Example: Creating a Circle Using a Transferred 
Measurement
1. Create a triangle from the Shapes menu, and then use the 

Measurements menu to measure the length of one side. This length 
will be used as the radius for a new circle.

2. From the Construction menu, click Measurement transfer.

3. Click the measured value that you created in step 1.

4. From the Shapes menu, click Circle.

A new circle is created with a radius equal to the transferred value.

5. Move the pointer to position the circle, and click to anchor it.

6. Press d to exit the tool, and then reshape the triangle to explore 
the effect on the circle.

Example: Transferring a Measurement onto a Circle
1. Create a circle using the Circle tool on the Shapes menu. 
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2. Create a line segment using the Points menu, and use the 
Measurements menu to create a measurement of its length. This 
length will be used as the length of an arc on the circle.

3. From the Construction menu, click Measurement transfer.

4. Click the measured value that you created in step 2.

5. Click the circle.

A point representing the start of the arc follows the pointer as you 
move around the circle.

6. Position the starting point, and then click to anchor the arc.

The measurement is transferred in a counter-clockwise direction, and 
the starting and ending points of the value are marked by points.

7. Press d to exit the tool, and then move the end points of the 
original line segment to explore the effect on the arc. You can also 
move the arc by dragging its starting point.

Note: If you measure the distance between the two points on the 
circle, the value will be less than the transferred measurement. This is 
because you are measuring a straight line between the points, not 
the arc formed between the points. The arc’s length is the 
transferred measurement.

Using the Calculate Tool
The Calculate tool enables you to perform arithmetic calculations using 
measured and entered values. An example best shows how this tool is 
used.

1. Create an object and display measurements for it. In this example, a 
triangle is constructed and its angles are measured using the Angle 
tool on the Measurements menu.
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2. From the Actions menu, click Text.

3. Type the formula for the calculation. In this example, the formula 
adds the measurements of the three angles. 

4. From the Actions menu, click Calculate. 

5. Click the formula you created.

You are prompted to select a value for each term in the formula.

6. Click each angle measurement when prompted.

Note: If you have stored a measurement as a variable, you can select 

it when prompted by clicking  (or pressing h). If the name of a 
stored measurement matches a term in the formula, you can press 
“L” when prompted for that term.

When all variables in the formula have values, the answer is 
displayed on the work area. 
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7. Press · to anchor the result as a new text object. 

Transforming Objects
You can apply transformations to drawn objects, and some can be 
applied to functions. When working with functions, the axes are most 
frequently involved and may be required. Object transformations can 
occur without the use of axes as a reference point. 

The transformations supported by Graphs & Geometry are:

• Symmetry with respect to any point, including the origin

• Reflections with respect to any straight line, including the axes

• Translations along any vector, including vectors on the axes

• Rotations about any point, including the origin, and any angle

• Dilations from any point, including the origin, with any factor

The first step in any transformation is to create an object or the graph of 
a function.

Exploring Symmetry
1. Create an object. 

2. From the Points & Lines menu, click Point. 

3. Click the work area to create the point of symmetry.

4. From the Transformation menu, click Symmetry. 

5. Select the object, and then select the point.

The symmetrical image is displayed. 

Exploring Reflection
1. Create an object.

2. Create a line or segment about which the object will be reflected.

3. From the Transformation menu, click Reflection.
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4. On the work area, select the reflection line or segment. 

5. Select the object.

The object reflection is displayed. 

6. To anchor the reflection, click the work area.

—or—

Press ·.

Exploring Translation
1. Create an object to translate (duplicate).

2. (Optional) Create a vector to indicate the distance and direction of 
translation.

3. From the Transformation menu, click Translation. 

4. Indicate the distance and the direction of translation by performing 
one of the following actions.

– Click the vector.

—or—

– Click the work area to indicate the distance between the object 
and the translation object, and then click a second time to 
indicate the direction of translation.

5. Click the translation object. 

The translated object is displayed.
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Exploring Rotation
1. Create the shape or graph the function to rotate.

2. (Optional) Create a point to rotate around and an angle for 
specifying the angle of the rotation. 

3. From the Transformations menu, click Rotation.

4. If you predefined a rotation point and angle in step 2, click the 
object first, the point of rotation next, and the angle of rotation last.
—or—
If you did not predefine a rotation point and angle:

a) Type the opening parenthesis and type the x and y coordinates 
of a rotation point, and press ·.

b) Type a measurement to use for the angle of rotation, and 
press ·.

The object is recreated in the rotated position. 
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Exploring Dilation
1. Create an object to enlarge by dilation.

2. Create a point to act as the center of the dilation. 

3. From the Actions menu, click Text and type a value to establish the 
size of the dilation. You can also measure an existing length to 
establish the sizing for the dilation.

Note: If you specify a large sizing value, you may have to use the 
Zoom tools or pan the display to view the dilated object.

4. Press · to anchor the sizing value on the work area.

5. From the Transformation menu, click Dilation. 

6. Click the object, the center point, and the sizing value before moving 
toward the object. 

Note: You can also specify center point coordinates and the sizing 
value of the dilation by typing the numbers after an opening 
parenthesis.

The dilated object appears on the work area. 

Performing Other Investigations
You can investigate other scenarios by bisecting segments, lines, and 
angles, or by creating a Locus.

• Bisecting a segment

• Bisecting an angle

• Finding the Locus

Bisecting a Segment 
1. From the Construction menu, click Perpendicular Bisector.

2. Click the segment. 
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The perpendicular bisector is displayed. 

Note: If the segment is not already present on the work area, you 
can create one by selecting two different points.

3. Click once more to anchor the bisector on the work area.

Note: A segment can be one side of a triangle, rectangle, or a 
polygon. 

Bisecting an Angle
1. From the Construction menu, click Angle Bisector.

Note: If no angle is present on the work area, you can create one by 
selecting three different points. 

2. Click to define the first side of the angle. 

3. Click to define the vertex of the angle. 

Bisecting an existing segment (bisector not anchored 
on page)
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4. Click to define the second side of the angle.

The bisector line appears and is anchored on the work area when 
you select the third point. 

Note: If you select the Pointer tool and move one point of the 
created angle, the angle bisector moves so that it always bisects the 
angle.

Creating a Locus
The Locus tool enables you to explore the range of motion of one object 
with respect to another object as constrained by a shared point. 

1. Create a segment, line, or circle. 

2. Create a point on the segment, line, or circle.

Creating an angle bisector by defining three points. 
The second point represents the vertex of the angle.

Point defined on the line segment.
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3. Create another object that uses the defined point created in the 
previous step.

4. From the Construction menu, click the Locus tool.

5. On the work area, select the object defined to share the point (this is 
the object to vary). 

6. Select the point shared by the objects (this is the object to constrain). 

The continuous locus is displayed. 

7. Move the point on the first construction. 

Circle created to use the defined 
point on the segment.
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The second construction deforms to follow the locus point.

You can create and explore other designs using the Locus tool.

Animating Points
You can animate a point on a line, ray, axis, vector, graph, segment, or 
circle. In addition, you can also animate points on multiple objects in the 
work area at one time. 

Animating a Point on an Object 
1. From the Points & Lines menu, click Point On.

2. Click the object to create the point on, and then click the location for 
the point. 

3. From the Actions menu, click Attributes. 

 
Two examples of the radius change of the circle as the locus 
moves along the line segment. The radius is labeled to better 
show the change.

 

Locus created using a point and a segment.
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The Attributes tool is displayed.

4. Press £ or ¤ to move to the animation attribute and press ¡ or ¢ to 
move to either the unidirectional or alternating animation speed 
attribute. 

5. Type a number from 1 - 9 to set the speed. The default speed is 0. 

The higher the number you type, the faster the animation speed. 

6. Animation begins automatically when you select the speed and 
direction. 

Press + and - on the computer keyboard or handheld to 
increase/decrease the speed of ongoing animation incrementally.

The Animation Control Panel

Once a point is animated, a floating control panel is displayed on the 
page. You can move this panel by dragging it to a new location.

When animation is active, the panel contains a Reset  and a 

Pause  button. When either button is pressed and animation is reset 

or paused, the Pause button changes to a Start  button. These 
controls affect all animated points on a page.

Panel when animation is active

Panel with animation paused/reset
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Changing the Animation of a Point in Motion
To change the speed of a point’s movement or the direction of 
animation:

1. Reset or pause the animation. 

a) Select the Attributes tool. 

b) Select the point you want to change. 

c) When the list of attributes is displayed, select an animation 
attribute.

2. To change the speed, type a new number. 

3. To change the direction of animation, press 78.

4. Press the Start  button. 

The point moves at the new speed and/or in the new direction you 
selected.

Pausing and Resuming Animation

1. To pause the animation on a page, click the Pause  button. 

2. To restart animation, click the Start  button.

Resetting Animation

Selecting the Reset button  not only pauses animation but also 
returns the animated point to its initial coordinate position on the object 
when animation was first started. If multiple points are animated on the 
page, all are returned to their original locations when you select Reset.

Stopping Animation
To stop the animation of an object:

1. Click the Pause  or Reset  button on the control bar. 

2. Display the Animation attribute for the point. 

3. Change the speed to 0 (zero). 

4. Click an empty area of the screen to apply the change.

—or—

Press ·. 

5. Click Start to resume animation if other animated points were 
temporarily stopped. 
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If no other animated points are on the page, the animation control 
box does not reappear when the velocity is set to zero.

Note: If you have multiple points in motion on one page and want 
to permanently stop the animation of all objects, when motion is 
paused or stopped, display the list of attributes for each point, and 
change the velocity to zero. 

3D Graphing
The 3D Graphing view lets you view and explore three-dimensional 
graphs of:

• 3D functions of the form z(x,y)

• 3D parametric plots

While you are in the 3D Graphing view, you can define, rotate, resize, 
and trace 3D graphs. You can set the colors and other visual attributes of 
a selected graph, and you can customize the 3D viewing environment.

Operators and Functions Supported
You can use any of the following items in an expression for 3D graphing:

À 3D Graphing menu. This menu is specific to 3D Graphing and is 
accessible from the Graphs & Geometry View menu.

Á Sample 3D graph. Each 3D graphing page can show multiple 
graphs.

Â Entry line with expression that defines the graph

Ã Legend displaying orientation of the axes



456 Graphs & Geometry

+  N Q P ^
exp ln log
sqrt abs ceiling floor int sign root
real imag conj
sin cos tan sec csc cot
arcsin arccos arctan arcsec arccsc arccot
sinh cosh tanh sech csch coth
arcsinh arccosh arctanh arcsech arccsch arccoth

Graphing 3D Functions
1. From the View menu, click 3D Graphing.

2. From the 3D Graph Entry/Edit menu, click Function.

The entry line appears.

3. Type the expression that defines the graph.

4. Press · to draw the graph and hide the entry line. You can show 

or hide the entry line anytime by pressing / G.

Graphing 3D Parametric Equations
1. From the View menu, click 3D Graphing.

2. From the 3D Graph Entry/Edit menu, click Parametric.

The entry line appears.
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3. Type the equations that define the graph.

4. (Optional) Click the Edit Parameters button  to set the graphing 
parameters tmin, tmax, umin, and umax.

5. Press · to draw the graph and hide the entry line. You can show 

or hide the entry line anytime by pressing / G.

Displaying the Context Menu of a 3D Graph
Some 3D graphing features are accessible only through context menus.

1. If necessary, press d to return to the Pointer tool.

2. Point to the graph to select it.
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The selected graph is displayed in gray.

3. Display the graph’s context menu.

– Handheld: Press / b. 

– Windows®: Right-click.

– Mac®: Hold “ and click.

Editing a 3D Graph
1. Display the graph’s context menu, and then click Edit Relation.

—or—

Press / G to show the entry line, and use the up/down arrow keys 
to display the expression.

2. Modify the existing expression, or type a new expression in the entry 
line.

3. Press ·.

Changing the Color or Appearance of a 3D Graph

To Set Wire and Surface Color:
1. Display the graph’s context menu, click Color, and then click 

Line Color or Fill Color.

2. Click a color swatch to apply it.

To Set Custom Plot Colors:
Custom plot colors can make it easier to see the shape characteristics of 
the graph. You can assign different colors to its top and bottom surfaces 
or choose to have the graph colored automatically, based on height or 
steepness. You can also set the wire color.

1. Display the graph’s context menu, and then click Color > 
Custom Plot Color.
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2. Select one of the three Surface color options: Top/bottom color, 
Vary color by height, or Vary color by steepness. 

– If you choose Top/bottom color, click the color swatches to select 
colors for the top and bottom surfaces.

– If you choose to vary color by height or steepness, colors are 
determined automatically.

3. To set the Wire color, click the color swatch and select a color.

To Set Other Attributes of a Graph:
1. Display the graph’s context menu, and then click Attributes. You can 

set the following attributes for the selected graph.

– format: surface+wire, surface only, or wire only

– x resolution (enter a value in range 2-200*, default=21)

– y resolution (enter a value in range 2-200*, default=21)

– transparency (enter a value in range 0-100, default=30)

– shading (controls highlights, enter a value in range 0-100, 
default=50)

* Handhelds are limited to a maximum display resolution of 21, 
regardless of the value entered.

2. Set the attributes as you like. For more information, see Changing an 
Attribute of an Object.

3. Press · to accept the changes.
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If a Graph is Difficult to Select
1. From the 3D Graph Entry/Edit menu, click the graph’s type (either 

Function or Parametric).

The entry line appears.

2. Use the up/down arrow keys to select the graph.

3. Display the graph’s context menu.

– Handheld: Press / b. 

– Windows®: Right-click.

– Mac®: Hold “ and click.

4. Click the menu item that you want to change.

Showing and Hiding 3D Graphs

To Hide a 3D Graph:
8 Display the graph’s context menu, and then click Hide.

To Show a Hidden 3D Graph:
1. From the Actions menu, click Hide/Show.

The Hide/Show icon  appears and all hidden graphs show in gray.

2. Click a graph to change its hide/show state.

3. To return to the Pointer tool, press d.

Customizing the 3D Viewing Environment

To Set the Background Color:
8 Display the context menu for the work area, and then click 

Background Color.
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To Show or Hide Specific View Elements:
8 From the View menu, click the item to show or hide. You can choose 

items such as the 3D box, axes, box end values, and legend. 

To Set the Visual Attributes of the Box and Axes:
1. Display the context menu for the box, and then click Attributes. You 

can set the following attributes.

– Show or hide tic labels

– Show or hide end values

– Show or hide arrows on axes

– Show 3D or 2D arrow heads

2. Set the attributes as you like. For more information, see Changing an 
Attribute of an Object.

3. Press · to accept the changes.

To Shrink or Magnify the 3D View:
8 From the Range/Zoom menu, click Shrink Box or Magnify Box.

To Change the 3D Aspect Ratio:
1. From the Range/Zoom menu, click Aspect Ratio.

2. Enter values for the x, y, and z axes. The default value for each axis 
is 1.

To Change the Range Settings
8 On the Range/Zoom menu, click Range Settings. You can set the 

following parameters.

– XMin (default=-5)
XMax (default=5)
XScale (default=Auto) You can enter a numeric value.

– YMin (default=-5)
YMax (default=5)
YScale (default=Auto) You can enter a numeric value.

– ZMin (default=-5)
ZMax (default=5)
ZScale (default=Auto) You can enter a numeric value.

– eye q¡ (default=35) 
eye f¡ (default=160)
eye distance (default=11)
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Rotating the 3D View

To Rotate Manually:
1. Press R to activate the Rotation tool (required only for the 

TI-Nspire™ handheld with Clickpad).

2. Press any of the four arrow keys to rotate the graph.

To Rotate Automatically:
Auto rotation is equivalent to holding down the right arrow key.

1. From the Actions menu, click Auto Rotation.

The Auto Rotation icon  appears, and the graph rotates.

2. (Optional) Use the up and down arrow keys to explore the rotating 
graph.

3. To stop the rotation and return to the Pointer tool, press d.

To View from Specific Orientations:

1. If necessary, press d to return to the Pointer tool.

2. Use letter keys to select the orientation:

– Press Z, Y, or X to view along the z, y, or x axis.

– Press letter O to view from the default orientation.

Tracing in the 3D View

To Start Tracing:
1. From the Trace menu, click z Trace.

The z Trace icon  and the trace plane appear, along with a text 
line showing the current "z=" trace value.

2. To move the trace, hold down Shift and press the up or down arrow 
key.

The "z=" text is updated as you move.
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3. (Optional) Use the four arrow keys to rotate the view and see how 
the trace plane and the graph intersect.

4. To stop tracing and return to the Pointer tool, press d.

To Change the Trace Settings:
1. From the Trace menu, click Trace Setup.

The 3D Trace Setup dialog box opens.

2. Enter or select the settings, and click OK to apply them.

3. If you are not already tracing, your new settings take effect the next 
time you trace.

Animating a 3D Graph with a Slider
The following steps illustrate an example of an animated 3D graph.

1. Insert a new problem and select the 3D Graphing view.

2. From the Actions menu, click Insert Slider, click to position it, and 
type time as the variable name.
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3. Display the slider’s context menu, click Settings, and enter the 
following values.

Value: 3.8
Minimum: 3.2
Maximum: 4.4
Step Size: 0.1

4. In the entry line, define the function shown here:

5. Drag the slider thumb to see the effect of varying time.

6. Add visual interest. For example, try:

– Rotating the graph.

– Hiding the box, axes, and legend.

– Setting the graph’s format attribute to show the surface only.

– Changing the graph’s transparency and shading attributes.

– Changing the background color and graph fill color.
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7. To animate the graph, display the slider’s context menu, and click 
Animate. (To stop, click Stop Animate from the context menu.)

You can combine manual or auto rotation with the slider animation. 
Experiment with the x and y resolution to balance curve definition 
against animation smoothness.
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Lists & Spreadsheet

The Lists & Spreadsheet application gives you a place to work with 
tabular data. It lets you:

• Store numeric data, text, or math expressions.

• Define a table cell in terms of the contents of other cells.

• Define an entire column based on the contents of another column.

• Share columns of data as list variables with other TI-Nspire™ 
applications. Also share individual cells as variables.

• Work with variables created in the Graphs & Geometry and 
Calculator applications.

• Collect tables of real-world data from sensors.

• Generate columns of data-based sequences that you define.

• Plot table data using the Data & Statistics application.

• Generate a table of values for a function.

• Copy and paste table data from the Lists & Spreadsheet application 
to other computer applications, such as TI Connect™ software and 
Excel® spreadsheet software.

• Perform statistical analysis on lists of data.
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The Menu and Work Area

The Parts of a Spreadsheet
A spreadsheet includes a column letter at the top of each column and a 
row number on the left of each row. The top two rows and the row 
numbers remain in place as you scroll. You can name a column of data to 
make it available as a list variable in TI-Nspire™ applications. 

À Lists & Spreadsheet menus (available when a Lists & Spreadsheet 
work area is active)

Á Sample Lists & Spreadsheet work area

Â Click horizontal and vertical scroll bars to view more rows and 
columns

Ã Lists & Spreadsheet data plotted in the Data & Statistics application

Ä Entry line
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Navigating in a Spreadsheet
You can select any cell to view or edit its contents. When a spreadsheet is 
larger than the Lists & Spreadsheet work area, you can move to different 
parts of the spreadsheet by using the e key and by pressing shortcut 
keys.

• Press e to move between the body of the spreadsheet (data zone) 
and the column names and formulas (naming zone).

• Press ¡, ¢, £, and ¤ to move through the spreadsheet one cell at a 
time (move between cells within a zone). The arrow keys move the 
cursor from cell to cell and scroll as necessary to keep the selected 
cell in view. 

• Move across several cells at a time by pressing Page up, Page Dn, 
Home, and End.

À Column reference letter

Á Column name cell for defining a column as a list variable

Â Column formula cell for generating a column of data

Ã Row reference number

Ä Entry line (includes cell reference for current cell)

Å Cells - Any empty (void) element in a list is displayed as an 
underscore (“_”). Any value that cannot fit in a cell’s width is 
truncated. Hover over the cell to display the complete value.

Æ Naming zone (first tab stop - column names and formulas)

Ç Data zone (second tab stop - body cells)
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Handheld: Press / 9 (Page up), / 3 (Page Dn), / 7 

(Home), and / 1 (End) keys.

• Use the Go To command on the Actions menu to select a specific cell. 
Type the cell’s column letter and row number (such as G16).

• Press · to put the selected cell in Edit mode.

• Drag the scroll bar to move vertically without changing the cell or 
block of cells selected.

Creating and Sharing Spreadsheet Data as Lists
You can define a column as a named list of elements of the same type of 
data. After defining a list, you can link to it from the Graphs & Geometry, 
Calculator, or Data & Statistics applications, and from other instances of 
the Lists & Spreadsheet application within the current problem.

Note: Lists & Spreadsheet can display a maximum of 2500 elements in a 
list.

Sharing a Spreadsheet Column as a List Variable
You share a column of data by naming it as a list variable. 

Note: Avoid defining variables that use the same names as those used 
for statistical analysis. In some cases, an error condition could occur.

Variable names used for statistical analysis are listed in the TI-Nspire™ 
Reference Guide, under the stat.results entry.

1. Click the cell to move to the column’s name cell (the top cell of the 
column).

—or—

Press £ as necessary.

2. Type a name for the list variable, and press ·.

The column is now available as a list variable to other TI-Nspire™ 
applications.

3. Create elements in the list the same as you would create data in 
spreadsheet cells. For example, you can type the data into each cell 
or use a formula to generate a column of data.

Notes:

• If a variable with the name you specified already exists in the current 
problem, Lists & Spreadsheet displays an error message.
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• When you select the column formula cell of a list, it displays the list 
name in an expression similar to width:=.

• Lists can contain empty elements (denoted by “_”) .

• You can refer to a specific element in a named list from the 
Calculator application. Use the list name and the element’s position 
within the list. In a list named Heights, for example, refer to the first 
element as Heights[1]. The expression Heights[2] refers to the second 
element, and so on.

Linking to an Existing List Variable
Linking a column to an existing list variable lets you easily view and edit 
the values in the list. The list can be any shared list in the current problem 
and can be defined in Graphs & Geometry, Calculator, or any instance of 
Lists & Spreadsheet.

After you link a column to a list, Lists & Spreadsheet automatically shows 
any changes that you make to the list with other TI-Nspire™ applications.

1. Click the column formula cell (the second cell from the top) of the 
column that you want to link to the variable.

2. Type the name of the list variable you want to link to.

—or—

Click  on the toolbar (press h on the handheld), click Link To, 
and click the variable you want to link to.

3. Press ·.

The column shows the list elements.

Notes: 

• You cannot link to the same variable multiple times on the same 
page.

• Use caution if you link to a system variable. Doing so could prevent 
the variable from being updated by the system. System variables 
include ans and statistics results (such as stat.results, stat.RegEqn, and 
stat.Resid).

Inserting an Element in a List
When you insert an element in a list, the remaining elements shift 
downward to create space. No other columns are affected.

8 Click Insert > Insert Cell.
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Deleting an Element from a List
When you delete an element, the remaining list elements shift upward to 
close the gap. The upward shift affects only the selected column.

1. Click the cell of the element to delete.

2. Open the context menu for the cell, and click Delete Cell.

Note: If you press . or Backspace to clear the contents of the cell 
instead of deleting the list element, the element is assigned a value 
of 0 (zero). The remaining list elements do not shift.

Creating Spreadsheet Data
You can type numeric values, text, or formulas into body cells. Column 
formula cells can contain formulas only. (For more information, see 
Generating Columns of Data.)

Data Examples

Typing a Math Expression, Text, or Spreadsheet Formula
1. Double-click the cell to select it and put it in edit mode.

Note: If the cell is already selected, you can press · or click the 
entry line.

2. Type the expression, text, or formula. Be sure to enclose text entries 
in quotes and start formula entries with an “=” symbol.

Entry Remarks

1.234 Simple numeric entry

“Green” Text - Enclose categorical data (such as the names of 
colors used in a study) within quotes to distinguish them 
from variable names. 

Handheld: Press / r to enter quoted data.

=a3*length Formula - Consists of an “=” symbol followed by an 
expression.

You can type the expression or use the Catalog and 
expression templates to build it. For more information, 
see the Calculator section.

To ensure a decimal result instead of a fraction, type 
one of the integers in the expression as a decimal. For 
example, type 1.0 instead of 1. 
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As you type the data, it appears in the cell and on the entry line 
simultaneously.

3. Press · to complete the entry and move down to the next cell.

—or—

Press e to complete the entry and move right to the next cell.

The Lists & Spreadsheet application automatically recalculates any 
cells that are dependent on the cell you entered. If you have shared 
the cell, and other TI-Nspire™ applications are linked to the cell, the 
other applications are also updated.

Note: Empty cells in a spreadsheet display as a void represented by 
an underscore (_). The underscore is automatically added to empty 
cells when a list is named or when an empty cell is referenced in a 
formula. When you plan to perform calculations on a range of cells, 
be sure to notice the location of void cells. Cells without a value can 
affect calculations. For example, if you include a void cell in the 
range for a sum such as “=b2+c2,” the result of the calculation is 
void (_).

Inserting a Cell Range into a Formula
The Select Range feature lets you insert a cell range (such as a1:b3) into a 
formula by selecting the range instead of typing cell addresses into an 
argument.

Suppose you want to calculate the mean of a range of cells.

1. Select the cell that will contain the result.

2. From the Data menu, click List Math > Mean.

An editable formula appears in the cell.

3. Click Actions > Select > Select Formula Range.

4. Drag a selection rectangle around the range of values for which you 
want to calculate the mean.
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The formula is updated as you select the cells.

5. Press · to complete the formula and display the result.

Working with Cells

Working with Color
The Lists & Spreadsheet application displays black text and cells with a 
white background by default. You can change the color of cells and text 
to emphasize or distinguish data. The colors and the order in which color 
is assigned is based on the TI-Nspire™ color palette. For more 
information, see Changing the color of cells and Changing the color of 
text. 

Color changes made in the software are displayed in shades of gray when 
you work on documents on the TI-Nspire™ handheld. Color is preserved 
when you move documents back to the software. 

Changing the Fill Color of Cells
1. Select the cells to fill with color. You can choose one or more cells in 

any adjacent cells, columns, or rows.

2. Access the context menu and click Color > Fill Color.

3. Click the color to apply to the cells. The color of the selected cells 
changes.

Note: If you combine color text and color cells, choose colors carefully to 
ensure visibility as you work with documents in the software and on the 
handheld.

Changing the Color of Text
1. Select the cells that contain the text to change. You can choose one 

or more cells in any adjacent cells, columns, or rows.

2. Access the context menu and click Color > Text Color.
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3. Click the color to apply to the text. Empty cells in the selection area 
show the color change when text is added.

Understanding Cell References in Formulas
Use a cell reference to use data from a cell or range of cells in a formula. 
The calculation results update automatically when values in cells change. 

Relative references include only the cell’s column letter and row number 
(for example, E7). A relative reference describes where a cell is in relation 
to other cells of the spreadsheet. The Lists & Spreadsheet application 
keeps track of relative cell references and adjusts the reference 
automatically when surrounding cells shift (because of actions you 
perform, such as column deletions or cell insertions). 

Follow these guidelines to specify cell references:

• Include a column letter and row number in a relative reference. 

• Include the $ symbol before both the column letter and the row 
number to specify an absolute reference. 

• Include a colon (:) between a two cell reference to specify a range of 
cells.

Absolute references include the $ symbol before the column letter and 
before the row number (for example, $B$16). Absolute references always 
refer to the cell in a specific position in the spreadsheet. The application 
does not automatically adjust the cell reference when cell positions 
change. 

Typing a Cell Reference in a Formula
1. Double-click the cell and type the formula. For more information, 

see the Calculator section.

2. Move to the appropriate position in the formula and type the cell 
reference. Use the format for a relative reference (B3), absolute 
reference ($B$2), or range of cells (A1:A4). 

Note: You can click Recalculate on the Actions menu to update all 
references and formula results in a spreadsheet.

Deleting the Contents of Cells
1. Click a cell to select it. 

—or—
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Use the arrow keys to move to the cell. 

Note: If you are deleting a range of cells, select a cell at one end or 
corner of the range, and then use g with the arrow keys to select 
the remaining cells in the range.

2. Press ..

Note: Any cell that uses a formula with an absolute reference to 
deleted data shows an error. A cell that uses a formula with a 
relative reference to deleted data is updated to use the data 
currently in the referenced position.

Copying Cells
When you copy cells, any formulas in the original cells are copied to the 
destination cells.

1. Click the cell to copy. 

—or—

Use the arrow keys to move to the cell. 

Note: If you are copying a range of cells, select a cell at one end or 
corner of the range, and then use g with the arrow keys to select 
the remaining cells in the range.

2. Copy the selected cells by pressing / C.

Mac®: “+C

3. Click the cell where you want to duplicate the copied cell. If you are 
copying a block of data, click the cell that will become the upper left 
corner of the copied block.

4. Paste the selected cells by pressing / V.

Mac®: “+V)

Important: Paste copied data into a cell that is in the same mode as 
the cell from which the data was originally copied. Otherwise, a 
formula could paste as a string enclosed in quotes instead of a 
formula.

Filling Adjacent Cells
You can repeat a cell’s formula or value throughout adjacent cells within 
the row or column. You can also repeat a range of cells horizontally or 
vertically. If you fill from a range that contains a simple sequence (such as 
2, 4, 6), the sequence continues in the filled cells.
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1. Click the cell that contains the value or formula to repeat. 

Note: If you are repeating a range of cells, drag to select the range, 
or select a cell at one end of the range, and then use g with the 
arrow keys to select the remaining cells.

2. Click Data > Fill.

3. Use the arrow keys.

—or—

Drag to select the range that will hold the repetitions.

4. Press ·.

The value, formula, or pattern that you selected for duplication is 
repeated over the selected range.

Sharing a Cell Value as a Variable
You can share the value of a cell with other TI-Nspire™ applications by 
storing it as a variable. When you define or refer to a shared cell or 
variable in Lists & Spreadsheet, the name is preceded with an 
apostrophe (‘).

1. Click the cell that you want to share.

2. Click  on the toolbar, and click Store Var to store the cell’s value.

Handheld: Press / h.

—or—

Press h and select Store Var).

A formula is inserted into the cell with var as a placeholder for a 
variable name.

3. Type over the letters “var” with a name for the variable, and press 
·. Use a variable name that does not exist in the current problem.

The value is shown in bold to indicate that it is now available as a 
variable to other TI-Nspire™ applications.

Linking a Cell to a Variable
When you link a cell to a variable, Lists & Spreadsheet keeps the cell 
value updated to reflect the current value of the variable. The variable 
can be any variable in the current problem and can be defined in 
Graphs & Geometry, Calculator, Data & Statistics, or any instance of 
Lists & Spreadsheet.

1. Click the cell that you want to link to a variable.
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2. Click  on the toolbar, and click Link to.

Handheld: Press / h.

—or—

Press h and select Link to.

The VarLink menu opens.

3. Under Link To, press £, and ¤ to scroll to the name of the variable.

4. Press ·.

The cell shows the value of the variable.

Note: Use caution if you link to a system variable. Linking could prevent 
the variable from being updated by the system. System variables include 
statistics results (such as Stat.RegEqn, Stat.dfError, and Stat.Resid) and 
finance-solver variables (such as tvm.n, tvm.pmt, and tvm.fv).

Working with Rows and Columns of Data

Selecting a row or column
8 To select a column, move to the top of the column and click the 

column reference letter. To select a row, move to the leftmost cell of 
the row and click the row reference number. Press d to cancel the 
selection.

Handheld: Hold down £ to move past the top cell, or hold down ¡ to 
move past the leftmost cell.

8 To extend a selection to adjacent rows or columns, hold down g 

and press ¡, ¢, £, or ¤.

Resizing a Row or Column
1. Click the row or column that you want to resize.

2. Click Actions > Resize, and then select an option.

3. Choose a resizing option for a column or row.

– For a column, choose Resize Column Width, Maximize Column 
Width, or Minimize Column Width.

– For a row, you can choose Resize Row Height.

The tools that minimize and maximize the column width work 
automatically. You must manually adjust the size to use the Resize 
Column Width and Resize Row Height tools.
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4. To resize manually, use ¡ and ¢ to resize the column, or use £ and ¤ 

to resize the row, and then press ·.

Inserting an Empty Row or Column
1. Click a column or row where you want to insert the new data.

2. Click Insert, and then click either Row or Column.

– If you are inserting a row, the remaining rows shift down to 
create space for the new row.

– If you are inserting a column, the remaining columns shift right 
to create space.

Note: If other cells contain formulas with relative references to a 
displaced row or column, those references adjust accordingly.

Deleting Entire Rows or Columns
You can delete a row, column, group of rows, or group of columns. When 
you delete a row or column, the remaining rows or columns move up or 
left to fill the gap.

1. Click the column or row that you want to delete.

2. (Optional) To select adjacent rows or columns to delete, hold down 
g and press ¡, ¢, £, or ¤.

3. Display the context menu.

– Handheld: Press / b.

– Windows®: Right-click the selected row.

– Mac®: Hold the “ key, and click the selected row.

4. On the context menu, select Delete Row.

The selected rows or columns are deleted.

Note: If other cells contain formulas that refer to the deleted row or 
column, those cells show an error. Relative references to cells whose 
positions have changed because of a deletion adjust accordingly.

Copying Rows or Columns
1. Click the column or row that you want to copy. 

You can click the column letter to copy a column, or click the row 
number to copy a row.

2. (Optional) To select adjacent rows or columns to copy, hold down 
g and press ¡, ¢, £, or ¤.
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3. Copy the column or row by pressing / C.

Mac®: “+C.

4. Move to any cell in the row or column where you want to place the 
copied items.

5. Paste the selected column or row by pressing / V. 

Mac®: “+V.

The copied row or column is pasted in place, replacing the previous 
contents.

Note: If you copy a named column, it is pasted with the name 
removed to prevent a variable conflict.

Moving a Column
1. Click the column that you want to move.

2. Click Actions > Move Column. 

An insertion bar appears. 

3. Press ¡ or ¢ to place the insertion bar at the column’s new position, 

and then press ·.

Note: Relative references to any cell in a position is affected by the 
move adjust accordingly.

Displaying Results as Exact or Approximate
You can choose to display a column’s calculated results in Exact (fraction) 
or Approximate (decimal) form. This affects only the values calculated 
from a formula.

1. Select the column by clicking the reference letter at the top of the 
column.

2. Display the context menu for the column.

3. On the context menu, click either Data > Exact or 
Data > Approximate.

Note: To restore the column results to the document’s default setting, 
select the column and click Data > Restore Document Setting.

Clearing Column Data
The Clear Data command lets you remove the data from selected 
columns. Clear Data does not delete the column, and it does not clear a 
column’s name or formula.
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After clearing the data, Lists & Spreadsheet recalculates column formulas 
for the selected columns. This makes Clear Data useful for capturing a 
fresh set of data from another application or selectively generating a 
fresh column of random numbers.

1. Click the column or columns that you want to clear.

2. Click Data > Clear Data.

Note: If a recalculated formula produces the same data as before, it 
may appear that the Clear Data command has failed.

Sorting Data
You can sort a selected area of the spreadsheet in ascending or 
descending order. You select which column in the selected area will be 
used as the key for the sort. When the sort moves data up or down in the 
key column, the corresponding data in the other selected columns is also 
moved up or down. This preserves the integrity of each row.

Note: Sorting is based on numeric values. If you select a key column that 
contains text, you could get unexpected results.

1. Select the range of cells. 

2. Click Actions > Sort.

The Sort dialog box opens.

3. Click the column letter to use for ordering.

4. Click Descending or Ascending as the sort method, and then click 
OK.



482 Lists & Spreadsheet

Note: Sorting a column that is defined by a formula will remove the 
formula, because it may not be valid after the sort.

Generating Columns of Data
You can create a column of values based on the contents of another 
column. You can also create a column based on any of several types of 
sequential data.

Entering a formula in a column’s formula cell tells the Lists & Spreadsheet 
application that you want to apply the formula to all cells in the column, 
not just to a single cell.

À Column formula based on a variable

Á Column formula based on another column

Â Column formula that generates a sequence
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Notes:

• If you generate data in a column that already contains one or more 
cell values, Lists & Spreadsheet asks for confirmation before 
replacing the existing values. Proceeding removes all of the existing 
values in the column.

• If you edit a cell manually in a column of generated data, 
Lists & Spreadsheet asks for confirmation before replacing the 
generated data. Proceeding removes the generated data for the 
entire column.

Creating Column Values Based on Another Column
1. Click the column formula cell (the second cell from the top) of the 

column where you want to use a formula.

Lists & Spreadsheet inserts the leading equal sign (=) for the formula. 
If the column is a named list, Lists & Spreadsheet inserts listname:= 
followed by the cursor.

2. Type the expression for the formula after the = and press ·. Use 
brackets ([]) after any column letter you include in the formula. For 
example, type =a[]^2 to create a column of values in which each cell 
is the square of the corresponding cell of column A.

Lists & Spreadsheet shows the formula in the formula cell and fills 
the column with the results.

Generating a Column of Random Numbers
This example generates a column of 20 random integers in the range 1 
through 6.

1. Click the column formula cell (the second cell from the top) of the 
column.

Lists & Spreadsheet inserts the leading equal sign (=) for the formula. 
If the column is a named list, Lists & Spreadsheet inserts listname:= 
followed by the cursor.
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2. After the equal sign, type RandInt(1,6,20).

Note: You can also use the Catalog or click Data > Random > 
Integer to insert the RandInt() function.

3. Press · to generate the numbers.

4. To generate (Recalculate) a new set of random numbers, press 
/ R.

Mac®: “+R.

Generating a Numerical Sequence
1. Click any cell in the column in which you want to generate the 

sequence.

2. Click Data > Generate Sequence.

The Sequence dialog box opens.

3. Type the Formula that will be applied to the column values. 

4. Type any starting numbers required by the sequence in the Initial 
Terms field and separate them with commas. 
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5. Type a starting value for the independent variable (n0).

6. Type a maximum number of values to be generated (nMax).

7. Type the step value (nStep).

8. (Optional) Type a maximum value for the sequence in the Ceiling 
Value field.

9. Click OK.

Lists & Spreadsheet shows the formula in the formula cell and fills 
the column with the results.

Graphing Spreadsheet Data
You can graph the data in a spreadsheet using Quick Graph or Summary 
Plot. Lists & Spreadsheet cells that contain no data are not represented 
by data points on graphs.

Using Quick Graph
You can easily create a dot plot of the data in one column or a scatter 
plot of two adjacent columns by using the Quick Graph feature. This 
feature displays the graphed data using the Data & Statistics application.

To create a scatter plot:

1. Name both of the columns to declare them as lists.
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2. Select both columns.

3. Click Data > Quick Graph.

A Data & Statistics application is added to the page with the plotted 
data. The leftmost of the two lists is plotted on the x axis, and the 
other list is plotted on the y axis.

4. (Optional) Use the Data & Statistics features to analyze or visually 
enhance the graph.

Note: For more information, see Using Data and Statistics.
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Creating a Summary Plot from a Summary Table
In this example, you create a summary table from raw data, and then use 
the table to generate a summary plot. For more information, see Using 
Data & Statistics.

A summary table contains an X (or Y) List and a Summary List. 

• The X (or Y) List contains numeric or string values (such as 1999 or 
“color”). Numeric values result in a histogram. String values identify 
the categories for a bar chart.

• The Summary List contains numeric values (such as count, frequency, 
or probability) for each element in the other list.

To Create a Summary Plot:
Note: For situations in which you already have a summary table, you can 
skip the first two steps. 

1. Create a list that holds the category identifiers. For this example, 
name the list “color” and type strings for eye color. Enclose category 
names in quotes to prevent them from being interpreted as 
variables.

raw data summary table for eye color based on 
raw data
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2. Create the summary list. For this example, name the list “counts” and 
type the total count for each of the eye colors.

3. Select either list by clicking the top cell of the column and 
pressing £. 

4. Click Data > Summary Plot.

The Summary Plot dialog box opens.

5. If necessary, use e and the arrow keys to select the correct lists for 
X List and Summary List.

6. In the Display On field, select how to display the summary plot in 
the Data & Statistics application.

• Select Split Page to place the chart on half of the current page. 
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• Select New Page to add the chart on a new page.

The summary plot is displayed with the list names along the axes and 
a summary plot symbol in the lower left corner of the chart window.

Note: In this example, the X List contains string data, so the 
summary plot displays as a bar chart. The category strings from the 
list display beneath the bars.

Exchanging Data with Other Computer Software
You can use the TI-Nspire™ desktop software to copy table data to and 
from software outside the TI-Nspire™ applications, such as TI DataEditor 
(in the TI Connect™ software) and Excel® spreadsheet software.

For example, you can copy:

• The values of individual cells, a range of cells, or an entire list from 
TI DataEditor.

• The values (not the underlying formulas) of individual cells, a range 
of cells, or an entire column from an Excel® spreadsheet.

• A number from TI DataEditor.

• The value of a matrix from TI DataEditor.

Example - Copying Data from TI DataEditor
1. Open the TI Connect™ software.

2. Display the TI DataEditor.
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3. If necessary, open the file containing the number, list, or matrix that 
you want to copy.

4. Drag to select the values that you want to copy. To copy an entire 
list, click the top cell in the list.

5. Click Edit > Copy.

6. In Lists & Spreadsheet, click the cell where you want the data to be 
pasted.

If you have copied a range of cells, they will be pasted so that the 
upper-left corner of the range is positioned at the selected cell. Any 
data in those cells will be overwritten.

7. Click Edit > Paste.
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Copying Cells from an Excel® Spreadsheet
You can copy up to 26 columns and 2500 rows from an Excel® 
spreadsheet to a Lists & Spreadsheet application.

1. Drag to select the values that you want to copy from the Excel® 
spreadsheet. To copy an entire column, click the column identifier at 
the top of the column.

Note: If you select non-contiguous columns in the Excel® 
spreadsheet, they will be pasted as contiguous columns in Lists & 
Spreadsheet.

2. Press / C to copy cells.

3. In Lists & Spreadsheet, click the cells where you want the data to be 
pasted.

If you are copying a range of cells, they will be pasted so that the 
upper-left corner of the range is positioned at the selected cell. Any 
data in those cells in will be overwritten.

4. Press / V to paste the copied cells into Lists & Spreadsheet.

Note: Categorical data must be enclosed in quotes (“ “) after the 
data is pasted.

Capturing Data from Graphs & Geometry
You can use Lists & Spreadsheet application to capture information about 
objects in the Graphs & Geometry application. For example, you could 
track changes in the area of a triangle as you change the length of a side 
in the Graphs & Geometry application.

Captured values replace values in the column. If you prefer, you can 
remove all data from a column before starting a new capture by clicking 
Clear Data on the Data menu.

You can select manual or automatic capture as the method of capturing 
data.

• With manual capture, you trigger the capture of each data element 
by pressing a key combination. 

Windows®: Press / ^.

Mac®: Press “ ^.

• With automatic capture, the capture of each data value is triggered 
automatically when you move or animate the target in Graphs & 
Geometry.
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Capturing Data Manually
1. Make sure the data value that you want to capture is linked to a 

variable name.

2. Click the column formula cell (the second cell from the top) of the 
column in which you want to capture the values.

Note: Captured values replace values in the column.

3. Click Data > Data Capture > Manual Data Capture. 

A capture expression is inserted into the column formula cell with 
var as a placeholder for the name of the variable you are capturing.

4. Replace the letters “var” with the name of the variable to capture 
from Graphs & Geometry. For example, type area.

The formula cell now contains an expression similar to 
=capture(area,0).

Note: The argument “0” tells Lists & Spreadsheet that you want to 
trigger each capture manually.

5. Press ·.

6. From the Graphs & Geometry application, change the object with a 
measured value stored as the variable (area, in this example) 
referenced in the data capture expression.

7. Each time you are ready to capture the current value of area, press 
the capture keys.

Windows®: Hold down / and press . (the period key).

Mac®: Hold down “ and press . (the period key).

Handheld: Press / ^.
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The current area value is added to the end of the list as a list 
element.

Capturing Data Automatically
When you capture data automatically, you can specify that you want the 
captures to be triggered by:

• Changes in the captured variable only.

• Changes in the captured variable or additional variables.

This lets you set up multiple columns of synchronized captures, such as 
the x and y coordinates of a moving object.

To Capture Automatically
1. Clear all columns that you will be using for the captured data.

2. Make sure any data values that you want to capture are linked to 
variable names.

3. Click the column formula cell (the second cell from the top) of the 
column in which you want to capture the values.

4. Click Data > Data Capture > Automated Data Capture.

A capture expression is inserted into the column formula cell with 
var as a placeholder for the name of the variable you are capturing.

5. Replace the letters “var” with the name of the variable to capture. 
For example, type objpathX. Alternatively, you can select the variable 
name from the Variables menu.
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The formula cell now contains an expression similar to 
=capture(objpathX,1).

Note: The argument “1” tells Lists & Spreadsheet that you want the 
captures to be triggered by the variable change.

6. If you want the capture to also be triggered by changes in an 
additional variable or variables, type a comma after the 1, and then 
type the variable name or the name of a list that itemizes the 
variables.

The formula cell will contain an expression similar to 
=capture(objpathX,1,objpathY).

7. Press · to complete the formula.

8. If you are capturing multiple columns of synchronized data, set up 
the additional columns. For example, you might set up a second 
capture variable using 
=capture(objpathY,1,objpathX).

9. When you are ready to capture the values, begin moving the object 
or start the animation that affects it in Graphs & Geometry.

Each captured value is added to the end of the list.

Using Table Data for Statistical Analysis
Tools on the Statistics menu provide access to wizards that help you 
perform statistical analyses on the data in table columns. You specify the 
location of the data, and Lists & Spreadsheet stores the results in two 
columns: one for the result names, and one for the corresponding values.

Plotting Statistical Data
Some statistics wizards include a Draw check box. By default, the box is 
not selected. Selecting this box creates a Data & Statistics work area on 
the page, displays the calculated results in Lists & Spreadsheet, and draws 
the results of the statistical analysis in the Data & Statistics work area. 
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Note: For functions that support the Draw option, the option is available 
only if you type the function in a column formula cell.

Statistics Input Descriptions
The following table describes the different inputs used in 
Lists & Spreadsheet wizards.

Draw check box (as shown in the z Test wizard).

Input Description

m0 Hypothesized value of the population mean that you 
are testing.

s The known population standard deviation; must be a 
real number > 0.

List The name of the list containing the data you are 
testing.

Frequency List The name of the list containing the frequency values 
for the data in List. Default=1. All elements must be 
integers | 0. The frequency values can also be typed 
as a list, in the format {1, 1, 3, 2}.

v, Sx, n Summary statistics (mean, standard deviation, and 
sample size) for the one-sample tests and intervals.

s1 The known population standard deviation from the 
first population for the two-sample tests and 
intervals. Must be a real number > 0.

s2 The known population standard deviation from the 
second population for the two-sample tests and 
intervals. Must be a real number > 0.
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List 1, List 2 The names of the lists containing the data you are 
testing for the two-sample tests and intervals. 

Frequency 1 
Frequency 2

The names of the lists containing the frequencies for 
the data in List 1 and List 2 for the two-sample tests 
and intervals. Defaults=1. All elements must be 
integers | 0.

v1, Sx1, n1, v2, 
Sx2, n2

Summary statistics (mean, standard deviation, and 
sample size) for sample one and sample two in two-
sample tests and intervals.

Pooled Specifies whether variances are to be pooled for 
2-Sample t Test and 2-Sample t Interval.

p0 The expected sample proportion for 1-Prop z Test. 
Must be a real number, such that 0 < p0 < 1.

x The count of successes in the sample for the 
1-Prop z Test and 1-Prop z Interval. Must be an 
integer | 0. 

n The count of observations in the sample for the 
1-Prop z Test and 1-Prop z Interval. Must be an 
integer > 0.

x1 The count of successes from sample one for the 
2-Prop z Test and 2-Prop z Interval. Must be an 
integer | 0. 

x2 The count of successes from sample two for the 
2-Prop z Test and 2-Prop z Interval. Must be an 
integer | 0.

n1 The count of observations in sample one for the 
2-Prop z Test and 2-Prop z Interval. Must be an 
integer > 0.

n2 The count of observations in sample two for the 
2-Prop z Test and 2-Prop z Interval. Must be an 
integer > 0.

C-Level The confidence level for the interval instructions. 
Must be | 0 and < 100. If it is | 1, it is assumed to be 
given as a percent and is divided by 100. 
Default=0.95. 

Input Description
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Statistical Calculations

Performing a Statistical Calculation
You can perform statistical calculations to analyze data. The following 
example fits a y=mx+b linear regression model to two lists.

1. Click the column formula cell (second cell from the top) in column A.

2. Click Statistics > Stat Calculation > Linear Regression (mx+b) to 
choose the regression model.

The Linear Regression (mx+b) dialog box opens and displays fields 
for typing or selecting each argument. Because you selected a cell in 
advance, the column for X List is already filled in with the column 
letter of the list with a cell selected.

3. Press e to move to the Y List box and click the drop-down arrow 
to select a named list.

4. To store the regression equation in a specified variable, press e 
and replace Save RegEqn To with the name of the variable.

5. Press e as necessary to move to the 1st Result box and type c[] as 
the column letter for the first result column.

6. Click OK.

Lists & Spreadsheet inserts two columns: one containing the names 
of the results, and one containing the corresponding values.

Note: The results are linked to the source data. For example, if you 
change a value in column A, the regression equation is updated 
automatically.

RegEQ The prompt for the name of the function where the 
calculated regression equation is to be stored. 

Input Description
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Storing Statistical Results
Lists & Spreadsheet stores statistical results using a variable-group name 
with the format stat.nnn, where nnn is the result name (for example, 
stat.RegEqn and stat.Resid). The use of standard names for variables 
makes it easier to identify and use the statistical variables later. If you 
want to use a custom variable group instead of the standard name, you 
can edit the formula in the column formula cell.

You could use the following formula to store the results in the variable 
group MystatsB.

=LinRegMx(a[],b[],1 ): CopyVar Stat., MystatsB.

Later, you could view the results by entering the following expression 
in the Calculator application or in another column of the 
Lists & Spreadsheet application:

MystatsB.results

Supported Statistical Calculations
The Stat Calculations menu lets you select from the calculations 
described below. For more information, see the TI-Nspire™ Reference 
Guide.

One-Variable Statistics (OneVar)
Analyzes data with one measured variable. You can specify an optional 
frequency list. The statistical data returned using this analysis technique 
are:

• Sample mean, x

• Sum of the data, Gx

• Sum of the squared data, Gx2

• Sample standard deviation, sx

• Population standard deviation, sx

• Sample size, n

• X-min

• First quartile, Q1

• Median

• Third quartile, Q3

• X-max

• Sum of squared deviations, SSx = G(x N x)2
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Two-Variable Statistics (TwoVar)
Analyzes paired data. List 1 is the independent variable. List 2 is the 
dependent variable. You can specify an optional frequency list. The 
statistical data returned using this analysis technique are:

For each list:

• Sample mean, x or y

• Sum of the data, Gx or Gy

• Sum of the squared data, Gx2 or Gy2

• Sample standard deviation, sx = sn-1x or sy = sn-1y

• Population standard deviation, sx = snx or sy = sny

• X-min or Y-min

• First quartile, Q1X or Q1Y

• Median

• Third quartile, Q3X or Q3Y

• X-max or Y-max

• Sum of squared deviations, SSx = G(x N x)2 or SSy = G(y N y)2

Additional data:

• Sample size for each data set, n

• Gxy

• Correlation coefficient, R.

Linear Regression (mx+b) (LinRegMx)
Fits the model equation y=ax+b to the data using a least-squares fit. It 
displays values for m (slope) and b (y-intercept).

Linear Regression (a+bx) (LinRegBx)
Fits the model equation y=a+bx to the data using a least-squares fit. It 

displays values for a (y-intercept), b (slope), r2, and r.

Median-Median Line (MedMed)
Fits the model equation y=mx+b to the data using the median-median 
line (resistant line) technique, calculating the summary points x1, y1, x2, 
y2, x3, and y3. Median-Median Line displays values for m (slope) and 
b (y-intercept).
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Quadratic Regression (QuadReg)

Fits the second-degree polynomial y=ax2+bx+c to the data. It displays 

values for a, b, c, and R2. For three data points, the equation is a 
polynomial fit; for four or more, it is a polynomial regression. At least 
three data points are required.

Cubic Regression (CubicReg)

Fits the third-degree polynomial y=ax3+bx2+cx+d to the data. It displays 

values for a, b, c, d, and R2. For four points, the equation is a polynomial 
fit; for five or more, it is a polynomial regression. At least four points are 
required.

Quartic Regression (QuartReg)

Fits the fourth-degree polynomial y=ax4+bx3+cx2+dx+e to the data. It 

displays values for a, b, c, d, e, and R2. For five points, the equation is a 
polynomial fit; for six or more, it is a polynomial regression. At least five 
points are required.

Power Regression (PowerReg)

Fits the model equation y=axb to the data using a least-squares fit on 

transformed values ln(x) and ln(y). It displays values for a, b, r2, and r.

Exponential Regression (ExpReg)

Fits the model equation y=abx to the data using a least-squares fit on 

transformed values x and ln(y). It displays values for a, b, r2, and r.

Logarithmic Regression (LogReg)
Fits the model equation y=a+b ln(x) to the data using a least-squares fit 

on transformed values ln(x) and y. It displays values for a, b, r2, and r. 

Sinusoidal Regression (SinReg)
Fits the model equation y=a sin(bx+c)+d to the data using an iterative 
least-squares fit. It displays values for a, b, c, and d. At least four data 
points are required. At least two data points per cycle are required to 
avoid aliased frequency estimates.

Note: The output of SinReg is always in radians, regardless of the 
Radian/Degree mode setting. 

Logistic Regression (d=0) (Logistic)

Fits the model equation y=c/(1+a*eLbx) to the data using an iterative least-
squares fit. It displays values for a, b, and c.
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Logistic Regression (dƒ0) (LogisticD)

Fits the model equation y=c/(1+a*e(Lbx))+d to the data using an iterative 
least-squares fit. It displays values for a, b, c and d.

Multiple Linear Regression (MultReg)
Calculates multiple linear regression of list Y on lists X1, X2, …, X10.

Distributions

Calculating Distributions
You can calculate a distribution to fit the Normal Pdf distribution model. 

1. Click the column formula cell (second cell from the top) in column A. 

2. Click Statistics menu > Distributions > Normal Pdf to choose the 
Distribution model. 

The Normal Pdf dialog box opens and displays fields for typing or 
selecting the arguments for the calculation. 

– Press e as necessary to move from field to field and provide 
each argument. You can type values, or select them from the 
drop down list:

– X Value: Click the drop-down arrow to choose any list in the 
problem to provide the x values for the calculation.

– Mean: Type a value for the mean or click the drop-down arrow 
to choose a variable that contains the mean.

– Standard Deviation: Type a value for the standard deviation or 
choose a variable that contains the standard deviation.

3. Click the Draw check box to see the distribution plotted in Data & 
Statistics. 

Note: The Draw option is not available for all distributions.

4. Click OK. 

Lists & Spreadsheet inserts two columns: one containing the names 
of the results, and one containing the corresponding values. The 
results are plotted in Data & Statistics. 
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Note: The results are linked to the source data. For example, you can 
change a value in Column A, and the equation updates 
automatically. 

Supported Distribution Functions
The following distributions are available from the Lists & Spreadsheet 
application. For more information regarding these functions, see the 
TI-Nspire™ Reference Guide.

• To return a single distribution result based on a single value, type the 
function in a single cell.

• To return a list of distribution results based on a list of values, type 
the function in a column formula cell. In this case, you specify a list 
(column) that contains the values. For each value in the list, the 
distribution returns a corresponding result. 

Note: For distribution functions that support the draw option 

(normPDF, t PDF, c2 Pdf, and F Pdf), the option is available only if 
you type the distribution function in a formula cell.

Normal Pdf (normPdf)
Computes the probability density function (pdf) for the normal 
distribution at a specified x value. The defaults are mean m=0 and 
standard deviation s=1. The probability density function (pdf) is:

This distribution is used to determine the probability of the occurrence of 
a certain value in a normal distribution. The draw option is available 
when Normal PDF is invoked from a formula cell.
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When you access distributions from the formula cell, you must select a 
valid list from the drop-down list to avoid unexpected results. If accessed 
from a cell, you must specify a number for the x-value. The distribution 
returns the probability that the value you specify will occur.

Normal Cdf (normCdf)
Computes the normal distribution probability between Lower Bound and 
Upper Bound for the specified mean, m (default=0) and the standard 
deviation, s (default=1). You can click the Draw (Shade area) check box 
to shade the area between the lower and upper bounds. Changes to the 
initial Lower Bound and Upper Bound automatically update the 
distribution.

This distribution is useful in determining the probability of an occurrence 
of any value between the lower and upper bounds in the normal 
distribution. It is equivalent to finding the area under the specified 
normal curve between the bounds.

Inverse Normal (invNorm)
Computes the inverse cumulative normal distribution function for a 
given area under the normal distribution curve specified by mean, m, and 
standard deviation, s. 

This distribution is useful in determining the x-value of data in the area 
from 0 to x<1 when the percentile is known.

t Pdf (tPdf)
Computes the probability density function (pdf) for the t-distribution at 
a specified x value. df (degrees of freedom) must be > 0. The probability 
density function (pdf) is:

This distribution is useful in determining the probability of the 
occurrence of a value when the population standard deviation is not 
known and the sample size is small. The draw option is available when 
t Pdf is invoked from a formula cell.

t Cdf (tCdf)
Computes the Student-t distribution probability between Lower Bound 
and Upper Bound for the specified df (degrees of freedom). You can click 
the Draw (Shade area) check box to shade the area between the 
bounds. Changes to the initial Lower Bound and Upper Bound 
automatically update the distribution.
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This distribution is useful in determining the probability of the 
occurrence of a value within an interval defined by the lower and upper 
bound for a normally distributed population when the population 
standard deviation is not known.

Inverse t (invt)
Computes the inverse cumulative t-distribution probability function 
specified by Degrees of Freedom, df, for a given area under the curve.

This distribution is useful in determining the probability of an occurrence 
of data in the area from 0 to x<1. This function is used when the 
population mean and/or population standard deviation is not known.

c2 Pdf (c2 Pdf())

Computes the probability density function (pdf) for the c2 (chi-square) 
distribution at a specified x value. df (degrees of freedom) must be an 
integer > 0. The probability density function (pdf) is:

This distribution is useful in determining the probability of the 

occurrence of a given value from a population with a c2 distribution. The 

draw option is available when c2 Pdf is invoked from a formula cell.

c2 Cdf (c2 Cdf())

Computes the c2 (chi-square) distribution probability between lowBound 
and upBound for the specified df (degrees of freedom). You can click the 
Draw Shade area check box to shade the area between the lower and 
upper bounds. Changes to the initial lowBound and upBound 
automatically update the distribution.

This distribution is useful in determining the probability of the 

occurrence of value within given boundaries of a population with a c2 

distribution.

F Pdf (F Pdf())
Computes the probability density function (pdf) for the F distribution at 
a specified x value. numerator df (degrees of freedom) and denominator df 
must be integers > 0. The probability density function (pdf) is:



Lists & Spreadsheet 505

This distribution is useful in determining the probability that two 
samples have the same variance. The draw option is available when F Pdf 
is invoked from a formula cell.

F Cdf (F Cdf())
Computes the F distribution probability between lowBound and upBound 
for the specified dfnumer (degrees of freedom) and dfDenom. You can click 
the Draw (Shade area) check box to shade the area between the lower 
and upper bounds. Changes to the initial lowBound and upBound 
automatically update the distribution.

This distribution is useful in determining the probability that a single 
observation falls within the range between the lower bound and upper 
bound.

Binomial Pdf (binomPdf())
Computes a probability at x for the discrete binomial distribution with 
the specified numtrials and probability of success (p) on each trial. The x 
parameter can be an integer or a list of integers. 0{p{1 must be true. 
numtrials must be an integer > 0. If you do not specify x, a list of 
probabilities from 0 to numtrials is returned. The probability density 
function (pdf) is:

where n = numtrials

This distribution is useful in determining the probability of success in a 
success/failure trial, at trial n. For example, you could use this distribution 
to predict the probability of getting heads in a coin toss on the fifth toss.

Binomial Cdf (binomCdf())
Computes a cumulative probability for the discrete binomial distribution 
with n number of trials and probability p of success on each trial.

This distribution is useful in determining the probability of a success on 
one trial before all trials are completed. For example, if heads is a 
successful coin toss and you plan to toss the coin 10 times, this 
distribution would predict the chance of obtaining heads at least once in 
the 10 tosses.

where n = numerator degrees of freedom
d = denominator degrees of freedom
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Poisson Pdf (poissPdf())
Computes a probability at x for the discrete Poisson distribution with the 
specified mean, m, which must be a real number > 0. x can be an integer 
or a list of integers. The probability density function (pdf) is: 

This distribution is useful in determining the probability of obtaining a 
certain number of successes before a trial begins. For example, you could 
use this calculation to predict the number of heads that would occur in 
eight tosses of a coin.

Poisson Cdf (poissCdf())
Computes a cumulative probability for the discrete Poisson distribution 
with specified mean, l.

This distribution is useful in determining the probability that a certain 
number of successes occur between the upper and lower bounds of a 
trial. For example, you could use this calculation to predict the number of 
heads displayed between coin toss #3 and toss #8.

Geometric Pdf (geomPdf())
Computes a probability at x, the number of the trial on which the first 
success occurs, for the discrete geometric distribution with the specified 
probability of success p. 0{p{1 must be true. x can be an integer or a list 
of integers. The probability density function (pdf) is:

This distribution is useful in determining the likeliest number of trials 
before a success is obtained. For example, you could use this calculation 
to predict the number of coin tosses that would be made before a heads 
resulted.

Geometric Cdf (geomCdf())
Computes a cumulative geometric probability from lowBound to 
upBound with the specified probability of success, p.

This distribution is useful in determining the probability associated with 
the first success occurring during trials 1 through n. For example, you 
could use this calculation to determine the probability that heads display 
on toss #1, #2, #3, ..., #n.
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Confidence Intervals

Supported Confidence Intervals
The following confidence intervals are available from the Lists & 
Spreadsheets application. For more information regarding these 
functions, see the TI-Nspire™ Reference Guide.

z Interval (zInterval)
Computes a confidence interval for an unknown population mean, m, 
when the population standard deviation, s, is known. The computed 
confidence interval depends on the user-specified confidence level.

This test is useful in determining how far from a population mean a 
sample mean can get before indicating a significant deviation.

t Interval (tInterval)
Computes a confidence interval for an unknown population mean, m, 
when the population standard deviation, s, is unknown. The computed 
confidence interval depends on the user-specified confidence level.

This test is useful in examining whether the confidence interval 
associated with a confidence level contains the value assumed in the 
hypothesis. Like the z Interval, this test helps you determine how far 
from a population mean a sample mean can get before indicating a 
significant deviation when the population mean is unknown.

2-Sample z Interval (zInterval_2Samp)
Computes a confidence interval for the difference between two 
population means (m1Nm2) when both population standard deviations (s1 
and s2) are known. The computed confidence interval depends on the 
user-specified confidence level.

This test is useful in determining if there is statistical significance 
between the means of two samples from the same population. For 
example, this test could determine whether there is significance between 
the mean college entrance test score of female students and the mean of 
college entrance test score of male students at the same school.

2-Sample t Interval (tInterval_2Samp)
Computes a confidence interval for the difference between two 
population means (m1Nm2) when both population standard deviations (s1 
and s2) are unknown. The computed confidence interval depends on the 
user-specified confidence level.
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This test is useful in determining if there is statistical significance 
between the means of two samples from the same population. It is used 
instead of the 2-sample z confidence interval in situations where the 
population is too large to measure to determine the standard deviation.

1-Prop z Interval (zInterval_1Prop)
Computes a confidence interval for an unknown proportion of successes. 
It takes as input the count of successes in the sample x and the count of 
observations in the sample n. The computed confidence interval depends 
on the user-specified confidence level.

This test is useful in determining the probability of a given number of 
successes that can be expected for a given number of trials. For instance, 
casino examiners would use this test to determine if observed payouts for 
one slot machine demonstrate a consistent pay out rate.

2-Prop z Interval (zInterval_2Prop)
Computes a confidence interval for the difference between the 
proportion of successes in two populations (p1-p2). It takes as input the 
count of successes in each sample (x1 and x2) and the count of 
observations in each sample (n1 and n2). The computed confidence 
interval depends on the user-specified confidence level.

This test is useful in determining if two rates of success differ because of 
something other than sampling error and standard deviation. For 
example, a bettor could use this test to determine if there is an 
advantage in the long run by playing one game or machine versus 
playing another game or machine.

Linear Reg t Intervals (LinRegtIntervals)
Computes a linear regression t confidence interval for the slope 
coefficient b. If the confidence interval contains 0, this is insufficient 
evidence to indicate that the data exhibits a linear relationship.

Multiple Reg Intervals (MultRegIntervals)
Computes multiple regression prediction confidence interval for the 
calculated y and a confidence for y.

Stat Tests

Supported Statistical Tests
Hypothesis tests are available from the Lists & Spreadsheets application. 
For more information regarding these functions, see the TI-Nspire™ 
Reference Guide.
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Some of the wizards for Stat Tests display a Draw check box. By default, 
the box is not selected. Selecting the box creates a Data & Statistics work 
area on the page and plots the results in that work area.

z test (zTest)
Performs a hypothesis test for a single unknown population mean, m, 
when the population standard deviation, s, is known. It tests the null 
hypothesis H0: m=m0 against one of the alternatives below.

• Ha: mƒm0 

• Ha: m<m0 

• Ha: m>m0 

This test is used for large populations that are normally distributed. The 
standard deviation must be known. 

This test is useful in determining if the difference between a sample 
mean and a population mean is statistically significant when you know 
the true deviation for a population.

t test (tTest)
Performs a hypothesis test for a single unknown population mean, m, 
when the population standard deviation, s, is unknown. It tests the null 
hypothesis H0: m=m0 against one of the alternatives below.

• Ha: mƒm0 

• Ha: m<m0 

• Ha: m>m0

This test is similar to a z-test, but is used when the population is small and 
normally distributed. This test is used more frequently than the z-test 
because small sample populations are more frequently encountered in 
statistics than are large populations. 

This test is useful in determining if two normally distributed populations 
have equal means, or when you need to determine if a sample mean 
differs from a population mean significantly and the population 
standard deviation is unknown.

2-Sample z Test (zTest_2Samp)
Tests the equality of the means of two populations (m1 and m2) based on 
independent samples when both population standard deviations (s1 and 
s2) are known. The null hypothesis H0: m1=m2 is tested against one of the 
alternatives below.

• Ha: m1ƒm2 
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• Ha: m1<m2 

• Ha: m1>m2 

2-Sample t Test (tTest_2Samp)
Tests the equality of the means of two populations (m1 and m2) based on 
independent samples when neither population standard deviation (s1 or 
s2) is known. The null hypothesis H0: m1=m2 is tested against one of the 
alternatives below.

• Ha: m1ƒm2 

• Ha: m1<m2 

• Ha: m1>m2 

1-Prop z Test (zTest_1Prop)
Computes a test for an unknown proportion of successes (prop). It takes 
as input the count of successes in the sample x and the count of 
observations in the sample n. 1-Prop z Test tests the null hypothesis 
H0: prop=p0 against one of the alternatives below.

• Ha: propƒp0 

• Ha: prop<p0 

• Ha: prop>p0 

This test is useful in determining if the probability of the success seen in a 
sample is significantly different from the probability of the population or 
if it is due to sampling error, deviation, or other factors.

2-Prop z Test (zTest_2Prop)
Computes a test to compare the proportion of successes (p1 and p2) from 
two populations. It takes as input the count of successes in each sample 
(x1 and x2) and the count of observations in each sample (n1 and n2). 
2-Prop z Test tests the null hypothesis H0: p1=p2 (using the pooled 
sample proportion Ç) against one of the alternatives below.

• Ha: p1ƒp2 

• Ha: p1<p2 

• Ha: p1>p2 

This test is useful in determining if the probability of success seen in two 
samples is equal.
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c2GOF (c2GOF)
Performs a test to confirm that sample data is from a population that 

conforms to a specified distribution. For example, c2 GOF can confirm 
that the sample data came from a normal distribution.

c2 2-way Test (c22way)
Computes a chi-square test for association on the two-way table of 
counts in the specified Observed matrix. The null hypothesis H0 for a two-

way table is: no association exists between row variables and column 
variables. The alternative hypothesis is: the variables are related.

2-Sample FTest (FTest_2Samp)
Computes an F-test to compare two normal population standard 
deviations (s1 and s2). The population means and standard deviations 
are all unknown. 2-Sample FTest, which uses the ratio of sample 

variances Sx12/Sx22, tests the null hypothesis H0: s1=s2 against one of the 
alternatives below.

• Ha: s1ƒs2 

• Ha: s1<s2 

• Ha: s1>s2 

Below is the definition for the 2-Sample FTest.

2-Sample FTest for the alternative hypothesis s1 > s2.

Sx1, Sx2 = Sample standard deviations having n1N1 
and n2N1 degrees of freedom df, 
respectively.

F =
F-statistic  = 

df(x, n1N1, n2N1) = Fpdf( ) with degrees of freedom df, n1N1, 
and n2N1

p = reported p value
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2-Sample FTest for the alternative hypothesis s1 < s2.

2-Sample FTest for the alternative hypothesis s1ƒs2. Limits must satisfy 
the following:

where: [Lbnd,Ubnd] = lower and upper limits

The F-statistic is used as the bound producing the smallest integral. The 
remaining bound is selected to achieve the preceding integral’s equality 
relationship.

Linear Reg t Test (LinRegtTest)
Computes a linear regression on the given data and a t test on the value 
of slope b and the correlation coefficient r for the equation y=a+bx. It 
tests the null hypothesis H0: b=0 (equivalently, r=0) against one of the 
alternatives below.

• Ha: bƒ0 and rƒ0 

• Ha: b<0 and r<0

• Ha: b>0 and r>0

Multiple Reg Tests (MultRegTest)
Computes a linear regression on the given data, and provides the F test 
statistic for linearity. 

For more information, see the TI-Nspire™ Reference Guide.

ANOVA (ANOVA)
Computes a one-way analysis of variance for comparing the means of 2 
to 20 populations. The ANOVA procedure for comparing these means 
involves analysis of the variation in the sample data. The null hypothesis 
H0: m1=m2=...=mk is tested against the alternative Ha: not all m1...mk are 
equal.

The ANOVA test is a method of determining if there is a significant 
difference between the groups as compared to the difference occurring 
within each group. 
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This test is useful in determining if the variation of data from sample-to-
sample shows a statistically significant influence of some factor other 
than the variation within the data sets themselves. For example, a box 
buyer for a shipping firm wants to evaluate three different box 
manufacturers. He obtains sample boxes from all three suppliers. ANOVA 
can help him determine if the differences between each sample group 
are significant as compared to the differences within each sample group.

ANOVA 2-Way (ANOVA2way)
Computes a two-way analysis of variance for comparing the means of 
two to 20 populations. A summary of results is stored in the stat.results 
variable.

The two-way ANOVA analysis of variance examines the effects of two 
independent variables and helps to determine if these interact with 
respect to the dependent variable. (In other words, if the two 
independent variables do interact, their combined effect can be greater 
than or less than the impact of either independent variable additively.) 

This test is useful in evaluating differences similar to the ANOVA analysis 
but with the addition of another potential influence. To continue with 
the ANOVA box example, the two-way ANOVA might examine the 
influence of box material on the differences seen.

Selecting an Alternative Hypothesis (ƒ < >)
Most of the inferential stat editors for the hypothesis tests prompt you to 
select one of three alternative hypotheses.

• The first is a ƒ alternative hypothesis, such as mƒm0 for the z Test.

• The second is a < alternative hypothesis, such as m1<m2 for the 
2-Sample t Test.

• The third is a > alternative hypothesis, such as p1>p2 for the 
2-Prop z Test.

To select an alternative hypothesis, move the cursor to the appropriate 
alternative, and then press ·.

Selecting the Pooled Option
Pooled (2-Sample t Test and 2-Sample t Interval only) specifies whether 
the variances are to be pooled for the calculation.

• Select No if you do not want the variances pooled. Population 
variances can be unequal.

• Select Yes if you want the variances pooled. Population variances are 
assumed to be equal.

To select the Pooled option, select Yes from the drop-down list.
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Working with Function Tables
The Lists & Spreadsheet application lets you show a table of function 
values for any function in the current problem. You can change the 
settings for the table, delete columns, add values for multiple functions, 
and edit the expression that defines a function without leaving the 
Lists & Spreadsheet application.

Switching to a Table

1. While working in the Lists & Spreadsheet application, press / T to 
switch to a table.

Mac®: “ T

The Lists & Spreadsheet application disappears and an empty table is 
displayed with a list of the functions that are available in the 
problem.

Note: If you have previously shown a table for a function from the 
Lists & Spreadsheet application, the table includes that function by 
default.

2. Choose the name of the function for which you want to display 
values. 

Values for the function you selected are displayed in the first column 
of the table.

3. To move through adjacent cells of the table, press £ or ¤. Press e 
to move from the body of the table (cells) to the top two rows (cells 
for column names and formulas).

4. To hide the table of values and return to the Lists & Spreadsheet 
application, repeat Step 1.

Making Changes from a Table
You can change the table of function values using the tools on the Table 
menu.

8 To remove a column from the table, click any cell and click Delete 
Column.

8 To display the list of functions, click a cell in a column and click 
Choose. Select a cell in an empty column unless you are replacing 
values already displayed. Click a function in the list to add its values 
to the column.

Note: You can also click the drop-down arrow on the top cell of a 
column to display the list of functions in the problem.
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8 To change the expression that defines a function, click Edit 
Expression. You can also edit the expression directly on the entry 
line beneath the table.

Note: When you edit the expression for a function, that function 
automatically changes in the application used to define the function. 
For example, if you edit a Graphs & Geometry function in the table, 
the table values and graph of the function are both updated.

8 To change the default table settings, choose Edit Table Settings.

The Table dialog box opens. Press e to move from field to field 
and type or select new values for the default table settings:

– Table Start: Type the value to use as the first value in the table 
of values.

– Table Step: Type a value for the interval between values.

– Independent and Dependent: Click the drop-down arrow to 
choose Auto or Ask as the method for populating a column 
with the values of the independent and dependent variables. 
Auto populates the table starting at the defined table start 
value and displays an independent and dependent value for 
each step. Ask lets you select a cell and press · to generate a 
value for a cell.
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Data & Statistics

The Data & Statistics application provides tools to: 

• Visualize sets of data in different types of plots.

• Directly manipulate variables to explore and visualize data 
relationships. Data changes in one application are dynamically 
applied to all linked applications.

• Explore central tendency and other statistical summary techniques.

• Fit functions to data.

• Create regression lines for scatter plots.

• Graph hypothesis tests and results (z- and t-tests) based on summary 
statistics definitions or data.

À Data & Statistics tool menu

Á Work area

Â Add Variable regions on x-axis and y-axis

Ã Normal Probability Plot with expression (click line to open)

Ä Data point with coordinates (hover to open xlist variable data with 
Expected z)



518 Data & Statistics

Getting Started with the Data & Statistics 
Application
The Data & Statistics application lets you explore and visualize data and 
graph inferential statistics. The Lists & Spreadsheet application can work 
in conjunction with the Data & Statistics application. The 
Lists & Spreadsheet Summary Plot and Quick Graph tools automatically 
add a Data & Statistics application to show plots. A list that you create in 
a problem (using the Lists & Spreadsheet or Calculator applications) can 
be accessed as a variable in any TI-Nspire™ application in that problem.

Using the Default Caseplot
The Data & Statistics application plots numeric and string (categorical) 
data from variables. When you add a Data & Statistics application to a 
problem that includes lists, a default caseplot displays on the work area.

The caseplot is like having a stack of cards with information on them and 
scattering the cards randomly on a table. You can click a dot to see the 
information on that “card.” You can drag a dot to “group” the “cards” 
by the caption variable.

8 Click the variable name displayed after Caption to use the caseplot.

– Choose <None> to remove the default caseplot.

– Choose the name of a variable to have it replace the current 
caseplot variable. 

– Hover over any data point to see the summary information.

– Drag any data point toward an axis to see how the points group.

– Activate the Graph Trace tool and press 7 or 8 to move across 
points.

When you add a variable to either axis, the plot for that variable replaces 
the default caseplot. The default caseplot redisplays if you remove the 
plotted variable from each axis.
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Navigating in the Data & Statistics Application
You can plot variables by clicking the Add Variable region in the center 
of the horizontal and vertical axes. The work area displays data points to 
represent the values in variables. You can press e to move among 
these functional areas.

Using the Axes
The horizontal and vertical axes include an Add Variable region near the 
center. You can click the Add Variable region of an axis to view a list of all 
variables available in the problem, or open the context menu to use tools 
to help you work with data.

Using the Context Menu
The context menu provides access to the tools most commonly used with 
the selected object. The context menu displays different options 
depending on the active object and the task you are performing.

8 To open the context menu for an object:

Windows®: Right-click the object.

Mac®: Hold “ and click the object.

Handheld: Point to the object and press / b.

The context menu includes the Color option. You can use the Color 
option to change the data to the color of your choice.

Other options that are appropriate for various plots also appear on the 
context menu. 

Selecting Data and Displaying Summary Information
When you hover over part of a plot, the Data & Statistics application 
displays summary information for the data it represents. 

1. Hover at an area of interest in a plot to display data values or 
summary information. For example, you can hover over the center of 
a box plot to display the median summary data.

2. Click once to select a representation of data in a plot.

Data points are shown with a bold outline to indicate selection. You 
can click a point a second time to deselect it, or click additional 
points to add to the selection.

Plotting Variables
To plot variables, start with a problem that includes a Data & Statistics 
application and lists created in the Lists & Spreadsheet application or the 
Calculator application.
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1. Click the Add Variable region near the center of an axis. 

If no variable is plotted on the axis, the tooltip Click or Enter to add 
variable displays. 

2. Click the tooltip Click or Enter to add variable. 

A list displays the names of available variables.

3. Click the name of the variable to plot.

Note: By convention, the independent variable is shown on the 
x-axis.

The default plot for one variable is a dot chart. The data points in 
the default caseplot reposition to represent the elements of the 
selected variable in a dot chart. 

4. (Optional) Click the Add Variable region near the center of the 
remaining axis to plot a second variable. 

The default plot for two variables is a scatter plot. The data points 
shift to represent the elements of both variables as a scatter plot. 

5. (Optional) Repeat Steps 1-3 to choose additional variables to plot on 
the vertical axis.

The name of each variable that you add is appended to the label on 
the axis. The default data point shape changes to help you 
distinguish data, and a legend is displayed to identify the shapes.

6. Change, analyze, or explore the plotted data.

– Remove or change the variable on an axis by clicking the Add 
Variable region again. 
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– View the plotted data in another supported plot type by 
selecting a tool from the Plot Types menu. 

– Choose the Graph Trace tool on the Analyze menu and press 
7 or 8 to move across the data points in the plot.

– The lists that you plot as variables can include incomplete or 
missing cases. (A case is the data contained in a row of cells in 
the Lists & Spreadsheet application.) The Lists & Spreadsheet 
application displays a void as an underscore (“_”), and 
Data & Statistics plots no data point for a void cell.

Manipulating Plotted Data
You can manipulate data points on the Data & Statistics work area to 
explore their effects. For example, you could explore how a specific 
group of values affects the median.

You can move a data point only in directions allowed by its definition. If 
a list is defined with a formula in Lists & Spreadsheet, the points in 
Data & Statistics may not move because of the formula’s restrictions. For 
example, you can manipulate a plot that represents the result of y=x, but 
you can only move along a line. 

You cannot move points that represent data in a locked variable or data 
that represents a categorical value.

To Move Plotted Data:
1. On the Data & Statistics work area, click a representation of data—

such as a histogram bin or a whisker of a box plot—that is not locked 
or restricted by a formula.

The pointer changes to an open hand to show that the data can be 
moved.
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2. Drag the selection to explore how different values of the point 
affect the plot.

As you drag, the changing value displays on the work area.

Overview of Raw and Summary Data
You can create plots directly from raw data or from a summary table.

• Raw data consists of a single list, such as a list of eye colors. When 
you create a plot of raw data, Data & Statistics counts the 
occurrences for you. Plotting raw data directly gives you flexibility in 
analyzing it.

• A summary table consists of two lists, such as eye colors (the 
X or Y List) and counts of eye-color occurrences (the Summary List). 
For more information, see Using Lists & Spreadsheet chapter.

Working with Numeric Plot Types
Plots can represent the data from a variable in a variety of ways. 
Choosing the appropriate plot can help you visualize the data. For 
example, you may be able to observe the shape and spread of the data in 
one plot type and another type may be useful for determining the best 
method for statistically evaluating data. Use Data & Statistics to create 
the following types of numeric plots.

• Dot Plot

• Box Plot

• Histogram

• Normal Probability

• Scatter Plot

• X-Y Line 

raw data summary table for eye color based on 
raw data
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Creating Dot Plots
Dot plots, also known as dot-frequency plots, represent one-variable 
data. Dot plots are the default plot type for numeric data. When you plot 
a variable as a dot plot, one dot represents each value in the list. Each dot 
displays on the axis at a point that correspond to the value. 

1. To create a dot plot, click the Add Variable region in the center of an 
axis and click the name of a numeric variable. For more information, 
see Plotting Variables.

2. (Optional) To split a dot plot by category, click the Add Variable 
region on the other axis and choose the list that contains the 
corresponding category data. 

3. (Optional) To plot multiple dot plots, choose Add X Variable on the 
Plot Properties menu and click a numeric variable from the list that 
displays. 

A second dot plot appears on the work area and the name of the 
plotted variable is added to both axis labels. 

4. Explore the plotted data.

– Hover over a data point to display data values.

– Drag a dot to move it. As you move a point, the values 
associated with it change on the work area display and in the list 
for the variable.

– Activate the Graph Trace tool and press 7 or 8 to move across 
the data points in the plot in list order. Points enlarge and 
display a bold outline as you move across them in Trace mode.

Creating Box Plots
The Box Plot Tool plots one-variable data in a modified box plot. 
“Whiskers” extend from each end of the box, either to 1.5 times the 
interquartile range or to the end of the data, whichever comes first. 
Points that are a width of 1.5 * Interquartile Range past the quartiles 
plot individually, beyond the whiskers. These points are the potential 
outliers. When no outliers exist, x-min and x-max are the prompt for the 
end of each whisker. 

Box plots are useful for comparing two or more sets of data that use the 
same scale. If a dataset is large, a box plot can also be useful in exploring 
data distribution. 

1. Click the Add Variable region in the center of an axis. The default 
plot for one numeric variable is a dot plot. For more information, see 
Plotting Variables.
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Note: If two variables are plotted in the work area, you can create a 
dot plot by removing one variable. Choose Remove X Variable or 
Remove Y Variable from the Plot Types menu.

2. On the Plot Types menu, click Box Plot. 

A modified box plot displays on the Data & Statistics work area. 

Note: You can split a box plot by category by adding a list that 
contains corresponding categorical data to the y-axis. 

3. (Optional) To add additional variables for comparing box plots on 
the same axis, click Add X Variable on the Plot Properties menu. 
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For example, you can use multiple box plots to compare the 
distributions of sample proportions. In the example, true proportion 
is .5 and sample size varies from n=20 to n=40 to n=90.

Notes:

– You can create a box plot with frequency by choosing Add X 
Variable or Add Y Variable on the Plot Properties menu.

– You can specify a variable multiple times as you choose variables 
to plot as box plots. 

– The variable used to provide frequency information is added to 
the label on the horizontal axis in the format: 
x_variablename{frequencylist_name}.

4. Point and click the regions of the box plot to explore and analyze the 
data it represents.

– Hover over a region or over a whisker to display the details for 
the portion of the plot that interests you. The label for the 
quartile that corresponds to your selection is displayed.

– Click a region of the box plot to select the data points or 
whiskers. Click again to remove the selection.

– You can select any box plot that does not include frequency data 
and choose Dot Plot on the context menu to change the plot 
type.

– Drag a selection to move it and explore other possibilities for the 
data.

– Use the arrow keys to move a data point one pixel at a time.

– Activate the Graph Trace tool and press 7 or 8 to move across 
dots and regions of the plot. As the trace cursor moves, the 
values for Q1, the median, Q3, and whisker ends/outliers are 
displayed.
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5. Change the plot from a modified box plot to a standard box plot by 
choosing Extend Box Plot Whiskers on the Plot Properties menu. 

The box plot is redrawn as a standard box plot with extended 
whiskers. 

The standard box plot’s whiskers use the minimum and maximum 
points in the variable and outliers are not identified. The whiskers on 
the plot extend from the minimum data point in the set (x-min) to 
the first quartile (Q1) and from the third quartile (Q3) to the 
maximum point (x-max). The box is defined by Q1, Med (median), 
and Q3.

Note: You can click Show Box Plot Outliers on the Plot Properties 
menu to return to the modified box plot.

Plotting Histograms
A histogram plots one-variable data and depicts the distribution of data. 
The number of bins displayed depends on the number of data points and 
the distribution of these points. A value that occurs on the edge of a bin 
is counted in the bin to the right.

Creating a Histogram from Raw Data
1. Create the list that you want to plot as a histogram. For example, 

you can enter or collect data as a named list on a Lists & Spreadsheet 
page.

2. On a Data & Statistics page, click the x or y axis, and select your list as 
the data to plot.

3. From the Plot Types menu, click Histogram.

The data forms the bins of a histogram, with Frequency plotted by 
default on the unselected axis.
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4. Explore the data.

– Hover over a bin to see the information for that bin.

– Click a bin to select it. Click the bin again to deselect it.

– Drag the side of a bin to adjust bin width and number of bins.

Note: The bins are not adjustable in categorical plots or plots in 
which you choose variable bin widths.

– On the Analyze menu, click Graph Trace and press 7 or 8 to 
cycle through the bins and display their values.

Adjusting the Histogram Scale of Raw Data
1. On the Plot Properties menu, click Histogram Properties and 

choose Histogram Scale.

2. Choose the format for the scale of the histogram. 

– Frequency - displays data based upon the number of values that 
occur within each bin. This is the default data representation.

– Percent - displays data in the histogram by each group’s percent 
value of the whole data set. 

– Density - displays data based upon the density of each group 
within the data set.

Creating a Histogram with Frequency or Summary Data
1. On a Lists & Spreadsheet page, create two lists: one containing the 

“bins,” such as heights in a population (ht), and the other containing 
the frequencies of those heights (freq).
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2. On a Data & Statistics page, access the context menu on the x axis, 
and click Add X Variable with Summary List.

3. Select ht as the X List and freq as the Summary List.

Note: It is up to you to set the data and bins in a meaningful way 
when using summary data.

Setting Equal Bin Widths
By default, bin widths are set to equal. You can specify the width and 
alignment of equal-width bins.

1. On the Plot Properties menu, click Histogram Properties > 
Bin Settings, and choose Equal Bin Width.

The Equal Bin Width Settings dialog box opens.

2. Type values to set Width and Alignment of the bins.

3. Click OK to apply the changes and redraw the bins.
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Both the data represented by the bins and the value you type for the 
alignment affect the placement of bins on the scale.

Setting Variable Bin Widths
You can set variable bin widths based on a list of bin boundaries.

1. Create a named list containing boundary values.

For example, a boundary list defined as {60,70,100,110} will create 
bins at 60 to 70, 70 to 100, and 100 to 110.

Note: The data must fall within the specified bin widths. For 
example, a data point of 115 would be outside the bins in the above 
list, and you would receive a Data/Bin Location Mismatch error.

2. On the Plot Properties menu, click Histogram Properties > 
Bin Settings, and choose Variable Bin Width.

The Variable Bin Width Settings dialog box opens.

3. Select your boundary list as the List of Bin Boundaries.

4. Click OK to apply the changes and redraw the bins.

Note: You cannot change variable bin widths by dragging their 
boundaries; you must edit the list of boundaries or restore equal-
width bins.



530 Data & Statistics

Creating a Normal Probability Plot
A normal probability plot shows one set of data against the 
corresponding quartile (z) of the standard normal distribution. You can 
use normal probability plots to judge the appropriateness of the normal 
model for your data.

1. Choose or create the data you want to use for a normal probability 
plot. Use a named list from Lists & Spreadsheet or Calculator.

2. Plot the data in one of the following ways:

– Create a dot plot by selecting a column and choosing Quick 
Graph.

– Add a Data & Statistics work area. Click the Add Variable region 
on an axis and click the data list name to plot the variable.

3. On the Plot Types menu, click Normal Probability Plot. 

The data graphs in the Data & Statistics work area. You can examine 
the graph to compare the normal variable against the quartile.

4. Explore the data represented in the normal probability plot.

– Hover over a data point to display its value.

– Click to select a data point. Click again to deselect it.

– Click multiple data points to select them.

– Activate the Graph Trace tool and press ¡ or ¢ to move across the 
data points and display values.

Creating a Scatter Plot
A scatter plot shows the relationship between two sets of data. You can 
also plot a scatter plot by using the Quick Graph tool in the 
Lists & Spreadsheet application.

1. In the Data & Statistics work area, click the Add Variable region and 
select the variable that contains the data you want to see 
represented on an axis. 

The plot of the selected variable displays on the axis.

2. Click the Add Variable region of the other axis and select the 
variable containing the data you want to plot.

The data points shift to represent the data in the selected variable.
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3. Analyze and explore the data in the plot.

– Click a point to select it.

– Hover over a data point to view the summary data.

– Work with the data using the available tools on the Analyze 
menu. For example, choose the Graph Trace tool and press ¡ or ¢ 
to move across the plot.

4. Optional: To plot additional lists against the x-axis, right-click the 
y-axis and click Add Variable.

Creating an X-Y Line Plot
An X-Y line plot is a scatter plot in which the data points are plotted and 
connected in order of appearance in the two variables. Like scatter plots, 
these plots depict the relationship between two sets of data.

By convention, the left-most column of data is represented on the 
horizontal axis. 

1. Create a scatter plot. For more information, see Creating a Scatter 
Plot for details.

2. On the Plot Types menu, click the XY Line Plot tool.

The data points within each set are connected to each other by a 
line. 
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Note: The dots are connected in the order that they appear in the 
list variable on the horizontal axis. To change the order, use the sort 
tool in Lists & Spreadsheet.

3. Analyze and explore the data in the plot.

– Hover over a data point to view the summary data.

– Work with the data using the available tools on the Analyze 
menu. For example, choose the Graph Trace tool and press the 
arrow keys to move across the dots in the plot and view the 
values.

Working with Categorical Plot Types
You can sort and group data using the categorical plot types:

• Dot Chart

• Bar Chart

• Pie Chart

The categorical plot types can be used to compare the representations of 
data across different plots. When the same variable (list) is used for a dot 
chart and a bar chart or pie chart in a problem, selecting a data point or 
segment in one of the plots selects the corresponding data point, 
segment, or bar in all other plots that include the variable.

Creating a Dot Chart
The default plot type for categorical data is the dot chart.

When one variable is plotted, the value of each cell is represented as one 
dot, and the dots are stacked at the point on the axis that corresponds to 
the cell value. 

1. In Lists & Spreadsheet, create a spreadsheet that includes at least one 
column of string values that can be used as categories for data.
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Note: To type a string in Lists & Spreadsheet, enclose the characters 
in quotes.

2. Add a Data & Statistics page to the problem. 

Notes: 

– You can also use the Lists & Spreadsheet Quick Graph tool to 
automatically add a Data & Statistics page and plot the selected 
column.

– The new Data & Statistic work area displays a default caseplot 
with a caption, variable name, and unplotted data points for the 
variable. You can click the variable name in the caption to 
choose another variable for previewing, or drag a default data 
point toward an axis to plot the current variable.

3. Move near the center of either axis and click the Add List region. The 
list of variables displays.
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4. Click the list that contains the categories you want to use for sorting 
data.

A dot chart plots in the work area. The application labels the axis 
with the variable name and shows a dot for each instance of a 
category.

5. Explore the plotted data.

– Hover over a dot in the plot to display data values.

– Click a dot to select it. Click the dot a second time to deselect it 
or remove it from a selection of multiple dots.

– Activate the Graph Trace tool and press 7 or 8 to move across 
the points in list order. Dots display a bold outline as you move 
across them in Trace mode.

Creating a Bar Chart
Like dot charts, bar charts display categorical data. The length of a bar 
represents the number of cases in the category. 

1. Click the Add Variable region of either axis and choose the name of a 
categorical variable. For more information, see Creating a Dot Chart. 

2. On the Plot Types menu, click Bar Chart.

The dot chart changes to a bar representation of the data.
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3. Explore the data in the plot.

– Hover over a bar to see a category summary (the number of 
cases and percentage among all categories). 

– Activate the Graph Trace tool and press 7 or 8 move across the 
bars and view summary information.

Creating a Bar Chart from a Frequency Table or Summary 
Data
1. On a new Data & Statistics page, create a bar chart with frequency or 

summary data by choosing Add X Variable on the Plot Properties 
menu.

Note: You can also create a bar chart with frequency by selecting 
Add Variable with Summary List from the context menu of the Add 
Variable region of an axis.

2. Select the desired variable from the pop-up choices.

3. Set the height of the bars with the summary variable by selecting 
Add Summary List from the Plot Properties menu.
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4. Select the summary list from the pop-up choices.

The bar chart plots on the work area. The icon in the lower left 
corner indicates that this plot was generated from summary data.

5. Hover over a bar to see a category summary, or use the Graph Trace 
tool on the Analyze menu to move across all of the bars displaying 
the summaries. 

6. (Optional) Add summary lists to create a comparative bar chart.

Creating a Pie Chart
A pie chart represents categorical data in a circular layout and uses an 
appropriately proportioned segment for each category.

1. Create a dot chart on the work area.

2. On the Plot Types menu, click Pie Chart.

The dots move by category into the segments of the pie chart. 
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3. Hover over a segment to see the summary for the category, or use 
the Graph Trace tool on the Analyze menu to move across each 
segment displaying all of the summaries. The summary shows the 
number of cases for the category and the percentage among all 
cases. 

Note: You can switch to a pie chart from a bar chart generated from 
summary data.

Creating a Comparative Bar Chart
This might be used to explore data in a two-way table.

1. Type the raw data on a Lists & Spreadsheet page.

2. From the Insert menu in the toolbar, click Data & Statistics.
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Note: Your screen may differ, depending on the data you entered.

3. Select the Click to add variable field, and select eyecolor as the 
variable for the x axis.

4. On the Plot Type menu, click Bar Chart.

The frequency of the eyecolor data is plotted.

5. To split the eyecolor data by gender, click the Plot Properties menu, 
click Split Categories by Variable, and then click gender.

Splitting a Numeric Plot by Categories
You can use a categorical split to sort the values plotted on an axis.

1. Open a problem that includes a Lists & Spreadsheet page, or create 
data to be plotted in the Lists & Spreadsheet application. 

In this example, lists contain dog breed and weight information.
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2. Click the column letter (A) to highlight the breed column. 

3. On the Lists & Spreadsheet Data menu, click the Quick Graph tool.

The Quick Graph tool adds a Data & Statistics page. Data & Statistics 
plots the variable and labels the horizontal axis. 

4. To plot the numeric data for each category, hover on the Add 
Variable region near the center of the vertical axis and click the 
tooltip Click or Enter to add variable. 

The list of available variables displays.
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5. On the list of variables, click the name of the numeric variable. 

Data & Statistics labels the vertical axis and plots the numeric data 
for each category. 

Exploring Data
You can manipulate and explore plotted data.

• Select and move points or data bins

• Change the type of plot

• Rescale the graph

• Add a movable line

• Show regression lines

• Show residual squares

• Show a residual plot
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Moving Points or Bins of Data
1. Click and hold the desired point or bin.

The cursor changes to ÷.

2. Drag the point or bar to the new location and release it. Moving the 
point changes the values for x and y.

If you are working with data from Lists & Spreadsheet, the data that 
corresponds to the original point or bar automatically updates in the 
original column(s) in Lists & Spreadsheet as you move the point.

You can also move points or bins by changing the numbers in the 
Lists & Spreadsheet or Calculator applications. Data will update in all 
of the representations.

Moving Multiple Points
1. Position the pointer over each data point that you want to select. 

When the pointer changes to ÷, click to add the point to the 
selection.
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Alternatively, you can drag a selection rectangle around the points 
to select them.

2. Drag any of the selected points to move them all.

Note: When a list is defined in Lists & Spreadsheet as a formula, the 
movement of points is restricted to positions that satisfy the formula.

Sorting Plotted Categories
You can sort plotted categories in list order, value order, or alphabetically 
by category name.

1. Click the work area that contains the plotted data.

2. On the Actions menu, click Sort, and then click the type of sort.

Note: You can customize the order of the categories by clicking a label 
and dragging it.

Plotting a Value
You can plot a value on an existing plot. It displays as a vertical line in the 
work area.

1. From the Analyze menu, click Plot Value. 

Months listed chronologically but plotted by 
value (amount of rain)
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A text box with a default expression opens in the work area.

2. Type the value you want to plot, and press ·. In this example, the 
value is v1:= mean(cost). 

The line is drawn at that value, perpendicular to the axis. If you have 
multiple plots on the work area, a plot value segment displays for 
each plot.

Note: If you use a frequency table to generate a histogram, 
reference the frequency list in your expression. For example, type the 
expression ”v1:= mean(List, FreqList)” in the plot value entry box.

3. Click the line to display the value. 

Note: Double-click the value to edit the expression.

Plot value entry box

Plot value line with value displayed
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You can use Plot value for a single number or any expression that 
evaluates to a number. If the value is dependent on the data, like 
mean, when you drag a point or make changes in the 
Lists & Spreadsheet application, the line updates to reflect the 
change, allowing for investigation of the influence of points on the 
calculation.

Removing a Plotted Value
1. Select the plotted value line.

2. From the Actions menu, click Remove Plotted Value.

Changing the Plot Type
You can change the plot type, to view different representations of data.

8 On the Plot Type menu, click a new plot type. Only the supported 
plot types are available. For example, only univariate plot types are 
available when a single variable plotted on an axis.

The data representation changes to the new plot format.

Note: Options are unavailable on the menu if the plotted data 
cannot be represented by the plot type. For example, if a scatter plot 
is displayed in the work area, you cannot create a box plot without 
first removing the variable from the y-axis. 

Rescaling a Graph
You can change the scale of the axes by using Translation and Dilation:

À Dilation region

Á Translation region
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The cursor changes to indicate whether Translation (ö) or Dilation (ô) is 
available in zones on the axes.

Translation
A translation slides a set of axes a fixed distance in a given direction. The 
original axes have the same shape and size.

1. Position the cursor over a tic mark or label in the middle third of the 
axis. The cursor changes to ö.

2. Click to grab. The cursor changes to ù. Drag the cursor to the 
desired position and release.

Dilation
Dilation retains the shape of the axes, but enlarges or reduces the size.

1. Position the cursor over a tic mark or label near the ends of the axis. 
The cursor changes to ó on the vertical axis or ô on the horizontal 
axis.
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2. Click to grab. The cursor changes to ÷. Drag the cursor to the 
desired position and release.

Adding a Movable Line
You can add a movable line to a plot. Moving and rotating the line on 
the work area changes the function that describes it. 

8 From the Analyze menu, click Add Movable Line. 

The movable line displays and is labeled with a function that 
describes it. For this example, Data & Statistics stores the expression 
for the movable line in the variable m1.

Rotating a Movable Line
1. Click and grab either end of the line.

The cursor changes to é.

2. Drag to rotate and change the slope of the line.
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The function m1(x) is updated for the changes in the position of the 
movable line.

Changing the Intercept
1. Click in the middle of the movable line.

The cursor changes to ö.

2. Drag to change the intercept.

The number at the end of the equation changes to show the change 
in the intercept.

Note: The movable line is stored as a function that can be used for 
prediction in the Calculator application.

Locking the Intercept at Zero
You can lock the intercept of the movable line at zero. 

8 From the Analyze menu, click Lock Intercept at Zero.

You can unlock the intercept by choosing Unlock Movable Line 
Intercept on the Analyze menu. 

Tracing a Movable Line
You can trace a movable line to predict and analyze values. 

1. Click the line.

The cursor changes.

2. From the Analyze menu, click Graph Trace to enable Trace mode for 
the line. Rotation of the line is not supported in Trace mode.

3. Press ¡ or ¢ (left or right arrow keys) to trace the movable line. 

If the plotted variables change, points on the graph and the line are 
updated automatically.
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Showing a Line of Regression
You can show a line of regression when you have a scatter plot or an X-Y 
line plot on the work area. Studying the line of regression can help you 
understand the relationship between two variables. 

1. With a scatter plot or X-Y line plot of two variables on the work 
area, click the Analyze menu, choose Regression and view the list of 
regressions.

2. Click the type of regression line to show. For example, choose Show 
Linear (mx+b) to plot a linear regression line as shown in the 
following example. 

When the line of regression is selected, the expression for the line 
displays.

Showing Residual Squares
You can display residual squares on a plot. Residual squares can help you 
assess the appropriateness of the model for your data.

Note: This tool is only available when a regression or movable line is 
present in the work area.

8 From the Analyze menu, click Residuals > Show Residual Squares.
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The sum of squares is updated as the line or data changes.

Showing a Residual Plot
You can show a residual plot to determine how well a line fits data. The 
work area must include a scatter plot and one or more movable lines, 
regressions, or plotted functions for Show Residual Plot to be available.

8 With a scatter plot, line of regression, and/or movable line in the 
work area, click the Analyze menu, and click Show Residual Plot > 
Residuals.

Notes:

• With multiple regressions or functions and movable lines plotted, 
you can select each by clicking the line to show its residual plot. 

• Click and hold a dot on the residual plot to see the residual.

• The residual plot for the selected regression or function displays in 
the work area. 

• For consistency in comparing sets of data, residual plots do not 
rescale when you move from one function or regression to another. 

• Select a function or regression before a showing residual plot. If no 
function or regression is selected and there are several plotted, Data 
& Statistics arbitrarily selects the function or regression for showing 
the residual plot.

• Axes can be adjusted by clicking and dragging.

Removing a Residual Plot
8 With a scatter plot, line of regression, and/or movable line in the 

work area, click the Analyze menu, and click Hide Residual Plot.
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Using Window/Zoom Tools
Use the Window/Zoom tools to redefine the graph to better view points 
of interest. The Window/Zoom tools include:

• Window Settings: displays a Window Settings dialog box that lets 
you type the x-min, x-max, y-min, and y-max values for the axes. 

• Zoom - Data: adjusts the zoom factor to display all plotted data.

• Zoom - In: lets you define the center point of the zoom in location. 
The Zoom In factor is approximately 2.

• Zoom - Out: lets you define the center point of the zoom out 
location. The Zoom Out factor is approximately 2.

Using the Window Settings Tool
1. On the Window/Zoom menu, click Window Settings.

2. The Window Settings dialog box opens. The current values for 
x-min, x-max, y-min, and y-max are displayed in the fields. 

Note: Only the appropriate boxes are editable, depending on 
whether there are one or two axes in the work area.

3. Type the new values over the old values. 

4. Click OK to apply the changes and redraw the plot.

Using the Zoom Data Tool
8 On the Window/Zoom menu, click Zoom Data. 

The work area rescales to display all plotted data.

Using the Zoom In Tool
1. On the Window/Zoom menu, click Zoom In. 

2. In the work area, click the center point of the area of interest. This 
will be the center of the zoom in action.

The plot redraws to focus and enlarge the portion of the plot 
centered about the point you selected in the previous step.

Using the Zoom Out Tool
1. On the Window/Zoom menu, click Zoom Out. 

2. In the work area, click the center point of the area of interest. This 
will be the center of the zoom out action.

The plot redraws to display a larger portion of the plot, centered 
about the point you selected in the previous step.
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Graphing Functions
You can graph functions by typing them in Data & Statistics, or you can 
graph functions defined in other applications.

Graphing Functions Using the Plot Function Tool
You can use the Plot Function tool to plot functions in a work area that 
already includes a plot on the axes. Plot Function lets you specify and 
graph a function for comparison to an existing plot. 

To use the Plot Function tool:

1. Create or open a problem that includes variables (from Lists & 
Spreadsheet) that are plotted on a Data & Statistics work area. 
Ensure that your work area contains both a horizontal axis and a 
vertical axis scale.

2. From the Analyze menu, click Plot Function.

A function entry field displays in the work area.

Note: You can edit the function’s expression typed in the entry field. 
However, the function graphed in Data & Statistics cannot be 
manipulated or moved around the work area. To do that, use Graphs 
& Geometry. 

3. Type the function in the entry field, and press ·. 

Note: You can rename the function by typing over f1(x): with 
another name, if you choose.

The function graphs in the work area and is saved as a variable for 
use in other applications. 

Plot 
Function 
entry field

Plot from 
variables
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Entering Functions from Other Applications
You can enter a function that has been defined as a variable in another 
application, such as Lists & Spreadsheet, Graphs & Geometry, or 
Calculator.

1. Add a variable to each axis. You can access any variables defined in a 
Lists & Spreadsheet or Calculator application in your problem from 
the variable list.

2. From the Analyze menu, click Plot Function.

A function entry field displays in the work area. 

3. Press h.

A list of variables available in the problem displays.

4. Click to select the variable containing the function you want to plot.

In the example below, the variable a contains the function f(x)=x2.
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5. Press ·.

The function plots in the work area. 

Editing a Function 
You can edit a function and update it in the work area.

1. You can edit a function by double-clicking the equation and then 
making changes as required.

2. Press · after making all changes and the updates are displayed in 
the work area. 

Using Data & Statistics Functions in other Applications
Data & Statistics functions are stored as variables, and may be used in 
other applications, in the same manner as any other variable. Support for 
all function types is included.

Note: Function numbers increment to use the next available. If you have 
defined f1(x) and f2(x) in Graphs & Geometry, the first function you 
create in Data & Statistics will be f3(x).

Using Show Normal PDF
You can approximate data plotted in the Data & Statistics work area 
against the normal probability density function. The tool overlays the 
normal probability density function using the mean and the standard 
deviation of the data in the histogram.

To show the normal probability density function for plotted data:

1. Add a variable to the x-axis.

2. On the Plot Types menu, click Histogram.
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Note: Show Normal PDF is available only when histogram is the 
plot type.

3. From the Analyze menu, click Show Normal PDF.

The normal PDF for the graph plots in the work area. The expression 
used to calculate the PDF displays when selected. 

You can click Hide Normal PDF on the Analyze menu to remove the 
PDF.

Using Shade Under Function
Use Shade Under Function to find the area of a selected region under a 
function graphed in the work area.

1. Select any function graphed in the Data & Statistics work area. For 
example, select a previously graphed normal PDF.

2. From the Analyze menu, click Shade Under Function. 

The cursor becomes a dotted vertical line and the boundary +/- ˆ 
displays when you position the mouse near the boundary on the left 
or right. You can click when ˆ displays to set it as a boundary.
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3. Select a point on the curve and click to indicate where to start 
shading under the function. The direction in which you move next 
determines whether the region shaded is on the left, right, or center 
of the curve.

4. Select a point on the curve and click to indicate the end boundary of 
the shaded area. A region under the function is shaded based on the 
points you selected. 

You can work with Shade Under Function in the following ways: 

• Select the region to display the values for data points in the 
shaded area. 

• To remove the shading, right-click or /-click the shaded 
region and choose Remove Shaded Region.

• To change the fill color of the shaded area, right-click or /-
click the shaded region, choose Color, choose Fill, and click a 
color.

• Use plot value to set the boundary to an exact number. When a 
boundary for shading is set to a plotted value, you can change 
the plotted value to update the shading.

• Edit a shaded region by clicking and dragging the edge at the 
starting or ending boundary.

Using Graph Trace
Graph Trace lets you move from one point on a graph to another to 
analyze variations in the data. You can use Graph Trace mode to explore 
the data for the following graphs.

• Graphs from Plot Function and Show Normal PDF

• Distribution curves (created in the Lists & Spreadsheet application)

• Movable Lines
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• Regressions

• Caseplots

• Dot plots

• Scatter plots and X-Y line plots

• Box plots

• Histograms

• Bar charts

• Pie charts

1. From the Analyze menu, click Graph Trace.

2. Press ¡ or ¢ to move across the plot.

The data representations enlarge and appear with a bold outline as 
you move across them in Trace mode.

Customizing Your Workspace

Working with Color 
All data points for a plotted variable display in the same color to 
distinguish them from the data points of other variables. Data plotted by 
category and split plots are automatically displayed in different colors to 
help you distinguish the data.

To emphasize or distinguish certain parts of your work, you can change 
the default color for a variable’s data.

• Apply fill colors to objects, such as shading, or change the color for a 
variable’s data points. 

• Apply color to plotted lines (such as lines of regression) or movable 
lines.

TI-Nspire™ handhelds without color show color objects in shades of gray. 
The color information is preserved in the document unless you change 
color from the handheld. If you choose to, you can work in grayscale 
mode to view objects in the desktop software similarly to how they 
appear on the handheld. 

Inserting a Background Image
When using the computer software, you can insert an image as a 
background for a Data & Statistics page. The file format of the image can 
be .bmp, .jpg, or .png.

1. From the Insert menu, click Image.
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2. Navigate to the image that you want to insert.

3. Select it, and then click Open.

The image is inserted as a background.

For more information, see the Working with Images chapter.

Working with Text
The Insert Text tool lets you type text to describe details related to plots 
on the work area.

1. From the Actions menu, click Insert Text.

A text box opens. 

2. Type notes or descriptions in the text box.

3. Customize the text to suit your needs.

• Move the cursor over the edges of the text box to drag the 
borders and change the width or height.

• Click and grab the text box to move it near objects that relate to 
the text.

• Scroll to view additional text in a box by clicking the arrows at 
the top and bottom edge.

• Click outside of the text entry box to exit the Text tool.

• Hide text by clicking the Actions menu and clicking Hide Text.

• Change the color of text.

Adjusting Variable Values with a Slider
A slider lets you easily explore the effects of adjusting a numeric variable 
through a range of values. You can control a slider's location and visual 
appearance, and its adjustment range and step size.
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Inserting a Slider
You can insert sliders on a Graphs page, a Geometry page, or a 
Data & Statistics page.

1. From the Actions menu, click Insert Slider. 

A gray image of a horizontal slider with default settings attaches 
itself to the pointer.

2. Drag to position the slider, and click to release it.

3. Press · to accept the default name (such as V1),

—or—

À Horizontal slider showing variable name, current value, and range

Á Vertical slider

Â Slider “thumb” that you can drag to adjust the current value of the 
variable

Ã Slider track

Ä Minimized sliders with arrows to adjust the variable’s current value
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Type the name of a numeric variable that you want to assign, and 
then press ·.

Setting up the Slider
You can change many slider settings, such as Minimum and Maximum, by 
clicking parts of the slider. Some settings, such as Step Size, are accessible 
only through the Slider Settings dialog box.

1. Right-click in the slider to display its context menu, and click 
Settings to open the Slider Settings dialog box. 

Handheld: Point to the slider, press / b, and select Settings. 

2. Use the Slider Settings dialog box to enter settings for the slider. 
Each setting is described below. Settings that accept a numeric value 
also accept an expression that evaluates to a numeric value.

Variable — Specifies which variable is assigned to the slider. Type an 
available numeric variable name, or click the drop-down arrow and 
click a name from the list.

Value — Sets the current value of the variable.

Minimum — Sets the lowest value in the slider range (left or bottom 
end point on the track).

Maximum — Sets the highest value in the slider range (right or top 
end point on the track).

Step Size — Sets the size of the increment between values. The 
default setting is Automatic. To type a specific size, click the drop-
down arrow, click Enter Size, and type a positive numeric value.

Style — Click the drop-down arrow to choose Horizontal or Vertical.

Display Digits — Specifies the display format of the variable’s 
current value. Choose Auto to display the value according to the 
Document Settings option. Click the drop-down arrow to choose 
from floating-point or fixed formats.

Show Variable — Shows or hides the variable name in the slider.

Show Scale — Shows or hides the scale in a maximized slider.
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Adjusting a Slider Variable’s Current Value
8 After setting up a slider, use one of these methods to adjust the 

current value:

– Grab the slider thumb ( or ) and drag it.

– Click the slider thumb, and then press 9, :, 7, or 8.

– Click after the “=” or press e as necessary to select the current 
value, and type a numeric value.

– Click a new position on the track.

Note: Any time the variable’s current value is outside the slider’s 
defined range, the thumb is not displayed. To bring the value 
inside the slider’s range, click the slider track or arrows.

Repositioning a Slider on the Page
8 Grab and drag any empty space in the slider’s selection rectangle. 

—or— 

Click an empty space in the slider, and then press 9, :, 7, or 8.

Minimizing a Slider
8 To minimize a slider and display only the variable name, current 

value, and direction arrows, access the slider’s context menu and 
click Minimize.

8 To further minimize a slider and show only the arrows, access its 
context menu and clear the Show Variable option.

Stretching a Slider
8 Grab the Minimum or Maximum end point on the track, and drag it.

Note: Stretching or shrinking a slider affects only the length of the 
track. The Minimum and Maximum values do not change.
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Animating a Slider
An animated slider steps repeatedly through its range, using the slider’s 
Step Size.

8 Access the slider’s context Menu and click Animate.

Note: To stop the animation, click Stop Animate. Animation also 
stops if you lock the slider’s associated variable.

Removing a Slider
Removing a slider does not delete the variable associated with the slider.

1. Click in the slider’s selection rectangle to select it.

2. Press ..

Tips for Using Sliders

Use Multiple Sliders for a Variable
You can assign the same variable to multiple sliders. This lets you see the 
effect of adjusting a variable by different step sizes or through different 
ranges. 

Deselect a Slider
8 To deselect a slider, click another part of the work area, and press 

d.

—or—

Press e e to move to another element in the work area.

Associate a Different Variable with a Slider
8 Click the text box for the variable name and type the name of the 

numeric variable to use. 

With the slider active, click the h button to select a variable from the 
list.

Inferential Statistics
You can explore hypothesis tests and probability distributions in the 
Data & Statistics application after entering the data on a 
Lists & Spreadsheet page.

Drawing Inferential Statistics Plots
The following example uses the Draw option of the normCdf() function 
to plot a distribution model. 
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1. On a Lists & Spreadsheet page, select the column-formula cell 
(second cell from the top) in column A.

2. From the Statistics menu, click Distributions, and click Normal Cdf. 

3. Type the plot parameters into the Normal Cdf wizard.

4. Select the Draw check box to see the distribution plotted and 
shaded in Data & Statistics. 

Note: The Draw option is not available for all distributions.

5. Click OK.

Exploring Inferential Statistics Plots
After drawing the plot in the previous example, you can explore the 
effect of changing the upper bound.

8 On the Data & Statistics plot, drag the vertical line that represents 
the upper bound toward the left or right.

As you drag, the formula is updated and the shaded area is 
recalculated.
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Using Notes

The Notes application lets you create and share text documents using the 
TI-Nspire™ handheld and computer software. Use Notes to:

• Create study notes to reinforce learning, demonstrate your 
understanding of classroom concepts, and to review for exams.

• Edit collaboratively by assigning different roles to individuals using 
your document so that any edits appear in a different text format.

• Create and evaluate math expressions.

• Create correctly formatted chemical formulas and equations.

Getting Started with the Notes Application
To add a blank Notes page to an existing or new document:

8 In a new document, click Add Notes from the menu.

8 In an existing document, click Insert > Notes.

8 From a handheld, press  to open a new document with a notes 
page or add a notes page to an open document.

The Notes work area is displayed in Default mode.

Using the Notes Menu
Options on the Notes menu enable you to:

• Perform actions such as evaluate and approximate expressions

• Select a template:

– Q&A for questions and answers

– Proof for an outline structure containing statements and 
reasons
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– Default for freeform text entry

• Insert math expressions, shapes, comments, or images

• Format the text in a note

• Customize a math expression 

• Perform calculations

Opening Notes
On your desktop, the Notes menu icons are displayed in the Documents 

Toolbox panel. With the Notes application active, click  to open the 
Notes menu.

On a handheld, press b to open the Notes menu.
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Using Templates
Use the options on the Templates menu to select a format for your Notes 
page. 

Selecting a Template
Complete the following steps to select and apply a template:

À Notes tool menu – This menu is available anytime you are in 
the Notes work area.

Á Notes work area -- The area where you type and format text.

Menu Option Function

 2: Templates

 1: Q&A
Creates a template to enter 
question and answer text.

 2: Proof
Creates a template to enter 
statement and reason text.

 3: Default
Lets you type freeform text.

4:Hide Answer (Q&A)
Toggles to show or hide the 
Answer in a Q&A format.
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1. From the Notes menu, click .

2. From the menu, click the template you want to apply.

Handheld: From the Notes work area, press b, and then press ¢ to 
display the menu options.

The Notes page is displayed in the format you selected.

Using the Q&A Template
Use the Q&A template to create questions and answers. You can show or 
hide the answer so you can create questions for review and hide the 
answers. When you use the document as a study aid, you can verify that 
your answers are correct.

Press e to move the text cursor between the Question and Answer 
areas of the template.

Using the Proof Template
The proof template provides an outline structure for statements and 
corresponding reasons.

Press e to move the text cursor between the Statements and Reasons 
areas of the template.
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Formatting Text in Notes
Text formatting lets you apply visual properties, such as bold and italic, to 
your text. 

• Ordinary text. Apply most combinations of bold, italic, underline, 
superscript, subscript, and strikethrough formatting. Select font and 
font size for any character.

• Text in a math expression box. Apply formatting and enter math 
exponents and math subscripts for variable names. Select font and 
font size. Font size affects all text in the box.

• Text in a chemical equation box. Apply formatting. Select font 
and font size. Font size affects all text in the box. Superscript and 
subscript are handled automatically.

Selecting Text
8 Drag from the starting point to the ending point to select the text.

Handheld: If you are using the Q&A or Proof template, press e to 
place the cursor in the area containing the text. Use the Touchpad to 
place the cursor at the start or end of the text to be selected. Hold 
down g, and use the Touchpad to select the text.

Applying a Text Format
1. Select the text that you want to format.

2. On the formatting toolbar, click the formatting icons (such as  for 
bold) to toggle them, or click to select a font and font size.

Handheld: Click b, and then select Format > Format Text.
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The changes are applied to the text as you make selections.

Note: The toolbar shows only the icons that are applicable to the 
type of text selected. For example, superscript ( ) and subscript 
( ) are shown only for ordinary text.

Using Color in Notes

When working in the Notes application on a desktop, use the  (fill 

color) or the  (text color) options on the Documents Workspace 
toolbar to emphasize words, calculations, and formulas.

You can also apply color to text when working in the Notes application 
on the TI-Nspire™ CX handheld.

Note: If you transfer a document that contains color to a TI-Nspire™ 
handheld that does not support color, the colors are converted to gray 
scale.

Changing Text Colors
1. Select the text you want to change to another color. You can select a 

sentence, phrase, word, or a single letter. You can also select a math 
expression box, a chemical equation box, or individual characters in a 
calculation, formula, chemical equation, or math template.

2. From the Documents Workspace toolbar, click .

Handheld: Press ~, and then click Edit > Text Color.

The Text Color palette opens.

3. Click a color to apply it to the selected text.



Using Notes 571

Applying a Background Color
You can apply a background color to highlight selected characters in 
ordinary text, text in a math expression, or text in a chemical equation 
box.

1. Select the text.

2. From the Documents Workspace toolbar, click the arrow next to .

Handheld: Press ~, and then press Edit > Fill Color.

The Fill Color palette opens.

3. Click a color to apply it to the selected text.

Inserting Images
When working in the Notes application on a desktop, use the Images 
option on the Insert menu to add an image to a Notes page.

Note: The option for inserting an image is not available when working 
on a handheld. However, you can transfer a file containing an image 
from your computer to a TI-Nspire™ CX handheld and colors are 
retained. If transferred to a TI-Nspire™ handheld, the colors in the image 
are converted to gray scale.

1. Click Insert > Image from the Documents Toolbar. 

The Insert Image window opens.

2. Navigate to the folder where the image is located.

3. Select the image, and then click Open to insert the image into the 
Notes work area. Valid files types are .jpg, .png, or .bmp.

4. To type text around the image, place the cursor in front of the image 
or after the image, and then type the text.

Resizing an Image
Complete the following steps to resize an image.

1. Click the image to select it.

2. Move the cursor to the edge of the image. 

The cursor changes to a left-right arrow symbol.

3. Click the mouse and hold to enable the { tool, and then drag the 
image to make it smaller or larger.

4. Release the mouse button when the image is sized correctly.

For more information, see Working with Images.
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Inserting Items on a Notes Page
When working with the Notes application, open the Insert menu to 
insert a math expression, chemical equation, shape symbol, or a 
comment.

Inserting Comments
You can insert Teacher or Reviewer comments into a Notes application. 
Comments are easy to distinguish from the original text.

1. Define the type of comments you are inserting (Teacher or 
Reviewer):

• PC: From the Insert menu, click Comment, and then click 
Teacher or Reviewer.

• Handheld: While in the Notes work area, press b to display 
the Notes menu. Press Insert > Comment, and then select either 
Teacher or Reviewer.

2. Type your text.

Text that you type appears in italics.

Menu 
Name

Menu Option Function

3: Insert

1: Math Box - / M
Lets you insert a math expression.

2: Chem box - / E Lets you insert a chemical formula 
or equation.

2: Shape
Marks the selected text as an 
angle, triangle, circle, line, 
segment, ray, or vector.

3: Comment
Lets you type text that is italicized 
and prefaced with Teacher or 
Reviewer.
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Inserting Geometric Shape Symbols
You can use geometric shape symbols to designate selected text as 
geometric objects, such as an angle, circle, or line segment.

To insert a shape symbol, position the cursor where you want it, and then 
do the following:

• PC: From the Insert menu, click Shapes, and then select the shape to 
apply.

• Handheld: Press b to display the Notes menu. On the Insert 
menu, click Shapes, and then select the shape to apply.

Entering Math Expressions
You can include math expressions in Notes text, using the same tools as in 
other TI-Nspire™ applications. 

Math expression boxes have attributes that allow you to control how the 
expression is displayed.
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Entering an Expression
1. In the Notes work area, place the cursor where you want the 

expression. Then do the following:

• Windows®: From the Insert menu, click Math Expression Box 
or Ctrl + M.

• Mac®: Press “+ M.

• Handheld: Press b to open the Notes menu. Select Insert, and 
then click Math Expression Box.

2. Type the expression. You can use the Catalog, if necessary, to insert a 
function, command, symbol, or expression template.

Menu 
Name

Menu Option Function

 5: Math Box Options

1: Math Box Attributes

When a math box is selected, 
this option opens a dialog box 
allowing you to customize the 
math box. You can hide or show 
input or output, turn off 
calculation for the box, insert 
symbols, change display and 
angle settings, and allow or 
disallow the wrapping of 
expressions and the display of 
warning indicator after they 
have been dismissed. You can 
change the attributes of 
multiple selected math boxes at 
the same time.

2: Show Warning Info
Displays a warning indicator 
after the warning has been 
dismissed.

3: Show Error
Displays an error after the error 
has been dismissed.
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Evaluating and Approximating Math Expressions
You can evaluate or approximate one or more expressions and display 
the results. You can also convert selected text and multiple math 
expression boxes into a single math expression box. Notes automatically 
updates expressions and any variables used.

Evaluating or Approximating an Expression
To evaluate or approximate an expression, place the cursor anywhere in 
the math expression box and then do the following:

• Windows®: On the Actions menu, click Evaluate or Approximate. 
You can also use Enter to evaluate or Ctrl + Enter to approximate. 

• Mac®: Press “ + Enter to approximate.

• Handheld: Press b to display the Notes menu. On the Actions 
menu, select Evaluate.

The result replaces the expression. 

Evaluating Part of an Expression
To evaluate part of an expression, select the text or part of the math 
expression. Then do the following:

Menu 
Name

Menu Option Function

 1: Actions

 1: Evaluate - ·
Evaluates the expression.

2: Approximate / · Approximates the expression.

 3: Evaluate and replace
Replaces the selected part of 
the expression with the result.

4: Deactivate
Deactivates the current or 
selected item (box or boxes)

 5: Deactivate All
Deactivates all boxes in the 
current Notes application.

 6: Activate Activates the current or 
selected previously 
deactivated item.

7: Activate All
Activates all boxes in the 
current Notes application.
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8 On the Actions menu, click Evaluate and Replace.

Handheld: Press b to open the Notes menu. Select Actions, and 
then select Evaluate Selection.

The result replaces the selected part only.

Breaking Long Calculations
Some calculations may take a long time. Notes indicates that the 
handheld is performing a long calculation by displaying a busy icon. If a 
calculation is taking more time than you want to spend, you can end the 
calculation. 

To stop the function or program in progress, do the following:

• Windows®: Hold down the F12 key and press Enter repeatedly.

• Mac®: Hold down the F5 key and press Enter repeatedly.

• Handheld: Hold down the c key and press · repeatedly.

Showing Warnings and Errors
If a calculation in Notes results in a warning or error, you can view the 
warning or error again even after you have dismissed the dialog box.

To display a warning or error in Notes after you have dismissed the dialog 
box, do one of the following:

• Windows®: Right-click and select Show warning info or Show 
error.

• Mac®: “ + click and select Show warning info or Show error.

Note: You can change your settings so that warnings do not appear at 
all. The showing of warning indicators is controlled by the Math Box 
Attributes dialog box. See Changing the Attributes of Math Expression 
Boxes.

Converting Selected Items to Math Expression Boxes
To convert items to math expression boxes:

1. Select the text, or combination of text and existing math expression 
box that you want to evaluate. 

2. From the Actions menu, click Convert to Math Expression Box.

—or—

Right-click and click Convert to Math Expression Box.

Handheld: Press b to display the Notes menu, and then select 
Actions > Convert to Math Expression Box.
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The result replaces the selected part only.

Inserting Chemical Equations
Chemical equation boxes (chem boxes) make it easy to type chemical 
formulas and equations, such as .

As you type in a chem box, most of the formatting work is handled 
automatically:

• Correct capitalization of most element symbols, such as Ag and Cl, is 
automatic. 

• Leading digits are treated as coefficients and are shown at full size. 
Numbers that follow an element or a closed parenthesis are 
converted to subscripts.

• The equals “=” symbol is converted to a yields “&” symbol.

Notes: 

• Equations in a chem box cannot be evaluated or balanced.

• Element capitalization may not work in every situation. For example, 
to enter carbon dioxide, CO2, you must manually capitalize the O. 
Otherwise, typing “co” would result in“Co,” the symbol for cobalt.

Entering a chemical equation
1. Position the cursor where you want the equation.

2. On the Insert menu, select Chem Box, or press Ctrl + E.

An empty chemical equation box is displayed.

3. Type the equation in the box. For example, to represent sulphuric 
acid, type h2sO4, capitalizing the O manually. 

The chem box automatically formats the text as you type:

4. If you need superscripts for ionic equations, type a caret symbol (^) 
and then the text.

5. Use parentheses to indicate whether a compound is solid (s), 
liquid (l), gas (g) or aqueous (aq).
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6. To exit the chem box, click anywhere outside it.

Deactivating Math Expression Boxes
Calculations are by default activated, which means that results 
automatically update when you evaluate or approximate an expression. 
If you don’t want results to automatically update, you can deactivate a 
math expression box, group of boxes, or the entire application.

Deactivating a Box or a Group of Boxes
To deactivate a box or a group of boxes:

1. Select the box or boxes that you want to deactivate.

2. Deactivate the selected box or boxes:

• Windows®: Click Actions > Deactivate (or right-click and click 
Actions > Deactivate).

• Mac®: Click Actions > Deactivate (or “ + click and click 
Actions > Deactivate).

• Handheld: Press b to open the Notes menu. From the Actions 
menu, select Deactivate.

Note: You can manually update a deactivated box or boxes by 
selecting the box or boxes and using the process described in 
Evaluating and Approximating Math Expressions.

Deactivating All Boxes in the Notes Application
To deactivate all boxes in the Notes application:

8 With a document open, place your cursor in the Notes application 
that you want to deactivate and select Deactivate All.

• Windows®: Click Actions > Deactivate All or right-click and 
click Actions > Deactivate All.

• Mac®: Click Actions > Deactivate or “+ click and click Actions 
> Deactivate.

• Handheld: Press b to display the Notes menu. On the Actions 
menu, click Deactivate.

Note: When you use this option in Q&A and Proof templates, 
Deactivate All deactivates only the math boxes in the current work 
area.
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Changing the Attributes of Math Expression 
Boxes
You can change attributes in one or more math expression boxes at the 
same time. Controlling the attributes in math expression boxes allows 
you to do the following:

• Show or hide the input or output, or prevent calculation in the box.

• Select a symbol separator using Insert Symbol.

• Choose the number of digits to display in the output of a math 
expression.

• Select angle settings so you can use both radian/degree and gradian 
angle measures in the same Notes application.

• Select whether to allow math expressions to wrap.

• Select whether to show or hide warning indicators.

To change the attributes of one or more boxes, do the following:

1. Select the box or boxes that you want to change.

2. On the Math Box Options menu, click Math Box Attributes.

3. Use the menus or selection boxes to make your selections.

4. Click OK to save or Cancel to abandon the change.

Note: Math expression boxes recalculate automatically after you have 
made attribute changes and saved the changes.

Undoing Changes to Math Expression Boxes
8 To undo changes you have made to a math expression box, press 

/ Z.

Using Calculations in Notes
In the Notes application, the options on the Calculations menu enable 
you to perform calculations. The calculations are described in the 
following table.

Important Information to Know
• Notes does not support editing programs. Use Program Editor 

instead.

• Notes does not support executing Lock or Unlock commands. Use 
Calculator instead.

• Notes does not display intermediate results obtained using the 
"Disp" command. Use Calculator instead.
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• Notes does not support user-defined dialog boxes obtained using 
the "Request," "RequestStr," or "Text" commands. Use Calculator 
instead.

• Notes does not support the execution of multiple statistics 
commands that produce stat. variables.

Menu 
Name

Menu Option Function

 6: Calculations

1: Define Variables
Define a variable in a Note using 
the Calculator application.

2: Number
Use tools from the Calculator 
Number menu, including Convert to 
Decimal, Approximate to Fraction, 
Factor, Least Common Multiple, 
Greatest Common Divisor, 
Remainder, Fraction Tools, Number 
Tools, and Complex Number Tools.

3: Algebra
Use tools from the Calculator 
Algebra menu, including Numerical 
Solve, Solve System of Linear 
Equations, Polynomial Tools.

4: Calculus
Use tools from the Calculus menu 
including Numerical Derivative at a 
Point, Numerical Definite Integral, 
Sum, Product, Numerical Function 
Minimum, and Numerical Function 
Maximum.

3 (CAS): Algebra
Use tools from the Calculator 
Algebra menu, including Solve, 
Factor, Expand, Zeros, Numerical 
Solve, Solve System of Equations, 
Polynomial Tools, Fraction Tools, 
Convert Expressions, Trigonometry, 
Complex, and Extract.
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Exploring Notes with Examples
This section shows you how the Notes application works with other 
applications to automatically update results.

Example #1: Using Notes to Explore Roots of a Quadratic 
Function
1. Open a new document and select the Notes application.

4 (CAS): Calculus
Use tools from the Calculus menu 
including Derivative, Derivative at a 
Point, Integral, Limit, Sum, Product, 
Function Minimum, Function 
Maximum, Tangent Line, Normal 
Line, Arc Length, Series, Differential 
Equation Solver, Implicit 
Differentiation, and Numerical 
Calculations

5: Probability
Use tools from the Calculator 
Probability menu, including 
Factorial, Permutations, 
Combinations, Random, and 
Distributions.

6: Statistics
Use tools from the Calculator 
Statistics menu, including Stat 
Calculations, Stat Results, List Math, 
List Operations, and others.

7: Matrix & Vector
Use tools from the Calculator Matrix 
& Vector menu, including Create, 
Transpose, Determinant, Row-
Echelon Form, Reduced Row-
Echelon Form, Simultaneous, and 
others.

8: Finance
Use tools from the Calculator 
Finance menu, including Finance 
Solver, TVM Functions, 
Amortization, Cash Flows, Interest 
Conversions, and Days between 
Dates.

Note: For more information, see the Calculator chapter.

Menu 
Name

Menu Option Function
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2. Define a function in a math box, evaluate, and hide the output using 
the Math Box attributes.

3. Type some more text; for example: “Real Roots of f1(x) are:”

4. In a new math box, type: polyRoots(f1(x),x).

5. Press · and hide the input of this math box by using the Math 
Box attributes dialog box.

6. Use the Page Layout toolbar icon to select the split layout.

7. Add the Graph application and plot f1(x).

See how the roots of f1 change when the function is modified in 
Graph.
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Example #2: Using Notes to Explore Data Sampling
This example shows how to create a sampling distribution of sample 
means drawn from a given population. We will be able to watch the 
sampling distribution take shape for a given sample size and describe its 
characteristics. You can change the population and the sample size.

1. Set up the population and the sample size.

a) Type "Create sample data:"

b) Insert a math expression box and define the population. For 
example, type "population:=seq(n,n,1,50)".

c) Press Enter and hide the output using the Math Expression Box 
Attributes dialog box.

d) Insert a math expression box and define the sample size. For 
example, type "size:=5".

e) Press Enter and hide the output using the Math Expression Box 
Attributes dialog box.

2. Set up the initialization.

a) Type "Start taking samples:"

b) Insert a math expression box and set the initial values for the 
number of samples (num) and the list of sample means 
(sampmeans). Type:

"num:=0:sampmeans:={}"

c) Press Enter and hide the output using the Math Expression Box 
Attributes dialog box.

d) Deactivate the math expression box using Actions > Deactivate. 
The deactivation will prevent the content of that math box from 
being overwritten when the values for num and sampmeans 
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change. The deactivated math box will be shown with the light 
color background.

3. Set up Data & Statistics for the sampling.

a) Change the page layout and insert Data & Statistics.

b) Click on the horizontal axis and add sampmeans list.

c) Change the window setting: XMins=1 and XMax = 50.

d) You can also set up the plot of the mean of sample means using 
Analyze > Plot Value.

4. Enter the instructions to add data.

a) Type "Create new samples:"

b) Insert a math expression to define the sample (sample) and 
update the number of samples and the list of sample means. 
Type: 

"num:=num+1:sample:=randsamp(population,size):
sampmeans:=augment(sampmeans,{mean(sample)})"

c) Press Enter, hide the output, and turn off the expression 
wrapping using the Math Expression Box Attributes dialog box.

d) Deactivate the math expression box using Actions > Deactivate 
to prevent the content of the math box to be overwritten when 
num and sampmeans values are reinitialized.
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e) Create math expression boxes that display the current number 
of experiments (num), sample (sample), and the list of sample 
means (sampmeans).

5. Now you are ready to explore. Add more samples by simply pressing 
Enter when you are in the math expression box in the "Create new 
samples" section.

Note: You can also automate the sampling process by using a 
For ... EndFor loop.
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You can also change the sample size and restart the sampling.
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Getting Started with Data Collection

The Vernier DataQuest™ application is built into the TI-Nspire™ software 
and the operating system (OS) for handhelds. Use the Vernier 
DataQuest™  application to collect, view, and analyze data. 

To use the Vernier DataQuest™  application, the TI-Nspire™ handheld OS 
must be 3.0 or higher. To update the OS, go to education.ti.com.

About Vernier DataQuest™
• Run the application on either a TI-Nspire™ handheld or a Windows® 

or Mac® computer.

• Choose from multiple sensor interfaces and sensors, such as the 
TI-Nspire™ Lab Cradle, to collect data.

• Collect data with up to five connected sensors (three analog and two 
digital) using the TI-Nspire™ Lab Cradle. For a complete list of 
compatible sensors, see Compatible Sensors. 

Important: The TI-Nspire™ CM-C Handheld is not compatible with 
the Lab Cradle and only supports the use of a single sensor at a time.

• Collect data either in the classroom or at remote locations using 
collection modes such as time-based or event-based.

• Select and focus on a subset of collected data.

• Collect several data runs for comparison.

• Create a graphical hypothesis using the Draw Prediction feature.

• Play back the data set to compare the outcome to the hypothesis.

• Analyze data using functions such as interpolation, tangential rate, or 
modeling.

• Display results in a graph or a table.

• Customize the way results are displayed.

• Link the data to other TI-Nspire™ applications.

Using Vernier DataQuest™ Data in Other TI-Nspire™ 
Applications
Data obtained during a data collection run is written to the graph and 
table views in the Vernier DataQuest™  application and can be used in 
these TI-Nspire™ applications:

• Calculator

• Graph
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• Geometry

• Lists & Spreadsheet

• Data & Statistics

This graphic shows how data can be shared among the applications. 

Exploring the Screens
The Vernier DataQuest™  application screen is identical in the handheld 
and the TI-Nspire™ software. The following graphic shows the 
application screen.
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Learning About Menus
Like other TI-Nspire™ applications, the Vernier DataQuest™  application 
has its own application and context menus.

When you first open a document or problem, insert the Vernier 
DataQuest™  application to open the application menu.

 Click Insert > Vernier DataQuest.

The Vernier DataQuest™  application opens with the Meter view 
active and the application menu open.

Important! If you connect a sensor before starting the Vernier 
DataQuest™  application, the connected sensor automatically 
launches the Vernier DataQuest™ application screen.

À Vernier DataQuest™ application view tabs. The application 
provides three views. 

• Meter. Displays the list of sensors connected or set up to use 
offline.

• Graph. Displays collected data in a graphical representation, 
or displays the prediction before a data collection run.

• Table. Displays collected data in columns and rows.

Á Data Set selection tool. This tool is displayed in the Graph view 
only and lets you choose which data set to graph.

Â View Details area. This area contains information about the data 
appropriate for the current view.

Ã Data work area. The primary display of the data. The type of data 
displayed depends on the view.

Ä Data collection controls. Use these buttons to start and stop 
collections, store data sets, and capture data points.
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À Workspace Selector. In the TI-Nspire™ Teacher Software, click 
these tabs to switch from the Content Workspace to the 
Documents Workspace. These tabs are not shown in the student 
software. The Documents Workspace is the default workspace in 
the student software.

Á Toolbar. Contains shortcuts to tools used to create folders, save 
files, create lesson bundles, send files to handhelds, and copy/paste. 
Options available from the toolbar change depending on which 
workspace is open.

Â Application menu. Contains commands specific to the Vernier 
DataQuest™  application. Use these commands to collect and 
analyze data, set up sensors, view data in a graph or table, and so 
on.

Ã Context menu. Provides access to the tools most commonly used 
with the selected objects. Different options can appear on the 
context menu depending on the active object or the task you are 
performing.

Open the context menu by right-clicking an object or a work area.

Handheld: Move the cursor to the desired object, and then press 
/ b.
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Exploring the Status Bar

Learning about Collection Devices
You can select from a variety of sensors and interfaces to collect data 
while running the Vernier DataQuest™ application with TI-Nspire™ 
software.

Multi-Channel Sensor Interfaces
Multi-channel sensor interfaces let you connect more than one sensor at 
a time.

Ä Status bar. Provides information about the active document and 
allows you to switch between the handheld view and the computer 
view.

À Problem and page number. Displays the current page number and 
problem number in an active document.

Á Settings. Double-click to display Document Settings.

Â Handheld: Lets you view documents as they appear on a handheld 
screen. The screen size is limited as it would be on the handheld.

Click  to activate the handheld view. 

Ã Computer: Lets you view documents as they appear in the 
software. Computer is the default view in the software.

Click  to activate the computer view. 

Ä Scale. A slider that lets you manage contrast (computer) or the size 
of the document (handheld).

• Used in the handheld view to change the size of the document 
and work area. Select the Zoom percentage menu to make the 
document larger.

• Used in the computer view to make the lines lighter or darker. 
Select the Boldness percentage menu or click – and + icons to 
change the document boldness.
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Single-Channel Sensor Interfaces
Single-channel sensor interfaces can only connect to one sensor at a time. 
These sensors have either a mini-USB connector for a handheld or a 
standard USB connector for a computer. For a complete list of compatible 
sensors, see Compatible Sensors.

Sensor Interface Description

Texas Instruments 
TI-Nspire™ Lab Cradle 

This sensor can be used with a handheld, a 
computer, or as a stand-alone sensor.

The sensor interface allows you to connect 
and use one to five sensors at the same time. 
It can be used in the lab or at a remote 
collection location.

The Lab Cradle supports two digital sensors 
and three analog sensors.

The Lab Cradle also supports high-sample 
data collection sensors, such as a hand-grip 
heart rate or a blood pressure monitor.

When used as a remote sensor, you can 
download data to either a handheld or 
computer.

For more information, see the TI-Nspire™ 
Lab Cradle Guidebook.

Sensor Interface Description

Vernier EasyLink®

This sensor interface is used with 
handhelds. It has a mini-USB connector 
so it can be plugged directly into the 
handheld.

Connect sensors to Vernier EasyLink® to:

• Measure barometric pressure.

• Measure the salinity of a solution.

• Investigate the relationship between 
pressure and volume (Boyles’ Law).



Getting Started with Data Collection 593

Sensor Types
You can select from three types of sensors.

• Analog sensors. Temperature, light, pH, and voltage sensors are 
analog sensors and require a sensor interface.

• Digital sensors. Photogates, radiation monitors, and drop counters 
are digital sensors. These sensors can only be used with the 
TI-Nspire™ Lab Cradle.

• Direct-connect USB sensors. These sensors connect directly to a 
handheld or computer and do not require a sensor interface.

For a complete list of compatible sensors, see Compatible Sensors.

Sensors for Handhelds
The following lists some sensors you can use with a handheld.

Vernier Go!Link®

This sensor interface is used with 
computers. It has a standard connector 
so it can be plugged into a Windows® or 
Mac® computer.

Connect sensors to Vernier GoLink® to:

• Measure the acidity or alkalinity of a 
solution.

• Monitor greenhouse gases.

• Measure sound level in decibels.

Sensor Description

Texas 
Instruments 
CBR 2™

This analog sensor connects directly to TI-Nspire™ 
handhelds through the mini-USB port. It is used to 
explore and graph motion. 

This sensor automatically launches the Vernier 
DataQuest™  application when you connect it to a 
handheld. Data collection begins when you select 
the Motion Match function.

This sensor collects up to 200 samples per second.

Use this sensor to:

• Measure position and speed of a person or 
object.

• Measure the acceleration of an object.

Sensor Interface Description
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Sensors for Computers
The following table lists some sensors you can use with a computer.

Vernier 
EasyTemp® 
temperature 
sensor

This analog sensor connects directly to TI-Nspire™ 
handhelds through the mini-USB port and is used 
to collect temperature ranges. You can design 
experiments to:

• Collect weather data.

• Record temperature changes due to chemical 
reactions.

• Perform heat fusion studies.

Sensor Description

Vernier Go!Temp® 
temperature sensor

This analog sensor connects to the 
computer’s USB port and is used to collect 
temperature ranges.

You can use this sensor to:

• Collect weather data.

• Record temperature changes due to 
chemical reactions.

• Perform heat fusion studies.

Vernier Go!Motion® 
motion detector

This analog sensor connects to the 
computer’s USB port and is used to measure 
acceleration, speed, and velocity.

Use this sensor to:

Measure position and speed of a person or 
object.

Measure the acceleration of an object.

Sensor Description
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Performing an Experiment

When performing an experiment, these basic steps are the same no 
matter which type of experiment you perform.

1. Start a new document or problem.

Important! If you connect a sensor before starting the Vernier 
DataQuest™ application, the software automatically opens the 
Vernier DataQuest™ application.

2. Connect a sensor.

3. Modify sensor settings. (Optional, if using default settings)

4. Set the collection mode. (Optional, if using default settings)

5. Collect data.

6. Stop collecting data.

7. To save the data for future use, store the data set.

8. Save the experiment.

9. Analyze data.

10. Print data. (Optional, if you do not need a paper copy.)

Starting a Document
TI recommends starting a new document for each new experiment. 
Starting a new document ensures that the Vernier DataQuest™ 
application is set to its default values.

Important: The handheld can only have one document open. You are 
prompted to save it before creating a new document. TI also 
recommends that you have only one document open so the system 
assigns the sensor to the correct document.

Starting a New Document
To start a new document:

1. Click File > New TI-Nspire™ Document.

Handheld: Press c, and then select New Document.

A new document opens.

2. Click Add Vernier DataQuest.

The Vernier DataQuest™ opens.
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Adding a Problem to a Document
You can add a new problem to an existing document. TI recommends 
adding a new problem to the document, which ensures that the Vernier 
DataQuest™ application is set to its default values.

1. Click Insert > Problem.

Handheld: Press ~, and then select Insert > Problem.

2. Click Add Vernier DataQuest.

A new problem is added to the document.

Connecting Sensors
Some sensors require a sensor interface. For sensors that require an 
interface, you must connect the sensor to the interface first.

To connect a sensor and sensor interface:

1. Attach the sensor to the sensor interface using either the mini-USB, 
USB, or BT connector and the appropriate cable.

2. Attach the interface to a computer or handheld using the 
appropriate connector and cable.

Note: To attach a handheld to a TI-Nspire™ Lab Cradle, slide the 
handheld into the connector at the bottom of the Lab Cradle.

Direct-connect USB sensors, such as the Vernier Go!Temp® temperature 
sensor (for computers) or the Vernier EasyLink® temperature sensor (for 
handhelds), connect directly to the computer or handheld and do not 
need a sensor interface.

Modifying Sensor Settings
You can modify how the sensor values are displayed and stored. For 
example, when using a temperature sensor, you can change the unit of 
measure from Centigrade to Fahrenheit.

Changing Sensor Measurement Units
The unit options that can be changed vary depending on the selected 
sensor. For example, options for the Vernier Go!Temp® Temperature 
sensor are Fahrenheit, Celsius, and Kelvin. Options for the Vernier Hand 
Dynamometer (a specialized force sensor) are Newton, Pound, and 
Kilogram.

To change a unit of measure:

1. Click Experiment > Set Up Sensors.
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2. Click Change Units, and then select the sensor you want to change.

Note: The sensors displayed are those you attached or selected to use 
offline.

3. Select the unit type from the unit menu.

The measurement unit is changed.

Note: You can change the units before or after you collect data. The 
collected data reflects the new measurement unit.

Calibrating a Sensor
When the software or handheld detects a sensor, the calibration for that 
sensor automatically loads. You can calibrate some sensors manually. 
Other sensors, such as the Colorimeter and the Dissolved Oxygen Sensor, 
must be calibrated to provide useful data.

There are three options for calibrating a sensor:

• Manual Entry

• Two Point

• Single Point

For more information, see the sensor’s documentation for calibration 
values and procedures. 

Setting a Sensor to Zero
Not all sensors can be set to zero. You cannot set sensors in which relative 
measurements such as force, motion, and pressure are common to zero. 
Sensors designed to measure specific environmental conditions, such as 
Temperature, pH, and CO2 also cannot be set to zero.
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To set the standing value to zero:

1. Click Experiment > Set Up Sensor.

2. Click the sensor, and then click Zero.

Note: The sensors displayed in the sensor list are those attached or 
selected to use offline.

The sensor value is now at zero.

Reversing a Sensor Reading Display
Use this feature to change the display of the reading.

By default, pulling with a force sensor produces a positive force and 
pushing produces a negative force. Reversing the sensor allows you to 
display pushing as a positive force.

If more than one sensor can be reversed, choose the one to reverse from 
the list.

To reverse the display of the sensor reading:

1. Click Experiment > Set Up Sensor. 

2. Click the sensor, and then click Reverse.

The sensor display is now reversed. If you are in Meter View, the 

reverse indicator appears  after the sensor name.

Setting the Collection Mode
Use Collection Mode to select the appropriate mode for the experiment. 
The default Collection Mode is Time Based for new experiments. 

If you have unsaved data when you change the mode, a warning 
message states that changing modes clears unsaved data.

You can only use 

• Photogate timing mode with the Vernier Photogate sensor.

Reverse indicator
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• Drop Counting mode with the Vernier Drop Count sensor.

Setting a Time Based Collection Mode
The Time Based collection mode captures data using timing as a guide. 
Set this mode to collect either samples per second (Rate) or seconds per 
sample (Interval) to determine how often data points are collected. Rate 
and Interval are simply reciprocals of each other. To set the Collection 
Mode to Time Based: 

1. Click Experiment > Collection Mode > Time Based.

The Configure Time Based Data Collection window opens with either 
Interval or Rate selected. (It uses previous settings as the opening 
value.)

2. Select Rate or Interval from the list. 

• Rate (samples/second): Type the number of samples per second. 
The interval is calculated. 

• Interval (seconds/sample): Type the number of seconds per 
sample. The rate is calculated. 

3. Type the number of seconds the data collection should last in the 
Duration field.

4. Review the value in the Number of points field to ensure the rate and 
duration are reasonable.

Note: The Number of points field is a calculated field. This value is 
determined by the formula: Rate * Duration + 1.

Important: Collecting too many data points impacts system 
performance.

5. Select one of the following, if needed.

• Strip Chart (Optional): Strip Chart continuously collects samples 
but only retains the last x data points collected. (“x” represents 
the number of points defined in the Number of points field.)

• Data Marker (Optional): Selecting this option places the Add Data 
Marker  in the Data collection controls area. 

Click Add Data Marker  to emphasize specific points, such as 
when you observe a change or when you change a condition. 
Some examples of change are: 

– Ice begins to form. 

– You stir the solution. 
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– You add a chemical to the solution.

6. Click OK.

The settings are saved for the next run.

Setting the Events with Entry Collection Mode
Use the Events with Entry collection mode to capture samples manually 
by defining the independent value for each point you collect.

To set the collection mode as Events with Entry:

1. Click Experiment > Collection Mode > Events with Entry.

The Events with Entry Setup dialog box opens.

2. (Optional) Type a name for the label.

3. (Optional) Type the units for the independent variable.

4. (Optional) Select the Average over 10 s (seconds) option.

Data Markers
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Use this option when sensor values fluctuate. The system collects ten 
seconds of data and retains the average reading.

5. Click OK.

The settings are saved for the next run.

The Keep current reading icon  now appears (inactive) in Data 
collection controls.

Setting the Selected Events Collection Mode
Use the Selected Event collection mode to capture samples manually by 
defining the independent value for each point you collect.

To set the collection mode as Selected Events:

1. Click Experiment > Collection Mode > Selected Events.

The Selected Events Setup dialog box opens.

2. (Optional) Type a name for the label.

Use any meaningful value.

3. (Optional) Type the units for the independent variable.

4. (Optional) Select the Average over 10 s (seconds) option.

Use this option when sensor values fluctuate. The system collects ten 
seconds of data and retains the average reading.

5. Click OK.

The settings are saved for the next run. 

The Keep current reading icon  now appears (inactive) in Data 
collection controls.

Setting the Photogate Timing Collection Mode
Select the Photogate Timing collection mode only when using the 
Vernier Photogate sensor. The Photogate is for motion timing. It can time 
objects that pass through the gates or as a laser gate outside of the 
gates. It can also be used to time motion in any of these states:

• Pulse

• Pendulum

• Gate and pulse

• Gate state only



602 Performing an Experiment

Setting the Drop Counting Collection Mode
Select the Drop Counting collection mode only when using the Vernier 
Drop Counter optical sensor.

Collecting Data
After the sensor and collection mode are set up, you can start collecting 
the data for the experiment. The collection mode determines the steps 
required for collecting data.

If you are in Meter View when you start data collection, the Vernier 
DataQuest™ application changes to Graph View and begins recording 
sensor data. The graph updates to show the data as it is collected.

Important: When you use either Events with Entry mode or the 
Selected Events mode, data points are not recorded until you click 

Experiment > Keep or click .

Stopping the Data Collection
In most data collection modes, the collection ends automatically. If using 
the Events with Entry collection mode, you must stop data collection 
manually. You can also end data collection for any other mode manually 
at any time.

To stop a collection:

 Click Experiment > Stop Collection.

The current run stops.

Collecting Data in the Time Based Mode
To collect data using the Time Based mode:

1. Click Experiment > New Experiment to reset the sensor to its default 
values.

This step removes any existing data and ensures the connected sensor 
is set to its default values. 

2. Connect a sensor.

Note: When you connect a sensor, the sensor name is added to the 
sensor list.

3. Select Time Based for the collection mode. 

4. Click Experiment > Start Collection.

5. Click Experiment > Stop Collection.
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The data set run is complete.

Collecting Data in the Events with Entry Mode
Use this procedure only after you assign Events with Entry as the 
collection mode.

To collect data using the Events with Entry mode only:

1. Click Experiment > New Experiment to reset the sensor to its default 
values.

This step removes any existing data and ensures the connected sensor 
is set to its default values. 

2. Connect a sensor.

Note: When you connect a sensor, the sensor name is added to the 
sensor list.

3. Select Events with Entry for the collection mode. 

4. Click Experiment > Start Collection.

The Keep current reading icon  becomes active. The sensor shows 
the data point in the center of the screen. 

5. Click Experiment > Keep for each data point you want to keep.

The Events with Entry dialog box opens.

6. Type the value of the data point.

7. Click OK.

The data point is saved in the appropriate location on the graph. The 
next point appears in the center of the graph.

8. Repeat steps 5 through 7 until you collect all of the desired data 
points.

9. Click Experiment > Stop Collection.

The data set run is complete.
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Collecting Data in the Events with Entry Mode Average 
over 10 Option
Use this procedure only after you assign Events with Entry as the 
collection mode and select the Average over 10 option.

To collect data using the Events with Entry mode Average over 10 s 
option:

1. Click Experiment > New Experiment to reset the sensor to its default 
values.

This step removes any existing data and ensures the connected sensor 
is set to its default values. 

2. Connect a sensor.

Note: When you connect a sensor, the sensor name is added to the 
sensor list.

3. Select Events with Entry as the collection mode.

4. Check the Average over 10 s option.

5. Click Experiment > Start Collection.

The Keep current reading icon  becomes active. The sensor shows 
the data point in the center of the screen. 

6. When you are ready, click . 

The Averaging dialog box opens, counting down to zero seconds. 
When the counter reaches zero, the system records the data point in 
the appropriate location on the graph.

7. Repeat step 6 until you collect all of the data points.

8. Click Experiment > Stop Collection.

The data set run is complete.

Collecting Data in the Selected Events Mode
To use the Selected Events collection mode:
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1. Click Experiment > New Experiment to reset the sensor to its default 
values.

This step removes any existing data and ensures the connected sensor 
is set to its default values. 

2. Connect a sensor.

Note: When you connect a sensor, the sensor name is added to the 
sensor list.

3. Select Selected Events as the collection mode.

4. Check the Average over 10 s option.

5. Click Experiment > Start Collection.

Keep current reading becomes active. The sensor shows the data 
point in the center of the screen when in Graph View. 

6. Click Experiment > Keep for each data point to keep.

The data point is saved in the appropriate location on the graph. The 
next point appears in the center of the graph.

7. Repeat step 6 until you collect all of the data points.

8. Click Experiment > Stop Collection.

The data set run is complete.

Collecting Data in the Photogate Timing Mode
Use this procedure only after you assign Photogate Timing as the 
collection mode.

1. Click Experiment > New Experiment to reset the sensor to its default 
values.

This step removes any existing data and ensures the connected sensor 
is set to its default values. 

2. Connect a sensor.

Note: When you connect a sensor, the sensor name is added to the 
sensor list.

3. Select Photogate Timing as the collection mode.

4. Click Experiment > Start Collection.

5. Collect your data set.

6. Click Experiment > Stop Collection. 

The data set run is complete.
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Collecting Data in the Drop Counting Mode
Use this procedure only after you assign Drop Counting as the collection 
mode.

1. Click Experiment > New Experiment to reset the sensor to its default 
values.

This step removes any existing data and ensures the connected sensor 
is set to its default values.

2. Connect a sensor.

Note: When you connect a sensor, the sensor name is added to the 
sensor list.

3. Select Drop Counting as the collection mode.

4. Click Experiment > Start Collection.

5. Collect your data set.

6. Click Experiment > Stop Collection.

The data set run is complete.

Storing a Data Set
For most experiments, data is collected for multiple trials (runs). You can 
store the data set from the latest run before performing a new run. 
Storing the data prevents it from being overwritten and retains the data 
by creating a new data set for the next run. The data set is not saved 
outside the application until you save the data set as a TI-Nspire™ or 
PublishView™ document. 

Important: You must save the document if you want to keep the data 
after the application has been closed.

Note: The PublishView™ application is only available in the computer 
software.

If you do not need to retain the data from the previous run, overwrite 
the data set by starting another collection without storing the current 
data run.

To store a data set:

 Click Experiment > Store Data Set.

The first data set is stored as “Run 1" by default and “Run 2" opens 
for collecting additional data. You can change the data set names.
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Saving an Experiment
After you complete the experiment, save it as a TI-Nspire™ document 
(.tns file) or as a TI-Nspire™ PublishView™ document (.tnsp).

Important: The PublishView™ application is only available in the 
computer software.

1. Select the document you want to save.

2. Select File > Save Document.

Handheld: Press ~, and then click File > Save. 

The document is saved.

Working in the Graph View

When you collect data, it is written in both the Graph and Table views. 
Use the Graph view to analyze data. 

Important: The Graph menu and Analyze menu items are only active 
when working in Graph View.

To display the Graph view:

 Click View > Graph.

The Graph View screen opens.

.

Displaying Graphs
Use the Show Graph menu to show separate graphs when using:

• A sensor that plots more than one column of data.

• Multiple sensors with different defined units at the same time. 
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You can display the top graph (Graph1), bottom graph (Graph 2), or 
both.

In this example, two sensors (the Gas Pressure sensor and the Hand 
Dynamometer) were used in the same run. The following image shows 
the columns Time, Force, and Pressure in the Table view to illustrate why 
two graphs are shown. 

 Select View > Graph.

Displaying One Graph
When two graphs are displayed, the top graph is Graph 1 and the 
bottom graph is Graph 2.

To display only Graph 1:

 Select Graph > Show Graph > Graph 1.

Only Graph1 is displayed.

To display only Graph 2:

 Select Graph > Show Graph > Graph 2.

Only Graph 2 is displayed.

Displaying Multiple Graphs
To display both Graph 1 and Graph 2 together:

 Select Graph > Show Graph > Both.

Graph1 and Graph 2 are displayed.
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Displaying Graphs in the Page Layout View
Use the Page layout view when Show Graph is not the appropriate 
solution for showing more than one graph.

The Show Graph option is not applicable for:

• Multiple runs using a single sensor.

• Two or more of the same sensors.

• Multiple sensors that use the same column(s) of data.

To use Page Layout:

1. Open the original data set you want to see in two graph windows.

2. Click Edit > Page Layout > Select Layout.

Handheld: Press ~, and then select Page Layout > Select Layout.

3. Select the type of page layout you want to use. 
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In this example, the top and bottom  page symbol was selected.

4. Click Click here to add an application.

Handheld: Press b.

5. Select Add Vernier DataQuest.

The Vernier DataQuest™ application is added to the second view.

6. To see separate views, click the view you want to change, and then 
select View > Table.

The new view is displayed.

7. To show the same view, click the view to change.

8. Click View > Graph.

The new view is displayed.

Note: 
Selection in 
one view is 
reflected in 
the other.
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Customizing the Graph
You may customize the graph by adding a title, changing colors, and 
setting ranges for the axis.

Adding a Title
When you add a title to a graph, the title is displayed in the View Details 
area. When you print the graph, the title prints on the graph.

1. Click Graph > Graph Title.

The Graph Title dialog box opens.

If there are two graphs in the work area, the dialog box has two title 
options. 
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2. Type the name of the graph in the Title field.

—or—

a) Type the name of the first graph in the Graph 1 field.

b) Type the name of the second graph in the Graph 2 field.

3. Select Enable to show the title.

Note: Use the Enable option to hide or show the graph title as 
needed.

4. Click OK.

The title is shown.

Setting Axis Ranges for One Graph
To modify the minimum and maximum range for the x and y axis:

1. Click Graph > Window Settings.

The Window Settings dialog box opens.
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2. Type the new values in one or more of these fields:

– X Min

– X Max

– Y Min

– Y Max

3. Click OK.

The application uses the new values for the graph visual range until 
you modify the range or change data sets.

Setting Axis Ranges for Two Graphs
When working with two graphs, enter two y axis minimum and 
maximum values, but only one set of minimum and maximum values for 
the x axis.

1. Click Graph > Window Setting.

The Window Setting dialog box opens.

2. Type the new values in one or more of these fields:

– X Min
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– X Max

– Graph 1: Y Min

– Y Max

– Graph 2: Y Min

– Y Max

3. Click OK.

The application uses the new values for the graph visual range until 
you modify the range or change data sets.

Setting the Axis Range on the Graph
You can modify the minimum and maximum range for the x and y axis on 
the graph.

1. Select the text you want to change.

2. Type a new value for the text.

Handheld: 

• Place the cursor over the value until the cursor changes to an 

I-beam . 

• Highlight the text you want to change.

• Type a new value for the text.

• Press ·.

The text is changed, and the graph redrawn to reflect the change in 
value.
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Selecting a Data Set to Plot
To save data sets or run multiple trials, select the data set to plot.

1. Click Graph > Select Data Set.

The list of available data sets opens.

2. Select one of the following:

• Data Set name. Plot one specific data set.

• All. Plot all data sets.

• More. Choose a combination of data sets to plot. 

When you use the More option and select more than one data set 
but not all data sets, the Data Set selection tool states Custom.

3. Click OK.

The data set you selected is displayed.

Autoscaling a Graph
Use the autoscale option to show all the points plotted. Autoscale Now is 
useful after you change the x and y axis range or zoom in or out of a 
graph. You can also define the automatic autoscale setting to use during 
and after a collection.

Autoscale Now Using the Application Menu
 Click Graph > Autoscale Now.

The graph now displays all the points plotted.

Autoscale Now Using the Context Menu
1. Open the context menu in the graph area.

2. Click Window/Zoom > Autoscale Now.

The graph now displays all the points plotted.

Defining Autoscale During a Collection
There are two options for using the automatic autoscaling that occurs 
during a collection. To choose an option:
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1. Click Options > Autoscale Settings.

The Autoscale Settings dialog box opens.

2. Click ¢ to open the During Collection drop-down list.

3. Select one of these options:

• Autoscale Larger - Expands the graph as needed to show all 
points as you collect them. 

• Do Not Autoscale - The graph is not changed during a collection.

4. Click OK to save the setting.

Defining Autoscale After a Collection
You have three options for setting the automatic autoscaling that occurs 
after a collection. To set your choice:

1. Click Options > Autoscale Settings.

The Autoscale Settings dialog box opens.

2. Click ¢ to open the After Collection drop-down list.

3. Select one of these options:

• Autoscale to Data. Expands the graph to show all data points. 
This option is the default mode.

• Autoscale From Zero. Modifies the graph so all data points 
including the origin point are displayed.

• Do Not Autoscale. The graph settings are not changed.

4. Click OK to save the setting.

Selecting a Range of Data
Selecting a range of data on the graph is useful in several situations, such 
as when zooming in or out, striking and unstriking data, and examining 
settings.

To select a range:
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1. Place the cursor at the start of the area. 

2. Drag the cursor across the graph to the end of the selected region. 

The selected area is indicated by gray shading.

Handheld:

• Place the cursor at the starting point, and then press / x. 

The cursor changes to  (double-headed arrow).

• Move the cursor to the end of the selection. 

• Press d. 

The cursor changes to å (single-headed arrow).

3. Perform one of these actions.

• Zoom in or out

• Strike or unstrike data

• Examine settings

Zooming In on a Graph
You can zoom in on a subset of the collected points. You can also zoom 
out from a previous zoom or expand the graph window beyond the data 
points collected.

To zoom in on a graph:

1. Select the area you want to zoom into or use the current view.

2. Click Graph > Zoom In.

The graph adjusts to display only the area you selected. 

The x range selected is used as the new x range. The y range 
autoscales to show all graphed data points in the selected range.

These images show an original view and zoom in performed multiple 
times (or as a selected region).
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Zooming Out of a Graph
To zoom out of a graph:

 Select Graph > Zoom Out.

The graph is now expanded.

If a Zoom In precedes a Zoom Out, the graph displays the original 
settings prior to the Zoom In. 

For example, if you Zoomed In twice, the first Zoom Out would 
display the window of the first Zoom In. To display the full graph with 
all data points from multiple zoom ins, use Autoscale Now.

Changing the Point Display
You can adjust the way points are displayed on graphs, change the point 
colors, and change the symbols for point markers.

Setting Point Options
To indicate how often marks show on the graph and whether to use a 
connecting line:

1. Click Options > Point Options.

The Point Options dialog box opens.

2. Select a Mark option from the drop-down list.

• None. No point protectors.

• Regional. Periodic point protectors.

• All. Every data point as a point protector.

3. Select Connect Data Points to display a line between points.

—or—

Clear Connect Data Points to remove the line between points.
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The following graphics show examples of some of the Point Mark 
options.

Changing Point Colors
To change the color of the marks from the default settings.

Note: On a TI-Nspire™ handheld, color is represented by different 
shades of gray.

1. Right-click the graph to open the menu.

2. Click Color.

Note: The data option is often preceded by the data set name and 
column name. 

3. Click the column variable to change.

4. Click the color.

The line representing the data changes to the color selected.

Selecting Point Markers
1. Right-click in the graph to open the menu.

2. Click Point Marker.

Note: If there is only one dependent variable column, the Point 
Marker option is preceded by the data set name and column name. 
Otherwise, the Point Marker option has a menu.

Regional

Connect Data Points - Selected

All 

Connect Data Points - not 
selected

None

Connect Data Points - Selected
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3. Select the column variable to change.

4. Select the point marker to set.

The Point Marker changes to the option selected.

Selecting an Independent Variable Column
Use the option Select X-axis Column to select the column used as the 
independent variable when graphing the data. This column is used for all 
graphs.

1. Click Graph > Select X-axis Column.

2. Select the variable you want to change.

The x-axis label on the graph changes and the graph is reordered 
using the new independent variable for graphing the data.

Selecting a Dependent Variable Column
Use the option Select Y-axis Column to select which dependent variable 
columns to plot on the displayed graph(s). 

1. Click Graph > Select Y-axis Column.

2. Select one of the following:

• A variable from the list. The list is a combination of dependent 
variables and the number of data sets. 

• More. Selecting More opens the Select dialog box. Use this when 
you want to select a combination of data set variables to graph.
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Showing and Hiding Details
You can hide parts of the screen to provide a larger view of the screen.

The following example shows screens with the details shown.

To hide details:

 Click Options > Hide Details.

The menu changes from Hide Details to Show Details.

The following parts of the screen are hidden:

• Vernier DataQuest™ application view tabs

• View Details area

• Data collection controls

To show details:

 Click Options > Show Details.

Analyzing the Data in Table View

Table view provides another way to sort and view collected data.
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Defining Column Options
You can name columns and define the decimal points and the precision 
you want to use. To define the columns:

1. Click View > Table.

The Table view is displayed.

In this example, no data sets have been run and the Vernier Gas 
Pressure Sensor is attached.

2. Click Data > Column Options. 

Note: You can be in the Meter, Graph, or Table view and still click 
these menu options. The results will still be visible.

3. Click the name of the column you want to define.

Note: Some of the fields may be populated but can be edited.

The Column Options dialog box opens.

4. Type the long name for the column in the Name field.

5. Type the abbreviated name in the Short Name field.

Note: This name is displayed if the column cannot expand to display 
the full name.
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6. Type the number of units in the Units field.

7. From the Displayed Precision drop-down list, select the precision 
value.

Note: The default precision is related to the precision of the sensor.

8. Select Link to list to link to the symbol table and make this 
information available to other TI-Nspire™ applications.

Note: Linking is the default for most sensors.

Important: Heart rate and blood pressure sensors require a 
tremendous amount of data to be useful, and the default for these 
sensors is to be unlinked to improve system performance. 

9. Select Apply changes to all Data Sets to apply these settings to all 
data sets.

10. Click OK.

The column settings are now defined with the new values.

Creating a New Data Set 
You can create a new data set that has the same columns as the existing 
data set(s). Column definitions from the latest data set are applied to the 
new data set.

 Select Data > New Data Set.

An empty data set is created with the same column definitions as the 
existing data set.

Changing a Data Set Name
You can change the Data Set name above the column headings. This 
change is also displayed in the Data Set selection tool and the Details 
View area.

1. Click View > Table.

2. Right-click the Table pane.

The context menu is displayed for the table data set name, for 
example, Run1.
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3. Click Options (preceded by the data set name).

The Data Set Options dialog box opens.

4. Type the new name in the Name field.

Note: The maximum character limit is 30 and the name cannot 
contain commas.

5. (Optional) Type information about the data set in the Notes field.

6. Click OK.

The data set name is now changed.

Adding a New Column
To enter data manually, add a new column. Sensor columns cannot be 
modified, but data entered manually can be edited.

1. Click Data > New Manual Column.

The Column Options dialog box opens.

Note: Some of the fields may be populated but can be edited.
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2. Type the long name for the column in the Name field.

3. Type the abbreviated name in the Short Name field.

Note: This name is displayed if the column cannot expand to display 
the full name.

4. Type the units to be used.

5. From the Displayed Precision drop-down list, select the precision 
value.

Note: The default precision is related to the precision of the sensor.

6. (Optional) Select Apply changes to all Data Sets to apply these 
settings to all data sets.

7. (Optional) Select Generate Values to automatically populate the 
rows.

If you select this option, complete these steps:

a) Type a starting value in the Start field.

b) Type an ending value in the End field.

c) Type the increase in value in the Increment field.

The number of points is calculated and shown in the Number of 
Points field.

8. Select Link from list to link to data in another TI-Nspire™ 
application.

Note: This list only populates when data exists in the other 
application and includes a column label.
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9. Select Link to list to link to the symbol table and make this 
information available to other TI-Nspire™ applications.

Note: Linking is the default for most sensors.

Important: Heart rate and blood pressure sensors require a 
tremendous amount of data to be useful, and the default for these 
sensors is to be unlinked to improve system performance. 

10. Click OK.

A new column is added to the table. This column can be edited.

Adding a New Calculated Column
You can add an additional column to the data set in which the values are 
calculated from an expression using at least one of the existing columns.

Use a calculated column when finding the derivative for pH data. For 
more information, see Adjusting Derivative Settings.

1. Click Data > New Calculated Column.

The Column Options dialog box opens.
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2. Type the long name for the column in the Name field.

3. Type the abbreviated name in the Short Name field.

Note: This name is displayed if the column cannot expand to display 
the full name.

4. Type the units to be used.

5. From the Displayed Precision drop-down list, select the precision 
value.

Note: The default precision is related to the precision of the sensor.

6. Type a calculation including one of the column names in the 
Expression field.

Note: The system-provided column names are dependent on the 
sensor(s) selected and any changes made to the name field in Column 
Options.

Important: The Expression field is case-sensitive. (Example: 
“Pressure” is not the same as “pressure.”)

7. Select Link to list to link to the symbol table and make this 
information available to other TI-Nspire™ applications.

Note: Linking is the default for most sensors.

Important: Heart rate and blood pressure sensors require a 
tremendous amount of data to be useful, and the default for these 
sensors is to be unlinked to improve system performance. 
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8. Click OK.

The new calculated column is created.

Striking and Restoring Data
To strike data:

1. Open the data run that contains the data to be struck.

2. Select View > Table.

3. Select the starting row and scroll to the ending point. 

To select the region: 

Drag the cursor to the bottom or top of the screen to select the area 
out of the immediate view. It also scrolls the screen so you can see the 
selection.

Handheld: Select the first cell by pressing the Touchpad and holding 
until the cell is filled. Release and move the cursor across cells until 
the row is selected. Move the cursor to the bottom or top of the 
screen to select the rest of the region. Click the Touchpad to complete 
the selection.
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In this example, row 21 is selected as the beginning area and row 147 
as the end.

4. Click Data > Strike Data.

Handheld: Press b, and then click Data > Strike Data.

5. Select one of the following:

• In Selected Region: Strike the data from the area you selected.

• Outside Selected Region: Strike all data except the area you 
selected.

The selected data is removed from the table.

Restoring Struck Data
You can restore previously struck data in any view.

1. Select the range of data to restore or if restoring all struck data, start 
at step two.

2. Click Data > Restore Data.

3. Select one of the following:

• In Selected Region - Restore data in the selected area.

• Outside Selected Region - Restore data outside the selected area.

• All Data - Restore all data. No data selection necessary.

The data is restored.

Beginning of 
selection

End of selection
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Analyzing Data in Graph View

In the Vernier DataQuest™ application, use Graph View to analyze data. 
Start by setting up graphs, and then use analysis tools such as integral, 
statistics, and curve fit to investigate the mathematical nature of the 
data.

Important: The Graph menu and Analyze menu items are only available 
when working in Graph View.

Viewing Data for Analysis
When analyzing data, you can view information in the View Details area, 
the View All Details dialog box, or on the graph.

Examining the View Details Area Data
When you perform analysis options, open the All Details for Graph dialog 
box to examine the details for the data. You can open and close this 
dialog box as often as you need.

Important: Some information is only shown in the View Details dialog 
box.

The detail information is shown in the View Details area even when the 
dialog box is closed. 

You can expand the View Details area to have more space to display 
information.

To view details for collected data:

1. Right-click in the View Details area to open the context menu.

Handheld: Press / b .

2. Click Details > All Details.

The All Details for Graph dialog box opens.
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3. Use the scroll bar to view the rest of the data.

4. Click OK.

Note: Other options under the Details context menu may be available. 
These options are subsets you can select if you only want to view some of 
the details.

Expanding the View Details Area
Use this procedure to expand the View Details area. Increasing its size 
reduces the size of the graph. Use this same procedure to reduce the 
View Details area.

In this example, tangent line and statistics are displayed.

1. Place the cursor at the edge of the View Details area and hover until 

the cursor changes to .

2. Click and hold until the cursor changes to .

3. Drag the area to the right to increase the size, and then click to set 
the size.

Drag the area to the left to decrease the size, and then click to set the 
size.
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Interpolating the Value Between Two Data Points
Use Interpolate to estimate the value between two data points and to 
determine the value of a Curve Fit between and beyond these data 
points. You can find the area under all of the data or a selected region of 
the data.

The examine line moves from data point to data point. When Interpolate 
is on, the examine line moves between and beyond data points.

To use Interpolate:

1. Click Analyze > Interpolate.

A check mark appears in the menu next to the option.

2. Click the graph.

The examine indicator is drawn to the nearest data point.

The values of the plotted data are shown in the View Details area and 
the All Details for Graph dialog box.

You can shift the examine line by moving the cursor with the arrow 
keys or by clicking on another data point.

For information on clearing the Integral analysis, see Removing 
Analysis Options.

Finding the Slope
Tangent displays a measure of the rate at which the data is changing at 
the point you are examining. The value is labeled “Slope.”

To find the slope:

1. Click Analyze > Tangent.

A check mark appears in the menu next to the option.

2. Click the graph.

The examine indicator is drawn to the nearest data point.

The values of the plotted data are shown in the View details area and 
the All Details for Graph dialog box.

You can move the examine line by moving the cursor with the arrow 
keys or clicking on another data point.



Analyzing Data in Graph View 633

For information on clearing the Integral analysis, see Removing 
Analysis Options.

Finding the Area Under a Data Plot
Use Integral to determine the area under a data plot. You can find the 
area under all of the data or a selected region of the data.

To find the area under a data plot:

1. Leave the graph unselected to examine all the data, or select a range 
to examine a specific area.

2. Click Analyze > Integral.

3. Select the plotted column name if you have more than a single 
column.

The data plot area is displayed in the View Details area.

For information on clearing the Integral analysis, see Removing 
Analysis Options.
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Generating Statistics
Use this option to determine the statistics associated with the plotted 
data. Minimum, maximum, mean, standard deviation, and number of 
samples are calculated. You can find the statistics for all the data or a 
selected region of data. The values are displayed in the View Details area 
and in the All Details for Graph dialog box.

To generate statistics:

1. Leave the graph unselected to examine all the data, or select a range 
to examine a specific area.

2. Click Analyze > Statistics.

3. Select the plotted column name if you have more than a single 
column. For example, run1.Pressure.

The Stats dialog box opens. 

4. Review the data. 

5. Click OK.

For information on clearing the Statistics analysis, see Removing 
Analysis Options.

Generating a Curve Fit
Use Curve Fit to find the best curve fit to match the data. Select all of the 
data or a selected region of data. The curve is drawn on the graph.

To generate curve fit:

1. Leave the graph unselected to examine all the data, or select a range 
to examine a specific area.

2. Click Analyze > Curve Fit.

The Model dialogue box opens.
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3. Refer to the table below to select a curve fit option.

The Fit Linear dialog box opens.

Curve Fit option Calculated in the form:

Linear y = m*x + b

Quadratic y = a*x^2 + b*x + c

Cubic y = a*x^3 + b*x^2 + c*x + d

Quartic y = a*x^4 + b*x^3 + c*x^2 + d*x + e

Power (ax^b) y = a*x^b

Exponential 
(ab^x)

y = a*b^x

Logarithmic y = a + b*ln(x)

Sinusoidal y = a*sin(b*x + c) + d

Logistic (d  0) y = c/(1 + a*e^(-bx)) + d

Natural 
Exponential

y = a*e^(-c*x)

Proportional y = a*x
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4. Click OK.

The following image is an example of a Quadratic curve fit.

5. Review the data.

For information on clearing the Curve Fit analysis, see Removing 
Analysis Options.

Plotting a Model
This option provides a manual method for plotting a function to fit data. 
Use one of the predefined models or enter your own.

You can also set the spin increment to use in the View Details dialog box. 
Spin increment is the value by which the coefficient changes when you 
click the spin buttons in the View Details dialog box.

For example, if you set m1=1 as the spin increment, when you click the 
up spin button the value changes to 1.1, 1.2, 1.3 and so on. If you click 
the down spin button, the value changes to 0.9, 0.8, 0.7, and so on.
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To plot the model:

1. Click Analyze > Model.

The Model dialog box opens.

2. Type your own function.

—or—

Click to select a value from the drop-down list.

3. Click OK.

The Set Coefficient Values dialog box opens.

4. Type the value for the variables.

5. Type the change in value in the Spin Increment fields.

6. Click OK.
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Note: These values are the initial values. You can also adjust these 
values in the View Details area.

The model is shown on the graph with adjustment options in the 
View Details area and in the All Details for Graph dialog box.

Notice that the minimum and maximum axis are too large for this 
particular example.

7. (Optional) Adjust the window setting for minimum and maximum 
axis values. For more information, see Setting the Axis for One Graph.

For information on clearing the Model analysis, see Removing 
Analysis Options.

8. Click  to make any desired adjustments to the coefficients.

—or—

Spin buttons
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Click the value in the View Details area.

This graphic is an example of a model with adjusted values.

Removing Analysis Options
When clearing previously analyzed data from the graph and the View 
Details area, you can choose to clear all data, a specific data display, or 
remove any generated models.

Use the View Detail menu to remove the following items:

• Integral

• Statistics

• Curve Fit

• Model

1. Click Analyze > Remove.

2. Select the data display you want to remove.

The display you selected is removed from the graph and the View 
Details area.

Working with Advanced Analysis Features

Use the Vernier DataQuest™ application advanced data analysis features 
to:

• Replay the data collection.

• Adjust derivative settings.

• Draw a predictive plot.
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• Use Motion Match.

• Examine graphs using the Page Layout view.

Replaying the Data Collection
Use the Replay option to playback the data collection. This option lets 
you: 

• Select the data set you want to replay.

• Pause the playback.

• Advance the playback by one point at a time.

• Adjust the playback rate.

• Repeat the playback. 

Selecting the Data Set to Replay
You can replay one data set at a time. By default, the latest data set plays 
using the first column as the base column (example: time reference). 

If you have multiple data sets, and want a different data set or base 
column than the default, you can select the data set to replay and the 
base column.

To select the data set to replay:

1. Click Experiment > Replay > Advanced Settings.

The Advanced Replay Settings dialog box opens.

2. Select the data set to replay from the Data Set drop-down list.

Note: Changing the run in the Data Set selection tool does not affect 
the playback choice. You must specify which data set in 
Experiment > Replay > Advanced Settings.

3. (Optional) Select a new value from the Base Column drop-down list.

The selected column acts as the “Time” column for the replay.

Note: The base column should be a strictly increasing list of numbers.
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4. Click Start to start the playback and save the settings.

Note: Data Set and Base Column options are based on the number of 
stored runs and the sensor type used.

Starting the Playback
To start the playback:

 Select Experiment > Replay > Start Playback.

Playback of the data set run starts, and the Data Collection Control 
buttons change to Stop Playback, Pause, and Advance by One Point. 
The Advanced by One Point button (and menu item) is inactive until 
you pause the replay.

Pausing the Playback
To pause the playback:

 Select Experiment > Replay > Pause or click .

The following events occur:

• The playback pauses.

• The menu option changes to "Resume." 

• The button changes to .

• The menu option Advance One becomes active.

Restarting the Playback
To restart the playback after pausing: 

 Select Experiment > Replay > Resume.

The playback resumes.

Advancing the Playback by One Point
Use this option to advance the playback point by point. The playback 
must be selected and paused for this option to be available. 

To advance the paused playback:

 Select Experiment > Replay > Advance One.

The playback advances by one point until the last point is reached. 
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Adjusting the Playback Rate
To adjust the playback rate:

1. Select Experiment > Replay > Playback Rate.

The Playback Rate dialog box opens.

2. In the Playback Rate field, click ¤ to open the drop-down list.

3. Select the rate at which the playback will play.

Normal speed is 1.00. A higher value is faster, and a lower value is 
slower.

4. Select one of the following options:

• Click Start to start the playback and save the settings.

• Click OK to save the settings for use on the next playback.

Repeating the Playback
1. Select Experiment > Replay > Start Playback.

2. Click Start to start the playback and save the settings.

Adjusting Derivative Settings
Use this option to select the number of points to use in derivative 
calculations. This value affects the tangent tool, velocity, and 
acceleration values.

Find pH derivative settings using a calculated column. 

The Vernier DataQuest™ application can determine a numeric derivative 
from a list of data with respect to another list of data. The data can be 
collected using sensors, input manually, or linked with other applications. 
The numerical derivative is found using a calculated column.

To determine the numerical 1st derivative of List B with respect to List A, 
enter the following expression in the Column Options dialog:

derivative(B,A,1,0) or derivative(B,A,1,1)
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To determine the numerical 2nd derivative of List B with respect to List A, 
enter the following express:

derivative(B,A,2,0) or derivative (B,A,2,1)

The last parameter is either 0 or 1 depending on the method you are 
using. When it is 0, a weighted average is used. When it is 1, a time 
shifted derivative method is used.

Note: The first derivative calculation (weighted average) is what the 
Tangent tool uses to display the slope at a data point when examining 
data. (Analyze > Tangent).

Note: The derivative calculation is completely row based. It is 
recommended that your List A data be sorted in ascending order.

1. Click Options > Derivative Settings.

The Settings dialog box opens.

2. Select the number of points from the drop-down list.

3. Click OK.

Drawing and Clearing a Predictive Plot
You can add points to the graph to draw a prediction and you can 
remove the prediction.

Drawing a Predictive Outcome
Use this option to add points to the graph to predict the outcome of an 
experiment.

To draw the prediction:

1. Click Analyze > Draw Prediction > Draw.

2. Move the cursor over the graph, and then click each area in which 
you want to place a point. 

3. Press Esc to release the drawing tool.

Handheld: Press d.

The following image is an example of a drawn prediction.
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Clearing the Prediction
To clear the drawn prediction:

 Click Analyze > Draw Prediction > Clear.

Using Motion Match
Use this option to create a randomly generated plot when creating 
position versus time or velocity versus time graphs.

This feature is only available when using a motion detector like the 
CBR 2™ sensor or the Go!Motion® sensor. 

Generating a Motion Match Plot
To generate a plot:

1. Attach the motion detector.

2. Click View > Graph.

3. Click Analyze > Motion Match.

4. Select one of the following options:

• New Position Match. Generates a random position plot.

• New Velocity Match. Generates a random velocity plot.

The following image is an example of the Motion Match (New 
Velocity Match) generated plot:
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Note: Continue selecting a new position or a new velocity match to 
generate a new random plot without removing the existing plot.

Removing a Motion Match Plot
To remove the generated plot:

 Click Analyze > Motion Match > Remove Match.

Using Advanced Data Collection Options

To collect information at a remote location, you can set up and use a 
remote sensor.

Use one of the two following methods to collect data using a remote 
sensor:

• The manual trigger on the TI-Nspire™ Lab Cradle or a sensor with a 
trigger to start the collection.

• A time delay to start the collection.

Setting Up Offline Sensors
Use the Add Offline Sensor option to set collection parameters and 
change units for a sensor that is not currently attached to a computer or 
handheld.

You cannot use a sensor offline, but you can prepare it for use before it is 
attached. This option makes it faster to share the sensor during a lesson 
or lab when there are not enough sensors for everyone.

1. Click Experiment > Advanced Set Up > Configure Sensor > Add 
Offline Sensor.
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The Select Sensor dialog box opens.

2. Select a sensor from the drop-down list.

The sensor is displayed in the view you have open.

3. Click View > Meter.

The Meter view shows the list of available sensors.

Setting Up a Remote Collection Unit
Only the TI-Nspire™ Lab Cradle, TI CBR 2™, and Vernier Go!Motion® 
support remote data collection.

Sensors use values currently defined in the Vernier DataQuest™ 
application. You must edit these collection mode values before you set 
up the remote unit. For more information, see Modifying Sensor 
Settings.

To select the collection unit:

1. Connect a sensor.

2. Set up the experiment by opening a new document and setting the 
collection mode.

For more information, see Setting the Collection Mode.

3. Click Experiment > Advanced Set Up > Remote Collection.

4. Select a data collection device from the content list.

The Remote Setup Details dialog box opens.
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5. (Optional) Type the delay value.

Setting the delay at zero allows you to use the manual trigger button 
on the Lab Cradle to start the collection. See Using the Manual 
Trigger to Start the Collection.

6. Click OK.

The Remote Setup dialog box opens.

A message is displayed telling you how to start the collection and that 
it is safe to disconnect the data collection device.

7. Disconnect the sensor.

8. View the LED lights to determine if the sensor is ready to collect data.

• Red. Indicates that the system is not ready.

• Amber. Indicates the system is ready, but is not collecting data.

• Green. Indicates the system is collecting data.

9. Press the trigger to collect data.

Setting Up the Sensor for Triggering
To start data collection based on a specific sensor reading, the TI-Nspire™ 
Lab Cradle and sensor must be connected.

You must set the sensor and the threshold type for the system to use 
when collecting data. When the trigger is reached, the sensor starts 
collecting data.

To set up the trigger:

1. Connect the sensor.

2. Click Experiment > Advanced Set up > Triggering > Set Up.

The Configure Trigger dialog box opens.
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3. Select the sensor from the Select the sensor to use as trigger drop-
down list.

Note: The menu displays the sensors connected to the TI-Nspire™ Lab 
Cradle.

4. Select one of the following from the Select the type of trigger to 
use drop-down list.

• Increasing through threshold. Use to trigger on increasing 
values.

• Decreasing through threshold. Use to trigger on decreasing 
values.

5. Type the appropriate value in the Enter the trigger threshold in 
units of the selected sensor field.

When entering the trigger value, enter a value within the range of 
the sensor.

If you change the unit type after setting the threshold, the value 
automatically updates.

For example, if you use the Vernier Gas Pressure sensor with the units 
set as atm and you later change the units to kPa, the settings are 
updated.

6. Type the number of data points to keep before the trigger value 
occurs.

7. Click OK.

The trigger is now set and enabled if values were entered.
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8. (Optional) Select Experiment > Advanced Set up > Triggering to 
verify the active indicator is set to Enabled.

Important: When the trigger is enabled, it stays active until it is 
disabled or you start a new experiment.

Enabling a Disabled Trigger
If you set the trigger values in the current experiment, and then disable 
them, you can enable the triggers again.

To enable a trigger:

 Click Experiment > Advanced Set Up > Triggering > Enable.

The trigger is now active.

Disabling an Enabled Trigger
To disable the active trigger.

 Click Experiment > Advanced Set Up > Triggering > Disable.

The trigger is no longer active.

Using the Manual Trigger to Start the Collection
1. Save and close any open documents.

When performing experiments, TI recommends that you have only 
one document open. The system cannot determine which of the 
documents to use with the sensor if multiple documents are open.

2. Create a new document.

Creating a new document ensures that the Vernier DataQuest™ 
application is set to its default values.

3. Attach a sensor to the TI-Nspire™ Lab Cradle.

4. Attach the TI-Nspire™ Lab Cradle to the computer or handheld.

5. Set up an experiment.

6. Click Experiment > Advanced Set Up > Remote Collection > 
TI-Nspire Lab Cradle.

The Remote Setup Details dialog box opens.
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7. Review the settings. Verify the delay is at zero (no delay).

Setting the delay at zero allows you to use the manual trigger button 
on the Lab Cradle to start data collection.

8. Click OK.

The Remote Setup dialog box opens indicating the sensor is ready for 
remote collection.

9. Disconnect the Lab Cradle.

10. Click OK.

When you disconnect the TI-Nspire™ Lab Cradle from the handheld 
or computer, verify the status. When the LED transfer is blinking 
amber, the Lab Cradle is ready to collect data.

11. Press the trigger button on the Lab Cradle.

The data collection starts immediately.

After you have collected data, see Retrieving Remote Data.

Using a Delay to Start the Collection
1. Save and close any open documents.

When performing experiments, TI recommends that you have only 
one document open. The system cannot determine which of the 
documents to use with the sensor if multiple documents are open.
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2. Create a new document.

Creating a new document ensures that the Vernier DataQuest™ 
application is set to its default values.

3. Attach a sensor to the TI-Nspire™ Lab Cradle.

4. Attach the TI-Nspire™ Lab Cradle to the computer or handheld.

5. Click Experiment > Advanced Setup > Remote Collection > 
TI-Nspire Lab Cradle.

The Remote Setup Details dialog box opens.

6. Review the settings. 

7. Type the amount of time in seconds to delay the start of the 
collection.

Important: When you use a delay, the manual trigger button on the 
TI-Nspire™ Lab Cradle has no impact on the start of the collection.

8. Click OK.

The Delayed Remote Setup dialog box opens indicating when 
sampling will begin.

9. Click OK.

The Remote Setup dialog box opens indicating the countdown has 
started.

10. Click OK.

11. Disconnect the Lab Cradle.

12. View the LED lights to determine if the sensor is ready to collect data.

• Red. Indicates that the system is not ready.

• Amber. Indicates the system is ready, but is not collecting data.

• Green. Indicates the system is collecting data.

13. Collect the data.

After you have collected the data, see Retrieving Remote Data.

Retrieving Remote Data
After data is collected, you must transfer the data to the computer or 
handheld. After the data transfers, you can analyze the data. For more 
information, see Analyzing Data in Graph View.

To retrieve data:

1. Open the Vernier DataQuest™ application.
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2. Attach the TI-Nspire™ Lab Cradle to the handheld or computer.

The Remote Data Detected dialog box opens.

3. Click Import.

The data transfers to the Vernier DataQuest™ application.

Printing Data

You can only print from the computer. You can print any single displayed 
active view, or with the Print All option:

• One data view.

• All of the data views.

• A combination of the data views.

The Print All option has no affect on applications outside of the Vernier 
DataQuest™ application.

Selecting Print All Options
To select the Print All option:

1. Click Options > Print All Settings.

The Print All Settings dialog box opens.

2. Select the views you want to print.

• Print Current View. The current view is sent to the printer.
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• Print All Views. All three views (Meter, Graph, and Table) are sent 
to the printer.

• More. Only the views you select are sent to the printer.

3. Click OK.

The Print All Settings are now complete and can be used when 
printing.

Printing Data Views
To print a data view:

1. Click File > Print.

The Print dialog box opens.

2. Select Print All from the Print what drop-down list.

3. Select additional options, if needed.

4. Click Print to send the document to the printer.

Using the Sensors and Data with Other Applications. The 
Sensor Console is a specialized view of the Vernier DataQuest™ 
application designed for using sensors with other TI-Nspire™ 
applications such as:

• Graphs

• Geometry
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• Data & Statistics

• Lists & Spreadsheet 

When you perform experiments, TI recommends that you have only one 
document open. The system cannot determine which of the documents 
to use with the sensor if multiple documents are open.

Collecting Data in Other Applications
To use Sensor Console with a sensor:

1. Open the application you want to use to capture the data.

2. Click Insert > Sensor Console.

Handheld: Press ~, and then Insert > Sensor Console.

3. Attach the sensor if it is not already attached. 

4. Wait a moment for the Sensor Console bar to become active.

5. Click Collect Data > Start Collections.

6. Wait for the data set run to end or stop the collection.

Stopping Data Collection
To stop collecting data:

1. Click Collect Data > Stop Collection.

Handheld: Press b and select Collect Data > Stop Collection

2. Click Collect Data > Close Console.

The data set is available for use in the current application. 

Opening the Sensor Console Application Menus
The Sensor Console menus are a subset of the Vernier DataQuest™ 
menus. 

Accessing the Application Menu on the Computer
To access the Sensor Console menu:

1. Click anywhere on the Sensor Console.

Handheld: Press b.

2. Click Collect Data.
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The Sensor Console menu opens.

Note: To access options specific to the Sensor Console, right-click the 
Sensor Console bar. On a handheld, press / b.

Viewing Existing Data
You can view data collected and stored from a different TI-Nspire™ 
application in the current application.

1. Open the document with the captured data set.

For example, open the Graphs application.
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2. Click Insert > [other application].

For example, insert Lists and Spreadsheet.

The selected application opens.

3. Click Insert > Sensor Console.

The Sensor Console bar opens at the bottom of the application.

In this example a sensor is attached, but it does not have any affect on 
this procedure.

4. Click Collect Data > View Data in Apps on Current Page.
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Handheld: 

a) Click in the Sensor Console area.

b) Press b, and then Collect Data > View Data in Apps on 
Current Page.

Wait until the data is populated. After a few moments, the data is 
displayed.

5. Click Collect Data > Close Console.

You can now work with the data in the current application.

Analyzing Data in the Data & Statistics 
Application
When you open existing data in the Data & Statistics application, the 
data first displays as a Dot Point graph. You must take additional steps to 
organize the points.

The following image is an example of existing data opened as a Dot 
Point graph in the Data and Statistics application.
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1. Open a document containing a data set from the Data & Statistics 
application.

2. Click the text “Click to add variable” on the y-axis.

3. Select the variable.

4. Click the text “Click to add variable” on the x-axis.

5. Select the variable.

The data is replotted.

À y-axis

Á x-axis
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Compatible Sensors

The following sensors can be used with the Vernier DataQuest™ 
application.

• 25-g Accelerometer

• 30-Volt Voltage Probe

• 3-Axis Accelerometer

• Low-g Accelerometer

• CBR 2™ - Connects directly to handheld USB port 

• Go!Motion® - Connects directly to computer USB port 

• Extra Long Temperature Probe

• Stainless Steel Temperature Probe

• Surface Temperature Sensor

• Ammonium Ion-Selective Electrode

• Anemometer

• Barometer

• Blood Pressure Sensor

• C02 Gas Sensor

• Calcium Ion-Selective Electrode

• Charge Sensor 

• Chloride Ion-Selective Electrode 
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• Colorimeter

• Conductivity Probe

• High Current Sensor

• Current Probe

• Differential Voltage Probe

• Digital Radiation Monitor

• Dissolved Oxygen Sensor

• Dual-Range Force Sensor

• EasyTemp® - Connects directly to handheld USB port

• EKG Sensor

• Electrode Amplifier

• Flow Rate Sensor

• Force Plate

• Gas Pressure Sensor

• Go!Temp® - Connects directly to computer USB port

• Hand Dynamometer

• Hand-Grip Heart Rate Monitor

• Instrumentation Amplifier

• Light Sensor

• Magnetic Field Sensor

• Melt Station

• Microphone

• Nitrate Ion-Selective Electrode

• O2 Gas Sensor

• ORP Sensor

• pH Sensor 

• Relative Humidity Sensor

• Respiration Monitor Belt (Requires Gas Pressure Sensor)

• Rotary Motion Sensor

• Salinity Sensor 

• Soil Moisture Sensor
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• Sound Level Meter

• Spirometer

• Thermocouple

• TI-Light - Sold only with the CBL 2™

• TI-Temp - Sold only with the CBL 2™

• TI-Voltage - Sold only with the CBL 2™

• Tris-Compatible Flat pH Sensor

• Turbidity Sensor

• UVA Sensor

• UVB Sensor 

• Vernier Constant Current System

• Vernier Drop Counter

• Vernier Infrared Thermometer

• Vernier Motion Detector

• Vernier Photogate 

• Voltage Probe

• Wide-Range Temperature Probe
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Embedding Documents in Web Pages

Using the Export features in the TI-Nspire™ software along with the 
TI-Nspire™ Document Player, you can embed both TI-Nspire™ documents 
and PublishView™ documents within HTML pages. You can then publish 
the HTML documents as web pages or share them using email, datashare, 
or an online storage site.

By default, the embedded documents are displayed in the TI-Nspire™ 
Document Player when opened. Anyone can view and interact with the 
embedded TI-Nspire™ or PublishView™ documents within the 
TI-Nspire™ Document Player—even if you don’t own TI-Nspire™ 
software.

This document contains examples of HTML code needed to create and 
customize embedded documents in web pages. To download a zip file 
containing the HTML code examples in a format appropriate for copying 
and pasting into web pages:

• Go to http://education.ti.com/nspireplayer/html-examples.

• Download the Player_source_code_examples.zip file.

Using Embedded Web Pages
There are two ways to create embedded web pages:

• Use the Export functions in the TI-Nspire™ software to generate the 
code needed to embed a document in a web page.

• Create your own HTML code using a text editor or HTML editor. Code 
examples are shown in this document.

To use embedded web pages:

• You must be connected to the Internet to load the Document Player 
and view the embedded document.

• If publishing a document to the web, you will need to post the 
original TI-Nspire™ or PublishView™ documents online and update 
the HTML source code to reflect the URL of the online document. 

• You can embed documents that are already available online. For 
example, you can embed a document from the TI Activities Exchange 
website.

• You can embed documents in any container that supports HTML and 
Java™ applets. For example, you can embed documents in Learning 
Management Systems such as Moodle or Blackboard™.
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• You can embed a web page in a Microsoft® PowerPoint® 
presentation. This requires a third-party add-in for PowerPoint®. 
Some add-in utiltities are often available at no cost such as the add-
in available from Live Web (http://skp.mvps.org/liveweb.htm).

Viewing Embedded Web Pages
To view embedded TI-Nspire™ and PublishView™ documents, you must 
have:

• A web browser 

– Microsoft® Internet Explorer® 7.0 and above

– Mozilla® FireFox® 4.0 and above

– Google® Chrome® 5.0 and above

– Apple® Safari® 5 and above

• Java™ Version 6 Update 26 (version 1.6.0_26) or later

If you plan to view PublishView™ documents containing video files, you 
must have Adobe® Flash® Player 10.

Using TI-Nspire™ HTML Inline Frames
TI-Nspire™ and PublishView™ documents are embedded using an HTML 
Inline Frame or "iframe." You can embed your TI-Nspire™ or 
PublishView™ document by typing the iframe code into an HTML 
document. When you create an iframe using an HTML or text editor, the 
embedded iframe code might look like the code in the following 
example. When creating your own code for the iframe, you will need to 
know the web address of the embedded document and include this 
address in your code.

Example: Hard-coded iframe

Line breaks are not recognized in HTML source code. You may see the 
iframe code strung together on a single line when you view the source 
code in a text editor or HTML editor. To make the code easier to view, 
you can manually add line breaks or enable Word Wrap. The following 
example shows the code without line breaks.

<iframe 
src="http://education.ti.com/go/nspireplayer?nspirefile=http://my.site.
com/myfile.tns" 
width="700"  
height="500"  
scrolling="no"  
frameborder="0">
</iframe>
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Iframe Tags and Attributes
The HTML code is opened and closed with iframe tags: <iframe> and 
</iframe>. The iframe tags tell the web browser to open an embedded 
window on a web page. Within the iframe code, you’ll see attributes and 
attribute values that control the content and appearance of the frame. 
Attribute values are usually enclosed in quotation marks.

Using the Source (src) Attribute
In the iframe example, the first attribute is the source attribute indicated 
by the "src=" code. The value of this attribute is specific to TI-Nspire™ 
content. The value can be modified to define the location of the 
embedded document and the tools available within the embedded 
document.

The source attribute contains the Internet address (URL) of the Document 
Player. URLs available for use are:

• http://education.ti.com/go/nspireplayer
Use this URL to launch the latest version of TI-Nspire™ Document 
Player. Using this link automatically redirects to the latest version of 
Document Player.

• http://education.ti.com/html/nspireplayer/3.0.1/application/index.html
Use this direct URL to launch version 3.0.1.

• http://education.ti.com/html/nspireplayer/3.1.0/application/index.html
Use this direct URL to launch version 3.1.0.

• http://education.ti.com/html/nspireplayer/3.2.0/application/index.html
Use this direct URL to launch version 3.2.0 (the current version).

Note: Authors who want to preview the latest version of Document 
Player before allowing it on their web page should use the direct 
URL. When comfortable with the latest release, you can change the 
URL to the redirect URL to automatically get the latest release.

You can add parameters to the source attribute to control the 
appearance of the embedded TI-Nspire™ Document Player. These 
parameters are optional. For more information, see Customizing an 
Embedded TI-Nspire™ Document Player.

<iframe src="http://education.ti.com/go/nspireplayer? 
nspirefile=http://my.site.com/myfile.tns" width="700" height="500" 
scrolling="no" frameborder="0"></iframe>



666 Embedding Documents in Web Pages

Defining the nspirefile Parameter
The nspirefile parameter is always last in the line of code and specifies 
the URL or the file system address (path) of the document you are 
embedding. You may need to modify this parameter to enable sharing 
your embedded page with others.

The path of the document can be an absolute address or a relative 
address:

• Absolute address. Identifies a specific and unique location or path 
that is not defined by reference to any other address. When using an 
absolute address, you must specify the full URL. If you move the 
documents, the URL must be modified. 

• Relative address. Identifies a location in relation to another 
location. When using a relative address, the URL contains only the 
file name, which means your document must be in the same 
directory as the embedded web page. As long as your document and 
the HTML file containing the embedded document are in the same 
folder, the URL will find the document even if you move the folder. 
For more information, see Using Dynamically-Generated Iframes.

Using Other Iframe Attributes
Other iframe attributes that control the appearance of the iframe on the 
web page are width, height, scrolling, and frame border. The values for 
these attributes are standard and are not specific to TI-Nspire™ content. 
The following table contains a list of standard iframe attributes for your 
reference. For more information about iframe attributes, see 
http://www.w3schools.com/TAGS/tag_iframe.asp.

Attribute Description

align Specifies the alignment of an iframe according to 
surrounding elements. If used, values are left, right, 
top, middle, or bottom. The align attribute will 
work, but is no longer widely used. Styles are widely 
used today.

To use styles to center the Document Player on a 
page, surround the iframe with division (div) tags:
<div style="text-align:center">

[insert code for iframe]

</div>
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Using Dynamically-Generated Iframes
To use a relative address, you must use a dynamically-generated iframe. 
This code generates an HTML iframe when the page is loaded. The 
"nspirefile" parameter holds the location and file name of the 
TI-Nspire™ or PublishView™ document that is to be shown on the page. 
If the "nspirefile" parameter contains only the file name instead of the 
full URL, you must upload the TI-Nspire™ or PublishView™ document to 
your web server and ensure that it resides in the same folder as your blog 
or web page.

frameborder Specifies whether or not to display a border around 
an iframe. Values are:

1 = show border

0 = no border

height Specifies the height of the frame in pixels.

longdesc The URL that points to the page containing a long 
description of the content in the iframe.

marginheight Defines the top and bottom margins in pixels.

marginwidth Defines the left and right margins in pixels.

name The name of the iframe.

scrolling Specifies whether or not to show scrollbars in an 
iframe. Values are yes, no, or auto.

src The URL of the document contained in the iframe.

width Defines the width of the iframe in pixels.

Attribute Description
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Line breaks are not recognized in HTML source code. You may see the 
iframe code strung together on a single line when you view the source 
code in a text editor or HTML editor. To make the code easier to view, 
you can manually add line breaks or enable Word Wrap. The following 
example shows the code without line breaks.

Using the TI-Nspire™ Document Player
The Document Player launches automatically when you open an HTML 
document that contains an embedded TI-Nspire™ or PublishView™ 
document. The Document Player plays directly from the Internet and 
does not require any other Texas Instruments handhelds or software.

Note: If you are opening the Document Player for the first time on your 
computer, you are asked to accept the license agreement. This is only 
needed once for a specific computer.

Exporting to a Web Page
In the TI-Nspire™ software, use the export web page option to create a 
stand-alone web page that can be used as is or that can be modified.

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></
script>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
    // IFRAME attributes.
    {   
        src : 'http://education.ti.com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters.
    {  
        nspirefile : 'myfile.tns'
    }
);
</script>

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></
script>
<script type="text/javascript"> 
tiDeployPlayer.tiCreateIframePlayer({src : 
'http://education.ti.com/go/nspireplayer', width : '640', height : 
'480', scrolling : 'no', frameborder : '0' },{ nspirefile : 
'myfile.tns'});</script>
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Note: You can embed a TI-Nspire™ document in a web page that can be 
opened in Document Player using TI-Nspire software. The ability to 
export a web page is not part of the Document Player.

1. Open the TI-Nspire™ document or PublishView™ document you 
want to embed in a web page.

2. Click File > Export Web Page.

The Web Page Text dialog box opens.

3. Type the title of the web page in the Web page title field. The title 
will centered at the top of the web page. This is also the default 
name for the HTML file.

4. If you want to include additional text above the iframe, type the text 
in the Text above the embedded window field.

To include text below the iframe, type the text in the Text below the 
embedded window field.

5. Click Export.

The Save Web Page dialog box opens.
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6. In the Save in field, navigate to the folder where you want to save 
the file. 

7. In the File Name field, type the name of the file if different than the 
default name.

8. Do not change the file type. By default, the file type is HTML 
Document. 

9. Click Save.

The HTML file is saved to your computer. The embedded web page 
automatically opens in your default web browser. If you move your 
exported HTML file to another folder, you must also move the 
associated TI-Nspire™ or PublishView™ document.

When the TI-Nspire™ document or PublishView™ document is 
exported to a web page, a copy is made of the document. This copy 
is saved with the same names as the exported HTML file and is saved 
in the folder where you save the HTML file.
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Exploring the Web Page

À Browser window title bar. The Texas Instruments default title is 
shown here. 

Á The absolute URL or file system path identifying where the HTML 
document is located.

Â Web browser menu bars and toolbars.

Ã Title of the embedded web page as specified in the Web page title 
field. 

Ä The text as specified in the Text above the embedded window 
field. Text that appears below the frame is specified in the Text 
below the embedded window field.

Å The iframe containing the embedded document.
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Customizing an Embedded TI-Nspire™ Document 
Player
The following example shows the iframe code needed to embed a 
document that will be stored on the Texas Instruments Activities 
Exchange or on the education.ti.com website.

—or—

Æ The Document Player tool bar. These tools enable you to interact 
with the document within the Document Player.

<iframe src="http://education.ti.com/go/nspireplayer? lock_toolbar=yes& 
openDoc=no&nspirefile=http://education.ti.com/xchange/US/Math/Algeb
raI/11340/From_Expressions_to_Equations.tns" width="700"  
height="500"  scrolling="no"  frameborder="0"></iframe>

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
    tiDeployPlayer.tiCreateIframePlayer(
        // IFRAME attributes.
        {   
    src : 'http://education.ti.com/go/nspireplayer', 
    width : '360',  
    height : '290',  
    scrolling : 'no',  
    frameborder : '0'  
        }, 

        // TI-Nspire(tm) Document Player parameters. 
        {  
            nspirefile : 
'http://education.ti.com/xchange/US/Math/AlgebraI/11340/ 
From_Expressions_to_Equations.tns ',
            lock_toolbar:'yes',
            openDoc:'no'
        }
    );
</script>
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Notice the parameters lock_toolbar=yes and openDoc=no. These settings 
were used to customize the Document Player so that it launches with the 
toolbar locked in the expanded (visible) state and with the Open icon 
hidden. The following table contains a list of Document Player 
parameters. When adding parameters to the iframe code, be sure to 
separate each parameter with an ampersand character (&).

Attribute Description

toolbar Determines if the toolbar is expanded or collapsed 
when the application is opened. If the parameter is 
not specified, the toolbar opens in the expanded 
state. To collapse the toolbar when the application is 
opened, set this parameter to "No."

lock_toolbar When this parameter is set to "No," the toolbar hide 
arrow is removed and the state of the toolbar is 
locked. If this parameter is not specified, the toolbar 
arrow is shown and the toolbar is unlocked. 

openDoc Controls the visibility of the Open icon in the toolbar. 
To hide the Open icon, set this parameter to "No." If 
not specified, the Open icon is shown. The 
nspirefile parameter must also be set for this 
setting to be accepted.

save_local Controls the visibility of the Save Local Copy icon in 
the toolbar. To hide the Save Local Copy icon, set this 
parameter to "No." If not specified, the Save Local 
Copy icon is shown. 

save_online Controls the visibility of the Save Online icon in the 
toolbar. To hide the Save Online icon, set this 
parameter to "No." If not specified, the Save Online 
icon is shown. 

cardId Limits the visibility of a document to a single page in 
the embedded window. The value of the cardId is 
the ordinal page number of the page within the 
TI-Nspire™ document being embedded. The 
nspirefile parameter must also be set for this 
setting to be accepted.

Note: This parameter does not apply to 
PublishView™ documents.
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locale By default, the language setting for Document Player 
is set by the operating system. The locale attribute 
enables you to manually change the preferred 
language. Values are:

da = Danish

de = German

en = English

es = Spanish

fi = Finnish

fr = French

gb = Great Britain (United Kingdom)

it = Italian

nl = Netherlands (Dutch)

no = Norwegian

pt = Portuguese

sv = Swedish

zh_CN = Simplified Chinese

zh_TW = Traditional Chinese

nspirefile Identifies the storage location of the 
TI-Nspire™ document or PublishView™ document to 
be embedded. The value can be the absolute URL, 
the file system path, or the relative address. 

If using the relative address, you can use only the 
document file name (for example, "myfile.tns"). The 
Document Player assumes the document is in the 
same directory as the exported HTML document, 
which makes the exported web page portable. This 
means you can put the HTML document and the 
embedded document in the same folder, and then 
copy that folder anywhere and the page will still 
work with no changes to the source code.

This is useful when you want to share files with 
someone using email but don’t want to post the file 
online.

Attribute Description
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Using Export to Generate HTML Source Code
The Export options in all versions of the TI-Nspire™ software enable you 
to easily and automatically generate the required HTML code and 
iframes needed to embed a document in an iframe. The code generated 
when using Export produces the iframe each time the web page is 
loaded using JavaScript. This is more flexible and robust than the hard-
coded iframe. For example, using JavaScript enables you to use relative 
addressing to refer to your embedded documents. With relative 
addressing, the web page will find and display your document as long as 
the document is stored in the same folder as the HTML file. This is 
especially helpful when sharing offline web pages.

Export options
TI-Nspire™ software provides two options for exporting documents in 
HTML format:

• Export Web Page
Use this option to produce a complete HTML document containing 
an embedded window for your TI-Nspire™ or PublishView™ 
document and supplementary text. This stand-alone web page can 
be used without any changes or can be embellished using third-party 
software.

• Export HTML to Clipboard
Use this option to produce a code snippet that can be pasted into 
existing web pages or blogs. A code snippet contains a few lines of 
HTML code that embeds a window into an existing page.

Both the full HTML document and the code snippet can be easily edited 
using any text editor or HTML editor. Editing the HTML document 
enables you to:

• Change the source location of the embedded TI-Nspire™ or 
PublishView™ document, which may be required to publish or share 
the HTML document.

• Modify the HTML to open the TI-Nspire™ or PublishView™ 
document in a dedicated browser window.

• Change the appearance of the embedded or dedicated window 
containing the TI-Nspire™ or PublishView™ document.

Viewing the Source Code
After the web page is created, you can view and edit the source code. 
The source code can be modified using any text editor or third-party 
HTML editor. To view the source code:

8 From your web browser’s menu bar, click View > Source.
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Note: The option for viewing source code may differ depending on 
your default browser.

—or—

8 Open a text editor such as Notepad, and then open the HTML file 
within the text editor.

The source code is displayed. 

Note: In some browsers, viewing the source code opens a text editor. 

The following example shows source code that contains comments 
to help anyone unfamiliar with HTML to understand and successfully 
modify the code. 
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<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 
Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>

<!--
Thanks for creating a web page containing a TI-Nspire(tm) or 
PublishView(tm) document. This page can easily be modified to fit your 
needs.  If you are not familiar with HTML, here are some basics to get you 
started: 

HTML DOCUMENTS
HTML documents are text documents that define a web page. 
The text itself is known as source code.   You are viewing source code now.
HTML documents become web pages when opened in a browser.
HTML documents have a Header (usually hidden information) and a Body 
(displayed content).
TAGS
The appearance of your page is controlled by "tags".
Tags are surrounded by angle brackets <> .
Some elements require a start tag <> and an end tag </> .
LINES
Lines in the source file mean nothing when displayed as a web page.
Instead, tags are used to control lines on the page.
<br> creates a line break, just like hitting Enter key on your keyboard.
<p> creates a new paragraph.  The browser will typically put empty space 
around this tag.
COMMENTS
Comments are used to explain the source file and are not displayed on the 
web page.
<!-- begin a comment.
- -> end a comment.

See http://www.w3.org/TR/REC-html40/struct/global html for more 
information on HTML.

That's it!
Your page starts below.
-->
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<head>
<!-- The line below tells the browser the Title of your Web Page. This may 
be displayed in title bar of your browser.  -->
<title>TI-Nspire&trade; Interactive Web Page</title>

<!-- The lines below help browsers and search engines quickly get 
information about your page. These are not displayed on the page. -->
<meta name="author" content="Your Name">
<meta name="keywords" content="Your Keywords">
<meta name="description" content="Your Page Description">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="keywords" content="&quot;ti-nspire document 
player&quot;,&quot;nspire document player&quot;,&quot;ti-
nspire&trade; document player&quot;,texas instruments, 
education.ti.com, ti-nspire, ti nspire, nspire, tinspire, nspire cas, ti-nspire 
cas, computer, software, publishview, publish view, publishview(tm), tns 
file, tnsp file, document player, ti-nspire player, nspire player, player, 
interactive math, mathematics, cas, student understanding, interactive 
classroom, educator's classroom computer">
</head>

<body bgcolor="#FFFFFF" TEXT="#000000">
<!--  Note the background color and text color are included with the "body" tag.  You can find out more 
about color codes here:  http://en.wikipedia.org/wiki/Web_colors -->

<!--The lines below create a high level header centered on the page.  It is very common to show the page 
title in this way. -->
<center>
<font size="5"><b>INSERT TITLE FROM DIALOG</b></font>  <br>
</center>

<!--The line below creates a visible line across the page. It automatically adjusts to a % of the window 
width.-->
<hr width="80%" align="center">

<!--Remove comment tags from the line below to create a bold section title.  .-->
<!--  <font size="4"><b>Instructions</b></font> <br>  -->

<!--The text below will appear above your embedded TI-Nspire(tm) or PublishView(tm) document. You 
might use this space for instructions for the embedded activity.  Spacing and returns are ignored.  Word 
wrapping will happen automatically. -->
<p>
THIS AREA CONTAINS "TEXT ABOVE"  FROM WEB PAGE TEXT DIALOG
</p>

<!--The section below embeds the TI-Nspire document in your web page.-->
<p>
THIS AREA CONTAINS THE CODE SNIPPET THAT EMBEDS THE TI-NSPIRE(TM) OR 
PUBLISHVIEW(TM) DOCUMENT
</p>
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<!--The text below will appear below your embedded TI-Nspire(tm) or PublishView(tm) document. You 
might use this space for guiding questions related to the activity. Spacing and returns are ignored. Word 
wrapping will happen automatically. -->
<p>
THIS AREA CONTAINS "TEXT BELOW"  FROM WEB PAGE TEXT DIALOG.
</p>

<!--The line below creates a visible line across the page. It automatically adjusts to a % of the window 
width.-->
<hr width="80%" align="center">

<!--
Insert related links. 
Insert links using the examples below as a guide.  Type or paste the URL 
between quotation marks.  Type the link text (visible on the page) after the 
URL bracket and before the ending tag '<a/>'. Note you can use comment 
tags to hide links without deleting them from the source code.
-->
<p>
<font size="1">
<a 
href="http://education.ti.com/educationportal/preference/selectCountry.do
">Texas Instruments Education Technology<a/> <br>
<!--  <a 
href="http://education.ti.com/calculators/timathnspired/">MathNspired.c
om<a/> <br> -->
</font>
</p>

<!--
Insert an email link.
Remove comment tags from the line below, then type your email after 
"mailto:" 
-->
<!--  <a href="mailto:username@yourserver.com">E-mail the 
author</a>   -->

<!-- 
Insert an image.
Copy and paste the line below into the body of your document where you 
want the image to appear.  Remove the comment tags, then replace the old 
image source URL or file name a new one.  You might also want to provide 
alternate text (alt=) in case the image file is not available.
NOTE:  If your image is not on the web, when you publish your page, you 
will need to upload your image file along with your html file.
-->
<!--  <img src="type_document_name.here" alt="This text appears if the 
image is not available"  />   -->

</body>
</html>
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Exporting HTML to the Clipboard
Use the HTML to Clipboard feature to create a code snippet that can be 
pasted into a blog, existing web page, or other HTML-compatible 
container that supports Java™ applets. A snippet is not a full web page 
because the source code does not contain the identifying information, 
headers, and body section needed to publish a stand-alone web page. 

1. Open the TI-Nspire™ document or PublishView™ document that you 
want to export.

2. Click File > Export > HTML to Clipboard.

The code is copied to the Clipboard. 

3. Paste the snippet into a blog or other existing web page.

Editing the Code Snippet
To preview or edit the snippet before pasting it to a web page or blog, 
paste the code into a text editor.

1. Open a new document in any text editor such Notepad (Windows®) 
or TextEdit (Mac®).

2. Paste the code into the text editor. The following code is an example 
of how the snippet may look when you copy it and open it in a text 
editor.

3. Edit the code snippet if needed.

4. Save the file using the .html file extension. You can use any name 
you choose to name the file; however, you must ensure the file 
extension is .html.

5. Open the file using your Internet browser (File > Open).

<!-- START: TI-Nspire(TM) Document Player -->
<!-- 
Paste the code below into the body of an existing web page or blog  The code will generate an HTML iframe when the page 
is loaded   Note the 'nspirefile' parameter holds the location and file name of the TI-Nspire(TM) or PublishView(TM) 
document that is to be shown on the page   If 'nspirefile' contains only a file name instead of a full URL, be sure to upload 
the TI-Nspire or PublishView document to your web server and place it in the same folder as your blog or web page  Also, 
be sure the 'nspirefile' string contains no backslash characters '\'   Use forward slash characters '/' instead
-->
<script type="text/javascript" src="http://education ti com/html/nspireplayer/js/ticreateiframe js"></script>
<script type="text/javascript">
tiDeployPlayer tiCreateIframePlayer(
    // IFRAME attributes
    {   
        src : 'http://education ti com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters
    {  
        nspirefile : 'myfile tns'
    }
);
</script>
<!-- END: TI-Nspire(TM) Document Player -->
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The embedded window is displayed in the web browser window.

Storing and Sharing Documents
Once you create an HTML document, you will want to share it with 
colleagues and students. You have the following options for sharing 
embedded TI-Nspire™ documents and PublishView™ documents:

• Publish your HTML document as a web page on the Internet.

• Attach your HTML document to an email.

• Save your HTML document on a file share on your school’s intranet.

• Save your HTML file to a flash drive.

• Paste a code snippet into an existing web page, blog, online course 
page, or other HTML-compatible container.

Storing Documents to be Shared Online
When you create an HTML page using the TI-Nspire™ export functions, a 
window is embedded in the web page. The documents and the 
Document Player themselves are not embedded in the HTML page. The 
HTML code loads the document and the Document Player from where 
ever they are stored when the HTML page is opened in a browser. This 
means:

• You must be connected to the Internet to view shared documents 
and load the Document Player.

• The shared documents must be stored in a place where all viewers 
can access them.

The Export feature produces HTML code that contains a relative address 
to the file being exported. The URL contains only the file name, which 
means your document must be in the same directory as the embedded 
web page. As long as your document and the HTML file containing the 
embedded document are in the same folder, the URL will find the 
document even if you move the folder.
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Modifying the nspirefile Parameter
If you have placed your file in the shared location, change the 
nspirefile parameter to reflect the new URL or path where the 
document is stored. The URL or path to a shared document is typically 
easy to find. Often, right-clicking the URL or path name copies a shortcut 
to the document, which you can paste into the iframe.

1. Place your document on a shared location. For example, a shared 
network drive or website.

2. Copy the path or URL.

3. Open the HTML page in a text editor to view and modify the code.

4. Replace the nspirefile parameter by pasting the new URL or path 
over the existing URL or path name.

5. Save the updated HTML file.

If your shared document is located on a shared network drive, the 
updated iframe might look like this:

—or—

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
    // IFRAME attributes.
    {   
        src : 'http://education.ti.com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters.
    {  
        nspirefile : 'myfile.tns'
    }
);
</script>

<iframe 
src="http://education.ti.com/go/nspireplayer?nspirefile=file:/P:/MathDepa
rtment/Algebra/Lessons/myfile.tns" width="360"  height="290"  
scrolling="no"  frameborder="0"></iframe>
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If you uploaded your document to a location on the Internet, the iframe 
might look like this:

—or—

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
    // IFRAME attributes.
    {   
        src : 'http://education.ti.com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters.
    {  
        nspirefile : 'file:/P:/MathDepartment/Algebra/Lessons/myfile.tns'
    }
);
</script>

<iframe src="http://education.ti.com/go/nspireplayer?nspirefile= 
http://dl.dropbox.com/u/10849702/myfile.tns" width="360"  height="290"  
scrolling="no"  frameborder="0"></iframe>
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After you have placed your document in a shared location and modified 
the iframe, opening the HTML file automatically launches the Document 
Player and displays your embedded document in your default web 
browser. Anyone accessing the document must be connected to the 
Internet and have access to the shared file to view it.

Storing and Sharing Files Offline
You can also share your documents with others to be opened and viewed 
offline. You can send the HTML file to others as an email attachment or 
on a flash drive. The recipient can save the file on their hard drive, and 
then open the document in their web browser or text editor.

Launching a Dedicated TI-Nspire™ Document 
Player Window
You can use JavaScript to add a link to your web page that will launch 
the Document Player in a dedicated window. The example code provided 
produces a link that launches a document from the Activities Exchange 
on education.ti.com in a dedicated window.

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
    // IFRAME attributes.
    {   
        src : 'http://education.ti.com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters.
    {  
        nspirefile : 'http://dl.dropbox.com/u/10849702/myfile.tns'
    }
);
</script>
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The first parameter after "window.open" is the same as the source (src) 
attribute in the embedded iframe. The other attributes in the script 
control the appearance of the browser components surrounding the 
dedicated window.

Opening Documents in a Linked Frame
You can create a web page that contains links to TI-Nspire™ and 
PublishView™ documents that open in a Document Player window 
embedded on the same web page. Creating this web page lets you 
quickly open documents from links without reloading Document Player. 
This saves time and provides a way to create a "one page" destination 
containing links to multiple documents. When you click a link, the 
document opens in the embedded Document Player window. Clicking 
another link on the page opens the document in the same Document 
Player window. The links and the Document Player window must be on 
the same HTML page. A simple web page might look like the following 
illustration.

<a href="javascript: void(0)" 
onclick="window.open('http://education.ti.com/go/nspireplayer?nspirefile
=http://education.ti.com/xchange/US/Math/AlgebraI/11340/From_Expres
sions_to_Equations.tns','_blank','width=800, \height=600, \directories=no, 
\location=no, \menubar=no, \resizable=yes, \scrollbars=no, \status=no, 
\toolbar=no'); return false;"> Click here </a>

À Links to documents

Á Embedded Document Player window
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Embedding a Linked Frame in a Web Page
You can use TI-provided code to create a web page that has links to 
documents and an embedded Document Player window. To create the 
web page, you must:

• Add the header lines to the header section

• Create links

• Create the Document Player window

You can use the File > Export feature to quickly generate the code 
needed to create a web page. When the web page is created, modify the 
frame using HTML parameters and the following Java script files.

Head Section
Place the following code into the head section.

Link Example
Use the following code to create links to either .tns or .tnsp files.

Creating the Document Player Window
Use the following code to create a window for displaying the applet that 
enables opening the Document Player when a user clicks a link.

<script 
src="http://education.ti.com/html/nspireplayer/3.2.0/application/js/strings.
js"></script> <script 
src="http://education.ti.com/html/nspireplayer/3.2.0/application/js/webns
pireapi.js"></script> <script 
src="http://www.java.com/js/deployJava.js"></script> 

Syntax

<a href="javascript:openDocument('YOUR_APPLET_ID', 
'PLAYER_DOCUMENT_URL', 'CARD_ID')"> MY LINK </a> 
Where: 
- YOUR_APPLET_ID is required 
- PLAYER_DOCUMENT_URL is required 
- CARD_ID is optional 

Example

<a href="javascript:openDocument('player2', 
'http://education.ti.com/xchange/US/Math/Geometry/13176/Secants_Tan
gents_and_Arcs.tns', '2')"> MY LINK </a> 

Syntax
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<script type="text/javascript">
tiCreatePlayer(
// attributes (REQUIRED)
{
id: 'YOUR_APPLET_ID', // REQUIRED
codebase: 'URL_WHERE_THE_PLAYER_IS_HOSTED', //REQUIRED
name: 'YOUR_APPLET_NAME',
},
// parameters (OPTIONAL)
{
nspirefile : 'PLAYER_DOCUMENT_URL', // This will be opened in the 
beginning (Relative addressing supported)
openDoc : 'yes/no', // Hide/show open document button
cardId : '1-n', // This will open a document on the specified card, 
parameter must be numeric
save_online : 'yes/no', // Hide/show save online button
save_local : 'yes/no' // Hide/show save a local copy button lock_toolbar : 
'yes/no' // Keep the toolbar as initialized
toolbar : 'yes/no' // Set toolbar to be shown or not when Player is 
initialized 
locale: 'da/de/en/es/fi/fr/it/nl/nl_BE/no/pt/sv/zh_CN/zh_TW' // these are 
the supported languages 
} 
);
</script> 

Example

<script type="text/javascript"> 
tiCreatePlayer(
// attributes (REQUIRED)
{ id: 'player2', // REQUIRED
codebase:'http://education.ti.com/html/nspireplayer/3.2.0/application/', 
//REQUIRED
name: 'myplayer'
},
// parameters (OPTIONAL)
{ nspirefile : 'documents/examples/02_Functions.tns',
openDoc : 'yes',
save_online : 'no',
save_local : 'no',
lock_toolbar : 'no',
toolbar : 'yes',
locale: 'fr'
}
);
</script> 
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Libraries

What is a Library?
A library is a TI-Nspire™ document that contains a collection of variables, 
functions, and/or programs that have been defined as library objects. 

Unlike ordinary variables, functions, and programs, which can be used 
only within a single problem (the problem in which they are defined), 
library objects are accessible from any document. You can even create 
public library objects that appear in the TI-Nspire™ Catalog.

For example, suppose you have created library document matrix 
containing public library function diagwithtrace() and a private library 
function errmsg(). 

Function diagwithtrace() displays the diagonal of a square matrix and 
calculates the trace of the matrix. If its input is not a square matrix, the 
function calls errmsg(), which should then return an appropriate error 
string.

You could then use the following syntax to display the diagonal and 
calculate the trace of matrix m defined in the current problem: 

matrix\diagwithtrace(m)
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Creating Libraries and Library Objects
A document is regarded as a library when it is saved or copied to the 
designated library folder. The default location is:

• Windows®: My Documents\TI-Nspire\MyLib.

• Mac®: Documents/TI-Nspire/MyLib.

• Handheld: MyLib

If the folder has been inadvertently deleted, you must create it before 
attempting to use libraries.

You can define library objects using either the Program Editor or the 
Calculator application. Library objects must be defined with a Define 
command and must reside in the first problem of a library document.

Note: If you use the Program Editor to define a library function or 
program, you must store the object and also save the document. Saving 
the document does not automatically store the object. For more 
information, see Programming.

Naming restrictions apply to library documents and library objects.

• A library document name must be a valid variable name between 1 
and 16 characters long, and it must not contain a period or begin 
with an underscore.

• A library object name must be a valid variable name between 1 and 
15 characters long. It must not contain a period and must not begin 
with an underscore.

Private and Public Library Objects
When you define a library object, you designate it as private (LibPriv) or 
public (LibPub).

Define a=5

a is not a library object.

Define LibPriv b={1,2,3}

b is a private library object.

Define LibPub func1(x)=x^2 - 1

func1 is a public library object.
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A Private library object does not appear in the Catalog, but you can 
access it by typing its name. Private objects serve well as building blocks 
that perform basic, low-level tasks. Typically, private library objects are 
called upon by the public functions and programs.

A Public library object appears in the Catalog’s library tab after you 
refresh the libraries. You can access a public library object through the 
Catalog or by typing its name.

Mac® only: In version 1.4 of the software, a library document name 
cannot contain extended characters, such as Ö, á, or ñ.

Note: In library programs and functions defined as public, a comment 
line (©) immediately following the Prgm or Func line is automatically 
displayed as help in the Catalog. You could, for example, show a syntax 
reminder there.

Using Short and Long Names
Anytime you are in the same problem where an object is defined, you 
can access it by entering its short name (the name given in the object’s 
Define command). This is the case for all defined objects, including 
private, public, and non-library objects.

You can access a library object from any document by typing the object’s 
long name. A long name consists of the name of the object’s library 
document followed by a backslash “\” followed by the name of the 
object. For example, the long name of the object defined as func1 in the 
library document lib1 is lib1\func1. To type the “\” character on the 
handheld, press g p.

Note: If you cannot remember the exact name or the order of arguments 
required for a private library object, you can open the library document 
or use the Program Editor to view the object. You also can use 
getVarInfo to view a list of objects in a library.

Using Library Objects
Before using a library variable, function, or program, make sure that 
these steps have been followed:

• The object has been defined with the Define command, and the 
command specifies either the LibPriv or LibPub attribute.

• The object resides in the first problem of a library document. The 
document must reside in the designated library folder and must 
meet the naming requirements.

• If you defined the object using the Program Editor, it has been stored 
using Check Syntax & Store from the Program Editor menu.
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• The libraries have been refreshed.

Refreshing the Libraries
8 Refresh libraries to make the library objects available to your 

documents.

– From the Tools menu, click Refresh Libraries.

Handheld: Press / b and click Refresh Libraries.

Using a Public Library Object
1. Refresh the libraries.

2. Open the TI-Nspire™ application in which you want to use the 
variable, function or program.

Note: All applications can evaluate functions, but only the 
Calculator and Notes applications can run programs.

3. Open the Catalog and use the library tab to find and insert the 
object.

4. If arguments are required, type them inside the parentheses.

Using a Private Library Object
1. Refresh the libraries.

2. Open the TI-Nspire™ application in which you want to use the 
variable, function, or program.

Note: All applications can evaluate functions, but only the 
Calculator and Notes applications can run programs.

3. Type the name of the object, such as lib1\func1(). 

In case of a function or program, always follow the name with 
parentheses. To type the “\” character on the handheld, press 
g p.

4. If arguments are required, type them inside the parentheses.

Creating Shortcuts to Library Objects
You can make the objects in a library more easily accessible by using 
libShortcut() to create shortcuts to them. This creates a variable group in 
the current problem that contains references to all the objects in the 
specified library document. You can choose to include or exclude the 
private library objects.
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For example, suppose the library document linalg contains functions 
named clearmat, cofactor, gausstep, help, inversestep, kernelbasis, rank, 
and simultstep. Executing libShortcut(“linalg”,“la”) would create a 
variable group containing the following members:

la.clearmat
la.cofactor
la.gausstep
la.help
la.inversestep
la.kernelbasis
la.rank
la.simultstep

You can refer to those library objects from within the current problem by 
typing their variable names or by selecting them from the Variables 
menu.

For more details about using libShortcut(), see the Reference Guide.

Included Libraries
To help you get started with libraries, the TI-Nspire™ Software 
installation includes a library document with useful Linear Algebra 
functions. The library is named linalg or linalgCAS and is installed in the 
designated library folder.

Note: Updating the handheld’s operating system or reinstalling the 
computer software places all included libraries in the default folder. If 
you have edited an object in an included library or replaced an included 
library with your own document of the same name, updating or 
reinstalling will overwrite your changes. This could also happen after 
batteries are replaced or the handheld system is reset.

Restoring an Included Library
If you inadvertently delete or overwrite an included library, you can 
restore it from the installation DVD.

1. Open the DVD, and navigate to the libs folder.

2. Identify the library file to restore, such as linalg.tns or linalgCAS.tns 
for the linear algebra library.

3. Copy the file.

– Windows®: Copy the file to your designated library folder. The 
default location is My Documents\TI-Nspire\MyLib.
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– Mac®: Copy the file to your designated library folder. The 
default location is Documents/TI-Nspire/MyLib.

– Handheld: Connect the handheld to your computer, open the 
TI-Nspire™ software, and copy the library file to the handheld’s 
MyLib folder.

4. Activate the new library objects.

– From the TI-Nspire™ Software Tools menu, click Refresh 
Libraries.

Handheld: Press / b, and click Refresh Libraries.
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Programming

You can create user-defined functions or programs by typing definition 
statements on the Calculator entry line or by using the Program Editor. 
The Program Editor offers some advantages, and it is covered in this 
section. For more information, see Calculator.

Overview of the Program Editor
The Program Editor helps you define, edit, and manage user-defined 
functions and programs. 

• The editor has programming templates and dialog boxes to help you 
define functions and programs using correct syntax.

• The editor lets you enter multiple-line programming statements 
without requiring a special key sequence to add each line.

• You can easily create private and public library objects (variables, 
functions, and programs). For more information, see Libraries.

• The editor is accessible from the main Insert menu as well as from 
the Calculator’s Functions & Programs menu.

À Program Editor menu – This menu is available anytime you are in 
the Program Editor work area using the Normal view mode. On the 
handheld, press b to display the menu.

Á Program Editor work area

Â Status line shows line number information and the name of the 
function or program being edited. An asterisk (*) indicates that this 
function is “dirty,” which means that it has changed since the last 
time its syntax has been checked and it has been stored.
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Defining a Program or Function

Starting a new Program Editor
1. To start the editor from a Calculator page,

– From the Insert menu, click Program Editor, and click New.

Handheld: Press b 9 1 1.

2. To start the editor when not on a Calculator page,

– From the Insert menu, click Program Editor, and click New.

Handheld: Press / b 4 8 1.

3. Type a name for the function or program you are defining.

4. Select the Type (Program or Function).

5. Set the Library Access:

– To use the function or program only from the current document 
and problem, select None.

– To make the function or program accessible from any document 
but not visible in the Catalog, select LibPriv.

– To make the function or program accessible from any document 
and also visible in the Catalog, select LibPub (Show in Catalog). 
For more information, see Libraries.

6. Click OK.

A new instance of the Program Editor opens, with a template 
matching the selections you made.
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Entering Lines into a Function or Program
The Program Editor does not execute the commands or evaluate 
expressions as you type them. They are executed only when you evaluate 
the function or run the program.

1. If your function or program will require the user to supply 
arguments, type parameter names in the parentheses that follow the 
name. Separate parameters with a comma.

2. Between the Func and EndFunc (or Prgm and EndPrgm) lines, type 
the lines of statements that make up your function or program.

– You can either type the names of functions and commands or 
insert them from the Catalog. 

– A line can be longer than the width of the screen; if so, you 
might have to scroll to view the entire statement.

– After typing each line, press ·. This inserts a new blank line 
and lets you continue entering another line. 

– Use the ¡, ¢, £, and ¤ arrow keys to scroll through the function 
or program for entering or editing commands.
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Inserting Comments
A comment symbol (©) lets you enter a remark. Comments can be useful 
to someone viewing or editing the program. Comments are not 
displayed when the program runs, and they have no effect on program 
flow.

To insert a comment:
1. Position the cursor at the end of the line in which you want to insert 

a comment.

2. From the Actions menu, click Insert Comment.

3. Type the text of the comment after the © symbol.

Checking Syntax
The Program Editor lets you check the function or program for correct 
syntax.

8 From the Check Syntax & Store menu, click Check Syntax.

If the syntax checker finds any syntax errors, it displays an error 
message and tries to position the cursor near the first error so you 
can correct it.

Define LibPub volcyl(ht,r) =
Prgm
©volcyl(ht,r) => volume of cylinder À 

Disp “Volume =”, approx(p ¦ r2 ¦ ht)
©This is another comment.
EndPrgm

À Comment showing required syntax. Because this library object is 
public and this comment is the first line in a Func or Prgm block, the 
comment is displayed in the Catalog as help. For more information, 
see Libraries.
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Storing the Function or Program
You must store your function or program to make it accessible. The 
Program Editor automatically checks the syntax before storing.

An asterisk (*) is displayed in the upper left corner of the Program Editor 
to indicate that the function or program has not been stored.

8 From the Check Syntax & Store menu, click Check Syntax & Store.

If the syntax checker finds any syntax errors, it displays an error 
message and tries to position the cursor near the first error.

If no syntax errors are found, the message “Stored successfully“is 
displayed in the status line at the top of the Program Editor.

Note: If the function or program is defined as a library object, you must 
also save the document in the designated library folder and refresh 
libraries to make the object accessible to other documents. For more 
information, see Libraries.

Viewing a Program or Function
1. From the Actions menu, click View.

2. If the function or program is a library object, select its library from 
the Location list.

3. Select the function or program name from the Name list.

The function or program is displayed in a viewer.
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4. Use the arrow keys to view the function or program.

5. If you want to edit the program, click Edit.

Note: The Edit selection is available only for functions and programs 
defined in the current problem. To edit a library object, you must 
first open its library document.

Opening a Function or Program for Editing
You can open a function or program from the current problem only.

Note: You cannot modify a locked program or function. To unlock the 
object, go to a Calculator page and use the unLock command.

1. Display the list of available functions and programs.

– From the Actions menu, click Open.

2. Click the item to open.

Importing a Program from a Library
You can import a function or program defined as a library object into a 
Program Editor within the current problem. The imported copy is not 
locked, even if the original is locked.

1. From the Actions menu, click Import.
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2. Select the Library Name.

3. Select the Name of the object.

4. If you want the imported object to have a different name, type the 
name under Import As.

Creating a Copy of a Function or Program
When creating a new function or program, you might find it easier to 
start with a copy of the current one. The copy that you create is not 
locked, even if the original is locked.

1. From the Actions menu, click Create Copy.

2. Type a new name, or click OK to accept the proposed name.

3. If you want to change the access level, select Library Access, and 
select a new level.

Renaming a Program or Function
You can rename and (optionally) change the access level of the current 
function or program.

1. From the Actions menu, click Rename.

2. Type a new name, or click OK to accept the proposed name.
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3. If you want to change the access level, select Library Access, and 
select a new level.

Changing the Library Access Level
1. From the Actions menu, click Change Library Access.

2. Select the Library Access:

– To use the function or program only from the current Calculator 
problem, select None.

– To make function or program accessible from any document but 
not visible in the Catalog, select LibPriv.

– To make the function or program accessible from any document 
and also visible in the Catalog, select LibPub.

Finding Text
1. From the Actions menu, click Find.

2. Type the text that you want to find, and click OK.

– If the text is found, it is highlighted in the program.

– If the text is not found, a notification message is displayed.

Finding and Replacing Text
1. From the Actions menu, click Find and Replace.
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2. Type the text that you want to find.

3. Type the replacement text.

4. Click Replace to replace the first occurrence after the cursor position.

—or—

Click Replace All to replace every occurrence.

Note: If the text is found in a math template, a message is displayed 
to warn you that your replacement text will replace the whole 
template—not just the found text.

Closing the Current Function or Program
8 From the Actions menu, click Close.

If the function or program has unstored changes, you are prompted 
to check syntax and store before closing.

Running Programs and Evaluating Functions
After defining and storing a function or program, you can use it from an 
application. All the applications can evaluate functions, but only the 
Calculator and Notes applications can run programs.

The program statements are executed in sequential order (although 
some commands alter the program flow). The output, if any, is displayed 
in the application’s work area.

• Program execution continues until it reaches the last statement or a 
Stop command.

• Function execution continues until it reaches a Return command.

• To stop a program or function manually, 

– Windows®: Hold down the F12 key and press Enter repeatedly.

– Mac®: Hold down the F5 key and press Enter repeatedly. 

– Handheld: Hold down the c key and press · repeatedly. 
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Using Short and Long Names
Anytime you are in the same problem where an object is defined, you 
can access it by entering its short name (the name given in the object’s 
Define command). This is the case for all defined objects, including 
private, public, and non-library objects.

You can access a library object from any document by typing the object’s 
long name. A long name consists of the name of the object’s library 
document followed by a backslash “\” followed by the name of the 
object. For example, the long name of the object defined as func1 in the 
library document lib1 is lib1\func1. To type the “\” character on the 
handheld, press g p.

Note: If you cannot remember the exact name or the order of arguments 
required for a private library object, you can open the library document 
or use the Program Editor to view the object. You also can use 
getVarInfo to view a list of objects in a library.

Using a Public Library Function or Program
1. Make sure you have defined the object in the document’s first 

problem, stored the object, saved the library document in the MyLib 
folder, and refreshed the libraries.

2. Open the TI-Nspire™ application in which you want to use the 
function or program.

Note: All applications can evaluate functions, but only the 
Calculator and Notes applications can run programs.

3. Open the Catalog and use the library tab to find and insert the 
object.

—or—

Type the name of the object. In the case of a function or program, 
always follow the name with parentheses. 

4. If the program requires you to supply one or more arguments, type 
the values or variable names inside the parentheses.

5. Press ·.

libs2\func1()

libs2\func1(34,power)
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Using a Private Library Function or Program
To use a Private library object, you must know its long name. For 
example, the long name of the object defined as func1 in the library 
document lib1 is lib1\func1.

Note: If you cannot remember the exact name or the order of arguments 
required for a private library object, you can open the library document 
or use the Program Editor to view the object.

1. Make sure you have defined the object in the document’s first 
problem, stored the object, saved the library document in the MyLib 
folder, and refreshed the libraries.

2. Open the TI-Nspire™ application in which you want to use the 
function or program.

Note: All applications can evaluate functions, but only the 
Calculator and Notes applications can run programs.

3. Type the name of the object. In the case of a function or program, 
always follow the name with parentheses.

4. If the object requires you to supply one or more arguments, type the 
values or variable names inside the parentheses.

5. Press ·.

Running a Non-Library Program or Function
1. Make sure you are in the same problem in which the function or 

program is defined.

2. Type the name of the function or program on the entry line.

—or—

Press h to select the name from a list.

You must always include a set of parentheses after the name.

If the function or program requires you to supply one or more 
arguments, type the values or variable names inside the parentheses.

libs2\func1()

libs2\func1(34,power)

prog1()

prog1(34,power)
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3. Press ·.

Interrupting a Running Program

While a function or program is running, the busy pointer } is displayed.

8 To stop the function or program,

– Windows®: Hold down the F12 key and press Enter repeatedly.

– Mac®: Hold down the F5 key and press Enter repeatedly. 

– Handheld: Hold down the c key and press · repeatedly. 

A message is displayed. To edit the function or program in the 
Program Editor, select Go To. The cursor appears at the command 
where the break occurred.

Getting Values into a Program
You can choose from several methods to supply the values that a 
function or program uses in calculations.

Embedding the Values Within the Program or Function
This method is useful primarily for values that must be the same each 
time the program or function is used.

1. Define the program.

2. Run the program.

Letting the User Assign the Values to Variables
A program or function can refer to variables created beforehand. This 
method requires users to remember the variable names and to assign 
values to them before using the object.

Define calculatearea()=
Prgm
 w:=3
 h:=23.64
 area:=w*h
EndPrgm

calculatearea() :area 70.92
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1. Define the program.

2. Supply the variables, and then run the program.

Letting the User Supply the Values as Arguments
This method lets users pass one or more values as arguments within the 
expression that calls the program or function. 

The following program, volcyl, calculates the volume of a cylinder. It 
requires the user to supply two values: height and radius of the cylinder.

1. Define the volcyl program.

2. Run the program to display the volume of a cylinder with a height of 
34 mm and a radius of 5 mm.

Note: You do not have to use the parameter names when you run 
the volcyl program, but you must supply two arguments (as values, 
variables, or expressions). The first must represent the height, and 
the second must represent the radius.

Requesting the Values from the User (Programs Only)
You can use the Request and RequestStr commands in a program to 
make the program pause and display a dialog box prompting the user for 
information. This method does not require users to remember variable 
names or the order in which they are needed.

You cannot use the Request or RequestStr command in a function.

Define calculatearea()=
Prgm
 area:=w*h
EndPrgm

w:=3 : h:=23.64
calculatearea() :area 70.92

Define volcyl(height,radius) =
Prgm
Disp "Volume =", approx(p ¦ radius2 ¦ height)
EndPrgm

volcyl(34,5) Volume = 534.071
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1. Define the program.

2. Run the program and respond to the requests.

Use RequestStr instead of Request when you want the program to 
interpret the user’s response as a character string rather than a math 
expression. This avoids requiring the user to enclose the response in 
quotation marks (““).

Displaying Information
A running function or program does not display intermediate calculated 
results unless you include a command to display them. This is an 
important difference between performing a calculation on the entry line 
and performing it in a function or program.

The following calculations, for example, do not display a result in a 
function or program (although they do from the entry line).

Displaying Information in the History
You can use the Disp command in a program or function to display 
information, including intermediate results, in the history.

Define calculatearea()=
Prgm

Request "Width: ",w
Request "Height: ",h

  area:=w*h
EndPrgm

calculatearea() : area
Width: 3 (3 entered as a response)
Height: 23.64 (23.64 entered as a response)

70.92

©
x:=12¦6
cos(p/4)&n
©

©
Disp 12¦6
Disp "Result:",cos(p/4)
©
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Displaying Information in a Dialog Box
You can use the Text command to pause a running program and display 
information in a dialog box. The user clicks OK to continue or clicks 
Cancel to stop the program. 

You cannot use the Text command in a function.

Note: Displaying a result with Disp or Text does not store that result. If 
you expect to refer later to a result, store it to a global variable.

Using Local Variables
A local variable is a temporary variable that exists only while a user-
defined function is being evaluated or a user-defined program is 
running.

Example of a Local Variable
The following program segment shows a For...EndFor loop (which is 
discussed later in this module). The variable i is the loop counter. In most 
cases, the variable i is used only while the program is running.

Note: When possible, declare as local any variable that is used only 
within the program and does not need to be available after the program 
stops.

What Causes an Undefined Variable Error Message?
An Undefined variable error message is displayed when you evaluate a 
user-defined function or run a user-defined program that references a 
local variable that is not initialized (assigned a value). 

©
Text "Area=" & area
©

©
cos(p/4)&maximum
Disp maximum
©

Local i À 
For i,0,5,1

Disp i
EndFor
Disp i

À Declares variable i as local.
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For example:

Initialize Local Variables
All local variables must be assigned an initial value before they are 
referenced.

Note (CAS): Functions and programs cannot use a local variable to 
perform symbolic calculations.

CAS: Performing Symbolic Calculations
If you want a function or program to perform symbolic calculations, you 
must use a global variable instead of a local. However, you must be 
certain that the global variable does not already exist outside of the 
program. The following methods can help.

• Refer to a global variable name, typically with two or more 
characters, that is not likely to exist outside of the function or 
program.

• Include DelVar within a program to delete the global variable, if it 
exists, before referring to it. (DelVar does not delete locked or linked 
variables.)

Define fact(n)=Func
Local m À 
While n>1
n¦m&m: n–1&n

EndWhile
Return m

 EndFunc

À Local variable m is not assigned an initial value.

Define fact(n)=Func
Local m: 1&m À 
While n>1
n¦m&m: n–1&n

EndWhile
Return m
EndFunc

À 1 is stored as the initial value for m.
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Differences Between Functions and Programs
A function defined in the Program Editor is similar to the functions built 
into the TI-Nspire™ Software.

• Functions must return a result, which can be graphed or entered in a 
table. Programs cannot return a result.

• You can use a function (but not a program) within an expression. For 
example: 3 ¦ func1(3) is valid, but not 3 ¦ prog1(3).

• You can run programs from Calculator and Notes applications only. 
However, you can evaluate functions in Calculator, Notes, Lists & 
Spreadsheet, Graphs & Geometry, and Data & Statistics.

• A function can refer to any variable; however, it can store a value to 
a local variable only. Programs can store to local and global variables.

Note: Arguments used to pass values to a function are treated as 
local variables automatically. If you want to store to any other 
variables, you must declare them as Local from within the function.

• A function cannot call a program as a subroutine, but it can call 
another user-defined function.

• You cannot define a program within a function.

• A function cannot define a global function, but it can define a local 
function.

Calling One Program from Another
One program can call another program as a subroutine. The subroutine 
can be external (a separate program) or internal (included in the main 
program). Subroutines are useful when a program needs to repeat the 
same group of commands at several different places.

Calling a Separate Program
To call a separate program, use the same syntax that you use to run the 
program from the entry line.

Define subtest1()=
Prgm
For i,1,4,1

subtest2(i,i¦1000)
EndFor

EndPrgm 

Define subtest2(x,y)=
Prgm

Disp x,y
EndPrgm 
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Defining and Calling an Internal Subroutine
To define an internal subroutine, use the Define command with 
Prgm...EndPrgm. Because a subroutine must be defined before it can be 
called, it is a good practice to define subroutines at the beginning of the 
main program.

An internal subroutine is called and executed in the same way as a 
separate program.

Note: Use the Program Editor’s Var menu to enter the Define and 
Prgm...EndPrgm commands.

Notes about Using Subroutines
At the end of a subroutine, execution returns to the calling program. To 
exit a subroutine at any other time, use Return with no argument.

A subroutine cannot access local variables declared in the calling 
program. Likewise, the calling program cannot access local variables 
declared in a subroutine.

Lbl commands are local to the programs in which they are located. 
Therefore, a Goto command in the calling program cannot branch to a 
label in a subroutine or vice versa.

Define subtest1()=
Prgm
local subtest2 À 
Define subtest2(x,y)= Á 
Prgm
Disp x,y

EndPrgm
©Beginning of main program
For i,1,4,1
subtest2(i,I*1000) Â 

EndFor
EndPrgm

À Declares the subroutine as a local variable.

Á Defines the subroutine.

Â Calls the subroutine.



Programming 713

Avoiding Circular-Definition Errors
When evaluating a user-defined function or running a program, you can 
specify an argument that includes the same variable that was used to 
define the function or create the program. However, to avoid circular-
definition errors, you must assign a value for variables that are used in 
evaluating the function or running the program. For example:

– or –

Controlling the Flow of a Function or Program
When you run a program or evaluate a function, the program lines are 
executed in sequential order. However, some commands alter the 
program flow. For example:

• Control structures such as If...EndIf commands use a conditional test 
to decide which part of a program to execute.

• Loop commands such as For...EndFor repeat a group of commands.

Using If, Lbl, and Goto to Control Program Flow
The If command and several If...EndIf structures let you execute a 
statement or block of statements conditionally, that is, based on the 
result of a test (such as x>5). Lbl (label) and Goto commands let you 
branch, or jump, from one place to another in a function or program.

The If command and several If...EndIf structures reside on the Program 
Editor’s Control menu.

When you insert a structure such as If...Then...EndIf, a template is 
inserted at the cursor location. The cursor is positioned so that you can 
enter a conditional test.

x+1&x À 

For i,i,10,1
Disp i À 

EndFor

À Causes a Circular definition error message if x or i does not have a 
value. The error does not occur if x or i has already been assigned a 
value.
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If Command
To execute a single command when a conditional test is true, use the 
general form:

In this example, you must store a value to x before executing the 
If command.

If...Then...EndIf Structures
To execute one group of commands if a conditional test is true, use the 
structure:

Note: EndIf marks the end of the Then block that is executed if the 
condition is true.

If x>5
Disp "x is greater than 5" À 

Disp x Á 

À Executed only if x>5; otherwise, skipped.

Á Always displays the value of x.

If x>5 Then
Disp "x is greater than 5" À 
2¦x&x À 

EndIf
Disp x Á 

À Executed only if x>5. 

Á Displays the value of:

2x if x>5

x if x{5
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If...Then...Else...EndIf Structures
To execute one group of commands if a conditional test is true and a 
different group if the condition is false, use this structure:

If...Then...ElseIf... EndIf Structures
A more complex form of the If command lets you test for multiple 
conditions. Suppose you want a program to test a user-supplied 
argument that signifies one of four options. 

To test for each option (If Choice=1, If Choice=2, and so on), use the 
If...Then...ElseIf...EndIf structure.

Lbl and Goto Commands
You can also control the flow by using Lbl (label) and Goto commands. 
These commands reside on the Program Editor’s Transfers menu.

Use the Lbl command to label (assign a name to) a particular location in 
the function or program.

You can then use the Goto command at any point in the function or 
program to branch to the location that corresponds to the specified 
label.

If x>5 Then
Disp "x is greater than 5" À 
2¦x&x À 

Else
Disp "x is less than or equal to 5" Á 
5¦x&x Á 

EndIf
Disp x Â 

À Executed only if x>5.

Á Executed only if x{5.

Â Displays value of:
2x if x>5 
5x if x{5

Lbl  labelName name to assign to this location (use 
the same naming convention as a 
variable name)

Goto labelName specifies which Lbl command to 
branch to
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Because a Goto command is unconditional (it always branches to the 
specified label), it is often used with an If command so that you can 
specify a conditional test. For example:

Using Loops to Repeat a Group of Commands
To repeat the same group of commands successively, use one of the loop 
structures. Several types of loops are available. Each type gives you a 
different way to exit the loop, based on a conditional test.

Loop and loop-related commands reside on the Program Editor’s Control 
and Transfers menus.

When you insert one of the loop structures, its template is inserted at the 
cursor location. You can then begin entering the commands that will be 
executed within the loop.

For...EndFor Loops
A For...EndFor loop uses a counter to control the number of times the 
loop is repeated. The syntax of the For command is: 

Note: The ending value can be less than the beginning value, provided 
the increment is negative.

For variable, begin, end [, increment]

If x>5
Goto GT5 À 

Disp x
--------
-------- Á 
Lbl GT5
Disp "The number was > 5"

À If x>5, branches directly to label GT5. 

Á For this example, the program must include commands (such as 
Stop) that prevent Lbl GT5 from being executed if x{5.

À Á Â Ã

À Variable used as a counter

Á Counter value used the first time For is executed

Â Exits the loop when variable exceeds this value
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When For is executed, the variable value is compared to the end value. If 
variable does not exceed end, the loop is executed; otherwise, control 
jumps to the command following EndFor.

Note: The For command automatically increments the counter variable 
so that the function or program can exit the loop after a certain number 
of repetitions.

At the end of the loop (EndFor), control jumps back to the For command, 
where the variable is incremented and compared to end.

For example:

Note: You can declare the counter variable as local if it does not need to 
be saved after the function or program stops.

While...EndWhile Loops
A While...EndWhile loop repeats a block of commands as long as a 
specified condition is true. The syntax of the While command is: 

While condition

When While is executed, condition is evaluated. If condition is true, the 
loop is executed; otherwise, control jumps to the command following 
EndWhile.

Ã Added to the counter each subsequent time For is executed (If this 
optional value is omitted, the increment is 1.)

For i,0,5,1
Disp i À 

EndFor
Disp i Á 

À Displays 0, 1, 2, 3, 4, and 5.

Á Displays 6. When variable increments to 6, the loop is not executed.

i > 5
i { 5

For i,0,5,1
------

--------
EndFor
--------
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Note: The While command does not automatically change the condition. 
You must include commands that allow the function or program to exit 
the loop.

At the end of the loop (EndWhile), control jumps back to the While 
command, where condition is re-evaluated.

To execute the loop the first time, the condition must initially be true.

• Any variables referenced in the condition must be set before the 
While command. (You can build the values into the function or 
program, or you can prompt the user to enter the values.)

• The loop must contain commands that change the values in the 
condition, eventually causing it to be false. Otherwise, the condition 
is always true and the function or program cannot exit the loop 
(called an infinite loop).

For example:

Loop...EndLoop Loops
A Loop...EndLoop creates an infinite loop, which is repeated endlessly. 
The Loop command does not have any arguments.

0&x À 
While x<5

Disp x Á 
x+1&x Â 

EndWhile
Disp x Ã 

À Initially sets x.

Á Displays 0, 1, 2, 3, and 4.

Â Increments x.

Ã Displays 5. When x increments to 5, the loop is not executed.

x | 5
x < 5

While x<5
-------

--------
EndWhile

------
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Typically, you insert commands in the loop that let the program exit from 
the loop. Commonly used commands are: If, Exit, Goto, and Lbl (label). 
For example:

Note: The Exit command exits from the current loop.

In this example, the If command can be anywhere in the loop.

The If command could also use a Goto command to transfer program 
control to a specified Lbl (label) command.

Repeating a Loop Immediately
The Cycle command immediately transfers program control to the next 
iteration of a loop (before the current iteration is complete). This 
command works with For...EndFor, While...EndWhile, and 
Loop...EndLoop.

0&x
Loop

Disp x
x+1&x
If x>5 À 
Exit

EndLoop
Disp x Á 

À An If command checks the condition.

Á Exits the loop and jumps to here when x increments to 6.

When the If command is: The loop is:

At the beginning of the loop Executed only if the condition is true.

At the end of the loop Executed at least once and repeated 
only if the condition is true.

Loop
--------
--------
EndLoop
--------
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Lbl and Goto Loops
Although the Lbl (label) and Goto commands are not strictly loop 
commands, they can be used to create an infinite loop. For example:

As with Loop...EndLoop, the loop should contain commands that let the 
function or program exit from the loop.

Changing Mode Settings
Functions and programs can use the setMode() function to temporarily 
set specific calculation or result modes. The Program Editor’s Mode menu 
makes it easy to enter the correct syntax without requiring you to 
memorize numeric codes.

Note: Mode changes made within a function or program definition do 
not persist outside the function or program.

Setting a Mode
1. Position the cursor where you want to insert the setMode function.

2. From the Mode menu, click the mode to change, and click the new 
setting.

The correct syntax is inserted at the cursor location. For example:

Debugging Programs and Handling Errors
After you write a function or program, you can use several techniques to 
find and correct errors. You can also build an error-handling command 
into the function or program itself.

If your function or program allows the user to select from several 
options, be sure to run it and test each option.

Techniques for Debugging
Run-time error messages can locate syntax errors but not errors in 
program logic. The following techniques may be useful.

• Temporarily insert Disp commands to display the values of critical 
variables.

setMode(1,3)

Lbl START
--------
--------
Goto START
--------
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• To confirm that a loop is executed the correct number of times, use 
Disp to display the counter variable or the values in the conditional 
test.

• To confirm that a subroutine is executed, use Disp to display 
messages such as “Entering subroutine” and “Exiting subroutine” at 
the beginning and end of the subroutine.

• To stop a program or function manually, 

– Windows®: Hold down the F12 key and press Enter repeatedly.

– Mac®: Hold down the F5 key and press Enter repeatedly. 

– Handheld: Hold down the c key and press · repeatedly. 

Error-handling Commands

Command Description

Try...EndTry Defines a block that lets a function or program execute 
a command and, if necessary, recover from an error 
generated by that command.

ClrErr Clears the error status and sets system variable errCode 
to zero. For an example of using errCode, see the Try 
command in the Reference Guide.

PassErr Passes an error to the next level of the Try...EndTry 
block.
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Using the TI-SmartView™ Emulator

With three layout options to choose from, teachers will find that the 
emulator facilitates classroom presentations. In the teacher software, 
layout options are:

• Handheld only

• Keypad plus side screen

• Handheld plus side screen

In the student software, the TI-SmartView™ emulates the keypad, which 
along with the handheld view, gives students the ability to drive the 
software as if using a handheld.

Opening the TI-SmartView™ Emulator 
The TI-SmartView™ emulator is located in the Documents Workspace. To 
open the emulator view:

1. Open the Documents Workspace.

2. Click , which is located in the Documents Toolbox.

In the teacher software, the handheld is displayed with Handheld 
and SideScreen panels open in computer mode as shown in the 
following illustration. You can use the keypad on the emulated 
handheld, but the document won’t appear on the emulated 
handheld screen until you switch to Handheld mode.
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In the student software, the TI-Nspire™ CX keypad is displayed with the 
side screen open in computer mode. You can use the keypad on the 
emulated handheld to work with the document in the side screen in 
either computer mode or handheld mode.

3. Click View > Handheld.

—or—

Click  in the status bar to switch to handheld mode. 

Choosing a Keypad
An open document is not affected by changing the keypad. You can 
switch between keypads anytime you want. To select a keypad: 

1. In the emulator panel, click  to open the menu and select one of 
the following options:

• TI-Nspire™ CX

• TI-Nspire™ with Touchpad

• TI-Nspire™ with Clickpad

2. Click ¢ to select a faceplate option:

• Normal
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• High Contrast

• Outline 

Choosing Display Options
In the teacher software, use this option to choose how to display the 
emulator in the software window.

1. In the emulator panel, click .

—or—

Click File > Settings > TI-SmartView™.

2. Select one of the following options:

• Handheld Only. Displays the emulated handheld and hides the 
workspace and other panels.

Note: To keep the Handheld Only display in front of other 
application windows, click Always in Front at the top right of 
the TI-SmartView™ panel.

• Keypad + SideScreen. Opens a larger view of the keypad 
along with the side screen.

• Handheld + SideScreen. Opens the entire emulated handheld 
along with the side screen.

Changing the Width of the TI-SmartView™ Panel
To change the width of the TI-SmartView™ emulator panel:

8 Click the right edge of the panel and drag it until it is the width you 
want.

Changing the Size of the Screen in the Workspace
When in handheld mode, use the Scale to change the size of the screen.

8 Drag the slider to the appropriate scale percentage. The scale slider 
is located on the far right side of the status bar, at the bottom of the 
TI-Nspire™ window. Scale percentages range from 100% to 200%. 
The default scale is 150%. 

Note: If computer mode is selected, you cannot change the size of the 
workspace.
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Working with the Emulated Handheld
To input data and work with files on the emulator, you can use the 
computer keyboard, TI-SmartView™ keypad, TI-Nspire™ menus and 
icons, or any combination of these. 

Note: Within one command, you cannot use a combination of both the 
keypad and the keyboard. For example, you cannot press Ctrl on the 
keyboard and click b on the emulator to open a context menu. 

For the most part, you can perform any function in the TI-SmartView™ 
emulator that you can perform on the handheld. Keys and applications 
operate the same way. 

Note: If you switch to Computer mode, you can still use most of the keys 
on the emulated handheld or keypad and all keystrokes are reflected in 
the workspace. However, some key combinations may only work in 
Handheld mode.

As you click keys on the emulator or press keys on the keyboard that 
activate keys on the emulator, those keys change color, making it easy for 
your audience to follow along. The last key selected stays highlighted.

In the teacher software, the emulator screen and the side screen are both 
interactive. You can click on icons and menu items on both screens. You 
can also right-click to display menus on both screens.

All handheld shortcuts and arrow functionality work from the computer 
keyboard. For example, to save a document, you can click / S on the 
emulator keypad or you can press Ctrl + S on the computer keyboard. 
When using a Mac®, press “ + S.

Using the Touchpad
You can operate the Touchpad on the TI-Nspire™ Touchpad keypad using 
either the touchpad on a laptop or by using the mouse to click the 
Touchpad. Areas of the Touchpad are highlighted as you click the arrow 
zones. 

An arrow is highlighted when you 
press or tap it.
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• Clicking the ¡, ¢, £, or ¤ keys on the Touchpad moves through 
menus one item at a time.

• Clicking and holding down an arrow on the Touchpad causes 
continual movement in the selected direction.

• Clicking and sliding the mouse across the Touchpad area enables you 
to move the mouse pointer.

• Clicking the middle of the Touchpad selects the highlighted menu 
option.

Using the Clickpad
You can use the Clickpad on the TI-Nspire™ Clickpad keypad using either 
the touchpad on a laptop or by using the mouse to click the Clickpad. 
Areas of the Clickpad are highlighted as you click the arrow zones.

• Clicking the ¡, ¢, £, or ¤ keys on the Clickpad moves through menus 
one item at a time.

• Clicking and holding down an arrow on the Clickpad causes 
continual movement in the selected direction.

• Clicking the middle of the Clickpad selects the highlighted menu 
option.

Using Settings and Status
When working with the TI-SmartView™ emulator, you can change 
General Settings and Document Settings. For more information, see 
Using the Documents Workspace.

You can view all other settings, but you cannot change them in the 
TI-SmartView™ emulator. However, the ability to view these options 
provides teachers with an instructional tool when they need to show 
students how to set up a handheld.

To view settings and status:

1. Click c to access the Home screen.

2. Click Settings. 
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Changing TI-SmartView™ Options
You can change the emulator options, even when the emulator panel is 
closed. 

1. In the teacher software, click File > Settings > TI-SmartView™ 
Options. 

The TI-SmartView™ Options dialog box opens.

In the student software, click File > Settings > Keypad Options.

Setting or 
Settings

Description

Language You can open the languages menu and select a 
language, but you cannot save changes. To change 
the language, use the TI-Nspire™ menu File > 
Settings > Change Language option.

Handheld 
Setup

You can open the menus and select items to 
demonstrate which items to choose, but you cannot 
save any changes.

Handheld 
Status

You can access the screen. The # symbol replaces any 
numeric values that would be displayed on the 
handheld.

About You can open the About screen and view the 
software version. Other information that pertains 
only to the handheld hardware is marked as "Not 
Applicable."

Login You can display the Login to Class screen and type in 
the User Name and Password fields. Login is not 
available. 
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The Keypad Options dialog box opens.

2. Click Browse to change the folder where documents are saved and 
accessed in the My Documents folder when using the emulator.

Important: If you change the TI-SmartView™ location, you must 
also copy or move the MyLib folder and paste it to the new location 
to see library objects. 

The default location of MyLib is:

• Windows®: Documents\TI-Nspire\MyLib.

• Mac®: Documents/TI-Nspire/MyLib.

Note: Close and reopen the TI-Nspire™ application for the libraries 
to reflect the change.

3. Click ¤ to open the menu and select a keypad.

4. Click ¤ to open the menu and select a faceplate.

5. In the teacher software, click ¤ to open the menu and select a view. 
If selecting Handheld only, select Always in Front to keep this 
window on top of all other open applications.

6. Click OK to save the settings.

Working with Documents
You can open multiple documents in the workspace by selecting 
File > Open Document from the menu or using keyboard shortcuts. 
When you switch between these documents, the emulated handheld 
shows only the current document. You can insert pages and problems 
using either the TI-Nspire™ menus or icons, keyboard shortcuts, or 
TI-SmartView™ menus or shortcuts.

Note: You cannot work with PublishView™ documents using the 
TI-SmartView™ emulator. When you create or open a PublishView™ 
document, the document opens in Computer mode.
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Opening a Document
You can open a document by navigating to it on the emulator, the same 
way you open a document on the handheld, or you click 
File > Open Document.

When you open a document using the emulator, you can only open 
documents that are in the folder displayed on the emulator (usually the 
My Documents folder, unless you specified a different folder in your 
TI-SmartView™ settings). When you open a document using the menu 
path, you can browse to find any TI-Nspire™ document on your 
computer or network. If you open a document using the emulated 
handheld, it replaces the document that was previously open.

Note: If the number of characters in the document’s file path name 
exceeds 256 characters, the document cannot be opened and an error 
message is displayed. To avoid this error, keep file and folder names short 
or move files up in the file path.

Saving a Document
When you save a document using the File > Save Document menu or 
icon, keyboard shortcuts, keypad shortcuts, or emulator menus, the 
document is saved in the same location where the file was opened. To 
save the file in another location or with a different name, click 
File > Save As.

Using Screen Capture
To capture the current page, press Ctrl + J (Mac®: “ + J) on your 
keyboard or on the emulated handheld. The image is automatically 
placed in the Clipboard and in the TI-Nspire™ Screen Capture window. 
You can paste the image into another application without having to take 
additional steps. This feature is only available when the TI-SmartView™ 
panel is active and the workspace is in Handheld mode.

All other screen capture features work the same way they do in other 
areas of TI-Nspire™ software. For more information, see Capturing 
Screens.
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Using the Script Editor 

The Script Editor allows you to create and deliver dynamically linked 
simulations, powerful and flexible utilities, and other educational 
content for exploring math and science concepts. When you open a 
document containing a script, the script runs automatically as 
programmed. To see the running script application, the page containing 
the script application must be active.

The Script Editor is directed toward teachers and other authors who are 
comfortable working in a Lua scripting environment. Lua is a powerful, 
fast, lightweight scripting language that is fully supported in TI-Nspire™ 
and PublishView™ documents. Documents containing script applications 
can be opened on TI-Nspire™ handhelds and in the TI-Nspire™ 
Document Player. The script application runs on a handheld or in 
Document Player, but you cannot view or edit the script. 

Note these resources for using the Script Editor and creating scripts:

• Press F1 to access the TI-Nspire™ help, which includes the Script 
Editor help. 

• Press F2 for additional TI-Nspire™ resources such as scripting samples 
and a link to the TI-Nspire™ Scripting API library. (This information is 
also available at education.ti.com/nspire/scripting/home.)

• Go to lua.org for more information about Lua. 

Overview of the Script Editor 
With the Script Editor, you can insert, edit, save, run, and debug script 
applications in TI-Nspire™ (.tns files) and Publishview™ (.tnsp files) 
documents.

• Script applications function within documents, problems, and pages 
the same way that other TI-Nspire™ applications do.

• When you create a new document or open an existing document, 
you can insert or edit a script application within a page or within a 
work area of a split page. 

• In a split page layout, you can add a script application to each work 
area of a page. A page can be split into a maximum of four 
quadrants.

• Images can be added to script applications. See the Inserting Images 
section.

• All work done in the Script Editor is lost if you close the TI-Nspire™ 
or PublishView™ document without saving it.
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Exploring the Script Editor Interface 
The Script Editor window opens when you insert a new script application 
or edit an existing script application in a TI-Nspire™ or PublishView™ 
document.

Select options for creating new scripts or editing scripts from the Insert 
menu in the Documents Workspace when a document is open.

Note: Although not labeled, the Documents Workspace is the default 
workspace in the TI-Nspire™ Student Software and TI-Nspire™ CAS 
Student Software. 

The following figure shows the Script Editor with an existing script.

À Menu bar. Contains options for working with the Script Editor. 

Á Toolbar. Provides tools for common Script Editor functions. See the 
Using the Toolbar section.

Â Script title. You can change the title from the menu, or right-click 
the title to change it.

Ã Script lines. Type your text in the script lines. This script shows 
several disabled breakpoints, which are indicated by slashes.
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Using the Toolbar 
The following table describes the toolbar options.

Ä Tools panel. Area of the window where the script data is stored. 
See the Using the Tools Panel section.

Å Status bar. Displays the operational state of the script. See the 
Using the Status Bar section.

Tool name Tool function

Suspend Script Pauses the script execution.

Resume Script Resumes the script execution. 

While debugging, the script continues to 
execute until the next breakpoint or the end 
of the script.

Set Script Starts the script execution.

Focus Script Sets the focus to the page in the document 
where the script application is attached:

• In a TI-Nspire™ document, sets the focus 
to the page.

• In a PublishView™ document, sets the 
focus to the frame on the page.

Step Into While debugging, executes the current 
statement. If the statement calls any 
functions, the debugger stops at the first line 
of each function. 

Step Over While debugging, executes the current 
statement.

If the statement calls any functions, the 
debugger does not stop within the function 
unless the function contains a breakpoint. 

Enable 
Breakpoints

Switches from normal mode to debugging 
mode.

Disable 
Breakpoints

Switches back from debugging mode to 
normal mode and resumes the script.
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Using the Tools Panel
At the bottom of the window, the Tools panel shows the scripting data. 
For more information, see the Debugging Scripts section.

Using the Status Bar
The status bar at the bottom of the window shows basic script data, as 
described in this example: stopwatch, 1.1 4:1 Running.

• Name of the document that the script application is attached to 
(stopwatch)

• Problem and page number (1.1)

• Script line and character, (4:1 describing line 4 and character 1)

• Operational state of the script (Running). Note the possible states:

– Normal mode: Running, Paused, or Error

– Debugging mode: Running (debugging), Paused, Stepping, or 
Error

Inserting New Scripts 
To insert a new script application and script, follow these steps.

Insert Image Inserts the image in a string format into the 
current script at the cursor location.

Set Permissions Sets permission levels to Protected, View Only, 
or Unprotected and allows you to set a 
password for the script.

Tab Window Display

Console Script errors are printed here. 

Print statements embedded in the script also print here.

Globals Selected global variables are displayed.

To select a global variable for display, select Click to add 
new watch variable at the bottom of the Tools panel. 

Call Stack Displays the call tree for the currently executing function.

Locals Local variables in the current function’s scope are 
displayed.

Tool name Tool function
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1. Open the document where you want to insert the script. It can be a 
new or existing document.

2. Click Insert > Script Editor > Insert Script.

A script application is inserted, and the Script Title dialog box opens.

Note: The TI-Nspire™ Student Software and the TI-Nspire™ CAS 
Student Software open automatically within the Documents 
Workspace.

3. Type a script title. (The maximum number of characters is 32.)

4. Click OK.

The Script Editor window opens showing a blank script. 

5. Type your text in the script lines. 

Note: Some nonstandard UTF-8 wide characters may not be 
displayed correctly. For these characters, it is highly recommended 
that you use the string.uchar function.

6. When the script is complete, click Set Script to execute it.

• In a TI-Nspire™ document, the script application is inserted in a 
new page. When the page containing the script application is 
active, the Documents Toolbox is empty.

• In a PublishView™ document, a frame containing the script 
application is added to the active page. You can move or size 
this frame just as you would any other PublishView™ object, and 
you can add other PublishView™ objects to the page.

7. To view the script application, click Focus Script.

Editing Scripts 
To edit an existing script, follow these steps.

1. Open the TI-Nspire™ or PublishView™ document that contains the 
script. The page containing the script must be active.

2. Select the page and the work area that contains the script.

3. Click Insert > Script Editor > Edit Script.

The Script Editor opens showing the script. If the selected work area 
on the page does not contain a script, Edit Script is dimmed. 

If the script is password protected, the Password Protected dialog 
box opens prompting for a password.

4. Make any desired changes. 
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• To designate comments, use double hyphens (--) at the start of 
each comment line.

• To change the title, click Edit > Set Script Title or right-click the 
title and click Set Script Title.

Notes: 

• Some nonstandard UTF-8 characters may not be displayed 
correctly. For these characters, it is highly recommended that 
you use the string.uchar function.

• The print function may yield unexpected results for non–UTF-8 
characters. 

• Some nonprintable characters returned by the on.save function 
will be discarded. 

5. To execute the script, click Set Script.

Any errors are displayed in the Console area in the Tools panel.

6. To view the script application (running script), click Focus Script.

Saving Script Applications 
Clicking Set Script resets (updates) a script application in a TI-Nspire™ or 
PublishView™ document. However, the script and script application are 
not saved until you save the document. If you close the document or 
close the TI-Nspire™ software without saving, work on the script is lost.

To ensure the script application is saved after all work is complete, follow 
these steps.

1. From the Script Editor window, click Set Script to reset (update) the 
script application in the document.

2. From an open document, click File > Save Document to save 
changes to the TI-Nspire™ or PublishView™ document.

Note: To ensure work is backed up, set the script and save the document 
frequently.

Inserting Images 
To insert an image into a script application, follow these steps.

1. Position your cursor where you want the image serialization to be 
located in the script.
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2. Using the example that follows, type the code for the image. 

<myImage> = image.new (<image serialization>)
function on.paint(gc)

gc:drawImage (<myImage>, 30, 30)
end

3. At <image serialization>, click File > Insert Image. 

A dialog box opens prompting you to navigate to the appropriate 
image file. The supported file types are .jpg, .jpeg, .bmp, and .png.

Note: To avoid slow editor performance, keep the image height plus 
width at less than 640 pixels.

4. Navigate to the image file that you want to insert.

The Script Editor reformats the image to a string format that the 
script image APIs understand. For more information about using 
images, see the API library.

5. To execute the script, click Set Script.

6. To view the simulation with the new image, click Focus Script.

Changing View Options 
To change viewing options:

8 To clear the scripting data in the Tools panel and restore the editor 
defaults, click View > Restore Editor to Defaults. 

8 To view the script title in the document and before each print 
statement in the Console, click View > Title in Document View.

8 To hide or show toolbar labels, click View > Toolbar Text Labels.

8 To show or hide the Tools panel or its areas, click View > Tools Panel 
and click the appropriate option. 

8 To create tab groups when multiple scripts are open, right-click one 
of the titles and click New Horizontal Group or New Vertical Group.

Setting Script Permissions 
You can set permission levels for a script and specify a password to 
protect a script. Follow these steps.

1. In the Script Editor window, click File > Set Permissions.

The Set Permissions dialog box opens.

2. In the Permissions Level area, select the appropriate security level:

• Protected. The script can be run, but not viewed or edited.
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• View only. The script can be viewed, but not edited.

• Unprotected. The script can be viewed and edited.

3. To secure a script, designate a password in the Security area. 

Note: Use caution when setting passwords because they cannot be 
recovered. 

4. Click OK.

The next time you click Insert > Script Editor > Edit Script, a Password 
Protected dialog box opens prompting for the password. Choose one of 
these options:

• To edit the script, enter the password and click OK.

• To view the script only, do not enter the password and click View.

Debugging Scripts 
You can debug your script to investigate runtime errors and trace the 
execution flow. While debugging, data is displayed in the Tools panel.

8 To enable debugging mode or disable it and return to normal mode, 
click Debug > Enable Breakpoints or Disable Breakpoints.

Note: Disabling breakpoints always resumes the script execution.

8 While debugging, click Step Into and Step Over as appropriate. See 
the Exploring the Script Editor interface section.

8 To set breakpoints, double-click in the space to the far left of the line 
number. Breakpoints are disabled until you click EnableBreakpoints.

8 Note these factors when debugging:

• Breakpoints in coroutines are not supported.

• If a breakpoint is set in a function that is a callback, the 
debugger may not stop at the breakpoint.

• The debugger may not stop at functions such as on.save, 
on.restore, and on.destroy.

On the toolbar, Step Into and Step Over are enabled when 
breakpoints are enabled.

8 To suspend and resume the script execution, click Suspend Script 
and Resume Script. When the script resumes, it runs until the next 
breakpoint is encountered or to the end of the script. A script can be 
suspended in normal mode or debugging mode.
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Getting Help

Use the Help menu to find useful information to help you use the 
software more productively. You can:

• Activate your software license.

• Register your TI product.

• Download the latest guidebooks, which can help you:

– Find information easily and quickly.

– Learn how to perform new tasks more easily and efficiently.

– Improve your proficiency with the TI-Nspire™ applications.

– Eliminate the need to keep track of a printed book.

• Visit knowledge sites on the Internet to improve your proficiency 
with the product. On these sites, you can find information about 
how to use TI products as well as lessons, quizzes, and other 
instructive activities shared by educators. 

Note: Activities available for download may vary depending on your 
geographical region.

• Explore online troubleshooting.

• Run TI-Nspire™ diagnostics.

• Check for updates to the software.

• Check for updates to operating systems for TI-Nspire™ handhelds 
and the TI-Nspire™ Lab Cradle.

• Find information about the current software version.

Activating Your Software License
1. Ensure you are connected to the Internet.

2. Click Help > Activate to open the Texas Instruments Activation 
Wizard.

3. Click Activate your License, and then click Next. 

The Complete Software Activation dialog box opens.
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4. Complete the name and email fields, and then select the region 
where you live if different from the default entry. If you want to 
receive emails from TI about updates, support, and promotions, 
ensure the check box is selected.

5. Click Next.

The Activate your software dialog box opens.

6. Type the license number. You can also copy the license number and 
paste it into the License Number field.

7. Click Next. 

The License Agreement dialog box opens.
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8. In the Country field, select your country from the drop-down list if it 
is different from the default entry.

9. Review the license agreement, and then select to accept the 
agreement.

10. Click Activate. The license number is validated against the TI 
database to ensure it is valid. 

If the license number is valid, the Successful Activation dialog box 
opens. If the license number is not valid, check to make sure the 
numbers are entered correctly. If the problem persists, contact TI 
Support.

11. Click Next or Finish to launch the software. 

12. When prompted, click OK to accept the default location for your 
TI-Nspire™ folder. If needed, navigate to the location on your 
computer where you want to store your TI-Nspire™ documents and 
files.



742 Getting Help

13. Select whether or not to replace any documents that have the same 
name.

The software launches and the Welcome Screen opens.

Registering Your Product
1. Ensure you are connected to the Internet.

2. Click Help > Register to access the TI Registration Product site.

3. Follow the instructions on the website to complete the product 
registration process.

Downloading the Latest Guidebook
1. Ensure you are connected to the Internet.

2. Click Help > Download latest Guidebook.

The Education Technology website opens with the Guidebooks tab 
active.

3. Click Sign In (located under the Search button on the right side of 
the banner).

The Sign In dialog box opens.

4. Type your user name and password, and then click Submit. 

Note: If you don’t have an account, click Create Account.

5. Click the name of the Guidebook that you want to download.

The Guidebooks available for the product you selected are listed. 

6. Click the title of the Guidebook you want to download.

A PDF verion of the Guidebook opens on your desktop. 

Exploring TI Resources
The Help menu also provides links to TI resources and websites. 

8 Click Help > Visit education.ti.com to access the Texas Instruments 
Education Technology website.
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8 Click Help > Visit Activities Exchange to access the Texas 
Instruments Activities Exchange, site, a forum where you can browse 
by subject to find ready-to-use math and science learning activities 
appropriate for middle grades through college.

8 Click Explore Online Troubleshooting to access TI’s Knowledge Base 
where you can find general information, troubleshooting help, 
product usage tips, and information specific to TI products.

Running TI-Nspire™ Diagnostics
If you have trouble with your software, this option enables you to run a 
short diagnostics program that will help TI support personnel 
troubleshoot the problem. You do not need Internet access to run 
diagnostics; however, Internet access is required to send the log file to TI 
Support. To run diagnostics:

1. Click Help > Run TI-Nspire™ Diagnostics.

The Software Diagnostic Tool dialog box opens.

2. Click Start to run the program. 

The log file is created and the Save as dialog box opens.

3. Navigate to the folder where you want to save the file, and then 
click Save As.

The Diagnostic Report dialog box opens providing the name of the 
zip file created and the location where it was saved.

4. Click OK.

5. From the Software Diagnostic Tool dialog box:

• Click Send to TI to send the file to TI Support.

• Click Restart to run the diagnostics program again.
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• Click Cancel to quit, and then click OK to confirm and close the 
dialog box.

Checking for Software Updates
If you are connected to the Internet and you have automatic notification 
enabled, your system will notify you of any TI-Nspire™ software updates 
when you open the software.

• The automatic check occurs once each time you open the software.

• If your system is up-to-date, you will not receive notification.

• You can turn off this feature if you don’t want to receive 
notifications automatically.

• You can also check for updates manually.

Manually Checking for Software Updates
1. Click Help > Check for Software Updates.

If your software is current, the Check for Software Update dialog 
opens indicating that you have the latest version of the software.

2. To turn off automatic notifications, clear the Automatically check 
for updates check box. By default, this option is selected.

3. Click OK to close the dialog box.

Installing Updated Software
If your software needs to be updated, the Check for Software Update 
dialog box opens with a message informing you that a newer version of 
the software is available.

To install the software update and manage your update notifications:

1. Check to make sure you are connected to the Internet.

2. To turn off automatic notifications, clear the Automatically check 
for updates check box.
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3. Click Update to save the settings and begin the download.

A progress dialog box opens to show the download progress.

Note: If you receive a connection error, check your Internet connection 
and try again.

Checking for Handheld or Lab Cradle OS Updates
This option is active only if a handheld or TI-Nspire™ Lab Cradle is 
connected. To check for OS updates for a connected, selected handheld 
or lab cradle, complete the following steps.

1. Open the Content Explorer, and then select a connected handheld or 
lab cradle.

2. Click Help > Check for Handheld/Lab Cradle OS Update.

If the operating system is current, the Check for Handheld OS Update 
dialog box opens indicating that the operating system on the 
handheld is current.

3. To turn off automatic notifications, clear the Automatically check 
for updates check box. By default, this option is turned on.

4. Click OK to close the dialog box.

Installing an Updated Operating System
If the operating system is not current on your handheld or Lab Cradle, 
the Check for Handheld OS Update dialog box opens informing you that 
a newer version of the OS is available.
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1. Check to make sure you are connected to the Internet.

2. Click Install OS on my handheld/lab cradle.

You can also save a copy of the OS file on your computer by selecting 
the Save a copy of the OS to check box. Click Browse to change the 
location where the OS file is saved. You can install it later using 
Tools > Install OS. 

3. Click Continue to download the OS and update the handheld or lab 
cradle.

4. Click Yes to confirm that you want to replace the OS file.

The License Agreement dialog box opens.

5. Accept the license agreement and click Continue.

6. When the message warning you that any unsaved data will be lost is 
displayed, click Yes. 

Note: Click No to cancel the update and save any unsaved 
documents, and then restart the update process.

The Installing OS dialog box opens indicating the progress of the 
download.

When the download is complete, the Information dialog box opens 
informing you that the OS has been downloaded and that you can 
disconnect the handheld or lab cradle from the computer.

7. Click OK. The updated operating system is installed on the handheld 
or lab cradle. 

When the update is complete, the handheld or lab cradle reboots.
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About the Software
Complete the following steps to open the About window, which provides 
legal information about the software, indicates which version you have, 
and lists your license number.

1. Click Help > About TI-Nspire™ <Product Name> Software.

Note: You do not need an Internet connection to open this window.

2. Click OK to close the window.
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Regulatory Information

FCC Statement
Note: This equipment has been tested and found to comply with the 
limits for a Class B digital device, pursuant to Part 15 of the FCC Rules. 
These limits are designed to provide reasonable protection against 
harmful interference in a residential installation. This equipment 
generates, uses and can radiate radio frequency energy and, if not 
installed and used in accordance with the instructions, may cause 
harmful interference to radio communications. However, there is no 
guarantee that interference will not occur in a particular installation.

If this equipment does cause harmful interference to radio or television 
reception, which can be determined by turning the equipment off and 
on, the user is encouraged to try to correct the interference by one or 
more of the following measures:

• Reorient or relocate the receiving antenna.

• Increase the separation between the equipment and receiver.

• Connect the equipment into an outlet on a circuit different from 
that to which the receiver is connected.

• Consult the dealer or an experienced radio/TV technician for help.

Modifications not expressly approved by the manufacturer could void the 
user’s authority to operate the equipment under FCC rules.

USA FCC Information Concerning Radio Frequency 
Interference

Product Name: 
TI-Nspire™ Navigator™ Cradle

FCC ID: V7R-TINAVWC2

Product Name: 
TI-Nspire™ Navigator™ Access Point

FCC ID: V7R-TINAVAP2

Product Name: 
TI-Nspire™ CX Wireless Network Adapter

FCC ID: 
V7R-TINAVWNA
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Federal Communication Commission Interference 
Statement
This equipment has been tested and found to comply with the limits for a 
Class B digital device, pursuant to Part 15 of the FCC Rules. These limits 
are designed to provide reasonable protection against harmful 
interference in a residential installation. This equipment generates, uses, 
and can radiate radio frequency energy and, if not installed and used in 
accordance with the instructions, may cause harmful interference to 
radio communications. However, there is no guarantee that interference 
will not occur in a particular installation. If this equipment does cause 
harmful interference to radio or television reception, which can be 
determined by turning the equipment off and on, the user is encouraged 
to try to correct the interference by one or more of the following 
measures:

• Reorient or relocate the receiving antenna.

• Increase the separation between the equipment and receiver.

• Connect the equipment into an outlet on a circuit different from 
that to which the receiver is connected.

• Consult the dealer or an experienced radio/TV technician for help.

FCC Caution: The TI-Nspire™ Navigator™ Access Point, TI-Nspire™ 
Navigator™ Cradle, and TI-Nspire™ CX Wireless Network Adapter 
comply with Part 15 of the FCC Rules. Operation is subject to the 
following two conditions: (1) These devices may not cause harmful 
interference, and (2) these devices must accept any interference received, 
including interference that may cause undesired operation.

RF Radiation Exposure and Hazard Statement:
To ensure compliance with FCC RF exposure requirements, the maximun 
SAR value for this device when worn on the body is 0.995 mW/g. Using 
higher gain antennas and types of antennas not covered under the FCC 
certification of this product is not allowed. Installers of the radio and end 
users of the product must adhere to the installation instructions provided 
in this manual.

This transmitter must not be co-located or operating in conjunction with 
any other antenna or transmitter.
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Non-modification Statement:
Use only the integral antenna supplied by the manufacturer when 
operating these devices. Unauthorized antennas, modifications, or 
attachments could damage the TI-Nspire™ Navigator™ Access Point, 
TI-Nspire™ CX Wireless Network Adapter, or TI-Nspire™ Navigator™ 
Cradle and violate FCC regulations. Any changes or modifications not 
expressly approved by the party responsible for compliance could void 
the user's authority to operate this equipment.

Deployment Statement:
This product is certified for indoor deployment only. Do not install or use 
this product outdoors.

Canadian IC Information

Industry Canada Statement:
This device complies with Industry Canada license-exempt RSS 
standard(s). Operation is subject to the following two conditions: 

1. This device may not cause interference, and 

2. This device must accept any interference, including interference that 
may cause undesired operation of the device. 

To prevent radio interference to the licensed service (i.e. co-channel 
Mobile Satellite systems) these devices are intended to be operated 
indoors and away from windows to provide maximum shielding. The 
maximun SAR value for this device when worn on the body is 0.995 
mW/g. Equipment (or its transmit antenna) that is installed outdoors is 
subject to licensing and not supported by the TI-Nspire™ Navigator™ 
Access Point, TI-Nspire™ CX Wireless Network Adapter, or TI-Nspire™ 
Navigator™ Cradle.

Industrie Canada Déclaration :
Ce dispositif est conforme à la norme (s) RSS de la licence-exonéré 
Industrie Canada. Opération est soumise aux deux conditions suivantes :

Product Name: 
TI-Nspire™ Navigator™ Cradle

IC: 451E-TINAVWC2

Product Name: 
TI-Nspire™ Navigator™ Access Point

IC: 451F-TINAVAP2

Product Name: 
TI-Nspire™ CX Wireless Network 
Adapter

IC: 451E-TINAVWNA
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1. Ce dispositif ne peut pas causer de brouillage, et

2. Ce dispositif doit accepter toute interférence, y compris le brouillage 
qui peut causer intempestif de fonctionnement du dispositif.

European Union and European Free Trade Association 
(EFTA) Regulatory Compliance
This equipment may be operated in the countries that comprise the 
member countries of the European Union and the European Free Trade 
Association. These countries, listed in the following paragraph, are 
referred to as The European Community throughout this document:

AUSTRIA, DENMARK, FINLAND, FRANCE, GERMANY, ITALY, 
NETHERLANDS, PORTUGAL, SPAIN, SWEDEN, UNITED KINGDOM,  
NORWAY, SWITZERLAND

The TI-Nspire™ Navigator™ Access Point communicates with either a 
TI-Nspire™ Navigator™ wireless cradle or TI-Nspire™ CX Wireless 
Network Adapter via a wireless 802.11b/g link to provide wireless local 
area networking (WLAN) capabilities and with a personal computer using 
a USB cable. TI-Nspire™ Navigator™ Access Point includes one 
802.11b/g/n radio.

Declaration of Conformity
Marking by this symbol:

indicates compliance with the Essential Requirements of the R&TTE 
Directive of the European Union (1999/5/EC).

This equipment meets the following conformance standards:

Safety: EN 60950-1:2006 + A11:2009

EMC: EN 55022:2006, EN 55024:1998 + A1:2001 + A2:2003, N 301 489-1 
V1.8.1/2008-4, EN 301 489-17 V2.1.1/2009-5, CISPR22:1997, CISPR24

Including: EN 61000-3-2, -3-3, -4-2, -4-3, -4-4, -4-5, -4-6 and -4-11. The 
product is also licensed as required for additional country specific 
standards as required for the International Marketplace.

Radio: EN 300-328 v.1.7.1 (2006-10)
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Electromagnetic compatibility and Radio spectrum Matters (ERM); 
Wideband transmission systems; Data transmission equipment operating 
in the 2,4 GHz ISM band and using wide band modulation techniques. 
Certifications are harmonized to the EN standards covering essential 
requirements under article 3.2 of the R&TTE Directive. Compliance 
includes testing with the supplied integral antenna.

SAR: EN62209-2:2010

European Community Declaration of Conformity
Hereby, Texas Instruments declares that the TI-Nspire™ Navigator™ 
Access Point, TI-Nspire™ Navigator™ wireless cradle, and TI-Nspire™ CX 
Wireless Network Adapter are in compliance with the essential 
requirements and other relevant provisions of Directive 1999/5/EC.

English Hereby, Texas Instruments declares that the 
TI-Nspire™ Navigator™ Access Point, TI-Nspire™ 
Navigator™ wireless cradle, and TI-Nspire™ CX 
Wireless Network Adapter are in compliance 
with the essential requirements and other 
relevant provisions of Directive 1999/5/EC.

The Declaration of Conformity may be consulted 
in the Product Stewardship page at 
education.ti.com.

Dansk Texas Instruments erklærer hermed, at 
TI-Nspire™ Navigator™ adgangspunktet, den 
trådløse TI-Nspire™ Navigator™ holder og den 
trådløse TI-Nspire™ CX netværksadapter er i 
overensstemmelse med de essentielle krav og 
andre relevante bestemmelser i direktiv 
1999/5/EF.

Du kan læse overensstemmelseserklæringen på 
produktforvaltningssiden på education.ti.com.

Norsk Texas Instruments erklærer herved at TI-Nspire™ 
Navigator™ tilgangspunkt, TI-Nspire™ 
Navigator™ trådløs bordholder og TI-Nspire™ 
CX Wireless Network Adapter overholder de 
vesentlige kravene og andre relevante 
bestemmelser i direktivet 1999/5/EC.

Samsvarserklæringen kan leses på siden 
Produktforvaltning på education.ti.com.
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Suomi Texas Instruments vakuuttaa, että TI-Nspire™ 
Navigator™-liityntäpiste, langaton TI-Nspire™ 
Navigator™-kelkka ja TI-Nspire™ CX Wireless 
Network Adapter täyttävät direktiivin 1999/5/EY 
oleelliset vaatimukset ja ja muut asianmukaiset 
ehdot.

Vaatimustenmukaisuusvakuutus on 
tarkasteltavissa tuotevastuusivulla osoitteessa 
education.ti.com.

Français Texas Instruments déclare que le point d’accès 
TI-Nspire™ Navigator™, le socle de 
synchronisation TI-Nspire™ Navigator‚™ et 
l’adaptateur de réseau sans fil TI-Nspire™ CX 
sont conformes aux exigences essentielles et aux 
autres clauses applicables de la Directive 
1999/5/CE.

La Déclaration de conformité peut être consultée 
à la page Gérance du produit à 
education.ti.com.

Deutsch Texas Instruments erklärt hiermit, dass der 
TI-Nspire™ Navigator™ Zugangspunkt, die 
drahtlose TI-Nspire™ Navigator™ Basisstation 
und der drahtlose TI-Nspire™ CX 
Netzwerkadapter mit den wesentlichen 
Anforderungen und anderen relevanten 
Bestimmungen der Richtlinie 1999/5/EG konform 
sind.

Die Konformitätserklärung kann auf der Seite 
“Engagement für die Umwelt” unter 
education.ti.com angezeigt werden.

Italiano Con la presente, Texas Instruments dichiara che il 
punto di accesso TI-Nspire™ Navigator™, la base 
di ricarica wireless TI-Nspire™ Navigator™ e la 
basetta wireless TI-Nspire™ CX  sono conformi ai 
requisiti fondamentali e ad altri provvedimenti 
della Direttiva 1999/5/CE.

È possibile consultare la Dichiarazione di 
conformità alla pagina Product Stewardship 
(Gestione responsabile del prodotto), 
all’indirizzo education.ti.com.
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Nederlands Hierbij verklaart Texas Instruments dat het 
TI-Nspire™ Navigator™ accesspoint, de 
TI-Nspire™ Navigator™ draadloze slede en de 
TI-Nspire™ CX draadloze netwerkadapter 
voldoen aan de essentiële vereisten en andere 
relevante bepalingen van Richtlijn 1999/5/EC.

De verklaring van overeenstemming kan worden 
geraadpleegd op de pagina Product Stewardship 
(Productbeheer) op education.ti.com.

Português A Texas Instruments declara, pela presente, que o 
ponto de acesso TI-Nspire™ Navigator™, a base 
sem fios TI-Nspire™ Navigator™, e o adaptador 
de rede sem fios TI-Nspire™ CX estão em 
conformidade com os requisitos essenciais e 
outras disposições relevantes da Directiva 
1999/5/CE.

A Declaração de Conformidade pode ser 
consultada na página Administração do Produto 
em education.ti.com.

Español Mediante el presente documento, Texas 
Instruments declara que el punto de acceso 
TI-Nspire™ Navigator™, el soporte inalámbrico 
TI-Nspire™ Navigator™ y el adaptador de red 
inalámbrica TI-Nspire™ CX cumplen con los 
requisitos esenciales y otras disposiciones 
relevantes de la directiva 1999/5/CE.

Puede consultar la declaración de conformidad 
en la página Administración de producto en 
education.ti.com.

Svenska Texas Instruments deklarerar härmed att 
TI-Nspire™ Navigator™ anslutningspunkt, 
TI-Nspire™ Navigator™ trådlös 
tillkopplingsenhet och TI-Nspire™ CX trådlös 
nätverksadapter uppfyller de väsentliga kraven 
och övriga relevanta bestämmelser enligt 
direktivet 1999/5/EG.

Deklarationen om överensstämmelse kan läsas 
på sidan Produktansvar på webbplatsen 
education.ti.com.
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Countries of Operation and Restrictions of Use in the 
European Community

Operation Using the 2.400 to 2.4835 GHz Channels in the 
European Community
The installer and/or end user should use the configuration utility 
provided with this product to verify the current channel of operation, the 
expected transmit power level, and to confirm that the device is 
operating in conformance with the spectrum usage rules for the selected 
European Community country. If operation is occurring outside of 
the allowable channels as indicated in this guide, then operation 
of the product must cease immediately and the installer must 
consult with the local technical support staff responsible for the 
wireless network.

These devices are intended to be operated in all countries of the 
European Community. Additional restrictions of use for the TI-Nspire™ 
Navigator™ Access Point within the European Community countries in 
the 2.400 to 2.4835 GHz band are listed below.

• The frequencies associated with channels 1 to 13 in the 2.400 to 
2.4835 GHz band are allowed to be used either indoors or outdoors 
in all countries of the European Community, except where noted 
below:

• In Greece, Italy, Latvia, and Spain the end-user must apply for a 
license from the national spectrum authority to operate this device 
outdoors. Please consult the TI-Nspire™ Navigator™ Teacher 
Software Guidebook for further information regarding restrictions 
and operating conditions for outdoor configurations.

• In France, the following operation is permitted:

– Outdoor operation is only permitted using the 2.400 - 2.454 GHz 
band, which includes channels 1 to 7, at a maximum EIRP of 100 
mW (20 dBm).

– Outdoor operation is permitted in the 2.400 to 2.4835 GHz band 
on channels 1 to 13 at a maximum EIRP of 10 mW (10 dBm).

– Indoor operation is permitted in the 2.400 to 2.4835 GHz band 
on channels 1 to 13 at a maximum EIRP of 100 mW (20 dBm).

Warning Statements
Warning! Install the TI-Nspire™ Navigator™ Access Point in such a 
manner as to maintain a minimum of 20 cm (7.9 inches) separation 
distance between the radiating element(s) and all persons. This safety 
warning conforms to FCC radio frequency exposure limits.



Regulatory Information 757

Warning! Do not touch or move the TI-Nspire™ Navigator™ Access 
Point when the antennas are transmitting or receiving.

Warning! The TI-Nspire™ Navigator™ Access Point, TI-Nspire™ 
Navigator™ Cradle, and TI-Nspire™ CX Wireless Network Adapter are 
intended for indoor use only. Do not install the device nor operate it 
outdoors.

Warning! Intentional radiators, such as the TI-Nspire™ Navigator™ 
Access Point, TI-Nspire™ Navigator™ Cradle, and TI-Nspire™ CX Wireless 
Network Adapter are not intended to be operated with any antenna(s) 
other than those furnished by Texas Instruments. An intentional radiator 
may only be operated with the antenna(s) with which it is authorized.

Warning! Only qualified personnel must perform installation. Read and 
follow all warning notices and instructions marked on the product or 
included in the documentation.
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Appendix: Service and Support

Texas Instruments Support and Service

For U.S. and Canada:

For General Information 

For Technical Support 

For Product (Hardware) Service
Customers in the U.S., Canada, Mexico, Puerto Rico and Virgin 
Islands: Always contact Texas Instruments Customer Support before 
returning a product for service.

For All Other Countries:
For general information 

For more information about TI products and services, contact TI by e-mail 
or visit the TI Internet address.

Home Page: education.ti.com

KnowledgeBase and 
e-mail inquiries:

education.ti.com/support

Phone: (800) TI-CARES / (800) 842-2737
For U.S., Canada, Mexico, Puerto Rico, and 
Virgin Islands only

International 
information:

education.ti.com/international

KnowledgeBase and 
support by e-mail:

education.ti.com/support

Phone 
(not toll-free):

(972) 917-8324

E-mail inquiries: ti-cares@ti.com

Home Page: education.ti.com

http://education.ti.com
http://education.ti.com/support
http://education.ti.com/support
http://education.ti.com/international
http://education.ti.com/support
http://education.ti.com/support
http://education.ti.com
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Service and Warranty Information
For information about the length and terms of the warranty or about 
product service, refer to the warranty statement enclosed with this 
product or contact your local Texas Instruments retailer/distributor.
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Index

A
access point

configuring 11
account, teacher 20
activities

copying 54
filtering 52
keyword searches 52
opening 52
saving 53

Activities file 38
ActivityTypes file 36
adapter 1, 3

adding to network 12, 14, 15
connecting to handhelds 6
removing from network 15

adding
(x,y) numerical input questions 

166
applications 192
applications (PublishView™ 

documents) 220
classes 71
colors 189
copyrights 155
copyrights to documents (.tns) 

200
drop points questions 169
equation questions 162
images in Quick Poll 297
images to pages 297
images to questions 158
links 49
lists questions 170
Master Documents 293
open response questions 161
pages 196
problems 196
questions 158, 160
shortcuts 47
students to classes 75
teacher equations to graphs 277
teacher points to graphs 276
text (PublishView™ documents) 

232

applications
adding 192
deleting 195
grouping 195
inserting images 297
Question 153
swapping 193

arranging
captured screens 108

aspect ratio
changing (Review Workspace) 

262
assignments

exporting 289
redistributing 293
removing 295
renaming 294
saving 285
viewing individual 284
viewing summary 282

Attendance file 37

B
bar charts

organizing 265
viewing (Review Workspace) 256

batteries
charging 3

beginning class sessions 81
borders (PublishView™ documents), 

hiding/showing 228

C
Capture Class

printing screens 114
saving screens 113
view options 107

capture class tool 104
capture page option 116
Capture Selected Handheld option 

117
captured screens

rearranging 108
refreshing 108

capturing
active pages in documents 116
handheld current screens 103
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images in handheld mode 103
pages in active documents 103
screen stacks 111
student handhelds 104

capturing images
DragScreen 121, 124

changing
class views 82
colors 264
General Settings 147
Graphs & Geometry settings 149
language 33
links 49
passwords 100
scores 289

charging
batteries 3
cradles 3

Class Record 89
canceling file transfers 99
checking file transfer status 99
viewing file properties 100

Class Session file 37
class sessions

beginning 81
ending 81

Class Workspace 71
classes

adding classes 71
adding students 75
assigning students 84
changing views 82
Class Record 71, 89
copying student information 88
creating classes 71
moving students to 87
removing classes 79
removing students from 77
seating charts 82, 83
sending files 54
student lists 82

clearing
Live Presenter keypress history 

134
closing

Live Presenter 137
closing documents (.tns) 186
collecting

files 93
missing files 294

colors
changing for student responses 

264
colors, adding 189
comparing

screens 112
configuring

access point 11
configuring plot lists 262
connecting

handhelds to cradles 7
handhelds to wireless adapters 6

content
viewing on handhelds 57

Content Explorer 143
Content Workspace 41
content workspace

exploring 41
converting

.tns files to .tnsp files 245

.tnsp files to .tns files 244
text to hyperlinks 239

copying
activities 54
handheld images 103
images 116
images in handheld mode 103
Live Presenter keypress history 

134
screens 120
student information 88

copying problems 196
copyrights

adding 155
adding to documents (.tns) 200
viewing in documents (.tns) 198

cradles
adding to network 12, 15
charging 3
checking LEDs 4
connecting to handhelds 7
removing from network 15, 16

creating
classes 71
passwords 102
PublishView™ documents 204
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SessionLogs folder 35
creating documents (.tns) 183

D
data

viewing in tables (Review 
Workspace) 257

viewing student responses 260
deleting

applications 195
classes 79
documents (.tns) 186
files (Portfolio Workspace) 295
hyperlinks (PublishView™ 

documents) 239
images 299
images (PublishView™ 

documents) 242
keypress history in Live Presenter 

134
pages 195
problems 197
PublishView™ objects 218
shortcuts 48
student information 77

displaying
student responses 253
teacher handhelds 106

document
settings 32

documents
creating .tnsp files 204
printing .tnsp files 246
saving .tnsp files 209

documents (.tns, .tnsp)
opening (Content Workspace) 52

documents (.tns)
changing General Settings 147
closing 186
creating 183
deleting 186
opening 61, 186
opening (Class Workspace) 258
opening (Portfolio Workspace) 

259
printing 197
properties 198

protecting 199
read-only 199
saving 61, 185, 186
switching between 189
types 183
viewing 189

Documents Workspace 139
DragScreen feature 103, 121, 124
drop points questions

adding 169

E
editing

scores 288, 289
emulator, See TI-SmartView™ 

emulator
ending class sessions 81
equation questions

adding 162
exploring

content workspace 41
resources pane 42

exporting
data 289
student scores (Portfolio 

Workspace) 289

F
features

refreshing screen captures 109
files

canceling transfers 99
checking transfer status 99
collecting 93
collecting missing 294
image file types 297
importing (Portfolio Workspace) 

286
previewing (Portfolio 

Workspace) 287
properties 100
redistributing (Portfolio 

Workspace) 293
removing (Portfolio Workspace) 

295
saving (Portfolio Workspace) 

278, 285



764

sending 54, 90
sending missing 294
viewing properties 100
working with files on connected 

handhelds 59
filtering activities 52
final scores, changing 289
Flash (.flv) files 242
folders

storing PublishView™ objects 
219

footers in PublishView™ documents 
227

formatting
text (PublishView™ documents) 

233
formatting text 187
formatting toolbar

hiding 188
showing 188

G
Gallery view 107
graphs

adding teacher equations 277
adding teacher points 276
viewing data (Review 

Workspace) 256
Graphs & Geometry settings 149
grouping

responses 266
grouping applications 195

H
handhelds

capturing current screens 103
capturing selected handhelds 

117
capturing student screens 104
checking for OS updates 64
connecting to adapters 6
connecting to cradles 7
copying images 103
installing OS update 66
locating using Identify Selected 

69
pasting images 103

renaming 68
software 5
transferring files 64
viewing content on connected 

57
working with files on connected 

59
headers in PublishView™ 

documents 227
hiding

handheld display in Live 
Presenter 131

Live Presenter keypress history 
133

presenter handheld 131
responses 253, 267, 268
student names 106
student names in Live Presenter 

130
hiding format toolbar 188
hyperlinks (PublishView™ 

documents)
converting text to 239
editing 238
linking to files 234
linking to websites 237

I
Identify Selected 69
images

adding to questions 158
deleting 299
file types 297
inserting 297
moving 298
Quick Poll 297
resizing 299
saving 103, 116
selecting 298
TI-Nspire™ applications 297

images (PublishView™ documents) 
240–242

importing files (Portfolio 
Workspace) 286

inserting
hyperlinks (PublishView™ 

documents) 234
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images (PublishView™ 
documents) 240

images in questions 158
images in Quick Poll 297
images to pages 297
PublishView™ objects 215
text (PublishView™ documents) 

232
installing a handheld OS update 66
installing handheld software 5
inventory 2

K
keypress history

copying 134
hiding in Live Presenter 133
Live Presenter 130
showing in Live Presenter 133
viewing in Live Presenter 132

keyword searches 52

L
language

changing 33
LED

cradles 4, 19
status on cradles 4

linking
to files 234
to websites 237

links 48
adding 49
changing 49
moving 50
removing 50

lists
organizing data 265

lists questions
adding 170

Live Presenter 127
clearing keypress history 134
copying keypress history 134
Display pane 130
Handheld pane 130
hiding keypress history 133
hiding presenter handheld 131
hiding student names 130

hiding the handheld display 131
keypress history 130
Menu bar 129
playing a recording 136
recording the live presentation 

135
requirements 127
save recording 135
sharing recordings 136
showing keypress history 133
showing presenter handheld 131
showing student names 130
showing the handheld 132
showing the handheld screen 

134
start recording 135
starting 127
starting from Class Screen 

capture 127
stop recording 135
stopping 137
Tool bar 129
View options 130
viewing keypress history 132

Live Presenter keypress history
clearing 134

live results 255
logging in to network 23
logging system use

session logs 35
login status 84

M
Make Presenter option 113
managing

session logs 36
marking responses 270
Master Documents 292
moving

images 298
images (PublishView™ 

documents) 241
links 50
PublishView™ objects 217
students to classes 87

multiple choice questions
adding 160
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N
network

logging in 23
setting up 9

numerical input questions
adding 166

O
objects

(PublishView™ documents) 214–
??

objects (PublishView™ documents) 
??–220

open response questions
adding 161

opening
activities 52
documents (.tns) 61
Master Documents 292
Portfolio items 291

opening documents (.tns) 186
options

capture page 116
Capture Selected Handheld 117
Make Presenter 113
randomize screens 106

organizing
bar chart data 265, 266
list data 265
responses 262, 267

organizing PublishView™ sheets 226
OS update

installing on a handheld 66
overlapping PublishView™ objects 

217
overview

software 29
TI-Nspire(TM) Navigator(TM) 

Teacher Software 29

P
packaging session logs 38
page numbers (PublishView™ 

documents) 226
Page Sorter 141, 193, 251
pages

adding 196
deleting 195
grouping 195
rearranging 194
selecting 194
ungrouping 195

panes
resource 42

passwords
changing for teacher 21
resetting for students 100
setting 102

pasting
handheld images 103
images 116
images in handheld mode 103
screens 120

pasting problems 196
playing

Live Presenter recording 136
plots

configuring lists 262
points

adding to graphs (Review 
Workspace) 276

polling students 178
polls

stopping 178
viewing results 180

Portfolio Workspace 281
print preview 198
printing

captured screens 114
PublishView™ documents 246

printing documents (.tns) 197
problems

adding 196
copying/pasting 196
deleting 197
renaming 197

problems (PublishView™ 
documents) 224–225

protecting documents (.tns) 199
PublishView™ documents 203

applications 220–223
converting 244–246
creating 204
hyperlinks 233–239
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images 240–242
objects 214–219
printing 246
problems 224–225
saving 209
sheets 226–231
text 231–233
video files 242–??

Q
questions

(x,y) numerical input 166
adding 158
adding images 158
drop points 169
equation 162
lists 170
multiple choice 160
open response 161
Self Check mode 161
suggested responses 162
using the Question application 

153
Quick Poll

images 297
opening 176
polling students 178
saving polls 180
stopping polls 178
viewing results 180

R
randomize screen option 106
read-only documents (.tns) 199
rearranging

captured screens 108
recording

Live Presenter presentation 135
starting Live Presenter recording 

135
redistributing assignments 293
refreshing

captured screens 108
removing

classes 79
files 295
hyperlinks from text 239

images 299
links 50
students from classes 77

removing adapters or cradles from 
network 15

renaming
items (Portfolio Workspace) 294
problems (PublishView™ 

documents) 225
renaming problems 197
reponses

adding suggested 162
reporting system use 35
repositioning images 298
requirements

Live Presenter 127
resetting student passwords 100
resizing

images 299
images (PublishView™ 

documents) 242
PublishView™ objects 216

resources pane
exploring 42

responses
hiding 267
marking 270
organizing 262
showing 267, 270
showing correct 255
sorting 258

Review tools 250
Review Workspace 249

S
saving

activities to your computer 53
captured images 103
captured pages 119
data as new document (Review 

Workspace) 279
documents (.tns) 61
files to Portfolio Workspace 278
handheld screens 119
images 116
Live Presenter recording 135
Portfolio items 285
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PublishView™ documents 209
saving documents (.tns) 185, 186
scaling 32
scores, editing 288
screen capture tool 104
screen captures

Capture Class 103
comparing screens 112
copying 120
Gallery view 107
hiding student names 106
Make Presenter option 113
pasting 120
showing student names 106
stacks 111
teacher preferences 106
Tiled view 107
zoom percentages 110
zooming in/out 110

screen stacks 111
screens

comparing 112
searching for activities 52
seating charts 83
selecting

images 298
working folder (PublishView™ 

objects) 219
selecting pages 194
self-check

document types 156
Self-Check mode 161
sending

files to class 54, 90
missing files 294

sending session logs 38
session logs

Activities 38
activity types 36
Attendance file 37
Class Session 37
packaging 38
sending 38

setting
zoom percentages 110

setting up
network 9

settings

teacher preferences 83
sharing

Live Presenter recording 136
shortcuts 47, 48
showing

correct responses 255
handheld in Live Presenter 132
Live Presenter handheld screen 

134
Live Presenter keypress history 

133
presenter handheld 131
responses 267
student names 106
student names in Live Presenter 

130
student responses 253, 270

showing format toolbar 188
software

overview 29
sorting

Portfolio items 291
responses 258
student information 84

Starting
Live Presenter from Class Screen 

Capture 127
starting

Live Presenter 127
Live Presenter recordings 135

status
of file transfers 99

stopping
Live Presenter 137
Live Presenter recording 135
polls 178

student handhelds
capturing 104

student responses
individualizing 264
marking correct/incorrect 270
organizing 262
showing/hiding 267, 270
viewing 252

students
adding to classes 75
arranging in seating charts 83
changing classes 84
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changing names 86
changing student IDs 86
checking login status 84
copying information 88
creating passwords 102
deleting information 77
displaying responses 253
moving information 87
polling 178
removing from classes 77
resetting passwords 100
responses 253
setting passwords 102
viewing student list 82

suggested response 156

T
teacher

add to classroom view 20
teacher account 20

changing password 21
changing user name 22

teacher data, adding 276, 277
teacher handhelds

displaying 106
teacher preferences 83
Teacher Tool Palette 155
text formatting 187
Tiled view 107
TI-Nspire(TM) Navigator(TM) 

Teacher Software
overview 29

TI-Nspire(TM) Screen Capture 
Window 118
zooming in/out 118

TI-Nspire™ CX Wireless Network 
Adapter 1, 3
adding to network 12, 14, 15
connecting to handhelds 6
removing from network 15

TI-Nspire™ Navigator™ Cradle
adding to network 12, 15
checking the LED 4
removing from network 16

TI-Nspire™ SmartView Emulator
capturing images 121, 123

TI-SmartView™

capturing images 103
DragScreen feature 103

TI-SmartView™ emulator
toolbar

text formatting 187
tools

capture class 104
screen capture 104

tools menu 30
tracking system use 35
transferring files

canceling 99
checking transfer status 99

transferring files to connected 
handhelds 64

U
ungrouping

applications 195
pages 195

user name, changing for teacher 22
Using the Preview Pane 44

V
videos (PublishView™ documents)

inserting files 242
video console 243

view options
Live Presenter 130

viewing
answers 260
assignment summaries 282
bar charts/graphs (Review 

Workspace) 256
capture class options 107
captured screens 118
copyrights 198
data (Review Workspace) 256, 

257
documents (.tns) 147, 189
individual assignments 284
Live Presenter keypress history 

132
live results 255
poll results 180
student responses 252, 260

views
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handheld/computer modes 147
seating chart 82
student list 82
table (Review Workspace) 257

W
Welcome Screen 27

navigating 28
opening 29

windows
TI-Nspire(TM) Screen Capture 

118
wireless adapter 1, 3

adding to network 12, 14, 15
connecting to handhelds 6
removing from network 15

workspaces 30, 33
Class Workspace 71
Content Workspace 41
Documents Workspace 139
exploring 41
Portfolio Workspace 281
Review Workspace 249

Z
zoom percentages 110
zooming

in/out 110, 118
PublishView™ documents 231
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