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Important Information
Except as otherwise expressly stated in the License that accompanies a 
program, Texas Instruments makes no warranty, either express or 
implied, including but not limited to any implied warranties of 
merchantability and fitness for a particular purpose, regarding any 
programs or book materials and makes such materials available solely on 
an "as-is" basis. In no event shall Texas Instruments be liable to anyone 
for special, collateral, incidental, or consequential damages in connection 
with or arising out of the purchase or use of these materials, and the sole 
and exclusive liability of Texas Instruments, regardless of the form of 
action, shall not exceed the amount set forth in the license for the 
program. Moreover, Texas Instruments shall not be liable for any claim of 
any kind whatsoever against the use of these materials by any other 
party.

License
Please see the complete license installed in C:\Program Files\TI 
Education\TI-Nspire CAS.

© 2011 Texas Instruments Incorporated

Macintosh®, Windows®, Excel®, PowerPoint®, Microsoft® Internet 
Explorer®, Mozilla® FireFox®, Java™, Google® Chrome®, Apple® 
Safari®, Vernier EasyLink®, EasyTemp®, Go!Link®, Go!Motion®, 
Go!Temp®, DataQuest™, and Blackboard™ are trademarks of their 
respective owners.
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Setting up the TI-Nspire™ Navigator™ 
Teacher Software

The TI-Nspire™ Navigator™ classroom learning system provides the 
hardware and software tools you need to set up a wireless classroom 
network.

The system is composed of two parts, hardware and software. The 
hardware creates a wireless communications network so that your 
computer can communicate with your students’ handhelds. The 
hardware includes TI-Nspire™ CX Wireless Network Adapters, TI-Nspire™ 
Navigator™ Cradles, and the TI-Navigator™ access point.

The wireless adapters are used with the TI-Nspire™ CX handhelds. The 
cradles are used with the TI-Nspire™ CX, TI-Nspire™ CX CAS, TI-Nspire™, 
or TI-Nspire™ CAS handhelds. The access point is the communication link 
used in all wireless classroom setups.

The software contains a number of tools to enhance your classroom, 
including: 

• Quick Poll. Lets you send polls to your students, receive the students’ 
responses to the polls, and review the poll results with your students.

• Screen Capture. Lets you capture your students’ handheld screens 
automatically or at specific time intervals.

• Live Presenter. Lets you display work as it is being performed on 
your handheld screen or your students’ handheld screens.

• Review and Analysis. Lets you collect and review student 
assignments, and analyze data for the entire class or for individual 
students.

You can obtain educational content on the Web at TI’s Activities 
Exchange (education.ti.com/activities). 

There are a few ways to learn to set up and use the TI-Nspire™ 
Navigator™ Teacher Software:

• The Start Here Guide—a short version of the setup process with fewer 
details.

• The Getting Started with the TI-Nspire™ Navigator™ Teacher 
Software guide, provided in both printed and PDF formats. The 
Getting Started Guide introduces you to the software and walks you 
through setting up classrooms.

• The TI-Nspire™ Navigator™ Teacher Software Guidebook, provided 
in PDF format and available at education.ti.com/guides. The 

http://otresources.ti.com
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TI-Nspire™ Navigator™ Teacher Software Guidebook gives you 
complete information on all functions of the software.

After you install the TI-Nspire™ Navigator™ Teacher Software on your 
computer, you can use the Getting Started Guide or the Software 
Guidebook as a reference for the software tools.

The process of unpacking the equipment, setting up the hardware, and 
installing the software will probably require about two hours of your 
time.

Unpacking the boxes
The TI-Nspire™ Navigator™ system product consists of TI-Nspire™ 
Navigator™ Teacher Software, an access point, and either 15 or 30 
cradles or wireless adapters, depending on your specific order. If 
necessary, you can purchase additional kits to accommodate as many as 
40 students.

Identify each item, and check the items against the following lists to 
make sure your order is complete.
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Each TI-Nspire™ Navigator™ system comes with the following items.

• 1 TI-Navigator™ access point

• 1 AC9930 power adapter (includes power supply and power cord)

• 1 USB computer cable

• 1 DVD containing system software

• The Getting Started with the TI-Nspire™ Navigator™ Teacher 
Software guide

Access point

USB cableAC9930 power adapter for the access point

One DVD
Getting Started guide
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If you purchased the TI-Nspire™ Navigator™ System for use with the 
TI-Nspire™ CX, TI-Nspire™ CX CAS, TI-Nspire™, or TI-Nspire™ CAS 
handhelds, your contents include the following items:

• TI-Nspire™ Navigator™ Cradles

• AC9940 power adapter (includes power supply and power cord)

• TI-Nspire™ Navigator™ Cradle Charging Bay

If you purchased the TI-Nspire™ CX Navigator™ System for use with the 
TI-Nspire™ CX or TI-Nspire™ CX CAS handhelds exclusively, your contents 
include the following items. Quantities will vary, depending on the 
system you purchased.

• TI-Nspire™ CX Wireless Network Adapaters

• TI-Nspire™ CX Wireless Network Adapter storage cases

Cradle charging bay

Cradles
AC9940 power adapter 
(for the charging bay)

Wireless network 
adapter

Storage case for 
the TI-Nspire™ CX Wireless Network 
Adapters
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Charging the cradles
The TI-Nspire™ Navigator™ Cradles contain rechargable batteries. You 
must charge the batteries overnight before using them in your class. 
When the cradles are fully charged, they will function all day under 
continuous use. You should recharge them each night.

The TI-Nspire™ Navigator™ Cradle Charging Bay can hold from one to 
five cradles. After you place the cradles in the charging bay, they are 
charged simultaneously until all are fully charged. If the batteries are 
fully discharged, it may take up to 12 hours to fully charge the batteries.

Note: You cannot damage the batteries by leaving them in the charging 
bay beyond the time needed to fully charge them. Also, it is not 
necessary to fully discharge the batteries before recharging them. 

Make sure you have enough (3–4) power outlets for the equipment you 
received. If necessary, obtain a plug strip so that you have plenty of 
grounded outlets.

1. Insert the small end of the AC9940 power adapter cord into the 
charging bay’s power jack.

2. Plug the other end of the adapter into a power outlet.

3. Insert each TI-Nspire™ Navigator™ wireless cradle into the 
TI-Nspire™ Navigator™ Cradle Charging Bay. Make sure the LED is 
amber.

Note: You can charge a single wireless cradle using an AC9926 adapter 
(sold separately).

Checking the LEDs
Two LEDs (small lights) at the top of each TI-Nspire™ Navigator™ 
wireless cradle blink or change colors to indicate various operations or 
status.
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The  LED indicates network activity. The  LED indicates battery-
charging status.

When the cradles are still in the TI-Nspire™ Navigator™ Cradle Charging 
Bay:

• A solid amber  LED means the wireless cradle is currently 
recharging.

• A solid red  LED means the wireless cradle does not have good 
contact with the charging bay. Reposition the cradle so it has good 
contact and the LED turns amber.

• A solid green  LED means the wireless cradle is fully charged.

Installing the handheld software
Before you use the TI-Nspire™ Navigator™ Teacher Software with your 
handhelds, make sure you have the latest operating system installed on 
all of the handhelds in order for the software to work properly.

You can use the TI-Nspire™ Navigator™ Teacher Software to update the 
handheld operating system. 

Note: After you install the latest OS on one handheld, you can use that 
handheld to install the OS on other handhelds.

1. Make sure you have connected a TI-Nspire™ handheld to your 
computer.

2. Open the TI-Nspire™ Navigator™ Teacher Software.

3. Make sure you are in the Content workspace.

The software displays a list of connected handhelds in the Resources 
pane and lets you select one.

Note: You can communicate with only one handheld at a time.

 LEDs
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4. If multiple handhelds are connected, click the handheld to which you 
want to connect.

5. Click Help >Check for Handheld OS Update.

TI-Nspire™ Navigator™ Teacher Software displays a dialog box asking 
if you want to install the OS on the handheld, save it to your 
computer, or both.

6. Click Browse if you want to change the location to save the handheld 
operating system. 

7. Click Continue.

8. Accept the license agreement and click Continue.

TI-Nspire™ Navigator™ Teacher Software displays a message box 
warning you that any unsaved data will be lost. Click Yes to continue.



8 Setting up the TI-Nspire™ Navigator™ Teacher Software

A progress screen is displayed.

9. When the operating system software has transferred to your 
TI-Nspire™ handheld, click OK. You may now disconnect the 
handheld from your computer, and the operating system software 
will install itself onto your handheld.

Note: Consider keeping one or two spare handhelds with the latest 
operating system and ample memory. It is also a good idea to have spare 
cradles on hand. If a problem occurs, you can substitute a spare part.

Setting up your TI-Nspire™ Navigator™ network 
the first time
A Network Setup wizard helps you activate the access point and wireless 
adapters and cradles for wireless communication.

If you have not used the TI-Nspire™ Navigator™ Teacher Software 
before, a prompt opens asking if you want to set up your classroom. You 
can choose to set up your classroom or continue on to the TI-Nspire™ 
Navigator™ computer home screen.

Before you begin
1. Make sure you have installed and activated the TI-Nspire™ 

Navigator™ Teacher Software on your computer.

2. If you are using TI-Nspire™ Navigator™ Cradles, make sure each 

cradle is charged (  LED is solid amber or solid green).

Note: If you are using TI-Nspire™ Wireless Network Adapters, you do not 
need to charge them. The wireless network adapters are powered by the 
TI-Nspire™ CX or TI-Nspire™ CX CAS handheld.
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Connecting the cables to the access point
1. Identify the cables.

2. Connect the AC9930 power adapter to the power jack on the access 
point.

3. Connect the USB cable to the access point.

4. Make sure the access point power light is on.

AC9930 Power adapter
USB cable

USB connection

Access point, side view

Power adapter 
jack
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Checking the access point LEDS

POWER – Indicates that the access point is receiving power from the 
power adapter.

TEST – The access point is in self-test mode. This LED should blink for a 
minute and then stop.

STATUS: 100 LINK/ACT – Indicates data transfer.

SIGNAL: 802.11 b/g – Indicates wireless link activity.

Starting the wizard
When you complete the installation of the TI-Nspire™ Navigator™ 
Teacher Software, open TI-Nspire™ Network Manager to set up your 
system. 

To open Network Manager, click Tools > Network Manager.

A setup wizard helps you through the next steps.

Note: You can run the setup wizard later by opening TI-Nspire™ 
Network Manager and clicking Actions > Network Setup Wizard.

1. Confirm that the AC9930 power adapter is connected to the access 
point.

2. Plug the AC adapter into a power outlet.

3. Plug the USB cable into the computer.

4. Click Next to proceed with the wizard.

TI-Nspire™ Network Manager displays a dialog box to select a country 
and channel.

Power Test

Status

Signal
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5. Select your country. The operating channel is automatically set to a 
default setting.

6. Click OK.

TI-Nspire™ Network Manager sends signals to the access point to add 
it to the network.

After the access point is found, the wizard displays a message.

7. Click OK.
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The software may display a message saying the access point firmware 
needs to be updated. Click Yes to update the access point firmware.

The next step is to add the TI-Nspire™ CX Wireless Network Adapters 
or TI-Nspire™ Navigator™ Cradles to your classroom network. The 
wireless adapters are used to communicate between the TI-Nspire™ 
CX handhelds and the access point. The cradles are used to 
communicate between any of the TI-Nspire™ handhelds and the 
access point. Both the wireless adapters and the cradles allow 
teachers to communicate with the students’ handhelds to transfer 
files, update the OS, and other actions.

Note: The TI-Nspire™ Network Manager wizard automatically guides 
you through the process for adding wireless adapters or cradles. You 
can automatically or manually add wireless adapters or cradles at any 
time by following the procedures below.

Adding wireless adapters or cradles automatically 
Before you use the auto-discover feature, make sure the TI-Nspire™ 
Navigator™ Cradles are charged. 

1. Click Auto-Discover Wireless Client(s).

2. Turn on each TI-Nspire™ handheld.

3. Attach the wireless adapter or the wireless cradle to each handheld. 
(See the instructions below for connecting wireless adapters or 
cradles to a TI-Nspire™ handheld.)

After a brief search for existing wireless adapters or cradles, a dialog 
box opens, listing all adapters and cradles that were found.
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4. Highlight each wireless adapter or wireless cradle you want to add, 
and click Add.

To add all of the wireless clients listed in the Available Wireless Clients 
column, click Add All.

Note: If the adapter or cradle does not appear in the Available 
Wireless Clients column after 6 minutes, try these tips:

• Check the ID numbers of the wireless adapters or cradles to see 
which ones are not connecting.

• Detach and reattach the wireless adapter or wireless cradle to the 
handheld.

• Verify that the cradle is locked. (The lock on the back of the cradle 
is in the ON position.)

5. When all of the adapters and cradles are added, click Finish.

Adding wireless adapters or cradles manually
When you add a wireless adapter or cradle manually, it immediately 
appears in the TI-Nspire™ Network Manager window. 

1. Click Manually Add Wireless Client(s).

The Add Wireless Clients by ID Number dialog box displays.

2. For each wireless adapter or cradle you are adding, identify the ID 
number on the back of the adapter or cradle, and enter it in the 
Wireless Client ID box. The ID is six digits. 

Wireless network 
adapter ID

Cradle ID
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3. Enter a nickname in the Wireless Client Nickname box (optional).

Nicknames can consist of letters, spaces, and numbers. A nickname 
must contain a minimum of 1 character and can contain a maximum 
of 64 characters.

4. Click Add Next to add another adapter or cradle if you have more 
than one wireless client to add. 

5. When you are finished adding all of the adapters and cradles, click 
Finish.

Removing adapters or cradles from an existing network
Even though a classroom network has been set up correctly, sometimes 
you may need to remove TI-Nspire™ Navigator™ Wireless Network 
Adapters or TI-Nspire™ Navigator™ Cradles from the network.

You might need to remove adapters or cradles because your access point 
has been associated with wireless clients that should belong to another 
classroom.

1. In the TI-Nspire™ Network Manager window, select the wireless 
adapters and cradles that you want to remove from the network.

2. Click Actions > Remove Selected or click .

3. Click Remove at the prompt.

The wireless client is no longer listed in the Network Manager 
window.

Connecting the handhelds to the wireless 
adapters
The TI-Nspire™ CX wireless network adapters work with the TI-Nspire™ 
CAS and TI-Nspire™ CX CAS handhelds. To connect the handheld to the 
wireless adapter, follow these steps.

1. Position the wireless adapter on top of the handheld so the connector 
on the adapter lines up with the connector on top of the handheld. 
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2. Slide the adapter into position, making sure the guides on the sides 
of the adapter slide into the grooves on the sides of the handheld.

3. Firmly press the adapter into place.

Guides for aligning with 
handheld

Connector

Grooves to 
align wireless 
adapter

Sideview of 
handheld
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Connecting the handhelds to the cradles
The cradles work with the TI-Nspire™, TI-Nspire™ CAS, TI-Nspire™ CX 
and TI-Nspire™ CX CAS handhelds. To connect the handheld to the 
cradle, follow these steps.

1. Slide the lock on the back of the cradle to the OFF position.

2. To attach the handheld, face the screen upward and slide the 
handheld onto the top of the TI-Nspire™ Navigator™ wireless cradle. 
Be sure that both sides of the handheld are inserted into both of the 
side guides.

Lock in OFF position.



Setting up the TI-Nspire™ Navigator™ Teacher Software 17

3. Press firmly to make a good connection. When properly connected, 
the TI-Nspire™ handheld appears to be sitting on top of the cradle.

4. Lock the handheld in place by sliding the lock on the back of the 
cradle to the ON position.

5. Insert each cradle into the charging bay. Make sure the LED is amber.

At the end of the school day, return the wireless cradle to the charging 
bay and charge them overnight. The cradles are charged when all the 

(power status) LEDs are solid green or amber.

Lock in ON position.
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Storing the wireless adapters and cradles
When you charge the handhelds overnight, you can leave the TI-Nspire™ 
Wireless Network Adapters attached to the handhelds before placing the 
handhelds in the TI-Nspire™ CX Docking Station. When you are ready to 
use the handhelds the next morning, the handheld should be fully 
charged, and the adapter is ready for use. 

You can remove the wireless adapter from the handheld, and store the 
adapters in the adapter storage case overnight.

If you need to store the wireless adapters for more than two weeks, 
remove the wireless adapter from the handheld, and store the adapters 
in the adapter storage case. Place the storage case in a cool, dry place.

If you need to store the TI-Nspire™ Navigator™ Cradles for more than 
two weeks, remove the handhelds from the cradles, and store the cradles 
in a cool, dry place. You cannot damage the batteries by leaving them in 
the charging bay beyond the time needed to fully charge them, or by 
leaving them in the charging bay while the charging bay is unplugged.

Checking the status of wireless adapters and 
cradles
After you have added wireless adapters or cradles automatically or 
manually, all of the adapters or cradles you added appear in the 
TI-Nspire™ Network Manager window. If the wireless adapter or cradle is 
charged and attached to a TI-Nspire™ handheld that is powered on, 
TI-Nspire™ Network Manager shows the status as connected. It may take 
up to 30 seconds to recognize the wireless client and show its status as 
connected. The status window also displays the battery status and signal 
strength.
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If the cradle is not charged, or the adapter or cradle is not connected to a 
TI-Nspire™ handheld that is powered on, TI-Nspire™ Network Manager 
displays the status as disconnected. TI-Nspire™ Network Manager 
remembers the adapter and cradle IDs you added, and the next time you 
turn on the TI-Nspire™ handheld that is connected to the adapter or 
cradle, TI-Nspire™ Network Manager recognizes it.

Note: To refresh the TI-Nspire™ Network Manager window, click 

View > Refresh or click .

Identifying selected cradles
At times you may have a problem with one or two TI-Nspire™ 
Navigator™ Cradles in your network that aren’t responding. When you 
look at the list of cradles in the TI-Nspire™ Network Manager window, 
you can identify which ones are not responding by the Status message, 
and you can see the serial numbers.

You could match the serial numbers in the window with the ones printed 
on the back of each wireless cradle. However, TI-Nspire™ Network 
Manager gives you an easier way to physically locate them. You can use 
the Identify selected command to quickly tell which cradles are working 
properly in your classroom.

1. From the list of hardware components in the TI-Nspire™ Network 
Manager window, click to select all of the working cradles. To select 
more than one cradle, press and hold the Shift or Ctrl key 
(Macintosh®: “key), and click the items you want to select.

2. Click Actions > Identify Selected.

3. Look around your classroom at the cradles in your network. Both LEDs 
on the cradles that you selected will blink rapidly with a green color. 
You can identify the cradles that are not working because their LEDs 
are not blinking.
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Now that you know where the non-working cradles are, you can add the 
cradles to the network again.

Cradle LEDs
The LEDs on each cradle use various colors and blink patterns to indicate 
data activity or power status. This can occur either when the cradles are 
seated in the charging bay or when they are outside the charging bay.

The LEDs indicate status as follows.

 Activity LED

 Battery (Power Status) LED

Creating and managing your teacher account
You can create your teacher account in the Teacher Preferences section of 
the TI-Nspire™ Navigator™ Teacher Software. Your teacher account lets 
you log in to the TI-Nspire™ Navigator™ network from your handheld. 

Color and pattern Meaning

Blinking green Indicates data transfer to and from the 
access point.

Color and pattern Meaning

In the charging bay

Solid amber The battery is charging.

Solid green Power on; charged and powered by a 
charging bay or power adapter.

Solid red The battery is charging, but does not have 
good contact with the charging bay. 
Reposition the cradle so it has good contact. 
The LED should then turn amber to indicate 
it is recharging.

Outside the charging bay

Blinking green Power on; battery powered. The battery is 
30% to 99% charged.

Blinking amber Low battery (less than 30% charged).

Blinking red Battery is critically low (less than 8% 
charged).
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After you create your teacher account, you can later change your 
password or your user name.

Creating your teacher account 
1. Use the Workspace selector to choose the Class workspace.

2. Click File > Settings > Teacher Preferences .

The Teacher Preferences dialog box opens.

 

3. Enter a username.

4. Enter a password.

5. Select or deselect the preference for the teacher icon to appear in the 
classroom view.

If you select this preference, the teacher icon will appear in the 
classroom view, and you will be included as a recipient in Send to 
Class, Collect from Class and Delete from Class operations. The 
teacher handheld screen will be included in screen captures of the 
class.

6. Select or deselect the options to randomize the order in Screen 
Capture, and to individualize the teacher handheld in Screen Capture. 

• Randomize order in Screen Capture: selecting this option captures 
and displays student screens in a random order, not the order on 
the class listing. This enables students to concentrate on the 
assignment, not whose screen they are viewing.
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• Individualize Teacher Handheld in Screen Capture: selecting this 
option shows the teacher’s screen in the screen capture.

7. Click OK.

Changing the password of your teacher account
1. Make sure you are not logged in to the TI-Nspire™ Navigator™ 

network on your handheld.

2. Click File > Settings > Teacher Preferences .

The Teacher Preferences dialog box opens.

3. Click Reset.

TI-Nspire™ Navigator™ software clears the current password.
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4. Enter a new password.

5. Click OK.

Changing the user name of your teacher account
1. Make sure you are not logged in to the TI-Nspire™ Navigator™ 

network on your handheld.

2. Click File > Settings > Teacher Preferences .

The Teacher Preferences dialog box opens.
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3. Enter a new user name.

4. Click OK.

Logging in to the TI-Nspire™ Navigator™ system 
from the handheld
The TI-Nspire™ Navigator™ classroom learning system uses both your 
computer and your students’ handhelds. In order for you and your 
students to communicate using the TI-Nspire™ Navigator™ network, 
your students must log in to the network from their handhelds.

Note: You do not have to log in to communicate with your students’ 
handhelds; you can use the Transfer Tool to delete files or send files and 
operating systems to the students handhelds. However, if you plan to 
participate from your handheld during the TI-Nspire™ Navigator™ class 
session, then you must log in to the TI-Nspire™ Navigator™ network 
from your handheld.

For more information on using a handheld, refer to the handheld 
guidebooks available at education.ti.com/guides.

Before you log in, make sure these items are ready:

• You have created your teacher account in Teacher Preferences.

• You have started a class session on your computer.

• The TI-Nspire™ handheld is ready for login. (The icon is 
blinking.)

Before your students log in, make sure you have completed these items:

• Create your students’ accounts.

• Provide your students with their usernames and, if necessary, their 
passwords.

Logging in to the TI-Nspire™ Navigator™ network
1. To log in, do one of the following:

– From the home screen of your TI-Nspire™ handheld, select 
5:Settings & Status > 5:Login.

– From a screen other than the home screen:
On a TI-Nspire™ Touchpad, press ~ > 8:Login.

On a TI-Nspire™ Clickpad, press /c > 8:Login.

2. Type your username and password. (Press e to move to the next 
field.)
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3. Select Login.

The Login Successful screen displays.

TI-Nspire™ handheld login status icons
The icons on the TI-Nspire™ CX, TI-Nspire™ CX CAS, TI-Nspire™, and 
TI-Nspire™ CAS handheld screens indicate the communication status 
between the handheld and the access point, wireless adapter, wireless 
cradle, or TI-Navigator™ network. The icons indicate status as follows.

Icon Status Meaning

Blinking The handheld is searching for an access 
point.

Solid The handheld has found an access point.

Solid The handheld is not communicating 
with the adapter or cradle. Unattach the 
handheld from the adapter or cradle, 
wait for the icon to disappear, and then 
reattach the handheld to the adapter or 
cradle.

Blinking The handheld is connected to the 
network and is ready to login.

Solid The handheld is logged in to the 
network and is fully charged.
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Getting started with the TI-Nspire™ 
Navigator™ Teacher Software

The DVD that comes with your classroom kit contains TI-Nspire™ 
Navigator™ Teacher software and TI-Nspire™ CAS Navigator™ Teacher 
software. When you install the software, both versions of the software 
are installed on your computer. 

The software automatically opens upon installation, or you can start the 
software at any time by clicking the Start > Programs > TI Tools menu 
on a PC, or the Applications menu on a Macintosh®, and then choosing 
the software you purchased.

To help you get started quickly when you open the software, the 
Welcome Screen appears with some common task options.

To begin working with documents, click on an icon or link, or close this 
screen manually. Any normal action that takes place automatically, such 
as upgrade prompts or the ability to begin using connected handhelds, 
appears after you close the Welcome Screen.

À Name. Shows software name.

À
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Á Quick Start icons. Click one of these icons to create a new document 
in the chosen application. The icon applications are Calculator, 
Graphs, Geometry, Lists & Spreasheet, Data & Statistics, Question, 
Notes, and Vernier® DataQuest. The Welcome Screen automatically 
closes and the chosen application opens.

Â Preview area. When your mouse is hovering over an application icon 
or a link in Teacher Tools, this area shows a preview of the application 
or tool. A brief description of the icon or link is also displayed at the 
top of the area.

Ã Always show this at startup. Deselect this checkbox to skip this 
screen when you open the software.

Ä Close the Welcome Screen. Click here to close this screen and begin 
working in the software.

Å Teacher Tools. Click one of these links to close the Welcome Screen 
and open the software in the chosen tool.

• View content. Opens the Content workspace, where you can find 
content on your computer, the web, or connected handhelds.

• Manage handhelds. Opens the Content workspace where you 
can see every handheld connected to your computer as well as the 
status of each.

• Transfer documents. Opens the Transfer Tool application in the 
Content workspace, where you can send documents, folders, or 
new handheld OS files to the connected handhelds.

• View classes and students. Opens the Class workspace where you 
can see the students in a class, or add new classes and students.

• Open. Opens a dialog box where you can select an existing file on 
your computer to open.

• Recent Documents. Lists the names of recently opened 
documents. As your mouse hovers over each document name, the 
first page of that document is displayed in the Preview Pane. Click 
the name of a document in the list to open that document.

Navigating through the Welcome Screen icons
Press Tab to navigate through the icons.

Press Shift + Tab to go backward through the icons.

Click to act on the selected icon. 

As you move through the icons, the Preview area displays a preview of 
the application.
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Opening the Welcome Screen manually
The Welcome Screen opens automatically when you open the software. 
To open the screen manually, do the following:

Click Help > Welcome Screen.

Exploring the TI-Nspire™ Navigator™ Teacher 
software
When you close the Welcome Screen, the TI-Nspire™ Navigator™ 
Teacher software is open to the last workspace you used. If this is your 
first time using the software, the Content workspace is open by default. 
Workspaces are explained in more detail below.

The tools described below are available in all workspaces of the 
TI-Nspire™ Navigator™ Teacher software. For more details on other 
areas of the software, see the chapter for each workspace.
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À Title bar. Shows the name of the current document and the name of 
the software. The minimize, maximize, and close buttons are located 
in the right corner.

Á Menu bar. Contains tools for working with documents in the current 
workspace, and for modifying system settings.

Â Workspace Selector. Use these tabs to switch between the Content, 
Class, Documents, Review, and Portfolio workspaces.

Note: Some tasks you perform may prevent you from immediately 
changing workspaces. If a dialog box awaits a response from you, 
enter your response and then change workspaces.

Ã Tools menu. Shows tools frequently used when working in each 
workspace. Every workspace has the Quick Poll, Capture Page, and 
Student Name Format icons. Other tool menu options change 
depending on which workspace is open. Those tools are covered in 
their respective chapters.

• The Quick Poll tool lets you send a poll to students that they 
immediately receive on their handhelds, and receive student 
responses. For more information on the Quick Poll tool, see the 
Polling Students chapter.

• The Capture Page tool lets you take a picture of an active 
document on the computer, or capture the screen of one or all 
connected handhelds. You can take several pictures, and you can 
copy/paste and save the images. For more information on 
capturing screens, see the Capturing Screens chapter.

• Student Name Format lets you choose how student names are 
displayed, either by Last Name, First Name; or hidden. 

Ä Class list. Lists classes that are currently available.

Å Class Actions button. Use this to begin, pause, resume, or end a class.

Understanding the status bar
The status bar gives you information about the network status and the 
student login status.

À
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Note: Some workspaces have additional information on their status bars. 
Any additional status bar information is covered in the respective 
workspace chapter.

The network status shows how many TI-Nspire™ CX wireless network 
adapters and TI-Nspire™ Navigator™ wireless cradles are currently 
connected to the system. You can click here to launch the Network 
Manager window.

The student login status shows how many students are currently logged 
into class, and how many students are assigned to the current class.

If class is not in session, the student login status shows "Class not 
started."

Exploring workspaces
The TI-Nspire™ Navigator™ Teacher software uses workspaces to help 
you easily access the tasks you most commonly perform. The TI-Nspire™ 
Navigator™ Teacher software has five predefined workspaces. Each 
workspace is explained in additional detail in their respective chapters.

• Content Workspace. Find and manage content on your computer, 
links to websites, connected handhelds, or Texas Instruments web 
content.

• Class Workspace. Manage classes and students, use the class record 
panel, and exchange files with students.

• Documents Workspace. Author documents and demonstrate 
mathematical concepts.

• Review Workspace. Review a collected set of documents; mark, 
show, or hide student responses; switch data views; and organize 
data.

• Portfolio Workspace. Save, store, review, and manage class 
assignments from students.

Changing language
1. Select File > Settings > Change Language.

The Choose a Language dialog box displays.

Network status Student login status
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2. Use the drop-down menu to select the desired language.

3. Restart the application for the language change to take effect.

Note: If you select Simplified Chinese or Traditional Chinese as the 
language in the TI-Nspire™ software, you should see Chinese characters 
in the menus and dialogs. If your computer uses the Windows® XP 
operating system and you do not see Chinese characters, you may need 
to install the Windows® XP East Asian Language Support package.

Using help
The Help menu is available in all workspaces. From the Help menu, you 
can perform tasks and get useful information to help you use the 
software more productively. You can:

• Open the help file (Press F1 or select Help > TI-Nspire™ Navigator™ 
Teacher Software Help)

• Activate or update the software license

• Manage your subscription

• Register your TI product

• Download the latest guidebooks

– Find information easily and quickly

– Learn how to perform new tasks more easily and efficiently

• Visit knowledge sites on the Internet to improve your proficiency with 
the product. On these sites, you can find information about how to 
use TI products as well as lessons, quizzes, and other instructive 
activities shared by educators. 

Note: Activities may vary depending on your geographical language.

• Explore online troubleshooting

• Run TI-Nspire™ diagnostics

• Check for updates to the software and handheld operating systems

• Find information about the current software version

• Open the Welcome Screen



Getting started with the TI-Nspire™ Navigator™ Teacher Software 33

Note: Aside from viewing your current software version, you must be 
connected to the Internet to perform any of these tasks. You do not need 
to be connected to the Internet to view your current version of software 
as shown in the About command.
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Using the Content Workspace

Use this workspace to move, copy, and transfer content between your 
computer and connected handhelds.

À Menu - Contains tools for working with documents and modifying 
system settings.

Á Workspace Selector. Click here to choose between the Content, 
Class, Documents, Review, and Portfolio workspaces.

Note: Some tasks you perform may prevent you from immediately 
changing workspaces. If a dialog box awaits a response from you, 
enter your response and then change workspaces.

Â Content Workspace toolbar. Shows frequently performed tasks. Each 
of these are explained in more detail in "Using menus and toolbar 
icons"later in this chapter.

Ã Resources pane. Select content here. You can select from files on 
your computer, web content, and connected handhelds.

Ä Class session controls. Choose a class from a list of available classes. 
You can begin, pause, resume, or end a class.

À
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Å Content Pane. Shows what you have selected in Resources. You can 
resize this pane by selecting the splitter bar between this pane and 
the Preview Pane.

Use your context menu or select Options  in the Content pane to 
perform common tasks related to the item or area you select, or to 
change how the information displays.

To open an item from the Content pane, double-click on that item.

To sort on a column of items in the Content pane, click on the top of 
that column.

Search within any item selected in Resources. Type the search 
keyword in the Search box at the top right of the Content pane and 
press Enter.

Æ Preview Pane. Shows more information about the content you have 
selected in the content pane. The content appearing in this pane 
varies, depending on the item you have selected. You will see the 
name and a description of the selected item; actions you can perform; 
and files included, if applicable (such as lesson bundle files).

Ç Status bar. See additional details below.

Understanding the status bar
The status bar gives you information about the network status and the 
student login status.

The network status shows how many TI-Nspire™ CX Wireless Network 
Adapters and TI-Nspire™ Navigator™ Cradles are currently connected to 
the system. You can click here to launch the Network Manager window.

The student login status shows how many students are currently logged 
into class, and how many students are assigned to the current class.

If class is not in session, the student login status shows "Class not 
started."

Network status Student login status
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Exploring the Resources pane

À Local Content. Helps you navigate to the correct file on your 
computer. Local Content expands and collapses to show these folders:

• Desktop

• My Documents (PC)

• Documents (Macintosh®)

When you select an item in Local Content, the file structure appears 
in the Content pane. When you select an item in the Content pane, it 
previews the item in the Preview pane.

You can add your own shortcuts in Local Content.

Á Links. You can add your own links to this section. There are also a few 
existing links to Texas Instrument sites. Links from the latest version of 
the TI-Nspire™ Navigator™ Teacher software are added when you 
upgrade.

Click on any link to open the link in a new browser. 

Note: You can add your own links to the Links section, but you 
cannot save website links to the Web Content section.

For those users in the United States, you can search US standards or 
textbooks by selecting the search option from Links.
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Â Web Content. Links to Texas Instruments activities that are available 
to a user who is connected to the Internet. You can save material that 
you find on these sites to your computer and share items through 
Local Content pane and Connected Handhelds. You cannot save 
website links to the Web Content section.

Note: The web content available to you varies depending on your 
region. If there is no online content, this section will not appear.

When you select an item in Web Content, the list of activities display 
in the Content pane, with a preview of the activity selected appearing 
in the Preview pane.

Ã Connected Handhelds. When you select Connected Handhelds in the 
left pane, the Content pane displays detailed information about each 
handheld including a name, battery status for the rechargeable and 
AAA batteries, the storage space, and the OS in use. Error messages 
also appear showing, for instance, connection errors.

Exploring the Content pane
By default, the Desktop and My Documents folders are listed. Use the 
Content pane as you would a file manager to navigate to folders and 
files on a computer. 

À Toolbar. Tools used to locate folders and files.

À
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Á Content pane. Lists the folders and files from the location you have 
selected in Resources: your computer, web content, or connected 
handhelds.

Â Preview pane. Shows details about a selected folder or file in the 
Content pane.

Using the content pane tool bar
The Content pane tool bar provides tools needed to locate folders and 
files.

À Options. Click ¤ to open the drop-down menu to access options for 
working with files and folders.

Á Look in: field. Contains the path and name of the current folder and 
file. Click ¤ to view a history of accessed folders.

Â Click  to move up a level in the folder hierarchy.

Ã Click  to create a new folder. The new folder is added to the list. 
Type a name for the folder and and press Enter.

Ä Search. Enter a search keyword or phrase and press Enter to find all 
files containing that word or phrase.

Using the Preview pane
In the Content workspace, detail about a selected folder, file, or lesson 
bundle is displayed in the Preview pane.

À Á Â Ã Ä
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À A thumbnail preview of the selected folder, file, or lesson bundle. If a 
lesson bundle is empty, this space is blank. If you selected a folder 
that does not contain supported files, an error message is displayed.

Á If a document has multiple pages, use the forward arrow  to 
preview the next page. The backward arrow becomes active so you 
can move backward through the pages. If working with a lesson 
bundle, you can choose to preview a TI-Nspire™ document within the 
bundle.

Â If a lesson bundle is selected the Files window appears above the 
Details window listing the files in the lesson bundle. You can double-
click a file to open it.

Ã If a folder is selected, the Details window shows the name of the 
folder, the path where the folder is located, and the date modified. 

À Á

Â

Ã
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For document files and lesson bundle files, the Details window shows 
the name, the date the file was modified, the file size, and whether 
or not the file is read only.

Using shortcuts
Use this option to add drives, folders, or lesson bundles containing 
frequently used files to the Local Content list. If a selected folder does 
not contain TI-Nspire™ (.tns or .tnsp) files, an error message is displayed.

Adding a shortcut
To access files on a drive, you must add the shortcut to the Local Content 
pane. To add a shortcut:

1. Navigate to the folder that contains the frequently used files.

2. Click , then select Create Shortcuts. 

The folder is added to the list of folders under the Local Content 
heading in the Resources pane.

Deleting a shortcut
To delete a shortcut:

1. From the Local Content list, select the folder to be deleted.

2. Right-click on the selected folder to open the context menu, then 
click Remove Shortcut.

Note: You cannot remove default shortcuts.

Working with Links
By default, the Links list contains a list of links to Texas Instruments web 
sites. Click a link to launch your web browser and access the web site. 

Using the Links toolbar
When you select Links in the Resource pane, the tools on the toolbar are 
specific to working with links. Use these tools to add, edit, or delete links 
from the list. You can also move a link up or down in the list.
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Adding a link
Complete the following steps to add a link to the list of Links in the 
Resource pane.

1. Click  to open the Add Link dialog box.

2. Type the name of the link.

3. Type the URL in the Address field.

4. Click Add Link.

The link is added to the bottom of the list of existing links.

Click ¤ to open the drop-down menu to access options for 
working with links.

Click this icon to add a link to the list.

Select an existing link, then click this icon to edit the link’s 
attributes.

Click this icon to delete a link. You cannot delete a default link.

Select a link and click this icon to move the link up in the list.

Select a link and click this icon to move the link down in the list.
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Editing an existing link
Complete the following steps to edit an existing link.

1. Select the link you want to change.

2. Click  to open the Edit Link dialog box.

3. Make needed changes to the name of the link or to the URL.

4. Click Edit Link.

The changes are applied to the link.

Removing a link
Complete the following steps to delete a link.

1. Select the link you want to delete.

2. Click .

3. Click Remove Link when the confirmation window opens. 

The link is removed from the list.

Note: You cannot delete a default link.

Moving links up or down in the list
You can change the order of the links in the list to suit your needs.

Click  to move a selected link up one place in the list.

Click  to move a selected link down one place in the link.

Click , then select Move to Top of List to relocate a selected link 
to the top of the list.
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Click , then select Move to Bottom of List to relocate a selected 
link to the bottom of the list.

Using Web Content
Web Content provides links to online activities on Texas Instruments web 
sites. You can save material found on these web sites to your computer 
and share items using the Local Content pane and Connected Handhelds. 

Information provided for each activity includes the name of the activity, 
the author, the date the activity was posted, the size of the file, and the 
source.

Note: An Internet connection is required to access Texas Instruments web 
sites.

À Tool bar.

Á Column headings.

Â List of available activities.

Ã List of the files contained in the activity.

Ä Details about the selected activity. A description of the file is also 
shown.

À
Á

Â

Ã

Ä
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Sorting the list of activities
Use the column headings to sort the information in the list of activities or 
add additional column headings. By default the list is displayed in 
alphabetical order by Name. 

• Click the Name heading to list activities in reverse alphabetical order. 
Click the heading again to return to A to Z order.

• Click the Author heading to list the activities in alphabetical order by 
author name.

• Click the Posted Date heading to list the activities in order from 
newest to oldest or from oldest to newest.

• Click the Size heading to list the activities according to file size.

• Click the Source heading to list the activities in order by source.

• Right-click a column heading to add column headings. Choose from 
the following options: Description, Grade Level, Subject Area, Device, 
Activity Time, Subject, Topic, and Category.

Filtering the list of activities
By default, all available activities are listed in the Content pane. Options 
on the tool bar enable you to filter the activities by subject, topic, and 
category. You can also search for an activity using a keyword search. 

To find all activities related to a particular subject:

1. In the Subject field, click ¤ to open the drop-down menu.

2. Select a subject.

All activities related to the selected subject are listed. 

3. To narrow the search, click ¤ in the Topic field to view and select a 
topic related to the subject selected. 

4. Use the Category field to narrow the search even further. Click ¤ to 
select a category related to the selected subject and topic.

Using keywords to search for an activity
Complete the following steps to search for an activity using a keyword or 
phrase.

1. Type a keyword or phrase in the "Filter by Keyword" field.

2. Press Enter.

All activities that contain the keyword or phrase are listed.
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Opening an activity
1. Select the activity you want to open.

2. Double-click the activity to open it, or click , then select Open. 

The Open Activity dialog box opens with a list of all documents 
related to the selected activity.

You can open a .tns or .tsnp in the TI-Nspire™ software. Other files 
such as Microsoft® Word and Adobe® PDF files will open in their 
respective applications.

3. Double-click the activity to open it, or click ¢, then select Open.

The selected .tns document opens in the Documents workspace.

Saving an activity to your computer
Complete the following steps to save an activity to your computer. 

1. Select the activity you want to save. The file details are displayed in 
the bottom half of the window.

2. Click Save this Activity to Computer.

3. When the Save Selected Files dialog opens, navigate to the folder 
where you want to save the file.
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4. Click Save. A copy of the activity is saved to your computer as a lesson 
bundle.

Copying an activity
Complete the following steps to copy an activity. Once the activity is 
copied to the clipboard, you can paste the activity into a folder on your 
computer, then drag the activity to your list of shortcuts in the Local 
Content pane.

1. Click the activity you want to copy to select it.

2. Use one of the following methods to copy the activity to the 
clipboard:

• Select the activity with your mouse, then drag it to a folder in the 
Local Content list.

• Click , then select Copy. 

• Right-click, then select Copy from the context menu.

• Right-click on a file in the Files list, then select Copy.

• Click , which is located in the tool bar.

The activity is copied to the clipboard.

3. Open a folder on your computer, then select Edit > Paste to copy the 
activity to the selected folder.

Sending an activity to a connected handheld
Complete the following steps to send a selected activity to connected 
handhelds. 

1. Select the file you want to send to connected handhelds. The file 
details are displayed in the bottom half of the window.

2. Use one of the following options to send the file to the selected 
handhelds:

• To "drag and drop" the file, click the file to select it, then drag it 
to the Selected Handhelds label to transfer to the file to all 
connected handhelds. To transfer the file to a specific handheld, 
drag the file to a specific handheld name.

• To transfer the file using Transfer Tool:

Note: You can not use the Transfer Tool to transfer files to 
handhelds while a class is in session.
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– From the tool bar, click , then select Send to Connected 
Handhelds.

– Click , then select Send to Connected Handhelds.

The Transfer Tool opens.

3. Select the file, then click Start Transfer. 

The Status window opens and the Stop Transfer button is enabled. 
The selected files and folders are transferred to the selected 
handhelds.

4. When the transfer is complete, close the Transfer Tool.

Working with connected handhelds
You can use the Content workspace to perform a number of tasks. To use 
the features described in this section, your handhelds must be turned on 
and connected by one of these means:

• The TI-Nspire™ Docking Station or TI-Nspire™ CX Docking Station

• TI-Nspire™ Navigator™ Cradle

• TI-Nspire™ CX Wireless Network Adapter

• A direct connection through a standard USB cable

Note: The tasks in this section can only be performed by TI-Nspire™ 
handhelds. TI-84 handhelds are not supported in these tasks. 
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Viewing content on connected handhelds
When you select a handheld in the Resources pane, all files and folders 
on the handheld appear in the Content pane. When a .tns file is selected, 
you will have to click for screen capture preview within the Preview 
pane.

À Workspace selector - Click here to choose between the Content, 
Class, Documents, Review, and Portfolio workspaces.

Á Connected Handhelds - Shows all handhelds that are connected 
and turned on.

Â Options - Available options vary depending on the task you select 
under Resources.

Ã Content pane - When Connected Handhelds is selected, the Content 
pane shows details about handhelds that are connected and turned 
on:

• Name of handhelds

• Li-ion (rechargeable) battery charge (Critical 2%, 25%, 50%, 75%, 
100%, or "--" to indicate no battery is present)

• AAA battery charge (Critical 2%, 25%, 50%, 75%, 100%, or "--" to 
indicate no battery is present)

• Storage / Size - The amount of space left and available on the 
handheld

À
Â

Ã

Ä

Á
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• OS version - The operating system in use

Ä Preview Pane - Illustrates the selected handheld. If you click on a 
handheld file in the Content pane, the Preview pane shows a preview 
of that file.

When you select a handheld, all files and folders on the handheld appear 
in the Content pane. When a file or folder is selected, the details are 
displayed in the Preview pane. Click the icon to preview the document.

Details about the selected folder or file are shown in the Preview pane.

To view the files in a folder, double-click the folder name in the 
Content pane. The files in the folder are listed in the Content pane. 

To preview the contents of a .tns file, select Click here to preview 
document.

Details for selected folder Details for selected file
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Using Identify Selected to locate handhelds
If you are using the TI-Nspire™ Docking Station or the TI-Nspire™ CX 
Docking Station, you can use this feature to locate handhelds.

1. Be sure that the handhelds are turned on and that the docking 
station is connected to your computer. 

2. Use the Workspace selector to select the Content Workspace.

3. Click Tools > Identify Selected or right-click on the handheld in the 
Content pane.

Both LED lights on the TI-Nspire™ CX Docking Station or TI-Nspire™ 
Docking Station under the slot where the handheld is located will 
blink for 30 seconds.

Performing tasks on connected handhelds

You can perform tasks on connected handhelds in the same way you do 
in other areas of the software:

• Toolbar icons

• Edit menu

• Drag and drop

• Keyboard shortcuts

• Context menu option

Note: For easier reading, descriptions here do not always show every 
way to perform a task.

For more information about working with handhelds, including 
connecting and saving to handhelds, please see Working with documents 
in the TI-Nspire™ Software.

Managing files on a connected handheld
When working with files on connected handhelds in the Content 

workspace, use the Options drop-down menu  or the context menu 
to manage files.

Option How it Works

Open Open a file on a connected handheld:

• Select the file you want to open.

• Select Open. The document opens in the Documents 
Workspace.
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Save to 
Computer

Save a copy of the selected file on your computer.

• Select the file you want to save.

• Select Save to Computer. The Save Select File dialog 
box opens.

• Navigate to the folder where you want to save the 
file.

• Click Save.

Copy/Paste Create a copy of a file:

• Select the file you want to copy.

• Select Options > Copy to copy the file to the 
clipboard.

• To paste the file in another location, navigate to the 
new location, then select Options > Paste. 

Note: If you don’t select a new location, the copied 
file is pasted with a new name "Copy of ..."

Delete Delete a file on a connected handheld:

• Select the file you want to delete.

• Select Delete.

• Click Yes when the Warning dialog opens. Click No 
to cancel.

Refresh To refresh the list of files, select Options > Refresh.

Rename To rename a file on a connected handheld:

• Select the file you want to rename.

• Select Rename

• Type the new name and press Enter.

Up a Level Go up a level. This option is available when you select a 
file inside a folder.

New Folder Create a new folder:

• Click New Folder.

• Type a name for the new folder.

• Press Enter.

Option How it Works
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Renaming handhelds
You can rename the handhelds that you store in the TI-Nspire™ 
Navigator™ Teacher Software.

Note: Renaming a handheld does not affect student login information.

1. Right-click on the handheld(s) in the Content pane.

2. Select Rename.

3. Edit the name(s). 

4. Press Enter to go to the next name to edit.

To exit the Edit mode, click on an area of the screen outside the handheld 
names. You will also leave the Edit mode after you click Enter on the last 
name you edit.

Working with lesson bundles
Many lessons or activities contain multiple files. For example, teachers 
usually have a teacher version of a file, a student version, assessments, 
and sometimes supporting files. A lesson bundle is a container that 
enables you to group all files needed for a lesson together. Using lesson 
bundles enables you to:

• Add any type of file (for example, .tns, .tnsp, .doc, .pdf, .ppt) to a 
lesson bundle. You can send lesson bundles to connected handhelds; 
however, only the .tns files are sent to the handheld.

• View all the files in a lesson bundle using the TI-Nspire™ Navigator™ 
Teacher Software.

• Group all files associated with one lesson in one place.

• E-mail one lesson bundle file to teachers or students instead of 
looking for and attaching multiple files.
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Creating a new lesson bundle
Complete the following steps to create a new lesson bundle.

1. In the Content workspace, navigate to the folder in Local Content 
where you want to save the lesson bundle.

2. Click  or select File > New Lesson Bundle.

The new lesson bundle file is created with a default name and placed 
in your list of files.

3. Type a name for your lesson bundle and press Enter to save the file.

Adding files to a lesson bundle
By default, lesson bundles are empty when created. Use any of the 
following methods to add files to a lesson bundle:

• "Drag and drop" any file into a selected lesson bundle. This method 
moves the file to the lesson bundle. If you delete the lesson bundle, 
the file is deleted from your computer. You can recover the file from 
the Recycle Bin.

• Copy and paste any file into a selected lesson bundle.

• Use the "Add files to lesson bundle" option. This method copies the 
selected files into the lesson bundle. The file is not moved from its 
original location.

Using the Add files lesson bundle option
To add files to the bundle using the Add files to lesson bundle option:

1. In the content pane, select the lesson bundle name. The file details 
are displayed in the Preview pane. 

Note: If the lesson bundle already contains files, the first file in the 
lesson bundle is also shown in the Preview pane.
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2. To open the lesson bundle window:

• Double-click the lesson bundle file.

-or-

• Right-click the name of the lesson bundle to open the context 
menu, then select Open.

3. Click Add Files to Lesson Bundle to open the Add window.

Note: You can also click Add Files to Lesson Bundle in the Preview 
Pane.
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4. Use the file manager in the Add window to navigate to and select the 
file you want to add to the lesson bundle.

• You can select multiple files at one time if they are located in the 
same folder by pressing and holding the Ctrl key (Macintosh®: “) 
while clicking each file name.

• If files are located in different folders, you can add them one at a 
time.

• You cannot create a folder within a lesson bundle or add a folder 
to a lesson bundle.

• You cannot add a lesson bundle to a lesson bundle.

5. Click Add to add the file to the bundle. 

The file is copied to the lesson bundle and the file name is listed in 
the lesson bundle window.

6. Repeat this process until all needed files are added to the lesson 
bundle.

Selecting files to create a lesson bundle
Within the software, you can select multiple files in a folder, then create 
the lesson bundle. You cannot add a folder or a lesson bundle to a lesson 
bundle.

1. In the Content workspace, navigate to the folder that contains the 
files you want to bundle.

2. Select the files. To select multiple files, select the first file then hold 
down the Shift key and select the last file in the list. To select random 
files, select the first file, then hold down the Ctrl key (Macintosh®: “) 
and click the other files to select them.
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3. Click , then select Lesson Bundles > Create Lesson Bundle from 
selected.

4. A new lesson bundle is created and placed in the open folder. The 
lesson bundle contains copies of the selected files.

5. Type a name for the lesson bundle and press Enter.

Opening a lesson bundle
To view and work with files within a lesson bundle, complete one of the 
following steps to open the lesson bundle file.

Double-click the lesson bundle name.

Select the lesson bundle, then right-click and select Open from the 
context menu.

Select the lesson bundle, click , then select Open.

Select the lesson bundle, then press Ctrl + O. (Macintosh®: “ + O).

When you open a lesson bundle, the files in the bundle are displayed in a 
separate window.

Note: You cannot open a lesson bundle outside of the TI-Nspire™ 
software. For example, if you open the folder using the file manager on 
your computer and double-click the lesson bundle name, it does not 
automatically launch the software.

Opening files within a lesson bundle
You can open any file within a lesson bundle on your computer if you 
have the program associated with the file type. 

• When you open a .tns or .tnsp file, the file opens in the Documents 
workspace in the TI-Nspire™ software.

• When you open another file type, it launches the application or 
program associated with that file. For example, if you open a .doc 
file, it opens in Microsoft® Word.

Use one of the following options to open a file within a lesson bundle:
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Double-click the lesson bundle, then double-click a file within the 
lesson bundle.

Within a lesson bundle, select the file, then click ¢ or right-click the 
file name and select Open from the context menu.

Managing files in a lesson bundle
You can open, copy/paste, delete, and rename files in an existing lesson 
bundle. To locate and work with files in an existing lesson bundle:

1. In the content pane, select the lesson bundle name. The Files window 
shows the file details in the Preview pane.

2. In the Preview pane, select the file name in the Files window and click 
¢ to open the context menu.

3. Select the action you want to perform:

• Click Open. TI-Nspire™ and PublishView™ documents open in the 
Documents workspace. When you open another file type, it 
launches the application or program associated with that file.

• Click Copy to place the file in the clipboard. 

• Navigate to a folder on your computer or select a connected 
handheld, then right-click and select Paste to place the copied file 
in a new location.
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• Click Delete to delete the file from the lesson bundle. Use caution 
when deleting a file from a lesson bundle. You should ensure files 
contained in the bundle are backed up if you need the files for 
future use.

• Click Rename to give the file a new name. To cancel this action, 
press the Esc key.

• To add more files to the lesson bundle, click Add Files to Lesson 
Bundle.

• Click Refresh to update the list of files in the bundle.

• Select Package Lesson Bundle to create a .tilb file. A .tilb file is a 
packaged file that contains all the contents of a lesson bundle and 
allows you to e-mail it.

• Click Send to Connected Handhelds to open the Transfer Tool 
and send the selected file to a handheld. Only .tns files can be sent 
to handhelds.

Managing lesson bundles
Use the options menu or the context menu to copy, delete, rename, or 
send a lesson bundle to connected handhelds. You can also create a 
shortcut to the lesson bundle. 

Note: You cannot add a folder or a lesson bundle to a lesson bundle.

1. Select Local Content in the Resources pane.

2. In the Content pane, navigate to the lesson bundle you want to work 

with, then right-click to open the context menu or click  to open 
the menu of options.
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3. Select the action you want to perform:

• Click Open to open the lesson bundle.

• Click Copy to place the lesson bundle file in the clipboard. 

• Navigate to a folder on your computer or select a connected 
handheld, then right-click and select Paste to place the copied file 
in a new location.

• Click Delete to delete the lesson bundle. Use caution when 
deleting a lesson bundle. You should ensure files contained in the 
bundle are backed up if you need the files for future use.

• Click Refresh to update the list of files in the bundle.

• Click Rename to give the lesson bundle a new name. To cancel this 
action, press the Esc key.

• To move up a level in the folder hierarchy, click Up a Level.

• To add the lesson bundle to the list of shortcuts in Local Content, 
select Create Shortcut.

• To add more files to the lesson bundle, select Lesson Bundles > 
Add Files to Lesson Bundle.

• Select Lesson Bundles > Package Lesson Bundle to create a .tilb 
file.

• Click Send to Connected Handhelds to open Transfer Tool and 
send the lesson bundle to connected handheld. Only .tns files are 
sent to the handheld.

Packaging lesson bundles
Packaging lesson bundles creates a "package" folder with a .tilb file. This 
file contains all contents of the lesson bundle. You must package the 
lesson before you can e-mail the lesson bundle (.tilb file) to colleagues or 
students.

To package a lesson from the Content workspace:

1. Select Local Content in the Resources pane.

2. Select the lesson bundle you want to package in the Content pane. 
The Lesson Bundle details are displayed in the Preview pane.

3. Use one of the following methods to create the package:

• From the Preview pane, click ¢ in the Files window, then select 
Package Lesson Bundle.

• From the Content pane, Right-click the lesson bundle name, then 
select Lesson Bundles > Package Lesson Bundle.
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A dialog box opens confirming that the lesson bundle was created.

4. Click Yes to open the folder where the lesson package is stored. Click 
No to skip this step and close the dialog box.

E-mailing a lesson bundle
After a lesson bundle is packaged, you can e-mail the .tilb file to other 
teachers or students. To attach the lesson bundle to an e-mail:

1. In your e-mail client, select attach, then navigate to the Lesson Bundle 
.tilb folder.

2. Make sure you open the package folder and select the .tilb file to 
attach to the email. You cannot email the .tilb folder.

Sending files to a class
You can send folders and TI-Nspire™ document files (.tns), 
LearningCheck™ files (.edc) and CABRI™ files (.fig) to your whole class, 
members of the class currently logged in, or to individual students. Class 
must be in session for you to send files. 

When you send a file to the whole class, all students currently logged in 
will receive the file immediately. Students not logged in will receive the 
file when they log in.

Note: File types .edc and .fig are converted to .tns files when they are 
sent to the class.

1. From the Content pane, navigate to the file you want to send to the 
handheld.

2. Click the file to select it.

3. Click Send to Class , or Select File >Send to > Send to Class to 
send the file to the class.

The Select individual(s) dialog box opens.
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4. Select the student(s) to whom you want to send the file:

• To send the file to the whole class, click Class . To send the file 
only to class members who are currently logged in, check the 
Logged in only checkbox.

• To send the file to an individual student, click Individuals  and 
then click the student.

Note: If you had any students selected in the classroom area, the 
software already has them selected.

• Use the Send to handheld folder drop-down list to toggle 
between the class folder or the top level folder on the handheld.

5. Click Finish.

The file transfer appears in the Class Record in the Class workspace.

Understanding the rules of content transfer
Using the Content Workspace, you can transfer content between the 
web, your computer, and connected TI-Nspire™ handhelds.

Note: You cannot transfer content to a TI-Nspire™ handheld from a 
TI-84 keypad.

Types of content you can transfer
Items you can manipulate include:
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• Folders

• Supported files

Methods you can use to transfer content
You can transfer content several ways (again, depending on the content):

• "Drag and drop"

• Copy and paste 

• Save to Computer 

• Send to Connected Handhelds

You can perform these tasks using the following methods:

• Dialog boxes that automatically launch when you transfer the 
content

• Menu options

• Context menu shortcuts (select the content and right-click your 
mouse for options)

• Standard computer keyboard shortcuts such as Ctrl + C to copy and 
Ctrl + V to paste, for example.

• Icons appearing on the workspace

Using menus and toolbar icons
The menu items are listed in the following table, as well as the 
corresponding toolbar icon and keyboard shortcut.

.tco .tns .edc .fig

.tcc .tnc .tno .tilb

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut

File

Open - Opens a supported file you 
have selected.

Windows®: 
Ctrl + O

Macintosh®: 
ì“ + O
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Save to Computer - Displays a file 
browser window to let you save an 
existing TI-Nspire™ file to your 
computer.

Windows®: 
Ctrl + S

Macintosh®: 
ì“ + S

Send To Class - Sends a selected file or 
folder to the class, if a class is in 
session.

Send To Connected Handhelds - 
Sends a selected file or folder to a 
handheld, using the Transfer Tool. 
Class can not be in session. Opens a 
dialog box on the handhelds to save 
the file.

New Folder - Creates a new folder at 
the location you have selected.

Windows®: 
Ctrl + N

Macintosh®: 
ì“ + N

New Lesson Bundle - Creates a new 
lesson bundle at the location you have 
selected.

Windows®: 
Ctrl + L

Macintosh®: 
ì“ + L

Add Files to Lesson Bundle - Adds the 
selected file(s) to a selected lesson 
bundle.

Package Lesson Bundle - Packages 
the selected lesson bundle.

Settings 8 Opens a dialog box that 
lets you change language.

Change Language 8 Select a 
different language.

Exit - Closes all applications, with a 
prompt to save the current document.

Windows®: 
Alt + F4

Macintosh®: 
ì“ + Q

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Edit

Copy - Copies the selected 
information. 

Windows®: 
Ctrl + C

Macintosh®: 
ì“ + C

Paste - Inserts content, either cut or 
copied, at a chosen location. 

Windows®: 
Ctrl + V

Macintosh®: 
ì“ + V

Rename - Lets you rename a file or 
folder. 

Windows®: F2

Delete - Deletes the selected objects, 
text, applications, pages, or problems.

Delete key

Select All - Select all items. Windows®: 
Ctrl + A

Macintosh®: 
ì“ + A

Content 8

Create Shortcut - Customize the 
content under Local Content by 
creating shortcuts.

Remove Shortcut - Remove 
shortcuts that you have created in 
Local Content.

Note: You cannot remove default 
shortcuts.

Links 8

Add New Link - Customize the 
links in the resources pane by 
creating a new link.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Remove Link - Remove links that 
you have created in the resources 
pane.

Note: You cannot remove default 
links.

Edit Link - Change the name of the 
link.

Move to Top of List - Move the 
selected link to the top of the list 
of links.

Move Up - Move the selected link 
up one level in the list of links.

Move Down- Move the selected 
link down one level in the list of 
links.

Move to Bottom of List - Move 
the selected link to the bottom of 
the list of links.

View

Local Content - Changes the left panel 
to display a selected Local Content 
item.

Windows®: 
Ctrl + Shift + C

Macintosh®: 
ì“ + Shift + C

Links - Changes the left panel to 
display a selected My Links item.

Windows®: 
Ctrl + Shift + L

Macintosh®: 
ì“ + Shift + L

Web Content - Changes the left panel 
to display a selected Web Content 
item.

Windows®: 
Ctrl + Shift + W

Macintosh®: 
ì“ + Shift + W

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Connected Handhelds - Changes the 
left panel to display a selected item 
from a connected handheld.

Windows®: 
Ctrl + Shift + H

Macintosh®: 
ì“ + Shift + H

Refresh - Refreshes the view to display 
any changes and updates in the 
menus, text, and so forth.

Windows®: 
Ctrl + R

Macintosh®: 
ì“ + R

Up a Level - When viewing a Local 
Content item, lists all levels available 
so you can move up a level.

Show Columns - Shows the columns 
in the current content pane view. A 
bullet next to an item denotes sort 
status.

Sort by - When viewing web content, 
lets you sort by subject matter.

Tools

Quick Poll - Opens a tool that allows 
you to send a quick poll to students 
with connected handhelds. Class must 
be in session.

Windows®: 
Ctrl + Alt + Q

Macintosh®: 
ì“ + Alt + Q

Screen Capture 8 Capture the screen 
of the active page of a current 
document, or a student’s connected 
handheld, or an entire class of 
connected handhelds.

Capture Class - Captures the 
screens of selected student 
handhelds or the entire class in the 
active class session. The captured 
images are located in the Class 
Capture tool.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Capture Page - Captures the active 
page of the current document. The 
captured image is located in the 
TI-Nspire™ Screen Capture tool.

Windows®: 
Ctrl + J

Macintosh®: 
ì“ + J

Capture Selected Handheld - 
Captures the screen of a selected 
student or teacher handheld. The 
captured image is located in the 
TI-Nspire™ Screen Capture tool.

Transfer Tool - Opens a tool that 
allows you to send files to multiple 
students at once when a class is not in 
session.

Windows®: 
Ctrl + T

Macintosh®: 
ì“ + T

 Identify Selected Handheld - Enables 
you to locate a handheld in the 
TI-Nspire™ Docking Station or 
TI-Nspire™ CX Docking Station. 

Install Handheld OS - On a handheld 
you have selected, allows you to select 
an OS file that you have downloaded 
and install it on the handheld.

Network Manager - Opens a tool that 
lets you check the status of wireless 
adapters and cradles, and lets you add 
or remove wireless adapters, cradles, 
and access points from the classroom 
system.

Class

Select Class 8 Displays a list of 
available classes for you to select.

Begin/End Class - Begins a class sesion. 
If a class session is currently running, 
ends the class session.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Pause/Resume Class - Pauses a class 
session. If a class session is paused, 
resumes the class session.

Student Name Format 8 Allows you 
to choose how student names are 
displayed, either by Last Name, First 
Name; User Name; Display Name; 
Student ID; or hidden.

Window

Reset Workspace Layout - Returns 
your workspace to its original layout.

Content Workspace - Opens the 
Content Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage content from 
your computer, links to websites, 
connected handhelds, or Texas 
Instruments web content.

Windows®: 
Ctrl + Alt + 1

Macintosh®: 
ì“ + Alt + 1

Class Workspace - Opens the Class 
Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage classes and 
students, use the class record panel, 
and exchange files with students.

Windows®: 
Ctrl + Alt + 2

Macintosh®: 
ì“ + Alt + 2

Documents Workspace - Opens the 
Documents Workspace in the 
TI-Nspire™ Navigator™ Teacher 
Software. Use this workspace to 
author documents and demonstrate 
mathematical concepts.

Windows®: 
Ctrl + Alt + 3

Macintosh®: 
ì“ + Alt + 3

Review Workspace - Opens the 
Review Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to review a collected set of 
documents, manage student 
responses, and organize data.

Windows®: 
Ctrl + Alt + 4

Macintosh®: 
ì“ + Alt + 4

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Portfolio Workspace - Opens the 
Portfolio Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to save, store, review, and 
manage class assignments from 
students.

Windows®: 
Ctrl + Alt + 5

Macintosh®: 
ì“ + Alt + 5

Screen Capture Window - Opens the 
TI-Nspire™ Screen Capture tool, where 
you can view page captures and 
selected handheld screen captures.

Help

TI-Nspire™ Help - Provides help 
information for this software.

F1

Activate... your trial copy of the 
software. This option is available only 
if you use a trial version of the 
software.

Manage Subscription 8 

Purchase Now - Purchase the 
software.

Reminder Settings - Renew your 
license or change your reminder 
settings, if your software is already 
activated.

Register - When connected to the 
Internet, opens a page where you can 
register your product.

Download Latest Guidebook - When 
connected to the Internet, opens a 
page where you can download the 
latest product guidebooks. 

Visit education.ti.com - When 
connected to the Internet, opens the 
Texas Instruments Education 
Technology site.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Visit Activities Exchange - When 
connected to the Internet, opens the 
Activities Exchange site.

Explore Online Troubleshooting - 
When connected to the Internet, 
opens the online troubleshooting site.

Run TI-Nspire Diagnostics - Run 
diagnostics and send a report to TI 
support.

Check for Software Updates - Locates 
software updates.

Check for Handheld OS Update - Is 
active when a handheld is selected.

About - Displays TI-Nspire™ 
Navigator™ product information.

Welcome Screen - Opens the 
Welcome Screen, which gives you 
quick links to commonly used features.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Using the Transfer Tool

When a class is not in session, you can transfer individual files or entire 
folders containing files from your computer to connected TI-Nspire™ 
handhelds using the Transfer Tool. With the Transfer Tool, you can 
transfer one or more files or documents to one or more handhelds 
without requiring students to log in.

You can transfer the following files to TI-Nspire™ handhelds.

Notes:

• You can transfer more than one operating system file at a time. 
However, you can only transfer one operating system file with the 
same file extension at a time. For example, you can transfer a .tcc and 
a .tco file at the same time, but only one .tcc file at that time.

• When transferred, the TI-Nspire™ Navigator™ Teacher Software 
converts .edc and .fig file types into .tns file types.

Transfer Tool interface
The Transfer Tool window contains a Setup tab and a Status tab.

Setup tab
The Setup tab allows you to select files you want to transfer and select a 
destination folder.

Files File Extensions

Operating systems (OS) .tcc (for TI-Nspire™ CX CAS handhelds)

.tco (for TI-Nspire™ CX handhelds)

.tnc (for TI-Nspire™ CAS handhelds)

.tno (for TI-Nspire™ handhelds)

Documents .edc (LearningCheck™ TI-84 file)

.fig (CABRI™ TI-84 file)

.tilb (TI-Nspire™ Lesson Bundle)

.tns (TI-Nspire™ document)
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The Setup tab includes the following features:

Feature Description

Add to Transfer List Click to add files or folders with files to the 
Transfer List. The Transfer List indicates the 
File Name (or folder name), the 
Destination Folder and the Size of the file 
or folder (in KB) you want to transfer.

Remove Selected Click to remove selected files and folders 
from the Transfer List. This option becomes 
active when you add files to the Transfer List.

Delete all files and 
folders before transfer

Check to clear all files and folders on a 
handheld before a file transfer.

Edit Destination Folder Select to change the destination folder for 
the files you want to transfer.
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Status tab
The Status tab is only active when a transfer is in progress.

When you start a transfer, the Transfer Tool automatically switches to the 
Status tab. The Status tab allows you to view the progress and status of 
files as they transfer and provides the following information:

Notes:

• If no transfers are active, the following message is displayed: “No 
transfers are active. Use the Setup tab to configure and start the 
transfer.”

• During a transfer, no options are available on the Setup tab.

Opening the Transfer Tool
Before you can use the Transfer Tool, you must end any running class 
sessions.

Information Description

File Name Indicates the file name and extension.

Folder/Handheld ID Indicates the destination folder and the handheld 
ID.

Status Indicates the completion status, the progress bar, 
or any error message. Error messages include low 
battery, wrong handheld type, memory full, and 
lost connectivity.
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To open the Transfer Tool, complete one of the following actions:

• From the menu bar, select Tools > Transfer Tool.

• From the keyboard, press Ctrl+T (Macintosh®: “+T).

• From the toolbar, click  and select Send to Connected 
Handhelds from the dropdown menu.

• In the Content workspace, select the files or folders you want to 
transfer, and drag and drop them in the Resources pane on to 
Connected Handhelds (top level for all connected handhelds) or 
an on to an individual handheld.

By default, the Transfer Tool opens on the Setup tab.

Adding files or folders to the Transfer List
You must add files or folders to the Transfer List before you can start a 
transfer.

Note: You can only add a folder that contains files to the Transfer List.

To add files or folders to the Tranfer List, complete the following steps:

1. In the Transfer Tool window, click Add to Transfer List.

The Add to Transfer List window opens with the Files tab active.
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2. To add files to the Transfer List, navigate to the folder or folders that 
contain the files you want to transfer. Click Select to add highlighted 
files to the Transfer list.

• On the Files tab, you can see both files and folders, but you cannot 
select folders. You must drill down and select a file.

• To select multiple files within a folder, press and hold the Ctrl key 
(Macintosh®: “) while selecting files.

3. To add folders containing files, click the Folders tab, then navigate to 
the folder you want to select. Click Select to add the highlighted 
folders to the Transfer List.

Note: To select multiple folders, press and hold the Ctrl key 
(Macintosh®: “) while selecting folders.

Selected files and folders are displayed in the Transfer Tool window.

Note: You can only add one operating system file type to the Transfer 
List. If you attempt to add more than one operating system file type, 
you receive the following error message.

Removing files or folders from the Transfer List
You can remove files or folders from the Transfer List that you no longer 
want to transfer.
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To remove files or folders from the Transfer List, complete the following 
steps:

1. In the Transfer Tool window, select files or folders you want to 
remove.

Note: To select multiple files or folders, press and hold the Ctrl key 
(Macintosh®: “) while selecting each file or folder.

2. Click Remove Selected.

The files or folders are removed from the Transfer List.

Editing the destination folder
Except for an operating system file, you can change the destination 
folder for any file or folder in the Transfer List.

By default, the Transfer Tools creates the destination folder as “Transfer-
date.” The date format is based on the user’s preferred language setting 
and location. For example, the default date format for the United States 
is mm-dd-yy. If you change your preferred language setting, this default 
date format changes.

To change the destination folder, complete the following steps:

1. In the Transfer List, select a file or folder.

2. Complete one of the following actions:
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• From the Edit Destination Folder dropdown, select “Top level of 
handheld” or any available folder.

• In the Edit Destination Folder dropdown, type a new destination 
folder name.

Note: Folder names can contain alphanumeric characters and can 
include slashes ( / and \ ). You cannot use double slashes ( // and \\ ) and 
some special characters (? | : * " " < > | ).

3. Click Change.

The destination folder in the Transfer List changes for the files or 
folders you selected.

Deleting all handheld files and folders
You can use the Transfer Tool to delete all files and folders on a 
connected handheld. Use this feature to delete existing files and folders 
to baseline student handhelds and ensure that only the files you want 
students to work with are on the handhelds.

By default, the Transfer Tool disables this setting. If selected, the new 
setting becomes the default the next time you open Transfer Tool.

To delete all files and folders from a connected handheld without 
transferring files, complete the following steps:

1. In the Transfer Tool window, check Delete all files and folders 
before transfer.
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2. Click Start Transfer.

The Confirm dialog box opens.

3. Click Yes to confirm.

The Transfer Tools switches to the Status tab, which displays the status 
and progress of the deleting process. 

Starting a transfer
After you have added all files and folders to the Transfer List and selected 
other options as necessary, you can start the transfer. You can transfer 
operating system files and documents at the same time.

To start a transfer, complete the following steps:

1. Connect one or more TI-Nspire™ handhelds.

If handhelds are not connected, the Status tab indicates “No Active 
Connected Handhelds” when you start a transfer.

2. From the Resources pane, complete one of the following actions:

• To transfer files to one or more TI-Nspire™ handhelds, select the 
individual handhelds.
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• To transfer files to all connected TI-Nspire™ handhelds, select 
Connected Handhelds (top level).

3. In the Transfer Tool window, click Start Transfer.

The Transfer Tool window switches to the Status tab and displays the 
transfer information.

• The progress bar disappears when a transfer is complete.

• During a transfer, the Transfer Tool indicates which handhelds are 
connected and successfully received files.

• If a handheld disconnects and then reconnects during a transfer, 
the Transfer Tool indicates the status of completed transfers, and 
resumes transferring other files as necessary.

Stopping file transfers
You can stop a file transfer at any time.

To stop a file transfer, complete the following steps:

1. In the Tranfer Tool, click Stop Transfer. 

The Confirm dialog box opens.

2. Click Yes to confirm.

The Transfer Tool stops transferring and switches back to the Setup 
tab.

• If a connected handheld has already received files, those files 
remain on the handhelds.

• Files remain in the Setup tab until you close the Transfer Tool, or 
until you remove them by selecting the files and clicking Remove 
Selected.

Closing the Transfer Tool
When you have completed transferring files and folders, close the 
Transfer Tool.

To close the Transfer Tool, click Close.

• You cannot close the Transfer Tool if a transfer is active.
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• When closed, the Transfer Tool clears files and folders you added 
to the Transfer List.

• When closed, the Transfer Tool keeps the last Delete all files and 
folders before transfer setting.
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Using the Documents Workspace

Use this workspace to create, modify, and view TI-Nspire™ and 
PublishView™ documents, and to demonstrate mathematical concepts.

À Menu. Contains tools for working with documents and modifying 
system settings.

Á Workspace Selector. Click here to choose between the Content, 
Class, Documents, Review, and Portfolio workspaces.

Note: Some tasks you perform may prevent you from immediately 
changing workspaces. If a dialog box awaits a response from you, 
enter your response and then change workspaces.

Â Documents Workspace toolbar. Shows frequently performed tasks. 
Each of these are explained in more detail in "Using menus and 
toolbar icons" later in this chapter.

Ã Documents toolbox. Contains tools such as the Tool Palette, Page 
Sorter, TI-SmartView™, Utilities, and Content Explorer. Click each icon 
to access the available tools.

Ä Toolbox panel. Options for the selected tool are displayed in this 
area. For example, click the Tool Palette icon to access tools needed to 
work with the active application.

À

Á

Â

Ã

Ä

Å

Æ

Ç
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Å Class session controls. Choose a class from a list of available classes. 
You can begin, pause, resume, or end a class.

Æ Workspace. Shows the current document and enables you to perform 
calculations, add applications, and add pages and problems. Only one 
document at a time is active (selected). Multiple documents appear as 
tabs. 

Ç Status bar. Shows the current problem number, enables you to access 
document settings, toggle between Computer mode and Handheld 
mode, and adjust the contrast or scaling of documents in the 
workspace.

Using the Documents Toolbox
The Documents Toolbox contains tools needed for working with 
TI-Nspire™ documents and PublishView™ documents.

When you click a toolbox icon, the associated tools appear in the toolbox 
panel. Refer to the following table for information about each tool. 

Icon What you can do

Tool Palette

In a TI-Nspire™ document, the Tool Palette provides a 
menu of tools available for working with an 
application. The tools are specific to the active 
application. 

In a PublishView™ document, the Tool Palette allows 
you to insert TI-Nspire™ applications or documents, 
multimedia objects, image files, and video files into a 
PublishView™ document.

Page Sorter

Displays all the problems in a document and all the 
pages in each problem. 

Move to another page by clicking on the desired 
page.

You can rearrange and delete pages, copy a page 
from one problem and paste it into another, and copy 
a problem from a document and paste it into another.

Note: In a PublishView™ document, the Page Sorter 
is not available.
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Exploring the Tool Palette
The tool palette provides a menu of tools available for working with an 
application. The tools are specific to the active application. In the 
following example, the tool palette is open showing the application 
menu for the Calculator application.

TI-SmartView™

Demonstrate concepts on the handheld to the class. 
The TI-Smartview™ tool works almost the same as the 
handheld.

Note: Content is only displayed on the 
TI-Smartview™ small screen when the document is in 
Handheld Only or Handheld + SideScreen modes.

Utilities

Provides access to the following utilities:

• Math Templates

• Symbols

• Catalog

• Math Operators

• Unit Conversions

• Libraries

Content 
Explorer

Displays a list of files and folders on your computer 
and on connected handhelds. You can use the 
Content Explorer to create and manage lesson 
bundles, and transfer documents between your 
computer and connected handhelds without 
changing workspaces. 

Icon What you can do



86 Using the Documents Workspace

À The Documents Toolbox menu.

Á Tool Palette. Provides a menu of tools available for working with an 
application. Click ¢ to open the sub-menu for each option.

Â Click  to close and click  open the Tool Palette.

À

Á Â
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Exploring the Page Sorter Panel
The following example shows the Documents Toolbox with the Page 
Sorter open.

À The Documents Toolbox menu.

Á Click the minus sign (-) to collapse the view. Click the plus sign (+) to 
open the view and show the problems and pages in the document.

Â Scroll bar. The scroll bar is active when there are too many pages to 
show in the panel.

Exploring the TI-SmartView™ Panel
Use the TI-Smartview™ tool to demonstrate concepts on the handheld to 
the class. The TI-Smartview™ tool works almost the same as the 
handheld.

À

Á Â
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Note: Content is only displayed on the TI-Smartview™ small screen when 
the document is in Handheld Only view, or in Handheld + SideScreen 
view and the document workspace is in Handheld mode.

À The Documents Toolbox menu.

Á Handheld Selector. Click ¤ to select which handheld to show in the 
panel:

• TI-Nspire™ CX

• TI-Nspire™ Touchpad

• TI-Nspire™ Clickpad

Select how to show the handheld:

• Normal

• High contract

• Outline

Â View selector. Click ¤ to select the handheld view:

• Handheld only

• Keypad + SideScreen

• Handheld + SideScreen

Note: You can also change these options in the TI-SmartView™ 
Options window. Click File > Settings > TI-Smartview Options to 
open the window.

Ã When the Handheld Only display is selected, check Always in front to 
keep the display in front of all other open applications.

À

Á

Ã

Â
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Changing TI-SmartView™ options
You can change the location of the folder used to save TI-SmartView™ 
files on your computer. You can also change the keypad, faceplate, and 
view options.

To change TI-SmartView™ options:

1. Click File > Settings > TI-Smartview Options.

2. Click Browse to change the folder used to save TI-SmartView™ files. 
Choose the desired folder and click OK. By default, the files and 
folders in this location appear in the My Documents folder.

3. Make changes to keypad, faceplate, and view as desired.

4. Click OK.

Exploring the Utilities panel
The Utilities panel provides access to the math templates and operators, 
special symbols, catalog items, and libraries that you need when working 
with documents. In the following example, the Math templates tab is 
open.



90 Using the Documents Workspace

À The Documents Toolbox menu.

Á Math Templates are open. Double-click a template to add it to a 
document. Click the Math Template tab to close the template view.

To open the Symbols, Catalog, Math Operators, and Libraries , click 
the tab.

Â Wizards On check box. Turn this option on to use a wizard to enter 
function arguments.

Ã Tabs for opening views where you can select and add symbols, 
catalog items, math operators, and library items to a document. Click 
the tab to open the view.

Exploring the Content Explorer panel
Use the Content Explorer panel to:

• See a list of files on your computer

• See a list of files on any connected handheld

• Create and manage lesson bundles

• Update the OS on connected handhelds

• Transfer documents between your computer and connected 
handhelds without changing workspaces.

À

Á

Â

Ã
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À The Documents Toolbox menu.

Á Shows files on your computer and the name of the folder where the 
files are located. Click ¤ to navigate to another folder on the 
computer.

Â The list of folders and files within the folder named in the Look In: 
field. Right-click on a highlighted file or folder to open the context 
menu listing available actions for that file or folder.

Ã Click  to close the list of files. Click  to open the list of files.

Ä Options menu. Click ¤ to open the drop-down menu of actions you 
can perform on a selected file:

• Open an existing file or folder

• Move (navigate) up one level in the folder hierarchy

• Create a new folder

• Create a new lesson bundle

• Rename a file

• Copy a selected file

• Paste a file copied to the clipboard

• Delete the selected file

• Select all files in a folder

À

Á

Â

Å

Ã

Ä

Æ
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• Package a lesson

• Refresh the view

• Install OS 

Å Connected handhelds. Lists the connected handhelds. Multiple 
handhelds are listed if more than one handheld is connected to the 
computer. 

Æ The name of the connected handhelds. To display the folders and files 
on a handheld, double-click the name.

Click ¤ to navigate to another folder on the handheld.

Using the workspace
The space on the right side of the window provides an area for creating 
and working with TI-Nspire™ and PublishView™ documents. This space 
provides a view of the document so that you can add pages, add 
applications, and perform all work. Only one document at a time is 
active. 

You can view TI-Nspire™ documents in one of two modes: Computer 
mode or Handheld mode. Both modes remember the last size and file 
location you used. 

• Handheld mode. View documents as they appear on the handheld 
screen. The screen size is limited as it would be on the handheld.



Using the Documents Workspace 93

• Computer mode. This is the default view in the software.

Understanding the status bar
The status bar provides information about the current document, and 
enables you to toggle between between Handheld and Computer mode, 
and adjust the view of the document.

À Network status. shows how many TI-Nspire™ CX Wireless Network 
Adapters and TI-Nspire™ Navigator™ Cradles are currently connected 
to the system. You can click here to launch the Network Manager 
window.

Á Student login status. The student login status shows how many 
students are currently logged into class, and how many students are 
assigned to the current class. If class is not in session, the student login 
status shows "Class not started."

Â Problem and page number. References the current document.

Ã Settings. Click here to view or change General or Graphs & Geometry 
settings.

Ä Document View. Toggle between Handheld mode and Computer 
mode.

Á ÄÂ ÅÀ Ã
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Å Boldness/Scale. When working with a document in Computer mode, 
use the Boldness slider to make the lines and text of a document 
thicker or thinner.

When working with a document in Handheld mode, use the Scale 
slider to increase the size of the document in the workspace, up to 
200%.

Viewing and changing document settings
Settings control how information is displayed in TI-Nspire™ and 
PublishView™ documents.

• General settings control how all numbers, including elements or 
matrices and lists, are displayed. You can change the default settings 
at any time and you can specify the settings for a specific document.

• Graphs & Geometry settings control how information is displayed 
in open problems and in subsequent new problems. When you 
change the Graphs & Geometry settings, the selections become the 
default settings for all work in these applications.

Changing General settings
Complete the following steps to customize the general settings that are 
applied to your document.

1. Create a new document or open an existing document.

2. From the status bar, double-click Settings, or select File > Settings > 
Document Settings to open the Document Settings window.

When you open Document Settings the first time, the default General 
Settings are displayed.
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3. Press Tab or use your mouse to move through the list of settings. Click 
¤ to open the drop-down list to view the available values for each 
setting.

Field Value

Display Digits • Float

• Float1 - Float12

• Fix0 - Fix12

Angle • Radian

• Degree

• Gradian

Exponential Format • Normal

• Scientific

• Engineering

Real or Complex Format • Real

• Rectanglular

• Polar
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4. Use the mouse to click and select the desired setting.

5. Choose one of the following options:

• To apply the customized settings to all documents, click Make 
Default.

• To apply the settings to the current document only, click OK.

• To restore default settings, click Restore.

• Click Cancel to close the window without making changes.

Changing Graphs & Geometry settings
Complete the following steps to customize the application settings for 
graphs and geometry.

1. Create a new document or open an existing document.

2. From the status bar, double-click Settings or select File > Settings > 
Document Settings to open the Document Settings window.

3. Click Graphs & Geometry to view the current settings.

Calculation Mode • Auto

• CAS: Exact

• Approximate

Note: Auto mode displays an answer 
that is not a whole number as a fraction, 
except when a decimal is used in the 
problem. Exact mode (CAS) displays an 
answer that is not a whole number as a 
fraction or in symbolic form, except 
when a decimal is used in the problem.

Vector Format • Rectangular

• Cylindrical

• Spherical

Base • Decimal

• Hex

• Binary

Unit System (CAS) • SI

• Eng/US

Field Value
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4. Press Tab or use your mouse to move through the list of settings. Click 
¤ to open the drop-down list to view the available values for each 
setting. 

5. Use the mouse to select the desired setting.

6. Click a check box to enable or disable an option. 

Field Values

Display Digits • Auto

• Float

• Float1 - Float12

• Fix0 - Fix12

Graphing Angle • Auto

• Radian

• Degree

• Gradian

Geometry Angle • Auto

• Radian

• Degree

• Gradian

Checkbox Operation when selected

Automatically hide plot 
labels

Plot labels are displayed only when 
selected, grabbed, or hovered.
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7. Choose one of the following options:

• To apply the customized settings to all documents, click Make 
Default.

• To apply the settings to the current document only, click OK.

• To restore default settings, click Restore.

• Click Cancel to close the window without making changes.

Sending files to a class
You can send folders and TI-Nspire™ document files (.tns), 
LearningCheck™ files (.edc) and CABRI™ files (.fig) to your whole class, 
members of the class currently logged in, or to individual students. Class 
must be in session for you to send files. 

When you send a file to the whole class, all students currently logged in 
will receive the file immediately. Students not logged in will receive the 
file when they log in.

Note: File types .edc and .fig are converted to .tns files when they are 
sent to the class.

1. From the Content Explorer, navigate to the file you want to send to 
the handheld.

2. Click the file to select it.

3. Click Send to Class , or Select File >Send to > Send to Class to 
send the file to the class.

The Select individual(s) dialog box opens.

Show axis end values A numeric label is displayed at the 
least and greatest values visible on 
an axis

Show tool tips for function 
manipulation

Shows helpful information as you 
manipulate function graphs

Automatically find a point 
of interest

Shows zeros, minima, and maxima 
for graphed functions and objects 
while tracing function graphs.

Checkbox Operation when selected
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4. Select the student(s) to whom you want to send the file:

• To send the file to the whole class, click Class . To send the file 
only to class members who are currently logged in, check the 
Logged in only checkbox.

• To send the file to an individual student, click Individuals  and 
then click the student.

Note: If you had any students selected in the classroom area, the 
software already has them selected.

• Use the Send to handheld folder drop-down list to toggle 
between the class folder or the top level folder on the handheld.

5. Click Finish.

The file transfer appears in the Class Record in the Class workspace.

Sending files to a handheld
You can send folders, lesson bundles, and TI-Nspire™ document files 
(.tns), LearningCheck™ files (.edc) and CABRI™ files (.fig) to connected 
handhelds.

Note: File types .edc and .fig are converted to .tns files when they are 
sent to the handheld.
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1. From the Content Explorer, navigate to the file you want to send to 
the handheld.

2. Click the file to select it.

3. Select File >Save to Handheld to open the Save to Handheld 
window.

Working with Lesson Bundles
Many lessons or activities contain multiple files. For example, teachers 
usually have a teacher version of a file, a student version, assessments, 
and sometimes supporting files. A lesson bundle is a container that 
enables teachers to group all files needed for a lesson together. In the 
Documents workspace, you can view, edit, demonstrate, and save 
updates to .tns files in a lesson bundle. You can use lesson bundles to:

• Add any type of file (for example, .tns, .tnsp, .doc, .pdf, .ppt) to a 
lesson bundle. You can send lesson bundles to connected handhelds; 
however, only the .tns files are sent to the handheld.

• View all the files in a lesson bundle using the TI-Nspire™ Software.

• Group all files associated with one lesson in one place.

• E-mail one lesson bundle file to teachers or students instead of 
looking for and attaching multiple files.

In the Documents workspace, options for working with lesson bundles 
are in the Content Explorer.

Creating a new lesson bundle
Complete the following steps to create a new lesson bundle.

1. Click  in the Documents Toolbox panel to open the Content 
Explorer.

2. Click  to open the drop-down menu, then select New Lesson 
Bundle.

The new lesson bundle file is created and placed in your list of files.

3. Type a name for your lesson bundle and press Enter to save the file.

Adding files to a lesson bundle
By default, lesson bundles are empty when created. Use any of the 
following methods to add files to a lesson bundle:

• "Drag and drop" any file into a selected lesson bundle. This method 
moves the file to the lesson bundle. If you delete the lesson bundle, 
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the file is deleted from your computer. You can recover the file from 
the Recycle Bin.

• Copy and paste any file into a selected lesson bundle.

• Use the "Add files to lesson bundle" option. This method copies the 
selected files into the lesson bundle. The file is not moved from its 
original location.

Using the Add files to lesson bundle option
To add files to the bundle using the Add files to lesson bundle option:

1. From the Content Explorer, double-click the lesson bundle file to 
open the lesson bundle window. The window name reflects that 
name of the lesson bundle.

2. Click Add Files to Lesson Bundle to open the Add window.

3. Use the file manager to navigate to and select the file you want to 
add to the lesson bundle.

• You can select multiple files at one time if they are located in the 
same folder.

• If files are located in different folders, you can add them one at a 
time.
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• You cannot create a folder within a lesson bundle or add a folder 
to a lesson bundle.

• You cannot add a lesson bundle to a lesson bundle.

4. Click Add to add the file to the bundle. 

A copy of the file is added to the bundle and is now listed in the 
lesson bundle window.

5. Repeat this process until all needed files are added to the lesson 
bundle.

Opening a lesson bundle
To view and work with files within a lesson bundle, complete one of the 
following steps to open the lesson bundle file.

Double-click the lesson bundle name.

Select the lesson bundle, then right-click and select Open from the 
context menu.

Select the lesson bundle, click , then select Open.

Select the lesson bundle, then press Ctrl + O. (Macintosh®: “ + O).

When you open a lesson bundle, the files in the bundle are displayed in a 
separate window.

Note: You cannot open a lesson bundle outside of the TI-Nspire™ 
software. For example, if you open the folder using the file manager on 
your computer and double-click the lesson bundle name, it does not 
automatically launch the software.

Opening files within a lesson bundle
You can open any file within a lesson bundle on your computer if you 
have the program associated with the file type. 

• When you open a .tns or .tnsp file, the file opens in the Documents 
workspace in the TI-Nspire™ software.
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• When you open another file type, it launches the application or 
program associated with that file. For example, if you open a .doc 
file, it opens in Microsoft® Word.

Use one of the following options to open a file within a lesson bundle:

Double-click the lesson bundle, then double-click a file within the 
lesson bundle.

Within a lesson bundle, select the file, then click ¢ or right-click the 
file name and select Open from the context menu.

Managing files in lesson bundles
You can open, copy/paste, delete, and rename files in an existing lesson 
bundle. To locate and work with files in an existing lesson bundle:

1. In the Documents Tool box panel, open the Content Explorer.

2. Navigate to the folder where the lesson bundle is saved.

3. Click ¢ or double-click the lesson bundle name to open the New 
Lesson Bundle window.

4. Select the file you want to work with and right-click to open the 
context menu.

5. Select the action you want to perform:

• Click Open to open the file in the workspace

• Click Copy to place the file in the clipboard. 

• Navigate to a folder on your computer or select a handheld, then 
right-click and select Paste to place the copied file in a new 
location.

• Click Delete to delete the file from the lesson bundle.

• Click Rename to give the file a new name. 

6. When finished, click Close to close the window.

Packaging lesson bundles
Packaging lesson bundles creates a "package" folder with a .tilb file. This 
file contains all contents of the lesson bundle. You must package the 
lesson before you can e-mail the lesson bundle (.tilb file) to colleagues or 
students.

To package a lesson from the Documents workspace:

1. Open the Content Explorer.

2. Navigate to the folder where the lesson bundle is saved.
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3. Select the lesson bundle you want to package.

4. Right-click to open the context menu, then select Package Lesson.

A dialog box is displayed confirming that the lesson bundle was 
created.

5. Click Yes to open the folder where the lesson package is stored. Click 
No to close the dialog box.

E-mailing a lesson bundle
After a lesson bundle is packaged, you can e-mail the .tilb file to other 
teachers or students. To attach the lesson bundle to an e-mail:

1. In your e-mail client, select the option needed to attach a file, then 
navigate to the .tilb folder.

2. Make sure you open the folder and select the .tilb file to attach to the 
email. You cannot email the .tilb folder.

Managing lesson bundles
Use the options menu or the context menu to copy, delete, rename, or 
send a lesson bundle to connected handhelds. You cannot add a folder to 
a lesson bundle.

1. In the Content Explorer, right-click the lesson bundle name or click 

 to open the context menu.
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2. Select the action you want to perform. If an action is not available, it 
is grayed out.

• Click Open to open the lesson bundle.

• Click Up One Level to navigate up one level in the folder 
hierarchy.

• You cannot add a folder to a lesson bundle. If you select Open 
Folder, a new folder is added to the folder where the lesson 
bundle is stored.

• Select New Lesson Bundle to create a new lesson bundle. The 
new lesson bundle is not added to the existing lesson bundle—it is 
created in the same folder as the existing lesson bundle.

• Click Rename to change the name of the lesson bundle. Press the 
Esc key to cancel this action.

• Click Copy to copy the lesson bundle to the clipboard.

• Navigate to another folder, then click Paste to copy the lesson 
bundle in another location.

• Click Delete to delete the lesson bundle. Use caution when 
deleting a lesson bundle. You should ensure files contained in the 
bundle are backed up if you need the files for future use.

• Select All highlights all files in the open folder. This action does 
not apply to lesson bundles.

• Click Package Lesson to create a .tilb file.

• Click Refresh to update the list of files in the open folder.

Sending lesson bundles to connected handhelds
1. In the Content Explorer, select the lesson bundle you want to send.

2. Using your mouse, "drag and drop" the lesson bundle file to a 
connected handheld. You can also copy the lesson bundle, then paste 
it to a connected handheld.

The lesson bundle is transferred to the handheld as a folder with the 
same name. Only supported files are transferred to the handheld.

Updating the handheld OS
You can install or update the operating system (OS) on a connected 
handheld from the Documents workspace. To install a handheld 
operating system, follow these steps.

1. Ensure the updated OS file is downloaded to your computer and that 
all work on the handheld is saved.
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2. Open the Content Explorer to see Connected Handhelds.

3. Select the handheld you want to update.

4. Click  and then select Install OS or select Tools > Install 
Handheld OS from the menu bar. The Select Handheld OS File dialog 
box opens.

5. Navigate to the folder where the operating system file is located.

6. Select the file name, then click Install OS. 

• If you are upgrading a TI-Nspire™ CX handheld, select 
TI-Nspire.tco

• If you are upgrading a TI-Nspire™ CX CAS handheld, select 
TI-Nspire.tcc

• If you are upgrading a TI-Nspire™ handheld, select TI-Nspire.tno

• If you are upgrading a TI-Nspire™ CAS handheld. select 
TI-Nspire.tnc

A progress screen is displayed.

7. When the operating system software has transferred to your 
handheld, click OK. You may now disconnect the handheld from your 
computer, and the operating system software will install itself onto 
your handheld.

Using menus and toolbar icons
The menu items for the Documents Workspace are listed in the following 
table, as well as the corresponding toolbar icon and keyboard shortcut.
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Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut

File

New TI-Nspire™ Document - Creates 
a new TI-Nspire™ document.

Windows®: 
Ctrl + N

Macintosh®: 
“ + N

New PublishView™ Document - 
Creates a new PublishView™ 
document.

Windows®: 
Ctrl + Shift + N
Macintosh®: 
“ + Shift + N

Open Document - Displays a file 
browser window to let you open an 
existing document.

Windows®: 
Ctrl + O

Macintosh®: 
ì“ + O

Close - Closes the active document. Windows®:
Ctrl + W

Macintosh®: 
“ + W

Save Document - Displays a file 
browser window to let you save an 
existing TI-Nspire™ file to your 
computer. If you have previously saved 
the file, Save Document automatically 
saves the changes, in the same 
location and with the same name.

Windows®: 
Ctrl + S

Macintosh®: 
ì“ + S

Save As - Save an existing file with a 
new name.

Send To Handheld - Save the 
document to a connected handheld.

Convert to 8 Convert a TI-Nspire™ 
(.tns) document to a PublishView™ 
(.tnsp) document, or convert a 
PublishView™ document to a 
TI-Nspire™ document.
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Export 8 Export the file to a web page 
as a Java™ applet, or as html copied to 
the computer’s clipboard.

Send To Class - Sends a selected file or 
folder to the class, if a class is in 
session.

Start / Stop Quick Poll - Starts a poll if 
a question document is open and a 
class is in session. Stops a poll if one is 
currently active.

Print - Opens a dialog box that lets 
you choose options to print the 
current document.

Windows®:
Ctrl + P

Macintosh®: 
“ + P

Settings 8 Change a language, or edit 
and save document settings or 
TI-SmartView™ options.

Change Language 8 Select a 
different language.

Document Settings 8 Set how 
numbers are displayed in 
documents, and set Graphs & 
Geometry settings.

TI-SmartView Options 8 Change 
the settings for the TI-SmartView™ 
emulator.

Document Properties - View and edit 
author and copyright information, 
and set the document as Read Only.

View Copyright Information - View 
the copyright information for the 
current document.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Recent Documents - Access recently 
opened documents.

Exit - Closes all applications, with a 
prompt to save the current document.

Windows®: 
Alt + F4

Macintosh®: 
ì“ + Q

Edit

Undo - Undo the last action 
performed. 

Redo - Reverses the Undo action. 

Cut - Cut selected information. Cut 
copies the content to the computer’s 
clipboard. 

Windows®:
Ctrl + X

Macintosh®: 
“ + X

Copy - Copy the selected information. 
Copy also copies the content to the 
computer’s clipboard.

Windows®: 
Ctrl + C

Macintosh®: 
ì“ + C

Paste - Inserts content, either cut or 
copied, at a chosen location. 

Windows®: 
Ctrl + V

Macintosh®: 
ì“ + V

Rename - Lets you rename a file or 
folder. 

Windows®: F2

Delete - Deletes the selected objects, 
text, applications, pages, or problems.

Delete key

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Page Layout 8 Select from different 
page layouts, swap application 
positions on a page, select 
applications, and group or ungroup 
open applications on a page.

Select Layout - Select from a 
variety of layouts to view up to 
four applications at one time on 
the same page.

Select Application - Select one 
application from the group on the 
page. The border is highlighted to 
indicate the selected application.

Swap Application - Change the 
positions of multiple applications 
on a page.

Delete Application - Delete one of 
the applications on a page.

Delete Page - Delete a page from 
a problem.

Group - Adds the next page to the 
current page. Group up to four 
applications in a single page.

Ungroup - Separates the 
applications on the page to 
individual pages.

Color 8 Apply color to a background, 
a selected line, or text.

Fill - Add color to the background 
of selected text.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Line - Change the color of a line.

Text - Change the color of selected 
text.

View

Computer - View document in 
Computer mode.

Windows®: 
Alt +Shift+C 
Macintosh®: 
option + Shift 
+ C

Handheld - View document in 
Handheld mode.

Windows®: 
Alt +Shift+H

Macintosh®: 
option + Shift 
+ H

Scaling/Boldness - In Handheld mode, 
adjust the document size to 100%, 
150%, or 200%. In Computer mode, 
adjust the thickenss of text and lines 
to Normal, Bold, or Extra Bold.

Previous Page - Navigate back one 
page in the document.

Windows®: 
Ctrl + !

Macintosh®: 
option + !

Next Page - Navigate forward one 
page in the document.

Windows®: 
Ctrl + "

Macintosh®: 
option + "

Insert

Problem - Add a problem to a 
document.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Page - Add a page to a problem with 
one of the following applications:

Windows®: 
Ctrl + I

Macintosh®: 
ì“ + I

Calculator

Graphs

Geometry

Lists & Spreadsheet

Data & Statistics

Notes

Vernier DataQuest

Question

Image - Insert an image into a 
document. (The application must 
support images).

Text - Insert a text box into a 
PublishView™ document.

Program Editor 8 Insert a new 
program; or open, import, or view an 
existing program.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Sensor Console - Opens the sensor 
console on the bottom of the active 
application to accept data collection 
input.

Windows®: 
Ctrl + D

Macintosh®: 
ì“ + D

Tools

Quick Poll - Opens a tool that allows 
you to send a quick poll to students 
with connected handhelds. Class must 
be in session.

Windows®: 
Ctrl + Alt + Q

Macintosh®: 
ì“ + Alt + Q

Quick Poll Options 8 Set options for 
an active Quick Poll session.

Allow Document Access - Allow 
students to access the Scratchpad, 
other applications, and documents 
on their handhelds while in the 
Quick Poll session.

Allow Resubmit - Allow students 
to continue to submit answers to 
the Quick Poll until you stop the 
poll.

Screen Capture 8 Capture the screen 
of the active page of a current 
document, or a student’s connected 
handheld, or an entire class of 
connected handhelds.

Capture Class - Captures the 
screens of selected student 
handhelds or the entire class in the 
active class session. The captured 
images are located in the Class 
Capture tool.

Capture Page - Captures the active 
page of the current document. The 
captured image is located in the 
TI-Nspire™ Screen Capture tool.

Windows®: 
Ctrl + J

Macintosh®: 
ì“ + J

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Capture Selected Handheld - 
Captures the screen of a selected 
student or teacher handheld. The 
captured image is located in the 
TI-Nspire™ Screen Capture tool.

Transfer Tool - Opens a tool that 
allows you to send files to multiple 
students at once when a class is not in 
session.

Windows®: 
Ctrl + T

Macintosh®: 
ì“ + T

Variables - Insert a selected variable 
into the current document. 

Windows®: 
Ctrl + L

Macintosh®: 
ì“ + L

 Refresh Libraries - Refreshes the list 
of storied libraries.

Install Handheld OS - Allows you to 
select an OS file that you have 
downloaded and install it on the 
handheld you have selected.

Network Manager - Opens a tool that 
lets you check the status of wireless 
adapters and cradles, and lets you add 
or remove wireless adapters, cradles, 
and access points from the classroom 
system.

Class

Select Class 8 Displays a list of 
available classes for you to select.

Begin/End Class - Begins a class sesion. 
If a class session is currently running, 
ends the class session.

Pause/Resume Class - Pauses a class 
session. If a class session is paused, 
resumes the class session.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Reset Student Passwords - Reset the 
password of a selected student. The 
student can not be currently logged 
in.

Student Name Format 8 Allows you 
to choose how student names are 
displayed, either by Last Name, First 
Name; User Name; Display Name; 
Student ID; or hidden.

Window

Reset Workspace Layout - Returns 
your workspace to its original layout.

Content Workspace - Opens the 
Content Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage content from 
your computer, links to websites, 
connected handhelds, or Texas 
Instruments web content.

Windows®: 
Ctrl + Alt + 1

Macintosh®: 
ì“ + Alt + 1

Class Workspace - Opens the Class 
Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage classes and 
students, use the class record panel, 
and exchange files with students.

Windows®: 
Ctrl + Alt + 2

Macintosh®: 
ì“ + Alt + 2

Documents Workspace - Opens the 
Documents Workspace in the 
TI-Nspire™ Navigator™ Teacher 
Software. Use this workspace to 
author documents and demonstrate 
mathematical concepts.

Windows®: 
Ctrl + Alt + 3

Macintosh®: 
ì“ + Alt + 3

Review Workspace - Opens the 
Review Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to review a collected set of 
documents, manage student 
responses, and organize data.

Windows®: 
Ctrl + Alt + 4

Macintosh®: 
ì“ + Alt + 4

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Portfolio Workspace - Opens the 
Portfolio Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to save, store, review, and 
manage class assignments from 
students.

Windows®: 
Ctrl + Alt + 5

Macintosh®: 
ì“ + Alt + 5

Application Menu - Opens the 
application menu for the active page 
of a document in the Toolbox panel.

Windows®: 
Ctrl + Alt + M

Macintosh®: 
ì“ + Alt + M

Page Sorter - Opens the page sorter 
and displays the pages of a problem in 
the Toolbox panel.

Windows®: 
Ctrl + Alt + P

Macintosh®: 
ì“ + Alt + P

TI-SmartView Emulator - Opens the 
TI-SmartView™ emulator in the 
Toolbox panel.

Windows®: 
Ctrl + Alt + E

Macintosh®: 
ì“ + Alt + E

Content Explorer - Opens the Content 
Explorer panel in the Toolbox panel.

Windows®: 
Ctrl + Alt + O

Macintosh®: 
ì“ + Alt + O

Utilities - Opens the Utilities panel in 
the Toolbox panel.

Windows®: 
Ctrl + Alt + U

Macintosh®: 
ì“ + Alt + U

Show Documents in Tiles/Tabs - 
Toggles the document view between 
showing in tiles or tabs. Includes the 
list of open documents.

Screen Capture Window - Opens the 
TI-Nspire™ Screen Capture tool, where 
you can view page captures and 
selected handheld screen captures.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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DocumentName.tns - Lists the names 
of open documents, with a checkmark 
by the current document.

Help

TI-Nspire™ Help - Provides help 
information for this software.

F1

Activate... your trial copy of the 
software. This option is available only 
if you use a trial version of the 
software.

Manage Subscription 8 

Purchase Now - Purchase the 
software.

Reminder Settings - Renew your 
license or change your reminder 
settings, if your software is already 
activated.

Register - When connected to the 
Internet, opens a page where you can 
register your product.

Download Latest Guidebook - When 
connected to the Internet, opens a 
page where you can download the 
latest product guidebooks. 

Visit education.ti.com - When 
connected to the Internet, opens the 
Texas Instruments Education 
Technology site.

Visit Activities Exchange - When 
connected to the Internet, opens the 
Activities Exchange site.

Explore Online Troubleshooting - 
When connected to the Internet, 
opens the online troubleshooting site.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Run TI-Nspire Diagnostics - Run 
diagnostics and send a report to TI 
support.

Check for Software Updates - Locates 
software updates.

Check for Handheld OS Update - Is 
active when a handheld is selected.

About - Displays TI-Nspire™ 
Navigator™ product information.

Welcome Screen - Opens the 
Welcome Screen, which gives you 
quick links to commonly used features.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Working with TI-Nspire™ documents

This section describes how to work with TI-Nspire™ documents using the 
Documents workspace. Information in this chapter is for the following 
TI-Nspire™ software:

• TI-Nspire™ Teacher Software

• TI-Nspire™ Student Software

• TI-Nspire™ CAS Teacher Software

• TI-Nspire™ CAS Student Software

• TI-Nspire™ Navigator™ Teacher Software

When there are differences between the software, those differences are 
described.

About documents
All work that you create and save with the desktop software is stored as 
a document, which you can share with others using TI-Nspire™ software 
and with those using handhelds. There are two types of documents: 

• TI-Nspire™ document (.tns file)

• PublishView™ document (.tnsp file)

TI-Nspire™ documents
A TI-Nspire™ document consists of one or more problems and each 
problem contains one or more pages. A single page is displayed in the 
workspace on your screen. All work occurs in the applications within 
pages. Because the TI-Nspire™ software and the TI-Nspire™ handhelds 
share the same functionality, you can use the software to create 
TI-Nspire™ documents that can be transferred between the software and 
a handheld. 

PublishView™ documents
PublishView™ documents can be printed on a standard piece of paper or 
published to a web site or blog. PublishView™ documents can include 
formatted text, images, and hyperlinks as well as all TI-Nspire™ 
applications.

For more information about creating and using PublishView™ 
documents, see Working with PublishView™ documents
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Managing TI-Nspire™ documents
When you first open the desktop software, the Documents workspace 
opens with a blank document containing one problem. You can add 
applications and content to this problem to create a document.

Note: The Welcome Screen is displayed when you open the software if 
the "always show this at startup" option is selected. Click an application 
icon to add a problem with an active application to a new document. 

Creating a new TI-Nspire™ document
To create a new TI-Nspire™ document, complete the following steps:

1. From the menu bar in the Documents workspace, select File > New 

TI-Nspire™ Document or click  on the tool bar, then select New 
TI-Nspire™ Document.

The new document opens in the Documents workspace and you are 
prompted to select an application. By default, new documents open 
in your current view: computer or handheld. To change the view, use 
the View menu or click the appropriate icon in the status bar.

2. Select an application to add a problem to the document.

The problem is added to the document.
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Saving TI-Nspire™ documents

To save a new document:

1. Select File > Save Document, or click . 
The Save TI-Nspire™ Document dialog box opens.

2. Navigate to the folder where you want to save the document or 
create a folder in which to store the document.

3. Type a name for the new document. 

4. Click Save to save the document.

The document closes and is saved with the extension .tns. 

Note: When you save a file, the software will first look in the same folder 
the next time you open a file.

Saving a document with a new name
To save a previously saved document in a new folder and/or with a new 
name:

1. Select File > Save As... from the menu bar.

The Save TI-Nspire™ Document dialog box opens. 

2. Navigate to the folder where you want to save the document or 
create a folder in which to store the document.

3. Type a new name for the document. 

4. Click Save to save the document with a new name.
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Opening an existing document
To open an existing document:

1. Click File > Open Document or click . 
The Open dialog box opens.

2. Use the file browser to locate the file you want to open and click the 
file to select it.

3. Click Open. 
The document opens in the workspace.

Note: To select from your 10 most recent documents, click File > Recent 
Documents and select a document from the drop-down list.

Using Content Explorer to locate files
The Content Explorer is a file browser that lists files on your computer 
and on any connected handheld. Use the Content Explorer to:

• Transfer files and folders between your computer and any connected 
handhelds.

• Copy and paste files, lesson bundles, and folders.

Opening Content Explorer

From the Documents Toolbox, click .
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À Computer file browser - Contains folders and files on your computer.

Á Current top-level folder - The current folder. Click ¤ to navigate to 
another folder. The default folder is My Documents. 

Â Folders - Double-click the folder icon to view the files in a folder.

Ã Files - Files in the top-level folder.

Ä Handheld file browser - This section of the pane contains folders and 
files on a connected handheld.

Å Context menu - Click ¤ to open the drop-down menu listing options 
for working with folders and files in the Content Explorer.

Æ Expand/collapse double arrows - Click here to expand or collapse 
the Computer or Handheld file browser.

You can select files and folders in the Content Explorer file browser 
pane and drag and drop them to another location:

• Select a file or folder and drag it to another folder in the computer or 
handheld browser

À
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• Select a .tns or .tnsp file and drag it to the workspace to open the 
document.

Understanding which files and folders you can transfer
• You can use the file browser pane to transfer or move the following 

file types between a computer and a connected handheld:

• You cannot transfer .tnsp files to a handheld; however, you can 
convert a .tnsp file to a .tns file.

• The file folders that you can transfer may be limited depending on 
the handheld software version and on the file folder structure, such 
as how many levels there are within the folder. 

• If you move file folders that contain unsupported files, the supported 
files are transferred, and the unsupported files are ignored.

• All files in a lesson bundle will appear in the Content Explorer.

Saving a document to a connected handheld
From the Documents workspace, complete the following steps to save a 
document to a connected handheld. 

Note: Use a standard USB cable to connect a single handheld to a 
computer. In the classroom, use the TI-Nspire™ Docking Station or 
TI-Nspire™ CX Docking Station to connect multiple handhelds to the 
computer.

1. Open the document you want to save to a handheld.

2. Select File > Save to Handheld. The Save to Handheld dialog box 
opens.

File Type Extension

TI-Nspire™ document .tns

Packaged lesson bundle file .tilb

Learning Check file .edc

Cabri™ file .fig

Handheld operating system files

TI-Nspire™ CX Handheld .tco

TI-Nspire™ CX CAS Handheld .tcc

TI-Nspire™ Handheld .tno

TI-Nspire™ CAS Handheld .tnc
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Note: You can also "drag and drop" a file from the computer pane to 
a handheld listed in the Connected Handhelds pane.

3. Select the receiving handheld. If multiple handhelds are connected, 
the names are listed.

4. Click Save to save the file, or Cancel to abandon the save.

If you choose the name of an existing file, a dialog will open asking 
whether you want to replace the file.

To overwrite the file, click Replace. To abandon the save, click Cancel.

5. A dialog box shows that the file is being saved.

Note: Any file saved to a handheld will be saved as a .tns file.

Opening handheld documents in the software
You can open documents from a handheld directly in the software. You 
can then work with the documents and save them through ordinary save 
commands.

To open a document on your handheld:

In the Content Explorer, select the document from the Connected 
Handhelds browser pane.

— OR —

Right-click, choose Open, navigate to the document, and click OK.
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Saving handheld documents in the software
To save a handheld document you have been editing in the software, do 
one of the following:

Type Ctrl + S (Macintosh®: ì“ + S).

— OR —

Click File > Save Document.

Copying supported files and folders
To copy supported files and folders:

1. Click and hold the file you want to copy. To select multiple files, use 
Ctrl + Click (Macintosh®: ì“ + Click).

2. Drag the files to the destination you want and release the mouse.

3. If a file or files exist in the target destination with the same names, 
you’ll be asked whether you want to replace the files.

4. Click Yes to replace the file shown, Yes to All to replace all files, or 
No to stop.

5. When you are in the process of copying a group of files, cancel the 
operation by clicking Cancel. Only those files that haven’t yet been 
transferred to the destination will be canceled. Other files will have 
already been transferred.

Note: If you copy to a connected handheld, only .tns supported 
documents can be copied.

Creating new folders

1. In the Computer or Connected Handhelds pane, click , then 
select New Folder.

2. Type a name for the folder and press Enter.

Deleting documents
File deletions on the handheld are permanent and cannot be undone, so 
be sure that you want to delete the file that you select. File deletions on 
your computer are sent to the Recycle bin and can be retrieved if the 
Recycle bin has not been emptied.

1. Select the document you want to delete.

2. Click Edit > Delete or press the Delete key.

3. When the Warning dialog box opens, click Yes to confirm the delete.

The document is deleted.
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Working with multiple documents
When multiple documents are open, all document names are listed in 
tabs at the bottom of the work area. Only one document is active at a 
time, and only the active document is affected by commands from menus 
or tools. You can also show thumbnail views of all open documents in the 
workspace. To show thumbnails, select Window > Show Documents in 
Tiles. 

To switch between documents:

Working with multiple documents in tiled view
When multiple documents are open, you can view thumbnails of the 
documents in the workspace. To change the view:

Select Window > Show Documents in Tiles. Open documents are 
shown as thumbnails in the workspace and the scroll bar become 
active.

À Click the tab to show a document in the work space. This 
document becomes the active document. If the Show 
Documents in Tiles view is open, these tabs are not shown. 

Á Use the right and left arrows to scroll through the list of 
documents. These arrows are active only when there are too 
many documents to fit in the window.

Â Click the Show List icon to list all open documents. This is 
useful when you have a large number of documents open and 
documents names on the tabs may be truncated.

À Á Â
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The status bar remains available; however, document names now 
appear on the thumbnail view. Select Window > Show Documents 
in Tabs to view one document at time in the workspace.

Closing documents
To close a document, click File > Close or click the Close icon on the 
document tab at the bottom of the document.

If using the tiled view, click the Close icon in the upper right corner of 
the document window.

Working with applications
When you first open a new document or add a new problem to a 
document, select an application from the menu. 

The following illustration shows how a problem with the Lists & 
Spreadsheet application appears in the work space on the right side of 
the window when Handheld mode is selected.
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À Document name- This tab contains the document name.

Á Problem/Page counter - The first value represents the problem 
number of the active page, while the second value tells you the page 
number within the problem. In the example, the counter reads 1.2, 
indicating Problem 1, Page 2.

Â Settings - Enables you to change the General Settings and Graphs 
and Geometry Settings for the active document or change the default 
settings. See Using the Documents Workspace for information about 
changing settings.

Ã Document View - Enables you to switch between computer mode 
and handheld mode.

Ä Scaling/Boldness - When in computer view, use this scale to increase 
or decrease the boldness of the document. When in handheld view, 
use this scale to make the image larger or smaller.

Opening Document Tools
Tools for working with applications are located in the Documents 
Toolbox panel on the left side of the window. 

To open Document Tools:

Select Window > Document Tools or click  in the Documents 
Toolbox pane.

ÁÀ Ã ÄÂ
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The Document Tools menu opens with the tools and tool menus 
specific to the application in the active problem or page. The 
following illustration shows the menu for the Lists & Spreadsheet 
application.

If there are multiple problems and pages in the document, the tools 
specific to the application on the active page are shown in the 
Document Tools menu when you select the page.

Opening context menus
Use context menus to access options specific to a selected object or the 
current cursor location. 

1. To access a context-sensitive menu for an application, right-click in 
the work area. The following example shows the context menu for 
the Lists & Spreadsheet application.
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2. Click the option name to select it. When available, click ¢ to access 
actions specific to the menu option.

Working with multiple applications in a page
You can add up to four applications to a page. When you have multiple 
applications on a page, the menu for the active application is displayed 
in the Documents Toolbox. Using multiple applications involves two 
steps:

• Changing the page layout to accommodate multiple applications

• Adding the applications

You can add multiple applications to a page even if an application is 
already active.

Adding multiple applications to a page
By default, each page contains space to add one application. To add 
additional applications to the page, complete the following steps.

1. Click Edit > Page Layout > Select Layout, or click  from the tool 
bar to open the page layout menu. 

There are eight page layout options available. If an option is already 
selected, it is grayed out.

Highlight the layout you wish to add to the problem or page, then 
click to select it. The new layout is displayed with the first application 
active.



132 Working with TI-Nspire™ documents

2. Click to select an application for each new section in the problem or 
page.

Swapping applications
To change the position of applications on a page with multiple 
applications, “swap“ the positions of two applications.

1. Click Edit > Page Layout > Swap Application.

Note: The last active application you worked on is automatically 
selected as the first application to be swapped. 

2. Click on the second application to swap. This action performs the 
swap.

Note: When there are only two work areas, the selected application 
automatically swaps position with the other application on the work 
area.

To cancel a swap, press Esc.

Selecting and moving pages with the Page Sorter
The Page Sorter is part of the Documents Toolbox. Use the Page Sorter to 
list thumbnail views of all pages in the document. Use the Page Sorter to 
move to different pages in your document, and to quickly move and 
rearrange pages.
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À Page Sorter - Displays thumbnail sketches of all pages in all 
problems in the current document. Use the scroll bar to view pages 
off the screen. 

Á Active page - The page currently highlighted in the Page Sorter and 
active in the work space.

Â Problem/Page counter - Displays the problem number followed by 
the page number.

Selecting pages
The Page Sorter always indicates the active page in the work area. 

• If you are working on a page in the work space, this page is indicated 
in the Page Sorter by a color border. 

• If you are actively using the Page Sorter, the active page displayed in 
the work space has a color border in the Page Sorter pane. 

• Clicking on any page in the Page Sorter makes it the active page, and 
it is displayed in the work space.

Rearranging pages
Use the Page Sorter to change the order of pages within a problem.

1. Click to select the thumbnail view of the page in the Page Sorter.

2. Hold down the mouse button and drag the page to the desired 
position, and release to drop it in the new location.

À
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Grouping applications
To group up to four pages into a single page:

1. From the Documents Toolbox, click  to open the Page Sorter 
panel.

2. Select the first page in the series.

3. Select Edit > Page Layout > Group.

The next page is grouped with the first page. The page layout 
automatically adjusts to display all the pages in the group.

To ungroup pages:

1. Select the grouped page.

2. Select Edit > Page Layout > Ungroup.

The material becomes individual pages and applications.

Deleting an application from a page
1. Select the application you want to delete. 

2. Select Edit > Page Layout > Delete App.

The application is deleted.

If you want to undo the delete, type Ctrl-Z (Macintosh®: ì “+ Z).

Deleting pages 

You can delete an entire page using the delete tools on the tool bar. 

1. Select the page you want to delete.

2. Select Edit > Delete or right-click and select  Delete.

Working with problems and pages
When you create a new document, a problem is added with one page. 
When a document has a problem with multiple pages or multiple 
problems, select Window > Page Sorter to open the page sorter view in 
the Documents Toolbox to view the problems and pages.

Adding a problem to a document
A document can contain up to 30 problems. To add a new problem:

Select Insert > Problem, or click the toolbar icon  and select  
Problem.
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A new problem with one new page is added to your document.

Adding a page to a problem
Each problem can contain up to 50 pages. To add a new page to a 
problem:

1. Select Insert > Page, or click the toolbar icon  and select  
Page.

A new page is added to the problem. 

2. Select an application to add to the page.

Copying, pasting, and deleting problems
You can copy and paste a single problem from one location to another 
within the same document or a different document. You can also delete 
the problem from the document.

Copying and pasting a problem
To copy and paste the problem:

1. In the Documents Toolbox, click , to open the Page Sorter.

2. Click a problem to select it.

3. Press Edit > Copy or Ctrl + C (Macintosh®: ì“ + C).

4. Go to the location where you want the problem to appear.

5. Press Edit > Paste or Ctrl + V (Macintosh®: ì“ +V).

A duplicate problem is placed in the new location.

Deleting a problem
To delete a problem from the document:

1. Select the problem.

2. Press Edit > Delete or Ctrl+X (Macintosh®: ì“ + X).

The problem is deleted from the document.

Renaming a problem
To rename a problem:

1. Using the Page Sorter pane, select the problem name.

2. Right-click and select Rename.

The problem name box clears.

3. Type the name and click Enter.



136 Working with TI-Nspire™ documents

The new name appears in bold to indicate that it has been changed.

To Undo, click the Undo key or click Edit > Undo.

Using Utilities in documents
The Utilities pane is located in the Documents Toolbox. To access the 
Utilities pane:

1. Select Windows > Utilities or click . 

The Utilities pane opens in the Documents Toolsbox.

2. Click each tab to open a palette of items. 

Use the Utilities pane for quick access to the following items:

• Math templates. Contains math templates for creating two 
dimensional objects, including product, sum, square root and 
integral.
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• Symbols. Provides a symbol palette for adding special characters.

• Catalog. Contains all commands and functions, in alphabetical order.
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• Math operators. Contains all math functions.

• CAS: Unit conversions. Provides the values for standard 
measurement units.

• Libraries. Shows Public library (LibPub) objects defined in the 
documents located in the MyLib folder.

Note: For more information about libraries, please see the Library 
section of the documentation.
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To open any item on the Utilities pane, click the Utilities tab, and then 
click the item you want.

Inserting items from the Utilities pane
1. Open the Utilities pane. 

2. Select the header that contains the function, symbol, or expression 
you want to insert into your problem.

3. Double-click the item or drag and drop it into the expression. You can 
also select the item and press Enter.

Move the mouse over an item to view a short description of each item 
or view syntax information.

Using wizards
Wizards provide help for entering functions and performing tasks for 

items in the Utilities pane such as LinRegMx and OneVar. The  symbol 
appears next to items that are supported by wizards. To use a wizard:

1. In the Utilities pane, click the tab to open the set of utilities you want 
to work with. For example, click Catalog.

2. Click the check box next to the Wizards on box in the lower right 
corner of the pane. 

3. When you begin a command or function that is supported by a 
wizard, a dialog box provides help needed to use the selected 
function. For example, when you select LinRegtTest from the 
Catalog, the following dialog opens.
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Using colors in documents
You can use colors in the following desktop applications:

• Data & Statistics

• Graph

• Geometry

• Lists & Spreadsheet

• Notes

You can use color in filled areas of an object, or in lines or text, 
depending on the application you’re using and how you have selected 
the item. 

Color appears when displayed on your computer and on documents 
opened on the TI-Nspire™ CX handheld. If a document containing color 
is opened on a TI-Nspire™ handheld, it displays in shades of gray. 

Note: For more information about how to use color in specific objects 
(such as a shaded area in Data & Statistics), refer to the documentation 
for that application.

Adding color from a list
To add color to a fill area, line, or text, do the following:

1. Select the item.

2. Click Edit > Color and select where you want to add color (fill, line, or 
text).

3. Select the color from the list.

Adding color from a palette
To add color using the palette, do the following:
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1. Select the object.

2. Click the appropriate tool bar icon.

3. Select the color from the palette.

Note: If the icon or menu item that you want to use is not available 
(grayed out) after you have selected an item, coloring is not an option 
for the selection you’ve made.

Using Screen Capture
Use TI-Nspire™ Screen Capture to copy images of active pages. You can 
save images as .jpg files, which can be inserted into to TI-Nspire™ 
applications that allow images. The image is also copied to the clipboard 
and can be pasted into another application such as Microsoft® Word.

Capturing a page
1. Open a document and select the page you want to capture.

2. Click .

• To capture the current page on your computer, select Capture 
Page.

• To capture the current page on a connected handheld, select 
Capture Selected Handheld.

Note: You can also select Tools > Screen Capture to access the 
Capture Page and Capture Selected Handheld options.

The image is copied to the clipboard and to the TI-Nspire™ Screen 

Capture window. The  dialog opens in 
the lower right corner of your desktop when the screen capture is 
complete.

3. Click View it to open the TI-Nspire™ Screen Capture window.

You can also select Window > Screen Capture Window to open the 
TI-Nspire™ Screen Capture window.
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4. To capture additional pages, move to the next page in the document, 

then click  to select the option required to capture the selected 
page.

The page is copied to the TI-Nspire™ Screen Capture window. It 
replaces the image in the clipboard.

• Click  to copy an image to the clipboard.

• Click  to delete an image.

• Click  to zoom in.

• Click  to zoom out.

• Click  and  toggle between Single Screen View and 
Thumbnail View if there are multiple captured pages.

• Click  to add a border to the selected image. Click  to 
remove a border from a selected image.

• Click  or  to scroll through multiple captured pages.



Working with TI-Nspire™ documents 143

Saving captured pages
You can save one image at a time, select multiple images to save, or save 
all captured images.

1. In the TI-Nspire™ Screen Capture window, click  to save the 
selected image or images. To save all images, click File > Save All 
Screens. When you save multiple screen captures, the images are 
collected in a folder named with the current date.

2. When the Save As dialog box opens, the default Screen Captures 
folder is available. To save the images in a different folder, navigate 
to the folder or create a new folder.

3. Type a name for the file or folder.

4. Click Save.

The file is saved in the designated location.

Printing documents
If your computer is connected to a printer, you can print an open 
document.

1. Select File > Print to open the Print dialog.

2. Once you have selected the details of your print job, click Print.

The Print dialog enables you to control the following in your print job:

• The printer

• Print What:

– Viewable Screen — prints what is visible in the active document

– Print All — prints all data and pages in all open documents, 
including what is not currently visible on the screen

• Paper size

• The range of TI-Nspire™ pages 

• The number of printed copies, up to 100

• Layout:

– Orientation (portrait or landscape)

– The number of TI-Nspire™ pages to be printed on each sheet (1, 4, 
or 8) (available in Viewable Screen option only)

– Whether to allow space below each printed TI-Nspire™ page for 
comments (available in Viewable Screen option only)
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• Margins (from .25 inches to 2 inches)

• The option to include documentation information on the printout:

– Problem and page labels

– Header (up to two lines)

– Document name in the footer

• The ability to group the pages by problem

• Print Preview

To restore the Print defaults, click Reset.

Using print preview
You can also preview the document from the Print dialog. 

With the View Preview checkbox selected, use the arrows at the top 
of the right pane to page through the pages in the preview.

Viewing document properties and copyright 
information

Viewing copyright information
If a teacher has added copyright information to a document, you can 
view that information. 

To view copyright information, click File > View Copyright 
Information.
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Protecting a document (making a document read-only)
Note: This section applies only to the Teacher Software.

Teachers can protect documents to create a document for distribution to 
your students or for other use. A student who receives a read-only 
document and makes changes to it will be prompted to save the 
document as a new file.

To make a document read-only:

1. Open the document.

2. Click File > Document Properties.

3. When the Document Properties dialog box opens, click the 
Protection tab.

4. Select the checkbox next to Make this document Read Only.

5. Click OK.

Adding copyright information to a document
Note: This section applies only to the Teacher Software.

You can add copyright information individually to documents you create 
or apply the same copyright information to all new documents.

To add copyright information to a document:

1. With the document open, click File > Document Properties.
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The Document Properties dialog box opens with the Copyright tab 
visible. 

2. Edit the following fields to define the copyright details:

• Author

• Copyright (Public Domain or Copyright). 

Note: If you select Public Domain, you cannot enter a year or 
owner.

• Year

• Owner

• Comments

3. To add the supplied information to all new documents from this point 
forward, select Apply this copyright to all new documents.

4. Click OK to apply the copyright information to the document.
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Capturing Screens

In the TI-Nspire™ Navigator™ Teacher Software, Screen Capture enables 
you to:

• Capture Class

– View and monitor all student handheld screens at one time, which 
allows you to ensure all students are on track with an assignment. 

– Capture one or several students’ screens for discussion in the 
classroom. You can hide student names to focus the discussion on 
the lesson or concept, and not on individuals. 

– Select and display an individual student’s screen and view work as 
a live presentation. 

– Copy the active page in a TI-Nspire™ document. 

– Save captured images as .jpg, .gif, or .png files, which can be 
inserted into TI-Nspire™ applications that allow images.

• Capture Page

– Capture the active page in a TI-Nspire™ document from the 
software or from the TI-SmartView™ emulator as an image. 

– Save captured images as .jpg, .gif, .png, or .tif files, which can be 
inserted into TI-Nspire™ applications that allow images.

– Copy and paste images into another application such as 
Microsoft® Word.

• Capture Selected Handheld

– Capture the current screen on a connected handheld as an image.

– Save captured images as .jpg, .gif, .png, .tif files, which can be 
inserted into TI-Nspire™ applications that allow images.

– Copy and paste images into another application such as 
Microsoft® Word.

Accessing Screen Capture
The Screen Capture tool is available from all work spaces. To access 
Screen Capture:

From the menu bar, select Tools > Screen Capture.

From the toolbar, click .
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Using Capture Class
In the TI-Nspire™ Navigator™ classroom, use the Screen Capture tool to 
view and capture student handheld screens. You can capture the 
handheld screen of one selected student, of multiple selected students, 
or of all the students in the class.

Note: To view and capture student handheld screens, they must be 
logged into the TI-Nspire™ Navigator™ Teacher Software.

Capturing student handheld screens
1. If you have not already done so, begin the class session and ask your 

students to log in.

2. Click , then select Capture Class.

The Select Individual(s) window opens. If you selected students in the 
Class workspace view, those student names are highlighted. If no 
students were selected, all student names in the class are selected. 

3. To change the selected student or add more students:

• Click  to display the handheld screens of all students in 
the class. If a student is not logged in, the handheld display 
indicates "Not Logged In." As students log in, use refresh to 
update your screen.
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• Click , then click the name of each student to display the 
handheld screens of individual students. To select multiple 
students, hold down the Shift key. To select students in random 
order, hold down the Ctrl key (Macintosh®: “) and click each 
student name.

• Click the Logged in only check box under the left pane to display 
screens from only those students currently logged in. When you 
refresh your screen, any students who log in after the initial 
screen capture will be listed at the end of the Class Screen Capture 
window.

4. Click OK.

The screens of the selected students are displayed in the Class Screen 
Capture window.

Note: The example below shows the screens from two selected 
student handhelds who are logged in. The default view is Tiled, which 
shows all screens captured in the window.

5. Decide if you want to display or hide the students’ names. To hide or 
show student names, click the checkbox on the toolbar to toggle 
between hide and show or click View > Show Student Names. 
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Note: Your selection to show or hide student names remains in effect 
until you change it. For example, if you select to hide student names, 
the student names will remain hidden when you close the Class 
Screen Capture window and return to the Class workspace. If you 
select to hide student names in the Class workspace, they will be 
hidden when the Class Screen Capture window opens.

Using the Class Capture window menus and tool bar
The menu bar provides options for working with captured images. Click 
an option to open a drop-down menu that lists options needed to 
perform tasks. If applicable, shortcut keys are also listed.

The tool bar provides quick access to options frequently used when 
working with captured images. These options are also accessible from 
the menu bar.

Option Description Icon Shortcut 
key

File Menu

Save Selected 
Screen(s)

Save only selected screens 
if one or multiple screens is 
captured.

Ctrl + S

Macintosh®: 
“ + S

Print Print captured screens. Ctrl + P

Macintosh® 
“ + P

Close Close the Class Capture 
window.

Ctrl + W

Macintosh®: 
“ + W

Edit Menu

Copy Copy a selected screen to 
the clipboard.

Ctrl + C

Macintosh®: 
“ + C
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Select All Select all captured screens. Ctrl + A

Macintosh®: 
“ + A

Compare 
Selected

Open Gallery view to 
compare selected screens 
side-by-side.

View Menu

Tiled Click to show a Tiled view 
of all captured screens.

Ctrl + T

Macintosh®: 
“ + T

Gallery Click to show captured 
screens in Gallery view.

Ctrl + G

Macintosh®: 
“ + G

Refresh Now Click to refresh the view 
immediately.

F5

Auto Refresh Select to turn on the auto 
refresh feature. If turned 
on, you can select how 
often the view is refreshed. 

Zoom In Make the view larger. Ctrl + Up

Macintosh®: 
“ + Up

Zoom Out Make the view smaller. Ctrl + Down

Macintosh®: 
“ + Down

Zoom 
Percentage

Select percentage to 
increase or decrease a 
screen image when 
zooming in or out. 

Show Student 
Names

Select whether the student 
name will be shown under 
captured handheld screen.

Option Description Icon Shortcut 
key
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Setting Teacher Preferences for Capture Class
Use the Teacher Preferences option in the TI-Nspire™ Navigator™ 
Teacher Software to set preferences for using the randomize screen 
option and for displaying the teacher handheld. Creating a user name 
and password enables teachers to log in to an active class. You can also 
select to individualize the view of your handheld screen when it is 
displayed. For more information on using a handheld, refer to the 
handheld guidebooks available at education.ti.com/guides.

1. From the TI-Nspire™ Navigator™ Teacher Software window, select 
File > Settings > Teacher Preferences.

The Teacher Preferences dialog box opens.

2. If you haven’t already done so, create a Username and Password. 

3. Select "Add teacher to classroom view" to show your handheld in the 
Class Screen Capture window.

4. To randomize the order in which screens are captured, select 
"Randomize order in Screen Capture."

5. Select the "Individualize Teacher Handheld in Screen Capture" option 
so that a captured screen from the teacher handheld appears 
differently in the Class Screen Capture window than screens captured 
from student handhelds.

Live Presenter Access Live Presenter 
options.

See Using Live 
Presenter for more 

information.

Option Description Icon Shortcut 
key
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6. Click OK to save the settings.

Setting view options in Capture Class
When working with captured screens in the Class Screen Capture 
window, you have several options for optimizing the view of the screens 
for presentation to a classroom, including:

• Toggling between a tiled view and a gallery view

• Comparing selected screens in a side-by-side view

• Refreshing the view as needed or setting the auto-refresh feature to 
automatically refresh the view at timed intervals

• Zooming in or out to increase or decrease the size of the captured 
screens in the window. You can also select the percentage at which 
the size of the screen will be increased or decreased.

• Showing or hiding student names

• Accessing Live Presenter options (See Using Live Presenter for more 
information.)

Toggling between Tiled and Gallery views
When you capture student handheld screens, the default view for the 
Class Screen Capture window is Tiled. Switch to Gallery view to show an 
enlarged view of a selected screen. Thumbnail views of all the captured 
screens are shown in the left pane, enabling you to find and select 
screens.

To toggle between Tiled and Gallery views:

Click . then select Gallery or Tiled.

—OR—

Select View > Gallery or select View > Tiled.

—OR—

For Gallery view, press Ctrl + G. (Macintosh®: “ + G). For Tiled view, 
press Ctrl + T (Macintosh®: “ + T).

In Gallery view, thumbnail images of captured screens are displayed in a 
column in the left pane of this view. An enlarged view of a selected 
screen is displayed in the right pane.
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• Captured screens appear in the same order as in Tiled View. 

• If you select multiple thumbnails to view in the left pane, they are 
displayed in the right pane. 

• If you select more than four thumbnails, view the additional screens 
by scrolling down the right pane. 

• If you selected to show student names, names are centered under 
each student’s captured screen. 

• Zoom functions are disabled in Gallery View.

• You can change the order of the screens in the Gallery View.

• The width of the thumbnail pane cannot be changed.

Rearranging captured screens
Complete the following steps to change the order of the captured 
screens within the Class Screen Capture window.

1. Click the desired screen to select it.

2. Holding the left mouse button down, drag the screen to the desired 
location and release.
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Refreshing captured screens
As students log in to class and work on their handhelds, you can update 
the view of the captured screens. When you refresh the view in the Class 
Screen Capture window, the latest screens from the connected handhelds 
are displayed. You can refresh the view as needed, or you can set the 
auto-refresh option to refresh the view automatically at timed intervals.

Refreshing the view as needed

Click .

The latest screens from the connected handhelds are captured and 
displayed in the Class Screen Capture window.

Note: If a student handheld has lost connection and a screen cannot 
be refreshed, it is outlined in yellow.

Enabling the auto-refresh screen capture feature
The auto-refresh feature is useful for monitoring class performance. This 
feature enables you to automatically refresh the view of captured 
screens at timed intervals. The default setting for the auto-refresh 
feature is Off. To enable auto-refresh:

1. Click View > Auto Refresh or click  on the 
toolbar. 

border 
color 
changes if 
a screen 
cannot be 
refreshed
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2. Select one of the available time interval options.

Note: Auto-refresh is available when using either the Tiled or Gallery 
view. It is not available in Live Presenter mode.

Using zoom in and zoom out
In the Class Screen Capture window, use the zoom in and zoom out 
options to increase or decrease the size of the captured screens. 

From the toolbar, click  to increase the size of the screens in the 
view. You can also select View > Zoom In from the menu.

From the toolbar, click  to decrease the size of the screens in the 
view. You can also select View > Zoom Out from the menu.

Setting a zoom percentage
The Zoom Percentage option enables you to select the percentage by 
which the screen image is increased or decreased when zooming in or 
out. To select a percentage:

1. From the Class Screen Capture window, select View > Zoom 
Percentage.

The drop-down menu opens.
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2. Select one of the available percentages.

Comparing selected screens
This feature enables you to compare student screens side-by-side. 

1. Select the student screens you want to compare. To select multiple 
consecutive screens, hold down the Shift key. To select screens in 
random order, hold down the Ctrl key (Macintosh®: “) and click each 
image you want to save. When you select each screen, the border 
changes color. 

Note: If you select more than four screens, you will have to scroll the 
viewing pane to see them.

2. Select Edit > Compare Selected. 

If you are in Tiled view, the view switches to Gallery view and the 
selected screens are listed in the order selected.

Note: This option is disabled when in Gallery view.

3. To exit comparison mode, click outside the screen in the left pane of 
the Gallery view.

Using Make Presenter
Select a captured screen from the Class Screen Capture window, then 
click the Make Presenter option on the tool bar to launch Live Presenter 
and present the student’s screen to the class. You can only choose one 
student at a time to be the Live Presenter. See Using Live Presenter for 
more information about this option.
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Saving screens when using Capture Class
You can save captured screens for use in other TI-Nspire™ documents 
that allow images or for use in other application such as Microsoft® 
Word. You can save images in the following formats: .jpg, .png, or .gif. 
You can save one image at a time, select multiple images to save, or save 
all captured images.

Saving screen images
To save screen images captured when using Capture Class, complete the 
following steps.

1. In the Class Screen Capture window, select the screen or screens you 
want to save as image files.

• To select multiple consecutive screens, click the first image, then 
hold down the Shift key and click the additional images. To select 
screens in random order, hold down the Ctrl key (Macintosh®: “) 
and click each image you want to save.

• To select all captured screens, select Edit > Select All.

2. Select File > Save Selected Screen(s) or click Ctrl + S 
(Macintosh®: “ + S).

The Save window opens.

3. Navigate to the folder on your computer where you want to save the 
file(s).

4. Type a name for the file or files in the File Name field. 

The default file name is Image. 

5. In the Files of Type field, click ¤, then select the file type: .png, .jpg, 
or .gif. The default file type is .jpg.
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6. Click Save.

The file or files are saved in the designated folder.

• If you saved one image, the file is saved with the name as 
specified in the File Name field.

• If you saved multiple images, the files are saved with the name 
specified in the File Name field with a number appended to the 
file name to make each file name unique. For example, Image1, 
Image 2, and so on.

Printing captured screens
You can print screens captured using the Capture Class option. You can 
print one, multiple, or all captured screens. For each printed page, the 
class name is printed in the page header, and the date and page number 
are printed in the page footer.

Note: The print option is not available when using the Capture Page or 
Capture Selected Handheld options.

To print a captured screen:

1. Select the screen you want to print.

2. Click File > Print.

The Print dialog box opens.

3. If you selected more than one screen, click Print Options to select the 
number of screen captures that you want per page. 

The Print Options dialog box opens.
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4. Select options as needed. You can select to print one screen per page, 
six screens per page, or all screens on the page. You can also select 
whether to print student names.

5. Click OK to return to the Print dialog box.

6. Select the individual printer options for your printer.

7. Select the number of copies you want to print.

8. Click Print to send the print job to the selected printer.

Using Capture Page
Use the Capture Page option to capture an image of an active page in a 
TI-Nspire™ document. You can save images in the following file formats: 
.jpg, .gif, .png, and .tif. Saved images can be inserted into TI-Nspire™ 
applications that allow images. The image is also copied to the clipboard 
and can be pasted into other applications such as Microsoft® Word or 
PowerPoint.

Capturing a page
Complete the following steps to capture an image of an active page.

1. In the Documents workspace, open a document and navigate to the 
page you want to capture to make it active.

2. Click , then select Capture Page.

The image of the active page is copied to the clipboard and to the 

Screen Capture window. The  dialog 
opens in the lower right corner of your desktop when the screen 
capture is complete.

3. Click View it to open the Screen Capture window.
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You can also select Window > Screen Capture Window to open the 
Screen Capture window.

4. To capture additional pages, move to another page in the current 
document or open a new document to select a page. 

As you capture additional pages, the images are copied to the Screen 
Capture window, which holds multiple images. The last page 
captured replaces the contents of the clipboard.

Using Capture Selected Handheld
Use the Capture Selected Handheld option to capture the active screen 
on a connected handheld.

1. On a connected handheld, navigate to the menu or to a page in a 
document you want to capture.

2. In the TI-Nspire™ Navigator™ Teacher Software, select the connected 
handheld:

• In the Content workspace, select the handheld from the list of 
Connected Handhelds in the Resources pane.

• In the Documents workspace, open Content Explorer from the 
Documents Toolbox, then select the handheld from the list of 
Connected Handhelds.

• In the Class workspace, select a logged in student. 
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3. Click , then select Capture Selected Handheld.

—OR—

Click , then select Capture Selected Handheld.

The screen is copied to the clipboard and to the TI-Nspire™ Screen 

Capture window. The  dialog opens in 
the lower right corner of your desktop when the screen capture is 
complete.

4. Click View it to open the Screen Capture window.

You can capture additional screens from an open document on a 
connected handheld or open another document on a connected 
handheld to capture screens from that document. 

As you capture additional screens, the images are copied to the 
Screen Capture window, which holds multiple images. The last screen 
captured replaces the contents of the clipboard.

Viewing captured screens
When you capture a page in a document or from a handheld screen, it is 
copied to the Screen Capture window. 

menu bar

tool bar

captured 
screens
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Using the Screen Capture window menu and tool bar
The menu bar provides options for working with captured images. Click 
an option to open a drop-down menu that lists options needed to 
perform tasks. If applicable, shortcut keys are also listed.

The tool bar provides quick access to options frequently used when 
working with captured images. These options are also accessible from 
the menu bar.

Option Description Icon Shortcut 
Key

File Menu

Save Selected 
Screen(s)

Save only selected screens 
if multiple screens are 
captured.

Ctrl + S

Macintosh®: 
“ + S

Save All Screens Save all captured screens.

Close Close the Screen Capture 
window.

Ctrl + W

Macintosh®: 
“ + W

Edit Menu

Copy Copy a selected screen to 
the clipboard.

Ctrl + C

Macintosh®: 
“ + C

Delete Delete a selected screen 
from the window.

Delete key

Select All Select all captured screens. Ctrl + A

Macintosh®: 
“ + A



164 Capturing Screens

Zooming the view of captured screens
In the Screen Capture window, use the zoom in and zoom out options to 
increase or decrease the size of the captured screens. 

From the toolbar, click  to increase the size of the screens in the 
view. You can also select View > Zoom In from the menu.

Add/Remove 
Border

Toggle to add or remove a 
border from around the 
captured screens.

View Menu

Thumbnail 
View

Click to show a tiled view 
of all captured screens.

Single Screen 
View

Click to show only the 
selected screen in the 
window or see one image 
at a time.

Previous Return to previous screen. Left arrow 
key

Next Move the next captured 
screen.

Right arrow 
key

Zoom In Make the view larger. Ctrl + Plus 
sign

Macintosh®: 
“ + Plus sign

Zoom Out Make the view smaller. Ctrl + Minus 
sign

Macintosh®: 
“ + minus 
sign

Option Description Icon Shortcut 
Key
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From the toolbar, click  to decrease the size of the screens in the 
view. You can also select View > Zoom Out from the menu.

Saving captured pages and handheld screens
You can save captured pages and screens captured from connected 
handhelds as images for use in other TI-Nspire™ documents that allow 
images or for use in other applications such as Microsoft® Word. You can 
save one image at a time, select multiple images to save, or save all 
captured images.

Saving selected screens
1. In the Screen Capture window, select the screen image you want to 

save.

2. Select File > Save Selected Screen(s).

Note: From the Screen Capture window, you can also click .

The Save as window opens.

3. Navigate to the folder on your computer where you want to save the 
file.

4. Type a name for the file. 

Note: The default file name is MM-DD-YYYY Image ###.

5. Select the file type for the image file. The default format is .jpg. 
Click ¤ to select another format: .gif, .tif, or .png.

6. Click Save.

The file is saved in the designated folder.
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Saving multiple screens
1. In the Screen Capture window, select the screens you want to save.

To select multiple consecutive screens, click the first image, then hold 
down the Shift key and click the additional images. To select screens 
in random order, press Ctrl (Macintosh®: “) and click each image you 
want to save.

2. Click  or select File > Save Selected Screen(s). To save all 
captured screens, select File > Save All Screens.

Note: The "Save All Screens" option is not available when using 
Capture Class.

The Save as window opens.

3. In the Save In field, navigate to the folder where you want to save the 
images.

4. In the File Name field, type a new folder name. The default folder 
name is MM-DD-YYYY Image, where MM-DD-YYYY is the current 
date.

5. Select the file type for the image files. The default format is .jpg. 
Click ¤ to select another format: .gif, .tif, or .png.

6. Click Save. 

The images are saved in the specified folder with system-assigned 
names reflecting the current date and a sequence number. For 
example, MM-DD-YYYY Image 001.jpg, MM-DD-YYYY Image 002.jpg 
and so on.

Copying and pasting a screen
You can select a captured screen and copy it to the clipboard for inclusion 
into other documents or applications. You can also print copied screens. 
Copied screens are captured at 100% zoom level, and they are copied in 
the order of selection. 

Some of the applications that can receive copied screens are:

• TI-Nspire™ applications that allow images

• Microsoft® Word

• Microsoft® PowerPoint®

• Microsoft® Excel
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Copying a screen
1. Select the screen to copy.

2. Click  or select Edit > Copy.

The selected screen is copied to the clipboard.

Pasting a screen
Depending on the application you are pasting to, click Edit > Paste.

Note: You can also drag a screen capture to another application. This 
functions as a copy and paste.
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Working with Images

Images may be used for reference, assessment, and instructional 
applications. This section describes using images in the various 
applications.

Note: All image functionality described in this section applies to both 
handhelds and computer software unless otherwise noted.

TI-Nspire™ applications that can accept images
Images can be inserted into the following TI applications:

• Graphs - Image is set in background behind the axis and other 
objects. A maximum of one image can be used in each instance of this 
application but each instance can have the same or different image.

• Geometry - Image is set in background behind the axis and other 
objects. A maximum of one image can be used in each instance of this 
application but each instance can have the same or different image. 

• Data & Statistics - Image is set in background behind the axis and 
other objects. A maximum of one image can be used in each instance 
of this application but each instance can have the same or different 
image. 

• Notes - Image is set inline with text at the cursor location. You can 
use multiple images in this application.

• Question (includes Quick Poll) - Image is set inline with text at the 
cursor location. You can use multiple images in this application.
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Example applications using images

The Graphs application example shown above illustrates that each page 
can use the same or a different image, but only one image is allowed per 
page.

The Notes application example shown above illustrates that you can use 
multiple images and the image is placed in line with the text.
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Below is an example with two instances of an application running on the 
same page. You can have multiple instances on a page using the Page 
Layout option. For more information about Page Layout see the 
"Working with TI-Nspire™ documents.

Image types available
The following file types can be used in the TI-Nspire™ applications that 
accept images:

• JPG (Joint Photographic Experts Group)
• BMP (Device-independent Bitmap)

• PNG (Portable Network Graphics)
The transparency feature of .png is not supported. Any transparent 
.png backgrounds appear as white.

Inserting the image
There are two ways you can insert images into a document. 

Use the Insert command from the menu by browsing for the file. 

or 

Paste the image into the document from the Clipboard.

Warning: When inserting a second image in applications that can only 
accept one image (see “TI-Nspire™ applications that can accept images” ) 
the original image is replaced without warning.
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Using the Insert command
1. Select the application where you want to place the picture.

For example, Graphs.

2. From the Menu bar, click Insert > Image.

Note: If the application selected does not accept images, the menu 
item Image is grayed out.

3. Navigate to the image’s location and select your image.

4. Click Open.

The image appears in your application.
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Using Clipboard
These steps assume you have already copied or cut an image to the 
Clipboard from a TI-Nspire™ document, image file, or another program 
and have selected the image.

Copy: Edit > Copy or Ctrl + C (Mac®: Command + C)

Cut: Edit > Cut or Ctrl + X. (Mac®: Command + X)

Handheld: Ctrl + Menu (/ b) Copy or Paste

Inserting an image by pasting
1. Open the application and the document where you want to place the 

image.

2. Click Edit > Paste.

PC: Ctrl + V

Mac®: Command + V

Handheld: / b + Paste.

The image is now on the page. The application type determines 
whether the image displays in foreground or background. See 
“TI-Nspire™ applications that can accept images” .

Inserting an image using the context menu (right-click)
1. Open the application and the document where you want to place the 

image.

2. Right-click the area.
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3. Click Paste.

The image is now on the page. How the image behaves, (for example 
whether it displays in foreground or background) depends on the 
application’s type. See “TI-Nspire™ applications that can accept 
images” .

Working with images
When working with images, you have a visual cue that the image is 
selected by observing a bold and colored border around the image.

Selecting the image
Use one of these methods to select images as used in moving, resizing 
and deleting images.

Software: 
1. Right-click on the image to access the context menu. 

2. Choose Select > Image.

Handheld:
1. Once you are at the image, click Menu.

2. When the menu is displayed, select Actions > Select > Image.
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Moving an image
You can reposition an image by moving an image using your mouse or 
directional keys. 

1. Open the document that includes the image you want to reposition.

2. Select image. See “Selecting the image” for instructions.

The selected image will have a bold, colored border around it.

3. Use the mouse or directional keys to move the image horizontal (left, 
right) or vertical (up/down) by distinct steps.

Resizing image
1. Select the image. See “Selecting the image” for instructions.

2. Click the image. When selected the image displays a colored, bold 
border.

3. Hover the pointer over the image border. The cursor will change to a 
multisided-arrow. You can then hold the mouse button or if using a 
handheld use the touchpad arrows to move in or out. 

NOTE: If you resize by using one of the corner handles, the image 
retains the same proportions as it is resized. If you resize by using one 
of the side handles your image will lose its aspect ratio.

Example of resizing an image: side, corner, and move.

4. When the image is at the desired size, release.

Deleting the image
1. Open the document (if not already opened) that has the image you 

want to delete.

2. Select the image. See “Selecting the image” if you need help.

The selected image will have a bold, colored border around it.

3. Select Delete from the menu, the context menu, or the keyboard.

– Menu: Click on Edit > Delete.
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– Context menu: Right-click. Select Delete from the options 
displayed.

– Keyboard: Press the Delete key.

– Handheld: Select the image, then /  b  + Delete.

Technical considerations
• Number of images - There is no set limit on the total number of 

images in the TI-Nspire™ program or on a handheld. Available 
memory is the only limiting factor (other than the application 
limitations as stated in “TI-Nspire™ applications that can accept 
images” ).

• Image limitations- 

– Memory - The maximum image size you can attempt to insert is 
10 MB. This is not the actual size the image will retain, only the 
maximum size that the memory accepts before inserting. The 
TI-Nspire™ system automatically adjusts the image if necessary for 
performance.

If a document with images cannot be opened due to low available 
memory, the document is not opened and a notification is 
displayed. 

– Pixel - The resolution of an image is automatically adjusted to fit 
the screen when the document is displayed.

– Color - Maximum color depth is 65,000 colors on the computer, 
TI-Nspire™ CX Handheld and TI-Nspire™ CX CAS Handheld. The 
TI-Nspire™ Handheld and TI-Nspire™ CAS handheld is displayed 
at a maximum of 16 shades of gray.
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Working with PublishView™ documents

Use the PublishView™ feature to create and share interactive documents 
with teachers and students. You can create documents that include 
formatted text, TI-Nspire™ applications, images, hyperlinks, links to 
videos, and embedded videos in a format that is suitable for printing on 
a standard piece of paper, publishing to a web site or blog, or for use as 
an interactive worksheet.

PublishView™ features provide layout and editing features for 
presenting math and science concepts in a document where TI-Nspire™ 
applications can be interactively and dynamically linked with supporting 
media, enabling you to bring the document to life. Using the 
PublishView™ feature:

• Teachers can create interactive activities and assessments to used on 
screen.

• Teachers can create printed materials to complement documents used 
on TI-Nspire™ handhelds.

• When working with lesson plans, teachers can:

– Create lesson plans from existing handheld documents or convert 
lesson plans to handheld documents.

– Link to related lesson plans or documents.

– Embed explanatory text, images, video, and links to web 
resources.

– Build or interact with TI-Nspire™ applications directly from the 
lesson plan.

• Students can create reports or projects such as lab reports containing 
data playback, curve fits, pictures, and video — all on the same sheet.

• Students can print and turn in assignments on a standard piece of 
paper. 

• Students taking exams can use one tool to create a document that 
contains: all problems on the exam, text, images, hyperlinks, or 
videos, interactive TI-Nspire™ applications, screen shots, and layout 
options needed to print a document.

Software requirements
The PublishView™ feature is available in the following TI-Nspire™ 
software:

• TI-Nspire™ Teacher Software and TI-Nspire™ Student Software
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• TI-Nspire™ CAS Teacher Software and TI-Nspire™ CAS Student 
Software

• TI-Nspire™ Navigator™ Teacher Software

Note: Those using TI-Nspire™ Navigator software cannot exchange 
TI-Nspire™ PublishView™ documents electronically. PublishView™ 
documents can be exchanged using TI-Nspire™ Navigator™ for 
Networked Computers. TI-Nspire™ Navigator™ features such as 
autograding and porfolio storage are not available for PublishView™ 
documents.

Creating a new PublishView™ document
1. From the Documents workspace, select File > New PublishView™ 

Document or click  and select New PublishView™ Document.

• A blank letter-size document opens in the Documents workspace. 
The orientation is portrait, which cannot be changed.

• The default margin settings for the top and bottom margins are 
one-inch. There are no settings for side margins.

• By default, a problem is added to the document.

• By default, the document contains the page number in a # of # 
format at the bottom of the sheet.

• The scroll bars on the right side of the screen and at the bottom of 
the screen are active.

2. Add TI-Nspire™ applications and PublishView™ objects as needed to 
complete the document.
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About PublishView™ documents
When working with PublishView™ documents, it is important to keep 
the following points in mind:

• PublishView™ documents are saved as .tnsp files, which distinguishes 
them from TI-Nspire™ documents (.tns files). 

• When inserting PublishView™ objects into a document, the text, 
image, hyperlink, or embedded video are contained in boxes that can 
be moved and resized.

• When you insert TI-Nspire™ applications, they work the same way as 
pages in a TI-Nspire™ document. 

• In a PublishView™ document, objects can overlap each other and you 
can control which object is on top or bottom.

• Objects can be placed and positioned in a PublishView™ document in 
a free-form fashion.

• You can convert an existing TI-Nspire™ document to a PublishView™ 
document (.tnsp file).

• When you convert a PublishView™ document to a TI-Nspire™ 
document (.tns file), TI-Nspire™ applications are converted. 
PublishView™ objects containing text, hyperlinks, videos, and images 
are not converted.
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• You cannot create or open a PublishView™ document on a handheld. 
You must convert a PublishView™ document to a TI-Nspire™ 
document before sending it to a handheld. 

Exploring a PublishView™ document
The following example shows how you might use TI-Nspire™ 
applications and PublishView™ objects to build a PublishView™ 
document. In this example, borders are turned on to show the 
boundaries around the objects. Showing borders enables you to work 
with objects easily while building a document. When you are ready to 
print or publish the document to the web, you can select to the hide 
borders.

À

Á
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À Header. In this example, the header contains the title of 
the document. When the header area is active, you can 
type and format text as needed.

Á Problem break and name. In PublishView™ document, 
use problem breaks to control the page layout. You can 
select to hide or show problem breaks. Deleting a 
problem removes the contents of the problem and 
removes the space between problems when there are 
multiple problems. Problem breaks also enable you to use 
variables in PublishView™ documents. Variables that have 
the same name are independent of one another if they 
are used in different problems.

Â Text boxes. In this example, the introduction text and the 
text in boxes 1, 2, 3, and 4 is contained in text boxes. You 
can insert text and hyperlinks into a PublishView™ 
document using a text box. Text boxes can be resized and 
positioned as needed. PublishView™ text boxes are not 
retained when you convert a PublishView™ document to 
a TI-Nspire™ document. 

Ã TI-Nspire™ applications. In this example, the author uses 
Graphs & Geometry to show the math functions. When a 
TI-Nspire™ application is active in a PublishView™ 
document, the appropriate application menu opens in 
the Documents Toolbox. You can work in a TI-Nspire™ 
application just as you would in a TI-Nspire™ document. 
When you convert a PublishView™ document to a 
TI-Nspire document, applications are retained.

Ä Notes application. You can also use the TI-Nspire™ Notes 
application to add text to a PublishView™ document. 
Because Notes is a TI-Nspire™ application, it will be 
retained when you convert the PublishView™ document 
to a TI-Nspire™ document. Using the Notes application 
enables you to use an equation editor and can contain 
TI-Nspire™ math templates and symbols.

Å Video. This is an example of a video that is embedded in a 
PublishView™ document within a frame. Users can start 
and stop the video using the controls. Frames containing 
videos and images can be resized and positioned in the 
document as needed.
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Using the status bar in a PublishView™ document
When a PublishView™ document is open, options on the status bar are 
different than when working in a TI-Nspire™ document.

Æ Footer. By default, the footer area contains the page 
number, which cannot be edited. You can add other text 
above the page number if needed. Like the header, you 
can format text as needed.

À Document names are displayed in tabs. If multiple documents 
are open, the document names are listed. You can have 
TI-Nspire™ and PublishView™ documents open at the same 
time. In this example, Document 1 is an inactive TI-Nspire™ 

document ( ). Document 2 is the active PublishView™ 

document ( ). Click the X to close a document.

Á Click Settings to change General Settings and Graph and 
Geometry Settings. You can specify settings that are specific to 
an active document or set default settings for all 
PublishView™ documents. When you convert a TI-Nspire™ 
document into a PublishView™ document, the settings in the 
TI-Nspire™ document convert to the settings defined for 
PublishView™ documents.

Â Document View is not active in a PublishView™ document. 
You cannot switch between computer view and handheld 
view.

Ã  In TI-Nspire™ applications, use the Boldness scale to increase 
or decrease the boldness of text and line thickness within 
applications. Go to the left to decrease the boldness. Go to 
the right to increase the boldness.

For PublishView™ objects, boldness is used to match text 
within TI-Nspire™ applications to other text on the 
PublishView™ sheet. It can also be used to increase the 
visibility of Ti-Nspire™ applications when presenting a 
document to a class.

À Á Â Ã Ä Å
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Saving PublishView™ documents

Saving a new document

1. Select File > Save Document, or click . 

The Save TI-Nspire™ Document dialog box opens.

2. Navigate to the folder where you want to save the document or 
create a folder in which to store the document.

3. Type a name for the new document. 

4. Click Save to save the document.

The document closes and is saved with the extension .tnsp. 

Note: When you save a file, the software will first look in the same folder 
the next time you open a file.

Saving a document with a new name
To save a previously saved document in a new folder and/or with a new 
name:

1. Select File > Save As... from the menu.

The Save TI-Nspire™ Document dialog box opens. 

Ä When there are too many open document names to show in 
the status bar, click the forward and backward arrows ( ) to 
move through the documents.

Å
Click  to see a list of all open documents.
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2. Navigate to the folder where you want to save the document or 
create a folder in which to store the document.

3. Type a new name for the document. 

4. Click Save to save the document with a new name.

Note: You can also use the Save As... option to convert documents from 
TI-Nspire™ files to PublishView™ files or convert PublishView™ files to 
TI-Nspire™ files.

Exploring the Documents workspace
When you create or open a PublishView™ document, it opens in the 
Documents workspace. Use the menu options and the toolbar just as you 
would when working with a TI-Nspire™ document to: 

• Navigate to existing folders and documents using Content Explorer

• Open existing documents

• Save documents

• Use the copy, paste, undo, and redo options

• Delete documents

• Access TI-Nspire™ application-specific menus

• Open the Variables menu in TI-Nspire™ applications that allow 
variables

• Access and insert math templates, symbols, catalog items, and library 
items into a PublishView™ document

Note: For more information about the menu and toolbar options, see 
Using the Documents Workspace.

Exploring the Documents Toolbox
When a PublishView™ document is active, the Documents Toolbox 
contains tools needed for working with PublishView™ documents. You 
can add TI-Nspire™ applications to a problem, insert parts of existing 
TI-Nspire™ documents into a problem, and add PublishView™ objects.

The Documents Toolbox opens when you create a new PublishView™ 
document or open an existing PublishView™ document. When working 
in a PublishView™ document, Page Sorter and TI-SmartView™ emulator 
are not available.
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À In a PublishView™ document:

• Click  to open the application menu and tools needed to 
work with TI-Nspire™ applications and PublishView™ 
objects.

• Click  to open the Utilities panel where you can access 
Math Templates, Symbols, the Catalog, Math Operators, and 
Libraries.

• Click  to open Content Explorer.

Note: For more information about Utilities and Content 
Explorer, see Using the Documents Workspace.

Á Click  to collapse a pane containing a menu. Click  to 
expand a pane. 

À
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Using menus and the toolbar
When working in a PublishView™ document, select options from the 
menus or the toolbar in the Documents workspace to work with content 
and objects. When you insert an object into a PublishView™ document, 
you can manipulate it using the same tools as you would when working 
with a TI-Nspire™ document. In PublishView™ documents, you can:

• Right-click on an object to open a context menu, which displays the 
actions that can be performed on that object

• Use add, insert, and paste to add objects to a PublishView™ 
document

Â TI-Nspire™ applications. Drag and drop an icon to a problem to 
insert an application:

•  Calculator

•  Graph

•  Geometry

•  Lists & Spreadsheet

•  Data & Statistics

•  Notes

•  Vernier® Dataquest

•  Question Picker (Only available in TI-Nspire™ Teacher 
Software or TI-Nspire™ Navigator™ Teacher software).

Ã TI-Nspire™ Documents. Use this tool to locate and insert 
existing TI-Nspire™ documents (.tns files) into a problem. 

Ä PublishView™ Objects. Use this tool to drag and drop the 
following objects into a problem:

•  Image

•  Video

•  Text box

•  Hyperlink
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• Use delete and cut to remove objects from a PublishView™ document

• Move objects from one place to another within a PublishView™ 
document

• Copy objects from one document and paste them into another 
PublishView™ document

• Resize and scale objects such as text boxes and images

• Change the font face and size and apply formatting such as italics, 
bold, underline, and color to text

Note: For more information about menus and the toolbar, see Using the 
Documents workspace.

Using context menus
In TI-Nspire™ applications and in PublishView™ documents, context 
menus are drop-down menus that provide a list of options specific to the 
task you are working on. For example, when you right-click a cell while 
working in the TI-Nspire™ Lists & Spreadsheet application, a context 
menu opens providing a list of actions that you can perform on that cell. 
When you right-click the border of a text box in a PublishView™ 
document, the context menu provides actions that can be performed on 
the text box.

Context menus in TI-Nspire™ applications
When you insert a TI-Nspire™ application into a PublishView™ 
document, the application menu and the context menus associated with 
that application are available and work the same way they work in a 
TI-Nspire™ document.

Context menus in PublishView™ documents
In PublishView™ documents, context menus provide shortcuts to 
frequently performed tasks. Context menus are specific to an object or 
area:

• The Sheet context menu provides options for working with the layout 
of the sheet and document

• Object context menus provide options for manipulating the object

• Content-sensitive context menus provide options for working with 
the content inside the object such as text or a video.
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Working with PublishView™ objects
In a PublishView™ document, text, hyperlinks, images, and videos are 
contained in PublishView™ objects. You can move, resize, copy and 
paste, and delete an object within a PublishView™ document. Objects 
can also be positioned so that one overlaps the other.

Within a document, PublishView™ objects can exist in three states: 
unselected, selected, and interactive.

State Description

Unselected When unselected, an object 
does not have handles for 
repositioning and sizing. To 
deselect an object, left-click 
or right-click outside the 
object.

In this example, borders 
around the object are 
showing.

Selected When selected, an object 
will have eight square 
handles framing the object. 
To select an object, click the 
object’s borer. When 
selected, objects can be 
moved and resized.

• To move an object, 
select a border and drag 
the object to its new 
location. 

• To resize an object, grab 
a handle. 

• Right-click the border to 
open a context menu 
with options for 
manipulating the 
object.
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Inserting an object
1. In the Documents Toolbox, ensure the PublishView™ Objects menu is 

open.

2. Use your mouse to select an icon and drag it to the document.

3. Release the mouse button drop the object into the document.

Interactive An interactive state is 
indicated by a blue frame 
around the object. To enter 
interactive state, left-click 
or right-click anywhere in 
the body of the object. 
When in an interactive 
state, you can work with 
the contents of the object. 
For example, you can add 
or edit text in a text box or 
complete math functions in 
a TI-Nspire™ application. 
When in an interactive 
state, context menus 
contain options specific to 
the contents of an object.

State Description
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4. Using the mouse, grab the handles to resize the object and drag it to 
position the object in the document as needed.

Opening object context menus
Right-click the border of any object in a PublishView™ document.

The context menu opens to provide access to delete, copy/paste, cut, 
and bring to front/send to back actions.

Resizing an object
1. Click any border around the object to select it. The border becomes a 

bold blue line and the handles are active.

Selected text 
boxes and 
frames can 
be resized, 
moved, 
copied, 
pasted, and 
deleted.
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2. Move your mouse over one of the handles to activate the resizing 
tool.

3. Grab one of the handles and drag in the direction needed to make 
the object larger or smaller.

4. Click outside the object to save the new size.

Moving an object
To move an object to another location on the page:

1. Click any border around the object to select it. The border becomes a 
bold blue line and the handles are active.

2. Move your cursor over one of the borders to activate the positioning 
tool.

3. Click to grab the object. The horizontal and vertical alignment guides 
are activated at the top and bottom of the object. Use the grid lines 
to position the object on the page.

4. Drag the object to a new location on the page.

5. Release the mouse button to drop the object in its new location.

vertical 
alignment 
guide

horizontal 
alignment 
guide
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Overlapping objects
You can position objects so that one is on top of another. You can control 
the stacking order to specify which object is positioned in front or behind 
the other. Overlapping objects have many practical uses when presenting 
information in the classroom. For example, you can create a "curtain 
control" by placing and empty text box over other objects. Then, you can 
move the text box to reveal the items below it one at a time.

To change the position of an object in the stacking order:

1. Click the border of the object you want to position to select it, then 
right-click to open the context menu.

2. Click Send to back or Bring to front to move the selected object to 
the desired position.

Deleting an object
To delete an object from a sheet:
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1. Click any border of the object to select it. When an object is selected, 
the border is blue and the handles are active.

2. Press the Delete key to delete the text box or right-click a border, 
then select Delete from the context menu.

Choosing a working folder for PublishView™ objects
Use the Choose Your Working Folder field in the PublishView™ Objects 
pane to select a folder for storing PublishView™ documents and related 
files.

1. Ensure the PublishView™ Objects pane is open.

2. Click . 

The Choose Your Working Folder window opens.

3. Navigate to the folder where you want to store video and image files.

4. Click Open to choose the working folder.

The selected folder becomes the working folder and the folder name 
is displayed in the Choose your working folder field. Previews of 
supported images and video files in the folder are shown in the 
PublishView™ objects pane.
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5. To add an image or video file to a PublishView™ document, select the 
file and drag and drop it onto the active sheet.

Working with TI-Nspire™ applications
Note: For additional information about the TI-Nspire™ applications, see 
the appropriate chapter in this guidebook.

Adding an application to a problem
To add a TI-Nspire™ application to a problem in a PublishView™ 
document:

1. Choose one of the following actions to select an application:

• From the TI-Nspire™ Applications pane in the Documents Toolbox, 
use the mouse pointer to point to the application and drag it to 
the problem.

• From the menu bar, select Insert and choose an application from 
the drop-down menu.

• Right-click inside the sheet to open the context menu, select 
Insert and choose an application from the drop-down menu.

The application is added to the sheet. 
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2. Using your mouse, grab the handles to resize or position the 
application object as needed.

3. Click outside the application frame to accept the dimensions.

4. To open the menu for the active TI-Nspire™ application, click inside 
the application. The menu opens in the Documents Toolbox above 
the TI-Nspire™ Applications pane. 

Right-click on an application element, such as a cell or function to 
open the context menu for that item.

5. To work in the application, select an option from the application 

menu. Click  to collapse the application menu pane.
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Adding existing TI-Nspire™ documents
Use the TI-Nspire™ Documents pane to open an existing TI-Nspire™ 
document to add to a PublishView™ document. When you open an 
existing TI-Nspire™ document, all pages of the document appear in the 
preview pane. You can drag and drop complete problems or individual 
pages onto the PublishView™ sheet.

Choosing a working TI-Nspire™ document
To choose a working document:

1. In the Documents Toolbox, ensure the TI-Nspire™ Documents pane is 
open.

2. Click .

The Choose Your Working Document window opens.

3. Navigate to the folder where the TI-Nspire™ document is stored:

• Click ¤ in the Look in: field to use a file browser to locate a 
folder.

• From an open folder, click  to move up a level in the folder 
hierarchy
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• Click  to return to the default home folder 

• Click  to add a new folder to open folder on your computer. 

• Click  to list folders and files. To show details, click .

4. Select the file, then click Open.

The TI-Nspire™ document opens in the TI-Nspire™ Documents pane.

5. To add the TI-Nspire™ document to the PublishView™ document, 
drag and drop one page at a time or one problem at a time to the 
PublishView™ sheet.

If you are adding a problem with multiple pages, the pages are 
stacked on top of each other on the PublishView™ sheet. Move the 
top page to see the other pages.
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Working with problems
Like a TI-Nspire™ document, a PublishView™ document consists of one 
or more problems.

Problems are used to control the layout of a PublishView™ document so 
that you can isolate variables. When variables with the same name are 
used in multiple problems, variables can have different values. To add 
problems to PublishView™ documents, open the Sheet context menu or 
use the options on the Insert menu in the Documents workspace. When 
adding problems, keep the following guidelines in mind:

• By default, a new PublishView™ document contains one problem.

• You can insert a problem after any existing problem. 

• You cannot insert a problem in the middle of an existing problem.

• A new problem break is always inserted after the selected problem.

• Inserting a problem break adds empty space below the break. 

• Any object between two problem breaks is part of the problem above 
the break.

• The last problem includes all sheets and objects below the last 
problem break.

• Problem breaks are not relative to any object, which lets you move 
objects within a problem without affecting the problem break 
location.

Adding a problem
To add a problem to an open PublishView™ document:

1. Right-click anywhere on the sheet, then select Insert > Problem. 

The problem is added to the document below any existing problems. 
The problem break provides a visible divider between problems. 

2. To name the problem, highlight the default text, type a name, then 
click outside the text box to save the name.

The problem break is saved.

If a document has multiple problems, use the scroll bar on the right 
side of the document to move up and down through the problems.
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Managing problem breaks
Problem breaks are used to separate problems and variable sets. 

• Every problem has a problem break.

• A problem break becomes visible when a problem is added to a 
document.

• A problem break is represented by a dashed line with the name of the 
problem positioned on the left side of the sheet.

• By default, the problem name is shown as <Name of problem>. 
Highlight the default text to type a new name for the problem.

• Problem names do not have be unique. Two problems can have the 
same name.

Hiding and showing problem breaks
You can select to hide or show problem breaks in a PublishView™ 
document. By default, problems breaks are shown.

1. Right-click in any blank area of the document (outside of any object) 
to open the sheet context menu.

2. Select Layout Options.

The Show/Hide Options dialog box opens.

Note: You can also select View > PublishView™ Layout Options.

3. Deselect the Show problem breaks option to hide problem breaks in 
the document. Select the option to return to the default setting and 
show the problem breaks.

4. Click OK to close the dialog.

Renaming a problem
1. Click the existing problem name on the problem break line.

2. Type a new name for the problem.

3. Click outside the text box to save the new name.

Deleting a problem
To delete a problem, complete one of the following actions:
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Select the problem break and click  on the right side of the break.

Select Edit > Delete.

Right-click the problem break and select Delete.

Select the problem break and press the Delete or Backspace key.

When you delete a problem, all objects contained in the problem are 
removed and the space between the selected problem break and the 
next problem break is removed.

Organizing PublishView™ sheets
A PublishView™ document can have multiple sheets. A single sheet is 
displayed in the workspace on your screen. All work occurs in the 
PublishView™ objects and TI-Nspire™ applications within sheets.

Adding sheets to a problem
To add a sheet to a problem:

Select Insert > Sheet.

The sheet is added to the problem and the numbering increments by 
one.

Opening the sheet context menu
Right-click in any blank area (outside of any object) in a 
PublishView™ sheet.

A context menu opens with options for inserting problems, pages, 
applications, and PublishView™ objects, edit options for removing 
space or deleting a page, and options for hiding and showing 
problem breaks and object borders.

Page numbering
In a PublishView™ document, page numbering is displayed in the 
bottom margin (footer). By default, numbering is placed in the center of 
the PublishView™ sheet in a # of # format. You cannot edit or delete 
page numbering.



Working with PublishView™ documents 201

Working with headers and footers
PublishView™ documents contain space at the top and bottom of a sheet 
to add a header or a footer. Headers and footers can contain the date, 
the document name, the lesson plan name, the class name, your school’s 
name, or any other information needed to identify a document.

By default, headers and footers do not contain content and boundaries 
for the header and footer are hidden. To activate a header or footer for 
editing, click inside the top or bottom margin. When activated, a text 
box with a light gray border is displayed.

Inserting and editing text in headers and footers
1. Click inside the top or bottom margin.

The text box borders in the margin become visible and the object 
space is disabled. The cursor is placed in the header or footer space 
and the formatting menu opens.

2. Type the text.

• The default font is TI-Nspire™ true type, 12 pt, normal.

• By default, text is centered horizontally and vertically.

• Text can be aligned: left, center, right, or justified.

• Text that does not fit within the text box horizontally will wrap to 
the next line.

• Text that does not fit within the text box vertically will not be 
shown, but text is retained. (If you delete text, the hidden text will 
appear.)

header

footer
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3. Complete one of the following actions to save the text:

• Single-click anywhere outside the header or footer text box to 
save the text.

• Press Esc to save the text. 

The PublishView™ sheet becomes active and the formatting menu 
closes.

Showing and hiding borders
By default, borders are displayed when you insert an object into a 
problem. When you select to hide borders, the selection applies to all 
objects in the document and to objects that you add to the document. To 
hide the border:

1. Right-click in any blank area of the sheet (outside of any object) to 
open the context menu.

2. Select Layout Options. 

The Layout Options dialog box opens.

Note: You can also select View > PublishView™ Layout Options.

3. Deselect the Show object borders option to hide the borders around 
the objects in the problem. Select the option to return to the default 
setting and show borders.

4. Click OK to close the dialog.

Adding and removing space
To manage how PublishView™ objects appear on a sheet, you may need 
to add or delete space between objects.

Note: You can add and remove vertical space between objects using this 
method. To add or remove horizontal space between objects, move the 
object. 

Adding space
1. Right-click in the area outside of any object where you want to add 

space. The context menu opens.
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2. Select Edit > Add/Remove Space. The Add/Remove Space tool 
becomes active.

3. Use your mouse to position the tool to the exact place where you 
want to add space.

4. Click the tool, then drag down to select the amount of space you 
want to add. As you select the amount of space to be added, it is 
indicated in green.

Add/Remove 
Space tool
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5. Press the Enter key to add the space in between the objects. You can 
adjust the amount of space by dragging up and down before you 
press Enter.

Removing space
1. Right-click in the area outside of any object where you want to 

remove space. The context menu opens.

2. Select Edit > Add/Remove Space. The Add/Remove Space tool 
becomes active.

3. Use your mouse to position the tool to the exact place where you 
want to remove space.

4. Click the tool, then drag up to select the amount of space you want 
to remove. As you select the amount of space to be removed, it is 
indicated in red.

Add/Remove 
Space tool
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5. Press the Enter key to remove the space in between the objects. You 
can adjust the amount of space by dragging up and down before you 
press Enter.

Note: If there is not enough space on the sheet to accommodate the 
objects, the objects won’t be moved when space is removed.

Deleting blank sheets from problems
You can delete a sheet that does not contain any TI-Nspire™ applications 
or PublishView™ objects from a problem. To delete a blank sheet from a 
problem:

1. Delete any TI-Nspire™ applications, PublishView™ objects, move or 
delete any problem breaks from the sheet.

2. Place your cursor inside the sheet you want to delete.

3. Right-click inside the blank sheet to open the context menu.

4. Select Edit > Delete Sheet.

The blank sheet is removed from the problem.

Adding text to a PublishView™ document
In a PublishView™ document, there are three ways to add text:

• Insert a PublishView™ text box to enter free-form text or copy text 
from other sources into the document. For example, you can place a 
PublishView™ text box next to an image and type a description in a 
text box. You can also copy and paste text from .doc, .txt, and .rtf 
files. Use PublishView™ text boxes when you need options for 
emphasizing and formatting text. PublishView™ text boxes are not 
converted when you convert a PublishView™ document to a 
TI-Nspire™ document. You may want to use a PublishView™ text box 
to add text that you don’t want handheld users to see.

• Use the TI-Nspire™ Notes application. You should use the Notes 
application when you need an advanced equation editor and when 
you need to use TI-Nspire™ math templates and symbols. Superscript 
and subscript are also easier to use in the Notes application. You 
should also use Notes when you are planning to convert the 
PublishView™ document to a TI-Nspire™ document for use on a 
handheld and you want handheld users to see the text. 

• Add text in TI-Nspire™ applications that allow text just as you would 
in a TI-Nspire™ document.

Inserting text into a text box
1. Ensure the PublishView™ Objects pane is open.
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2. Use your mouse to select  and drag it to the problem.

3. Release the mouse button drop the text box into the problem.

4. Using the mouse, grab the handles to resize the text box or position 
in the problem as needed.

5. Click outside the text box to save the size and position.

6. Click "Type your text here." 

The formatting menu opens and the text becomes active.

7. Type the new text or copy and paste text from another file. 

8. Apply formatting as needed.

9. Click outside the text box to save the text.

Text box is in an 
interactive state 
for adding or 
editing text.
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Formatting and editing text
The options for editing and formatting text are located on a formatting 
toolbar attached to the text box when the text box is active. Formatting 
options for editing text include:

• Changing the font, font size, and font color

• Applying bold, italics, and underline formatting

• Applying the following text horizontal alignment options: left, right, 
centered, and justified.

• Inserting hyperlinks

Launching edit mode
Click inside a text box to launch edit mode. 

• The formatting menu opens.

• The text is selectable for editing. 

Opening the content context menu
Right-click inside a text box containing text or a hyperlink.

The formatting menu and context menu open providing shortcuts to 
cut, copy, and paste.

Using hyperlinks in PublishView™ documents
In PublishView™ documents, use hyperlinks to:

• Link to a file

• Link to a web site on the Internet

You can add a hyperlink to an open document or you can convert any 
text within a text box to a hyperlink. When a hyperlink is added, the 
formatting of the text is underlined and the font color is blue. You can 
change the formatting of the hyperlinked text without losing the 
hyperlink.

When you link files, it is best to store the files on a network datashare or 
online storage site before creating the hyperlinks. This enables you to 
freely share your PublishView™ document with anyone who has access 
to the datashare or storage site and the links will remain accessible. Links 
to files on your local hard drive should only be used if you do not plan to 
share the document.
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If you choose use local links, you can rename the PublishView™ 
document or move it to a different location on your computer and the 
links will remain intact. However, be sure to keep the target files in the 
same location. If you move the files or if the path name changes, the 
links to the files will no longer work.

If a link is broken, an error message is displayed when you click the link:

• Cannot open the specified file

• Cannot open the specified web page

Linking to a file
You can link to any file on your computer. If the file type is associated 
with an application on your computer, it will launch when you click the 
link.

Complete the following steps to add a link to a file to a PublishView™ 
document. 

1. Ensure the PublishView™ Objects pane is open.

2. Click , then drag and drop the icon onto the sheet.

The Add Hyperlink dialog box opens.
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3. Type the name of link in Text field. For example, this can be the name 
of the document.

4. Click  to select Link to a file.

The Select file to insert as a hyperlink dialog box opens.

5. Navigate to and select the file you want to link to, then click Insert.

The path name is inserted into the Address field in the Add Hyperlink 
dialog box.

6. Click OK. 

A text box containing the hyperlink is added to the PublishView™ 
document.

7. Using the mouse, grab the handles to resize the text box or grab any 
border to position the text box in the document as needed.
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Linking to a web site
Complete the following steps to add a link to a web site.

1. Ensure the PublishView™ Objects menu is open.

2. Click , then drag to icon to the document to open the Add 
Hyperlink dialog box.

3. Type the name of link in Text field. For example, this can be the name 
of a web site.

4. Click  to select Link to a page on the Internet. 

Your browser opens to your default web site.

5. Navigate to the web site or file on a web site that you want to link to.

6. Copy the URL, then paste it in the Address field in the Add Hyperlink 
dialog box.

7. Click OK.

A text box containing the hyperlink is added to the PublishView™ 
document.

8. Using the mouse, grab the handles to resize the text box or grab any 
border to position the text box in the document as needed.

Editing a hyperlink
To change the name of a hyperlink, change the path, or change the URL, 
complete the following steps.

1. Using your mouse, right-click the hyperlink text, then select Edit 
hyperlink.

The Edit Hyperlink dialog box opens.
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2. Make corrections as needed:

• Type corrections to the hyperlink name in the Text field.

• Click  to open the Select a file to add as a hyperlink 
dialog box and use the file browser to navigate to the folder 
where the file is located.

• Click  to open a browser and navigate to a web site to copy 
and paste the correct the URL in the Address field.

3. Click OK to save the changes.

Converting existing text to a hyperlink
1. Click inside the text box to activate edit mode and open the 

formatting menu.

2. Select the text you want to convert to a hyperlink.

3. Click . 

The Add Hyperlink dialog box opens with the selected text in the Text 
field.

4. Click  to create a link to a file.

—OR—

Click  to create a link to page on a web site.

Removing a hyperlink
Use this process to remove a link from text inside a text box. The text 
remains in the document.
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1. Using your mouse, right-click the hyperlink text.

2. Select Remove hyperlink.

The hyperlink formatting is removed from the text and the text is no 
longer clickable.

Note: To remove both the text and hyperlink, delete the text. If a text 
box contains only the linked text, delete the text box.

Working with images
Images can be added to PublishView™ documents as PublishView™ 
objects or can be added inside TI-Nspire™ applications that support 
images. Supported files types are .bmp, .jpg, and .png files. 

Note: If a TI-Nspire™ application is active in the PublishView™ 
document, the image is added to the TI-Nspire™ page if you select 
Insert > Image from the menu bar or context menu. If there is no 
TI-Nspire™ document active, the image is added as a PublishView™ 
object. Only images inside TI-Nspire™ applications convert to TI-Nspire™ 
documents (.tns files).

Inserting an image
1. Ensure the PublishView™ Objects pane is open.

2. Click , then drag to icon to the document.

The Choose an image to insert into PublishView™ dialog box 
opens.

Note: By default, the Texas Instruments preloaded images folder is 
displayed.
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3. Navigate to the folder where the image file you want to insert is 
located, then highlight the file name.

4. Click Insert image.

The image is added to the PublishView™ sheet.

5. Using the mouse, grab the handles to resize the text box or grab any 
border to position the text box in the document as needed. 

Moving images
1. Click the frame containing the image to select it.

2. Move your cursor over the edge of the image to activate the 

positioning tool.  

3. Drag and drop the image to its new location on the PublishView™ 
sheet.

Note: Objects can overlap each other on a PublishView™ sheet.
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Resizing images
1. Click the frame containing the image to select it.

2. Move your cursor over one of the blue handles to activate the 

resizing tool. 

3. Drag the handle to make the image smaller or bigger.

Deleting images
Click the image to select it, then press the Delete key.

—OR—

Right-click a handle to open the context menu, then select Delete.

Working with video files
You can embed a Flash (.flv) video file in a PublishView™ document and 
play the video directly from the PublishView™ document. 

Note: You can also insert a link to a video that will launch in a new 
browser window or media player window. See Working with Hyperlinks.

Inserting a video
1. Ensure the PublishView™ Objects pane is open.

2. Click , then drag the icon to the document.

The Choose a video to insert into PublishView™ window opens.
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3. Navigate to the folder where the video file you want to insert is 
located, then highlight the file name.

4. Click Insert video.

An object containing the embedded video is added to the 
PublishView™ sheet. By default, the resizing and positioning handles 
are active.

5. Using the mouse, grab the handles to resize the object or grab any 
border to position the object in the document as needed. For 
example, you may want to position the object containing the video 
above or below a text box that contains text introducing the video.

6. To play the video, click the forward arrow.

Using the video console
The video console enables users to control when to start and stop the 
video. 

The console contains the following controls:

À Click  to start the video. When playing, click  to stop the 
video.

Á As the video plays, the time elapsed is shown in minutes and 
seconds.

Â When the video starts, the length of the video is shown in 
minutes and seconds.

À Á Â Ã
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Using the video context menu
Right-click on the box containing the video to open the video-specific 
context menu.

Adjusting Adobe® Flash® Player settings
For information about Adobe® Flash® Player 10, please refer to Flash® 
Player Help at http://www.macromedia.com/support/documentation/.

Converting documents
You can convert PublishView™ documents (.tnsp files) to TI-Nspire™ 
documents (.tns files) for display on handhelds. You can also convert 
TI-Nspire™ documents to PublishView™ documents.

Ã Shows how high or low the volume is. You cannot control the 
volume with this control. Use the volume control on your 
computer to increase or decrease the volume.

Option Function

Settings Click to disable or enable hardware 
acceleration. 

Global Settings Opens the Adobe® Flash® Player Help web 
site.

About Adobe® Flash® 
Player 10

Opens the Adobe® Flash® Player web site. 
Open this site to find out which version you 
have or download a more current version of 
the player.
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Converting a document creates a new document — the original 
document remains intact and is not linked to the new document. If you 
make changes to one document, the changes are not reflected in the 
other document.

Converting PublishView™ documents to TI-Nspire 
documents
You cannot open a PublishView™ document (.tnsp file) on a handheld. 
However, you can convert the PublishView™ document to a TI-Nspire™ 
document that can be transferred to and opened on a handheld. When 
you convert a PublishView™ document to a TI-Nspire™ document:

• Only the TI-Nspire™ applications become part of the TI-Nspire™ 
document. 

• PublishView™ objects such as text boxes, images, hyperlinks, and 
videos are not converted.

• Text contained in PublishView™ text boxes is not converted; however, 
text in a TI-Nspire™ Notes application is converted.

• If images are contained in a TI-Nspire™ application, they are 
converted; however, images contained in PublishView™ objects are 
not converted.

Complete the following steps to convert a PublishView™ document 
(.tnsp file) to a TI-Nspire™ document (.tns file).

1. Open the PublishView™ document to be converted.

2. Select File > Convert to > TI-Nspire™ Document.

• The new TI-Nspire™ document opens in the Documents 
workspace. 

• All supported TI-Nspire™ applications are part of the new 
TI-Nspire™ document. 

• Starting from top to bottom, then left to right, the layout of the 
TI-Nspire™ document is based on the order of the TI-Nspire™ 
applications in the PublishView™ document. 

– Every TI-Nspire™ application in a PublishView™ document will 
appear as a page in the converted TI-Nspire™ document. The 
order of the pages in the TI-Nspire™ document is based on the 
layout of the TI-Nspire™ applications in the PublishView™ 
document.

– If two or more problems are at the same level, the order is left 
to right.

• Problem breaks are maintained.
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• The new TI-Nspire™ document is not linked to the PublishView™ 
document. 

3. When work in the document is complete, click  to save the 
document in the current folder or select File > Save As... to save the 
document in a different folder. 

Note: If the document has never been saved, both the Save and Save 
as options allow saving in a different folder.

Note: You can also use the Save as... option to convert a 
PublishView™ document to a TI-Nspire™ document.

Note: If you try to convert a PublishView™ document that does not 
contain TI-Nspire™ pages or applications, an error message is displayed.

Converting TI-Nspire™ documents to PublishView™ 
documents
You can convert existing TI-Nspire™ documents to PublishView™ 
documents, which enables you to take advantage of the richer layout 
and editing features for printing, generating student reports, creating 
worksheets and assessments, and publishing documents to a web site or 
blog.

Complete the following steps to convert a TI-Nspire™ document to a 
PublishView™ document:

1. Open the TI-Nspire™ document you want to convert.

2. Select File > Convert to > PublishView™ Document.

• The new PublishView™ document opens in the Documents 
workspace. 

• By default, there are six objects per page. 

• When converted, each problem from the TI-Nspire™ document 
will start a new sheet in the PublishView™ document.

• Problem breaks are maintained. 

3. When work in the document is complete, click  to save the 
document in the current folder or click File > Save As... to save the 
document in a different folder.

Note: You can also use the Save as... option to save a TI-Nspire™ 
document as a PublishView™ document.
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Printing PublishView™ documents
You can print reports, worksheets, and assessments created using the 
PublishView™ feature. To print a document:

1. Select File > Print.

The Print dialog box opens. A preview of the document is shown on 
the right side of the dialog box.

2. Select a printer from the drop-down menu.

Note: The Print what field is disabled. 

3. Select Paper Size from the drop-down menu. Options are:

• Letter (8.5 x 11 inches)

• Legal (8.5 x 14 inches)

• A4 (210 x 297 mm)

4. Select the number of Copies you want to print.

5. In the Print Range area, select to print all pages in the document, a 
range of pages, or the current page only.

Note: By default, top and bottom margins are set to one-inch and are 
maintained when printing a PublishView™ document. There are no 
side margins. PublishView™ sheets print just as they appear in the 
workspace.

6. If needed, select or deselect the boxes to:
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• Print Problem Breaks and Names. 

• Print Headers

• Print Footers

• Show object borders

7. Click Print.
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Embedding documents in web pages

Using the Export features in the TI-Nspire™ software along with the 
TI-Nspire™ Document Player, you can embed both TI-Nspire™ documents 
and PublishView™ documents within  pages. You can then publish the  
documents as web pages or share them using email, datashare, or an 
online storage site.

By default, the embedded documents are displayed in the TI-Nspire™ 
Document Player when opened. Anyone can view and interact with the 
embedded TI-Nspire™ or PublishView™ documents within the 
TI-Nspire™ Document Player — even if you don’t own TI-Nspire™ 
software.

Using embedded web pages
There are two ways to create embedded web pages:

• Use the Export functions in the TI-Nspire™ software to generate the 
code needed to embed a document in a web page.

• Create your own HTML code using a text editor or HTML editor. Code 
examples are shown in this document.

To use embedded web pages:

• You must be connected to the Internet to load the 
TI-Nspire™ Document Player and view the embedded document.

• If publishing a document to the web, you will need to post the 
original TI-Nspire™ or PublishView™ documents online and update 
the HTML source code to reflect the URL of the online document. 

• You can embed documents that are already available online. For 
example, you can embed a document from the TI Activities Exchange 
web site.

• You can embed documents in any container that supports HTML and 
Java™ applets. For example, you can embed documents in Learning 
Management Systems such as Moodle or Blackboard™.

• You can embed a web page in a Microsoft® PowerPoint presentation. 
This requires a third-party add-in for PowerPoint. Some add-in 
utiltities are often available at no cost such as the add-in available 
from Live Web (http://skp.mvps.org/liveweb.htm).

Viewing embedded web pages
To view embedded TI-Nspire™ and PublishView™ documents, you must 
have:
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• A Web browser 

– Microsoft® Internet Explorer® 7.0 and above

– Mozilla® FireFox® 4.0 and above

– Google® Chrome® 5.0 and above

– Apple® Safari® 5 and above

• Java™ Version 6 Update 22 (version 1.6.0_22) or later

If you plan to view PublishView™ documents containing video files, you 
must have Adobe® Flash® Player 10.

Using TI-Nspire™ HTML Inline Frames
TI-Nspire™ and PublishView™ documents are embedded using an HTML 
Inline Frame or "iframe." You can embed your TI-Nspire™ or 
PublishView™ document by typing the iframe code into an HTML 
document. When you create an iframe using an HTML or text editor, the 
embedded iframe code might look like the code in the following 
example. When creating your own code for the iframe, you will need to 
know the web address of the embedded document and include this 
address in your code.

Example: Hard-coded iframe

Line breaks are not recognized in HTML source code. You may see the 
iframe code strung together on a single line when you view the source 
code in a text editor or HTML editor. To make the code easier to view, 
you can manually add line breaks or enable Word Wrap. The following 
example shows the code without line breaks.

<iframe 
src="http://education.ti.com/go/nspireplayer?nspirefile=http://my.site.
com/myfile.tns" 
width="700"  
height="500"  
scrolling="no"  
frameborder="0">
</iframe>

<iframe src="http://education.ti.com/go/nspireplayer? 
nspirefile=http://my.site.com/myfile.tns" width="700" height="500" 
scrolling="no" frameborder="0"></iframe>
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Iframe tags and attributes
The HTML code is opened and closed with iframe tags: <iframe> and 
</iframe>. The iframe tags tell the web browser to display an embedded 
window on a web page. Within the iframe code, you’ll see attributes and 
attribute values that control the content and appearance of the frame. 
Attribute values are usually enclosed in quotation marks.

Using the Source (src) attribute
In the iframe example, the first attribute is the source attribute indicated 
by the "src=" code. The value of this attribute is specific to TI-Nspire™ 
content. The value can be modified to define the location of the 
embedded document and the tools available within the embedded 
document.

The source attribute contains the Internet address (URL) of the 
TI-Nspire™ Document Player, which is:

http://education.ti.com/go/nspireplayer

--OR--

http://education.ti.com/go/nspireplayer/3.0.1

You can add parameters the the source attribute to control the 
appearance of the embedded TI-Nspire™ Document Player. These 
parameters are optional. For more information, see Customizing the 
embedded Document Player.

Defining the nspirefile parameter
The nspirefile parameter is always last in the line of code and specifies 
the URL or the file system address (path) of the document you are 
embedding. You may need to modify this parameter to enable sharing 
your embedded page with others.

The path of the document can be an absolute address or a relative 
address:

• Absolute address - Identifies a specific and unique location or path 
that is not defined by reference to any other address. When using an 
absolute address, you must specify the full URL. If you move the 
documents, the URL must be modified. 

• Relative address - Identifies a location in relation to another 
location. When using a relative address, the URL contains only the file 
name, which means your document must be in the same directory as 
the embedded web page. As long as your document and the .html 
file containing the embedded document are in the same folder, the 
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URL will find the document even if you move the folder. To use a 
relative address, see Using dynamically-generated iframes.

Using other iframe attributes
Other iframe attributes that control the appearance of the iframe on the 
web page are width, height, scrolling, and frame border. The values for 
these attributes are standard and are not specific to TI-Nspire™ content. 
The following table contains a list of standard iframe attributes for your 
reference. For more information about iframe attributes, see 
http://www.w3schools.com/TAGS/tag_iframe.asp.

Attribute Description

Specifies the alignment of an  according to 
surrounding elements. If used, values are left, 
right, top, middle, or bottom. The align attribute 
will work, but is no longer widely used. Styles are 
widely used today.

To use styles to center the Document Player on a 
page, surround the  with division () tags:

Specifies whether or not to display a border 
around an . Values are:

1 = show border

0 = no border

Specifies the height of the frame in pixels.

The URL that points to the page containing a 
long description of the content in the iframe.

Defines the top and bottom margins in pixels.

Defines the left and right margins in pixels.

The name of the iframe.

Specifies whether or not to show scrollbars in an 
iframe. Values are yes, no, or auto.

The  of the document contained in the iframe.

Defines the width of the iframe in pixels.
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Using dynamically-generated iframes
To use relative address, you must use a dynamically-generated iframe. 
This code generates an HTML iframe when the page is loaded. The 
"nspirefile" parameter holds the location and file name of the 
TI-Nspire™ or PublishView™ document that is to be shown on the page. 
If the "nspirefile" parameter contains only the file name instead of the 
full URL, you must upload the TI-Nspire™ or PublishView™ document to 
your web server and ensure that it resides in the same folder as your blog 
or web page.

Line breaks are not recognized in HTML source code. You may see the 
iframe code strung together on a single line when you view the source 
code in a text editor or HTML editor. To make the code easier to view, 
you can manually add line breaks or enable Word Wrap. The following 
example shows the code without line breaks.

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></
script>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
    // IFRAME attributes.
    {   
        src : 'http://education.ti.com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters.
    {  
        nspirefile : 'myfile.tns'
    }
);
</script>

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></
script>
<script type="text/javascript"> 
tiDeployPlayer.tiCreateIframePlayer({src : 
'http://education.ti.com/go/nspireplayer', width : '640', height : 
'480', scrolling : 'no', frameborder : '0' },{ nspirefile : 
'myfile.tns'});</script>
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Using the TI-Nspire™ Document Player
The TI-Nspire™ Document Player launches automatically when you open 
an  document that contains an embedded TI-Nspire™ or PublishView™ 
document.The TI-Nspire™ Document Player plays directly from the 
Internet and does not require any other Texas Instruments handhelds or 
software.

Note: If this is your first time opening the player on your computer, you 
are asked to accept the license agreement. This is only needed once for a 
specific machine.

Exporting to a web page
Use the File > Export Web Page option to create a stand-alone web page 
that can be used as is or that can be modified.

1. Open the TI-Nspire™ document or PublishView™ document you want 
to embed in a web page.

2. Select File > Export Web Page.

The Web Page Text dialog box opens.

3. Type the title of the web page in the Web page title field. The title 
will centered at the top of the web page. This is also the default 
name for the  file.
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4. If you want to include additional text above the , type the text in the 
Text above the embedded window field.

To include text below the , type the text in the Text below the 
embedded window field.

5. Click Export.

The Save Web Page window opens.

6. In the Save in field, navigate to the folder where you want to save 
the file. 

7. In the File Name field, type the name of the file if different than the 
default name.

8. Do not change the file type. By default, the file type is . 

9. Click Save.

The  file is saved to your computer. The embedded web page 
automatically opens in your default web browser. If you move your 
exported  file to another folder, you must also move the associated 
TI-Nspire™ or PublishView™ document.

When the TI-Nspire™ document or PublishView™ document is 
exported to a web page, a copy is made of the document. This copy is 
saved with the same names as the exported HTML file and will be 
saved in the folder where you save the HTML file.
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Exploring the web page

À Browser window title bar. The Texas Instruments default title is 
shown here. 

Á The absolute  or file system path identifying where the  
document is located.

Â Web browser menu bars and tool bars.

Ã Title of the embedded web page as specified in the Web page 
title field. 

Ä The text as specified in the Text above the embedded window 
field. Text that appears below the frame is specified in the Text 
below the embedded window field.

Å The  containing the embedded document.

À

Á

Â

Ã

Ä
Å

Æ
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Customizing an embedded TI-Nspire™ Document 
Player
The following example shows the  code needed to embed a document 
that will be stored on the Texas Instruments Activities Exchange or on the 
education.ti.com web site.

Æ The TI-Nspire™ Document Player tool bar. These tools enable 
you to interact with the document within the TI-Nspire™ 
Document Player.

•  Open another TI-Nspire™ or PublishView™ document on 
your computer.

•  Save the original TI-Nspire™ or PublishView™ document. 
Any changes you made in the TI-Nspire™ Document Player 
window are not saved.

•  Link to your online storage site. For example, , or . When 
you link to a site, the document path is copied to the 
clipboard and can be pasted into the sharing site’s upload 
field. You can also add your own sites such as your  or  site.

•  Print the original embedded document or print the 
document with changes you made in the TI-Nspire™ 
Document Player.

•  Undo the last change you made. 

Note: The only changes you can make are mouse-driven. The 
player does not accept text edits or keyboard input.

• Redo the last change you made. 

•  Reset -- Resets the document back to its original state 
before any changes were made. 

For more information about the TI-Nspire™ Document Player, 
see the online TI-Nspire™ Document Player guide.
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--OR--

Notice the parameters  and . These settings were used to customize the 
TI-Nspire™ Document Player so that it launches with the toolbar locked 
in the expanded (visible) state and with the Open icon hidden. The 
following table contains a list of TI-Nspire™ Document Player 
parameters. When adding parameters to the  code, be sure to separate 
each parameter with an ampersand character (&).

<iframe src="http://education.ti.com/go/nspireplayer? lock_toolbar=yes& 
openDoc=no&nspirefile=http://education.ti.com/xchange/US/Math/Algeb
raI/11340/From_Expressions_to_Equations.tns" width="700"  
height="500"  scrolling="no"  frameborder="0"></iframe>

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
    tiDeployPlayer.tiCreateIframePlayer(
        // IFRAME attributes.
        {   
    src : 'http://education.ti.com/go/nspireplayer', 
    width : '360',  
    height : '290',  
    scrolling : 'no',  
    frameborder : '0'  
        }, 

        // TI-Nspire(tm) Document Player parameters. 
        {  
            nspirefile : 
'http://education.ti.com/xchange/US/Math/AlgebraI/11340/ 
From_Expressions_to_Equations.tns ',
            lock_toolbar:'yes',
            openDoc:'no'
        }
    );
</script>
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Attribute Description

Determines if the toolbar is expanded or 
collapsed when the application is opened. If the 
parameter is not specified, the toolbar opens in 
the expanded state. To collapse the toolbar when 
the application is opened, set this parameter to 
"No."

When this paramter is set to "No," the toolbar 
hide arrow is removed and the state of the 
toolbar is locked. If this parameter is not 
specified, the toolbar arrow is shown and the 
toolbar is unlocked. 

Controls the visibility of the Open icon in the 
toolbar. To hide the Open icon, set this parameter 
to "No." If not specified, the Open icon is shown. 
The  parameter must also be set for this setting to 
be accepted.

Controls the visibility of the Save Local Copy icon 
in the toolbar. To hide the Save Local Copy icon, 
set this parameter to "No." If not specified, the 
Save Local Copy icon is shown. The  parameter 
must also be set for this setting to be accepted.

Controls the visibility of the Save Online icon in 
the toolbar. To hide the Save Online icon, set this 
parameter to "No." If not specified, the Save 
Online icon is shown. The  parameter must also 
be set for this setting to be accepted.

Limits the visibility of a document to a single 
page in the embedded window. The value of the  
is the ordinal page number of the page within 
the TI-Nspire™ document or PublishView™ 
document being embedded. The  parameter must 
also be set for this setting to be accepted.
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By default, the language setting for Document 
Player is set by the operating system. The  
attribute enables you to manually change the 
preferred language. Values are:

 = Danish

 = German

 = English

 = Spanish

 = Finnish

 = French

 = Italian

 = Netherlands (Dutch)

 = Norwegian

 = Portuguese

 = Swedish

 = Simplified Chinese

 = Traditional Chinese

Identifies the storage location of the 
TI-Nspire™ document or PublishView™ 
document to be embedded. The value can be the 
absolute URL, the file system path, or the relative 
address. 

If using the relative address, you can use only 
document file name (for example, "myfile.tns"). 
The Document Player assumes the document is in 
the same directory as the exported  document, 
which makes the exported web page portable. 
This means you can put the  document and the 
embedded document in the same folder, then 
copy that folder anywhere and the page will still 
work with no changes to the source code.

This is useful when you want to share files with 
someone via email but don’t want to post the file 
online.

Attribute Description
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Using Export to generate  source code
The Export options in all versions the TI-Nspire™ software enable you to 
easily and automatically generate the required  code and  needed to 
embed a document in an . The code generated when using Export 
produces the  each time the web page is loaded using . This is more 
flexible and robust than the hard-coded . For example, using  enables 
you to use relative addressing to refer to your embedded documents. 
With relative addressing, the web page will find and display your 
document as long as the document is stored in the same folder as the  
file. This is especially helpful when sharing offline web pages.

Export options
TI-Nspire™ software provides two options for exporting documents in 
HTML format:

• Export Web Page
Use this option to produce a complete HTML document containing an 
embedded window for your TI-Nspire™ or PublishView™ document 
and supplementary text. This stand-alone web page can be used 
without any changes or embellished using third-party software.

• Export HTML to Clipboard
Use this option to produce a code snippet that can be pasted into 
existing web pages or blogs. A code snippet contains a few lines of 
HTML code that embeds a window into an existing page.

Both the full HTML document and the code snippet can be easily edited 
using any text editor or HTML editor. Editing the HTML document 
enables you to:

• Change the source location of the embedded TI-Nspire™ or 
PublishView™ document, which may be required to publish or share 
the HTML document.

• Modify the HTML to open the TI-Nspire™ or PublishView™ document 
in a dedicated browser window.

• Change the appearance of the embedded or dedicated window 
containing the TI-Nspire™ or PublishView™ document.

Viewing the source code
After the web page is created, you can view and edit the source code. 
The source code can be modified using any text editor or third-party  
editor. To view the source code:

From your web browser’s menu bar, select View > Source.

Note: The option for viewing source code may differ depending on 
your default browser.
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—OR—

Open a text editor such as Notepad, then open the  file within the 
text editor.

The source code is displayed. 

Note: In some browsers, viewing the source code opens a text editor. 

The following example shows source code that contains comments to 
help anyone unfamiliar with HTML to understand and successfully 
modify the code. 
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<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 
Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>

<!--
Thanks for creating a web page containing a TI-Nspire(tm) or 
PublishView(tm) document. This page can easily be modified to fit your 
needs.  If you are not familiar with HTML, here are some basics to get you 
started: 

HTML DOCUMENTS
HTML documents are text documents that define a web page. 
The text itself is known as source code.   You are viewing source code now.
HTML documents become web pages when opened in a browser.
HTML documents have a Header (usually hidden information) and a Body 
(displayed content).
TAGS
The appearance of your page is controlled by "tags".
Tags are surrounded by angle brackets <> .
Some elements require a start tag <> and an end tag </> .
LINES
Lines in the source file mean nothing when displayed as a web page.
Instead, tags are used to control lines on the page.
<br> creates a line break, just like hitting Enter key on your keyboard.
<p> creates a new paragraph.  The browser will typically put empty space 
around this tag.
COMMENTS
Comments are used to explain the source file and are not displayed on the 
web page.
<!-- begin a comment.
- -> end a comment.

See http://www.w3.org/TR/REC-html40/struct/global.html for more 
information on HTML.

That's it!
Your page starts below.
-->
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<head>
<!-- The line below tells the browser the Title of your Web Page. This may 
be displayed in title bar of your browser.  -->
<title>TI-Nspire&trade; Interactive Web Page</title>

<!-- The lines below help browsers and search engines quickly get 
information about your page. These are not displayed on the page. -->
<meta name="author" content="Your Name">
<meta name="keywords" content="Your Keywords">
<meta name="description" content="Your Page Description">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="keywords" content="&quot;ti-nspire document 
player&quot;,&quot;nspire document player&quot;,&quot;ti-
nspire&trade; document player&quot;,texas instruments, education.ti.com, 
ti-nspire, ti nspire, nspire, tinspire, nspire cas, ti-nspire cas, computer, 
software, publishview, publish view, publishview(tm), tns file, tnsp file, 
document player, ti-nspire player, nspire player, player, interactive math, 
mathematics, cas, student understanding, interactive classroom, educator's 
classroom computer">
</head>
<body bgcolor="#FFFFFF" TEXT="#000000">
<!--  Note the background color and text color are included with the "body" tag.  You can find out more 
about color codes here:  http://en.wikipedia.org/wiki/Web_colors -->

<!--The lines below create a high level header centered on the page.  It is very common to show the page 
title in this way. -->
<center>
<font size="5"><b>INSERT TITLE FROM DIALOG</b></font>  <br>
</center>

<!--The line below creates a visible line across the page. It automatically adjusts to a % of the window 
width.-->
<hr width="80%" align="center">

<!--Remove comment tags from the line below to create a bold section title.  .-->
<!--  <font size="4"><b>Instructions</b></font> <br>  -->

<!--The text below will appear above your embedded TI-Nspire(tm) or PublishView(tm) document. You 
might use this space for instructions for the embedded activity.  Spacing and returns are ignored.  Word 
wrapping will happen automatically. -->
<p>
THIS AREA CONTAINS "TEXT ABOVE"  FROM WEB PAGE TEXT DIALOG.
</p>

<!--The section below embeds the TI-Nspire document in your web page.-->
<p>
THIS AREA CONTAINS THE CODE SNIPPET THAT EMBEDS THE TI-NSPIRE(TM) OR 
PUBLISHVIEW(TM) DOCUMENT
</p>
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<!--The text below will appear below your embedded TI-Nspire(tm) or PublishView(tm) document. You 
might use this space for guiding questions related to the activity. Spacing and returns are ignored. Word 
wrapping will happen automatically. -->
<p>
THIS AREA CONTAINS "TEXT BELOW"  FROM WEB PAGE TEXT DIALOG.
</p>

<!--The line below creates a visible line across the page. It automatically adjusts to a % of the window 
width.-->
<hr width="80%" align="center">

<!--
Insert related links. 
Insert links using the examples below as a guide.  Type or paste the URL 
between quotation marks.  Type the link text (visible on the page) after the 
URL bracket and before the ending tag '<a/>'. Note you can use comment 
tags to hide links without deleting them from the source code.
-->
<p>
<font size="1">
<a 
href="http://education.ti.com/educationportal/preference/selectCountry.do
">Texas Instruments Education Technology<a/> <br>
<!--  <a 
href="http://education.ti.com/calculators/timathnspired/">MathNspired.c
om<a/> <br> -->
</font>
</p>

<!--
Insert an email link.
Remove comment tags from the line below, then type your email after 
"mailto:" 
-->
<!--  <a href="mailto:username@yourserver.com">E-mail the 
author</a>   -->

<!-- 
Insert an image.
Copy and paste the line below into the body of your document where you 
want the image to appear.  Remove the comment tags, then replace the old 
image source URL or file name a new one.  You might also want to provide 
alternate text (alt=) in case the image file is not available.
NOTE:  If your image is not on the web, when you publish your page, you 
will need to upload your image file along with your html file.
-->
<!--  <img src="type_document_name.here" alt="This text appears if the 
image is not available"  />   -->

</body>
</html>
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Exporting  to the clipboard
Use the  to Clipboard feature create a code snippet that can be pasted 
into a blog, existing web page, or other -compatible container that 
supports  applets. A snippet is not a full web page because the source 
code does not contain the identifying information, headers, and body 
section needed to publish a stand-alone web page. 

1. Open the TI-Nspire™ document or PublishView™ document that you 
want to export.

2. Select File > Export >  to Clipboard.

The code is copied to the clipboard. 

3. Paste the snippet into a blog or other existing web page.

Editing the code snippet
To preview or edit the snippet before pasting it to a web page or blog, 
paste the code into a text editor.

1. Open a new document in any text editor such Notepad (Windows®) 
or TextEdit (Macintosh®).

2. Paste the code into the text editor. The following code is an example 
of how the snippet may look when you copy it and open it in a text 
editor.

3. Edit the code snippet if needed.

<!-- START: TI-Nspire(TM) Document Player -->
<!-- 
Paste the code below into the body of an existing web page or blog. The code will generate an HTML iframe when the page 
is loaded.  Note the 'nspirefile' parameter holds the location and file name of the TI-Nspire(TM) or PublishView(TM) 
document that is to be shown on the page.  If 'nspirefile' contains only a file name instead of a full URL, be sure to upload the 
TI-Nspire or PublishView document to your web server and place it in the same folder as your blog or web page. Also, be 
sure the 'nspirefile' string contains no backslash characters '\'.  Use forward slash characters '/' instead.
-->
<script type="text/javascript" src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></script>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
    // IFRAME attributes.
    {   
        src : 'http://education.ti.com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters.
    {  
        nspirefile : 'myfile.tns'
    }
);
</script>
<!-- END: TI-Nspire(TM) Document Player -->
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4. Save the file using the .html file extension. You can use any name you 
choose to name the file; however, you must ensure the file extension 
is .

Note: If you are using a word processing application such as 
Microsoft® Word to edit the  file, save the file as plain text.

5. Open the file using your Internet browser (File > Open).

The embedded window is displayed in the web browser window.

Storing and sharing your documents
Once you create an  document, you will want to share it with colleagues 
and students. You have the following options for sharing embedded 
TI-Nspire™ documents and PublishView™ documents:

• Publish your  document as a web page on the Internet.

• Attach your  document to an email.

• Save your  document on a file share on your school’s intranet.

• Save your  file to a flash drive.

• Paste a code snippet into an existing web page, blog, online course 
page, or other -compatible container.

Storing documents to be shared online
When you create an  page using the TI-Nspire™ export functions, a 
window is embedded in the web page. The documents and the 
TI-Nspire™ Document Player themselves are not embedded in the  page. 
The  code loads the document and the TI-Nspire™ Document Player from 
whereever they are stored when the  page is opened in a browser. This 
means:

• You must be connected to the Internet to view shared documents and 
load the TI-Nspire™ Document Player.

• The shared documents must be stored in a place where all viewers can 
access them.

The Export feature produces  code that contains a relative address to the 
file being exported. The URL contains only the file name, which means 
your document must be in the same directory as the embedded web 
page. As long as your document and the .html file containing the 
embedded document are in the same folder, the URL will find the 
document even if you move the folder.
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Modifying the  parameter
If you have placed your file in the shared location, change the  parameter 
to reflect the new  or path where the document is stored. The  or path to 
a shared document is typically easy to find. Often, right-clicking the  or 
path name copies a shortcut to the document, which you can paste into 
the iframe.

1. Place your document on a shared location. For example, a shared 
network drive or web site.

2. Copy the path or .

3. Open the  page in a text editor to view and modify the code.

4. Replace the  parameter by pasting the new  or path over the existing  
or path name.

5. Save the updated  file.

If your shared document is located on a shared network drive, the 
updated  might look like this:

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
    // IFRAME attributes.
    {   
        src : 'http://education.ti.com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters.
    {  
        nspirefile : 'myfile.tns'
    }
);
</script>

<iframe 
src="http://education.ti.com/go/nspireplayer?nspirefile=file:/P:/MathDepa
rtment/Algebra/Lessons/myfile.tns" width="360"  height="290"  
scrolling="no"  frameborder="0"></iframe>
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-- OR --

If you uploaded your document to a location on the Internet, the  might 
look like this:

--OR--

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
    // IFRAME attributes.
    {   
        src : 'http://education.ti.com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters.
    {  
        nspirefile : 'file:/P:/MathDepartment/Algebra/Lessons/myfile.tns'
    }
);
</script>

<iframe src="http://education.ti.com/go/nspireplayer?nspirefile= 
http://dl.dropbox.com/u/10849702/myfile.tns" width="360"  height="290"  
scrolling="no"  frameborder="0"></iframe>
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After you have placed your document in a shared location and modified 
the , opening the  file automatically launches the TI-Nspire™ Document 
Player and displays your embedded document a your default web 
browser. Anyone accessing the document must be connected to the 
Internet and have access to the shared file to view it.

Storing and sharing files offline
You can also share your documents with others to be opened and viewed 
offline. You can send the  file to others as an email attachment or on a 
flash drive. The recipient can save the file on their hard drive, then open 
the document in their web browser or text editor.

Launching a dedicated TI-Nspire™ Document 
Player window
You can use  to add a link to your web page that will launch the 
TI-Nspire™ Document Player in a dedicated window. The example code 
provided produces a link that launches a document from the Activities 
Exchange on education.ti.com in a dedicated window.

<script type="text/javascript" 
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scrip
t>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
    // IFRAME attributes.
    {   
        src : 'http://education.ti.com/go/nspireplayer', 
        width : '640',  
        height : '480',  
        scrolling : 'no',  
        frameborder : '0'  
    }, 
    // TI-Nspire(TM) Document Player parameters.
    {  
        nspirefile : 'http://dl.dropbox.com/u/10849702/myfile.tns'
    }
);
</script>
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The first parameter after  is the same as the  attribute in the embedded . 
The other attributes in the script control the appearance of the browser 
components surrounding the dedicated window.

<a href="javascript: void(0)" 
onclick="window.open('http://education.ti.com/go/nspireplayer?nspirefi
le=http://education.ti.com/xchange/US/Math/AlgebraI/11340/From_Ex
pressions_to_Equations.tns','_blank','width=800, \height=600, 
\directories=no, \location=no, \menubar=no, \resizable=yes, 
\scrollbars=no, \status=no, \toolbar=no'); return false;"> Click here </a>
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Using the Class Workspace

Use this workspace to add and manage classes and students, and to 
exchange files with students.

À Menu. Contains tools for working with documents and modifying 
system settings.

Á Workspace Selector. Click here to choose between the Content, 
Class, Documents, Review, and Portfolio workspaces.

Note: Some tasks you perform may prevent you from immediately 
changing workspaces. If a dialog box awaits a response from you, 
enter your response and then change workspaces.

Â Class Workspace toolbar. Shows frequently performed tasks. Each of 
these are explained in more detail in "Using menus and toolbar 
icons" later in this chapter.

Ã Class Record. Document actions are shown here. You can open a 
document in the Review workspace; save a document to the Portfolio 
workspace; send, collect, and delete files; and view document 
properties.

Ä Class session controls. Choose a class from a list of available classes. 
You can begin, pause, resume, or end a class.

À
Á

Â

Ã

Ä

Å

Æ Ç
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Å Classroom area. Shows the students in your class, which ones are 
logged in, and the status of file transfers for selected files in the Class 
Record. You can view the students by Seating Chart or by Student List.

Æ Status bar. See additional details below.

Ç Student View. Lets you display the students in the classroom area in 
Seating Chart view or Student List view.

Understanding the status bar
The status bar gives you information about the network status and the 
student login status.

The network status shows how many TI-Nspire™ CX Wireless Network 
Adapters and TI-Nspire™ Navigator™ Cradles are currently connected to 
the system. You can click here to launch the Network Manager window.

The student login status shows how many students are currently logged 
into class, and how many students are assigned to the current class.

If class is not in session, the student login status shows "Class not 
started."

Student view lets you view the current classroom in the seating chart 
view or the seating list view. The seating chart view shows your students 
as student icons with display names. The student list view shows your 
students in a table that contains their display names, first name, last 
name, user name, and student ID.

Adding classes
When you start using the TI-Nspire™ Navigator™ Teacher Software, one 
of the first things you should do is create your classes. Make sure you 
create a class for each of the class periods you plan to teach with the 
TI-Nspire™ Navigator™ Teacher Software.

You can use a mix of TI-Nspire™ CX, TI-Nspire™ CX CAS, TI-Nspire™, and 
TI-Nspire™ CAS handhelds in the same class.

Adding a class
1. Use the Workspace selector to select the Class workspace.

2. Click Class > Add a Class.

Network status Student login status
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The Add Class dialog box opens.

3. Enter a class name.

4. Click Add Class.

The new class appears in the Add Class dialog box.

Note: If you want to import students from a list into a class you have 
created, see the instructions below.

5. Continue adding classes, and click Finish when you are done.

Importing students
When you add a class, you can import a list of students into the class. You 
must import students while you are adding classes, in the Add Class 
dialog box. 

Note: You can always add individual students to any class at any time. 
See "Adding students to classes" later in this chapter.

You can import a comma-separated value (CSV) file or a *.txt file. The 
CSV or .txt file must have all of these headers in this order:
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First Name
Last Name
User Name
Password
Display Name
Student ID

1. Highlight the class you just created.

2. Click Import Students.

The Open dialog box opens.

3. Select the file that contains the students you want to import.

4. Click Open.

The Import Status dialog box opens telling you how many students 
the TI-Nspire™ Navigator™ Teacher Software successfully imported.

5. Click OK.

Note: If some students did not import successfully, click View Details to 
determine the problem.
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Removing classes
If you have a class you no longer need, you can remove it from the 
TI-Nspire™ Navigator™ Teacher Software. When you remove a class, the 
software removes the class and removes the files on the hard drive that 
correspond to that class. If you have students who are not part of any 
other classes, the software removes those students as well.

Note: You cannot undo the removal of a class.

Removing a class
1. If you have a class session running, end it. 

2. From the Class Session list, select the class you want to remove.

3. Click Class > Remove Class.

The TI-Nspire™ Navigator™ Teacher Software asks if you are sure you 
want to remove the class.

4. Click Remove.

Adding students to classes
After you create your classes, you need to add students to the classes. 
You can add students to an active class session, or you can add students 
to any class at any time.

If this is your first time using the TI-Nspire™ Navigator™ Teacher 
Software, the classroom area may be empty. The software prompts you 
to add a class, and to add students to the class. You can click the prompt 

 in the classroom area to add students, or you can follow the steps 
below at any time.

Note: The instructions below explain how to add students after you 
create a class. You can also add students when you create a class by 
importing them. 

1. Select the class to which you want to add students.

• If class is in session, the student will be added to the current class. 
You have the option of adding the student to other classes.

• If class is not in session, use the Class Session controls to select the 
class to which you want to add the student.
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2. Click Class > Add Student or click Add Student .

The Add Student dialog box opens.

3. Enter the student’s first name and last name.

4. Enter a user name.

Note: The user name you choose must be unique. It cannot exist in 
the current class or any other class.

5. If you want your student to create their own password, select 
Student Chooses.

-or-

If you want to create a password for your student, select the blank 
password entry box and enter a new password.

6. (Optional) Enter a display name.

Note: If you leave the display name blank, the TI-Nspire™ 
Navigator™ Teacher Software uses the student’s first name as the 
display name.

7. (Optional) Enter a student ID.

8. (Optional) Assign the student to other classes:

a) Click Assign Classes.

The Assign Classes dialog box opens.
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b) Select the check boxes of the student’s classes.

c) Clear the check boxes of the classes to which the student does not 
belong.

d) Click OK.

9. If you need to add another student, click Add Next Student and 
repeat steps 3 - 8.

10. Click Finish.

Removing students from classes
As necessary, you can remove students from your classes. When you 
remove students, the TI-Nspire™ Navigator™ Teacher Software only 
removes them from the selected class. If the students are in other classes, 
they remain in those classes until you remove them.

Notes: 

• You cannot remove students who are logged in to the TI-Nspire™ 
Navigator™ network.

• You cannot undo the removal of students.

• You can access many of the student account items by right-clicking 
the student icon in the classroom area and choosing an action from 
the menu.

To remove a student from a class, follow these steps.

1. Click the student you want to remove.

2. Click Class > Remove Student, or click Remove Student .

The software asks if you are sure you want to remove the student.
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3. Click Yes.

The TI-Nspire™ Navigator™ Teacher Software removes the student.

Beginning and ending a class session
A class session is the period when the TI-Nspire™ Navigator™ Teacher 
Software is active for a specific class. While a class session is running, you 
can perform communication functions with the selected class. You cannot 
use TI-Nspire™ Navigator™ Teacher Software to interact with your class 
until you begin a class session, and you cannot begin another class until 
you end the current one.

Beginning a class session
1. Click Class > Select Class, or click the Classroom Session list. 

A list of available classes displays.

2. Select the class you want to begin.

3. Click Begin Class.

Pausing a class session
There are times you may want to pause a class. Pausing a class suspends 
all activity on the student’s handhelds, and they receive a message telling 
them class is paused. When you resume class, the message clears and the 
students are able to use their handhelds. The students remain logged in 
when you pause a class.

To pause a class in session, click Pause Class.

To resume the class, click Resume Class.

Ending a class session
When class is over, or before you start another class, you need to end the 
current class session. Ending a class stops all file communication between 
your computer or handheld and the students’ handhelds. When you end 
a class, the students receive a message on their handhelds saying class is 
ended, and the students are automtically logged off.

To end a current class session, click End Class.
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Changing the student view
In the classroom area, you can view the students in the selected class in 
either the Student List view or the Seating Chart view. The Student List 
view shows your students in a table that contains their display names, 
first name, last name, user name, and student ID. The Seating Chart view 
shows your students as student icons with display names. You can change 
the class view at any time.

Changing the class view to Student List

Click View > Student List or click  in the status bar.

The view changes to Student List.

Changing the class view to Seating Chart

Click View > Seating Chart or click  in the status bar.

The view changes to Seating Chart view.
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Arranging the seating chart
Initially, the classroom area arranges the students in the Seating Chart 
view in the order that you added them. However, you can rearrange the 
students so that they have the same seating arrangement in the 
classroom area as they do in your actual classroom. You can rearrange 
the seating chart at any time.

Arranging students in the seating chart
1. Select the class from the Class Session list.

2. Click View > Seating Chart.

The classroom area displays your class in the Seating Chart view.

3. Within the classroom area, drag each student’s icon to the location 
that you want.

The TI-Nspire™ Navigator™ Teacher Software moves the student 
icons to the new locations.

The software rememebers the student positions the next time you 
start the same class.

Note: Do not place one student’s icon on top of another students’ 
icon. If you do this, you will only be able to see one of the student’s 
icons.

Checking student login status
The TI-Nspire™ Navigator™ Teacher Software lets you view the students’ 
login status from the Seating Chart view. The color of the icon by your 
students’ display names indicates their login status as well as the class 
status: 

Icon Class status Student status Color

Class session not 
started.

N/A Grey

Class session started. Student not logged 
in.

Light blue

Class session started. Student logged in. Dark blue
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Sorting student information
The Student List view in the classroom area shows the information for 
students in the selected class. It includes your students’ display names, 
first names, last names, user names, and student IDs. In the Student List 
view, you can sort your students’ information by each of these categories. 
The TI-Nspire™ Navigator™ Teacher Software sorts the information 
alphabetically from A-Z or Z-A and numerically from 1-9 or 9-1. You can 
sort student information at any time.

Sorting student information
1. Select the class that contains the student information you want to 

sort. 

Note: If you have a class session running, you must end it to select the 
class. 

2. In the menu, click View > Student List.

3. Click the column title of the list you want to sort.

The TI-Nspire™ Navigator™ Teacher Software sorts the selected list.

4. If you want to sort the selected information in the opposite order, 
click the column title again.

Changing the classes assigned to a student
Occasionally your students may move to a different class, or they may 
take more than one of your classes. The TI-Nspire™ Navigator™ Teacher 
Software lets you change your students’ classes when necessary.

Note: You cannot change the classes of students who are logged in to 
the TI-Nspire™ Navigator™ network.

Changing a student’s class
1. Select a class to which the student belongs. 

2. Click the student you want to edit.

3. Click Class > Edit Student, or click Edit Student .

The Student Properties dialog box opens.
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4. Click Assign Classes.

The Assign Classes dialog box opens.

5. Select the check boxes of the student’s classes.

6. Clear the check boxes of the classes to which the student does not 
belong.

7. Click OK.

8. In the Student Properties dialog box, click OK.
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Changing student names and identifiers
After you add your students, you may find that you need to change one 
of their names or identifiers. In the TI-Nspire™ Navigator™ Teacher 
Software, there are five different names and identifiers associated with 
your students, including:

• First name

• Last name

• User name

• Display name

• Student ID

This section covers how to change any of these types of names and 
identifiers.

Note: You cannot change the account information of students who are 
logged in to the TI-Nspire™ Navigator™ network.

Note: You can access many of the student account items by right-clicking 
the student and choosing an action from the menu.

Changing a student’s names or identifiers
1. Select a class to which the student belongs. 

Note: If you have a class session running, you must end it to select the 
class. 

2. Click the student you want to edit.

3. Click Class > Edit Student, or click Edit Student .

The Student Properties dialog box opens.
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4. Click the field of the name or identifier you want to change.

5. Make the necessary changes.

6. Repeat steps 5 and 6 for any other names or identifiers you want to 
change.

7. Click OK.

Moving students to another class
If any of your students move to a different class, you can move them 
within the TI-Nspire™ Navigator™ Teacher Software as well.

Note: You cannot move students who are logged in to the TI-Nspire™ 
Navigator™ network.

Note: You can access many of the student account items by right-clicking 
the student and choosing an action from the menu.

Moving a student to another class
1. Select a class to which the student belongs. 

Note: If you have a class session running, you must end it to move the 
student. 

2. Click the student you want to move. 

3. Click Edit > Cut or click Cut .
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The TI-Nspire™ Navigator™ software removes the student from the 
class and places his or her student account information on the 
Clipboard.

4. From the Class Session list, select the class where you want to move 
the student.

5. Click Edit > Paste or click Paste .

TI-Nspire™ Navigator™ software moves the student to the selected 
class.

Copying students to another class
When you have students in more than one of your classes, you may find 
it convenient to simply copy them from one class to another. Copying 
students saves you the time of entering all of their information again.

Note: You cannot copy students who are logged in to the TI-Nspire™ 
Navigator™ network.

Note: You can access many of the student account items by right-clicking 
the student and choosing an action from the menu.

Copying a student to another class
1. Select a class to which the student belongs. 

Note: If you have a class session running, you must end it to select the 
class. 

2. Click the student you want to copy.

3. Click Edit > Copy or click Copy .

The TI-Nspire™ Navigator™ Teacher Software copies the student 
onto the clipboard.

4. From the Current Class drop-down list, select the class to which you 
want to copy the student.

5. Click Edit > Paste or click Paste .

The TI-Nspire™ Navigator™ software copies the student to the 
selected class.
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Exploring the Class Record
From the Class Record, you can open a document in the Review 
workspace; save a document to the Portfolio workspace; send, collect, 
and delete files; and view document properties.

À File action. The icons indicate the status of a file as follows.

Sent to class.

Collected from class.

Saved to portfolio.

Redistributed to class.

Quick Poll.

Unprompted.

À

Á

Â

Ã
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Deleted from student’s handheld.

Á File name. The names of files and folders used in this class.

Â Status. The progress of an action. For example, "23 of 25" indicates 
that 23 out of 25 students have received a file.

Ã Menu options. Click  for quick access to certain menu items. This 
icon gives you the same options as a right-click.

Sending files to a class
You can send folders and TI-Nspire™ document files (.tns), 
LearningCheck™ files (.edc) and CABRI™ files (.fig) to your whole class, 
members of the class currently logged in, or to individual students. Class 
must be in session for you to send files. 

When you send a file to the whole class, all students currently logged in 
will receive the file immediately. Students not logged in will receive the 
file when they log in.

Note: File types .edc and .fig are converted to .tns files when they are 
sent to the class.

1. Click Tools > Send to class or click Send to class .

The Select file(s) to send dialog box opens.
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2. Click the Files tab to choose files, or click the Folders tab to choose 
folders.

Note: You can send only files or folders, not a combination of files 
and folders. When you send folders to the students’ handhelds, only 
the .tns files will transfer.

3. To choose the files or folders you want to send, do one of the 
following:

• Navigate to the file or folder you want to send and click it. To 
select multiple files or folders, press and hold the Ctrl key 
(Macintosh®: “) while clicking each file name.

• Type the name of the file or folder in the File name or Folder 
name box. Folder names may use alphanumeric characters. You 
can enter slashes ( / and \ ), but double slashes ( // and \\ ) and some 
special characters (? | : * " " < > | ) are not allowed. 

Note: You can also drag and drop files from a file browser window 
onto the Class Record to send files.

4. Click Next.

The Select individual(s) dialog box opens.

5. Select the student(s) to whom you want to send the file:

• To send the file to the whole class, click Class . To send the file 
only to class members who are currently logged in, check the 
Logged in only checkbox.
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• To send the file to an individual student, click Individuals  and 
then click the student.

Note: If you had any students selected in the classroom area, the 
software already has them selected.

• Use the Send to handheld folder drop-down list to toggle 
between the class folder or the top level folder on the handheld.

6. Click Finish.

The file transfer appears in the Class Record.

Collecting files from students
You can collect handheld-compatible files (such as .tns files) from your 
students’ handhelds to your computer. Class must be in session for you to 
collect files. If any students are not logged in, the files you collect are 
automatically transferred when they log in.

You can collect selected files from the Class Record, or you can collect 
recent files that have been sent to the class from the Transfer Tool by 
using the Tools menu or icon. When you collect files from the menu or 
icon, you have the option of deleting the collected files from your 
students’ handhelds.

Collecting files from the Class Record
1. From the Class Record, choose the file or files that have been sent to 

class.
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2. Click  on any of the highlighted files and choose Collect from 
Class.

The file transfer appears in the Class Record.

Collecting files from the menu or icon

1. Click Tools > Collect from Class or click Collect from Class .

The Select file(s) to collect dialog box opens.

2. To choose the files or folders you want to collect, do one of the 
following:

• Click Recent Files and navigate to the file you want to collect and 
click it. To select multiple files or folders, press and hold the Ctrl 
key (Macintosh®: “) while clicking each file name.

• Click Enter Filename and type the name of the file in the File 
name box and then click Add.

3. Click Next.

The Select individual(s) dialog box opens.
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4. Select the student(s) from whom you want to collect the file:

• To collect the file from the whole class, click Class . To collect 
the file only from class members who are currently logged in, 
check the Logged in only checkbox.

• To collect the file from an individual student, click 

Individuals  and then click the student.

Note: If you had any students selected in the classroom area, the 
software already has them selected.

5. If you want to remove the file from the students’ handhelds after you 
collect it, select Delete from handheld after collecting.

6. Click Finish.

The collected file appears in the Class Record.

Managing Unprompted actions
When a student logged into a class session sends you a file outside of a 
collection, an Unprompted action is created.

These files, which are stored in a database, display in the Class Record 
until they are removed. 
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Reviewing and opening Unprompted actions
Unprompted actions are named "Unprompted" followed by the month 
and date. Each class session contains all .tns files sent from students in 
one Unprompted folder. 

The latest Unprompted action appears at the top of the Class Record for 
the most recent files sent by a student during a class session. During the 
next class session, more recent Unprompted actions appear in the Class 
Record above the previous action.

To open the Unprompted action:

1. Double-click the action or right-click and choose Record Item 
Properties.

The Unprompted dialog opens. By default, no items in the 
Unprompted action are selected.

2. From the Unprompted dialog, you can view one or more items, save 
the items to Portfolio, remove the items, export the items to another 
file location, or do nothing.

Viewing items in an Unprompted action
1. From the Unprompted dialog, click on the checkbox to the left of the 

item(s) you want to view.

Note: You can also click on the View icon beside an item to quickly 
access the item.

2. Click View.

The items open as read-only files.

Removing individual items from an Unprompted action
The Class Record displays items in Unprompted actions until you remove 
the Unprompted action. Even if you have exported or saved items, its 
Unprompted action continues to display until you remove it. To remove 
items from an Unprompted action:

1. From the Class Record, double-click on the Unprompted action to 
open it.

2. From the Unprompted dialog, click on the checkbox to the left of the 
item(s) you want to remove.

3. Click Remove.



Using the Class Workspace 267

Removing an entire Unprompted action
You can remove an Unprompted action from the Class Record. This 
removes all items contained within the Unprompted action, as well as 
removing the Unprompted action from the Class Record.

1. From the Class Record, click on the Unprompted action to highlight it.

2. Click Remove from Class Record.

Exporting Unprompted action items
You can export items from the database to the file system. To export 
items from an Unprompted action:

1. From the Class Record, double-click on the Unprompted action to 
open it.

2. Select the files you want to export.

3. Click Export.

A file browser opens. 

4. Select the location for the export.

5. Click Select Folder.

Saving files to a Portfolio record
You can save collected, unprompted, and Quick Poll files to a Portfolio 
record.

1. From the Class Record, select the files.

2. Click  and select Save selected to Portfolio. 

The Save to Portfolio dialog opens.

3. Select to save the files to a new Portfolio column or add them to an 
existing Portfolio column.

• To add the files to a new Portfolio column, click Add as new 
portfolio column and type the name for the new portfolio 
column.

• To save the files to an existing Portfolio column, click Add to 
existing portfolio column and select the column name you want 
from the drop-down list.

4. Click Save.

Note: The files you have saved in Portfolio display in the Class Record 
until you remove them using the Remove command.
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Deleting files from handhelds
When necessary, you can delete files from your students’ handhelds. You 
can delete files that were sent to the class, collected from the class, or 
sent from the Transfer Tool. Class must be in session for you to delete files 
from the students’ handhelds.

1. Click Tools > Delete from class or click Delete from class .

The Select file(s) to delete dialog box opens.

2. To choose the files you want to delete, do one of the following:

• Click Recent Files and navigate to the file you want to delete and 
click it. To select multiple files or folders, press and hold the Ctrl 
key (Macintosh®: “) while clicking each file name.

• Click Enter Filename and type the name of the file in the File 
name box and then click Add.

3. Click Next.

The Select individual(s) dialog box opens.
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4. Select the student(s) whose files you want to delete.

• To delete the file from the whole class’s handhelds, click 

Class . To delete the file only from class members who are 
currently logged in, check the Logged in only checkbox.

• To delete the file from an individual student’s handheld, click 

Individuals  and then click the student.

Note: If you had any students selected in the classroom area, the 
software already has them selected.

5. Click Finish.

The file deletion appears in the Class Record.

Checking the status of file transfers
When you are sending or collecting files, you may want to check to see 
which of your students have received or sent their files.

1. In the Class Record, click the file whose status you want to check.

In the classroom area, the TI-Nspire™ Navigator™ Teacher Software 
indicates the status of your students as follows:

•  A green background indicates that students have 
sent/received the file.
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•  A yellow background indicates that a student received the 
collect or delete action, but they do not have the file on their 
handheld.

•  A red background indicates that students have not yet 
sent/received/deleted the file.

Note: You can also see the file transfer status in the file’s Properties 
dialog box. 

Canceling file transfers
If you change your mind about a file transfer, you can cancel the transfer 
in the Class Record. Canceling file transfers stops the TI-Nspire™ 
Navigator™ Teacher Software from transferring more files. Any files that 
transfer before you cancel remain on the students’ handhelds.

1. In the Class Record, click the file whose transfer you want to cancel.

2. Click Tools > Delete from Class.

The TI-Nspire™ Navigator™ software asks if you’re sure you want to 
remove the action.

3. Click Delete.

The TI-Nspire™ Navigator™ software stops the file transfer and 
removes the file from the Class Record list.

Deleting items from the Class Record
The Class Record maintains a list of all of the actions you have performed 
in your class. Items remain in this list until you delete the items or you 
delete the class. You can remove items from the Class Record at any time.

Note: If you remove a collected file list from the Class Record without 
first saving it to Porfolio, the TI-Nspire™ Navigator™ software deletes 
those students’ files.

1. In the Class Record, click the item you want to delete.

2. Click Remove from Class Record.

Note: If you are deleting an item that is still in progress, the softwre 
asks if you are sure you want to delete the item. Click Delete.



Using the Class Workspace 271

Viewing file properties
Each file that you send or collect has a set of properties that you can 
view. These properties include the file’s name, size, date sent, and status. 
You can view the file properties at any time.

1. Select the file in the Class Record. 

2. Right-click the file in Class Record and select Record Item Properties.

The Properties dialog box opens displaying the file’s properties.

 

Resetting student passwords
The TI-Nspire™ Navigator™ Teacher Software maintains the privacy of 
your students’ passwords. Because of this, you cannot retrieve passwords 
for your students if they forget them. However, if necessary you can reset 
your students’ passwords. You can reset passwords for all of the students 
in a class or for individual students.

Note: You cannot reset the passwords of students who are currently 
logged in to the TI-Nspire™ Navigator™ network.

Resetting passwords for all students in a class
1. Select the students’ class. 

2. Click Class > Reset Student Password(s).

The Confirm Reset Passwords dialog box opens.
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3. Click OK.

4. The next time your students log in, instruct them to enter passwords 
of their choosing.

Resetting passwords for individual students
1. Click the student you want to edit.

2. Click Class > Edit Student, or click Edit Student , or right-click 
the student and choose Edit Student from the menu.

The Student Properties dialog box opens.

3. Click the Reset button next to Password.

4. If you want the student to create his or her own password, select 
Student Chooses.

-or-

If you want to create a specific password for the student, select the 
blank password entry box and enter a new password.

5. Click OK.

The TI-Nspire™ Navigator™ Teacher Software resets the student’s 
password.

6. The next time the student logs in:
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• If you selected Student Chooses, instruct the student to enter a 
password of his or her choosing.

• If you created a password for the student, tell the student the new 
password.

Using menus and toolbar icons
The menu items for the Class workspace are listed in the following table, 
as well as the corresponding toolbar icon and keyboard shortcut.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut

File

Open in Review Workspace - Opens a 
selected Quick Poll or collected file in 
the Review workspace.

Save Selected to Portfolio - Saves a 
selected Quick Poll or collected file in 
the Portfolio workspace.

Collect Selected from Class - Collects 
a sent or redistributed file selected in 
the Class Record from all students in 
class. Class must be in session.

Redistribute Selected to Class - Sends 
a previously collected file to all 
students in the class. Class must be in 
session.

Send Missing - Sends files or lesson 
bundles to students currently logged 
in, and did not receive the file last 
time it was sent to the class.

Collect Missing - Collects files from 
students currently logged in, and did 
not send the file last time it was 
collected from the class.

Settings 8 Opens a dialog box that 
lets you change language and set or 
change your teacher preferences.
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Change Language 8 Select a 
different language.

Teacher Preferences 8 Set and 
manage your teacher account 
preferences. See Setting up the 
TI-Nspire™ Navigator™ Teacher 
Software for more information on 
teacher preferences.

Exit - Closes all applications, with a 
prompt to save the current document.

Windows®: 
Alt + F4

Macintosh®: 
ì“ + Q

Edit

Cut - Cut selected information. Cut 
copies the content to the computer’s 
clipboard. 

Windows®:
Ctrl + X

Macintosh®: 
“ + X

Copy - Copies the selected 
information. 

Windows®: 
Ctrl + C

Macintosh®: 
ì“ + C

Paste - Inserts content, either cut or 
copied, at a chosen location. 

Windows®: 
Ctrl + V

Macintosh®: 
ì“ + V

Remove from Class Record - Removes 
a selected item from the Class Record. 

View

Seating Chart - Changes the view in 
the classroom area to Seating Chart 
view.

Student List - Changes the view in the 
classroom area to Student List view.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Tools

Send to Class - Opens a tool that 
allows you to send files or folders to 
the class. Class must be in session.

Windows®: 
Ctrl + Shift + S

Macintosh®: 
ì“ + Shift + S

Collect from Class - Opens a tool that 
allows you to collect files that have 
previously been sent to the class. Class 
must be in session.

Windows®: 
Ctrl + Shift + C

Macintosh®: 
ì“ + Shift + C

Delete from Class - Opens a tool that 
allows you to collect files that have 
previously been sent to or collected 
from the class. Class must be in session.

Windows®: 
Ctrl + Shift + D

Macintosh®: 
ì“ + Shift + D

Delete All - Opens a tool that allows 
you to delete all folders and files at 
once for the entire class or for selected 
students. Class must be in session.

Quick Poll - Opens a tool that allows 
you to send a quick poll to students 
with connected handhelds.

Windows®: 
Ctrl + Alt + Q

Macintosh®: 
ì“ + Alt + Q

Live Presenter - Opens a tool that lets 
you display your handheld screen or a 
student’s handheld screen, and record 
their actions. See Live Presenter for 
more information.

Screen Capture 8 Opens a tool that 
lets you capture the screens of the 
entire class of connected handhelds.

Capture Class - Captures the 
screens of selected student 
handhelds or the entire class in the 
active class session. The captured 
images are located in the Class 
Capture tool.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Capture Page - Captures the active 
page of the current document. The 
captured image is located in the 
TI-Nspire™ Screen Capture tool.

Windows®: 
Ctrl + J

Macintosh®: 
ì“ + J

Capture Selected Handheld - 
Captures the screen of a selected 
student or teacher handheld. The 
captured image is located in the 
TI-Nspire™ Screen Capture tool.

Transfer Tool - Opens a tool that 
allows you to send files to multiple 
students at once.

Windows®: 
Ctrl + T

Macintosh®: 
ì“ + T

Network Manager - Opens a tool that 
lets you check the status of wireless 
adapters and cradles, and lets you add 
or remove wireless adapters, cradles, 
and access points from the classroom 
system.

Class

Select Class 8 Displays a list of 
available classes for you to select.

Begin/End Class - Begins a class sesion. 
If a class session is currently running, 
ends the class session.

Pause/Resume Class - Pauses a class 
session. If a class session is paused, 
resumes the class session.

Add a Class - Lets you add a new class. 
Class must not be in session.

Import Class Data - Lets you import 
class data from previous classes. Class 
must not be in session.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Remove Class - Lets you remove a 
selected class and all class data from 
the software. Class must not be in 
session.

Add Student - Lets you add a new 
student to available classes. Class must 
not be in session.

Edit Student - Opens the Student 
Properties box on a selected student 
so you can edit their name, password, 
and ID, and assign them to additional 
classes.

Remove Student - Removes a selected 
student from all classes. Class must not 
be in session.

Reset Student Passwords - Resets the 
passwords for all selected students 
who are not logged in.

Student Name Format 8 Allows you 
to choose how student names are 
displayed, either by Last Name, First 
Name; User Name; Display Name; 
Student ID; or hidden.

Window

Reset Workspace Layout - Returns 
your workspace to its original layout.

Content Workspace - Opens the 
Content Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage content from 
your computer, links to websites, 
connected handhelds, or Texas 
Instruments web content

Windows®: 
Ctrl + Alt + 1

Macintosh®: 
ì“ + Alt + 1

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Class Workspace - Opens the Class 
Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage classes and 
students, use the class record panel, 
exchange files with students, and 
monitor documents.

Windows®: 
Ctrl + Alt + 2

Macintosh®: 
ì“ + Alt + 2

Documents Workspace - Opens the 
Documents Workspace in the 
TI-Nspire™ Navigator™ Teacher 
Software. Use this workspace to 
author documents and demonstrate 
mathematical concepts.

Windows®: 
Ctrl + Alt + 3

Macintosh®: 
ì“ + Alt + 3

Review Workspace - Opens the 
Review Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to review or document a 
Quck Poll, manage student responses, 
and organize data.

Windows®: 
Ctrl + Alt + 4

Macintosh®: 
ì“ + Alt + 4

Portfolio Workspace - Opens the 
Portfolio Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to save, store, review, and 
manage class assignments from 
students.

Windows®: 
Ctrl + Alt + 5

Macintosh®: 
ì“ + Alt + 5

Page Capture Window - Opens the 
TI-Nspire™ Screen Capture tool, where 
you can view page captures and 
selected handheld screen captures.

Help

TI-Nspire™ Help - Provides help 
information for this software.

F1

Activate... your trial copy of the 
software. This option is available only 
if you use a trial version of the 
software.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Manage Subscription 8 

Purchase Now - Purchase the 
software.

Reminder Settings - Renew your 
license or change your reminder 
settings, if your software is already 
activated.

Register - When connected to the 
Internet, opens a page where you can 
register your product.

Download Latest Guidebook - When 
connected to the Internet, opens a 
page where you can download the 
latest product guidebooks. 

Visit education.ti.com - When 
connected to the Internet, opens the 
Texas Instruments Education 
Technology site.

Visit Activities Exchange - When 
connected to the Internet, opens the 
Activities Exchange site.

Explore Online Troubleshooting - 
When connected to the Internet, 
opens the online troubleshooting site.

Run TI-Nspire Diagnostics - Run 
diagnostics and send a report to TI 
support.

Check for Software Updates - Locates 
software updates.

Check for Handheld OS Update - Is 
active when a handheld is selected.

About - Displays TI-Nspire™ 
Navigator™ product information.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Welcome Screen - Opens the 
Welcome Screen, which gives you 
quick links to content.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Using Live Presenter

In the TI-Nspire™ Navigator™ Teacher Software, Live Presenter enables 
teachers to project and present actions on a selected handheld in real-
time. Teachers can choose to project their own handheld screen or any 
student’s handheld screen to show work as it is being performed and 
discuss the step-by-step process with the class. During the live 
presentation, you can show the TI-Nspire™ handheld being displayed 
and show the keys as they are pressed by the presenter.

Teachers can also control what appears on the presentation screen: 
student’s name, handheld display, or keypress history. Teachers can also 
record the Live Presenter session and save the file as a movie for later 
use.

While Live Presenter is active, all other student handhelds are unaffected 
by the presentation and can be used.

Before starting Live Presenter
Live Presenter is accessible from the Class workspace. To use Live 
Presenter:

• Ensure student handhelds are connected.

• Begin a class.

• Ensure students are logged in.

Starting Live Presenter
Make sure the student selected to be the presenter is logged into an 
active class session. Although only one person can present at a time, you 
can select anyone to present as long as they are logged in and the class 
session is active.

From the Class workspace, select a student in the class, then select 
Tools > Live Presenter.

To present the teacher handheld, ensure you are logged in, then 
select Tools > Live Presenter.

Note: If you have not set teacher preferences, go to File > Teacher 
Preferences. For more information on using a handheld, refer to the 
handheld guidebooks available at education.ti.com/guides.

Starting Live Presenter from Class Screen Capture window
You can also start Live Presenter from the Class Screen Capture window:
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1. From the Class workspace, click , then select Capture Class.

The Select Individual(s) window opens.

2. Check the "Logged in only" box to display all students currently 
logged in.

Note: If you selected a logged in student in the Class workspace, that 
student’s name is highlighted in the Select Individual(s) window. To 

select all students in the class, click .

3. Click OK.

The Class Screen Capture window opens.

4. Select a student who is logged in, then click .

The Class Screen Capture window opens in Live Presenter mode. By 
default, the window opens in full-screen view. Use the minimize and 
maximize buttons in the upper right corner to adjust the size of the 
window.

Exploring Live Presenter mode
By default, Live Presenter opens with all panes active. You can select to 
show or hide the Handheld pane and the Keypress History. 

À

ÁÂ

Ã

Ä

Å
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À Menu bar. Only options applicable to Live Presenter are 
available from the File menu and the View menu:

• Select File > Close to close Live Presenter.

• Select Edit > Copy to copy the keys in the Keypress History 
pane. You can also press Ctrl + C (Macintosh®: “ + C).

• Select View > Show Student Names to hide student names 
if they are showing or show student names if they are 
hidden.

• Select View > Live Presenter to access options for working 
with Live Presenter.

Note: Other menu options are enabled when viewing 
captured screens.

Á Tool bar. Only tools applicable to Live Presenter are selectable. 
In Live Presenter you can:

• Click  to stop Live Presenter.

• Select  to show student names or deselect 
to hide student names.

Â Handheld pane. Displays the presenter’s handheld type. As 
the presenter presses keys on their handheld, the keys in the 
display turn red so viewers can follow along. The last key 
pressed remains highlighted until a different key is pressed.

Note: In Live Presenter, the handheld pane does not function 
like the TI-SmartView™ emulator. You cannot use a mouse to 
click or select keys—the presenter must press the keys on their 
handheld.

Ã Display pane. Displays the presenter’s handheld screen. If you 
selected to show the student name, the name is shown under 
the screen.
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Hiding and showing student names
If showing, the student name is shown under the handheld screen in Live 
Presenter. 

Ä View options: 

• Click  to record the session. Click  
to stop the recording.

• Select  to show the handheld pane. Deselect 
to hide the handheld pane. When you hide the handheld, 
the Keypress History is shown in this pane.

• Select  to show the Keypress History 
pane. Deselect to hide the Keypress History pane.

Note: To view only the handheld screen, deselect  

and .

Å Keypress History pane. As the presenter presses keys on their 
handheld, the keypress sequence is shown left to right.

Note: If the handheld is hidden, the keys pressed are shown in 
the left pane and this pane closes.

student 
name is 
shown here
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The student name is shown in the same format selected in Capture Class. 
If you select to show or hide student names in Capture Class, the student 
name will be shown or hidden when you start Live Presenter.

To hide the student name in Live Presenter:

Deselect  by clicking the check box. 

The student name is hidden. 

Hiding and showing the presenter handheld
By default, the handheld is shown when you start Live Presenter. 
Showing the handheld enables the class to see which keys are pressed 
during the presentation. When the handheld is shown:

• The key turns red in the display so that the class can follow along 
when the presenter presses a key.

• The last key pressed remains highlighted until a different key is 
pressed.

• The keys on the handheld display are not pressable or clickable. This 
visual display only shows what the presenter presses on their 
handheld.

Hiding the handheld display
To hide the handheld, deselect Show Handheld in the View Options 
bar.

The handheld is hidden and the Keypress History is shown in the left 
pane. 
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Showing the handheld
If the handheld is hidden, select Show Handheld to show the 
presenter’s handheld in the left pane.

The handheld is displayed in the left pane and the Keypress History 
pane opens under the handheld screen if selected.

Viewing Keypress History
By default, the Keypress History pane is open under the handheld screen 
when you start Live Presenter. 

• As keys are pressed during the live presentation, they appear in the 
Keypress History pane. 

• As keys are pressed, they are displayed from left-to- right, then top-
to-bottom.

• If the presenter presses the same key more than once, each repeated 
key press is shown in the Keypress History pane. If the presenter 
presses and holds one key (as when moving the cursor), then the key 
is recorded only one time. 

• You can copy the keys captured in the Keypress History pane to the 
clipboard and then paste the images into another document. You can 
also clear the Keypress History pane. (Students are not able to do 
this.) 
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• During lengthy live presentation sessions, the keys pressed may 
expand beyond the display area. When this happens, a scroll bar 
appears so you can review all keys pressed during the session.

Hiding Keypress History
To hide the Keypress History pane, deselect Show Keypress History. 

The Keypress History pane closes.

Showing Keypress History
If the Keypress History pane is hidden, click the check box to select 
Show Keypress History.

• If the handheld is shown, the Keypress History pane opens below 
the presenter’s handheld screen.

• If the handheld is hidden, the Keypress History is displayed in the 
pane to the left of the presenter’s handheld screen.

Copying Keypress History
You can copy the keys captured in the Keypress History pane to the 
clipboard then paste the images of the keys into a Microsoft® Word 
document or PowerPoint presentation.



288 Using Live Presenter

1. In the Keypress History pane, select the keys you want to copy.

2. Select Edit > Copy or press Ctrl + C (Macintosh®: “ + C).

Images of the keys are copied to the clipboard.

Clearing Keypress History
To clear the Keypress History pane:

Select View > Live Presenter > Clear Keypress History.

The keys displayed in the Keypress History pane are removed.

Showing the handheld screen only
To show only the presenter’s handheld screen during the Live Presenter 
session:

Deselect the Show Handheld and the Show Keypress History 
options. 

The Handheld and Keypress History panes close and the handheld 
screen is displayed in the window.
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Recording the live presentation
You can record and save the live presentation as a movie (.avi file). 
Movies are useful way to present demonstrations to a class, provide 
additional tutoring for difficult concepts, or provide a way for students 
who missed the class to review the lesson. When you record the 
presentation, only the handheld screen is captured. The handheld display 
and the keys pressed are not recorded. When you save a recorded 
presentation, the file is saved with the .avi (Audio Video Interleave) file 
extension.

Starting the recording

Click  or select View > Live Presenter > Start Recording.

Recording begins. When clicked, the button changes to Stop 
Recording. All of the presenter’s work on the handheld screen is 
recorded until you stop the recording.

Stopping and saving the recording
Complete the following steps to stop the recording and save the movie 
file.

1. Click  or select View > Live Presenter > Stop Recording.

The Save dialog box opens. The default name for the movie is 
"presentation" and the default save location is the class folder for the 
class that is active. You can change both the file name and the storage 
location.

Note: If you don’t want to save the recording, click Cancel.
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2. Navigate to the folder where you want to save the .avi file if different 
from the default folder.

3. Type a new name for the file.

4. Click Save.

The file is saved in the designated folder.

Playing and sharing the recording
Once the recording is saved as an .avi file, you can play it on your 
computer. You can also send the file to others as an email attachment.

To play the recording on your computer:

1. Using your file browser, navigate to the folder where you saved the 
presentation (.avi) file.

2. Double-click the .avi file name.

Your default media player opens and the movie plays. 

Note: If the .avi file format is not compatible with your default 
player, an error message is displayed.

Stopping Live Presenter

To stop Live Presenter, click  or select View > Live 
Presenter > Stop Presenter. 

The presentation window closes and the Class workspace is displayed. 
The class is still active. When you are ready to end the class, click 

.
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Using Question in the Teacher Software

The Question application in the Teacher Software allows you to author 
multiple choice, open response, equation, coordinate points, and lists 
questions.

Although your students cannot author questions, they can open 
documents containing questions, answer these questions, and, in 
Self-Check mode, check their work. 

The Question application is located on the Insert menu on the 
Documents workspace.

À Tool Palette icon. Click this icon to open the Tool Palette.

Á Tool Palette. Provides a menu of tools available for working with 
an application. The tools are specific to the active application.

Â Configuration tool. Allows you to set certain properties for each 
question you insert.

Ã Question area. This is where you type questions and view 
student responses.

Understanding the Question Tool Palette
When you add a question, the Question application opens. If necessary, 

click the Tool Palette icon  to open the Tool Palette.

À

Á

Â

Ã
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Note: Your student will see only the first four tools. The Teacher Tool 
Palette will not be available.

Understanding the configuration tool
The configuration tool allows you to set certain properties for each 
question type you insert. The properties you can set include the response 
type, the number of responses (if applicable), the correct answer, and 
other options.

For example, you can specify the correct answer to a question, set the 
text prompt that appears in the student answer area, and set the scale, 
axes, and grid on a graph. You can add a 2D math expression on the 
question types that contain a Correct Answer field. 

Each question type has a unique set of options.

The configuration settings are retained when you copy and paste a 
question from one document to another.

Adding configuration options
1. Click the down arrow on the configuration bar in the Documents 

Toolbox to open the configuration tool.

Tool name Tool function

Clear Answers Lets the teacher or student clear the 
answers in the current question or in 
the document.

Check Answer If you select “Self-Check” as the 
document type in the Question 
Properties dialog box, students can 
check their answer to the question. 

Insert Lets you insert an expression box or 
image into the question.

Format Lets the teacher or student format 
the selected text as subscript or 
superscript.

Teacher Tool Palette Lets you add copyright information 
and set the document type as 
Self-Check or Exam.
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2. Click the down arrow next to the choices you want to edit, and enter 
your desired information.

3. Close the configuration panel. The options you chose are saved when 
you save the document.

Using the Teacher Tool Palette
The Teacher Tool Palette allows you to add copyright information and set 
the document type as Self-Check or Exam.

Adding copyright information
Use the Question Properties dialog box to add copyright information on 
the current question.

1. Click the Teacher Tool Palette icon  > Question Properties.

The Question Properties dialog box opens.

Click to open the configuration tool.
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2. Type the author’s name and move to the Copyright field.

Note: TI-Nspire™ software allows you to use questions from more 
than one author in the same document. Therefore, the information 
that you enter about the author and copyright is not global. You 
must enter the relevant information for each different question.

3. Select whether the question is public domain or has a copyright 
assigned to it and move to the Year field.

4. Type the year the question was copyrighted and move to the Owner 
field. If you are copyrighting a new question, type the current year 
(example: 2010).

5. Type the name of the person or entity that owns the copyright.

6. Define other properties, if desired, and click OK.

Self-Check and Exam document types
You can use the Question Properties dialog to define the document type 
as Self-Check or Exam.

Note: When you define a document as Self-Check or Exam, all of the 
question items in that document will be either Self-Check or Exam.

• When you define the document type as Self-Check, students can see 
the answer and check their work.

• In Exam mode, when you enter a suggested response to a question, 
students cannot see the answers. You can use Exam mode to 
automatically grade student responses.

Adding images to questions
You can add images to the Question Text Area of all questions. On some 
question types, you can add an image in the Student Answer or 
Suggested Response Area of a question.

You can choose the image from a set of images on your computer, or 
copy and paste an image from a different application into the question 
text area. (To learn more about inserting images, see the Using Images 
chapter.)

Image types available
The following file types can be used in the Question application:

• .jpg

• .jpeg

• .bmp
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• .png

Note: The transparency feature of .png is not supported. Any 
transparent .png backgrounds will appear as white.

Adding images using the Insert command
1. Click Insert > Image.

2. Navigate to the location and select the image.

3. Click Open.

The image now appears in your question. 

Note: The image may be too large to view on a handheld screen. On 
a handheld, you may have to scroll to view the entire image.

Adding images using the clipboard
Copy an image to the clipboard from a TI-Nspire™ document, image file, 
or another program, using Ctrl + C (Mac®: “ + C).

Paste the image into the question using Ctrl + V (Mac®: “ + V).

Adding questions
You can add the following types of questions:

• Multiple Choice

– Custom

– ABCD

– True/False

– Yes/No

– Always/Sometimes/Never

– Agree/Disagree

– Strongly Agree...Strongly Disagree

• Open response

– Explanation (not auto-graded)

– Text Match (auto-graded)

• Equation

– y=

– f(x)=

• Coordinate Points and Lists
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– (x,y) numerical input

– Drop Point(s)

– List(s)

When you select a question type, a brief explanation of the question is 
displayed at the bottom of the Choose Question Type dialog box.

Note: You can insert only a question type, not a question category.

When you open a question template, the cursor is in the Question text 
area. You can add images as a visual aid to help explain the context of 
the question, or as a background on a graph. 

You can also apply color to a line or text in the question text box using 

the fill color tool  and the text color tool .

Adding a custom multiple choice question
Adding a custom choice question allows you to specify answers your 
students can select. You can then select one or more responses as correct 
to help you when grading or to help students check questions that are in 
Self-Check mode.

To add a custom multiple choice question:

1. Click Insert > Question.

2. Select Custom under the Multiple Choice question from the Choose 
Question Type dialog box.

3. Click Insert to insert the selected question type.

The Custom Choice template opens with the cursor in the Question 
text area.

• Two response options exist in the template by default, but neither 
response option contains any answer.

• You can type any combination of text and math expressions in the 
Question Area and Suggested Response area.
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À Question text area. Write your question here.

Á Custom response area. Type the responses that your student 
will be able to choose between.

Â Suggested response (optional). You can click the radio button 
that corresponds to a suggested response. The student sees this as 
part of the question.

4. Type the question. You can add an image in the question text area.

5. Press Enter to add another question line, or Tab to go to the first 
Correct Answer radio button.

6. Type the response options. Add an image, if desired.

7. Press Enter to add other response options, and add the response text.

• Press Delete to edit or delete a response.

• Use the Backspace key to delete an empty response line.

8. Click the radio button next to a suggested response, if desired.

9. Open the configuration tool. Choose the response type, and click the 
radio button that corresponds to the correct answer.

Á

À

Â
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Adding an open response question
An open response question prompts the student to write a response. An 
explanation question type allows students to respond without any 
predefined answers. A text match question type allows the teacher to 
specify an answer for the student response. Text match questions are 
automatically graded. 

This example shows how to add an explanation question.

1. Click Insert > Question.

2. Select Explanation under the Open Response question from the 
Choose Question Type dialog box.

3. Click Insert to insert the selected question type.

The Open Response template opens with the Question toolbar visible. 
The cursor is in the Question text area.

À Question text area. Write your question here.

Á Student answer area. Leave this field blank. The answer your 
student has given for a question displays here when you gather 
data later.

4. Type the question.

• You can type any combination of text and math expressions in the 
Question Area.

• Use the Tab key or mouse pointer to navigate between fields.

Á

À
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5. Open the configuration tool. Select the response type as Explanation 
or Text Match, and enter the correct answer.

• The Explanation response type allows the student to give answers 
that closely match your suggested response.

• The Text Match response type requires student to exactly match 
your suggested response. You can uncheck the Ignore case box if 
capitalization is not important.

• You can type any combination of text and math expressions in the 
Response area.

Adding an equation question
An equation question prompts the student to write an equation in the 
form of y= or f(x)=.

This example shows how to add a y= question.

To add an equation question:

1. Click Insert > Question.

2. Select y= under the Equation question from the Choose Question 
Type dialog box.

3. Click Insert to insert the selected question type.

The equation template opens with the Question toolbar visible. The 
cursor is in the Question text area.

À Question text area. Write your question here.

Á

À
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Á Student answer area. The answer your student has given for a 
question displays here when you gather data later.

4. Type the question. 

• You can type any combination of text and math expressions in the 
Question Text area.

• Use the Tab key or mouse pointer to navigate between fields.

5. Enter a suggested response, if desired.

• You can type any combination of text and math expressions in the 
suggested response area.

6. Press Enter to add other response options, and add the response text.

• Press Delete to edit or delete a response.

• Use the Backspace key to delete an empty response line.

7. Open the configuration tool to set the number of responses, the 
correct answer, and whether the students should show their work. 
You can also add a graph that will show in the Question area.

• The number of responses can range from 1 to 5.

• You can add additional fields for multiple correct answers. For 
example you might want to accept both y=(x+1)(x+2) and 
y=(x+2)(x+1) as correct answers. You can type any combination of 
text and math expressions in the correct answer fields.

• The Show your work option includes areas for the students to 
write their starting point, their steps, and their final answer. The 
option to show work is disabled if multiple responses are allowed.

Note: Spaces, case differences, and extra parentheses are ignored 
when the software evaluates student answers. For example, 
y=2x+1 is evaluated the same as Y = 2X + 1.

• To add a graph in the Question area, check the box to Include a 
Graph Preview. The Question text area splits to show a graph on 
the right.

• When you are in the graph, the Graphs & Geometry toolbar is 
available to allow you to add functions.

Note: Only the teacher can manipulate the graph. Students can 
only view and zoom the graph.
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Adding an (x,y) numerical input question

À Question text area. Write your question here.

Á Student answer area. The answer your student has given for a 
question displays here when you gather data later.

1. Click Insert > Question.

2. Select (x,y) Numerical Input under the Coordinate Points and Lists 
question from the Choose Question Type dialog box.

3. Click Insert to insert the selected question type.

The list template opens with the Question toolbar visible. The cursor 
is in the Question text area.

4. Type the question.

• You can type any combination of text and math expressions in the 
Question Text area.

• You can add an image in the Question Area.

• Use the Tab key or mouse pointer to navigate between fields.

5. Enter a suggested response, if desired.

• The response fields are expression boxes and accept only 
expression inputs.

6. Press Enter to add other response options (up to five), and add the 
response text.

• Press Delete to edit or delete a response.

• Use the Backspace key to delete an empty response line.

À

Á
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7. Open the configuration tool to set the number of points, enter a 
correct answer, and add a graph preview, if desired.

• The number of points can range from 1 to 5.

• You can add additional fields for multiple correct answers. You 
can type any combination of text and math expressions in the 
correct answer fields.

• Click the Utilities button  to open the Templates and Symbols 
Palette that allows you to enter 2D math expressions.

• To add a graph in the Question area, check the box to Include a 
Graph Preview. The Question text area splits to show a graph on 
the right.

• When you are in the graph, the Graphs & Geometry toolbar is 
available to allow you to add functions.

Note: Only the teacher can manipulate the graph. Students can 
only view and zoom the graph.

Adding a drop points question

À Question text area. Write your question here.

Á Student answer area. The answer your student has given for a 
question displays here when you gather data later.

1. Click Insert > Question.

2. Select Drop Points under the Coordinate Points and Lists question 
from the Choose Question Type dialog box.

À

Á
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3. Click Insert to insert the selected question type.

The drop points template opens with the Question toolbar visible. 
The cursor is in the Question text area.

The graph is in the Student answer area.

• When you are in the graph, the Graphs & Geometry toolbar is 
available to allow you to add functions.

Note: Only the teacher can manipulate the graph. Students can 
only view, zoom, or place points on the graph.

4. Type the question.

• You can type any combination of text and math expressions in the 
Question Text area.

• You can add an image in the Question Area.

• Use the Tab key or mouse pointer to navigate between fields.

5. Open the configuration tool to set the number of points, hide or 
show coordinates, and enter a correct answer.

• The number of points can range from 1 to 5.

• Showing coordinates is turned off by default. Check the box to 
display coordinate labels on the graph.

• You can add additional fields for multiple correct answers. You 
can type any combination of text and math expressions in the 
correct answer fields.

• Click the Utilities button  to open the Templates and Symbols 
Palette that allows you to enter 2D math expressions.
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Adding a lists question

À Question text area. Write your question here.

Á Student answer area. The answer your student has given for a 
question displays here when you gather data later.

1. Click Insert > Question.

2. Select List(s) under the Coordinate Points and Lists question from 
the Choose Question Type dialog box.

3. Click Insert to insert the selected question type.

The list template opens with the Question toolbar visible. The cursor 
is in the Question text area.

4. Type the question.

• You can add columns or rows, change the name of the lists, and 
input data in the lists, using the same functions allowed in the 
Lists & Spreadsheet application.

5. Enter initial data in the lists, if desired.

6. Open the configuration tool to set the number of lists for the student 
responses.

• The number of lists can range from 1 to 5. 

• Lists must have names. The default names are List1, List2, etc. 

À

Á
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Using Question for Students

The teacher may send you a question in a variety of format types. You 
may receive multiple choice, open response, and other types of 
questions. This section will show you how to answer the different 
question types.

Accessing the Question Toolbar
When you open a document with a question you may see a toolbar with 
four tool options. If you don’t see this menu you can access it using one 
of the following methods.

Software: 

In the Documents Toolbar, click the Tool Palette icon.

Handheld:

When in the question, click b.

Understanding the Question toolbar
When you open documents containing questions, the Question toolbar 
displays four available tools:

Tool name Tool function

Clear Answers Lets you clear the answers in the 
current question or in the document.

Check Answer If your document is in Self-Check 
mode, click here to view the correct 
answer. You cannot check answers to 
exam-type questions.

Insert Lets you insert an expression box in 
your answer.

Format Click this tool to format the selected 
text in your answer as subscript or 
superscript.
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Navigating in the Question application
Use the mouse, or if using a handheld use the touchpad arrows, to 
navigate to the correct response.

Use the Tab key to move between fields. Shift + Tab to move back.

Types of questions
There are several types of questions you may be asked. The following is a 
list of the types. There may be variations in a type but how you answer 
the question is basically the same for each type. 

• Multiple choice

– Custom

– ABCD

– True/False

– Yes/No

– Always/Sometimes/Never

– Agree/Disagree

– Strongly Agree...Strongly Disagree

• Open response

– Explanation

– Text match

• Equation

– y=

– f(x)=

• Coordinate points and list

– (x,y) numerical input

– Drop point(s)

– List(s)
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Answering questions
The general screen layout for all questions is the same. First is the 
question area followed by a separating horizontal bar; then the area for 
you to insert your answer. Some question types have slightly different 
answer areas. See the rest of this section’s images for these differences.

Checking your Answer
If your question is self-checking you will see the Check Answer option 
available. If not it will be grayed out.

Software: 

Select the Tool Palette icon .

Handheld: 

Click b.
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Multiple Choice
Select one or more answers from the list depending on the question 
type.

Multiple choice questions allow for the possibility of either multiple 
correct responses or a single correct response. If multiple answers can be 
given, the response will be in the form of a check box. If only one answer 
is allowed, the form will be an option button (also known as a radio 
button).

Note: If you want to change your answer in a check box, select the 
answer again and the selection will clear. It works as a toggle. For option 
type questions, select a new option to mark. The previous one will clear.

Software:
To answer the question, use your mouse to select the answer. 

Handhelds: 
You can use the touch pad as you would a mouse. Alternately, you 
can press e to navigate to your question and then press ·. 

Example of multiple choice questions with boxes (1) and option (2) 
buttons:

Note: Here are a few other examples illustrated in the preceding image. 

In the first example, because there are more choices than what is seen 
on the screen, the scroll bar is displayed. It is important that you verify 
you are seeing all possible responses before choosing your answer

Handheld: The first picture is also an example of how the screen 
appears on a handheld as compared to the software. The tabs at the 
top are used to navigate to the different questions (pages and 
problems) when using a handheld.

Software: The software uses the scrollbars or the page sorter in 

the Documents Tool bar.

1 2
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Open Response
In open response questions, use any combination of text and math 
expressions. You can use any keys and any characters.

Note: If your instructor informs you this is an exact match question, this 
means the instructor is using an automated checking system and you 
must answer the question exactly in the correct form. For example, if the 
question was "Give the value of X" and the correct response was "15" 
only respond with the value. Do not respond "The value of X is 15 
because the value of Y is 12." This would be counted wrong because it is 
not an exact match with the answer key.

Note: The teacher may decide to ignore the the text capitialization.

Equation

y= and f(x)
When you receive a equation question, it will be a "y=" or "f(x)=" 
option. Both of these forms work the same. Enter your answer in the box 
provided.

Note: When answering a question, spaces, upper and lowercase 
differences, and extra parentheses are ignored. Also answers given in 
math format are evaluated as correct when equivalent. For example, 
y=2x+1 is a text match to Y = 2 X + 1 and  is equivalent to 3/4.

Inner scroll bar 
is to see all the 
answer 
options.

Outer scroll bar 
is to move to 
another 
question.

Software:

3
4
---
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Example question and question answered:

Note: To enter math formats you can use the Utility function. 

1. Click the Utilities icon (software:  or handheld t). 

2. Select the correct format, in the example above, the fraction format is 
used.

(Double-click in the software to select or press · on handheld).

3. Enter the values.

(Tab to go to the next value or to escape the math format box.)

Example using handheld:

Software: See the next example for more detail with the software.

1

2

3
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Coordinate Points, Drop Points, and and List

Coordinate Points
When answering a coordinate point question you will be shown the 
question and then presented with two boxes to insert your answer.

Example answer completed:

You can use the Utility function to enter math formats.

Note: To enter math formats you can use the Utility function. 

1. Click the Utilities icon (software:  or handheld t). 

2. Select the correct format, in this example the fraction format.

(Double-click in software to select or press · on handheld).

3. Enter the values.

(Tab to go to the next value or to escape the math format box.)

Example user software:

Handheld: See the previous example for more detail on the handheld.

1

2

3
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Drop Points
A drop point question will automatically put you into the correct mode 
to place points in a graph that the instructor provides. In the question, 
you cannot alter the graph or its values, you can only insert a point.

Example question received:

When you place your cursor over the graph you will see the cursor looks 
like a pencil. This indicates you can place the point.

Placing the point
Move the cursor to where you want to place a point and click to drop.

Note: When the question is presented to you with a grid background 
you can place the point at any location but once you have placed it on 
one of the grid points it will always snap to the grid when moving. After 
it has been placed on a grid point it cannot be moved between grid 
points.

Moving a point
To move a point that has been placed in the question:
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Software: 

Place your cursor over the point you want to move. The cursor’s icon 

will change to the hand . Click and hold the mouse while moving.

Handheld: 

1. Place your cursor over the point. The cursor’s icon will change into a 
hand ø. 

2. Click / and select key a (on the touchpad). Use the touchpad 
navigation arrow to move the point. 

3. Press the select key a again to deselect.

Removing a point
To remove a point once placed in the graph pane.

Software: 

Ctrl + Z or Edit > Undo to clear the last action.

or

Click Menu > Clear Answers > Current Question.

You can also click Menu > Clear Answers > Document if you want to 
clear all answers in the entire document.

Handheld:

Click b > Clear Answers > Current Question.

You can also click b > Clear Answers > Document if you want to 
clear all answers in the entire document.

Background grid. Once 
a point is placed on a 
grid point it will 
always snap to the 
grid.
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List(s)
You can answer list questions simply by putting values into cells in the 
correct columns.
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Polling students

The Quick Poll tool in the TI-Nspire™ Navigator™ Teacher Software lets 
you “poll” your students. A poll is a survey you send to your students that 
they immediately receive on their handhelds. After your students receive 
the poll, they can send their responses back to your computer. As you 
receive your students’ responses, you can use the Review workspace to 
review the responses. This section contains information you need to 
know to use the Quick Poll tool in your class.

Quick Poll is available from all workspaces. When you open the Quick 
Poll tool, the software automatically changes to the Documents 
workspace. All Quick Polls for one class session are contained in one tab 
in the Documents workspace. 

Note: A new tab is started when a poll exceeds 15 questions, or when 
you start a new class session.

When you start the poll, the software automatically changes to the 
Review workspace. You can start and stop the poll from either 
workspace, and switch workspaces while a poll is in progress.

You can send the following types of questions:

• Multiple Choice

– Custom

– ABCD

– True/False

– Yes/No
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– Always/Sometimes/Never

– Agree/Disagree

– Strongly Agree...Strongly Disagree

• Open response

– Explanation (not auto-graded)

– Text Match (auto-graded)

• Equation

– y=

– f(x)=

• Coordinate Points and Lists

– (x,y) numerical input

– Drop Point(s)

– List(s)

When you select a question type, a brief explanation of the question is 
displayed at the bottom of the Choose Question Type dialog box.

Opening the Quick Poll tool
You can open the Quick Poll tool from any workspace of the TI-Nspire™ 
Navigator™ Teacher software. You can send a poll from an existing 
document, or open a new document to start a poll.

Before you begin, make sure a class is in session. 

1. Click Tools > Quick Poll or click  Quick Poll.

The software opens a new blank document in the Documents 
workspace, and displays the Choose Question Type dialog box.
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2. Select a question type and click Insert.

A new document opens with the question template open and the 
cursor in the Question text area.

Note: For detailed information about each question type, and how to 
create and configure questions, see Using Question in the Teacher 
Software.
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Sending a Quick Poll
After you have selected the Quick Poll question and entered the 
information and any options you want, you are ready to send the poll to 
your students.

To send the Quick Poll question, click Start Poll .

Clicking Start Poll immediately sends the poll to the students.

You can stop a poll and restart it at any time.

Each time you stop and restart a poll, a new document is created with 
the same name. When multiple documents are open, all document 
names are listed in tabs at the bottom of the work area. Only one 
document is active at a time, and only the active document is affected by 
commands from menus or tools.

Using the Quick Poll menu
After you start a Quick Poll, two menu options become available to you. 
These options are in the Tools menu. Use these options for the active 
Quick Poll session.

Allow Document Access - Allows you to grant or deny students access to 
the Scratchpad and any documents on their handheld. The students may 
access a document, do some math, and copy the results back into the 
poll. 

Note: If a data collection sensor is attached to the computer or handheld 
during a Quick Poll that does not have Allow Document Access turned 
on, the Quick Poll is dismissed and the data collection console becomes 
active.

Allow Resubmit - Allows the students to submit their responses several 
times.

Stopping polls
You can stop polls at any time. Your students do not need to do anything 
on their handhelds to stop the poll. When you stop a poll, the students 
can no longer submit answers.

To stop a poll, click Stop Poll  .

Note: If you pause a class while a Quick Poll is running, the Quick Poll 
remains on the students’ handhelds, but the students are not able to 
answer or submit the poll until you resume the class.



Polling students 319

Saving polls
You can save a poll that is still in progress. Doing so saves the poll to the 
Portfolio, and updates the information as it is received. This continues 
until you stop the poll. When you stop the poll, the latest information 
received is automatically saved in Portfolio.

Quick Polls sent in one class session are saved in one column in the 
Portfolio workspace.

Note: A new column is started when a poll exceeds 15 questions, or 
when you start a new class session.

Click File > Save to Portfolio or click .

Note: After the first save, subsequent changes to the poll are 
automatically updated in Portfolio until you stop the poll.

Viewing poll results 
You review Quick Poll results in the Review workspace. 

Polls sent in one class session are contained in a Quick Poll tab in the 
Review workspace. Each new question is added as a new problem in the 
page sorter, and the software automatically opens to the latest question 
that was sent. A new tab is started when a poll exceeds 15 questions.

You can view the results as a bar chart, graph, or table. The results 
automatically update as students send their responses, until you stop the 
poll.

The following example shows the poll results listed in a table.
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For detailed information on viewing and sorting poll results, see Using 
the Review Workspace.
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Responding to polls (student instruction) 
The poll you send to your students interrupts whatever your students are 
doing. You can use this section to instruct your students on how to 
respond to the polls you send them.

 Student Point of View: The following instructions are from the 
student’s point of view.

Navigating the handheld in a Quick Poll question

When your teacher sends a Quick Poll question, the question opens as a 
new document on your handheld, on top of any document you may 
currently have open.

If the teacher gives permission, the Quick Poll tool allows you to 
temporarily exit the question to perform calculations or access other 
documents. For example, you can access the Scratchpad to perform a 
function, or you can access the Lists and Spreadsheet application and 
copy data from there to a List question type.

If you need to access other features of your handheld while in the Quick 
Poll screen, do this:

1. Press c to access the Home menu. Choose your desired 
application from this menu.

Note: To return to the Quick Poll without accessing any documents, 
choose C: Quick Poll.

2. When you are finished, click the Quick Poll icon on the top of the 
handheld screen to return to the Quick Poll tool.

Responding to Quick Poll questions
To submit your answer to the teacher after you have answered the poll, 
press ~ and choose 1:Submit Answer.

When you respond to a poll, your response is immediately sent to the 
teacher’s computer, even before you submit your answer. Your teacher 
can keep track of student responses in real time. When you submit your 
answer, her computer is updated with the answer you submitted.

Your teacher may have applied color to some portions of the question 
she sent. If you are using a TI-Nspire™ CX or TI-Nspire™ CX CAS 
handheld, those questions display in color on your handheld. 

Note: Even though you can see color in the polls you receive, you can not 
add color to the responses you submit. 



322 Polling students

If you are using a TI-Nspire™ or TI-Nspire™ CAS handheld, the question 
displays in black and white on your handheld.

For Multiple Choice questions, use e to navigate to your response. 

Press · to mark your response.

For Open Response questions, press e to move the cursor to the 
answer box, and type your response.

For Equation questions, press e to move the cursor to the answer 
box, and type your response. If a graph is included with the question, 
when you press ·, the function you entered shows up on the 
graph. Your cursor will still be in the answer box. You can not 
manipulate the graph itself. The graph updates when you type an 
answer and press ·.

For Coordinate Points: (x,y) questions, press e to move the cursor 

to the x-field answer box. Type your answer, and press e to move 
to the y-field box. Type your answer. 

If a graph is included with the question, when you press ·, the 
function you entered shows up on the graph.

You can use / b to access the Window and Zoom functions 
while you are working on the graph.

For Coordinate Points: Drop Points questions, press e to move the 

cursor to a point on the graph. Press · to drop a point at that 
location.

If you need to delete a point, press / Z to undo the action.

For Lists questions, press e to move the cursor to the first cell of the 

list. Type your answer, and press e to move to the next cell. Type 
your answer.

The behavior in a Lists question closely matches the behavior of the 
Lists and Spreadsheet application, with the following exceptions. In a 
Lists question, you can not:

• Add, insert, or delete columns

• Change the header row

• Enter formulas

• Switch to Table

• Create plots



Polling students 323

Clearing your answers
After you answer a Quick Poll, you may decide you want to change your 
answer before you submit it to your teacher. There are a couple of ways 
to clear your answers.

1. Press b to access the Check Answer menu.

2. Click Menu > Clear Answers > Current Question or Document.

• Current Question clears your answers for the active question.

• Document clears your answers for all questions contained in the 
active document.

If you answered the question and are ready to submit it, you still have 
time to clear your answer before you submit it to your teacher. 

Press ~ and choose 2:Clear Answer to clear your answer and try 
again.

Submitting Quick Poll responses
When you have finished answering the Quick Poll question, send your 
answer to the teacher. 

Press ~ and choose 1:Submit Answer to send your answer to the 
teacher.

Note: Choose 2:Clear Answer to clear your answer and try again.

Your handheld sends your poll response to your teacher and returns you 
to the last screen you used. Your poll response appears on your teacher’s 
computer.

Your teacher may have set the poll to allow you to submit your answer 
more than once. If so, you can continue to respond to the poll and 
submit it, until your teacher stops the poll.
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Using the Review Workspace

Use this workspace to review a collected set of documents, manage 
student responses, run live activities, and organize data.

À Menu. Contains tools for working with documents and modifying 
system settings.

Á Workspace Selector. Click here to choose between the Content, 
Class, Documents, Review, and Portfolio workspaces.

Â Review Workspace toolbar. Shows frequently performed tasks in the 
Review workspace. Each of these are explained in more detail in 
"Using menus and toolbar icons"later in this chapter.

Ã Review toolbox. Contains the Review Tools, Page Sorter, and 
Student response tools. Click each icon to access the available tools. 
Options for the selected tool are displayed in the toolbox pane.

Ä Class session controls. Choose a class from a list of available classes. 
You can begin, pause, resume, or end a class.

Å Data View pane. Shows the data from the poll or document you have 
selected in the Analysis pane. You can switch the data view between 
bar chart, table, and graph (if available).

Æ Status bar. See additional details below.

À
Á

Â

Ã

Æ

Ä

Å
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Understanding the status bar
The status bar gives you information about the network status and the 
student login status.

Depending on the current view in the Page Sorter, the status bar gives 
additional information.

• If you are in the document view, the status bar provides information 
about the current document, and enables you to toggle between 
between Handheld and Computer mode, and adjust the view of the 
document.

• If you are in the student response view, the status bar allows you to 
change the data between bar chart, table, and graph views.

The image below shows the status bar in the document view. The bar 
chart, table, and graph views are explained in more detail later in this 
chapter.

À Network status. Shows how many TI-Nspire™ CX Wireless Network 
Adapters and TI-Nspire™ Navigator™ wireless cradles are currently 
connected to the system. You can click here to launch the Network 
Manager window.

Á Student login status. The student login status shows how many 
students are currently logged into class, and how many students are 
assigned to the current class. If class is not in session, the student login 
status shows "Class not started."

Â Document View. Toggle between Handheld mode and Computer 
mode.

Ã Boldness/Scale. When working with a document in Computer mode, 
use the Boldness slider to make the lines and text of a document 
thicker or thinner.

When working with a document in Handheld mode, use the Scale 
slider to increase the size of the document in the workspace, up to 
200%.

Á ÃÀ Â
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Using the Review toolbox
The Review toolbox contains tools needed for working with collected 
documents, Question results, and Quick Poll results.

Exploring the Review tools
Use the Review tools to:

• Organize data

• Use Graph Tools in responses that contain graphs

• Show selected responses

• Hide selected responses

• Mark selected answers as correct

• Mark selected answers as incorrect

À Organize. Click ¢ to organize the data in different views.

Icon What you can do

Review tools

The Review tools let you organize the response data, 
use graph tools, hide or show responses, and mark 
Question and Quick Poll responses as correct or 
incorrect.

Page sorter

Displays all the problems in a document, all the pages 
in each problem, and the student responses for each 
question in the document. 

Student pane

Displays the student names and responses in the Data 
View pane.

À
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Á Graph Tools. Click ¢ to access the graph tools when you are in 
coordinate graph view. 

Â Show Selected. Shows selected responses for review in the Data 
View pane.

Ã Hide Selected. Hides selected responses in the Data View pane.

Ä Mark Selected Correct. Select a response from the Data View pane 
and click Mark Selected Correct to mark that response as the correct 
answer. You can mark more than one answer as a correct answer.

Å Mark Selected Incorrect. Select a response from the Data View 
pane and click Mark Selected Incorrect to mark that response as an 
incorrect answer. You can mark more than one answer as an incorrect 
answer.

Exploring the Page sorter
Use the Page Sorter to display the pages in a document, and view student 
responses to any questions in the document.

À Click the minus sign (-) to collapse the view. Click the plus sign (+) to 
expand the view and show all the pages in a problem, and all the 
problems in a document.

À
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Á The pages in a problem. Click on a page to open it in the Data View 
pane.

Â Student responses. A student response icon follows each question 
in the document. Click the icon to view the student responses for the 
question in the Data View pane. 

In Quick Polls, the icon shows the number of students who have 
responded, and the number of students who have submitted their 
answer. In the example below, 9 students are in the class, 7 students 
have received and responded to the poll, and no students have 
submitted their answer yet.

Ã Scroll bar. The scroll bar is active when there are too many pages to 
show in the panel.

Ä Page numbers. Click on a page number to open the page in the 
Data View pane.

Exploring the Student pane
Use the Student pane to:

• Display the students to whom the file was sent

• View the students who responded

• View the students’ responses

• Mark responses as correct or incorrect

• Sort the responses by student or response, or by time in Quick Polls
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À Display Student Responses. Place a check mark in this box to 
display the responses of each student. Uncheck the box to hide the 
student responses.

Á Student, Response, and Time tabs. The Time tab is available only in 
Quick Poll reviews.

Click the Student tab to list the students in alphabetical order. Click 
again to list in reverse alphabetical order. 

Click the Response tab to list the responses in alphabetical or 
numerical order. Click again to list the responses in reverse order.

To add the Time tab in Quick Poll reviews, click the Options menu  
and choose Time.

Click on the Time tab to list the responses in order of the time they 
were answered (first response on top). Click again to list the 
responses with the first response on the bottom.

Â Student names. Lists all students in the class associated with the 
document currently opened for review. The student names display as 
chosen in the Class >Student Name Format menu. 

Student names in red text indicate students who did not receive the 
file.

Uncheck the box next to a name to hide that student’s response.

À
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Ã Responses. Lists all responses next to the student’s name. A student 
may be listed several times if they gave multiple responses. The 
response column may change if the review document is an active 
Quick Poll or a question document that has not been saved yet.

• A response displays if the student responded.

• The response area is blank if the student did not respond.

• "Responded" displays if the student responded and the responses 
are hidden.

• "No Response" displays if the student has not yet responded to 
the open question or active Quick Poll.

• "Working" displays if the student has modified their response to a 
Quick Poll, but has not submitted it.

Ä Options menu. Click ¤ to open the drop-down menu of options you 
can perform on the student responses:

• Display student responses

• Display student names only

• Display responses only

• Display a Time colunm for Quick Poll results

• Select all items in the list

• Show the selected item

• Hide the selected item

• Mark one or more responses as correct

• Mark one or more responses as incorrect
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Exploring the Data View pane

À Show Correct Answer. Click this box to display the answer you 
marked as the correct answer in the Data View pane. The software 
highlights the correct answer in green.

Á Responses. Displays the information chosen in the Page Sorter. This 
example shows the responses from a selected Student Response icon. 
You can show or hide responses, and mark responses as correct or 
incorrect.

Â Data View. Click an icon to view the data in different forms. See 
additional information below.

Understanding the Data View
The Data View pane displays the question of the open document, as well 
as the responses to that question. You can view live results in the Data 
View pane. The data updates as students respond to Quick Poll questions, 
graph functions, or move points on a graph.

The Data View icons allow you to view responses in the Data View pane 
as a bar chart, graph, or table. Each view displays the student responses 
and the frequencey of each response.

The bar chart and table views are available in all question types and 
Quick Poll documents. The graph view is available in equation, 
coordinate points, and list questions. 

Equation questions have an additional "Show Your Work" data view 
available, if you marked the question for students to show their work.

Á

À
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The examples below show the same data displayed in different data 
views.

Click  to view the data in bar chart form.

Click  to view the data in graph form.

When you are in graph view, the Graph Tools are available to allow you 
to work with the graph.

In the bar chart and graph views, you can let your mouse pointer hover 
over a response to see a list of students who gave that response.
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Click  to view the data in table form. 

The table view is available as a frequency table or as a student table.

To view data in different table views, click the Organize tool in the 
Review toolbox and choose Frequency Table or Student Table.

A frequency table shows the responses with the number of times the 
response occurred. You can click the Response tab to sort the responses in 
ascending order, descending order, or question order. Click the Frequency 
tab to sort by frequency of response.

A student table shows the student names with their responses. You can 
click the Student tab to sort the responses in ascending or descending 
alphabetical order. Click the Response tab to sort the responses in 
ascending order, descending order, or question order.
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You can copy selected rows from a table, or copy an entire table, and 
paste the information into a Lists & Spreadsheet document. You can use 
this information in a new document to send to the class.

Opening documents for review
You can review a document that has been collected from the class, a 
Quick Poll in progress, or a saved Quick Poll. You can not review a 
document that does not have questions.

When you start a Quick Poll, the software automatically switches to the 
Review workspace, and you can review the data as the students are 
responding. When you stop and save the poll, you can open it in the 
Review workspace to review the saved responses.

If this is your first time using the TI-Nspire™ Navigator™ Teacher 
Software, the Data View pane area may be empty. Follow the steps 
below to open a document for review.

Opening a document from the Class workspace
To open a document for review from the Class workspace, follow these 
steps:

1. Use the Workspace selector to select the Class workspace.

2. Right-click a file from the Class Record and select Open in Review 
workspace.

The software automatically switches to the Review workspace with 
the selected document open.

Note: You can open collected documents  that contain questions 

and Quick Polls  for review in the Class Record.
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Opening a document from the Portfolio workspace
To open a document for review from the Portfolio workspace, follow 
these steps:

1. Use the Workspace selector to select the Portfolio workspace.

2. Right-click on a column cell or a cell in a student’s row, and select 
Open in Review workspace.

The software automatically switches to the Review workspace with 
the selected document open.
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Viewing data
You can view data from the Student pane or the Data View pane. You 
can choose a student to view their answer, or you can choose an answer 
to view which students gave that answer.

Viewing data from the Student pane
Select a student name in the Student pane to view that answer in the 
Data View pane. You can select more than one student at a time.

The software highlights the selected student’s answer in blue.

If you switch between bar chart, table, and graph views, the software 
retains the selected information and highlights the responses from the 
selected students.

Note: Since student responses can vary for List questions, the software 
does not display List answers for selected students in the Data View pane.

Viewing data from the Data View pane
Select a response in the Data View pane to view the students who 
gave that response in the Student pane. You can select more than one 
response at a time.

The software highlights the corresponding student names in blue. 
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If you switch between bar chart, table, and graph views, the software 
retains the selected information and highlights the students who 
answered the selected response.

Note: Multiple Choice questions with multiple responses display a blue 
area next to all responses from the selected student. 

Note: For List questions, right-click anywhere in the table view and 
choose Show Student Column to display student names next to their 
responses.
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Organizing responses
You can configure a plot list for List questions, organize bar chart data 
and table views, individualize student responses, and organize Multiple 
Choice questions that have multiple responses into separate, group, or 
equivalent responses. 

Configuring a plot list
The plot list settings let you set different shapes for the different plots 
that can help you follow separate lines or responses on a graph.

To set the plot list settings, follow these steps.

1. While in graph view, Click Graph Tools in the Review toolbox.

2. Select Plot List Settings.

The Configure Plot(s) dialog box displays.

3. Choose which shape you want to represent the xList and yList, and 
click the down arrow next to that shape to choose which list to 
represent (list1, list 2, and so forth).

Note: You can choose more than one shape for each list.

4. Click OK.
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5. The Data View pane updates the graph view with the shapes you 
selected.

When you change plot list setting from the graph view and then change 
to bar chart view, the software asks you to choose the lists to display in 
the bar chart. You can choose an individual list, or a list for the Category 
and a list for the Frequency.

Mark your selections and click OK.

If you click Cancel, the software displays the bar chart as an individual 
list, using list1 as the default. 

You can configure the plot list at any time while in bar chart view.

To configure the plot list from the bar chart view, click Organize in 
the Review toolbox and select Plot List Settings.

Individualizing student responses
You can change the colors of each student’s response in a graph so you 
can identify the separate responses. This is useful when you are running a 
live activity; you can view the progress of individual students as they 
graph functions, move points on a graph, or respond to Quick Poll 
questions.
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To change the color of student responses, Click Graph Tools in the 
Review toolbox and select Individualize Student Responses.

The Data View pane displays the responses in different colors.

Organizing list data
In bar chart view, you can organize list data by Frequency, Numeric Value, 
or Alphabetically. 

To organize list data, follow these steps.

1. In bar chart view, click the Graph Tools bar.

2. Select to sort the bars by Frequency, Numeric Value, or Alphabetically.

The bar chart view updates in the Data View pane.

Organizing bar chart data
Organizing by separate responses shows the results for each individual 
response. For example, all of the A responses, all of the Bs, all of the Cs, 
and so forth. Organizing by group responses shows all multiple responses 
from the students. For example, all of the A plus B responses, all of the A 
plus C responses, and so forth.

Organizing by equivalency combines similar results into one bar. For 
example, y=4Mx, y= Mx+4, and y= M(xM4) would all be combined into one 
bar or table row.
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By default, the bar chart view for multiple response questions displays as 
separate responses.

To organize by grouped responses, follow these steps.

1. Click the Organize tool in the Review toolbox.

2. Select Show Student Responses Grouped Together.

The Data View pane displays the grouped responses.

To return to the default view, click the Organize tool and select Show 
Student Responses Separated. 

The Data View pane displays the data as separate responses.
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Organizing by equivalency
Organizing by equivalency groups all similar responses together in one 
bar or row. In bar chart view, you can still see separate responses by 
clicking on the bar.

To organize by equivalency, follow these steps.

1. Click the Organize tool in the Review toolbox.

2. Select Form Bars by Equivalence.

The Data View pane displays the grouped responses.

To return to the default view, click the Organize tool and select Form 
Bars by Exact Matches. 

The Data View pane displays the data as separate responses.

Hiding and showing responses
You can hide one or more selected students’ responses from the Student 
pane or from the Data View pane. When you hide a response, the 
corresponding data updates, and the Data View pane does not display 
the hidden data.
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When you hide responses, the following actions occur in the different 
views.

• Bar chart view - The bar chart is updated and re-sorted using the 
current data.

• Table view - The table is updated and re-sorted using the current 
data.

• Graph view - The graph is updated using the current data. Any 
regression that was added is automatically recalculated and the 
graph displays the new values.

• Show your work - The selected student’s work is hidden from view.

Hiding responses from the Student pane
To hide responses, follow these steps.

1. In the Student pane, select the students whose responses you want to 
hide.

The selected students’ responses are highlighted in blue in the Data 
View pane.

2. Click the Options menu  and choose Hide Selected, or uncheck the 
check box next to the student name.

The Data View pane hides the responses of the students you selected, 
and shows the responses of the remaining students.

The student names you selected are displayed in gray text.
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Note: You can click on a student whose response is hidden to show 
their response. The response displays in blue in the Data View pane. 
All bar chart, table, and graph views are updated with the selected 
data. The response stays in view until you select a different student.

Hiding responses from the Data View pane
You can hide responses from the bar chart, graph, or table views. When 
you hide responses, the Data View pane updates the data and does not 
show the hidden responses. If you are in the Student View, the student 
names are displayed in gray. If you are in the Page Sorter view, the 
software does not change the documents or icons.

To hide responses, follow these steps.

1. In the Data View pane, select the responses you want to hide.

The selected students are highlighted in blue in the Student pane.
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2. Right-click the response and choose Hide Selected.

The Data View pane hides the responses you selected, and shows the 
responses of the remaining students.

The student names that correspond with the responses you selected 
are displayed in gray text.

Showing responses
To show the hidden responses, follow these steps.

1. In the Student pane, select the students whose responses you want to 
show.

2. Click the Options menu  and choose Show Selected.

The student names display in black, and the Data View pane displays 
the student responses.
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Marking responses as correct or incorrect
You can use the Review workspace to mark selected answers as correct or 
incorrect. If you are reviewing a document with a correct answer already 
marked, you can change the correct answer. In a Multiple Choice 
question with multiple responses, you can add additional correct 
answers.

If you have the Show Correct Answer box checked, the answers marked 
as correct are highlighted in green.

The software reevaluates the data based on the correct responses, and 
the Data View pane updates the view to reflect the changes.

To mark a response as correct:

In the Student pane, right-click a student and choose Mark as 
Correct.

In the Data View pane, right-click a response and choose Mark 
Selected Correct.

In the Data View pane, select a response and choose Mark Selected 
Correct in the Review Tools pane.

In Multiple Choice questions with multiple answers, check marks display 
next to the responses. 

Click a check mark to mark a response as correct. 

When you mark a response as incorrect, the software removes the green 
highlight.

To mark a response as incorrect:

In the Student pane, right-click a student and choose Remove as 
Correct.

In the Data View pane, right-click a response and choose Mark 
Selected Incorrect.

In Multiple Choice questions with multiple answers, click the green 
check mark.

Note: If you change an answer to correct or incorrect, any points you 
already manually awarded students for correct or incorrect answers will 
not be changed.

When you mark responses, the following actions occur in the different 
question types.

• Multiple Choice: Single Response - Adding a new answer replaces the 
current answer. Removing an answer leaves the question with no 
correct answers.
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• Multiple Choice: Multiple Responses - Adding a new answer increases 
the correct answer set. For example, an answer of "A and B" becomes 
"A and B and C." Removing an answer decreases the correct answer 
set.

• Open Response: Match Text and Explanation - Adding a new answer 
increases the correct answer set. Removing an answer leaves the 
question with no correct answers.

• Equation: f(x) and y= - Adding a new answer increases the correct 
answer set. Removing an answer decreases the correct answer set.

• Coordinate points - Adding a new answer increases the correct 
answer set. Removing an answer decreases the correct answer set.

The examples below show answers marked as correct in different data 
views.

Bar chart view, Multiple Choice question with multiple 
responses and two correct answers, organized by Show 
Student Responses Separate, and no student selected in the 
Student pane.
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Bar chart view, Multiple Choice question with multiple 
responses and two correct answers, organized by Show 
Student Responses Separate, and one student selected in 
the Student pane.

Bar chart view, Multiple Choice question with multiple 
responses and two correct answers, organized by Show 
Student Responses Grouped Together, and no students 
selected in the Student pane.
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Bar chart view, Multiple Choice question with 
multiple responses and two correct answers, organized by 
Show Student Responses Grouped Together, and one 
student selected in the Student pane.

Frequency table view, Multiple Choice question with one 
correct answer, and no student selected in the Student 
pane.

Student table view, Multiple Choice question with one 
correct answer, and one student selected in the Student 
pane.
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Adding teacher data
There may be times you want to add your own data to a graph you are 
reviewing in class. The Graph Tools allow you to add teacher points and 
teacher equations to a graph, and to set the plot list settings and 
individualize the student responses.

Teacher data is displayed larger than the students’ data, and in a 
different color.

Graph view, Equation y= question with one correct answer, and 
no student selected in the Student pane.

Graph view, Equation y= question with one correct answer, 
and one student selected in the Student pane.
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When you add teacher data, the software reevaluates the data, and the 
Data View pane updates the view to reflect the changes.

You can hide and show the teacher’s data, but you can not mark the 
teacher’s response as correct or incorrect.

Adding teacher points
1. Click Graph Tools in the Review toolbox.

2. Select Add Teacher Point.

3. The Add Teacher Point dialog box displays. 

4. Enter your information in the fields. 

Click  to open math templates and symbols that you can add to the 
fields.

5. Click OK.

Your point displays on the graph, and the name Teacher is added to 
the names in the Student pane.
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Adding teacher equations
1. Click Graph Tools in the Review toolbox.

2. Select Add Teacher Equation.

3. The Add Teacher Equation dialog box displays. 

4. Enter your information in the field. 

Click  to open math templates and symbols that you can add to the 
fields.

5. Click OK.

Your line displays on the graph, and the name Teacher is added to 
the names in the Student pane.
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Saving to the Portfolio workspace
You can save documents that contain questions and Quick Polls to the 
Portfolio workspace, where you can review and analyze individual 
responses, and assign or change a student’s grade.

When you save Quick Polls to Portfolio, students can continue to submit 
answers to the Quick Poll until you stop the poll. The saved Quick Poll in 
Portfolio automatically updates without you having to save it again.

Note: If you opened the file from the Portfolio workspace, or if you have 
already saved the file to Portfolio, the software does not ask you for a 
file name. The software saves the file to Portfolio with the existing file 
name, and updates any grades you had given students. You can go to the 
Portfolio workspace and change a grade at any time.

To save a file to the Portfolio workspace, follow these steps.

1. Click File > Save to Portfolio, or click .

The Save to Portfolio dialog box opens, with the name of the file 
filled in the Portfolio name box.

• To add a new Portfolio column, choose Add as new portfolio 
column. You can use the existing name, or type in a new name.

• To add the file to an existing portfolio column, choose Add to 
existing portfolio column. Click the drop-down arrow to select 
the desired column.

Note: Quick Polls can not be added to existing columns.

2. Click Save.

The file is saved in the Portfolio workspace.
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Using menus and toolbar icons
The menu items for the Review Workspace are listed in the following 
table, as well as the corresponding toolbar icon and keyboard shortcut

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut

File

Save to Portfolio - Saves the current 
document in the Portfolio workspace.

Windows®:
Ctrl + S

Macintosh®: 
“ + S

Close - Closes the current document. Windows®:
Ctrl + W

Macintosh®: 
“ + W

Start / Stop Quick Poll - Starts a poll if 
a question document is open and a 
class is in session. Stops a poll if one is 
currently active.

Settings 8 Opens a dialog box that 
lets you change language and set or 
change your teacher preferences.

Change Language 8 Select a 
different language.

Exit - Closes all applications, with a 
prompt to save the current document.

Windows®: 
Alt + F4

Macintosh®: 
ì“ + Q

Edit

Copy - Copies the selected 
information. 

Windows®: 
Ctrl + C

Macintosh®: 
ì“ + C
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Delete - Deletes the selected objects, 
text, applications, pages, or problems.

Delete key

Select All - Selects all items in the 
Student pane or Data View pane.

Windows®: 
Ctrl + A

Macintosh®: 
ì“ + A

Mark as Correct - Gives credit to 
selected students.

Remove as Correct - Removes the 
selected response from the correct 
answer list. 

View

Class Data View - Shows the 
responses in the Data View pane in bar 
chart, graph, or table views. Only 
available from the student response 
views in the Analysis pane.

Bar Chart - Displays responses in 
the Data View pane as a bar chart.

Coordinate Graph - Displays 
responses in the Data View pane as 
a coordinate graph if applicable.

Table - DIsplays responses in the 
Data View pane as a table.

Show Your Work - Displays 
student’s work in the Data View 
pane, if that option was part of the 
question.

Previous Item - Navigate back one 
page in the document.

Next item - Navigate forward one 
page in the document.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Hide Selected - Hide selected 
students’ responses.

Show Selected - Show selected 
students’ responses that are hidden.

Tools

Quick Poll - Opens a tool that allows 
you to send a quick poll to students 
with connected handhelds.

Windows®: 
Ctrl + Alt + Q

Macintosh®: 
ì“ + Alt + Q

Screen Capture 8 Opens a tool that 
lets you capture the screens of the 
entire class of connected handhelds.

Capture Class - Captures the 
screens of selected student 
handhelds or the entire class in the 
active class session. The captured 
images are located in the Class 
Capture tool.

Transfer Tool - Opens a tool that 
allows you to send files to multiple 
students at once.

Windows®: 
Ctrl + T

Macintosh®: 
ì“ + T

Network Manager - Opens a tool that 
lets you check the status of wireless 
adapters and cradles, and lets you add 
or remove wireless adapters, cradles, 
and access points from the classroom 
system.

Class

Select Class 8 Displays a list of 
available classes for you to select.

Begin/End Class - Begins a class sesion. 
If a class session is currently running, 
ends the class session.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Pause/Resume Class - Pauses a class 
session. If a class session is paused, 
resumes the class session.

Reset Student Passwords - Resets the 
passwords for all selected students 
who are not logged in.

Student Name Format 8 Allows you 
to choose how student names are 
displayed, either by Last Name, First 
Name; User Name; Display Name; 
Student ID; or hidden.

Window

Reset Workspace Layout - Returns 
your workspace to its original layout.

Content Workspace - Opens the 
Content Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage content from 
your computer, links to websites, 
connected handhelds, or Texas 
Instruments web content

Windows®: 
Ctrl + Alt + 1

Macintosh®: 
ì“ + Alt + 1

Class Workspace - Opens the Class 
Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage classes and 
students, use the class record panel, 
exchange files with students, and 
monitor documents.

Windows®: 
Ctrl + Alt + 2

Macintosh®: 
ì“ + Alt + 2

Documents Workspace - Opens the 
Documents Workspace in the 
TI-Nspire™ Navigator™ Teacher 
Software. Use this workspace to 
author documents and demonstrate 
mathematical concepts.

Windows®: 
Ctrl + Alt + 3

Macintosh®: 
ì“ + Alt + 3

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Review Workspace - Opens the 
Review Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to review or document a 
Quck Poll, manage student responses, 
and organize data.

Windows®: 
Ctrl + Alt + 4

Macintosh®: 
ì“ + Alt + 4

Portfolio Workspace - Opens the 
Portfolio Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to save, store, review, and 
manage class assignments from 
students.

Windows®: 
Ctrl + Alt + 5

Macintosh®: 
ì“ + Alt + 5

Review Tools - Opens the Review 
Tools in the toolbox pane.

Page Sorter - Opens the Page Sorter in 
the toolbox pane.

Students - Opens the Student 
Response pane in the toolbox pane.

Autohide Review Toolbox - Hides the 
Review Toolbox and toolbox pane.

Class Screen Capture Window - 
Opens the TI-Nspire™ Screen Capture 
tool, where you can view page 
captures and selected handheld screen 
captures.

DocumentName.tns - Lists the names 
of open documents, with a checkmark 
by the current document.

Help

TI-Nspire™ Help - Provides help 
information for this software.

F1

Activate... your trial copy of the 
software. This option is available only 
if you use a trial version of the 
software.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Manage Subscription 8 

Purchase Now - Purchase the 
software.

Reminder Settings - Renew your 
license or change your reminder 
settings, if your software is already 
activated.

Register - When connected to the 
Internet, opens a page where you can 
register your product.

Download Latest Guidebook - When 
connected to the Internet, opens a 
page where you can download the 
latest product guidebooks. 

Visit education.ti.com - When 
connected to the Internet, opens the 
Texas Instruments Education 
Technology site.

Visit Activities Exchange - When 
connected to the Internet, opens the 
Activities Exchange site.

Explore Online Troubleshooting - 
When connected to the Internet, 
opens the online troubleshooting site.

Run TI-Nspire Diagnostics - Run 
diagnostics and send a report to TI 
support.

Check for Software Updates - Locates 
software updates.

Check for Handheld OS Update - Is 
active when a handheld is selected.

About - Displays TI-Nspire™ 
Navigator™ product information.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Welcome Screen - Opens the 
Welcome Screen, which gives you 
quick links to content.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Using the Portfolio Workspace

Use this workspace to save, store, review, and manage class assignments 
from students.

À Menu. Contains tools for working with documents and modifying 
system settings.

Á Workspace Selector. Click here to choose between the Content, 
Class, Documents, Review, and Portfolio workspaces.

Â Portfolio Workspace toolbar. Shows frequently performed tasks in 
the Portfolio workspace. Each of these are explained in more detail in 
"Using menus and toolbar icons" later in this chapter.

Ã Assignments pane. Select assignments here to view the students 
and the scores in the Workspace. From here, you can redistribute, 
rename, or remove an assignment.

Ä Class session controls. Choose a class from a list of available classes. 
You can begin, pause, resume, or end a class.

Å Workspace. Shows the list of students in the selected class and the 
scores they received for each assignment. Enables you to view class or 
student assignments; sort by assignment, score, or student; and edit 
assignment scores. 

Æ Status bar. Gives you information about the network status and the 
student login status. See additional details below.

À
Á
Â

Ã

Ä

Å

Æ
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Understanding the status bar
The status bar gives you information about the network status and the 
student login status.

The network status shows how many TI-Nspire™ CX Wireless Network 
Adapters and TI-Nspire™ Navigator™ Cradles are currently connected to 
the system. You can click here to launch the Network Manager window.

The student login status shows how many students are currently logged 
into class, and how many students are assigned to the current class.

If class is not in session, the student login status shows "Class not 
started."

Exploring the Assignments pane

À Assignments Summary. Lists the names of the assignments that 
you have saved to the Portfolio workspace. Shows a class and student 
average in the Workspace.

Click the minus sign (-) to collapse the list of individual assignments 
and view only the Assignments Summary.

Click the plus sign (+) to show the list of individual assignments.

Á Individual assignments. Click an assignment to see the student 
scores for that assignment in the Workspace.

Network status Student login status

À

Á

Â
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Â Options menu. Available when you have an individual assignment 

selected. Click  to open a menu that allows you to:

• Open the document in the Review workspace.

• Redistribute the assignment to the current class.

• Remove the assignment from the Portfolio workspace. The 
assignment still exists in other workspaces.

• Rename the assignment.

Exploring the Workspace views
The appearance of the workspace changes depending on what you have 
selected in the Assignments pane.

Assignments Summary View
This Workspace view displays when you have Assignments Summary 
selected in the Assignments pane.

À Column Actions. Lets you perform certain actions on a column. 
Clicking a file icon on this row allows you to: Open in the Review 
Workspace, Open for Editing, Select Column, Sort Ascending or 
Descending, Send Missing, Collect Missing, Redistribute to Class, Open 
Master Document, Remove from Portfolio, or Rename. Each of these 
actions is explained in further detail in this chapter.

Á Class Average. Shows the average score of the class for the item in 
that column.

Â Date. Shows the date the file was collected. The last collected file 
displays in the first column on the left.

À

Á

Â

Ã

Ä

Å

Æ
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Ã Students. Lists all students in the class.

Ä Column Header. Shows the name of the file that has been saved to 
Portfolio. You can perform the same actions on the column header as 
you can on the column actions. Right-click the column header to 
access the menu. 

The column header Average shows the class average overall, and the 
class average for each assignment. Right-click on the Average 
column to sort by ascending or descending scores.

Å File icon. Shows the type of file. The file types shown are Quick Poll 
and *.tns files.

Æ Student scores. If a question is automatically graded, the scores 
display here. You can change a student’s score for an assignment.

Individual Assignment View
This Workspace view displays when you have a single assignment 
selected in the Assignments pane.

À Name of the selected assignment.

Á Total Possible. This row shows the points for these categories: 

• Total possible points for each question in the assignment. You can 
edit this number.

• Total number of extra points possible for the assignment. You can 
edit this number.

• Total points for the assignment.

• Raw percentage. Average percentage for each page in the 
assignment, extra points, and total points.

À

Á

Â

Ä

Å

Æ

Ã
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• Final percentage. This number updates when you edit possible 
points or extra points. You can edit this score. The final score is the 
same as the raw score, unless you change it.

If you edit the final score, it no longer updates if the other points 
change.

Â Student names. All students who received the selected assignment. 
Right-click to open and edit the document in the Documents 
workspace, or to open the document for review in the Review 
workspace.

Ã Average. Shows the average score for all students.

Ä Questions in the assignment. If the document contained multiple 
questions, each question is displayed here, along with the total 
possible score for that question.

Å Scores. Lists the score for each student for the selected assignment. 
Each page in an assignment may have a separate score. Right-click to 
edit the score, open the assignment in the Documents workspace, or 
open the document in the Review workspace.

Æ Scroll bar. Appears when there are more questions in the assignment 
to view, or more students to view.

Saving an item to the Portfolio workspace
If this is your first time using the TI-Nspire™ Navigator™ Teacher 
Software, the Portfolio workspace may be empty. You need to save files 
to the Portfolio workspace in order to view and edit scores, and perform 
other work on the files.

You can save collected, unprompted, and Quick Poll files to the Portfolio 
workspace. You can save to the Portfolio workspace from the Class or 
Review workspaces.

When you save Quick Polls to Portfolio, students can continue to submit 
answers to the Quick Poll until you stop the poll. The saved Quick Poll in 
Portfolio automatically updates without you having to save it again.

Note: If you opened the file from the Portfolio workspace, or if you have 
already saved the file to Portfolio, the software does not ask you for a 
file name. The software saves the file to Portfolio with the existing file 
name, and updates any grades you had given students. You can go to the 
Portfolio workspace and change a grade at any time.

To save a file to the Portfolio workspace, follow these steps.

1. Select the files you want to save to Portfolio.
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• From the Class Record in the Class workspace, click  and select 
Save selected to Portfolio.

• From an open file in the Review workspace, click File > Save to 

Portfolio, or click .

The Save to Portfolio dialog box opens.

2. Select to save the files to a new Portfolio column or add them to an 
existing Portfolio column.

• To add the files to a new Portfolio column, choose Add as new 
portfolio column. You can use the existing name, or type in a 
new name.

• To save the files to an existing Portfolio column, click Add to 
existing portfolio column. Click the drop-down arrow to select 
the desired column.

Note: Quick Polls can not be added to existing columns.

3. Click Save.

The file is saved in the Portfolio workspace.

Note: The files you have saved in Portfolio remain in the Class Record 
until you remove them using the Remove command. 

If a file is deleted from the Class Record, that delete action does not 
affect the file copy in the Portfolio. The copy remains in the Portfolio 
workspace until it is deleted.

Importing an item to Portfolio
You can import a .tns file from your computer to a student’s Portfolio 
entry.
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1. Highlight the cell in the student’s row where you want to import the 
file.

Note: You can import a file for only one student at a time.

2. Click File > Import Item.

A window opens.

3. Navigate to the file you want to import and click it.

Note: You can import only one file at a time.

4. Click Import.

If a file already exists in that cell, the software displays a dialog box 
asking you to confirm replacing the file.

• Click Replace to save your imported file over the existing file.

• Click Keep Existing to keep the existing file and cancel the import 
file function.

Editing scores
There may be times when you want to edit a studen’t score. For example, 
an Open Response assignment contains a question that requires the 
word “Autumn” as the correct answer. One student has entered “Fall.” If 
you want to give the student full or partial credit, you can do so by 
changing the student’s score for the question.

In addition to editing an individual student’s score, you can edit the total 
possible points for each question, the extra points, and the final 
percentage.

Use whole numbers to edit the scores. For example, type 75 to give a 
score of 75%, type 100 to give a score of 100%, and so forth.

Note: If you type a score and do not press Enter, the change is not made, 
and the previous score remains in place.

Changing a student’s score for an item
You can edit the score for an assignment from the Assignments Summary 
view, or you can edit the score for individual questions in an assignment 
from the Individual Assignments view. These steps describe how to 
change a score from either view.

1. In the student’s row, select the score you want to edit.

2. Right-click the cell and select Edit Score.

3. Type the replacement score, and press Enter. To cancel, press Esc.
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Changing the total possible points for a question
You can edit a total possible score for individual questions and for extra 
points.

1. Select a cell in the Total Possible row.

2. Right-click the cell and select Edit Score.

3. Type the points for the question or for extra points, and press Enter. 

The software asks if you want to keep the student scores for this 
question, or reassess the scores for each student. The default setting is 
to reassess the score for each student.

• To keep the student scores without making changes, click Leave 
student assigned credit for this question intact.

• To reassess the score for each student, click Reassess question for 
each student.

Note: If you are editing a file that is open in another workspace, 
the file does not automatically update in the other workspace. 
You need to close the file and reopen it to see the changes you 
made.

4. Click OK.

Changing the final percentage score
1. In the Individual Assignments view, select the student whose score 

you want to edit.

2. Right-click the cell in the Final column, and select Edit Score.

3. Type the replacement score and press Enter. To cancel, press Esc.

Note: If you edit the final score, it retains the edited value and no longer 
updates if edit other values in the row.
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Exporting results
If you or your school district use electronic grade storage and reporting, 
you may want to export scores to these programs. The file type created 
by the export service is .csv. The export action includes all scores for all 
students for the selected assignment, or for all assignments.

1. Choose an assignment from the list of assignments, or choose 
Assignments Summary to export scores for all assignments.

2. Click File > Export.

The software prompts you for an export location. 

The default location is the My Documents folder. The default name is 
the name of the assignment.

3. Navigate to the location you want to save the file.

4. Click Save.

The .csv file contains all the columns and rows in the workspace except 
for the Column Actions row. If a student had an empty cell with no score, 
the .cvs file displays "No score" for that cell.

Sorting information in Portfolio
1. Click the column header of the list you want to sort.

The TI-Nspire™ Navigator™ Teacher Software sorts the selected list in 
ascending, descending, and student name order.

2. Click the column header again to sort in another order.
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Opening a Portfolio item in another workspace
You can open a .tns file in the Documents workspace to edit it, or you can 
open a .tns file or Quick Poll file in the Review workspace to view the 
students’ responses in bar chart, table, or graph views.

Opening an item in the Documents workspace
1. Select the .tns file you want to open.

To open a .tns file for all students: 

• From the Assignments Summary list, select the .tns file.

• From the Workspace in the Assignments Summary view, select the 
icon in the Column Actions row, or select the Column Header.

To open a .tns file for selected students: 

• From the Workspace in the Assignments Summary view, select a 
cell in a selected student’s row. You can open more than one file in 
a column, but you can not open multiple files from different 
columns.

• From the Workspace in the Individual Assignments view, select a 
cell in the selected student’s row.

2. Click File > Open for Editing or right-click and select Open for 
Editing.

The software opens the item in the Documents workspace.

Opening an item in the Review workspace
1. Select the .tns or Quick Poll file you want to open using one of these 

methods:

• From the Assignments Summary list, select the file.

• From the Workspace in the Assignments Summary view, select the 
icon in the Column Actions row, or select the Column Header.

• From the Workspace in the Assignments Summary view, select a 
cell in a selected student’s row. You can open more than one file in 
a column, but you can not open multiple files from different 
columns.

• From the Workspace in the Individual Assignments view, select a 
cell in the selected student’s row.

Note: Any method you choose to open the file in the Review 
Workspace opens the file with all student responses. You can not 
open a file for just one student. You can, however, choose an 
individual student to review their responses in the Review workspace.
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2. Click File > Open in Review Workspace or right-click and select Open 
in Review Workspace.

The software opens the item in the Review workspace.

Opening a Master Document
A Master Document is the original document that was sent to the 
students, and contains the answer key for evaluating the responses 
collected from the students. When you save a document to a column in 
the Portfolio workspace, there is usually a Master Document associated 
with that file.

You can open the Master Document from the Portfolio workspace, in the 
Assignments Summary view. When you open the Master Document, it 
opens in the Documents workspace as a read-only file.

1. In the Column Actions row, select the icon of the file you want to 
open.

2. Right-click the icon and select Open Master Document.

The document opens in the Documents workspace as a read-only file.

Adding a Master Document
There may be times when you want to replace an existing Master 
Document, or add a Master Document to an assignment that does not 
have one. For example, a question was marked with an incorrect answer 
and the students did not receive credit for that answer. You can give the 
students credit by changing the answer to that question, and retain the 
Master Document as a permanent record of the correct answer key.

Note: You can add or replace a Master Document for a .tns file, but not 
for a Quick Poll file.

The new Master Document is used to evaluate student scores. The 
evaluation works as follows:

• If a question changed, students answers are evaluated for the new 
question.

• If the new Master Document has questions that were not in the old 
Master Document, those questions are evaluated. This may result in 
students receiving zero credit for those questions, if they have not 
seen them.

To add or replace a Master Document, follow these steps:

1. In the Column Actions row, select the icon of the .tns file you want to 
open.
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2. Click File > Add Master Document.

The software opens a window to choose a file.

3. Navigate to the .tns file you want to use as the new Master Document 
and click Open.

The software displays a message warning that replacing the Master 
Document will cause the software to reevlaute the student scores.

4. Click Add/Replace Master to assign the new Master Document, or 
click Cancel to cancel the action.

Redistributing a Portfolio item
Redistributing a file to the class is a useful way to return graded 
assignments. It is also useful if you clear the students’ handhelds (for 
example, before a test) and later want to return assignments for 
additional work. Class must be in session to redistribute a file.

1. Select the item you want to redistribute.

2. Right-click and select Redistribute to Class, or click . 

The system sends the file to each student logged onto the TI-Nspire™ 
Navigator™ network. 

Collecting missing files from students
There may be times when you store a set of student files to the Portfolio 
workspace and the collection is incomplete because not all students were 
present, had the file ready for collection, or were not logged on. Class 
must be in session to collect a file.

1. Select an individual file, or click a file icon on the Column Actions row 
to select all files in that column.

Note: You can collect only one column of files at a time.

2. Select Collect Missing.

3. Missing files are collected from those students who are logged onto 
the network and whose files were not initially collected.
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Sending missing files to students
There may be times when you send a set of student files to the students 
and the send is incomplete because not all students were present, or 
logged on, or a new student was added to the class. Class must be in 
session to send a missing file.

1. Select an individual file, or click a file icon on the Column Actions row 
to select all files in that column.

Note: You can send only one column of files at a time.

2. Select Send Missing.

3. Missing files are sent to those students who are logged onto the 
network and who did not initially receive the files. 

Renaming a Portfolio item
You can rename an assignment from the Assignments pane or from the 
column header.

1. Select the assignment name or column header you want to rename. 

2. Right-click and select Rename.

The system displays the Rename Portfolio Column dialog box.

3. Type the new name, and click Rename. Click Cancel to cancel the 
request.

The column appears in the column header and in the Assignments 
pane with the new name. 

Removing files from Portfolio
There may be times you want to delete files from Portfolio. For example, 
an incorrect file was sent to or collected from a student. You can remove 
an assignment from the Assignments pane or from the column header.

1. Select the assignment name or column header you want to remove. 

2. Right-click and select Remove From Portfolio.

The system displays the Remove From Portfolio dialog box.
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3. Click Remove to perform the deletion. Click Cancel to cancel the 
request. 

Note: If a file is saved to the Portfolio workspace and later deleted from 
the Class Record, that delete action does not affect the file copy in the 
Portfolio. The copy remains in the Portfolio workspace until it is deleted.

Using menus and toolbar icons
The menu items for the Portfolio workspace are listed in the following 
table, as well as the corresponding toolbar icon and keyboard shortcut.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut

File

Open in Review Workspace - Opens a 
selected Quick Poll or .tns file in the 
Review workspace.

Open for Editing - Opens a selected 
.tns file in the Documents workspace.

Redistribute to Class - Sends a 
previously collected file to all students 
in the class. Class must be in session.

Open Master Document - Opens the 
Master Document associated with the 
selected assignment.

Add Master Document - Assigns a 
new Master Document or replaces an 
existing Master Document to the 
selected assignment.

Import Item - Opens a dialog box that 
allows you to choose a .tns file to 
import from your computer to a 
student’s Portfolio entry.
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Open Submitted File - If changes 
were made to a file and saved, this 
opens the original file the student 
submitted as a read-only file in the 
Documents workspace.

Export - Opens a dialog box that 
allows you to save assignments as a 
.csv file.

Settings 8 Opens a dialog box that 
lets you change language.

Change Language 8 Select a 
different language.

Exit - Closes all applications, with a 
prompt to save the current document.

Windows®: 
Alt + F4

Macintosh®: 
ì“ + Q

Edit

Undo - Undo the last action 
performed. 

Windows®:
Ctrl + Z

Macintosh®: 
“ + Z

Redo - Reverses the Undo action. Windows®:
Ctrl + Y

Macintosh®: 
“ + Y

Cut - Cut selected information. Cut 
copies the content to the computer’s 
clipboard. 

Windows®:
Ctrl + X

Macintosh®: 
“ + X

Copy - Copies the selected 
information. 

Windows®: 
Ctrl + C

Macintosh®: 
ì“ + C

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Paste - Inserts content, either cut or 
copied, at a chosen location. 

Windows®: 
Ctrl + V

Macintosh®: 
ì“ + V

Rename - Lets you rename a file or 
folder. 

Windows®: F2

Delete - Deletes the selected objects, 
text, applications, pages, or problems.

Delete key

View

Assignment Summary - Shows the 
Assignments Summary view in the 
workspace.

Single Assignments - Lists the names 
of assignments in the Assignments 
pane. Shows the selected assignment 
in the workspace.

Tools

Quick Poll - Opens a tool that allows 
you to send a quick poll to students 
with connected handhelds.

Windows®: 
Ctrl + Alt + Q

Macintosh®: 
ì“ + Alt + Q

Screen Capture 8 Opens a tool that 
lets you capture the screens of the 
entire class of connected handhelds.

Capture Class - Captures the 
screens of selected student 
handhelds or the entire class in the 
active class session. The captured 
images are located in the Class 
Capture tool. Class must be in 
session to use the Capture Class 
tool.

Windows®: 
Ctrl + Shift + R

Macintosh®: 
ì“ + Shift + R

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Transfer Tool - Opens a tool that 
allows you to send files to multiple 
students at once when class is not in 
session.

Windows®: 
Ctrl + T

Macintosh®: 
ì“ + T

Network Manager - Opens a tool that 
lets you check the status of wireless 
adapters and cradles, and lets you add 
or remove wireless adapters, cradles, 
and access points from the classroom 
system.

Class

Select Class 8 Displays a list of 
available classes for you to select.

Begin/End Class - Begins a class sesion. 
If a class session is currently running, 
ends the class session.

Pause/Resume Class - Pauses a class 
session. If a class session is paused, 
resumes the class session.

Reset Student Passwords - Resets the 
passwords for all selected students 
who are not logged in.

Student Name Format 8 Allows you 
to choose how student names are 
displayed, either by Last Name, First 
Name; User Name; Display Name; 
Student ID; or hidden.

Window

Reset Workspace Layout - Returns 
your workspace to its original layout.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Content Workspace - Opens the 
Content Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage content from 
your computer, links to websites, 
connected handhelds, or Texas 
Instruments web content

Windows®: 
Ctrl + Alt + 1

Macintosh®: 
ì“ + Alt + 1

Class Workspace - Opens the Class 
Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to manage classes and 
students, use the class record panel, 
exchange files with students, and 
monitor documents.

Windows®: 
Ctrl + Alt + 2

Macintosh®: 
ì“ + Alt + 2

Documents Workspace - Opens the 
Documents Workspace in the 
TI-Nspire™ Navigator™ Teacher 
Software. Use this workspace to 
author documents and demonstrate 
mathematical concepts.

Windows®: 
Ctrl + Alt + 3

Macintosh®: 
ì“ + Alt + 3

Review Workspace - Opens the 
Review Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to review or document a 
Quck Poll, manage student responses, 
and organize data.

Windows®: 
Ctrl + Alt + 4

Macintosh®: 
ì“ + Alt + 4

Portfolio Workspace - Opens the 
Portfolio Workspace in the TI-Nspire™ 
Navigator™ Teacher Software. Use this 
workspace to save, store, review, and 
manage class assignments from 
students.

Windows®: 
Ctrl + Alt + 5

Macintosh®: 
ì“ + Alt + 5

Page Capture Window - Opens the 
TI-Nspire™ Screen Capture tool, where 
you can view class captures.

Help

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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TI-Nspire™ Help - Provides help 
information for this software.

F1

Activate... your trial copy of the 
software. This option is available only 
if you use a trial version of the 
software.

Manage Subscription 8 

Purchase Now - Purchase the 
software.

Reminder Settings - Renew your 
license or change your reminder 
settings, if your software is already 
activated.

Register - When connected to the 
Internet, opens a page where you can 
register your product.

Download Latest Guidebook - When 
connected to the Internet, opens a 
page where you can download the 
latest product guidebooks. 

Visit education.ti.com - When 
connected to the Internet, opens the 
Texas Instruments Education 
Technology site.

Visit Activities Exchange - When 
connected to the Internet, opens the 
Activities Exchange site.

Explore Online Troubleshooting - 
When connected to the Internet, 
opens the online troubleshooting site.

Run TI-Nspire Diagnostics - Run 
diagnostics and send a report to TI 
support.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Check for Software Updates - Locates 
software updates.

Check for Handheld OS Update - Is 
active when a handheld is selected.

About - Displays TI-Nspire™ 
Navigator™ product information.

Welcome Screen - Opens the 
Welcome Screen, which gives you 
quick links to content.

Toolbar 
icon

Menu option and what you can do Keyboard 
shortcut
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Using the Scratchpad

The Scratchpad is a feature of the TI-Nspire™ handheld that lets you 
quickly:

• Evaluate math expressions.

• Graph functions.

Opening and closing the Scratchpad

From the Home screen, press » to open the Scratchpad.

The first time you open the Scratchpad, a blank page opens with the 
Calculator active.

Press » to alternate between the Calculate and Graph pages.
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Press b to see the Scratchpad Calculate or Scratchpad Graph 
menu. These menus are subsets of the TI-Nspire™ menus for the 
Calculator and Graphs & Geometry applications. For complete listings 
of those menus, refer to the documentation for those applications.

Press d to close the Scratchpad.

Calculating with the Scratchpad
From the Scratchpad Calculate page, enter a math expression on the 
entry line, then press · to evaluate the expression. Expressions display 
in standard mathematical notation as you enter them.

Each evaluated expression and result becomes part of the Scratchpad 
history, displayed above the entry line. 

Entering simple math expressions

Note: To enter a negative number, press v and then enter the number.

Suppose you want to evaluate  

1. Select the entry line in the work area.

2. Type 2 l 8 to begin the expression.

3. Press ¢ to return the cursor to the baseline, and then complete the 
expression by typing:
r 43 p 12

4. Press · to evaluate the expression.

The expression displays in standard mathematical notation, and the 
result displays on the right side of the page.

Note: You can force a decimal approximation in a result by pressing 
/ · instead of ·.
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Note: Results formatting can also be adjusted in Settings. See Working 
with documents on the TI-Nspire™ handheld for more information about 
Settings.

Inserting items from the Catalog
You can use the Catalog to insert functions and commands, units, 
symbols, and expression templates into the entry line.

1. Press k to open the Catalog. By default, the first tab is displayed, 
which lists all commands and functions in alphabetical order.

 

Pressing / · forces the approximate 
result.

Catalog 
for a non-
CAS 
handheld

Catalog for 
a CAS 
handheld
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2. If the function you are inserting is visible in the list, select it and press 
· to insert it.

3. If the function is not visible:

a) Press a letter key to jump to the entries that begin with that letter.

b) Press ¤ or £ as necessary to highlight the item you are inserting.

c) Click a numbered tab to list functions by category: math functions, 
symbols, math templates, library objects, and value for standard 
measurement units (CAS).

d) Press · to insert the item into the entry line.

Using an expression template
Templates help you enter matrices, piecewise functions, systems of 
equations, integrals, derivatives, products, and other math expressions.

For example, suppose you want to evaluate 

1. Press t to open the Template palette.

2. Select  to insert the algebraic sum template.

The template appears on the entry line with small blocks representing 
elements that you can enter. A cursor appears next to one of the 
elements to show that you can type a value for that element.

3. Use the arrow keys to move the cursor to each element’s position, and 
type a value or expression for each element.

4. Press · to evaluate the expression.
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Inserting expressions using a wizard
You can use a wizard to simplify entering some expressions. The wizard 
contains labeled boxes to help you enter the arguments in the 
expression.

For example, suppose you want to fit a y=mx+b linear regression model 
to the following two lists:

{1,2,3,4,5}
{5,8,11,14,17}

1. Press k 1 to open the Catalog and show the alphabetic list of 
functions.

2. Click inside the list, and then press L to jump to the entries that 
begin with “L.”

3. Press ¤ as necessary to highlight LinRegMx.

4. If the Wizards On option is not checked: Press e e to highlight 

Wizards On, press · to change the setting, then press e e to 
highlight LinRegMx again.

LinRegMx 
function in a 
non-CAS 
handheld
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5. Press ·.

A wizard opens, giving you a labeled box to type each argument.

6. Type {1,2,3,4,5} as X List.

7. Press e to move to the Y List box.

8. Type {5,8,11,14,17} as Y List.

9. If you want to store the regression equation in a specific variable, 
press e, and then replace Save RegEqn To with the name of the 
variable.

10. Select OK to close the wizard and insert the expression into the entry 
line.

The expression is inserted along with statements to copy the 
regression equation and display the variable stat.results, which will 
contain the results.

LinRegMx 
function in a 
CAS 
handheld
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LinRegMx {1,2,3,4,5},{5,8,11,14,17},1: CopyVar stat.RegEqn,f1: 
stat.results

The Scratchpad then displays the stat.results variables.

Note: You can copy values from the stat.results variables and paste 
them into the entry line.

Viewing the history
Each evaluated expression and result becomes part of the Scratchpad 
history, displayed above the entry line. 

Press £ or ¤ to scroll through the history.

À Current entry/total entries

À
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Copying a history item to the entry line
You can quickly copy an expression, subexpression, or result from the 
history into the entry line.

1. Press £ or ¤ to move through the history and select the item that 
you want to copy.

2. Optionally, select part of the expression or result by using Shift in 
combination with the arrow keys.

3. Press · to copy the selection and insert it into the entry line.

Clearing the history
When you clear the history, all variables and functions defined in the 
history retain their current values. If you clear the history by mistake, use 
the undo feature.

From the Actions menu, select Clear History.
(Press b 1 5.)

All expressions and results are removed from the history.

Editing Scratchpad expressions
Although you cannot edit a Scratchpad Calculate expression in the 
history, you can copy all or part of an expression from the history and 
paste it to the entry line. You can then edit the entry line.

Inserting elements into the entry line

1. Press e, ¡, ¢, £, or ¤ to position the cursor in the expression. The 
cursor moves to the closest valid position in the direction that you 
press.

2. Type the elements or insert them from the Catalog.

Selecting part of an expression
You can delete, cut, or copy a selected part of an expression.
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1. Press ¡, ¢, £, or ¤ to move the cursor to a starting point in the 
expression.

2. Press and hold g and press ¡, ¢, £, or ¤ to select.

– To delete the selection, press ..

– To cut the selection to the Clipboard, press / X.

– To copy the selection to the Clipboard, press / C.

– To paste the selection to a new entry line in Scratchpad, press 
/ V.

Graphing with the Scratchpad

From the Scratchpad Graph page, click the Entry Line Expand button  
to display the entry line and type an expression to graph. The entry line 
displays the required format for typing a function. The default graph 
type is Function, so the form f1(x)= displays. 

1. Choose Graph Type from the menu, and select a graph type.

For example,

• To graph a scatter plot, press b 3 4. Click var to choose 
variable to plot as x and y for sn.

• To graph a function, press b 3 1.

The entry line changes to display the expression format for the 
specified graph type. You can specify multiple functions of each 
graph type.

2. Type an expression and any other parameters required for the graph 
type.

3. Press · to graph the function, or press ¤ to add another function. 

If necessary, you can use press b 4 to choose a tool on the 
Window/Zoom menu and adjust the viewing area.

When you graph the expression, the entry line disappears to show an 
uncluttered view of the graph. If you select or trace a function, that 
function displays on the entry line. You can change a function by 
editing its expression or grabbing and changing the graph.
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As you graph multiple functions on the axes, the label containing the 
expression displays for each. You can define and graph a maximum of 
99 functions of each type. 

4. Use the b key to explore and analyze the graphed function by 
tracing it, finding points of interest, or assigning a variable in the 
expression to a slider. 

Viewing the function table
To display a table of values for the current function, press 
b 2 5.

To hide the function table, click the graph and then press 
b 2 5. 

Changing the appearance of the axes
As you work with graphs, the Cartesian axes are displayed by default. 
You can change the appearance of the axes in the following ways:

1. Press b 4 and choose the Zoom tool to use. 

2. Select the axes and press / b 3 to activate the Attributes 
tool.

a) Press 9 or : to move to the attribute to change. For example, 
choose the end style attribute.

b) Press 7 or 8 to choose the style to apply. 

c) Change any other attributes of the axes as required for your work, 
then press d to exit the attributes tool.

3. Adjust the axes scale and tic mark spacing manually. 
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a) Click and hold one tick mark, and move it on the axis. The spacing 
and number of tic marks increases (or decreases) on both axes.

b) To adjust the scale and tic mark spacing on a single axis, press and 
hold g, and then grab and drag a tic mark on that axis.

4. Change axis end values by double-clicking them and typing new 
values.

5. Adjust the location of the axes. To move the existing axes without 
resizing or rescaling them, click in and drag an empty region of the 
screen until the axes are in the desired location. 

6. Change the axes’ scales by pressing b 4 1. 

Type the values of your choice over the current values for x-min, 
x-max, y-min, and y-max and click OK. 

7. Press b 2 1 to hide or show the axes.

• If the axes are shown on the page, selecting this tool hides them.

• If the axes are hidden on the page, selecting this tool redisplays 
them.

Tracing a graphed function
Graph Trace moves through the points of a graphed function, 
parametric, polar, sequence, or scatter plot. To enable the trace tool:

1. Press b 5 1 to move across the points in a graphed function 
in Trace model.

2. (Optional) To change the step increment for tracing, press 
b 5 3.
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After you type a different step increment, the Graph Trace tool moves 
across the graph in steps of that size, instead of moving at the default 
step automatically defined with a function.

3. Use Graph Trace to explore a graphed function in the following ways: 

• Move to a point and hover to move the trace cursor to that point.

• Press 7 or 8 to move from point to point on the function’s graph. 
The coordinates of each point traced displays.

• Press 9 or : to move from one function’s graph to another, or to a 
scatter plot. The point’s coordinates update to reflect the new 
location of the trace. The trace cursor is positioned on the point of 
the new graph or plot with the closest x value to the last point 
identified on the previously traced function or graph. You can 
trace multiple functions as described in Tracing all graphs.

• Type a number and press · to move the trace cursor to that 
value on the function’s graph. 

• Create a persistent point that remains on the graph while in 
Graph Trace mode by pressing · when the trace point reaches 
the point you want to label.

• Trace through and identify the points at which the function has 
no defined x or y value (a discontinuity). The string undef displays 
instead of a value when you move over a point that is not defined 
for the function.

Notes: 

• When you select or trace a function on the work area, that 
function displays on the Edit Line.

• When you trace beyond the initially visible graph, the screen pans 
to show the area being traced.

4. Exit Graph Trace by pressing d or by choosing another tool.

Finding points of interest
You can use the tools on the Analyze Graph menu to find a point of 
interest in a specified range of any graphed function. Choose a tool to 
find zero, the minimum or maximum, the point of intersection or 
inflection, or the numeric derivative (dy/dx) or Integral on the graph. 

1. Select the point of interest that you want to find on the Analyze 

Graph menu. For example, to find a zero, press b 6 1.
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The icon for the selected tool displays at the top left on the work 
area. Point to the icon to view a tooltip about how to use the selected 
tool. 

2. Click the graph you want to search for the point of interest, then click 
a second time to indicate where to start the search for the point. 

The second click marks the lower bound of the search region and a 
dotted line displays.

Note: If you are finding the derivative (dy/dx), click the graph at the 
point (numeric value) to use for finding the derivative.

3. Press 3 or 4 to move the dotted line that marks the search region, then 
click the point at which you want to stop the search (upper bound of 
the search region). 

4. Press · at the point to start the search. The tool shades the range. 

If the search region you specified includes the point of interest, a 
label for the point displays. If you change a graph that has points of 
interest identified, be sure to check for changes in points of interest. 
For example, if you edit the function on the entry line or manipulate 
a plot, the point where the graph intersects zero can change. 

The labeled points of interest remain visible on the graph. You can 
exit the tool by pressing d or choosing another tool. 

Working with variables in the Scratchpad
Scratchpad variables are shared between Scratchpad Calculate and 
Scratchpad Graph, but not with any TI-Nspire™ documents. If you use the 
same name for a Scratchpad variable and a variable in a document, no 
conflict occurs unless you attempt to copy expressions between 
documents and the Scratchpad.
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Saving the Scratchpad contents
You can save the Scratchpad Calculate page, the Scratchpad Graph page, 
or both as a TI-Nspire™ document.

1. Press ~, then select Save to Document.

2. Press ·.
The Save to Document dialog box opens.

3. Select the page or pages to save.

4. If a document is open, select either New or Current document.

5. Click Save.

• If you selected to save to an open document, the Scratchpad 
pages are added to the document.

• If you selected to save to a new document:

– Click Yes when the Save dialog box opens.

– Type a name for the document.

– Click Save to save the new document.

Clearing Scratchpad contents
Complete the following steps to delete the calculations and graphing 
work from the Scratchpad application.

1. Press ~, then select Clear Scratchpad.

2. Press · to delete the Scratchpad contents.



Calculator 397

Calculator

Getting started with the Calculator application
The Calculator application gives you a place to enter and evaluate math 
expressions. You can also use it to define variables, functions, and 
programs. When you define or edit a variable, function, or program, it 
becomes available to any TI-Nspire™ math and science learning 
technology application—such as Graphs & Geometry—that resides in the 
same problem.

You can also use Calculator to define library objects, such as variables, 
functions, and programs, which are accessible from any problem of any 
document. For information on creating library objects, see the 
“Libraries” section of the documentation.

À Calculator menu – This menu is available anytime you are in the 
Calculator work area using the Normal view mode. The menu in this 
screen snapshot may not exactly match the menu on your screen.

Á Calculator work area

– Enter a math expression on the entry line and then press · to 
evaluate the expression.

– Expressions display in standard mathematical notation as you 
enter them.

À

Á Â
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– Entered expressions and results show in the Calculator history. 

Â Example of Calculator variables used in another application

Calculator menu
Use the Calculator menu to enter and evaluate a variety of math 
expressions.

Actions

Define Inserts the Define command.

Recall Definition Lets you view, reuse, or modify a 
function or program that you have 
defined.

Delete Variable Inserts the delVar command.

Clear a-z Deletes all variables with single-
letter names.

Clear History Deletes all expressions in the 
Calculator history.

Insert Comment Lets you insert text.

Library Lets you refresh all libraries, set 
LibPub or LibPriv access, insert a “\” 
character, or create a library 
shortcut.

Lock Inserts Lock, unLock, or 
getLockInfo().

Number

Convert to Decimal Inserts ¢Decimal command.

Approximate to Fraction Inserts ¢approxFraction().

Factor Inserts factor().

Least Common Multiple Inserts lcm().

Greatest Common Divisor Inserts gcd() function.

Remainder Inserts remain().
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Fraction Tools Lets you select propFrac(), 
getNum(), getDenom().

CAS: comDenom()

Number Tools Lets you select round(), iPart(), 
fPart(), sign(), mod(), floor(), or 
ceiling().

Complex Number Tools Lets you select conj(), real(), 
imag(), angle(), ¢Polar, ¢Rect, 
or the absolute value template.

Algebra

Numerical Solve Inserts ().

Solve System of Linear Equations Opens the  wizard.

Polynomial Tools Lets you open the  wizard or 
select () or ().

CAS: Algebra

Solve Inserts solve().

Factor Inserts factor().

Expand Inserts expand().

Zeros Inserts zeros().

Complete the Square Inserts ().

Numerical Solve Inserts nSolve().

Solve System of Equations Lets you open the  or the  
wizard.

Polynomial Tools Lets you open the  wizard or 
select , , , , , , or .

Fraction Tools Lets you select propFrac(), 
getNum(), getDenom(), or 
comDenom().

Number
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Convert Expression Lets you select ¢cos, ¢sin, or 

¢Exp.

Trigonometry Lets you select tExpand() or 
tCollect().

Complex Lets you select cSolve(), 
cFactor(), or cZeros().

Extract Lets you select left() or right().

Calculus

Numerical Derivative at a Point Opens the  wizard.

Numerical Integral Inserts The Definite integral 
template.

Sum Inserts the Sum template.

Product Inserts the Product template.

Numerical Function Minimum Inserts ().

Numerical Function Maximum Inserts ().

CAS: Calculus

Derivative Inserts the Derivative template.

Derivative at a Point Opens the  wizard.

Integral Inserts the Integral template.

Limit Inserts the Limit template.

Sum Inserts the Sum template.

Product Inserts the Product template.

Function Minimum Inserts fMin().

Function Maximum Inserts fMax().

Tangent Line Inserts tangentLine().

Normal Line Inserts normalLine().

CAS: Algebra
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Arc Length Inserts arcLen().

Series Lets you select taylor(), series(), or 
dominantTerm().

Differential Equation 
Solver

Inserts deSolve().

Implicit Differentiation Inserts impDif().

Numerical Calculations Lets you select (), (), (), (), or ()

Probability

Factorial (!) Inserts !.

Permutations Inserts nPr().

Combinations Inserts nCr().

Random Lets you select rand(), randInt(), 
randBin(), randNorm(), randSamp(), 
or RandSeed.

Distributions Lets you select from several 
distributions, such as Normal Pdf, 
Binomial Cdf, and Inverse F.

Statistics

Stat Calculations Lets you select from several statistics 
calculations, such as one-variable 
analysis, two-variable analysis, and 
regressions.

Stat Results Inserts the stat.results variable.

List Math Lets you select from several list 
calculations, such as minimum, 
maximum, and mean.

List Operations Lets you select from several list 
operations, such as sorting, filling, and 
converting to a matrix.

CAS: Calculus
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Distributions Lets you select from several 
distributions, such as Normal Pdf, 
Binomial Cdf, and Inverse F.

Confidence Intervals Lets you select from several 
confidence intervals, such as t interval 
and z interval.

Stat Tests Lets you select from several tests such 
as , , .

Matrix & Vector

Create Lets you open the  wizard or insert (), 
(), (), (), , (), (), (), or ().

Transpose Inserts T.

Determinant Inserts det().

Row-Echelon Form Inserts ref().

Reduced Row-Echelon 
Form

Inserts rref().

Simultaneous Inserts simult().

Norms Lets you select norm(), rowNorm(), or 
colNorm().

Dimensions Lets you select dim(), rowDim(), or 
colDim().

Row Operations Lets you select rowSwap(), rowAdd(), 
mRow(), or mRowAdd().

Element Operations Inserts “dot” operators such as .+ (dot 
add) and .^ (dot power).

Advanced Inserts trace(), LU, QR, eigVl(), 
eigVc(), or charPoly(), 

Vectors Inserts unitV(), crossP(), dotP(), 
8Polar, 8Rect ,8Cylind, or 8Sphere.

Statistics
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Finance

Finance Solver Displays the Finance Solver.

TVM Functions Inserts tvmN(), tvmI(), tvmPV(), 
tvmPmt(), or tvmFV().

Amortization Inserts amortTbl(), bal(), GInt(), or 
GPrn().

Cash Flows Inserts npv(), irr(), or mirr().

Interest Conversion Inserts nom() or eff().

Days between Dates Inserts dbd().

Functions & Programs

Program Editor Lets you view, open for editing, 
import, or create a new program or 
function.

Func...EndFunc Inserts a template for creating a 
function.

Prgm...EndPrgm Inserts a template for creating a 
program.

Local Inserts the Local command.

Control Lets you select from a list of function 
and program-control templates, such 
as , and error-handling and warning-
related items.

Transfer Inserts transfer commands Return, 
Cycle, Exit, Lbl, Stop, or Goto.

I/O Inserts input/output commands , , , or .

Mode Inserts commands for setting or 
reading modes, such as display digits, 
angle mode, base mode, and others. 
Also lets you get the current language 
information.

Add New Line Starts a new line within a function or 
program definition.
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Entering and evaluating math expressions

Entering simple math expressions

Note: To enter a negative number on the handheld, press v. To enter a 
negative number on a computer keyboard, press the hyphen key (-).

Suppose you want to evaluate  

1. Select the entry line in the Calculator work area.

2. Type 2^8 to begin the expression.

3. Press ¢ to return the cursor to the baseline.

4. Complete the expression:

– Type *43/12.

Handheld: Type r 43 p 12.

5. Press · to evaluate the expression.

The expression displays in standard mathematical notation, and the 
result displays on the right side of the Calculator.

Note: If a result does not fit on the same line with the expression, it 
displays on the next line.

Controlling the form of a result
You might expect to see a decimal result instead of 2752/3 in the 
preceding example. A close decimal equivalent is 917.33333..., but that’s 
only an approximation.

By default, Calculator retains the more precise form: 2752/3. Any result 
that is not a whole number displays in a fractional or (CAS) symbolic 
form. This reduces rounding errors that could be introduced by 
intermediate results in chained calculations.

You can force a decimal approximation in a result:
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• By pressing shortcut keys.

– Windows®: Press Ctrl+Enter to evaluate the expression.

– Macintosh®: Press “+Enter to evaluate the expression.

– Handheld: Press / · instead of · to evaluate the 
expression.

• By including a decimal in the expression (for example, 43. instead of 
43).

• By wrapping the expression in the approx() function.

• By changing the document’s Auto or Approximate mode setting to 
Approximate.

– From the File menu, select Settings > Document Settings.

Handheld: Press ~ 1 7.

Note that this method forces all results in all of the document’s 
problems to approximate.

Inserting items from the Catalog
You can use the Catalog to insert system functions and commands, 
symbols, and expression templates into the Calculator entry line.

1. Click the Utilities tab, and click  to display the Catalog.

Handheld: Press k 1.

Pressing / · forces the approximate 
result.
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Note: Some functions have a wizard that prompts you for each 
argument. Those functions are shown with an indicator. To receive 
the prompts, select Wizards On.

2. If the item you are inserting is visible in the list, select it and press 
· to insert it.

3. If the item is not visible:

a) Click inside the list of functions, and then press a letter key to 
jump to the entries that begin with that letter.

b) Press ¤ or £ as necessary to highlight the item you are inserting.

Help, such as syntax information or a short description of the 
selected item, appears at the bottom of the Catalog.

c) Press · to insert the item into the entry line.
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Using an expression template
The Calculator has templates for entering matrices, piecewise functions, 
systems of equations, integrals, derivatives, products, and other math 
expressions.

For example, suppose you want to evaluate 

1. On the Utilities tab, click  to display the templates. 

Handheld: Press t.

2. Select  to insert the algebraic sum template.

The template appears on the entry line with small blocks representing 
elements that you can enter. A cursor appears next to one of the 
elements to show that you can type a value for that element.

3. Use the arrow keys to move the cursor to each element’s position, and 
type a value or expression for each element.

4. Press · to evaluate the expression.

Creating matrices

1. On the Utilities tab, click  to display the templates.
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Handheld: Press t.

2. Select .

The Create a Matrix dialog box displays.

3. Type the Number of rows.

4. Type the Number of columns, and then select OK.

Calculator displays a template with spaces for the rows and columns.

Note: If you create a matrix with a large number of rows and 
columns, it may take a few moments to appear.

5. Type the matrix values into the template, and press · to define the 
matrix.

Inserting a row or column into a matrix
To insert a new row, hold down Alt and press Enter.

To insert a new column, hold down Shift and press Enter.

Handheld:

To insert a new row, press @.

To insert a new column, press g ·.

Inserting expressions using a wizard
You can use a wizard to simplify entering some expressions. The wizard 
contains labeled boxes to help you enter the arguments in the 
expression.

For example, suppose you want to fit a y=mx+b linear regression model 
to the following two lists:

{1,2,3,4,5}
{5,8,11,14,17}
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1. On the Utilities tab, click  to display the Catalog.

Handheld: Press k 1.

2. Click an entry in the Catalog, and then press L to jump to the entries 
that begin with “L.”

Handheld: Press L.

3. Press ¤ as necessary to highlight LinRegMx.

4. Click the Wizards On option, if it is not already selected:

Handheld: Press e e to highlight Wizards On, press · to 

change the setting, and then press e e to highlight LinRegMx 
again.

5. Press ·.

A wizard opens, giving you a labeled box to type each argument.

6. Type {1,2,3,4,5} as X List.

7. Press e to move to the Y List box.

8. Type {5,8,11,14,17} as Y List.

9. If you want to store the regression equation in a specific variable, 
press e, and then replace Save RegEqn To with the name of the 
variable.

10. Select OK to close the wizard and insert the expression into the entry 
line.

Calculator inserts the expression and adds statements to copy the 
regression equation and display the variable stat.results, which will 
contain the results.
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Calculator then displays the stat.results variables.

Note: You can copy values from the stat.results variables and paste 
them into the entry line.

Creating a piecewise function
1. Begin the function definition. For example, type the following.

Define f(x,y)=

2. On the Utilities tab, click  to display the templates.

Handheld: Press t.

3. Select .

The Piecewise Function dialog box displays.

4. Type the Number of Function Pieces, and select OK.

Calculator displays a template with spaces for the pieces.

5. Type the expressions into the template, and press · to define the 
function.

6. Enter an expression to evaluate or graph the function. For example, 
enter the expression f(1,2) on the Calculator entry line.
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Creating a system of equations

1. On the Utilities tab, click  to display the templates.

Handheld: Press t.

2. Select .

The Create a System of Equations dialog box displays.

3. Type the Number of Equations, and select OK.

Calculator displays a template with spaces for the equations.

4. Type the equations into the template, and press · to define the 
system.

Deferring evaluation
You don’t have to complete and evaluate an expression as soon as you 
begin typing it. You can type part of an expression, leave to check some 
work you did on another page, and then come back to complete the 
expression later.

Working with variables
When you first store a value in a variable, you give the variable a name.

• If the variable does not already exist, Calculator creates it.

• If the variable already exists, Calculator updates it.

Variables within a problem are shared by TI-Nspire™ math and science 
learning technology applications. For example, you can create a variable 
in Calculator and then use or modify it in Graphs & Geometry or Lists & 
Spreadsheet within the same problem.

For detailed information about variables, refer to the guidebook chapter 
“Using variables.”
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CAS: Working with measurement units
A list of pre-defined constants and measurement units is available in the 
Catalog. You can also create your own units.

Note: If you know a unit’s name, you can type the unit directly. For 
example, you can type _qt to specify quarts. To type the underscore 
symbol on the handheld, press / _.

CAS: Converting between measurement units
You can convert a value between any two units within the same category 
(such as length). 

Example: Using the Catalog, convert 12 meters to feet. The desired 
expression is 12·_m¢_ft.

1. Type 12 on the entry line.

2. On the Utilities tab, click  to display the unit conversions.

Handheld: Press k 3.

3. Select the Length category to expand the list of pre-defined length 
units.

Handheld: Scroll to the Length category, and press ·.

4. Scroll to meter.

Handheld: Scroll to _m (noting the meter hint in the Help window).
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5. Press · to paste _m to the entry line.

6. Select the Conversion Operator (¢) at the top of the Units list, and 

press · to paste it to the entry line.

7. Select _ft from the Length category, and press ·.

8. Press · to evaluate the expression. 

CAS: Creating a user-defined unit
As with the pre-defined units, user-defined unit names must begin with 
an underscore symbol.

Example: Using the pre-defined units _ft and _min, define a unit named 
_fpm that lets you enter velocity values in feet per minute and convert 
velocity results to feet per minute.
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Now you can use the new velocity unit _fpm.

Creating user-defined functions and programs
You can use the Define command to create your own functions and 
programs. You can create them in the Calculator application or in the 
Program Editor and then use them in other TI-Nspire™ applications.

For information on programming with the Program Editor, see the 
“Programming” and “Libraries” sections of the documentation.

Defining a single-line function
Suppose you want to define a function named cube() that calculates the 
cube of a number or variable.

1. On the Calculator entry line, type Define cube(x)=x^3 and press 
·.

The message “Done” confirms that the function has been defined.

2. Type cube(2) and press · to test the function.

Defining a multiple-line function using templates
You can define a function consisting of multiple statements entered on 
separate lines. A multiple-line function may be easier to read than one 
with multiple statements separated by colons.

Note: You can create multiple-line functions only by using the Define 
command. You cannot use the := or & operators to create multiple-line 
definitions. The Func...EndFunc template serves as a container for the 
statements.

As an example, define a function named g(x,y) that compares two 
arguments x and y. If argument x > argument y, the function should 
return the value of x. Otherwise, it should return the value of y.
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1. On the Calculator entry line, type Define g(x,y)=. Do not press · 
yet.

2. Insert the Func...EndFunc template.

– From the Functions & Programs menu, select Func...EndFunc.

Calculator inserts the template.

3. Insert the If...Then...Else...EndIf template.

– From the Functions & Programs menu, select Control, and then 
select If...Then...Else...EndIf.

Calculator inserts the template.

4. Type the remaining parts of the function, using the arrow keys to 
move the cursor from line to line.

5. Press · to complete the definition.

6. Evaluate g(3,-7) to test the function.
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Defining a multiple-line function manually
To start each new line without completing the function definition, 
hold down Alt and press Enter

Handheld: Press @ instead of pressing ·.

As an example, define a function sumIntegers(x) that calculates the 
cumulative sum of integers from 1 through x.

1. On the Calculator entry line, type Define sumIntegers(x)=. Do not 
press · yet.

2. Insert the Func...EndFunc template.

– From the Functions & Programs menu, select Func...EndFunc.

Calculator inserts the template.

3. Type the following lines, pressing @ or Alt+Enter at the end of each 
line.

4. After typing Return tmpsum, press · to complete the definition.

5. Evaluate sumIntegers(5) to test the function.

Defining a program
Defining a program is similar to defining a multiple-line function. The 
Prgm...EndPrgm template serves as a container for the program 
statements.
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As an example, create a program named g(x,y) that compares two 
arguments. Based on the comparison, the program should display the 
text “x > y” or “x  y” (showing the values of x and y in the text).

1. On the Calculator entry line, type Define prog1(x,y)=. Do not press 
· yet.

2. Insert the Prgm...EndPrgm template.

– From the Functions & Programs menu, select Prgm...EndPrgm.

3. Insert the If...Then...Else...EndIf template.

– From the Functions & Programs menu, select Control, and then 
select If...Then...Else...EndIf.

4. Type the remaining parts of the function, using the arrow keys to 
move the cursor from line to line. Use the Symbol Palette to type the 
““ symbol.

5. Press · to complete the definition.
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6. Execute prog1(3,-7) to test the program.

Recalling a function or program definition
You might want to reuse or modify a function or program that you have 
defined.

1. Display the list of defined functions.

– From the Actions menu, select Recall Definition.

2. Select the name from the list.

The definition (for example, Define f(x)=1/x+3) is pasted into the 
entry line for editing.

Editing Calculator expressions
Although you cannot edit an expression in the Calculator history, you can 
copy all or part of an expression from the history and paste it to the entry 
line. You can then edit the entry line.

Positioning the cursor in an expression

Press e, ¡, ¢, £, or ¤ to move the cursor through the expression. 
The cursor moves to the closest valid position in the direction that you 
press.

Note: An expression template may force the cursor to move through its 
parameters, even though some parameters may not be exactly in the 
path of the cursor movement. For example, moving upward from the 
main argument of an integral always moves the cursor to the top limit.

Inserting into an expression in the entry line
1. Position the cursor at the point where you want to insert additional 

elements.

2. Type the elements that you want to insert.

Note: When you insert an open parenthesis, Calculator adds a temporary 
close parenthesis, displayed in gray. You can override the temporary 
parenthesis by typing the same parenthesis manually or by entering 
something past the temporary parenthesis (thereby implicitly validating 
its position in the expression). After you override the temporary gray 
parenthesis, it is replaced with a black parenthesis.
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Selecting part of an expression
1. Position the cursor at the starting point in the expression.

Handheld: Press ¡, ¢, £, or ¤ to move the cursor.

2. Press and hold g and press ¡, ¢, £, or ¤ to select.

Deleting all or part of an expression on the entry line
1. Select the part of the expression to delete.

2. Press ..

Financial calculations
Several TI-Nspire™ functions provide financial calculations, such as time 
value of money, amortization calculations, and return on investment 
calculations.

The Calculator application also includes a Finance Solver. It lets you 
dynamically solve several types of problems, such as loans and 
investments.

Using the Finance Solver
1. Open the Finance Solver.

– From the Finance menu, select Finance Solver.

The solver displays its default values (or previous values, if you have 
already used the solver in the current problem).

2. Enter each known value, using e to cycle through the items.

– The help information at the bottom of the solver describes each 
item.
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– You might need to temporarily skip the value that you want to 
calculate.

– Make sure to set PpY, CpY, and PmtAt to the correct settings (12, 
12, and END in this example).

3. Press e as necessary to select the item that you want to calculate, 

and then press ·.

The solver calculates the value and stores all the values in “tvm.” 
variables, such as tvm.n and tvm.pmt. These variables are accessible to 
all TI-Nspire™ applications within the same problem.

Finance functions included
In addition to the Finance Solver, TI-Nspire™ built-in finance functions 
include:

• TVM functions for calculating future value, present value, number of 
payments, interest rate, and payment amount.

• Amortization information such as amortization tables, balance, sum 
of interest payments, and sum of principal payments.

• Net present value, internal rate of return, and modified rate of 
return.

• Conversions between nominal and effective interest rates, and 
calculation of days between dates.

Notes: 

• Finance functions do not automatically store their argument values or 
results to the TVM variables.

• For a complete list of TI-Nspire™ functions, refer to the Reference 
Guide.
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Working with the Calculator history
As you enter and evaluate expressions in the Calculator application, each 
entry/result pair is saved in the Calculator history. The history gives you a 
way to review your calculations, repeat a set of calculations, and copy 
expressions for reuse in other pages or documents.

Viewing the Calculator history
The history of the expressions you have entered accumulates above the 
entry line, with the most recent expression at the bottom. If the history 
does not fit in the Calculator work area, you can scroll through the 
history.

Note: You may notice a processing slowdown when the history contains 
a large number of entries.

Press £ or ¤ to scroll through the history.

À Current entry/total entries

Copying a Calculator history item to the entry line
You can quickly copy an expression, subexpression, or result from the 
history into the entry line.

1. Press £ or ¤ to move through the history and select the item that 
you want to copy.

2. Optionally, select part of the expression or result by using Shift in 
combination with the arrow keys.

À
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Note: The float setting for the current document may limit the 
number of decimal places displayed in a result. To capture the result 
in its full precision, select it either by scrolling with the up and down 
arrow keys or by triple-clicking it.

3. Press · to copy the selection and insert it into the entry line.

Copying a history item to another application

1. Press £ or ¤ to move through the history and select the item that 
you want to copy.

2. Optionally, select part of the expression or result by using Shift in 
combination with the arrow keys.

3. Use the standard key shortcut for copying a selection.

– Windows®: Press Ctrl+C.

– Macintosh®: Press “+C.

– Handheld: Press / C.

4. Place the cursor at the location where you want the copy.

5. Paste the copy.

– Windows®: Press Ctrl+V.

– Macintosh®: Press “+V.

– Handheld: Press / V.

Note: If you copy an expression that uses variables into a different 
problem, the values of those variables are not copied. You must define 
the variables in the problem where you paste the expression.

Deleting an expression from the history
When you delete an expression, all variables and functions defined in the 
expression retain their current values.

1. Drag or use the arrow keys to select the expression.

Handheld: Use the arrow keys.
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2. Press ..

The expression and its result are removed.

Clearing the Calculator history
When you clear the history, all variables and functions defined in the 
history retain their current values. If you clear the history by mistake, use 
the undo feature.

To clear the history,

– From the Actions menu, select Clear History.

All expressions and results are removed from the history.
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Using Variables

A variable is a defined value that can be used multiple times in a 
problem. You can define a value or function as a variable within each 
application. Within a problem, variables are shared by 
TI-Nspire™ applications. For example, you can create a variable in 
Calculator, then use or modify it in Graphs & Geometry or Lists & 
Spreadsheet within the same problem. 

Each variable has a name and a definition and the definition can be 
changed. When you change the definition, all occurrences of the variable 
in the problem are updated to use the new definition. In the TI-Nspire™ 
software, a variable has four attributes:

• Name - User-defined name assigned when the variable is created.

• Location - Variables are stored in memory.

• Value - Number, text, mathematical expression, or function.

• Type - Type of data that can be stored as a variable.

Note: Variables created with the Local command within a user-defined 
function or program are not accessible outside that function or program.

Linking values on pages
Values and functions created or defined in one application can interact 
with other applications (within the same problem) to share data. 

When using linked items, keep in mind:

• Values can be linked between applications on one page or between 
different pages of the same problem. 

• All applications are linked to the same data.

• If the linked value is changed in the original application, the change 
is reflected in all linked usages.

Defining a variable is the first step in linking values.

Creating variables
Any portion or attribute of an object or function created within an 
application can be stored as a varible. Examples of attributes that can 
become variables are the area of a rectangle, the radius of a circle, the 
value contained in a spreadsheet cell or the contents of a row or column, 
or a function expression. When you create a variable, it is stored in 
memory. 



426 Using Variables

Types of variables
You can store the following data types as variables:

When you click  or press h on a handheld to open the list of stored 
variables, a symbol indicates the type.

Creating a variable from a Calculator value 
This example shows how to create a variable using a handheld. Complete 
the following steps to create a variable named num and store the result of 

the expression 5+83 in that variable.

1. On the Calculator entry line, type the expression 5+8^3.

2. Press ¢ to expand the cursor to the baseline.

Data type Examples

Expression

2.54 1.25E6 2p xmin/10 2+3i (xN2)2

List {2, 4, 6, 8} {1, 1, 2} {"red", "blue", "green"}

Matrix

This can be entered as:  [1,2,3;3,6,9]

Character string “Hello” “xmin/10” “The answer is:”

Function, 
program

myfunc( arg ) ellipse( x, y, r1, r2 )

Measurement area, perimeter, length, slope, angle

1 2 3
3 6 9
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3. Press / h and then type the variable name num.

This means: Calculate 5+83 and store the result as a variable named 
num.

4. Press ·.

Calculator creates the variable num and stores the result there.

Creating a variable in the computer software
When creating a variable in the computer software, use the following 
conventions. As alternatives to using & (store), you can use “:=” or the 
Define command. All of the following statements are equivalent.

5+83 & num

num := 5+83

Define num=5+83

Checking a variable’s value
You can check the value of an existing variable by entering its name on 
the Calculator entry line. When you type the name of a stored variable, it 
appears in bold type.

On the Calculator entry line, type the variable name num and press 
·. 

The value most recently stored in num displays as the result.

Automatically creating variables in Graphs & Geometry
In the Graphs and Geometry applications, functions defined on the entry 
line are automatically stored as variables.



428 Using Variables

In this example, f1(x)=x3 is a variable definition, which allows it to be 
displayed in other applications including a table in the Lists & 
Spreadsheet application.

Creating a variable from a Graphs & Geometry value
1. Click to select the value to store as a variable.

2. Click .
Handheld: Press h.

The Variables options are displayed with Store Var highlighted.

3. Press ·. VAR := appears before the selected value. This is the 
default name.
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4. Replace the default name VAR with the variable name you want to 
give the value. 

5. When the variable name is typed, press ·. 

The value is saved to that variable name, and the stored value or its 
name appears in bold text to indicate it is a stored value. 

Note: You can also share a Graphs & Geometry axis end value with other 
applications. If necessary, click Actions, Show/Hide Axes End Values to 
display the end values on the horizontal and vertical axes. Click the 
number for an end value to highlight it in the entry field. Name the 
variable and store it for use with other applications by using any method 
described in Step 2.

Automatically creating variables in Lists & Spreadsheet
Naming a list at the top of a Lists & Spreadsheet column automatically 
stores that value as a list variable. This variable can be used in other 
applications including Data & Statistics.
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Creating a variable from a Lists & Spreadsheet cell value 
You can share a cell value with other applications. When defining or 
referring to a shared cell in Lists & Spreadsheet, precede the name with 
an apostrophe (‘).

1. Click the cell that you want to share.

2. Click  to open the Variables menu.
Handheld: Press h. 

3. Select Store Var.

A formula is inserted into the cell with var as a placeholder for a 
variable name.

4. Replace the letters “var” with a name for the variable, and press ·.

The value is now available as a variable to other applications within 
the same problem.

Note: If a variable with the name you specified already exists in the 
current problem space, Lists & Spreadsheet displays an error message.
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Using (linking) variables
Sharing, or linking, the variables you create is a powerful tool for math 
exploration. The display of linked variables is automatically updated 
when the variable’s value changes. 

Linking to shared variables
To use a stored variable:

1. Display the page and select the location or object to which you want 
to link a variable. 

2. Select the Variables tool h.

The Variables options are displayed. The software knows which types 
of variables will work in the location or with the object selected and 
will only display those variables.

3. Use 9 and : to scroll the list, or type part of the variable name. 

As you type, the system displays a list of variables that begin with the 
letters you typed. Typing part of the name enables you to locate a 
variable more quickly if the list is long. 

4. When you locate and highlight the name of the variable you want to 
use, click the name or press ·. 

The selected variable value is linked. 

Linking a Lists & Spreadsheet cell to a variable
When you link a cell to a variable, Lists & Spreadsheet keeps the cell 
value updated to reflect the current value of the variable. The variable 
can be any variable in the current problem and can be defined in Graphs 
& Geometry, Calculator, or any instance of Lists & Spreadsheet.

Note: Do not link to a system variable. Doing so could prevent the 
variable from being updated by the system. System variables include ans, 
StatMatrix, and statistics results (such as RegEqn, dfError, and Resid).

1. Click the cell that you want to link to the variable.

2. Open the VarLink menu:

– Click , then click Cell.

– Handheld: Press h.

The VarLink menu displays.
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3. Under Link To, scroll to the name of the variable and click it.

The cell shows the value of the variable.

Using a variable in a calculation
After storing a value in a variable, you can use the variable name in an 
expression as a substitute for the stored value.

1. Enter the expression:

– Type 4*25*num^2 on the entry line, and press Enter. 

– Handheld: Type 4 r 25 r num^2 on the entry line, and press 

·. 

Calculator substitutes 517, the value currently assigned to num, and 
evaluates the expression.

2. Enter the expression:

– Type 4*25*nonum^2, and press Enter. 

– Handheld: Type 4 r 25 r nonum^2 on the entry line, and press 

·.

CAS: Because the variable nonum has not been defined, it is treated 
algebraically in the result.

Because the variable nonum has not been defined, the expression 
returns an error message.

Entering multiple statements on the entry line
To enter several statements on a single line, separate them with a colon 
(“:”). Only the result of the last expression is shown.
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Setting variable values with a slider
In the Graphs and Geometry applications, a slider control lets you adjust 
or animate the assignment of values for a numeric variable. Use a slider 
to represent multiple variable values in a continuous range. 

1. From the Document Tools menu, select Actions > Insert Slider.

Handheld: Press b 1 A to insert a slider.

The slider displays on the work area. If you need to adjust or animate 
value selection for more than one variable, you can repeat this step 
and insert multiple sliders. 

Note: You can access the context menu to Pin a slider to its location 
and prevent unintentional movement.

2. Click the slider to activate it and press e to move between the 
slider scale and the variable’s value.

3. Use ¡ and ¢ to move the slider on the scale.

4. Press Enter to select the value.

Access the context menu and choose Settings to view or change the 
default slider settings.

Naming variables
Variable and function names that you create must meet the following 
naming rules.

Note: In the unlikely event that you create a variable with the same 
name as one used for statistical analysis or by the Finance Solver, an error 
condition could occur. If you begin entering a variable name that is 
already in use in the current problem, the software shows the entry in 
bold to let you know.

• Variable names must be in one of the forms xxx or xxx.yyy. The xxx part 
can have 1 to 16 characters. The yyy part, if used, can have 1 to 15 
characters. If you use the xxx.yyy form, both xxx and yyy are required; 
you cannot start or end a variable name with a period “.”
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• Characters can consist of letters, digits, and the underscore character 
(_). Letters can be U.S. or Greek letters (but not Π or p), accented 
letters, and international letters.

• Do not use c or n from the symbol palette to construct a variable 
name such as c1 or n12. These may appear to be letters, but they are 
treated internally as special symbols.

• You can use uppercase or lowercase letters. The names AB22, Ab22, 
aB22, and ab22 all refer to the same variable.

• You cannot use a digit as the first character of xxx or yyy.

• Do not use spaces.

• If you want a variable to be treated as a complex number, use an 
underscore as the last character of the name.

• CAS: If you want a variable to be treated as a type of unit (such as _m 
or _ft), use an underscore as the first character of the name. You 
cannot use subsequent underscores in the name.

• You cannot use an underscore as the first character of the name.

• You cannot use a preassigned variable, function, or command name, 
such as Ans, min, or tan.

Note: For a complete list of TI-Nspire™ functions, refer to the 
Reference Guide.

• Library documents and library objects are subject to additional 
naming restrictions. For details, see the “Libraries” section of the 
documentation.

Here are some examples:

Variable names Valid?

Myvar, my.var Yes

My var, list 1 No. Contains a space.

a, b, c Yes

Log, Ans No. Preassigned to a system function or variable.

Log1, list1.a, list1.b Yes

3rdTotal, list1.1 No. xxx or yyy starts with a digit.
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Locking and unlocking variables
Locking lets you protect variables from modification or deletion. Locking 
prevents unintended changes to a variable.

Variables you cannot lock
• System variable Ans

• stat. and tvm. variable groups

Important information about locked variables
• To lock variables, use the Lock command.

• To modify or delete a locked variable, you must first unlock the item.

• Locked variables display a lock icon on the variable menu list.

• The Lock command clears the Redo/Undo history when applied to 
unlocked variables.

Examples of locking

For details about Lock, UnLock, and getLockInfo(), refer to the 
Reference Guide section of the documentation.

Time and altitude lists can be 
locked to ensure problem fidelity

Reference function f1 can be 
locked to prevent unintended 
change

Lock a,b,c Locks variables a, b, and c from the Calculator 
application.

Lock mystats. Locks all members of variable group mystats.

UnLock func2 Unlocks variable func2.

lm:=getLockInfo(var2) Retrieves the current lock status of var2 and 
assigns that value to lm in the Calculator 
application.
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Updating a variable
If you want to update a variable with the result of a calculation, you 
must store the result explicitly.

Reusing the last answer
Each instance of Calculator automatically stores the last calculated result 
as a variable named Ans. You can use Ans to create a chain of 
calculations.

Note: Do not link to Ans or any system variable. Doing so could prevent 
the variable from being updated by the system. System variables include 
statistics results (such as Stat.RegEqn, Stat.dfError, and Stat.Resid) and 
Finance Solver variables (such as tvm.n, tvm.pmt, and tvm.fv).

As an example of using Ans, calculate the area of a garden plot that is 1.7 
meters by 4.2 meters. Then use the area to calculate the yield per square 
meter if the plot produces a total of 147 tomatoes.

1. Calculate the area:

– On the Calculator entry line, type 1.7*4.2, and press Enter.

– Handheld: On the Calculator entry line, type 1.7 r 4.2, and press 

·.

2. Reuse the last answer to calculate the yield per square meter:

– Type 147/ans, and press Enter to find the yield.

– Handheld: Type 147 p ans, and press · to find the yield.

Entry Result Comment

a := 2 2

a3 8 Result not stored in variable a.

a 2

a := a3 8 Variable a updated with result.

a 8

a2 & a 64 Variable a updated with result.

a 64
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3. As a second example, calculate  and then add 2*log(45).

– Type 3.76/(-7.9+sqrt(5)), and press Enter.

– Handheld: Type 3.76 p (v7.9+sqrt(5)), and press ·.

4. Reuse the last answer:

– Type ans+2*log(45), and press Enter.

– Handheld: Type ans+2 r log(45), and press ·.

Temporarily substituting a value for a variable
Use the “|” (such that) operator to assign a value to a variable for just a 
single execution of the expression.

Removing a linked variable
1. Select the linked variable. 

2. Press h.

The Variables options display.

3. Select Unlink. 

The link is removed from the value, and the value displays without 
any bolding.
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Graphs & Geometry

Getting started with Graphs & Geometry
The Graphs & Geometry application enables you perform the following 
tasks.

• Graph and explore functions, including 3D functions.

• Create and explore geometric shapes.

• Animate points on objects or graphs and explore their behavior.

• Graph data collected by the Data Collection tool.

• Explore graphical and geometric transformations.

• Explore and investigate concepts of calculus.

• Link to data created by other applications and utilize it in 
Graphs & Geometry.

À Graphs & Geometry tool menu

Á Sample Graphs & Geometry work area in Graphing View

Â Sample tool icon (Trace tool) shows tooltip on hover

Ã Sample Function graph (from function expression on the entry line)

Ä Sample Graphs & Geometry entry line (for the Function Graph Type)

Å Entry Line Expansion button (click to show/hide the entry line)

À Á Â

Ã

Ä

Å

Æ
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Æ Function History button (click to show/hide all graphed functions of 
the type and next available function)

À Sample Graphs & Geometry work area in Plane Geometry View

Á Sample tool icon (Regular Polygon tool) shows tooltip on hover

Â Sample shape (regular polygon)

Graphs & Geometry menu
The Graphs & Geometry menu appears immediately above the work 
area. To display the menu on the Handheld, press b.

Note: In the 3D Graphing view, the menu shows commands for working 
with 3D graphs specifically.

When you select a tool from the menu, the tool’s icon displays in the 
upper left corner of the Graphs & Geometry work area. You can hover 
over the tool icon to view tooltips. 

Actions

Pointer Selects, moves, and manipulates 
objects.

Select Lets you select the background image 
or select objects in part of the work 
area by placing a dashed-line box 
around them. 

Hide/Show Enables you to hide or display 
selected objects in the work area. 

Â

À
Á
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Attributes Enables you to change the attributes 
of a selected object in the work area. 
Attributes vary depending upon the 
object selected. 

Delete All Removes all objects (such as graphs, 
shapes, points, and text) from the 
work area.

Text Lets you type alphanumeric text on 
the work area. You can type numeric 
values to apply to objects and type 
expressions for graphing functions. 

Coordinates and 
Equations 

Displays the coordinates of a point or 
the equation of a line or circle.

Calculate Opens the calculate tool to perform 
calculations using measurements, 
numerical values, or calculation 
results. This tool is different from the 
Calculator application.

Redefine Redefines a previously defined point 
to a new location. For example, you 
can redefine a point in free space to a 
location on an object, or redefine a 
point from one object to another.

Insert Slider Adds a slider object to let you easily 
modify a numeric variable. A slider 
also lets you animate the assigment 
of different numeric values to the 
variable.

View 

Graphing Places the work area in graphing mode 
and displays the Cartesian axes in the 
work area with an entry line below.

Actions
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Plane Geometry Places the work area in geometry mode 
and displays a work area with a scale, but 
no axes, grid, or entry line until you 
select Show Analytic Window from the 
View menu.

3D Graphing Displays a work area for defining and 
graphing functions of the form z(x,y). 
Also changes the Graphs & Geometry 
menu to show commands for 3D 
graphing.

Hide (Show) Analytic 
Window

Opens a small graphing window on a 
plane geometry work area. Places the 
Graphs & Geometry work area in 
modeling mode. This tool can be used 
only after Plane Geometry is selected. 

Hide (Show) Axes Hides the axes if they are currently 
displayed on the page. Displays the axes 
if none are displayed on the page. 

Show (Hide) Grid Turns the grid on or off for the work area 
or the analytic window. Objects can be 
attached to the grid when the grid is 
displayed.

Hide (Show) Entry Line Hides or displays the entry line on the 
page.

Show (Hide) Scale Toggles between showing and hiding the 
scale legend on the work area. When the 
scale is shown, the value and/or units can 
be changed to desired values/units. This 
applies only to geometric constructions.

Show (Hide) Axes End 
Values

Toggles between showing and hiding the 
lowest value and highest value on the 
horizontal and vertical axes.

Show (Hide) Table Toggles between showing and hiding a 
table of values associated with a graph.

View 
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Hide (Show) Object 
Selection Guides

Toggles between showing and hiding the 
label information for objects in the work 
area. Hide the object selection guides to 
keep an uncluttered display as you work 
near objects with information labels.

Graph Type

Function Displays the function mode entry line at the 
bottom of the work area.

Parametric Displays the parametric mode entry line at 
the bottom of the work area. This display 
shows the t-min, t-max, and t-step values. 
The defaults are 0-2p for t-min, t-max, and 
p/24 for t-step.

Polar Displays the Polar mode entry line at the 
bottom of the work area. This display shows 
the q-min, q-max, and q-step values. The 
defaults are 0-2p for q-min and q-max, and 
p/24 for q-step.

Scatter Plot Displays the Scatter Plot mode entry line at 
the bottom of the work area.

Sequence Displays a Sequence mode entry line for a 
time plot or web plot, or displays an entry 
line for a custom plot.

Diff Eq Displays an editor for defining and graphing 
ordinary differential equations.

Window/Zoom

Window Settings Lets you specify the minimum and 
maximum values for the x-axis and 
y-axis. You can also set the axis 
scaling increment between tics. 

Zoom - Box Enables you to define an area that 
you want to enlarge. 

View 
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Zoom - In Enables you to define the center 
point of the zoom in location. The 
Zoom In factor is approximately 2.

Zoom - Out Enables you to define the center 
point of the zoom out location. The 
Zoom Out factor is approximately 2.

Zoom - Standard Automatically sets x-min, x-max, y-
min, and y-max to center the origin. 
The x and y scale factors are equal. 
This is the default axes setting when 
Graphs & Geometry is first added to 
a page.

Zoom - Quadrant 1 Automatically sets x-min, x-max, 
y-min, and y-max to emphasize the 
first quadrant. The x and y scale 
factors are equal.

Zoom - User If you have modified any window 
settings (such as x-min), Zoom-User 
saves the present settings. If you 
have not modified any window 
settings since last selecting Zoom-
User, Zoom-User restores those 
settings.

Zoom - Trig Automatically sets x-min and x-max 
to integer multiples of p. The x and y 
scale factors are equal.

Zoom - Data Redefines the axes so that all 
statistical data points are displayed. 

Zoom - Fit Recalculates y-min and y-max to 
include the minimum and maximum 
y values of all functions between the 
current x-min and x-max. Hidden 
functions are not included. 

Zoom - Square Recalculates y-min and y-max so that 
the vertical scale is the same as the 
horizontal scale.

Window/Zoom
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Zoom - Decimal Recalculates x-min, x-max, y-min, 
and y-max so that the origin is 
centered and resolution is set to.1 
(one tenth).

Trace

Graph Trace Activates a trace point on the graph, 
enabling you to trace functions. Applies 
to function graphs only.

Trace All Activates trace points on all graphs on 
the work area, enabling you to trace 
multiple functions simultaneously.

Trace Step Enables you to set the Graph Trace 
increment automatically, or by 
specifying a numeric trace step value. 

Geometry Trace Enables you to view the pathway of a 
geometric or analytic object (such as a 
function graph) on the work area. 
Earlier portions of the pathway are 
automatically removed to reduce 
screen clutter.

Erase Geometry Trace Halts geometric trace and erases all 
persistent pathways on the work area.

Analyze Graph

Zero Finds zeros of a function (if any exist 
within the specified range.)

Minimum Finds the minimum within a specified 
range.

Maximum Finds the maximum within a specified 
range.

Window/Zoom
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Intersection Finds a point at which the selected 
function intersects another (if such a 
point exists within the specified range).

Inflection (CAS) Finds a point of inflection within the 
specified range.

dy/dx Finds the derivative at the point clicked 
on a function graph.

Integral Finds the integral over a specified 
bound.

Points & Lines 

Point Constructs a point defined in free space, 
on an object, or at the intersection of 
two objects.

Point On Constructs a point defined on an object. 
When the object is a function graph, the 
coordinates are displayed. 

Intersection Point(s) Constructs a point at each intersection of 
two selected objects.

Line Constructs a line defined by two points 
or by a point and a direction. You can 
press g while creating a line to limit 
its orientation, relative to an axis, by 15- 
increments.

Segment Constructs a segment, defined by two 
end points, which may be created or 
defined in free space or on a defined 
object. You can press g while 
creating a segment to limit its 
orientation, relative to an axis, by 15- 
increments.

Analyze Graph
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Ray Constructs a ray, defined by two points 
or by a point and a direction, extending 
infinitely. You can press g while 
creating the ray to limit its orientation, 
relative to an axis, by 15- increments.

Tangent Creates a tangent line.

Vector Constructs a vector with magnitude and 
direction defined by two points. You can 
press g while creating the vector to 
limit its orientation, relative to an axis, 
by 15- increments.

Circle arc Creates an arc defined by three points.

Measurement

Length Displays the distance between two 
selected points or the length of a 
segment, perimeter, circumference, or 
radius.

Area Displays the area of a selected polygon 
or circle.

Slope Displays the slope of a selected line or 
segment. A vertical slope is represented 
by %.

Angle Displays the measure of an angle 
defined by three selected points.

Shapes

Circle Constructs a circle by defining the center 
point at the first click and the radius by 
the second click. You can press g while 
creating the circle to constrain the radius 
to integer values.

Points & Lines 
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Triangle Constructs a triangle, defined by three 
points (vertices), which may be created or 
defined in free space or on a defined 
object. You can press g while creating 
a triangle to limit its orientation, relative 
to an axis, by 15- increments.

Rectangle Constructs a rectangle. You can press 
g while creating a rectangle to limit 
its orientation, relative to an axis, by 15- 
increments.

Polygon Constructs an n-sided polygon. Each click 
defines a vertex, and the polygon is 
completed by clicking the initial vertex or 
by pressing ·. You can press g 
while creating a polygon to limit its 
orientation, relative to an axis, by 15- 
increments.

Regular Polygon Constructs an n-sided regular polygon. 

Construction

Perpendicular Constructs a line perpendicular to a 
selected line, segment, ray, vector, axis, 
or side of a polygon, and passing 
through a created or selected point.

Parallel Constructs a line parallel to a selected 
line, segment, ray, vector, axis, or side 
of a polygon, and passing through a 
created or selected point.

Perpendicular Bisector Constructs a perpendicular line that 
bisects two points, a segment, or side 
of a polygon.

Angle Bisector Constructs a line that bisects an angle 
identified by three selected points 
where the second point is the vertex.

Shapes
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Midpoint Constructs a midpoint of two selected 
points, a segment, or side of a 
polygon.

Locus Constructs the locus of a point or 
object defined by the movement of a 
driver point along a pathway.

Compass Constructs a circle from a center point 
with a radius defined by a selected 
segment or the distance between two 
points.

Measurement transfer Transfers an entered or measured 
value to a selected object, axis, or 
function graph. If the original value 
changes, the change is also reflected in 
the transferred measurement.

Transformation

Symmetry Creates the image of an object rotated 
180- around a point.

Reflection Creates the image of an object reflected 
across a line, segment, ray, vector, axis, or 
side of a polygon.

Translation Creates the image of an object translated 
by a specified vector.

Rotation Creates the image of an object rotated 
around a point by a specified angular 
value.

Dilation Creates the image of an object dilated 
from a point by a specified factor.

Construction
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Using keystroke shortcuts
Use keystroke shortcuts to simplify tasks that you can perform in the 
Graphs & Geometry application. 

Keystrokes: Task accomplished:

. Removes a selected object from the work area.

g Constrains certain objects as you draw. Press while 
drawing a circle with the Circle tool, or while 
drawing objects with linear components. For 
example, you can constrain a ine to multiples of 15 
degrees, or constrain a circle to integer radius 
values.

+ (+) - (-) When a number is under the pointer, the + and - 
keys enable you to change the number of 
displayed digits.

< > When a number is under the pointer, the < and > 
keys decrease or increase a value.

/μ Displays application hints on the 
TI-Nspire™handheld.

e Move to functional areas of the application in the 
following order: the entry line, Entry Line 
Expansion button, Slider, Animation panel, or Data 
Collection Console (when present), and then to 
the work area. Edits (if any) are committed when 
you e out of a field. Press g e to move 
through the tab stop areas in reverse order, or 
press d to jump to a graph on the work area.

£ ¤ Moves up and down among menu options and 
through functions in the function history list. 
When using the Trace tool, enables you to move to 
a different graph when more than one graph is on 
the page.

¡ ¢ Moves along the entry line, one space or one 
button at a time. When using the Trace tool, 
moves the trace cursor along the graph, either left 
or right. When viewing an attribute list, steps 
through the options for one attribute. 

Note: When using the TI-Nspire™ software, you 
can press Alt while pressing an arrow key to move 
selected objects one pixel on the work area.
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Using the context menu
The context menu provides access to the tools most commonly used with 
the selected objects. Different options can appear on the context menu 
depending on the active object or the task you are performing.

You can display the context menu for an object in one of the following 
ways.

Handheld: Move the pointer to the object and then press / b. 

Windows®: Right-click the object.

Macintosh®: Hold “ and click the object.

Many of the options that appear on the context menu provide 
convenient access to functionality that is also available from menus. The 
context menu can include the following options that are not available on 
the application menus.

• Click Recent to view and access the 9 most recently used tools. Recent 
shows tools used for any Graphs & Geometry application, regardless 
of the document in which they were used.

• The Label option lets you show a persistent label near a selected 
object. 

• The Color option lets you change the line color or fill color of selected 
objects (such as a function graph, shape, or point).

Note: Color is supported for the TI-Nspire™ software in 
Normal/Desktop view. If you are working in the Handheld view or 
using the TI-Nspire™ handheld, the colors display as shades of gray.

• The Edit Relation option moves the focus to the entry line for editing 
the selected function. 

• The Convert to Analytic and Convert to Geometric options change 
text created in one view to text that will display in the other. For 
example, select the text box and click Convert to Geometric on the 
context menu to change text you created in Graphing View to text 
that will display in Plane Geometry view. 

• The Attach option lets you create a text chain, constraining the 
relative horizontal or vertical position of one text object with respect 
to another text object of the same type (analytic or geometric).

• The Group option lets you group multiple objects and move them 
simultaneously. A single label (rather than multiple label displays) 
reduces screen clutter 

• The Pin option lets you pin objects to prevent accidental moves as you 
make other changes on the work area. You can pin points, shapes, 
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angles, values, text, graphed functions, the axes, and the work area 
background. 

Other options that are appropriate for various objects also display on the 
context menu. See Working with Documents in the TI-Nspire™ software 
for more information about using color in documents and changing the 
Graphs & Geometry application’s settings for the default plot label 
display.

Using the work area
The work area provides a space for drawing and working with objects 
such as graphed functions, shapes, or points and lines. 

When you select a graph or position the mouse over a graphed function, 
the expression for the corresponding graph displays on the work area. 
You can select multiple graphs to display their expressions. 

The top left corner of the work area displays a tool icon when you 
activate most tools. You can hover over the tool icon to display tips to 
help you use the tool. 

Grabbing and dragging items in the work area
Dragging lets you move and manipulate items. For example, you can 
drag a text label to move it or drag a circle’s perimeter to resize it.

1. Point to the item.

The pointer changes to show that you can grab or manipulate the 
item.

2. Use the mouse to grab and drag the item.

Handheld: Hold down x to grab the item, use the touchpad or 

clickpad to drag it, and then press x again to release it. 

Panning the work area
To see different portions of the work area, click and hold on an empty 
region until the pointer changes to ù, and then drag. 

Adding text
You can add text to the work area to label objects, or to summarize the 
results of your analysis of a graph. Use the Text tool to type numerical 
values, formulas, or other information in the work area.

1. From the Actions menu, select Text. 

2. On the work area, click the location for adding text. You can attach 
text to an object by clicking the object.
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A text box with a blinking cursor appears at the location you selected. 

3. Type the text. 

4. Press · to anchor the text on the work area. 

You can create a text chain by using the Attach tool on the context 
menu to connect text objects of the same type to each other. Detach 
disassociates chained text from a text chain. Spacing, alignment, and 
updating of calculated value text is handled automatically for 
chained text.

Note: You cannot include pinned text, text hidden using the 
Show/Hide tool, or geometric scale values in a text chain. 

5. You can customize text objects to suit your needs.

• Use context menu options to change text objects.

– Convert text created in Graphing View to geometric text.

– Convert text created in Plane Geometry View (outside of the 
analytic window) to analytic text. 

– Attach analytic or geometric text to text of the same type.

• Use the Text tool to enter numerical values that the 
Graphs & Geometry application can interpret as numbers. You can 
use these numeric text entries for calculations, or for specifying 
measurements.

6. Press d or choose another tool to exit the Text tool.

Working with multiple objects
You can select multiple objects with the Pointer tool or Select tool, and 
then use other tools to perform certain actions on several objects at 
once. As you move around and over objects, helpful details display, such 
as information about the object type, object state (for example, pinned, 
locked, or grouped). 
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Notes: 

• Do not select a pinned object if you plan to move or group all of the 
selected objects together. You cannot move pinned objects, and 
including pinned objects in a group pins the group.

• The e tooltip displays when you hover over a component object. 

This indicates that you can press e to move among the component 
objects and select them individually.

• Read the object labels to ensure you do not select unintended 
objects.

Selecting objects using the Pointer tool
1. Click the first object that you want to select. 

The object flashes to indicate selection, and displays with a thicker 
line style (bold) when you hover over it. 

2. Click the second object. 

You can continue clicking objects to select all of the objects that 
interest you. As each object is selected, it flashes with the others in 
the selection. You can deselect an individual object by clicking that 
object again, or deselect the entire selection by pressing d or by 
clicking on a part of the work area that contains no object.

Selecting objects with the Select tool
1. From the Actions menu, choose Select.

2. Click a point near the boundary of the part of the work area 
containing objects that you want to select. 

3. Move the pointer across the desired selection region. A dotted box 
outline appears around the selection area as you move.

4. Click the point on the opposite boundary to complete selection. 

The objects in the selection box flash. You can double-click the work 
area to begin marking another selection, or press d to exit the 
Select tool.
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Canceling selection
Cancel the selection of objects in a selection box in the following 
ways.

• Cancel selection of all objects by pressing d or by clicking on a 
space with no objects. 

• Cancel selection for one object by clicking the object a second 
time. 

Deleting selections

To delete one or more selected objects, press .. 

You cannot delete the origin, the axes, or locked points and values, 
even if they are selected. Objects that are pinned and/or grouped can 
be deleted.

Moving selections
1. Hover over one of the flashing objects in a selection of multiple 

objects. 

2. Grab and drag the object. All objects in the selection move together.

3. Click at the location of your choice to complete the move.

Notes: 

• If an unmovable object is included in a selection, then you must move 
the objects individually. You cannot move the origin, the axes, or a 
pinned object as part of a multiple-object selection. 

• Specific movements are supported for certain objects. For example, 
you can press an arrow key to move an object attached to the grid 
one point at a time. 

Working with color
Color changes made in the software display in shades of gray when you 
work on documents using a TI-Nspire™ handheld that does not support 
color. Color is preserved when you move documents back to the 
software. 

Changing the color of a function or the axes
1. Select the axes or the function.

2. Access the context menu and choose Color > Line Color.

3. Select the color to apply.

Changing the line or fill color of objects
1. Select the object or objects.
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2. Access the context menu and choose Color > Line Color or Color > 
Fill Color.

3. Select the color to apply to the objects.

Understanding attributes
The following table lists the attributes available for objects. The list of 
available attributes depends upon the object you select. To view 
attributes, select the Attributes tool. When an object is selected, a list of 
the attributes available for that object displays on the work area. You can 
choose an attribute and select an option to change the appearance of 
the selected object. Attributes indicated with an asterisk support 
entering a number to indicate a value for the attribute.

Name Icon(s) Options Available for use on

Line Weight

  

Thin, Medium, 
Thick

Line, Tangent, 
Segment, Ray, Vector, 
Circle, Circle arc, 
Triangle, Polygon, 
Regular Polygon, 
Rectangle, Graphed 
Functions, Integrals

Line Style

  

Continuous, 
Dotted, Dashed

Line, Tangent, 
Segment, Ray, Vector, 
Circle, Circle arc, 
Triangle, Polygon, 
Regular Polygon, 
Rectangle, Graphed 
Functions, Polar 
Equations, Integrals, 
Parametric Plots

Animation

  

Unidirectional 
Animation 
Speed*, 
Alternating 
Animation 
Speed*

Point, Point On

Lock/ 
Unlock  

Object is 
unlocked, Object 
is locked

Point, Point On, 
Intersection Point, 
Length, Area, Angle, 
Circle Arc
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Custom 
Precision

Current value: n* Length, Area, Angle, 
Slope

Point Style

  

  

  

   

Circle, Empty 
circle, Square, 
Empty square, 
Cross, Plus, Thin 
(small circle), 
Large, Empty 
Large

Point, Point On, 
Intersection Point, 
Circle Arc

Activation

 

Point is activated, 
Point is 
unactivated

Scatter Plot elements

Graph 
Appearance   

 

Graph is 
continuous, 
Graph is discrete, 
Number of 
Points*, Step 
Size*, T 
Minimum*, T 
Maximum*, q 
Minimum*, q 
Maximum*, 

Graphed Functions, 
Parametric and Polar 
graphs

Axes Style

    

Grid, No Grid Axes 

Axes 
Settings

 

Axes user 
settings, Axes 
quadrant 1 
settings, Axes trig 
settings, Axes stat 
settings, Axes 
standard settings, 
Axes decimal 
settings

Axes

Axes End 
Style   

No arrows, 
Positive arrows, 
All arrows

Axes

Name Icon(s) Options Available for use on
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Changing an attribute of an object
You can change attributes to change the appearance of objects such as 
shapes, lines, graphed functions, and axes. 

1. From the Actions menu, choose the Attributes tool.

2. Select the object that you want to change. The list of the attributes 
for the selected object displays. 

3. Use 9 and : to move through the list of icons for attributes. 

4. Highlight the icon for the attribute you want to change and use 
7 or 8 to move through the options. For example, highlight the Line 
Weight option, and use 7 or 8 to move to Thick, Thin, or Medium.

Axes Tic 
Labels

Tic labels are 
shown, Tic labels 
are hidden

Axes

End Values 
of Axes   

End values are 
shown, End 
values are hidden

Axes

Line 
Equation 
Type

  

Cartesian (y=_), 

Canonical (_=0)

Line, Tangent, 
Segment, Ray, Vector

Equation 
Type  

Canonical (...=0),

Cartesian (...=r2)

Circle 

Plot Points

 

Points are not 
connected, Points 
are connected 

Scatter Plots

Labels

  

  

 

f, f( ), f( )=, 
y=f( ), y=,

Graphed Functions 

Sequence 
Type   

Time plot, Web 
plot

Sequence plots 

Name Icon(s) Options Available for use on
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As you move through the options, you can review the changes on the 
work area. For example, you can see the line weight for the selected 
object change from Thin to Medium as you preview the line weight 
options.

Note: You can enter a numeric value instead of selecting an option to 
change an animation speed attribute for a supported object, or to set 
the step size, number of points, minimum values, or maximum values 
for supported graph types.

5. Press · to apply the option to the attribute.

Locking measured values and points
Locking measured values and points can be useful when you need to 
prevent inadvertent change, or for explorations in which object 
manipulations are constrained such that the locked measurement 
remains  constant. 

1. From the Actions menu, select Attributes.

2. Select the value or point that you want to lock. 

3. Use 9 and : to locate the Lock attribute. 

4. Use 7 or 8 to select Lock. 

5. Click or press · to lock the value or point. 

A lock icon appears near the locked value or point. 

Initial rectangle with locked 
perimeter
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In this case, a rectangle is created with the desired perimeter, and 
then both the perimeter and area values are displayed. The perimeter 
value is locked. As you manipulate the rectangle, the perimeter 
remains unchanged but the area changes. When the optimum area 
displays, you can measure the sides to obtain the necessary 
dimensions. 

Graphs & Geometry views
The Graphs & Geometry application has three separate views. Each is 
tailored to specific types of explorations:

• In Graphing view, the work area contains axes for graphing 2D 
functions. The view includes an entry line where you can type and 
edit the expressions to be graphed.

• In Plane Geometry view, you can explore geometric objects. You can 
optionally use the Plane Geometry view in modeling mode (that is, 
Plane Geometry view with an analytic window added for working 
with objects in an axis system).

• In 3D Graphing view, the menu and work area change to let you 
graph and explore 3D functions of the form z(x,y). The section 
“Graphing 3D functions”  in this chapter discusses 3D features.

When you add a new document, problem, or page, you can choose 
Graphs or Geometry separately. The software adds a 
Graphs & Geometry application in the selected view.

Summary of view differences
The following table describes some work area differences between the 
Plane Geometry view and the Graphing View.

Feature Graph Area Plane Geometry Area

Aspect Ratio Adjustable; initially 1:1 Always 1:1 (static)

Units of Measure Generic (displayed as u) User-defined (per scale)

Area Graph Type Cartesian (default) or 
Polar

Euclidian
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Using the Graphing View
The following items display initially when you launch Graphing View.

• Cartesian axes in the Zoom Standard format (1:1 scale)

• Entry line from which you can graph up to 100 functions

The axes, entry line, and grid can all be displayed or hidden. All objects 
created in Graphing View are analytic objects, so no scale displays for 
shapes you draw (such as a circle or triangle). The Show Scale tool has no 
effect.

Uses • Define , graph, and 
manipulate 
functions to:

– Graph 
functions of 
the form f (x)

– Create scatter 
plots

– Graph polar 
equations

– Graph 
parametric 
equations

– Graph 
sequences

• Construct, 
manipulate, and 
measure analytic 
objects

• Display 
coordinates, 
equations, labels, 
and informative 
text 

• Construct, 
manipulate, 
transform, and 
measure Euclidean 
objects

• Display labels and 
informative text

Behavior Analytic objects must 
remain in the analytic 
area.

Geometric objects can 
be displayed as a layer 
behind the analytic 
area, but they remain 
geometric in nature.

Feature Graph Area Plane Geometry Area
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Creating an object in the Graphing View
When you create an object in the Graphing View, it is an analytic object, 
and all points of the object reside on the graph plane. When you change 
the axes scale, you automatically affect the appearance of the object. If 
you calculate a value associated with the object such as the area, only 
generic units are assigned (u for unit). These objects remain associated 
with the coordinate plane until you delete them or redefine them to the 
plane geometry area. 

Note: When working with a modeling view work area (Plane Geometry 
view with analytic window), you cannot move an analytic object onto the 
plane geometry area.

Customizing the work area

Panning views
Panning lets you explore nearby objects, parts of graphs, or plots. 

Grab any empty space in the work area, and drag it.

The pointer changes to ù as you pan.

Note: Panning works in both the Graphing View and the Plane Geometry 
View. In Plane Geometry View with the Analytic Window shown, you can 
pan each view independently.

Showing/hiding the axes and other elements
In the Graphing View or in the Analytic Window in Plane Geometry View, 
You can selectively show or hide the axes, grid, entry line, and end values 
of the axes. You can show or hide the Scale indicator in any view.

Note: You can also hide or show the entry line by clicking or  at the 
lower left corner of the work area.
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From the View menu, select the elements that you want to show or 
hide. In this example, the grid is shown and the axes and entry line 
are hidden.

Changing the appearance of the axes
The axes attributes tool lets you change display attributes such as end 
arrows, end values, tic mark labels, and zoom settings.

1. From the Actions menu, select Attributes.

2. Click either axis.

3. Press 9 and : to move to the desired attribute, and then press 
7 and 8 to choose the option to apply.

Zooming/rescaling the work area
Use one of the following methods to change the scale of the Graphing 
View or the Analytic Window in Plane Geometry View.

From the Window / Zoom menu, select one of the Zoom tools 
(Zoom - Box, Zoom - In, or Zoom - Out), or select one of the 
predefined Zoom settings. The initial setting is Zoom - Standard.

Select an axis end value, press · to edit it, and type a new value.
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Grab any tick mark on an axis, and drag it to rescale the view.

The aspect ratio of the axes is retained as you drag. To modify the 
scale of only one axis, hold g as you drag.

From the Window / Zoom menu, select Window Settings. In the 
Window Settings tool, type the end values XMin, XMax, YMin, or 
YMax. To set custom spacing of the tic-marks and grid, click the down 
arrow for XScale or YScale, and type a value.

Note: You can store an axis end value as a variable and then access it 
outside of the Graphs & Geometry application. Select the end value in 

the work area, and then click  (or press h) to store the value. 

Inserting a background image
You can insert an image as a background for a Graphs & Geometry page. 
The file format of the image can be .bmp, .jpg, or .png.

1. From the Insert menu, select Image.

Default range and domain

Extended domain
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2. Navigate to the image you want to insert, select it, and then click 
Open.

The image is inserted as a background.

For more information, refer to the Working with Images chapter.

Adjusting variable values with a slider
A slider lets you easily explore the effects of adjusting a numeric variable 
through a range of values. You can control a slider's location and visual 
appearance, and its adjustment range and step size.

À Horizontal slider showing variable name, current value, and range.

Á Vertical slider

Â Slider “thumb” that you can drag to adjust the current value of the 
variable

Ã Slider track

Ä Minimized sliders with arrows to adjust the variable’s current value

Inserting a slider
You can insert sliders on a Graphs page, a Geometry page, or a 
Data & Statistics page.

1. From the Actions menu, select Insert Slider. 

A gray image of a horizontal slider with default settings attaches 
itself to the pointer.

Â

À

Á

Ã

Ä
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2. Drag to position the slider, and click to release it.

3. Press · to accept the default name (such as V1), or type the name 

of a numeric variable that you want to assign and then press ·.

Setting up the slider
You can change many slider settings, such as Minimum and Maximum, by 
clicking parts of the slider. Some settings, such as Step Size, are accessible 
only through the Slider Settings dialog.

1. Right-click in the slider to display its context menu, and select 
Settings to display the Slider Settings dialog. 

Handheld: Point to the slider, press / b, and select Settings. 

2. Use the Slider Settings dialog to enter settings for the slider. Each 
setting is described below. Settings that accept a numeric value also 
accept an expression that evaluates to a numeric value.

Variable Specifies which variable is assigned to the slider. 
Type an available numeric variable name, or click 
the drop-down arrow and select a name from the 
list.

Value Sets the current value of the variable.

Minimum Sets the lowest value in the slider range (left or 
bottom end point on the track).

Maximum Sets the highest value in the slider range (right or 
top end point on the track).

Step Size Sets the size of the increment between values. The 
default setting is Automatic. To enter a specific size, 
click the drop-down arrow, select Enter Size, and 
type a positive numeric value.

Style Click the drop-down arrow to choose Horizontal or 
Vertical.
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Display Digits Specifies the display format of the variable’s current 
value. Choose Auto to display the value according to 
the Document Settings option. Click the drop-down 
arrow to choose from floating-point or fixed 
formats.

Show Variable Shows or hides the variable name in the slider.

Show Scale Shows or hides the scale in a maximized slider.

Adjusting a slider variable’s current value
After setting up a slider, use one of these methods to adjust the 
current value:

– Grab the slider thumb ( or ) and drag it.

– Click the slider thumb, and then press 9, :, 7, or 8.

– Click after the “=” or press e as necessary to select the current 
value, and type a numeric value.

– Click a new position on the track.

Note: Any time the variable’s current value is outside the slider’s 
defined range, the thumb is not displayed. To bring the value 
inside the slider’s range, click the slider track or arrows.

Repositioning a slider on the page
Grab and drag any empty space in the slider’s selection rectangle, or 
click an empty space in the slider and then press 9, :, 7, or 8.

Mimimizing a slider
To minimize a slider and display only the variable name, current 
value, and direction arrows, access the slider’s context menu and 
select Minimize.

To further minimize a slider and show only the arrows, access its 
context menu and uncheck Show Variable.

Stretching a slider
Grab the Minimum or Maximum end point on the track, and drag it.
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Note: Stretching or shrinking a slider affects only the length of the 
track. The Minimum and Maximum values do not change.

Animating a slider
An animated slider steps repeatedly through its range, using the slider’s 
Step Size.

Access the slider’s context Menu and select Animate.

Note: To stop the animation, click Stop Animate. Animation also 
stops if you lock the slider’s associated variable.

Removing a slider
Removing a slider does not delete the variable associated with the slider.

1. Click in the slider’s selection rectangle to select it.

2. Press ..

Tips for using sliders

Use multiple sliders for a variable
• You can assign the same variable to multiple sliders. This lets you see 

the effect of adjusting a variable by different step sizes or through 
different ranges. 

Deselect a slider

• To deselect a slider, click another part of the work area, press d, or 

press e e to move to another element in the work area.

Associate a different variable with a slider
• Click the text box for the variable name and type the name of the 

numeric variable to use. 

• With the slider active, click the h button to select a variable from 
the list.

Using the Trace tools
Graphs & Geometry provides two trace tools:

• Graph Trace - point-to-point trace of the graph for a function, 
parametric or polar equation, scatter plot, or sequence.
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• Geometry Trace - trail of functions or objects.

See Using the Plane Geometry View for details about using the Geometry 
Trace tool.

Tracing a graph or plot
Graph Trace moves over the points of a graph or plot and displays value 
information. 

1. From the Trace menu, select Graph Trace:

2. (Optional) From the Trace menu, select Trace Step to change the step 
increment.

3. Use Graph Trace to explore a graph or plot in the following ways: 

– Move to a point and hover to move the trace cursor to that point.

– Press 7 or 8 to move the trace cursor from point to point and 
display the coordinates or values of each point.

– Press 9 or : to move from one graph to another. The point’s 
coordinates update to reflect the new location of the trace. The 
trace cursor is positioned on the point of the new graph or plot 
with the closest x value to the last point identified on the 
previously traced graph. You can trace multiple functions as 
described in Tracing all graphs.

– Type a number and press · to move the trace cursor to that 
independent value on the graph or plot. 
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– Create a persistent point that remains on the graph while in 
Graph Trace mode by pressing · when the trace point reaches 
the point you want to label.

– Trace through and identify the points at which the graph has no 
defined value (a discontinuity) for a coordinate. The coordinate 
pair (x, undef) displays when you trace a point with an undefined 
x coordinate.

Notes: 

– When you select or trace a graph or plot on the work area, that 
relation displays on the entry line.

– When you trace beyond the initially visible graph, the screen pans 
to show the area being traced.

4. Exit Graph Trace by pressing d or by choosing another tool.

Tracing all graphs
The Trace All tool works like Graph Trace, but allows tracing multiple 
functions simultaneously. With several functions graphed on the work 
area, perform the following steps:

Note: The Trace All tool traces only function graphs, not plots of other 
relations (polar, parametric, scatter, sequence).

1. Choose Trace All from the Trace menu.

A vertical line indicates the x value of the trace and a trace point 
appears on each function graphed on the work area. 

2. Press 7 or 8 to move the trace point along each graph on the work 
area simultaneously. 

3. Exit Trace All by pressing d or by choosing another tool.

Working with relations
The entry line under the work area lets you specify relations in the 
format supported for each graph type. 

Using the entry line
The entry line displays at the bottom of the work area. You can specify 
multiple relations for each graph type. The default graph type is 
Function, so the form f1(x)= displays.

1. To graph a function, select a graph type.

– To graph a function, select Function on the Graph Type menu. 
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The work area and entry line change to function mode. Type an 
expression for the function after the equal sign. 

– To graph a parametric equation, select Parametric on the Graph 
Type menu. 

Type expressions for xn(t) and yn(t). Specifying alternate values for 
the default t-min, t-max, and t-step displayed is optional.

– To graph a polar equation, select Polar on the Graph Type menu.

Type an expression for rn(q). Specifying alternate values for the 
default q-minimum and q-maximum, and q-step displayed is 
optional.

– To graph a scatter plot, select Scatter Plot on the Graph Type 
menu.

The work area and entry line change to scatter plot mode. Click 
var to choose variable to plot as x and y for sn. You can also type 
the name of a variable that already exists, or define a list as 
comma-separated elements enclosed within brackets, for 
example: {1,2,3}.

– Choose the option for the type of sequence you want to plot. 

To plot a web plot or time plot of a sequence, select Sequence on 
the Graph Type menu and choose Sequence.

Function mode entry line

Parametric mode entry line

Polar mode entry line

Scatter Plot mode entry line



472 Graphs & Geometry

To plot a phase plot of a sequence, select Sequence on the Graph 
Type menu and choose Custom.

The work area and entry line change to show parameters needed 
for the selected sequence mode. Specify the parameters required 
for the plot type. You can use the Attributes tool to change 
between the Time plot and Web plot of a sequence.

2. Press · to graph the relation. 

When you press · to graph the expression, Graphs & Geometry 
hides the entry line and shows an uncluttered view of the graph. 

3. Take one of the following actions to continue your work:

– To graph the one relation and then immediately specify another, 
press :. 

– To graph the relation and activate the Entry Line Expansion 

button , press e. 

After you graph f1(x) and redisplay the entry line, the entry line 
displays f2(x)= to enable you to enter another function. If you 
select or trace a function, that function displays on the entry line.

As you graph multiple relations on the graph axes, 
Graphs & Geometry labels each, unless the Graphs & Geometry 
setting "Automatically hide plot labels" is checked.. You can 
define and graph a maximum of 99 of each type. For example, you 
use function mode to specify functions (f1(x) - f99(x) ). You can 
rename relations using custom names, for example, g1(x). 

Note: The entry line is automatically hidden when you are not 
entering or editing relations. To display it at any time, press / G.

Sequence mode entry line

Sequence mode - Custom entry line
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Displaying relation history

Show the entry line, and then click the Function History button  to 
display a history of the relations typed on the entry line. The list displays 
relations in the order of entry (top to bottom), with the most recent 
entry closest to the entry line. Use 9 and : to move up and down the list. 

Use the relation history list to edit or delete relations.

Finding points of interest
You can use the tools on the Analyze Graph menu to find a point of 
interest in a specified range of a function graph. Choose a tool to find 
zero, the minimum or maximum, the point of intersection, or the 
derivative (dy/dx) or Integral. 

Note (CAS): You can also find the point of inflection.

1. Select the point of interest on the Analyze Graph menu. For example, 
select Minimum to find the minimum point.

The icon for the selected tool displays at the top left on the work 
area. Point to the icon to view a tooltip about using the selected tool. 

2. Click the graph you want to search for the point of interest.

When you point to the plot, a dotted line displays for marking the 
part of the graph to search for the point of interest.

Notes:

– If you are finding the derivative, click the graph at the point at 
which you want to find the derivative.

– You can choose tools for finding points of interest from the 
context menu. If you select the Integral tool or the Derivative tool 
from the context menu with a function graph selected, that 
function is used for finding the point of interest.
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3. Press 3 or 4 to move the dotted line to the lower bound of the search 
region. 

Note: You can also type a number to use as the lower bound for the 
search region and press ·. 

4. Press · to mark the lower bound for the search region. The tool 
shades the range. 

5. Repeat steps 3 and 4 to set the upper bound of the search region.

If the search region you specified includes the point of interest, a 
label for the point displays. If you change a graph that has points of 
interest identified, check for changes in points of interest. For 
example, if you edit the function on the entry line or manipulate a 
plot, the point where the graph intersects the y axis can change. 

You can exit the tool by pressing d or choosing another tool. The 
labeled points of interest remain visible on the graph.

Specifying a function with domain restrictions 
You can use the entry line or the Calculator application to specify a 
function with domain restrictions. For multiple domain restrictions on a 
function, use the piecewise function, piecewise().

In the following example, a function with a domain that is less than 2 
and greater than -2 is specified on the entry line:

1. Press / G to display the entry line.

2. Type piecewise(3, x > -2 and x < 2) on the entry line.

3. Press · to graph the function. 

Graphs & Geometry reformats the expression on the entry line and 
graphs the expression:
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Graphing a family of functions
A family of functions differ by one or more parameters and can be 
specified with a single expression. To graph a family of functions: 

1. Type an expression for a family of functions on the entry line. To 
specify a family of functions:

– Specify the parameters as one expression for multiple functions 
using the format 
f1(x) = {-1,0,1,2} * x + {2,4,6,8} 
or 
f1(x) = m*x | m = {1,2,3}.

– Enclose the lists of numbers or lists of variables in curly brackets. 
Specify parameters to graph a family of up to 16 functions. 

For example, four functions are denoted with the expression: 
f1(x) = {-1,0,1,2} * x + {2,4,6,8}. 
The first function to be evaluated is y = -1 * x + 2 and the second is 
0 * x + 4.

2. Press · to graph the family of functions specified. 

Graphs & Geometry creates and displays a separate graph object for 
each member of the family of functions. 

Each function is labeled (f1_1, f1_2) to indicate its sequence in the 
expression. You can select, analyze, or trace the graphs to explore 
them.

Note: Editing a single function graph to change it to a family of 
functions is not supported.
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Creating a time plot or web plot sequence
You can use the Sequence graphing mode to plot a time plot or web plot 
from the entry line.

• A Time plot plots n on the horizontal axis against the value of the 
sequence at each term, u1(n), on the vertical axis. A time plot is useful 
for identifying patterns in sequence values.

• A Web plot plots the sequence value for a preceding index, such as 
u1(n-1), on the horizontal axis against the value of the sequence for 
the current index, such as u1(n), on the vertical axis. A web plot is 
useful for analyzing the long-term behavior of a recursive sequence 
(as with a convergence or oscillation).

1. Specify the parameters required for the type of sequence plot you 
want:

– The u1(n)= expression field is where you enter or edit the 
sequence. Type the expression that defines the sequence. The 
term index, n is a series of consecutive integers that starts with 
zero or any positive integer. The sequence name can include 
letters, numbers, and parentheses in the formats: u1, u1(n), u1(), 
myseq, myseq(n), or myseq(). (If you type the sequence name in 
the format u1() or myseq(), the application automatically adds 
the n.)

– The expression you type for a sequence can reference a variable 
assigned to work with a slider.

– The Initial Terms parameter is the first term to evaluate for a 
recursive sequence. If the sequence expression references more 
than one prior term, such as u1(n-1) and u1(n-2), then you must 
type additional initial terms. Separate multiple terms with 
commas.

– The nStep range is the minimum index, maximum index, and the 
increment used for graphing.

For example, in the u1(n) field, type the expression 2*u1(n-1) + 1. No 
initial term or step range entry is required in this case.

2. After entering the parameters, press · to graph the sequence 
specified. 
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The sequence plot includes a point for each term of the sequence. 

Note: If you plot a sequence and the variable used to specify it is later 
changed to another type (such as to a Function), the plotted sequence 
is automatically deleted.

3. Click the sequence graph and use Graphs & Geometry tools to explore 
the graphed sequence. 

– Click the sequence graph to see its expression and the label for the 
graph. 

– Animate a slider assigned to use a variable included in a sequence 
expression to observe changes in the plot. 

– Right-click the work area and choose Graph Trace on the context 
menu to move through and highlight values for the sequence.

Handheld: Press / b and select Graph Trace to move 
through and highlight values on the sequence graph.

– Press / T to display or hide a table of the values found while 
evaluating the sequences at consecutive integer values.
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– Grab and drag the point that represents an initial term. As you 
drag the term, its value changes. The sequence definition on the 
entry line is updated automatically with the changes you make by 
manipulating a term. 

Creating a custom plot for a sequence
A custom plot lets you show the relationship between two sequences by 
plotting one sequence on the x axis and the other on the y axis.

When you define a custom plot, you specify the variable names of two 
defined sequences (from the Graphs & Geometry application) and assign 
each to an axis. This section demonstrates how to create a custom plot 
using the Predator-Prey model from biology to determine the numbers 
of rabbits and foxes that maintain population equilibrium.

rabbit(n) = rabbit(n-1) * (1 +.05-.001 * fox(n-1))

fox(n) = fox(n-1) * (1 +.0002* rabbit(n-1) -.03), where:

.05 = the growth rate of rabbits if there are no foxes,

.001 = the rate at which foxes can kill rabbits,

.0002 = the growth rate of foxes if there are rabbits,

.03 = and the death rate of foxes if there are no rabbits.

1. On the Graph Type menu, choose Sequence and select Sequence. 
Use the model equation to define rabbit and fox sequences over a 
cycle of 400 generations. Assume that there are 200 rabbits and 50 
foxes initially. 
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Note: For a less cluttered view, choose Hide/Show on the Actions 
menu to hide the rabbit(n) and fox(n) sequences on the work area.

2. On the Graph Type menu, choose Sequence and select Custom.

3. Type rabbit(n) as the x-axis sequence, and then press e and type 
fox(n) as the y-axis sequence. 

Note: You can also click h to choose the name of a previously 
defined sequence, or specify the name of a new sequence that you 
can define later.

4. Press e to move to the next line, and set the nstep and the range for 
n. For this example, n is set between 1 and 400 and the nstep is the 
default value, 1.

5. Press · to create the custom plot. 

Note: Choose Zoom - Fit on the Window/Zoom menu to adjust the 
window settings.

6. Explore the custom plot by grabbing and dragging the point that 
represents the initial term. 

As you drag the point, its value changes and the rabbit and fox initial 
terms are automatically updated.
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In this example, manipulating the intial term demonstrates that the 
point of equilibrium in the rabbit and fox populations over the cycle 
of 400 generations = (150, 50).

Graphing differential equations
You can study linear and non-linear differential equations and systems of 
ordinary differential equations (ODEs), including logistic models and  
Lotka-Volterra equations (predator-prey models). You can also plot slope 
and direction fields with interactive implementations of Euler and 
Runge-Kutta methods.

À Slope field

Á A solution curve passing through the intitial condition

Â ODE editor:

– Checkbox for designating this ODE as active or inactive

– y1 ODE identifier

– Expression k·y1 defines the relation

– Fields (1,1) for specifying initial condition

– Buttons for adding initial conditions and setting plot parameters

Ã Slider to control coefficient k of the ODE

Â

Á

À Ã
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To graph a differential equation:
1. On the Graph Type menu, select Diff Eq.

The entry line displays an ODE edit field for defining the next 
available ODE. The ODE is automatically assigned an identifier, such 
as “y1.”

Note: You can type a replacement identifier and then use that 
identifier in the relation on the right side of the “=” symbol.

2. Move to the relation field and enter the expression that defines the 
relation. For example, you might enter -y1+0.1*y1*y2.

3. Enter the initial condition for the independent value x0 and for y10.

Notes: 

– The x0 value(s) are common to all the ODEs in a problem but can 
be entered or modified only in the first ODE. They are displayed as 
non-editable for the other ODEs.

– You can delete an existing initial condition by clearing its x0 and 
y0 fields.

4. If you want to study multiple initial conditions for the current ODE, 

click the Add Initial Condition button  and enter the conditions.

5. Click the Edit Parameters button  to view or set the plot 
parameters.
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6. Refer to the summary of settings following this procedure. Select a 
numerical Solution Method and any additional plot parameters. You 
can change these parameters as needed.

7. Select OK.

8. To enter additional ODEs, press down arrow to display the next ODE 
edit field.

When you press · or press the up or down arrow keys to move 
among ODEs that you have defined, the graph is updated to reflect 
any changes. One solution to the ODE is graphed for each IC specified 
for each active ODE (selected by checkbox).

Summary of Differential Equation settings

Solution Method Selects Euler or Runge-Kutta as the numerical 
solution method.

Iterations Between 
Plot Step

Computational accuracy for Euler solution 
method only. Must be an integer value >0. To 
restore the default, select the down-arrow 
and select Default.
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Error Tolerance Computational accuracy for Runge-Kutta 
solution method only. Must be a floating-

point value |1×10-14. To restore the default, 
select the down-arrow and select Default.

Field None - No field is plotted. Available for any 
number of ODEs, but required if three or 
more 1st-order ODEs are active. Graphs a 
combination of the solution and/or values of 
one or more ODEs (according to user-
configured Axes settings).

Slope - Plots a field representing the family of 
solutions to a single 1st-order ODE. Exactly 
one ODE must be active. Sets Axes to Default 
(x and y). Sets Horizontal axis to x (the 
independent variable). Sets Vertical axis to y 
(the solution to the ODE).

Direction - Graphs a field in the phase plane 
representing the relationship between a 
solution and/or values of a system of two 
1st-order ODEs (as specified by the Custom 
Axes setting). Exactly two ODEs must be 
active. Axes: user-configured (neither axis can 
be x).

Axes Default (x and y) - Plots x on the x axis and y 
(the solutions to the active differential 
equations) on the y axis.

Custom - lets you select the values to be 
plotted on the x and y axes respectively. Valid 
entries include:

• x (the independent variable)

• y1, y2, and any identifiers defined in the 
ODE editor

• y1’, y2’, and any derivatives defined in 
the ODE editor

Plot Start Sets the independent variable value at which 
the solution plot starts .

Plot End Sets the independent variable value at which 
the solution plot stops.

Plot Step Sets the increment of the independent 
variable at which values are plotted.
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Using the Text tool to enter functions
You can graph a function, including a function of the form “y=”, by 
typing the expression into a text box. To graph a function this way:

1. From the Actions menu, select Text:

2. Click the work area to place the text box. Type the function you want 
to graph. 

3. Drag the text box to the axis and drop it. 

Graphs & Geometry graphs the function.

Field Resolution Sets the number of columns of field rendering 
elements (line segments) used to draw a slope 
or direction field. You can change this 
parameter only if Field = Direction or Slope.

Direction Field at x= Sets the independent variable value at which 
a direction field is drawn when plotting non-
autonomous equations (those that refer to x). 
Ignored when plotting autonomous 
equations. You can change this parameter 
only if Field = Direction.
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Regardless of how you specify a function, each function is labeled for 
identification.

Graphing inequalities
You can use the entry line for the Function graph type to define a 
function that uses a symbol other than the equal sign. 

1. Position the cursor to the right of the equal sign. 

2. Press . or Backspace to delete the equal sign.

A list of symbols displays.

3. Select or type the desired sign(s) to express the inequality. 

Note: You can also type two symbols, such as > and = to express 
greater than or equal, or use the Catalog’s Symbol Palette to choose 
from the inequality symbols: >, <, {, and |.

4. Type the rest of the inequality expression and press · to graph the 
expression. 

The expression, as typed, displays when you hover at the boundary of 
the graph. The shading on the graphs of inequalities shows the values 
that satisfy the inequality. If you graph two inequalities that overlap, 
the area of overlap is shaded darker than either of the individual 
inequality graphs.

Renaming f(x)
The default naming convention for functions is fn(x). (The number 
represented by n increases as you specify more functions.) You can 
replace the default name with a name of your choice.

1. Place your cursor to the right of the = sign in the entry line.

2. Select the default characters.
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3. Type the letters/numbers for the system you want to use, and then 
type the function that you want to graph. 

4. Press · to graph the function. 

Notice that the label shown next to the graph is identical to what you 
entered.

Note: To continue the custom naming convention, you must 
manually rename each function as you enter it.

Editing functions
You can edit graphed functions, one function at a time. To edit a 
function:

1. Use one of the following methods to access the function:

– Press d and double click the function label on the graph. 

– Click the Entry Line Expansion button , or press £ to move to 
the function. 

The expression displays in a text box or in the entry line.
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2. Move the cursor to the portion of the function you want to change.

3. If you are adding to the expression, type the new characters into the 
function. 

If you need to delete a portion of the function, remove the unneeded 
characters and type any new characters. 

4. Press · to graph the revised function.

Hiding a function on the work area
1. From the Actions menu, select Hide/Show.

The Hide/Show tool icon displays at the top of the work area.

2. Click the graph of any functions that you want to hide. You can also 
click any other type of object that you want to hide.

Objects you click while the tool is active appear dimmed.

3. Press d to exit the Hide/Show tool. 

The hidden function disappears. To redisplay hidden objects, repeat 
the steps above. 
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Deleting a function
1. Select the function by clicking its graph. 

2. Delete the function by pressing Backspace or ..

The function is removed from the work area and from the list of 
graphed functions. 

Manipulating functions
Some functions allow you to translate, stretch and/or rotate them by 
grabbing and manipulating the graph.

From the Actions menu, choose Pointer, and then move to the graph 
that you want to manipulate. 

The pointer changes to indicate supported manipulation (for 
example, to õ , ö, or é) when you hover on a graphed function that 
you can grab and manipulate. 
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As you change the graph, the expression for the graph updates to 
reflect changes. You can manipulate the following types of functions:

• Linear function; y=b

• Linear function; y=ax+b

• Quadratic function; y=a(x-b)2+c

• Quadratic function; y=ax2+bx+c

• Exponential function; y=exp(ax+b)+c

• Exponential function; y=b*exp(ax)+c

• Exponential function; y=d*exp(ax+b)+c

• Logarithmic function; y=a*ln(cx+b)+d

• Sinusoidal function; y=a*sin(cx+b)+d

• Cosinusoidal function; y=a*cos(cx+b)+d
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Manipulating a linear function 

 

Initial function graph Function translated along the x-axis. 
(Notice the revised function label) To 
translate, grab near the middle of the 
graph, and then drag.

Manually rotated function. To rotate, grab and 
drag near the ends of the graph.
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Manipulating a quadratic function 

Original quadratic function Manually rotated function. To 
stretch, grab away from the 
vertex of the graph, and then 
drag.

Function translated on the x-axis Function translated on the y-axis

To translate, grab and drag near the vertex of the graph.
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Manipulating a sine or cosine function 

 

Finding the derivative at a point (the slope)
This method uses the Analyze Graph menu. Alternatively, you could 
create a tangent on the graph to help visualize the slope and then use 
the Measurement menu to measure it.

1. From the Analyze Graph menu, select dy/dx. 

2. Click the point on the graph at which you want to find the derivative.

Original sine function Rotation manipulation of the sine 
function. To stretch, grab away from the 
axis of vertical symmetry of the graph, 
and then drag.

Translation manipulation along the 
y-axis.

Translation manipulation along the 
x-axis.

To translate, grab and drag near the axis of vertical symmetry of the graph.
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The value of the derivative at the selected point displays on the 
graph.

Note: To find the derivative at a specific value of x or y, use the 
context menu of the point to show its coordinates, and then edit the 
x or y coordinate.

Viewing function tables
You can show a table of function values for any function in the current 
problem. 

While viewing the table, you can change the settings for the table, 
delete columns, add values for multiple functions, and edit the 
expression that defines a function. For details, refer to Using Lists & 
Spreadsheet.

Showing the table
From the View menu, select Show Table.

The table displays in a split screen, showing columns of values for the 
currently defined functions.
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At the top of each column, you can choose the function to display in 
the column.

Hiding the table
Click in the Graphs & Geometry window to display its menu, and then 
select Hide Table on the View menu.

Using the Plane Geometry View
The plane geometry view includes a scale by default, but includes no axes 
or entry line on the work area. 

Change to Plane Geometry View from the View menu by selecting 
Plane Geometry View.

The display refreshes to clear the axes and entry line and display a 
default scale. Any graphs or drawings created in Graphing View are 
not displayed on the plane geometry area. 

Note: Any geometric constructions created while in the Plane 
Geometry View are retained and displayed along with any previously 
created graphs.

Creating an object in Plane Geometry View
You can choose Geometry on an empty page of a document to work in 
Plane Geometry View. The shapes, points, and lines you create while in 
this view are geometric objects. Geometric objects can have an assigned 
scale, such as centimeters, instead of u for units (as used with Graphing 
View). 

When working in modeling mode (that is, in Plane Geometry View with 
an analytic window), you can move a geometric object into the graphing 
work area. The object remains a geometric object, and is not associated 
with the axes. For example, you can move a vertex of a triangle, but since 
the object is not tied to a coordinate plane, no coordinates display for 
the vertex.

The examples below show a modeling work area and the two types of 
objects: A is an analytic object while B is a geometric object.
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Although the two circles appear to be identical, they do not behave in 
the same way. Analytic objects are affected when the graph area is 
altered. In the next example, the axes were altered. Notice that only 
Circle A’s appearance is affected by the change. 

If you create an object with the axis hidden, the object is a geometric 
object. However, if you create an analytic object and later hide the axis, 
the object remains an analytical one. 

Triangle as it appears in Graphing View. The 
unlabeled vertex remains a geometric point. 
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Using the analytic window
The analytic (graphing) window is available in the Plane Geometry View. 
It adds an analytic (graphing) window on top of a portion of the plane 
geometry work area. This provides a combination work area that enables 
you to use both work area types without having to change the view. 

1. Confirm that the work area is in Plane Geometry View. 

2. From the View menu, select Show Analytic Window.

A small graphing window opens on the lower left corner of the plane 
geometry work area. See Working with functions for more 
information about graphing.

3. Use the modeling view to work with analytic and geometric objects. 
You can perform the following actions:

– Use the View menu to show or hide the axes, axes end values, 
scale, and grid.

– Resale the axes using the Window > Zoom tools or by dragging tic 
marks.

– Grab an empty area of the screen and drag it to pan through the 
work area.

4. Select Hide Analytic Window to remove the analytic window from 
the work area:

Working with Cabri™ II Plus files
You can open Cabri™ II Plus Figures (.fig) files in Graphs & Geometry. 
Each .fig file converts to one Graphs & Geometry page with converted 
figures and one Notes page with conversion messages.

Opening a Cabri™ II Plus file
To open a Cabri™ II Plus figures (.fig) file in Graphs & Geometry:

Plane 
Geometry 
area

Modeling view - shows the previous two views and 
the work done on both.

Graphing area
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1. From the File menu, select Open Document. 

2. On the Open TI Nspire Document dialog, click Files of Type and 
choose Cabri™ II Plus Figures (*.fig). 

3. Click the .fig file that you want to open in Graphs & Geometry and 
click Open. 

Using Geometry Trace
The Geometry Trace tool enables you to leave a visible trail of an object 
when it is moved on the work area. The movement can be done manually 
or by using the Animation tool. 

Note: The trace trail cannot be selected or manipulated.

1. Create an object or function. 

2. From the Trace menu, select Geometry Trace.

3. Click the object or function and manually grab and move the object, 
or select a point and use the Attributes tool to set animation. 

If you use animation, the point must be selected for Geometry Trace 
as well as animation. See Changing an attribute of an object for 
details.

4. Observe the Geometry Trace results. 

In the following example, a line segment was drawn and selected for 
Geometry Trace. Movement of the segment was done manually. 

The amount of trace track displayed on the work area depends upon 
the amount of movement. 

• If the object moves very little, then the entire track remains 
displayed until you erase it. 

• If the object moves a lot, the track can obscure a significant 
portion of the work area. In this case, the older portions of the 
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track fade out to prevent the work area from becoming obscured 
by the track. 

Erasing Geometry Trace
The easiest way to remove the trace tracks from the work area is to select 
the Erase Geometry Trace tool.

From the Trace menu, select Erase Geometry Trace.

When selected, this tool removes immediately all trace tracks from 
the work area. 

Grouping objects

You can group objects on the work area to maintain the positioning of 
the objects and to perform certain actions on all of the objects in the 
group. You can drag and move the objects in a group. 

1. Select the objects to group. 

Note: Do not include pinned objects if you plan to move the group. 
Including a pinned object in a group creates a pinned group.

For details about selecting the objects to group, see Selecting objects 
with the Pointer tool or Selecting objects with the Select tool.

2. With selected objects flashing, choose Group from the context menu. 

Handheld: Press / b.

Macintosh®: Press and hold “ and click the group.

Windows®: Right-click a selected object in the group.

The objects are grouped on the work area. When you hover over or 
click an object in the group of objects, the label “group” displays. You 
can ungroup the objects by clicking any object in the group and 
selecting Ungroup from the context menu.

Pinning objects
You can pin points, shapes, angles, values, text, graphed functions, the 
axes, and the work area background to prevent accidental moves as you 
manipulate other objects on the work area. 

1. Select one or more objects to pin. 

For details about selecting several objects to pin, see Selecting objects 
with the Pointer tool or Selecting objects with the Select tool.

2. Select Pin on the context menu. 

Handheld: Press / b.

Macintosh®: Press and hold “ and click the object.
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Windows®: Right-click the object.

Pinned objects are labeled with the object type (“circle” or “axes”) 
and display a pin icon. You can select the object and choose Unpin 
from the context menu to return the object to its original state. 

Notes:

– The work area does not display a label when pinned. You cannot 
grab the work area to pan the view if the work area is pinned. 

– Pinning an object to another object does not prevent 
manipulation of the “pinned -to” object. For example, a point 
pinned to a graphed function does not prevent manipulation of 
the graphed function.

– You can still edit a pinned object in some cases. For example, you 
can edit the x and y coordinates of a pinned point. The point can 
move to reflect an edit of values, but not in response to 
manipulation.

– For an object that includes a Lock attribute, locking is disabled 
after you pin the object. 

– When you point to a pinned object, the pointer does not change 
to one that allows translation or grab-and-drag actions.

Working with points and lines
Use the Points & Line tools to draw the following types of points and 
lines. Point and line tools also let you name, label, or redefine points. 

• Points: Point, Point on, Intersection point(s)

• Lines

• Segments

• Rays

• Tangent

• Vectors

• Circle arcs

Working with points
There are three tools for creating points:

• Point

• Point On

• Intersection Point
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Creating a point
You can create a point using the Point tool. Create a point on on the 
work area, or on an object such as a graph or shape.

1. From the Points & Lines menu, select the Point tool.

2. Move to the work area, and click to create a point. 

3. Work with the point using the Pointer tool from the Actions menu. 

For example, select the point using the Pointer tool and drag it to 
move it. 

Notes:

– A point that is pinned displays the pin icon and is not movable.

– You can also create a point by typing an opening parenthesis and 
comma-separated coordinates. For example, activate the Point 
tool, type (3,5), and then press · to create a point with abscissa 
3 and ordinate 5.

Creating a point on an object 
1. From the Points & Lines menu, choose Point On.

2. Click on the object you want to create a specific point on, then click 
to place the point. 
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3. Work with the point using the Pointer tool from the Actions menu. 

For example, use the Attributes tool from the Actions menu to 
animate the point on the object.

Defining points of intersection 
Use this tool to find points at which two graphs intersect. 

1. From the Points & Lines menu, select the Intersection Point tool.

2. Click each graph to find points of intersection. 

The first intersection point between the two graphs is drawn. If the 
graphs intersect in more than one place, all intersection points are 
drawn.
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Labeling (identifying) the coordinates of a point
You can identify the coordinates of any analytic point using the 
Coordinates and Equations tool. 

Note: An analytic point is one created in the Graphing View, or within 
the analytic window of the Plane Geometry View.

1. Create a point. 

You can also create a point on an object using the Point On tool.

2. From the Actions menu, select Coordinates and Equations. 

3. Move the pointer toward the point’s location. The coordinates 
display. 

4. Click to select the point. The point blinks to indicate selection.

5. Move to the place where you want to anchor the point coordinaties 
and press ·. 

If you move the point to a different location, the new coordinates are 
updated to the new position. 
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Naming a point 
You can name points and vertices in either the Graphing or Plane 
Geometry view. Because they are not tied to a specific coordinate, names 
remain unchanged if you alter the location of any portion of an object. 

1. Right-click the item to display its context menu, and select Label. 

Handheld: Hover over the point, press / b, and select Label. 

2. Type the name for the point in the text box.

(Optional) You can name a point as you create it by typing a letter or 
name immediately after you define the point. For example, when 
creating a triangle, type the letter “x” after creating the first vertex. 
Type “y” and “z”for the remaining two vertices as you create them.

Redefining a point
You can redefine a point from a point on the work area to an object, 
from one object to another, or from the analytic window to the Plane 
Geometry View work area (or from the geometric work area to the 
analytic window). 

1. Create a point, or decide which existing point you want to redefine. 

2. From the Actions  menu, select the Redefine tool. 

3. Click the point you want to redefine, then click the object or work 
area at the location for the redefinition.

The point moves to the object or new location. 
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Working with linear objects
The linear objects you can create and explore are located on the 
Points & Lines menu. Graphs & Geometry creates “smart” lines and rays. 
This means that only a portion of the line or ray is displayed. This feature 
reduces clutter on the work area. 

Creating a line 
1. From the Points & Lines menu, select the Line tool. 

2. Click a location to start the line. 

This click defines one point on the line. 

Note: If you press and hold g while creating the line, you limit its 
orientation (relative to the x-axis or the horizontal aspect of the 
screen), by 15- increments. 

3. Move and click again to define the direction and second point of the 
line. 

Graphs & Geometry draws the line.

Creating a ray
1. From the Points & Lines menu, select the Ray tool. 

2. Click to define the endpoint of the ray. 

Note: If you press and hold g while while creating the ray, you 
limit its orientation, relative to the x-axis or the horizontal aspect of 
the screen, by 15- increments.

3. Move the pointer and click again to define the direction of the ray.

Graphs & Geometry draws the ray. 
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Lengthening the visible part of a line or ray
1. On the Actions  menu, select Pointer.

2. Grab the end of the visible line or ray, and drag to lengthen or 
shorten it.

Creating a segment
1. From the Points & Lines menu, select Segment.

2. Click to define the first endpoint of the segment. 

Note: If you press and hold g while creating the segment, you 
limit its orientation (relative to the x-axis or the horizontal aspect of 
the screen), by 15- increments. 

3. Move the pointer and click again to define the second endpoint of 
the segment. 

Graphs & Geometry draws the segment on the page.

Creating a segment with a defined midpoint
With the Midpoint tool, you can define a midpoint on an existing line 
segment, between two specified points on a line, or between two points 
as you create the points. (When you select the second point, the 
midpoint is created.)

1. From the Construction menu, select Midpoint.

2. Click at the location to start the segment. 

As you move the pointer, a second point, the midpoint, appears. 

3. You can move the segment in any direction until you click on the 
work area a second time. 

With the second click, the segment is anchored and the midpoint 
remains identified. 
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4. If you are defining the midpoint of a segment that already exists, click 
the segment. 

The midpoint is created.

Modifying segments with midpoints
1. On the Actions  menu, select Pointer.

2. Select the segment and drag it to a new location without changing its 
orientation or length, or select one endpoint and drag it to a new 
location. 

If just an endpoint is moved and if the length of the segment 
changes, then the midpoint is repositioned to remain at the middle of 
the segment.

Creating a parallel line
You can create a parallel line with respect to any existing line on the 
work area including the axes, and the side of any triangle, square, 
rectangle and polygon. 

1. From the Construction menu, select Parallel.

2. On the work area, click once on an existing line, segment, or axis.

This click identifies the reference line for the new parallel line you are 
creating.

3. Move the pointer away from the reference line, axis, or segment.

Notice that a dotted line displays, representing the parallel line.

4. When the dotted line is in the desired position, click again to anchor 
it on the work area. 

Parallel line following the pointer
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Note: You can also click first on the work area and then select the 
reference line to create the parallel line.

Creating a perpendicular line
You can create a perpendicular line with respect to any existing line or 
segment in the work area including the axes, and the side of any 
triangle, square, rectangle or polygon. 

1. From the Construction menu, select the Perpendicular tool.

2. Click a point on the work area through which the perpendicular line 
should pass. A dotted line shows the position for the perpendicular 
line. 

3. Click again to anchor the perpendicular line. The dotted line changes 
to a solid line.

Anchored parallel line

Perpendicular line before anchoring to 
page
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Note: Alternatively, you can double-click the line or segment to 
create at the point where you want the perpendicular line to 
intersect.

4. (Optional) On the Actions menu, select the Pointer for moving the 
perpendicular line to a different location on the reference line.

5. (Optional) Click the intersection point and drag the point and 
perpendicular line to the new location. 

Creating a vector
1. From the Points & Lines menu, select the Vector tool.

2. On the work area, click the spot from which the vector originates.

3. Move the pointer in the direction of the vector. 

A dotted line follows the pointer as you move about the area.

4. When the vector is in the correct position, click to anchor the vector 
on the work area. 

The dotted line changes to a solid line. 

Anchored perpendicular line

 

Vector following the pointer after identification 
of the endpoint
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Moving a vector 
1. From the Actions menu, select Pointer.

2. Click on any point other than the endpoint and drag the vector to the 
desired location. 

Resizing a vector
Select an end point and drag it to increase or decrease the magnitude 
of the vector. 

Note: If the endpoint is located on an axis or another object, you can 
only move the endpoint of the vector along that object. 

Creating a tangent
You can create a tangent by identifying a specific point on an existing 
object or function. To create a tangent line:

1. From the Points & Lines menu, select Tangent.

2. On the work area, select the point at which you want the tangent 
drawn. 

A dotted tangent line blinks on the work area.

3. Press · to anchor the tangent on the work area.

Creating and working with shapes
You can use the Shape tools to draw many different geometric shapes.

• Circles

• Triangles

• Rectangles

• Polygons

• Regular Polygons

Tangent of an object
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When you use a shape tool, the pointer becomes a pencil. As you create 
any shape that includes a linear portion (for example a ray, segment, or 
triangle), you can enable custom alignment.

• Align a linear portion of the shape to either the horizontal or the 
vertical axis. 

• Press g to orient the linear portion of a shape in 15 degree 
increments relative to the x axis.

For precise shape definition, you can type the coordinates of a shape’s 
defining points in parentheses instead of clicking. For example, to create 
a circle with a center point at (-1,4) type (-1,4) when prompted for the 
center point.

Tool Press · after these steps:

Circle 1. Click the work area to position the circle’s center point. 

2. Move outward from the center point to size the circle. 
A dotted circumference displays.

Triangle 1. On the work area, click once to establish the first 
vertex of the triangle. 

2. Move to the location for the second vertex and click 
the work area a second time. The side of the triangle 
displays as a dotted line.

3. Move to the location for the last vertex. As you move, 
all sides of the triangle are shown as dotted lines. 

4. Click the work area a third time to create the final 
vertex and anchor the triangle on the work area. The 
sides are defined by solid lines

Rectangle 1. Click once to establish the first corner of the rectangle. 

2. Move to the location for the second corner, and click 
again. One side of the rectangle displays.

3. Move away from the side of the rectangle. Move in the 
direction that corresponds to the rectangle orientation 
of your choice. The outline of the rectangle appears on 
the work area. 

4. When the rectangle is the correct size, click again to 
anchor the rectangle to the work area.
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Creating a shape
1. From the Shapes menu, select the tool for the shape you want to 

draw. 

Polygon 1. On the work area, click once to establish the first point 
of the polygon. 

2. Move the location for the second point and click the 
work area a second time. The side of the polygon is 
shown as a dotted line.

3. Move to the location of the next point. As you move 
the pointer, the polygon’s sides display as dotted lines.

4. Continue to move and click the work area to create as 
many sides as needed. After you press · to 
complete the polygon, the sides display as solid lines.

Regular 
Polygon

1. Click once on the work area to establish the center 
point of the regular polygon.

2. Move the pointer away from the center point and click 
on the work area again to establish the first vertex and 
radius.

A 16-sided regular polygon is formed. The number of 
sides displays near the center point in brackets; for 
example, {16}. 

– To reduce the number of sides, select a vertex and 
move the pointer in a clockwise motion around 
the perimeter of the polygon.

– To increase the number, select a vertex and move 
the pointer in a counter-clockwise motion. 

The number of sides of the polygon displays as you 
move the pointer. 

Circle arc 1. Click once on the work area to establish the first point 
of the arc.

2. Move in the direction you want the arc to take and 
click on the work area again to establish the second 
point. 

3. Move away from the second point to establish the 
length of the circle arc and click on the work area a 
third time. An arc displays. 

Tool Press · after these steps:
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The pointer displays as a pencil to indicate that the Shape tool is 
active. You can hover over the icon for the tool to view tips for 
drawing a shape.

2. Move the pointer to the location of your choice on the work area. 

A dotted line, shape, or partial shape displays to help you visualize 
the completed shape.

3. Click once to establish the first point of the shape.

Note: You can press the keys to affect the sizing of some shapes as 
you draw them. For example, if you press and hold g while 
creating a circle, the radius is limited in length to integers. 

4. Move the pointer away from the first point as required to position 
the second point of the shape. 

The direction and movement of the pointer can establish height, 
orientation, or angles for a shape. A dimmed representation of the 
shape or a partial shape displays to guide you.

5. Click the work area again to establish the second point or complete 
the shape. You will need to move and position the pointer as many 
times as required for the shape you are drawing. 

You can move the pointer to the shape tool icon at the top of the 
work area to read tips for creating a shape.

6. When all points or angles are in position, press · to complete the 
shape.

You can perform actions to explore the shapes you draw. For 
example, you can move a shape around the work area, resize it, 
change its attributes, and pin it to the work area or an axis. You can 
explore and analyze shapes using tools such as the measurement or 
transformation tools.

Sizing and positioning shapes
1. From the Actions  menu, select the Pointer.

2. Hover over a shape to change the pointer to ÷. You can click and 
drag a circle’s perimeter to resize it, or click and drag a point to resize 
a polygon, rectangle, or triangle. 

3. Click and hold the selected area to change the pointer to { . 

4. Drag to resize the selection. 

5. Move a shape by grabbing and dragging the center point (circle) or a 
side (triangle, rectangle, or polygon).
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Identifying equations for circles and lines
You can display the equation of any Analytic object (constructed in the 
Graphing View, or within the Analytic Window of the Plane Geometry 
View) and label it on the screen. 

1. From the Actions  menu, select Coordinates and Equations. 

2. Click the circle or line to select it. 

The equation for the circle or line displays and the object blinks on 
the screen. 

3. Press · to anchor the equation on the screen.

Note: If you approach a defined point on the line or the center point 
of a circle, the coordinates for that point display instead of the 
equation. Move the pointer away from the defined point to obtain 
the equation of the object.

Measuring objects 
You can obtain various measurements from the objects you draw. These 
measurements include finding areas, lengths, angles, and slopes.

Measurement values are dynamic. If you measure sides and angles of a 
triangle, for example, and then alter the triangle, the measurement 
values update automatically.

To change the displayed precision of an area, length, angle, or slope 
measurement, point to it and then press + or -.

Measuring length
You can use the Length tool to measure the length of a segment, circle 
arc, or vector. The length tool can also measure the side or perimeter of a 
polygon, the circumference of a circle, the distance between two points, 
the distance from a point to a line, ray, segment, or vector, and the 
distance from a point to a circle. 
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Note: Measurements made on Graphing View objects and lines have 
generic units, u. Measurements made on Plane Geometry View objects 
and lines have the unit value you create. The default unit value is 
centimeters (cm).

Measuring length of a segment, circle arc, or vector
1. From the Measurement menu, select the Length tool.

2. Click or press · to select the object. The target segment, circle arc, 
or vector blinks. 

3. Click or press · to anchor the measurement on the work area. 
Note that a line segment can be part of a triangle, rectangle, or 
polygon.

Measuring distance between two points, a point and a 
line, or a point and a circle: 
1. From the Measurement menu, select the Length tool.

2. Select the first point. 

3. Select the second point or a point on the line or circle. The selected 
length blinks. 

4. Click or press · to anchor the value on the work area.
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Finding the circumference of a circle or the perimeter of a 
polygon, rectangle or triangle
1. From the Measurement menu, select the Length tool.

2. Click the object to measure its circumference or perimeter.

3. Press · to anchor the measured value on the work area. 

Measuring one side of a triangle, rectangle, or polygon: 
1. From the Measurement menu, select the Length tool.

2. Point to the side that you want to measure.

Initially, the perimeter of the object displays, along with a visual 
reminder that you can use e to measure the side instead.

3. Press e to display the length of the side, and click to attach it to the 
pointer.

4. Position the measurement, and click or press · to anchor it on the 
work area. 

In this example, length is measured 
from the center of the circle to the 
upper left vertex of the polygon.

Measured circumference and perimeter
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Finding the area of a circle, polygon, rectangle, or triangle
1. From the Measurement menu, select Area.

2. Click the object to measure its area.

3. Press · to anchor the measured value on the work area. 

Finding the measure of an angle
1. From the Measurement menu, select Angle.

2. Click a point on one side of the angle to be measured.

3. Click the vertex of the angle you want to measure. 

When you move the pointer, the measure of the angle displays near 
the second point clicked. 

4. Click on a point on the second side of the angle to be measured to 
anchor the value on the work area.

Defining an angle with three points
You can define and measure an angle by selecting three points on the 
work area.

1. From the Measurement menu, select the Angle tool.

Areas of a circle and a polygon
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2. Click once on the work area and move to the next point. The first click 
represents one side of the angle. As you move to the next point, a 
dotted line shows the path used for angle measurement.

3. Click a second time on the work area. The second click represents the 
vertex. As you move to the next point, Graphs & Geometry calculates 
the measurement of the angle and displays it on the work area. 

If you are defining an angle with a specific measurement, you can 
change the path to adjust the angle size.

4. Click a third time on the work area, or press ·. The third click 
represents the second side of the angle and anchors the three points. 

The measurement remains visible and close to the angle even if you 
change the size of the angle. If you alter the angle, the measurement 
updates to reflect the new value. 

Notes:

– The value of any angle will always be between 0- and 180- in 
degree mode or between 0- and p in radian mode.

– The default angle measure is in radians for measurements within 
Graphing View or an Analytic Window, and in degrees for 
measurements within Plane Geometry View. To change it, change 
the document settings.

Repositioning a measured value
1. From the Actions menu, select Pointer. 

2. Select and drag the measurement to the desired location.

Finding the slope of a line, ray, segment, or vector
1. From the Measurement menu, select Slope.

2. On the work area, press · to select the object. 

3. Press · to anchor the value on the work area. 
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The slope remains visible and close to the object even if you alter the 
slope. Note that the value changes as the object is moved. 

Note: If the object is vertical, the slope value is -% or +%. If the object is 
horizontal, the slope value is 0.

Transferring measurements
The Measurement Transfer tool lets you transfer a numeric value to an 
object. The transferred value remains linked to the original value. If you 
adjust the length of the initial measurement, all objects created with that 
measurement are adjusted automatically to reflect the change.

The tool can use any measured value or numerical text entry as the value 
to transfer.

You can transfer the value to:

• An axis -This creates a point on the axis at a distance equal to the 
transferred value.

• A new circle - This creates a circle with a radius equal to the 
transferred value. If you later delete the original value, the circle is 
also deleted.

• An existing circle - This defines an arc on the circle. You set the 
starting point, and the transferred value is used to create the ending 
point.

• A ray or vector - This creates a second point on the ray or vector at the 
transferred value, as measured from the object’s endpoint.
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Example: Transferring a numerical text entry to an axis
1. From the Actions  menu, select Text, and then click to create a text 

box on the work area.

2. Type the number that you want to transfer, and and press · to 
anchor it.

3. Press d to exit the Text tool.

4. From the Construction menu, select Measurement Transfer. 

5. Click the number to transfer, and then click the desired axis.

The value is marked by the addition of a point on the axis. In this 
example, the point has been labeled to show its coordinates. 

 

Example: Creating a circle using a transferred 
measurement
1. Create a triangle from the Shapes menu, and then use the 

Measurements menu to measure the length of one side. This length 
will be used as the radius for a new circle.

2. From the Construction menu, select Measurement Transfer.
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3. Click the measured value that you created in step 1.

4. From the Shapes menu, select Circle.

A new circle is created with a radius equal to the transferred value.

5. Move the pointer to position the circle, and click to anchor it.

6. Press d to exit the tool, and then reshape the triangle to explore 
the effect on the circle.

Example: Transferring a measurement onto a circle
1. Create a circle using the Circle tool on the Shapes menu. 

2. Create a line segment using the Points menu, and use the 
Measurements menu to create a measurement of its length. This 
length will be used as the length of an arc on the circle.

3. From the Construction menu, select Measurement Transfer.

4. Click the measured value that you created in step 2.

5. Click the circle.

A point representing the start of the arc follows the pointer as you 
move around the circle.

6. Position the starting point, and then click to anchor the arc.

The measurement is transferred in a counter-clockwise direction, and 
the starting and ending points of the value are marked by points.
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7. Press d to exit the tool, and then move the end points of the 
original line segment to explore the effect on the arc. You can also 
move the arc by dragging its starting point.

Note: If you measure the distance between the two points on the 
circle, the value will be less than the transferred measurement. This is 
because you are measuring a straight line between the points, not 
the arc formed between the points. The arc’s length is the transferred 
measurement.

Using the Calculate tool
The Calculate tool enables you to perform arithmetic calculations using 
measured and entered values. An example best shows how this tool is 
used.

1. Create an object and display measurements for it. In this example, a 
triangle is constructed and its angles are measured using the Angle 
tool on the Measurements menu.

2. From the Actions menu, select Text.

3. Type the formula for the calculation. In this example, the formula 
adds the measurements of the three angles. 
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4. From the Actions menu, select Calculate tool. 

5. Click the formula you created.

You are prompted to select a value for each term in the formula.

6. Click each angle measurement when prompted.

Note: If you have stored a measurement as a variable, you can select 
it when prompted by clicking . If the name of a stored 
measurement matches a term in the formula, you can press “L” when 
prompted for that term.

When all variables in the formula have values, the answer displays on 
the work area. 

7. Press · to anchor the result. 

Transforming objects
You can apply transformations to drawn objects, and some can be 
applied to functions. When working with functions, the axes are most 
frequently involved and may be required. Object transformations can 
occur without the use of axes as a reference point. 

The transformations supported by Graphs & Geometry are:

• Symmetry with respect to any point, including the origin

• Reflections with respect to any straight line, including the axes
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• Translations along any vector, including vectors on the axes

• Rotations about any point, including the origin, and any angle

• Dilations from any point, including the origin, with any factor

The first step in any transformation is to create an object or the graph of 
a function.

Exploring symmetry
1. Create an object. 

2. From the Points & Lines menu, select Point. 

3. Click the work area to create the point of symmetry.

4. From the Transformation menu, select Symmetry. 

5. Select the object, then select the point.

The symmetrical image displays. 

Exploring reflection
1. Create an object.

2. Create a line or segment about which the object will be reflected.

3. From the Transformation menu, select Reflection.

4. On the work area, select the reflection line or segment. 

5. Select the object.

The object reflection displays. 
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6. To anchor the reflection, click on the page, or press ·.

Exploring translation
1. Create an object to translate (duplicate).

2. (Optional) Create a vector to indicate the distance and direction of 
translation.

3. From the Transformation menu, select Translate. 

4. Indicate the distance and the direction of translation by performing 
one of the following actions.

– Click the vector, or 

– Click the work area to indicate the distance between the object 
and the translation object, then click a second time to indicate the 
direction of translation.

5. Click the translation object. The translated object displays.
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Exploring rotation
1. Create the shape or graph the function to rotate.

2. (Optional) You can optionally create the point to rotate around and 
the angle for specifying the angle of the rotation. 

3. From the Transformations menu, select Rotation.

4. If you defined the point of rotation and angle of rotation before 
activating the tool, start the rotation by clicking the object first, 
clicking the point of rotation next, and clicking the angle of rotation 
last.

Or,

With the Rotation tool active and no pre-defined point and angle, 
specify the point to rotate around and the angle of rotation.

a) Type the opening parenthesis and type the x and y coordinates of 
the point to rotate the object around and press ·.

b) Type the measurement to use for the angle of rotation and 
press ·.

The object is recreated in the rotated position as defined by the 
rotation point and angle of rotation. 

Exploring Dilation
1. Create an object to enlarge by dilation.

2. Create a point that is the center for the Dilation. 

3. From the Actions menu, select Text and type a value to establish the 
size of the Dilation You can also measure an existing length to 
establish the sizing for the Dilation

Note: If you specify a large sizing value, you may have to use the 
Zoom tools or pan the display to view the dilated object.
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4. Press · to anchor the sizing value on the work area.

5. From the Transformation menu, select Dilation. 

6. Click the object, the center point, and the sizing value before moving 
toward the object. 

Note: You can also specify center point coordinates and the sizing 
value of the Dilation by typing the numbers after an opening 
parenthesis.

The Dilation appears on the work area. 

Performing other investigations
You can investigate other scenarios by bisecting segments, lines, and 
angles, or by creating a Locus.

• Bisecting a segment

• Bisecting an angle

• Finding the Locus

Bisecting a segment 
1. From the Construction menu, select Perpendicular Bisector.

2. Click the segment. 

The perpendicular bisector displays. 

Note: If the segment is not already present on the work area, you can 
create one by selecting two different points.
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3. Click once more to anchor the bisector on the work area.

Note: A segment can be one side of a triangle, rectangle, or a 
polygon. 

Bisecting an angle
1. From the Construction menu, select Angle Bisector.

Note: If no angle is present on the work area, you can create one by 
selecting three different points. 

2. Click to define the first side of the angle. 

3. Click to define the vertex of the angle. 

4. Click to define the second side of the angle. 

Bisecting an existing segment (bisector not 
anchored on page)
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The bisector line appears and is anchored on the work area when you 
select the third point. 

Note: If you select the Pointer tool and move one point of the 
created angle, the angle bisector moves so that it always bisects the 
angle.

Creating a locus
The Locus tool enables you to explore the range of motion of one object 
with respect to another object as constrained by a shared point. 

1. Create a segment, line, or circle. 

2. Create a point on the segment, line or circle. 

3. Create another object that uses the defined point created in the 
previous step. 

Creating an angle bisector by defining three 
points. The second point represents the vertex of 
the angle.

Point defined on the line segment.
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4. From the Construction menu, select the Locus tool.

5. On the work area, select the object defined to share the point (this is 
the object to vary). 

6. Select the point shared by the objects (this is the object to constrain). 

The continuous locus displays. 

7. Move the point on the first construction. 

The second construction deforms to follow the locus point. 

Circle created to use the 
defined point on the segment.

Two examples of the radius 
change of the circle as the locus 
moves along the line segment. 
The radius is labeled to better 
show the change.
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You can create and explore other designs using the Locus tool. 

Animating points
You can animate a point on a line, ray, axis, vector, graph, segment or 
circle. In addition, you can also animate points on multiple objects in the 
work area at one time. 

Animating a point on an object 
1. From the Points & Lines menu, select Point On.

2. Click the object to create the point on, and then click the location for 
the point. 

3. From the Actions menu, select Attributes. The Attributes tool 
displays.

Locus created using a point and a segment. 



Graphs & Geometry 531

4. Press £ or ¤ to move to the animation attribute and press ¡ or ¢ to 
move to either the unidirectional or alternating animation speed 
attribute. 

5. Type a number from 1 - 9 to set the speed. The default speed is 0. 

The higher the number you type, the faster the animation speed. 

6. Animation begins automatically when you select the speed and 
direction. 

Press + and - on the computer keyboard or handheld to 
increase/decrease the speed of ongoing animation incrementally.

The animation control panel

Once a point is animated, a floating control panel displays on the page. 
You can move this panel by dragging it to a new location.

When animation is active, the panel contains a Reset  and a 

Pause  button. When either button is pressed and animation is reset 

or paused, the Pause button changes to a Start  button. These 
controls affect all animated points on a page.

Panel when animation is active

Panel with animation paused/reset
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Changing the animation of a point in motion
To change the speed of a point’s movement or the direction of 
animation:

1. Reset or pause the animation. 

a) Select the Attributes tool. 

b) Select the point you want to change. 

c) When the list of attributes displays, select an animation attribute.

2. To change the speed, type a new number. 

3. To change the direction of animation, press 78.

4. Press the Start  button. 

The point moves at the new speed and/or in the new direction you 
selected.

Pausing and resuming animation

1. To pause the animation on a page, click the Pause  button. 

2. To restart animation, click the Start  button.

Resetting animation

Selecting the Reset button  not only pauses animation but also 
returns the animated point to its initial coordinate position on the object 
when animation was first started. If multiple points are animated on the 
page, all are returned to their original locations when you select Reset.

Stopping animation
To stop the animation of an object:

1. Select the Pause  or Reset  button on the control bar. 

2. Display the Animation attribute for the point. 

3. Change the speed to 0 (zero). 

4. Click an empty area of the screen to apply the change, or press ·. 

5. Select Start to resume animation if other animated points were 
temporarily stopped. 

If no other animated points are on the page, the animation control 
box does not reappear when the velocity is set to 0.

Note: If you have multiple points in motion on one page and want to 
permanently stop the animation of all objects, when motion is 
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paused or stopped, display the list of attributes for each point and 
change the velocity to 0. 

Graphing 3D functions
The 3D Graphing view lets you enter functions of the form z(x,y) and 
view and explore them in three-dimensional space.

While you are in the 3D Graphing view, you can define, rotate, resize, 
and trace 3D graphs. You can set the colors and other visual attributes of 
a selected graph, and you can customize the 3D viewing environment.

À 3D Graphing menu. This menu is specific to 3D Graphing and is 
accessible from the Graphs & Geometry View menu.

Á Icon of the current 3D tool (Rotation tool in this example). Press d 
to close the tool and return to the Pointer tool.

Â Sample 3D graph

Ã Entry line with expression that defines the graph

Ä Legend displaying orientation of the axes

Defining a 3D graph
Each 3D graphing page can show multiple graphs.

1. From the View menu, select 3D Graphing.

2. If the entry line is hidden, click the Show Entry Line button .

3. Type the expression that defines the graph.

4. Press · to draw the graph.

Displaying the context menu of a 3D graph
Some 3D graphing features are accessible only through context menus.

À

Á

Â

Ã

Ä
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1. If necessary, press d to return to the Pointer tool.

2. Point to the graph to select it.

The selected graph displays in gray.

3. Use the applicable method to display the context menu.

– Handheld: Press / b. 

– Windows®: Right-click.

– Macintosh®: Hold “ and click.

Editing a 3D graph
1. Display the graph’s context menu, and then select Edit Relation.

- or -

Click the Show Entry Line button , and then use the up/down 
arrows to display the expression.

2. Modify the existing expression, or type a new expression in the entry 
line.

3. Press ·.

Setting the appearance of a 3D graph

To set wire and surface color:
1. Display the graph’s context menu, select Color, and then select 

Line Color or Fill Color.

2. Click a color swatch to apply it.

To set custom plot colors:
Custom plot colors can make it easier to see the shape characteristics of 
the graph. You can assign different colors to its top and bottom surfaces 
or choose to have the graph colored automatically, based on height or 
steepness. You can also set the wire color.

1. Display the graph’s context menu, and then select Color > 
Custom Plot Color.
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2. Select one of the three Surface color options: Top/bottom color, Vary 
color by height, or Vary color by steepness. 

– If you choose Top/bottom color, click the color swatches to select 
colors for the top and bottom surfaces.

– If you choose to vary color by height or steepness, colors are 
determined automatically.

3. To set the Wire color, click the color swatch and select a color.

To set other attributes of a graph:
1. Display the graph’s context menu, and then select Attributes. You 

can set the following attributes for the selected graph.

– format: surface+wire, surface only, or wire only

– x resolution (enter a value in range 2-200*, default=21)

– y resolution (enter a value in range 2-200*, default=21)

– transparency (enter a value in range 0-100, default=30)

– shading (controls highlights, enter a value in range 0-100, 
default=50)

* Handhelds are limited to a maximum display resolution of 21, 
regardless of the value entered.

2. Set the attributes as you like. If necessary, refer to “Changing an 
attribute of an object” in this chapter.

3. Press · to accept the changes.
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Showing and hiding 3D graphs

To hide a 3D graph:
Display the graph’s context menu, and then select Hide.

To show a hidden 3D graph:
1. From the Actions menu, select Hide/Show.

The Hide/Show icon  appears and all hidden graphs show in gray.

2. Click a graph to change its hide/show state.

3. To return to the Pointer tool, press d.

Customizing the 3D viewing environment

To set the background color:
Display the context menu for the work area, and then select 
Background Color.

To show or hide specific view elements:
From the View menu, select the item to show or hide. You can choose 
items such as the 3D box, axes, box end values, and legend. 

To set the visual attributes of the box and axes:
1. Display the context menu for the box, and then select Attributes. You 

can set the following attributes.

– show or hide tic labels

– show or hide end values

– show or hide arrows on axes

– show 3D or 2D arrow heads

2. Set the attributes as you like. If necessary, refer to “Changing an 
attribute of an object” in this chapter.

3. Press · to accept the changes.

To shrink or magnify the 3D view:
From the Range/Zoom menu, select Shrink Box or Magnify Box.

To change the Range settings
On the Range/Zoom menu, select Range Settings. You can set the 
following parameters.

– XMin (default=-5)
XMax (default=5)
XScale (default=Auto) You can enter a numeric value.
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– YMin (default=-5)
YMax (default=5)
YScale (default=Auto) You can enter a numeric value.

– ZMin (default=-5)
ZMax (default=5)
ZScale (default=Auto) You can enter a numeric value.

– eye q¡ (default=35) 
eye f¡ (default=160)
eye distance (default=11)

Rotating the 3D view

To rotate manually:
1. Press R to activate the Rotation tool (required only for the TI-Inspire™ 

handheld with Clickpad).

2. Press any of the four arrow keys to rotate the graph.

To rotate automatically:
Auto rotation is equivalent to holding down the right arrow key.

1. From the Actions menu, select Auto Rotation.

The Auto Rotation icon  appears, and the graph rotates.

2. (Optional) Use the up and down arrow keys to explore the rotating 
graph.

3. To stop the rotation and return to the Pointer tool, press d.

To view from specific orientations:

1. If necessary, press d to return to the Pointer tool.

2. Use letter keys to select the orientation:

– Press Z, Y, or X to view along the z, y, or x axis.

– Press letter O to view from the default orientation.

Tracing in the 3D view

To start tracing:
1. From the Trace menu, select z Trace.

The z Trace icon  and the trace plane appear, along with a text line 
showing the current "z=" trace value.
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2. To move the trace, hold down Shift and press the up or down arrow 
key.

The "z=" text is updated as you move.

3. (Optional) Use the four arrow keys to rotate the view and see how 
the trace plane and the graph intersect.

4. To stop tracing and return to the Pointer tool, press d.

To change the trace settings:
1. From the Trace menu, select Trace Setup.

2. Enter or select the settings, and click OK to apply them.

3. If you are not already tracing, your new settings take effect the next 
time you trace.

Animating a 3D graph with a slider
1. Insert a new problem and select the 3D Graphing view.

2. From the Actions menu, select Insert Slider, click to position it, and 
type time as the variable name.
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3. Display the slider’s context menu, select Settings, and enter the 
following values.

Value: 3.8
Minimum: 3.2
Maximum: 4.4
Step Size: 0.1

4. In the entry line, define the function shown here:

5. Drag the slider thumb to see the effect of varying time.

6. Add visual interest. For example, try:

– Rotating the graph.

– Hiding the box, axes, and legend.

– Setting the graph’s format attribute to show the surface only.

– Changing the graph’s transparency and shading attributes.

– Changing the background color and graph fill color.
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7. To animate the graph, display the slider’s context menu, and select 
Animate. (To stop, select Stop Animate from the context menu.)

You can combine manual or auto rotation with the slider animation. 
Experiment with the x and y resolution to balance curve definition 
against animation smoothness.
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Using Lists & Spreadsheet

Getting started with tabular data
The Lists & Spreadsheet application gives you a place to work with 
tabular data. 

• Store numeric data, text, or math expressions.

• Define a table cell in terms of the contents of other cells.

• Define an entire column based on the contents of another column.

• Share columns of data as list variables with other TI-Nspire™ math 
and science learning technology applications. Also share individual 
cells as variables.

• Work with variables created in the Graphs & Geometry and Calculator 
applications.

• Collect tables of real-world data from sensors.

• Generate columns of data based sequences that you define.

• Plot table data using the Data & Statistics application.

• Generate a table of values for a function.

• Copy and paste table data from the Lists & Spreadsheet application to 
other computer applications, such as TI Connect™ software and 
Excel® spreadsheet software.

• Perform statistical analysis on lists of data.
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The menu and work area

À Lists & Spreadsheet menus (available when a Lists & Spreadsheet work 
area is active). 

Á Sample Lists & Spreadsheet work area

Â Click horizontal and vertical scroll bars to view more rows and 
columns

Ã Lists & Spreadsheet data plotted in the Data & Statistics application

Ä Entry line

Lists & Spreadsheet menu

Actions

Move Column Lets you reposition the current column.

Resize For a selected column, lets you set the 
width to maximum, minimum, or a 
custom width.

For a selected row, lets you set a custom 
row height.

Select Selects an entire row or column, or helps 
you insert a range of cells into a cell 
formula.

À Á ÃÂ

Ä
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Go To Jumps to the specified cell, such as d16 
or g20.

Recalculate Recalculates results of all cell formulas 
and generates new results for random 
functions such as rand(), randInt(), and 
randSamp().

Sort Lets you sort the selected columns of the 
spreadsheet based on the contents of a 
single column.

Insert

Insert Cell Inserts a cell.

Insert Row Inserts a row above the current row.

Insert Column Inserts a column before the current 
column.

Data

Generate Sequence Displays a dialog box for creating a 
sequence.

Data Capture Allows manual or automatic capture of 
variable data from the Graphs & 
Geometry, Calculator, or Data & 
Statistics applications, or within the 
Lists & Spreadsheet application. Press 
/ ^ (period ).

Macintosh®: “+ . (period).

Fill Lets you repeat the contents of a 
selected cell or range of cells 
horizontally or vertically.

Actions



544 Using Lists & Spreadsheet

Clear Data Removes data from the selected 
column or columns. Does not clear list 
names or column formulas. After the 
data has been cleared, column 
formulas are recalculated in the 
selected columns.

Summary Plot Uses the Data & Statistics application 
to graph summary data from one 
X or Y List and one Summary List. 
Categorical data is plotted as a bar 
chart, and numeric data is plotted as a 
histogram.

Quick Graph Uses the Data & Statistics application 
to graph one or two selected columns 
of data as a dot plot, dot chart, or 
scatter plot.

Statistics

Stat Calculations Lets you select from several statistics 
calculations, such as one-variable 
analysis, two-variable analysis, and 
regressions.

Distributions Lets you calculate and plot several 
distributions, such as Normal Pdf, 
Binomial Cdf, and Inverse F.

Confidence Intervals Lets you calculate several confidence 
intervals, such as t interval and 
z interval.

Stat Tests Lets you perform and plot several 
hypothesis tests such as t test, z test, 
and ANOVA.

Table

Switch to Table/Switch to 
Lists & Spreadsheet

Toggles the table view when you press 
/ T. (Macintosh®: “+T.)

Data
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The Parts of a Spreadsheet
A spreadsheet includes a column letter at the top of each column and a 
row number on the left of each row. The top two rows and the row 
numbers remain in place as you scroll. You can name a column of data to 
make it available as a list variable in TI-Nspire™ applications. 

À Column reference letter

Á Column name cell for defining a column as a list variable

Â Column formula cell for generating a column of data

Ã Row reference number

Ä Entry line (includes cell reference for current cell)

Å Cells - Any empty (void) element in a list displays as an underscore 
(“_”). Any value that cannot fit in a cell’s width is truncated. Hover 
over the cell to display the complete value.

Æ Naming zone (first tab stop - column names and formulas)

Ç Data zone (second tab stop - body cells)

Delete Column Removes the current column.

Choose Lets you select an available function 
for displaying in the current column.

Edit Expression Lets you change the expression 
associated with the table of values 
without leaving the table.

Edit Table Settings Lets you change the viewing 
parameters for the table.

Table

Ä

Ã

Å

Æ

Ç

À Á Â



546 Using Lists & Spreadsheet

Navigating in a spreadsheet
You can select any cell to view or edit its contents. When a spreadsheet is 
larger than the Lists & Spreadsheet work area, you can move to different 
parts of the spreadsheet by using the e key and by pressing shortcut 
keys.

• Press e to move between the body of the spreadsheet (data zone) 
and the column names and formulas (naming zone).

• Press ¡, ¢, £, and ¤ to move through the spreadsheet one cell at a 
time (move between cells within a zone). The arrow keys move the 
cursor from cell to cell and scroll as necessary to keep the selected cell 
in view. 

• Move across several cells at a time by pressing Page up, Page Dn, 
Home, and End.

Handheld: Press / 9 (Page up), / 3 (Page Dn), / 7 

(Home), and / 1 (End) keys.

• Use the Go To command on the Actions menu to select a specific cell. 
Type the cell’s column letter and row number (such as G16).

• Press · to put the selected cell in Edit mode.

• Drag the scroll bar to move vertically without changing the cell or 
block of cells selected.

Creating and sharing spreadsheet data as lists
You can define a column as a named list of elements of the same type of 
data. After defining a list, you can link to it from the Graphs & Geometry, 
Calculator, or Data & Statistics applications, and from other instances of 
the Lists & Spreadsheet application within the current problem.

Note: Lists & Spreadsheet can display a maximum of 2500 elements in a 
list.

Sharing a spreadsheet column as a list variable
You share a column of data by naming it as a list variable. 

Note: Avoid defining variables that use the same names as those used 
for statistical analysis. In some cases, an error condition could occur.

Variable names used for statistical analysis are listed in the TI-Nspire™ 
Reference Guide, under the stat.results entry.

1. Move to the column’s name cell (the top cell of the column) by 
clicking the cell or pressing £ as necessary.
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2. Type a name for the list variable, and press ·.

The column is now available as a list variable to other TI-Nspire™ 
applications.

3. Create elements in the list the same as you would create data in 
spreadsheet cells. For example, you can type the data into each cell or 
use a formula to generate a column of data.

Notes:

• If a variable with the name you specified already exists in the current 
problem, Lists & Spreadsheet displays an error message.

• When you select the column formula cell of a list, it displays the list 
name in an expression similar to width:=.

• Lists can contain empty elements (denoted by “_”) .

• You can refer to a specific element in a named list from the Calculator 
application. Use the list name and the element’s position within the 
list. In a list named Heights, for example, refer to the first element as 
Heights[1]. The expression Heights[2] refers to the second element, 
and so on.

Linking to an existing list variable
Linking a column to an existing list variable lets you easily view and edit 
the values in the list. The list can be any shared list in the current problem 
and can be defined in Graphs & Geometry, Calculator, or any instance of 
Lists & Spreadsheet.

After you link a column to a list, Lists & Spreadsheet automatically shows 
any changes that you make to the list with other TI-Nspire™ applications.

1. Click the column formula cell (the second cell from the top) of the 
column that you want to link to the variable.

2. Type the name of the list variable you want to link to.
- or -

Click  on the toolbar (press h on the handheld), click Link To, 
and select the variable you want to link to.

3. Press ·.

The column shows the list elements.

Notes: 

• You cannot link to the same variable multiple times on the same 
page.



548 Using Lists & Spreadsheet

• Use caution if you link to a system variable. Doing so could prevent 
the variable from being updated by the system. System variables 
include ans and statistics results (such as stat.results, stat.RegEqn, and 
stat.Resid).

Inserting an element in a list
When you insert an element in a list, the remaining elements shift 
downward to create space. No other columns are affected.

From the Insert menu, select Insert Cell.

Deleting an element from a list
When you delete an element, the remaining list elements shift upward to 
close the gap. The upward shift affects only the selected column.

1. Select the cell of the element to delete.

2. Display the context menu for the cell, and select Delete Cell.

Note: If you press . or Backspace to clear the contents of the cell 
instead of deleting the list element, the element is assigned a value of 
0 (zero). The remaining list elements do not shift.

Creating spreadsheet data
You can enter numeric values, text, or formulas into body cells. Column 
formula cells can contain formulas only. (Column formulas are discussed 
under Generating columns of data.)
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Data examples

Typing a math expression, text, or spreadsheet formula
1. Double-click the cell to select it and put it in edit mode.

Note: If the cell is already selected, you can press · or click the 
entry line.

2. Type the expression, text, or formula. Be sure to enclose text entries in 
quotes and start formula entries with an “=” symbol.

As you enter the data, it appears in the cell and on the entry line 
simultaneously.

3. Press · to complete the entry and move down to the next cell.
– or –
Press e to complete the entry and move right to the next cell.

The Lists & Spreadsheet application automatically recalculates any 
cells that are dependent on the cell you entered. If you have shared 
the cell, and other TI-Nspire™ applications are linked to the cell, the 
other applications are also updated.

Note: Empty cells in a spreadsheet display as a void represented by an 
underscore (_). The underscore is automatically added to empty cells 
when a list is named or when an empty cell is referenced in a formula. 
When you plan to perform calculations on a range of cells, be sure to 
notice the location of void cells. Cells without a value can affect 
calculations. For example, if you include a void cell in the range for a 
sum such as “=b2+c2,” the result of the calculation is void (_).

Entry Remarks

1.234 Simple numeric entry

“Green” Text - Enclose categorical data (such as the names of 
colors used in a study) within quotes to distinguish 
them from variable names. On the Handheld, press 
/ r to enter quoted data.

=a3*length Formula - Consists of an “=” symbol followed by an 
expression.

You can type the expression or use the Catalog and 
expression templates to build it. For details, see the 
Calculator section.

To ensure a decimal result instead of a fraction, 
type one of the integers in the expression as a 
decimal. For example, type 1.0 instead of 1. 



550 Using Lists & Spreadsheet

Inserting a cell range into a formula
The Select Range feature lets you insert a cell range (such as a1:b3) into a 
formula by selecting the range instead of typing cell addresses into an 
argument.

Suppose you want to calculate the mean of a range of cells.

1. Type “=mean(“ in the cell that will contain the result.

2. From the Actions menu, choose Select > Select Range.

A dotted selection rectangle appears around the cell that contains 
the formula. 

3. Select the range of values for which you want to calculate the mean. 
Move to the first cell in the range, then hold g while pressing the 
arrow keys. 

The dotted selection rectangle moves to enclose the cells you specify 
for the range. The formula is updated as you select.

4. Press · to complete the formula, evaluate the formula, and 
display the result.
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Working with cells

Working with color
The Lists & Spreadsheet application displays black text and cells with a 
white background by default. You can change the color of cells and text 
to emphasize or distinguish data. The colors and the order in which color 
is assigned is based on the TI-Nspire™ color palette. See Changing the 
color of cells and Changing the color of text for more details. 

Color changes made in the software display in shades of gray when you 
work on documents on the TI-Nspire™ handheld. Color is preserved 
when you move documents back to the software. 

Changing the fill color of cells
1. Select the cells to fill with color. You can choose one or more cells in 

any adjacent cells, columns, or rows.

2. Access the context menu and choose Color > Fill Color.

3. Select the color to apply to the cells. The color of the selected cells 
changes.

Note: If you combine color text and color cells, choose colors carefully to 
ensure visibility as you work with documents in the software and on the 
handheld.

Changing the color of text
1. Select the cells that contain the text to change. You can choose one or 

more cells in any adjacent cells, columns, or rows.

2. Access the context menu and choose Color > Text Color.

3. Select the color to apply to the text. Empty cells in the selection area 
will show the color change when text is added.

Understanding cell references in formulas
Use a cell reference to use data from a cell or range of cells in a formula. 
The calculation results update automatically when values in cells change. 

Relative references include only the cell’s column letter and row number 
(for example, E7). A relative reference describes where a cell is in relation 
to other cells of the spreadsheet. The Lists & Spreadsheet application 
keeps track of relative cell references and adjusts the reference 
automatically when surrounding cells shift (because of actions you 
perform, such as column deletions or cell insertions). 

Follow these guidelines to specify cell references:

• Include a column letter and row number in a relative reference. 
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• Include the $ symbol before both the column letter and the row 
number to specify an absolute reference. 

• Include a colon (:) between a two cell references to specify a range of 
cells.

Absolute references include the $ symbol before the column letter and 
before the row number (for example, $B$16). Absolute references always 
refer to the cell in a specific position in the spreadsheet. The application 
does not automatically adjust the cell reference when cell positions 
change. 

Typing a cell reference in a formula
1. Double-click the cell and type the formula. See the Calculator section 

for details about inserting symbols and operators from the Catalog.

2. Move to the appropriate position in the formula and type the cell 
reference. Use the format for a relative reference (B3), absolute 
reference ($B$2), or range of cells (A1:A4). 

Note: You can select Recalculate from the Actions menu to update 
all references and formula results in a spreadsheet.

Deleting the contents of cells
1. Click a cell to select it, or use the arrow keys to move to the cell. 

Note: If you are deleting a range of cells, select a cell at one end or 
corner of the range and then use g with the arrow keys to select 
the remaining cells in the range.

2. Press ..

Note: Any cell that uses a formula with an absolute reference to 
deleted data will show an error. A cell that uses a formula with a 
relative reference to deleted data is updated to use the data currently 
in the referenced position.

Copying cells
When you copy cells, any formulas in the original cells are copied to the 
destination cells.

1. Select the cell to copy by clicking it, or use the arrow keys to move to 
the cell. 

Note: If you are copying a range of cells, select a cell at one end or 
corner of the range and then use g with the arrow keys to select 
the remaining cells in the range.

2. Copy the selected cells by pressing / C (Macintosh®: “+C).
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3. Select the cell where you want to duplicate the copied cell. If you are 
copying a block of data, select the cell that will become the upper left 
corner of the copied block.

4. Paste the selected cells by pressing / V (Macintosh®: “+V).

Important: Paste copied data into a cell that is in the same mode as 
the cell from which the data was originally copied. Otherwise, a 
formula could paste as a string enclosed in quotes instead of a 
formula.

Filling adjacent cells
You can repeat a cell’s formula or value throughout adjacent cells within 
the row or column. You can also repeat a range of cells horizontally or 
vertically. If you fill from a range that contains a simple sequence (such as 
2, 4, 6), the sequence continues in the filled cells.

1. Select the cell that contains the value or formula to repeat. 

Note: If you are repeating a range of cells, drag to select the range, 
or select a cell at one end of the range and then use g with the 
arrow keys to select the remaining cells.

2. From the Data menu, select Fill.

3. Use the arrow keys or drag to select the range that will hold the 
repetitions.

4. Press ·.

The value, formula, or pattern that you selected for duplication is 
repeated over the selected range.

Sharing a cell value as a variable
You can share the value of a cell with other TI-Nspire™ applications by 
storing it as a variable. When you define or refer to a shared cell or 
variable in Lists & Spreadsheet, the name is preceded with an 
apostrophe (‘).

1. Select the cell that you want to share.

2. Click  on the toolbar, and click Store Var to store the cell’s value.

Handheld: Press / h (or press h and select Store Var).

A formula is inserted into the cell with var as a placeholder for a 
variable name.

3. Type over the letters “var” with a name for the variable, and press 
·. Use a variable name that does not exist in the current problem.
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The value is shown in bold to indicate that it is now available as a 
variable to other  applications.

Linking a cell to a variable
When you link a cell to a variable, Lists & Spreadsheet keeps the cell 
value updated to reflect the current value of the variable. The variable 
can be any variable in the current problem and can be defined in 
Graphs & Geometry, Calculator, Data & Statistics, or any instance of 
Lists & Spreadsheet.

1. Select the cell that you want to link to a variable.

2. Click  on the toolbar, and click Link to.

Handheld: Press / h (or press h and select Link to).

The VarLink menu displays.

3. Under Link To, press £, and ¤ to scroll to the name of the variable.

4. Press ·.

The cell shows the value of the variable.

Note: Use caution if you link to a system variable. Linking could prevent 
the variable from being updated by the system. System variables include 
statistics results (such as Stat.RegEqn, Stat.dfError, and Stat.Resid) and 
finance-solver variables (such as tvm.n, tvm.pmt, and tvm.fv).

Working with rows and columns of data

Selecting a row or column
To select a row, move to the top of the column and click the column 
reference letter. To select a row, move to the leftmost cell of the row 
and click the row reference number. Press d to cancel the selection.

Handheld: Hold down £ to move past the top cell, or hold down ¡ 
to move past the leftmost cell.

To extend a selection to adjacent rows or columns, hold down g 

and press ¡, ¢, £, or ¤.

Resizing a row or column
1. Select the row or column that you want to resize.

2. From the Actions menu, select Resize then select an option.

3. Choose a resizing option for a column or row.
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– For a column, choose Resize Column Width, Maximize Column 
Width, or Minimize Column Width.

– For a row, you can choose Resize Row Height.

The tools that minimize and maximize the column width work 
automatically. You must manually adjust the size to use the Resize 
Column Width and Resize Row Height tools.

4. To resize manually, use ¡ and ¢ to resize the column, or use £ and ¤ 

to resize the row, and then press ·.

Inserting an empty row or column
1. Select a column or row where you want to insert the new data.

2. From the Insert menu, select either Row or Column.

– If you are inserting a row, the remaining rows shift down to create 
space for the new row.

– If you are inserting a column, the remaining columns shift right to 
create space.

Note: If other cells contain formulas with relative references to a 
displaced row or column, those references adjust accordingly.

Deleting entire rows or columns
You can delete a row, column, group of rows, or group of columns. When 
you delete a row or column, the remaining rows or columns move up or 
left to fill the gap.

1. Select the column or row that you want to delete.

2. (Optional) To select adjacent rows or columns to delete, hold down 
g and press ¡, ¢, £, or ¤.

3. Press ..

The selected rows or columns are deleted.

Note: If other cells contain formulas that refer to the deleted row or 
column, those cells show an error. Relative references to cells whose 
positions have changed because of a deletion adjust accordingly.

Copying rows or columns
1. Select the column or row that you want to copy. 

You can click the column letter to copy a column, or click the row 
number to copy a row.
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2. (Optional) To select adjacent rows or columns to copy, hold down 
g and press ¡, ¢, £, or ¤.

3. Copy the column or row by pressing / C (Macintosh®: “+C).

4. Move to any cell in the row or column where you want to place the 
copied items.

5. Paste the selected column or row by pressing / V 
(Macintosh®: “+V.).

The copied row or column is pasted in place, replacing the previous 
contents.

Note: If you copy a named column, it is pasted with the name 
removed to prevent a variable conflict.

Moving a column
1. Select the column that you want to move.

2. From the Actions menu, select Move Column. 

An insertion bar appears. 

3. Press ¡ or ¢ to place the insertion bar at the column’s new position, 

and then press ·.

Note: Relative references to any cell in a position is affected by the 
move adjust accordingly.

Clearing column data
The Clear Data command lets you remove the data from selected 
columns. Clear Data does not delete the column, and it does not clear a 
column’s name or formula.

After clearing the data, Lists & Spreadsheet recalculates column formulas 
for the selected columns. This makes Clear Data useful for capturing a 
fresh set of data from another application or selectively generating a 
fresh column of random numbers.

1. Select the column or columns that you want to clear.

2. From the Data menu, select Clear Data.

Note: If a recalculated formula produces the same data as before, it 
may appear that the Clear Data command has failed.
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Sorting data
You can sort a selected area of the spreadsheet in ascending or 
descending order. You select which column in the selected area will be 
used as the key for the sort. When the sort moves data up or down in the 
key column, the corresponding data in the other selected columns is also 
moved up or down. This preserves the integrity of each row.

Note: Sorting is based on numeric values. If you select a key column that 
contains text, you could get unexpected results.

1. Select the range of cells. 

2. From the Actions menu, select Sort.

The Sort dialog box displays.

3. Select the column letter to use for ordering.

4. Select Descending or Ascending as the sort method, and then select 
OK.

Note: Sorting a column that is defined by a formula will remove the 
fomula, because it may not be valid after the sort.

Generating columns of data
You can create a column of values based on the contents of another 
column. You can also create a column based on any of several types of 
sequential data.
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Entering a formula in a column’s formula cell tells the Lists & Spreadsheet 
application that you want to apply the formula to all cells in the column, 
not just to a single cell.

À Column formula based on a variable

Á Column formula based on another column

Â Column formula that generates a sequence

Notes:

• If you generate data in a column that already contains one or more 
cell values, Lists & Spreadsheet asks for confirmation before replacing 
the existing values. Proceeding removes all of the existing values in 
the column.

• If you edit a cell manually in a column of generated data, 
Lists & Spreadsheet asks for confirmation before replacing the 
generated data. Proceeding removes the generated data for the 
entire column.

Creating column values based on another column
1. Click the column formula cell (the second cell from the top) of the 

column where you want to use a formula.

Lists & Spreadsheet inserts the leading equal sign (=) for the formula. 
If the column is a named list, Lists & Spreadsheet inserts listname:= 
followed by the cursor.

2. Type the expression for the formula after the = and press ·. Use 
brackets ([]) after any column letter you include in the formula. For 
example, type =a[]^2 to create a column of values in which each cell 
is the square of the corresponding cell of column A.

À Á Â
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Lists & Spreadsheet shows the formula in the formula cell and fills the 
column with the results.

Generating a column of random numbers
1. Click the column formula cell (the second cell from the top) of the 

column.

Lists & Spreadsheet inserts the leading equal sign (=) for the formula. 
If the column is a named list, Lists & Spreadsheet inserts listname:= 
followed by the cursor.

2. Type the expression for generating the random numbers. You can use 
the Catalog to insert an expression instead of typing characters.

RandInt(1,6,20)

This example places 20 random integers in the column.

3. Press · to generate the numbers.

4. To generate (Recalculate) a new set of random numbers, press / R 
(Macintosh®: “+R).

Generating a numerical sequence
1. Select any cell in the column in which you want to generate the 

sequence.

2. From the Data menu, select Generate Sequence.

The Sequence dialog displays.
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3. Type the Formula that will be applied to the column values. 

4. Type any starting numbers required by the sequence in the Initial 
Terms field and separate them with commas. 

5. Type a starting value for the independent variable (n0).

6. Type a maximum number of values to be generated (nMax).

7. Type the step value (nStep).

8. (Optional) Type a maximum value for the sequence in the Ceiling 
Value field.

9. Select OK.

Lists & Spreadsheet shows the formula in the formula cell and fills the 
column with the results.
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Graphing spreadsheet data
You can graph the data in a spreadsheet using Quick Graph or Summary 
Plot. Lists & Spreadsheet cells that contain no data are not represented 
by data points on graphs.

Using Quick Graph
You can easily create a dot plot of the data in one column or a scatter 
plot of two adjacent columns by using the Quick Graph feature. This 
feature displays the graphed data using the Data & Statistics application.

To create a scatter plot:

1. Name both of the columns to declare them as lists.

2. Select both columns.

3. From the Data menu, select Quick Graph.

A Data & Statistics application is added to the page with the plotted 
data. The leftmost of the two lists is plotted on the x axis, and the 
other list is plotted on the y axis.
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4. (Optional) Use the Data & Statistics features to analyze or visually 
enhance the graph.

Note: Refer to Using Data and Statistics for information about 
analyzing and exploring graphs.

Creating a summary plot from a summary table
In this example, you create a summary table from raw data and then use 
the table to generate a summary plot. For an example of how to create a 
similar chart directly from the raw data, refer to the “Using 
Data & Statistics” chapter.

A summary table contains an X (or Y) List and a Summary List. 

raw data summary table for eye color based on 
raw data
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• The X (or Y) List contains numeric or string values (such as 1999 or 
“color”). Numeric values result in a histogram. String values identify 
the categories for a bar chart.

• The Summary List contains numeric values (such as count, frequency, 
or probability) for each element in the other list.

To create a summary plot:
Note: For situations in which you already have a summary table, you can 
skip the first two steps. 

1. Create a list that holds the category identifiers. For this example, 
name the list “color” and enter strings for eye color. Enclose category 
names in quotes to prevent them from being interpreted as variables.

2. Create the summary list. For this example, name the list “counts” and 
enter the total count for each of the eye colors.

3. Select either list by clicking the top cell of the column and pressing £. 

4. From the Data menu, select Summary Plot.

The Summary Plot dialog displays.
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5. If necessary, use e and the arrow keys to select the correct lists for 
X List and Summary List.

6. In the Display On field, select how to display the summary plot in the 
Data & Statistics application.

• Select Split Page to place the chart on half of the current page. 

• Select New Page to add the chart on a new page.

The summary plot displays with the list names along the axes and a 
summary plot symbol in the lower left corner of the chart window.

Note: In this example, the X List contains string data, so the summary 
plot displays as a bar chart. The category strings from the list display 
beneath the bars.

Exchanging data with other computer software
You can use the TI-Nspire™ desktop software to copy table data to and 
from software outside the TI-Nspire™ applications, such as TI DataEditor 
(in the TI Connect™ software) and Excel® spreadsheet software.

For example, you can copy:

• The values of individual cells, a range of cells, or an entire list from 
TI DataEditor.
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• The values (not the underlying formulas) of individual cells, a range 
of cells, or an entire column from an Excel® spreadsheet.

• A number from TI DataEditor.

• The value of a matrix from TI DataEditor.

Example - copying data from TI DataEditor
1. Open the TI Connect™ software.

2. Display the TI DataEditor.

3. If necessary, open the file containing the number, list, or matrix that 
you want to copy.

4. Drag to select the values that you want to copy. To copy an entire list, 
click the top cell in the list.

5. Click Edit > Copy.

6. In Lists & Spreadsheet, click the cell where you want the data to be 
pasted.

If you have copied a range of cells, they will be pasted so that the 
upper-left corner of the range is positioned at the selected cell. Any 
data in those cells will be overwritten.

7. Click Edit > Paste.
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Copying cells from an Excel® spreadsheet
You can copy up to 26 columns and 2500 rows from an Excel® 
spreadsheet to a Lists & Spreadsheet application.

1. Drag to select the values that you want to copy from the Excel® 
spreadsheet. To copy an entire column, click the column identifier at 
the top of the column.

Note: If you select non-contiguous columns in the Excel® 
spreadsheet, they will be pasted as contiguous columns in Lists & 
Spreadsheet.

2. Press / C to copy cells.

3. In Lists & Spreadsheet, click the cells where you want the data to be 
pasted.

If you are copying a range of cells, they will be pasted so that the 
upper-left corner of the range is positioned at the selected cell. Any 
data in those cells in will be overwritten.

4. Press / V to paste the copied cells into Lists & Spreadsheet.

Note: Categorical data must be enclosed in quotes (“ “) after the 
data is pasted.

Capturing data from Graphs & Geometry
You can use Lists & Spreadsheet application to capture information about 
objects in the Graphs & Geometry application. For example, you could 
track changes in the area of a triangle as you change the length of a side 
in the Graphs & Geometry application.

Captured values will replace values in the column. If you prefer, you can 
remove all data from a column before starting a new capture by 
selecting Clear Data on the Data menu.

You can select manual or automatic capture as the method of capturing 
data.
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• With manual capture, you trigger the capture of each data element 
by pressing a key combination. Press / ^ to capture on a 

Windows® operating system, or press “ ^ to capture on a 
Macintosh® operating system.

• With automatic capture, the capture of each data value is triggered 
automatically when you move or animate the target in Graphs & 
Geometry.

Capturing data manually
1. Make sure the data value that you want to capture is linked to a 

variable name.

2. Select the column formula cell (the second cell from the top) of the 
column in which you want to capture the values.

Note: Captured values will replace values in the column.

3. From the Data menu, select Data Capture, and then select Manual 
Data Capture. 

A capture expression is inserted into the colum formula cell with var 
as a placeholder for the name of the variable you are capturing.

4. Replace the letters “var” with the name of the variable to capture 
from Graphs & Geometry. For example, type area.

The formula cell now contains an expression similar to 
=capture(area,0).

Note: The argument “0” tells Lists & Spreadsheet that you want to 
trigger each capture manually.

5. Press ·.



568 Using Lists & Spreadsheet

6. From the Graphs & Geometry application, change the object with a 
measured value stored as the variable (area, in this example) 
referenced in the data capture expression.

7. Each time you are ready to capture the current value of area, press 
the capture keys.

Windows®: Hold down / and press . (the period key).

Macintosh®: Hold down “ and press . (the period key).

Handheld: Press / ^.

The current area value is added to the end of the list as a list element.

Capturing data automatically
When you capture data automatically, you can specify that you want the 
captures to be triggered by:

• Changes in the captured variable only.

• Changes in the captured variable or additional variables.

This lets you set up multiple columns of synchronized captures, such as 
the x and y coordinates of a moving object.

To capture automatically
1. Clear all columns that you will be using for the captured data.

2. Make sure any data values that you want to capture are linked to 
variable names.

3. Select the column formula cell (the second cell from the top) of the 
column in which you want to capture the values.

4. From the Data menu, select Data Capture and then select 
Automated Data Capture.

A capture expression is inserted into the column formula cell with var 
as a placeholder for the name of the variable you are capturing.
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5. Replace the letters “var” with the name of the variable to capture. 
For example, type objpathX. Alternatively, you can select the variable 
name from the Variables menu.

The formula cell now contains an expression similar to 
=capture(objpathX,1).

Note: The argument “1” tells Lists & Spreadsheet that you want the 
captures to be triggered by the variable change.

6. If you want the capture to also be triggered by changes in an 
additional variable or variables, type a comma after the 1, and then 
type the variable name or the name of a list that itemizes the 
variables.

The formula cell wil contain an expression similar to 
=capture(objpathX,1,objpathY).

7. Press · to complete the formula.

8. If you are capturing multiple columns of synchronized data, set up 
the additional columns. For example, you might set up a second 
capture variable using 
=capture(objpathY,1,objpathX).

9. When you are ready to capture the values, begin moving the object 
or start the animation that affects it in Graphs & Geometry.

Each captured value is added to the end of the list.

Using table data for statistical analysis
Tools on the Statistics menu provide access to wizards that help you 
perform statistical analyses on the data in table columns. You specify the 
location of the data, and Lists & Spreadsheet stores the results in two 
columns: one for the result names, and one for the corresponding values.
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Plotting statistical data
Some statistics wizards include a Draw check box. By default, the box is 
not checked. Checking this box creates a Data & Statistics work area on 
the page, displays the calculated results in Lists & Spreadsheet, and draws 
the results of the statistical analysis in the Data & Statistics work area. 

Note: For functions that support the Draw option, the option is available 
only if you enter the function in a column formula cell.

Statistics Input Descriptions
The following table describes the different inputs used in 
Lists & Spreadsheet wizards.

Input Description

m0 Hypothesized value of the population mean that 
you are testing.

s The known population standard deviation; must be 
a real number > 0.

List The name of the list containing the data you are 
testing.

Frequency List The name of the list containing the frequency 
values for the data in List. Default=1. All elements 
must be integers | 0. The frequency values can also 
be typed as a list, in the format {1, 1, 3, 2}.

v, Sx, n Summary statistics (mean, standard deviation, and 
sample size) for the one-sample tests and intervals.

s1 The known population standard deviation from the 
first population for the two-sample tests and 
intervals. Must be a real number > 0.

Draw check box 
(as shown in the 
z Test wizard).
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s2 The known population standard deviation from the 
second population for the two-sample tests and 
intervals. Must be a real number > 0.

List 1, List 2 The names of the lists containing the data you are 
testing for the two-sample tests and intervals. 

Frequency 1 
Frequency 2

The names of the lists containing the frequencies 
for the data in List 1 and List 2 for the two-sample 
tests and intervals. Defaults=1. All elements must be 
integers | 0.

v1, Sx1, n1, v2, 
Sx2, n2

Summary statistics (mean, standard deviation, and 
sample size) for sample one and sample two in two-
sample tests and intervals.

Pooled Specifies whether variances are to be pooled for 
2-Sample t Test and 2-Sample t Interval.

p0 The expected sample proportion for 1-Prop z Test. 
Must be a real number, such that 0 < p0 < 1.

x The count of successes in the sample for the 
1-Prop z Test and 1-Prop z Interval. Must be an 
integer | 0. 

n The count of observations in the sample for the 
1-Prop z Test and 1-Prop z Interval. Must be an 
integer > 0.

x1 The count of successes from sample one for the 
2-Prop z Test and 2-Prop z Interval. Must be an 
integer | 0. 

x2 The count of successes from sample two for the 
2-Prop z Test and 2-Prop z Interval. Must be an 
integer | 0.

n1 The count of observations in sample one for the 
2-Prop z Test and 2-Prop z Interval. Must be an 
integer > 0.

n2 The count of observations in sample two for the 
2-Prop z Test and 2-Prop z Interval. Must be an 
integer > 0.

Input Description
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Statistical calculations

Performing a statistical calculation
You can perform statistical calculations to analyze data. The following 
example fits a y=mx+b linear regression model to two lists.

1. Select the column formula cell (second cell from the top) in column A.

2. From the Statistics menu, select Stat Calculation, and select Linear 
Regression (mx+b) to choose the regression model.

The Linear Regression (mx+b) dialog box opens and displays fields 
for typing or selecting each argument. Because you selected a cell in 
advance, the column for X List is already filled in with the column 
letter of the list with a cell selected.

3. Press e to move to the Y List box and click the drop-down arrow to 
select a named list.

4. To store the regression equation in a specified variable, press e and 
replace Save RegEqn To with the name of the variable.

5. Press e as necessary to move to the 1st Result box and type c[] as 
the column letter for the first result column.

6. Select OK.

Lists & Spreadsheet inserts two columns: one containing the names of 
the results, and one containing the corresponding values.

C-Level The confidence level for the interval instructions. 
Must be | 0 and < 100. If it is | 1, it is assumed to be 
given as a percent and is divided by 100. 
Default=0.95. 

RegEQ The prompt for the name of the function where the 
calculated regression equation is to be stored. 

Input Description
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Note: The results are linked to the source data. For example, if you 
change a value in column A, the regression equation is updated 
automatically.

Storing statistical results
Lists & Spreadsheet stores statistical results using a variable-group name 
with the format stat.nnn, where nnn is the result name (for example, 
stat.RegEqn and stat.Resid). The use of standard names for variables 
makes it easier to identify and use the statistical variables later. If you 
want to use a custom variable group instead of the standard name, you 
can edit the formula in the column formula cell.

You could use the following formula to store the results in the variable 
group MystatsB.

=LinRegMx(a[],b[],1 ): CopyVar Stat., MystatsB.

Later, you could view the results by entering the following expression 
in the Calculator application or in another column of the 
Lists & Spreadsheet application:

MystatsB.results

Supported statistical calculations
The Stat Calculations menu lets you select from the calculations 
described below. For a complete description of inputs and outputs, refer 
to the TI-Nspire™ Reference Guide details for the function name that is 
in parentheses.

One-Variable Statistics (OneVar) analyzes data with one 
measured variable. You can specify an optional frequency list. The 
statistical data returned using this analysis technique are:

• sample mean, 

• sum of the data, 

x

Σx
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• sum of the squared data, 

• sample standard deviation, s

• population standard deviation, s

• sample size, n

• X-min

• first quartile, Q1

• median

• third quartile, Q3

• X-max

• sum of squared deviations, SSx = 

Two-Variable Statistics (TwoVar) analyzes paired data. List 1 is the 
independent variable. List 2 is the dependent variable. You can specify an 
optional frequency list. The statistical data returned using this analysis 
technique are:

For each list:

• sample mean,  or 

• sum of the data,  or 

• sum of the squared data,  or 

• sample standard deviation, sx = sn-1x or sy = sn-1y

• population standard deviation, sx = snx or sy = sny

• X-min or Y-min

• first quartile, Q1X or Q1Y

• median

• third quartile, Q3X or Q3Y

• X-max or Y-max

• sum of squared deviations, Sex =  or Say = 

Additional data:

• sample size for each data set, n

•

Σx2

x

x

Σ x x–( )2

x y

Σx Σy

Σx2 Σy2

Σ x x–( )2 Σ y y–( )2

Σxy
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• correlation coefficient, R.

Linear Regression (mx+b) (LinRegMx) fits the model equation 
y=ax+b to the data using a least-squares fit. It displays values for m (slope) 
and b (y-intercept).

Linear Regression (a+bx) (LinRegBx) fits the model equation 
y=a+bx to the data using a least-squares fit. It displays values for a 

(y-intercept), b (slope), r2, and r.

Median-Median Line (MedMed) fits the model equation y=mx+b 
to the data using the median-median line (resistant line) technique, 
calculating the summary points x1, y1, x2, y2, x3, and y3. 
Median-Median Line displays values for m (slope) and b (y-intercept).

Quadratic Regression (QuadReg) fits the second-degree 

polynomial y=ax2+bx+c to the data. It displays values for a, b, c, and R2. 
For three data points, the equation is a polynomial fit; for four or more, 
it is a polynomial regression. At least three data points are required.

Cubic Regression (CubicReg) fits the third-degree polynomial 

y=ax3+bx2+cx+d to the data. It displays values for a, b, c, d, and R2. For 
four points, the equation is a polynomial fit; for five or more, it is a 
polynomial regression. At least four points are required.

Quartic Regression (QuartReg) fits the fourth-degree polynomial 

y=ax4+bx3+cx2+dx+e to the data. It displays values for a, b, c, d, e, and 

R2. For five points, the equation is a polynomial fit; for six or more, it is a 
polynomial regression. At least five points are required.

Power Regression (PowerReg) fits the model equation y=axb to 
the data using a least-squares fit on transformed values ln(x) and ln(y). It 

displays values for a, b, r2, and r.

Exponential Regression (ExpReg) fits the model equation y=abx to 
the data using a least-squares fit on transformed values x and ln(y). It 

displays values for a, b, r2, and r.

Logarithmic Regression (LogReg) fits the model equation 
y=a+b ln(x) to the data using a least-squares fit on transformed values 

ln(x) and y. It displays values for a, b, r2, and r. 

Sinusoidal Regression (SinReg) fits the model equation 
y=a sin(bx+c)+d to the data using an iterative least-squares fit. It displays 
values for a, b, c, and d. At least four data points are required. At least 
two data points per cycle are required in order to avoid aliased frequency 
estimates.



576 Using Lists & Spreadsheet

Note: The output of SinReg is always in radians, regardless of the 
Radian/Degree mode setting. 

Logistic Regression (d=0) (Logistic) fits the model equation 

y=c/(1+a*eLbx) to the data using an iterative least-squares fit. It displays 
values for a, b, and c.

Logistic Regression (dƒ0) (LogisticD) fits the model equation 

y=c/(1+a*e(Lbx))+d to the data using an iterative least-squares fit. It 
displays values for a, b, c and d.

Multiple Linear Regression (MultReg) calculates multiple linear 
regression of list Y on lists X1, X2, …, X10.

Distributions

Calculating distributions
You can calculate a distribution to fit the Normal Pdf distribution model. 

1. Select the column formula cell (second cell from the top) in column A. 

2. From the Statistics menu, select Distributions, and select Normal 
Pdf to choose the Distribution model. 

The Normal Pdf dialog box opens and displays fields for typing or 
selecting the arguments for the calculation. 

– Press e as necessary to move from field to field and provide 
each argument. You can type values, or select them from the drop 
down list:

– X Value: Click the drop-down arrow to choose any list in the 
problem to provide the x values for the calculation.

– Mean: Type a value for the mean or click the drop-down arrow to 
choose a variable that contains the mean.

– Standard Deviation: Type a value for the standard deviation or 
choose a variable that contains the standard deviation.

3. Click the Draw check box to see the distribution plotted in Data & 
Statistics. 

Note: The Draw option is not available for all distributions.

4. Select OK. 

Lists & Spreadsheet inserts two columns: one containing the names of 
the results, and one containing the corresponding values. The results 
are plotted in Data & Statistics. 
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Note: The results are linked to the source data. For example, you can 
change a value in Column A, and the equation updates automatically. 

Supported Distribution functions
The following distributions are available from the Lists & Spreadsheet 
application. For complete information regarding these functions, refer to 
the TI-Nspire™ Reference Guide details for the function name that is in 
parentheses.

• To return a single distribution result based on a single value, enter the 
function in a single cell.

• To return a list of distribution results based on a list of values, enter 
the function in a column formula cell. In this case, you specify a list 
(column) that contains the values. For each value in the list, the 
distribution returns a corresponding result. 

Note: For distribution functions that support the draw option 

(normPDF, t PDF, c2 Pdf, and F Pdf), the option is available only if you 
enter the distribution function in a formula cell.

Normal Pdf (normPdf) computes the probability density function 
(pdf) for the normal distribution at a specified x value. The defaults are 
mean m=0 and standard deviation s=1. The probability density function 
(pdf) is:

This distribution is used to determine the probability of the occurrence of 
a certain value in a normal distribution. The draw option is available 
when Normal PDF is invoked from a formula cell.

f x( ) 1
2πσ

--------------e
x μ–( )2

2σ2
-------------------–

–

σ 0>,=
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When you access distributions from the formula cell, you must select a 
valid list from the pull-down to avoid unexpected results. If accessed 
from a cell, you must specify a number for the x-value. The distribution 
returns the probability that the value you specify will occur.

Normal Cdf (normCdf) computes the normal distribution probability 
between Lower Bound and Upper Bound for the specified mean, m 
(default=0) and the standard deviation, s (default=1). You can click the 
Draw (Shade area) check box to shade the area between the lower and 
upper bounds. Changes to the initial Lower Bound and Upper Bound 
automatically update the distribution.

This distribution is useful in determining the probability of an occurrence 
of any value between the lower and upper bounds in the normal 
distribution. It is equivalent to finding the area under the specified 
normal curve between the bounds.

Inverse Normal (invNorm) computes the inverse cumulative normal 
distribution function for a given area under the normal distribution curve 
specified by mean, m, and standard deviation, s. 

This distribution is useful in determining the x-value of data in the area 
from 0 to x<1 when the percentile is known.

t Pdf (tPdf) computes the probability density function (pdf) for the 
t-distribution at a specified x value. df (degrees of freedom) must be > 0. 
The probability density function (pdf) is:

This distribution is useful in determining the probability of the 
occurrence of a value when the population standard deviation is not 
known and the sample size is small. The draw option is available when 
t Pdf is invoked from a formula cell.

t Cdf (tCdf) computes the Student-t distribution probability between 
Lower Bound and Upper Bound for the specified df (degrees of freedom). 
You can click the Draw (Shade area) check box to shade the area 
between the bounds. Changes to the initial Lower Bound and Upper Bound 
automatically update the distribution.

This distribution is useful in determining the probability of the 
occurrence of a value within an interval defined by the lower and upper 
bound for a normally distributed population when the population 
standard deviation is not known.

f x( ) Γ df 1+( )/2[ ]
Γ df 2⁄( )

---------------------------------= 1 x2/df+( )
df 1+( )/2–

πdf
----------------------------------------------
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Inverse t (invt) computes the inverse cumulative t-distribution 
probability function specified by Degrees of Freedom, df, for a given area 
under the curve.

This distribution is useful in determining the probability of an occurrence 
of data in the area from 0 to x<1. This function is used when the 
population mean and/or population standard deviation is not known.

c2 Pdf (c2 Pdf()) computes the probability density function (pdf) for 

the c2 (chi-square) distribution at a specified x value. df (degrees of 
freedom) must be an integer > 0. The probability density function (pdf) 
is:

This distribution is useful in determining the probability of the 

occurrence of a given value from a population with a c2 distribution. The 

draw option is available when c2 Pdf is invoked from a formula cell.

c2 Cdf (c2 Cdf()) computes the c2 (chi-square) distribution probability 
between lowBound and upBound for the specified df (degrees of freedom). 
You can click the Draw Shade area check box to shade the area between 
the lower and upper bounds. Changes to the initial lowBound and 
upBound automatically update the distribution.

This distribution is useful in determining the probability of the 

occurrence of value within given boundaries of a population with a c2 

distribution.

F Pdf (F Pdf()) computes the probability density function (pdf) for the 
F distribution at a specified x value. numerator df (degrees of freedom) 
and denominator df must be integers > 0. The probability density function 
(pdf) is:

This distribution is useful in determining the probability that two 
samples have the same variance. The draw option is available when F Pdf 
is invoked from a formula cell.

where n = numerator degrees of freedom
d = denominator degrees of freedom

f x( ) 1
Γ df 2⁄( )
-------------------- 1/2( )df/2xdf 2 1–⁄ e x/2– x 0≥,=

f x( ) Γ n d+( )/2[ ]
Γ n/2( )Γ d/2( )
---------------------------------- n

d
---⎝ ⎠
⎛ ⎞ n/2

xn/2 1– 1 nx/d+( ) n d+( )/2– x 0≥,=
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F Cdf (F Cdf()) computes the F distribution probability between 
lowBound and upBound for the specified dfnumer (degrees of freedom) and 
dfDenom. You can click the Draw (Shade area) check box to shade the 
area between the lower and upper bounds. Changes to the initial 
lowBound and upBound automatically update the distribution.

This distribution is useful in determining the probability that a single 
observation falls within the range between the lower bound and upper 
bound.

Binomial Pdf (binomPdf()) computes a probability at x for the 
discrete binomial distribution with the specified numtrials and probability 
of success (p) on each trial. The x parameter can be an integer or a list of 
integers. 0{p{1 must be true. numtrials must be an integer > 0. If you do 
not specify x, a list of probabilities from 0 to numtrials is returned. The 
probability density function (pdf) is:

where n = numtrials

This distribution is useful in determining the probability of success in a 
success/failure trial, at trial n. For example, you could use this distribution 
to predict the probability of getting heads in a coin toss on the fifth toss.

Binomial Cdf (binomCdf()) computes a cumulative probability for 
the discrete binomial distribution with n number of trials and probability 
p of success on each trial.

This distribution is useful in determining the probability of a success on 
one trial before all trials are completed. For example, if heads is a 
successful coin toss and you plan to toss the coin 10 times, this 
distribution would predict the chance of obtaining heads at least once in 
the 10 tosses.

Poisson Pdf (poissPdf()) computes a probability at x for the discrete 
Poisson distribution with the specified mean, m, which must be a real 
number > 0. x can be an integer or a list of integers. The probability 
density function (pdf) is: 

This distribution is useful in determining the probability of obtaining a 
certain number of successes before a trial begins. For example, you could 
use this calculation to predict the number of heads that would occur in 
eight tosses of a coin.

f x( ) n
x⎝ ⎠
⎛ ⎞ px 1 p–( )n x– x, 0,1,...,n= =

f x( ) e μ– μx x!⁄ x, 0,1,2,...= =
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Poisson Cdf (poissCdf()) computes a cumulative probability for the 
discrete Poisson distribution with specified mean, l.

This distribution is useful in determining the probability that a certain 
number of successes occur between the upper and lower bounds of a 
trial. For example, you could use this calculation to predict the number of 
heads displayed between coin toss #3 and toss #8.

Geometric Pdf (geomPdf()) computes a probability at x, the 
number of the trial on which the first success occurs, for the discrete 
geometric distribution with the specified probability of success p. 0{p{1 
must be true. x can be an integer or a list of integers. The probability 
density function (pdf) is:

This distribution is useful in determining the likeliest number of trials 
before a success is obtained. For example, you could use this calculation 
to predict the number of coin tosses that would be made before a heads 
resulted.

Geometric Cdf (geomCdf()) computes a cumulative geometric 
probability from lowBound to upBound with the specified probability of 
success, p.

This distribution is useful in determining the probability associated with 
the first success occurring during trials 1 through n. For example, you 
could use this calculation to determine the probability that heads display 
on toss #1, #2, #3, ..., #n.

Confidence Intervals

Supported Confidence Intervals
The following confidence intervals are available from the Lists & 
Spreadsheets application. For complete information regarding these 
functions, refer to the TI-Nspire™ Reference Guide details for the 
function name that is in parentheses.

z Interval (zInterval) computes a confidence interval for an 
unknown population mean, m, when the population standard deviation, 
s, is known. The computed confidence interval depends on the user-
specified confidence level.

This test is useful in determining how far from a population mean a 
sample mean can get before indicating a significant deviation.

f x( ) p 1 p–( )x 1– x, 1,2,...= =
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t Interval (tInterval) computes a confidence interval for an unknown 
population mean, m, when the population standard deviation, s, is 
unknown. The computed confidence interval depends on the user-
specified confidence level.

This test is useful in examining whether the confidence interval 
associated with a confidence level contains the value assumed in the 
hypothesis. Like the z Interval, this test helps you determine how far 
from a population mean a sample mean can get before indicating a 
significant deviation when the population mean is unknown.

2-Sample z Interval (zInterval_2Samp) computes a confidence 
interval for the difference between two population means (m1Nm2) when 
both population standard deviations (s1 and s2) are known. The 
computed confidence interval depends on the user-specified confidence 
level.

This test is useful in determining if there is statistical significance 
between the means of two samples from the same population. For 
example, this test could determine whether there is significance between 
the mean college entrance test score of female students and the mean of 
college entrance test score of male students at the same school.

2-Sample t Interval (tInterval_2Samp) computes a confidence 
interval for the difference between two population means (m1Nm2) when 
both population standard deviations (s1 and s2) are unknown. The 
computed confidence interval depends on the user-specified confidence 
level.

This test useful in determining if there is statistical significance between 
the means of two samples from the same population. It is used instead of 
the 2-sample z confidence interval in situations where the population is 
too large to measure in order to determine the standard deviation.

1-Prop z Interval (zInterval_1Prop) computes a confidence 
interval for an unknown proportion of successes. It takes as input the 
count of successes in the sample x and the count of observations in the 
sample n. The computed confidence interval depends on the user-
specified confidence level.

This test is useful in determining the probability of a given number of 
successes that can be expected for a given number of trials. For instance, 
casino examiners would use this test to determine if observed payouts for 
one slot machine demonstrate a consistent pay out rate.
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2-Prop z Interval (zInterval_2Prop) computes a confidence 
interval for the difference between the proportion of successes in two 
populations (p1-p2). It takes as input the count of successes in each 
sample (x1 and x2) and the count of observations in each sample 
(n1 and n2). The computed confidence interval depends on the user-
specified confidence level.

This test is useful in determining if two rates of success differ because of 
something other than sampling error and standard deviation. For 
example, a bettor could use this test to determine if there is an 
advantage in the long run by playing one game or machine versus 
playing another game or machine.

Linear Reg t Intervals (LinRegtIntervals) computes a linear 
regression t confidence interval for the slope coefficient b. If the 
confidence interval contains 0, this is insufficient evidence to indicate 
that the data exhibits a linear relationship.

Multiple Reg Intervals (MultRegIntervals) computes multiple 
regression prediction confidence interval for the calculated y and a 
confidence for y.

Stat Tests

Supported Statistical tests
Hypothesis tests are available from the Lists & Spreadsheets application. 
For complete information regarding these functions, refer to the 
TI-Nspire™ Reference Guide details for the function name provided in 
parentheses.

Some of the wizards for Stat Tests display a Draw check box. By default, 
the box is not checked. Checking the box creates a Data & Statistics work 
area on the page and plots the results in that work area.

z test (zTest) performs a hypothesis test for a single unknown 
population mean, m, when the population standard deviation, s, is 
known. It tests the null hypothesis H0: m=m0 against one of the 
alternatives below.

• Ha: mƒm0 

• Ha: m<m0 

• Ha: m>m0 

This test is used for large populations that are normally distributed. The 
standard deviation must be known. 
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This test is useful in determining if the difference between a sample 
mean and a population mean is statistically significant when you know 
the true deviation for a population.

t test (tTest) performs a hypothesis test for a single unknown 
population mean, m, when the population standard deviation, s, is 
unknown. It tests the null hypothesis H0: m=m0 against one of the 
alternatives below.

• Ha: mƒm0 

• Ha: m<m0 

• Ha: m>m0

This test is similar to a z-test, but is used when the population is small and 
normally distributed. This test is used more frequently than is the z-test 
because small sample populations are more frequently encountered in 
statistics than are large populations. 

This test is useful in determining if two normally distributed populations 
have equal means, or when you need to determine if a sample mean 
differs from a population mean significantly and the population 
standard deviation is unknown.

2-Sample z Test (zTest_2Samp) tests the equality of the means of 
two populations (m1 and m2) based on independent samples when both 
population standard deviations (s1 and s2) are known. The null 
hypothesis H0: m1=m2 is tested against one of the alternatives below.

• Ha: m1ƒm2 

• Ha: m1<m2 

• Ha: m1>m2 

2-Sample t Test (tTest_2Samp) tests the equality of the means of 
two populations (m1 and m2) based on independent samples when 
neither population standard deviation (s1 or s2) is known. The null 
hypothesis H0: m1=m2 is tested against one of the alternatives below.

• Ha: m1ƒm2 

• Ha: m1<m2 

• Ha: m1>m2 
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1-Prop z Test (zTest_1Prop) computes a test for an unknown 
proportion of successes (prop). It takes as input the count of successes in 
the sample x and the count of observations in the sample n. 1-Prop z Test 
tests the null hypothesis H0: prop=p0 against one of the alternatives 
below.

• Ha: propƒp0 

• Ha: prop<p0 

• Ha: prop>p0 

This test is useful in determining if the probability of the success seen in a 
sample is significantly different from the probability of the population or 
if it is due to sampling error, deviation, or other factors.

2-Prop z Test (zTest_2Prop) computes a test to compare the 
proportion of successes (p1 and p2) from two populations. It takes as 
input the count of successes in each sample (x1 and x2) and the count of 
observations in each sample (n1 and n2). 2-Prop z Test tests the null 
hypothesis H0: p1=p2 (using the pooled sample proportion Ç) against one 
of the alternatives below.

• Ha: p1ƒp2 

• Ha: p1<p2 

• Ha: p1>p2 

This test is useful in determining if the probability of success seen in two 
samples is equal.

c2GOF (c2GOF) performs a test to confirm that sample data is from a 

population that conforms to a specified distribution. For example, c2 
GOF can confirm that the sample data came from a normal distribution.

c2 2-way Test (c22way) computes a chi-square test for association on 
the two-way table of counts in the specified Observed matrix. The null 
hypothesis H0 for a two-way table is: no association exists between row 

variables and column variables. The alternative hypothesis is: the 
variables are related.

2-Sample FTest (FTest_2Samp) computes an F-test to compare two 
normal population standard deviations (s1 and s2). The population 
means and standard deviations are all unknown. 2-Sample FTest, which 

uses the ratio of sample variances Sx12/Sx22, tests the null hypothesis 
H0: s1=s2 against one of the alternatives below.
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• Ha: s1ƒs2 

• Ha: s1<s2 

• Ha: s1>s2 

Below is the definition for the 2-Sample FTest.

2-Sample FTest for the alternative hypothesis .

2-Sample FTest for the alternative hypothesis .

2-Sample FTest for the alternative hypothesis s1ƒs2. Limits must satisfy 
the following:

where: [Lbnd,Ubnd] = lower and upper limits

The F-statistic is used as the bound producing the smallest integral. The 
remaining bound is selected to achieve the preceding integral’s equality 
relationship.

Sx1, Sx2 = Sample standard deviations having  

and  degrees of freedom df, 
respectively.

F = F-statistic  =  

df(x, , ) = Fpdf( ) with degrees of freedom df, , 

and 

p = reported p value

n1 1–

n2 1–

Sx1
Sx2
---------⎝ ⎠
⎛ ⎞ 2

n1 1– n2 1– n1 1–

n2 1–

σ1 σ2>

p f
F

α

∫ x n1 1 n2 1–,–,( )dx=
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0

F
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p
2
--- f x n1 1 n2 1–,–,( ) xd
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∞
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Linear Reg t Test (LinRegtTest) computes a linear regression on the 
given data and a t test on the value of slope b and the correlation 
coefficient r for the equation y=a+bx. It tests the null hypothesis H0: b=0 
(equivalently, r=0) against one of the alternatives below.

• Ha: bƒ0 and rƒ0 

• Ha: b<0 and r<0

• Ha: b>0 and r>0

Multiple Reg Tests (MultRegTest) computes a linear regression on 
the given data, and provides the F test statistic for linearity. 

Refer to the TI-Nspire™ Reference Guide for information about 
MultRegTests.

ANOVA (ANOVA) computes a one-way analysis of variance for 
comparing the means of two to 20 populations. The ANOVA procedure 
for comparing these means involves analysis of the variation in the 
sample data. The null hypothesis H0: m1=m2=...=mk is tested against the 
alternative Ha: not all m1...mk are equal.

The ANOVA test is a method of determining if there is a significant 
difference between the groups as compared to the difference occurring 
within each group. 

This test is useful in determining if the variation of data from sample-to-
sample shows a statistically significant influence of some factor other 
than the variation within the data sets themselves. For example, a box 
buyer for a shipping firm wants to evaluate three different box 
manufacturers. He obtains sample boxes from all three suppliers. ANOVA 
can help him determine if the differences between each sample group 
are significant as compared to the differences within each sample group.

ANOVA 2-Way (ANOVA2way) computes a two-way analysis of 
variance for comparing the means of two to 20 populations. A summary 
of results is stored in the stat.results variable.

The two-way ANOVA analysis of variance examines the effects of two 
independent variables and helps to determine if these interact with 
respect to the dependent variable. (In other words, if the two 
independent variables do interact, their combined effect can be greater 
than or less than the impact of either independent variable additively.) 

This test is useful in evaluating differences similar to the ANOVA analysis 
but with the addition of another potential influence. To continue with 
the ANOVA box example, the two-way ANOVA might examine the 
influence of box material on the differences seen.
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Selecting an Alternative Hypothesis (ƒ < >)
Most of the inferential stat editors for the hypothesis tests prompt you to 
select one of three alternative hypotheses.

• The first is a ƒ alternative hypothesis, such as mƒm0 for the z Test.

• The second is a < alternative hypothesis, such as m1<m2 for the 
2-Sample t Test.

• The third is a > alternative hypothesis, such as p1>p2 for the 
2-Prop z Test.

To select an alternative hypothesis, move the cursor to the appropriate 
alternative, and then press ·.

Selecting the Pooled Option
Pooled (2-Sample t Test and 2-Sample t Interval only) specifies whether 
the variances are to be pooled for the calculation.

• Select No if you do not want the variances pooled. Population 
variances can be unequal.

• Select Yes if you want the variances pooled. Population variances are 
assumed to be equal.

To select the Pooled option, select Yes from the drop down box.

Working with function tables
The Lists & Spreadsheet application lets you show a table of function 
values for any function in the current problem. You can change the 
settings for the table, delete columns, add values for multiple functions, 
and edit the expression that defines a function without leaving the 
Lists & Spreadsheet application.

Switching to a Table

1. While working in the Lists & Spreadsheet application, press / T 
(Macintosh®: “ T) to switch to a table.

The Lists & Spreadsheet application disappears and an empty table 
displays with a list of the functions that are available in the problem.

Note: If you have previously shown a table for a function from the 
Lists & Spreadsheet application, the table includes that function by 
default.

2. Choose the name of the function for which you want to display 
values. 

Values for the function you selected display in the first column of the 
table.
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3. To move through adjacent cells of the table, press £ or ¤. Press e 
to move from the body of the table (cells) to the top two rows (cells 
for column names and formulas).

4. To hide the table of values and return to the Lists & Spreadsheet 
application, repeat Step 1.

Making changes from a table
You can change the table of function values using the tools on the Table 
menu.

To remove a column from the table, select any cell and choose Delete 
Column.

To display the list of functions, click a cell in a column and select 
Choose. Choose a cell in an empty column unless you are replacing 
values already displayed. Click a function in the list to add its values to 
the column.

Note: You can also click the drop-down arrow on the top cell of a 
column to display the list of functions in the problem.

To change the expression that defines a function, choose Edit 
Expression. You can also edit the expression directly on the entry line 
beneath the table.

Note: When you edit the expression for a function, that function 
automatically changes in the application used to define the function. 
For example, if you edit a Graphs & Geometry function in the table, 
the table values and graph of the function are both updated.

To change the default table settings, choose Edit Table Settings.

The Table dialog displays. Press e to move from field to field and 
type or select new values for the default table settings:

– Table Start: Type the value to use as the first value in the table of 
values.

– Table Step: Type a value for the interval between values.

– Independent and Dependent: Click the drop-down arrow to 
choose Auto or Ask as the method for populating a column with 
the values of the independent and dependent variables. Auto 
populates the table starting at the defined table start value and 
displays an independent and dependent value for each step. Ask 
lets you select a cell and press · to generate a value for a cell.
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Using Data & Statistics

The Data & Statistics application provides tools to: 

• Visualize sets of data in different types of plots.

• Directly manipulate variables to explore and visualize data 
relationships. Data changes in one application are dynamically 
applied to all linked applications.

• Explore central tendency and other statistical summary techniques.

• Fit functions to data.

• Create regression lines for scatter plots.

• Graph hypothesis tests and results (z- and t-tests) based on summary 
statistics definitions or data.

À Data & Statistics tool menu

Á Work area

Â Add Variable regions on x-axis and y-axis

Ã Normal Probability Plot with expression (click line to display)

Ä Data point with coordinates (hover to display xlist variable data with 
Expected z)

À

Ã

Ä

Á

Â
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Data & Statistics menu
The Data & Statistics menu provides tools to graph and explore data, to 
modify data representations by using different plots, and to perform and 
plot statistical analyses. 

Handheld: Press b to open the Tools menu.

Plot type

Dot Plot Depicts data in a dot plot. This is the 
default plot type for a single numeric 
variable.

Box Plot Displays data in a box plot.

Histogram Displays data in a histogram. 

Normal Probability 
Plot

Displays data in a normal probability plot. 
Data is grouped against the z-value that 
corresponds to its quartile/normal score. 
This plot type is useful for checking for 
normality and determining the 
appropriateness of a normal model.

Scatter Plot Displays data in scatter plot form. This is 
the default plot type for two numeric 
variables.

X-Y Line Plot Displays data as an x-y line plot.

Dot Chart Displays data in a dot chart. This is the 
default plot type for categorical data.

Bar Chart Displays vertical or horizontal bars to 
represent cases in categories of data. 

Pie Chart Displays a circle with segments to represent 
the cases in each category of data. 
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Plot Properties

Connect Data Points Draws a line between each point on a 
scatter plot. Lines are connected in the 
order in which the data appears for the 
variable on the horizontal axis. This is the 
same as the X-Y Line plot type.

Histogram Properties Determines how histogram data displays in 
the work area. 

Histogram Scale lets you adjust the 
Frequency, Percent, and Density properties 
of the histogram.

• Frequency - displays data by 
occurrence in the data set.

• Percent - displays data by each bin’s 
percent value of the whole data set.

• Density - displays data by data density.

Bins displays a dialog for setting the 
histogram values for bin width and 
alignment.

Extend Box Plot 
Whiskers/ Show Box 
Plot Outliers

Extend Box Plot Whiskers extends the 
whiskers to the min and max of the data.

Show Box Plot Outliers stops the whiskers 
at 1.5 * Interquartile Range and shows 
outliers as individual dots. 

Note: If there are no points outside of 
1.5 * Interquartile Range, there may 
appear to be no whisker change.

Show/Hide All Labels Displays or hides labels for categorical 
data. Each bar or wedge is labeled.

Add X Variable Adds a variable to the horizontal axis 
when no variable is assigned.

Add X Summary List Lets you display plots from frequency 
tables, probability distribution tables, or 
other summary data.

Remove X Variable Removes the display of the variable 
assigned to the horizontal axis without 
changing the vertical axis.
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Add Y Variable Adds a variable to the vertical axis to 
support the plotting of multiple variables.

Add Y Summary List Lets you display plots from frequency 
tables, probability distribution tables, or 
other summary data.

Remove Y Variable Removes the display of the variable 
assigned to the vertical axis without 
changing the horizontal axis.

Force Numeric X Treats the variable on the x-axis as numeric 
although the default is categorical (list of 
strings). The categorical data label is 
replaced by an axis with numbers. 
Note: Forcing a numeric variable is 
supported only when there are numbers in 
the list.

Force Categorical X Treats the variable on the x-axis as a 
categorical variable (list of strings). The 
numeric axis is replaced by labels for 
categorical data. 

Force Numeric Y Treats the variable on the y-axis as a 
numeric variable although the default is 
categorical (list of strings). The categorical 
data label is replaced by an axis with 
numbers. 
Note: Forcing a numeric variable is 
supported only when there are numbers in 
the list.

Force Categorical Y Makes Data & Statistics treat a numeric 
variable assigned to the y-axis as a 
categorical variable (list of strings). The 
numeric is replaced by labels for 
categorical data.

Split Categories by 
Variable

Lets you split a category (such as a chart of 
eye colors) by an additional category (such 
as gender).

Remove Split Variable Removes the split variable added by the 
previous menu item.

Plot Properties
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Clear All Removes the variable assignments from 
the axes. This enables you to start your 
work again.

Actions

Remove Removes selected items from the work 
area.

Hide/Show Text Hides or shows selected text.

Insert Text Adds a text box with multiple lines for 
typing notes in the work area. You can 
edit, move, resize, remove, and hide text 
boxes. 

To go to the next line in a text box, press 
Alt ·. On the handheld, press @.

Insert Slider Inserts a slider object for dynamically 
changing the value of a numeric variable. 

Select all Points Selects all points in the work area.

Select Image Selects the background image.

Sort Sorts the data in List, Value, or Alpha order.

Analyze

Remove Removes a selected Movable Line, 
Regression, Plotted Value, or Plotted 
Function.

Add Movable Line Adds a line you can position and reposition 
in the work area. This can be used for 
manual fit.

Lock Intercept at 
Zero/Unlock 
Movable Line 
Intercept

Locks the intercept of a movable line at 
zero. 
Note: This tool is only available when a 
movable line is present in the work area.

Plot Function Lets you graph a function in the work area. 

Plot Properties
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Shade Under 
Function

Lets you select and shade a region under a 
function or distribution curve.

Regression The regression tools calculate and display a 
selected regression model for the plotted 
data. Regression is only available on Scatter 
plots or X-Y line plots.

You can show or hide the following 
regression models:

Linear (mx+b)
Linear (a+bx)
Median-Median
Quadratic
Cubic
Quartic
Power
Exponential
Logarithmic
Sinusoidal
Logistic (d=0)
Logistic (dƒ0)

Residuals The residuals tools display information 
about the residuals of the selected model. 
These tools are available when a scatter 
plot and one or more lines, regressions, or 
plotted functions are on the work area.

Show/Hide Residual Squares displays the 
squares of residuals.

Show/Hide Residual Plot plots the 
residuals against the explanatory variable. 
The residual is the difference between the 
observed value (data) and the value 
calculated by a regression or function.

Plot Value Lets you graph a statistical value on the 
axis. Examples of values that can be plotted 
are a number, mean, median, and standard 
deviation.

Analyze
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Getting started with the Data & Statistics 
application
The Data & Statistics application lets you explore and visualize data and 
graph inferential statistics. The Lists & Spreadsheet application can work 
in conjunction with the Data & Statistics application. The 
Lists & Spreadsheet Summary Plot and Quick Graph tools automatically 
add a Data & Statistics application to show plots. A list that you create in 
a problem (using the Lists & Spreadsheet or Calculator applications) can 
be accessed as a variable in any TI-Nspire™ application in that problem.

Show Normal PDF Overlays the normal probability density 
function using the mean and the standard 
deviation of the data in the histogram. 
Note: This tool is available when a 
histogram is present.

Graph Trace Lets you trace the graph from Plot 
Function, Show Normal PDF, Add Movable 
Line, distribution curves, regressions, case 
plots, dot plots, scatter plots, X-Y line plots, 
box plots, histograms, bar charts, pie 
charts, or multiple plots.

Window/Zoom

Window Settings Displays a Window Settings dialog that 
enables you to enter values that define the 
work area window. Values you can set 
include the x-min, x-max, y-min, and y-max 
values for the axes.

Zoom - Data Adjusts the zoom factor so that all plotted 
data appears in the work area.

Zoom In Enables you to zoom in on a plot based 
upon the selection of a center point. The 
Zoom In factor is approximately 2.

Zoom Out Enables you to zoom out on a plot based 
upon the selection of a center point. The 
Zoom Out factor is approximately 2.

Analyze
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Using the default case plot
The Data & Statistics application plots numeric and string (categorical) 
data from variables. When you add a Data & Statistics application to a 
problem that includes lists, a default case plot displays on the work area.

The case plot is like having a stack of cards with information on them and 
scattering the cards randomly on a table. You can click a dot to see the 
information on that “card.” You can drag a dot to “group” the “cards” 
by the caption variable.

Click the variable name displayed after Caption to use the case plot.

– Choose <None> to remove the default case plot.

– Choose the name of a variable to have it replace the current case 
plot variable. 

– Hover over any data point to see the summary information.

– Drag any data point toward an axis to see how the points group.

– Activate the Graph Trace tool and press 7 or 8 to move across 
points.

When you add a variable to either axis, the plot for that variable replaces 
the default case plot. The default case plot redisplays if you remove the 
plotted variable from each axis.

Navigating in the Data & Statistics application
You can plot variables by clicking the Add Variable region in the center 
of the horizontal and vertical axes. The work area displays data points to 
represent the values in variables. You can press e to move among 
these functional areas.
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Using the axes
The horizontal and vertical axes include an Add Variable region near the 
center. You can click the Add Variable region of an axis to view a list of all 
variables available in the problem, or display the context menu to use 
tools to help you work with data.

Using the context menu
The context menu provides access to the tools most commonly used with 
the selected object. The context menu displays different options 
depending on the active object and the task you are performing.

To display the context menu for an object.

Windows®: Right-click the object.

Macintosh®: Hold “ and click the object.

Handheld: Point to the object and press / b.

The context menu includes the Color option. You can use the Color 
option to change the data to the color of your choice.

Other options that are appropriate for various plots also display on the 
context menu. 

Selecting data and displaying summary information
When you hover over part of a plot, the Data & Statistics application 
displays summary information for the data it represents. 

1. Hover at an area of interest in a plot to display data values or 
summary information. For example, you can hover over the center of 
a box plot to display the median summary data.

2. Click once to select a representation of data in a plot.

Data points are shown with a bold outline to indicate selection. You 
can click a point a second time to deselect it, or click additional points 
to add to the selection.

Plotting variables
To plot variables, start with a problem that includes a Data & Statistics 
application and lists created in the Lists & Spreadsheet application or the 
Calculator application.

1. Click the Add Variable region near the center of an axis. 

If no variable is plotted on the axis, the tooltip Click or Enter to add 
variable displays. 

2. Click the tooltip Click or Enter to add variable. 
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A list displays the names of available variables.

3. Click the name of the variable to plot.

Note: By convention, the independent variable is shown on the 
x-axis.

The default plot for one variable is a dot chart. The data points in the 
default case plot reposition to represent the elements of the selected 
variable in a dot chart. 

4. (Optional) Click the Add Variable region near the center of the 
remaining axis to plot a second variable. 

The default plot for two variables is a scatter plot. The data points 
shift to represent the elements of both variables as a scatter plot. 

5. (Optional) Repeat Steps 1-3 to choose additional variables to plot on 
the vertical axis.

The name of each variable that you add is appended to the label on 
the axis. The default data point shape changes to help you distinguish 
data, and a legend displays to identify the shapes.

6. Change, analyze, or explore the plotted data.

– Remove or change the variable on an axis by clicking the Add 
Variable region again. 

– View the plotted data in another supported plot type by selecting 
a tool from the Plot Types menu. 

– Choose the Graph Trace tool on the Analyze menu and press 
7 or 8 to move across the data points in the plot.

– The lists that you plot as variables can include incomplete or 
missing cases. (A case is the data contained in a row of cells in the 
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Lists & Spreadsheet application.) The Lists & Spreadsheet 
application displays a void as an underscore (“_”), and 
Data & Statistics plots no data point for a void cell.

Manipulating plotted data
You can manipulate data points on the Data & Statistics work area to 
explore their effects. For example, you could explore how a specific 
group of values affects the median.

You can move a data point only in directions allowed by its definition. If 
a list is defined with a formula in Lists & Spreadsheet, the points in 
Data & Statistics may not move because of the formula’s restrictions. For 
example, you can manipulate a plot that represents the result of y=x, but 
you can only move along a line. 

You cannot move points that represent data in a locked variable or data 
that represents a categorical value.

To move plotted data:
1. On the Data & Statistics work area, click a representation of data—

such as a histogram bin or a whisker of a box plot—that is not locked 
or restricted by a formula.

The pointer changes to an open hand to show that the data can be 
moved.

2. Drag the selection to explore how different values of the point affect 
the plot.

As you drag, the changing value displays on the work area.

Overview of raw and summary data
You can create plots directly from raw data or from a summary table.
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• Raw data consists of a single list, such as a list of eye colors. When you 
create a plot of raw data, Data & Statistics counts the occurrences for 
you. Plotting raw data directly gives you flexibility in analyzing it.

• A summary table consists of two lists, such as eye colors (the 
X or Y List) and counts of eye-color occurrences (the Summary List). 
For an example that creates a summary table and then plots it, refer 
to the “Using Lists & Spreadsheet” chapter.

Working with numeric plot types
Plots can represent the data from a variable in a variety of ways. 
Choosing the appropriate plot can help you visualize the data. For 
example, you may be able to observe the shape and spread of the data in 
one plot type and another type may be useful for determining the best 
method for statistically evaluating data. Use Data & Statistics to create 
the following types of numeric plots.

• Dot Plot

• Box Plot

• Histogram

• Normal Probability

• Scatter Plot

• X-Y Line 

Creating dot plots
Dot plots, also known as dot-frequency plots, represent one variable 
data. Dot plots are the default plot type for numeric data. When you plot 
a variable as a dot plot, one dot represents each value in the list. Each dot 
displays on the axis at a point that correspond to the value. 

raw data summary table for eye color based on 
raw data
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1. To create a dot plot, click the Add Variable region in the center of an 
axis and click the name of a numeric variable. For more details, see 
Plotting variables.

2. (Optional) To split a dot plot by category, click the Add Variable 
region on the other axis and choose the list that contains the 
corresponding category data. 

3. (Optional) To plot multiple dot plots, choose Add X Variable on the 
Plot Properties menu and select a numeric variable from the list that 
displays. 

A second dot plot appears on the work area and the name of the 
plotted variable is added to both axis labels. 

4. Explore the plotted data.

– Hover over a data point to display data values.

– Click and drag a dot to move it. As you move a point, the values 
associated with it change on the work area display and in the list 
for the variable.

– Activate the Graph Trace tool and press 7 or 8 to move across the 
data points in the plot in list order. Points enlarge and display a 
bold outline as you move across them in Trace mode.

Creating box plots
The Box Plot Tool plots one-variable data in a modified box plot. 
“Whiskers” extend from each end of the box, either to 1.5 times the 
interquartile range or to the end of the data, whichever comes first. 
Points that are a width of 1.5 * Interquartile Range past the quartiles 
plot individually, beyond the whiskers. These points are the potential 
outliers. When no outliers exist, x-min and x-max are the prompt for the 
end of each whisker. 

Box plots are useful for comparing two or more sets of data that use the 
same scale. If a dataset is large, a box plot can also be useful in exploring 
data distribution. 

1. Click the Add Variable region in the center of an axis. The default plot 
for one numeric variable is a dot plot. See Plotting variables for more 
details about plotting data.
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Note: If two variables are plotted in the work area, you can create a 
dot plot by removing one variable. Choose Remove X Variable or 
Remove Y Variable from the Plot Types menu.

2. On the Plot Types menu, select Box Plot. 

A modified box plot displays on the Data & Statistics work area. 

Note: You can split a box plot by category by adding a list that 
contains corresponding categorical data to the y-axis. 

3. (Optional) To add additional variables for comparing box plots on the 
same axis, click Add X Variable on the Plot Properties menu. 
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For example, you can use multiple boxplots to compare the 
distributions of sample proportions. In the example, true proportion 
is .5 and sample size varies from n=20 to n=40 to n=90.

Notes:

– You can create a box plot with frequency by choosing Add X 
Variable or Add Y Variable on the Plot Properties menu.

– You can specify a variable multiple times as you choose variables 
to plot as box plots. 

– The variable used to provide frequency information is added to 
the label on the horizontal axis in the format: 
x_variablename{frequencylist_name}.

4. Point and click the regions of the box plot to explore and analyze the 
data it represents.

– Hover over a region or over a whisker to display the details for the 
portion of the plot that interests you. The label for the quartile 
that corresponds to your selection displays.

– Click a region of the box plot to select the data points or whiskers. 
Click again to remove the selection.

– You can select any box plot that does not include frequency data 
and choose Dot Plot on the context menu to change the plot 
type.

– Drag a selection to move it and explore other possibilities for the 
data.

– Use the arrow keys to move a data point one pixel at a time.

– Activate the Graph Trace tool and press 7 or 8 to move across dots 
and regions of the plot. As the trace cursor moves, the values for 
Q1, the median, Q3, and whisker ends/outliers display.

5. Change the plot from a modified box plot to a standard box plot by 
choosing Extend Box Plot Whiskers on the Plot Properties menu. 
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The box plot is redrawn as a standard box plot with extended 
whiskers. 

The standard box plot’s whiskers use the minimum and maximum 
points in the variable and outliers are not identified. The whiskers on 
the plot extend from the minimum data point in the set (x-min) to the 
first quartile (Q1) and from the third quartile (Q3) to the maximum 
point (x-max). The box is defined by Q1, Med (median), and Q3.

Note: You can select Show Box Plot Outliers on the Plot Properties 
menu to return to the modified box plot.

When you have a numeric list with a corresponding categorical list, you 
can create a box plot split by category. Adding the categorical list splits 
the box plot by category. A split box plot is useful for comparing the 
spread of various populations.

Plotting histograms
A histogram plots one-variable data and depicts the distribution of data. 
The number of bins displayed depends on the number of data points and 
the distribution of these points. A value that occurs on the edge of a bin 
is counted in the bin to the right.

Creating a histogram
1. Select the data that you want to plot as a histogram.

– For horizontal orientation, choose Add X Variable.

– For vertical orientation, choose Add Y Variable.

2. From the Plot Types menu, select the Histogram tool.

In this example, the data from the box plot separates into points and 
moves to form the bins of a histogram.

The histogram plots on the Data & Statistics work area.
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3. Explore the data in the bins of the histogram.

– Hover over a bin to see the information for that bin.

– Adjust the width and number by dragging the side of a bin.

– Click a bin to select it. Click the bin again to deselect it.

– Drag a selection to move it.

Note: The bars are not movable in categorical plots.

– Activate the Graph Trace tool and press 7 or 8 tto move across the 
bins and display values.

Creating a histogram with frequency or summary data
1. On a Lists & Spreadsheet page, create two lists: one containing the 

“bins,” such as heights in a population (ht), and the other containing 
the frequencies of those heights (freq).

2. On a Data & Statistics page, access the context menu on the x axis, 
and select Add X Variable with Summary List.

3. Select ht as the X List and freq as the Summary List.
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Note: It is up to you to set the data and bins in a meaningful way 
when using summary data.

4. Explore the data in the bins of the histogram.

– Hover over a bin to see the information for that bin.

– Adjust the width by dragging the side of a bin.

– Click a bin to select it. Click the bin again to deselect it.

– Activate the Graph Trace tool and press 7 or 8 tto move across the 
bins and display values.

Modifying histogram bins
1. To modify histogram bins, select Histogram Properties on the Plot 

Properties menu and choose Bin Settings.

The Bin Settings dialog displays.

2. Type values to set width and alignment of the bins that represent 
histogram data:

– To specify bin width, type a value in Width.

– To specify bin placement, type a value in Alignment. 

Note: You can also modify the bins by clicking and grabbing the edge 
of any bin and dragging it to the desired size.

3. Click OK to apply the changes.

The bins of the histogram are redrawn using the values set. Both the 
data represented by the bins and the value you type for the 
alignment affect the placement of bins on the scale. 

Adjusting the histogram scale of raw data
1. On the Plot Properties menu, select Histogram Properties and 

choose Histogram Scale.

The Histogram Scale dialog displays.
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2. Choose the format for the scale of the histogram. 

– Frequency - displays data based upon the number of values that 
occur within each bin (interval) on the histogram. This is the 
default data representation when you create a histogram.

– Percent - displays data in the histogram by each group’s percent 
value of the whole data set. 

– Density - displays data based upon the density of each value 
within the variable.

3. Click OK to complete the scale change.

Creating a normal probability plot
A normal probability plot shows one set of data against the 
corresponding quartile (z) of the standard normal distribution. You can 
use normal probability plots to judge the appropriateness of the normal 
model for your data.

1. Choose or create the data you want to use for a normal probability 
plot. Use a named list from Lists & Spreadsheet or Calculator.

2. Plot the data in one of the following ways:

– Create a dot plot by selecting a column and choosing Quick 
Graph.

– Add a Data & Statistics work area. Click the Add Variable region 
on an axis and select the data list name to plot the variable.

3. On the Plot Types menu, select Normal Probability Plot. 

The data graphs in the Data & Statistics work area. You can examine 
the graph to compare the normal variable against the quartile.

4. Explore the data represented in the normal probability plot.

– Hover over a data point to display its value.

– Click to select a data point. Click again to deselect it.

– Click on multiple data points to select them.

– Activate the Graph Trace tool and press ¡ or ¢ to move across the 
data points and display values.

Creating a Scatter Plot
A scatter plot shows the relationship between two sets of data. You can 
also plot a scatter plot by using the Quick Graph tool in the 
Lists & Spreadsheet application.



610 Using Data & Statistics

1. In the Data & Statistics work area, click the Add Variable region and 
select the variable that contains the data you want to see represented 
on an axis. 

The plot of the selected variable displays on the axis.

2. Click the Add Variable region of the other axis and select the variable 
containing the data you to plot.

The data points shift to represent the data in the selected variable.

3. Analyze and explore the data in the plot.

– Click a point to select it.

– Hover over a data point to view the summary data.

– Work with the data using the available tools on the Analyze 
menu. For example, choose the Graph Trace tool and press ¡ or ¢ 
to move across the plot.

4. Optional: To plot additional lists against the x-axis, right-click the 
y-axis and select Add Variable.

Creating an X-Y line plot
An X-Y line plot is a scatter plot in which the data points are plotted and 
connected in order of appearance in the two variables. Like scatter plots, 
these plots depict the relationship between two sets of data.

By convention, the left-most column of data is represented on the 
horizontal axis. 

1. Create a scatter plot. See Creating a scatter plot for details.

2. On the Plot Types menu, select the XY Line Plot tool.

The data points within each set are connected to each other by a line. 
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Note: The dots are connected in the order that they appear in the list 
variable on the horizontal axis. To change the order, use the sort tool 
in Lists & Spreadsheet.

3. Analyze and explore the data in the plot.

– Hover over a data point to view the summary data.

– Work with the data using the available tools on the Analyze 
menu. For example, choose the Graph Trace tool and press the 
arrow keys to move across the dots in the plot and view the 
values.

Working with categorical plot types
You can sort and group data using the categorical plot types:

• Dot Chart

• Bar Chart

• Pie Chart

The categorical plot types can be used to compare the representations of 
data across different plots. When the same variable (list) is used for a dot 
chart and a bar chart or pie chart in a problem, selecting a data point or 
segment in one of the plots selects the corresponding data point, 
segment, or bar in all other plots that include the variable.

Creating a dot chart
The default plot type for categorical data is the dot chart.

When one variable is plotted, the value of each cell is represented as one 
dot, and the dots are stacked at the point on the axis that corresponds to 
the cell value. 

1. In Lists & Spreadsheet, create a spreadsheet that includes at least one 
column of string values that can be used as categories for data.
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Note: To type a string in Lists & Spreadsheet, enclose the characters in 
quotes.

2. Add a Data & Statistics page to the problem. 

Notes: 

– You can also use the Lists & Spreadsheet Quick Graph tool to 
automatically add a Data & Statistics page and plot the selected 
column.

– The new Data & Statistic work area displays a default case plot 
with a caption, variable name, and unplotted data points for the 
variable. You can click the variable name in the caption to choose 
another variable for previewing, or drag a default data point 
toward an axis to plot the current variable.

3. Move near the center of either axis and click the Add List region. The 
list of variables displays.
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4. Click the list that contains the categories you want to use for sorting 
data.

A dot chart plots in the work area. The application labels the axis with 
the variable name and shows a dot for each instance of a category.

5. Explore the plotted data.

– Hover over a dot in the plot to display data values.

– Click a dot to select it. Click the dot a second time to deselect it or 
remove it from a selection of multiple dots.

– Activate the Graph Trace tool and press 7 or 8 tto move across the 
points in list order. Dots display a bold outline as you move across 
them in Trace mode.

Creating a bar chart
Like dot charts, bar charts display categorical data. The length of a bar 
represents the number of cases in the category. 

1. Click the Add Variable region of either axis and choose the name of a 
categorical variable. See Creating a dot chart for details. 

2. On the Plot Types menu, select Bar Chart.

The dot chart changes to a bar representation of the data.
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3. Explore the data in the plot.

– Hover over a bar to see a category summary (the number of cases 
and percentage among all categories). 

– Activate the Graph Trace tool and press 7 or 8 move across the 
bars and view summary information.

Creating a bar chart from a frequency table or summary 
data
1. On a new Data & Statistics page, create a bar chart with frequency or 

summary data by choosing Add X Variable on the Plot Properties 
menu.

Note: You can also create a bar chart with frequency by choosing 
Add Variable with Summary List from the context menu of the Add 
Variable region of an axis.

2. Select the desired variable from the pop-up.

3. Set the height of the bars with the summary variable by selecting Add 
Summary List from the Plot Properties menu.
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4. Select the summary list from the pop-up.

The bar chart plots on the work area. The icon in the lower left corner 
indicates that this plot was generated from summary data.

5. Hover over a bar to see a category summary, or use the Graph Trace 
tool on the Analyze menu to move across all of the bars displaying 
the summaries. 

6. (Optional) Add summary lists to create a comparative bar chart.

Creating a pie chart
A pie chart represents categorical data in a circular layout and uses an 
appropriately proportioned segment for each category.

1. Create a dot chart on the work area.

2. On the Plot Types menu, select Pie Chart.

The dots move by category into the segments of the pie chart. 
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3. Hover over a segment to see the summary for the category, or use the 
Graph Trace tool on the Analyze menu to move across each segment 
displaying all of the summaries. The summary shows the number of 
cases for the category and the percentage among all cases. 

Note: You can switch to a pie chart from a bar chart generated from 
summary data.

Creating a comparative bar chart
This might be used to explore data in a 2-way table.

1. Enter the raw data on a Lists & Spreadsheet page.

2. From the Insert menu in the toolbar, select Data & Statistics.
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Note: Your screen may differ, depending on the data you entered.

3. Click the Click to add variable field, and select eyecolor as the 
variable for the x axis.

4. On the Plot Type menu, select Bar Chart.

The frequency of the eyecolor data is plotted.

5. To split the eyecolor data by gender, select the Plot Properties menu, 
select Split Categories by Variable, and then select gender.

Splitting a numeric plot by categories
You can use a categorical split to sort the values plotted on an axis.

1. Open a problem that includes a Lists & Spreadsheet page, or create 
data to be plotted in the Lists & Spreadsheet application. 

In this example, lists contain dog breed and weight information.
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2. Click the column letter (A) to highlight the breed column. 

3. On the Lists & Spreadsheet Data menu, select the Quick Graph tool.

The Quick Graph tool adds a Data & Statistics page. Data & Statistics 
plots the variable and labels the horizontal axis. 

4. To plot the numeric data for each category, hover on the Add 
Variable region near the center of the vertical axis and click the 
tooltip Click or Enter to add variable. 

The list of available variables displays.
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5. On the list of variables, click the name of the numeric variable. 

Data & Statistics labels the vertical axis and plots the numeric data for 
each category. 

Exploring data
You can manipulate and explore plotted data.

• Select and move points or data bins

• Change the type of plot

• Rescale the graph

• Add a movable line

• Show regression lines

• Show residual squares

• Show a residual plot
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Moving points or bins of data
1. Click and hold the desired point or bin.

The cursor changes to ÷.

2. Drag the point or bar to the new location and release it. Moving the 
point changes the values for x and y.

If you are working with data from Lists & Spreadsheet, the data that 
corresponds to the original point or bar automatically updates in the 
original column(s) in Lists & Spreadsheet as you move the point.

You can also move points or bins by changing the numbers in the 
Lists & Spreadsheet or Calculator applications. Data will update in all 
of the representations.

Moving multiple points
1. Position the pointer over each data point that you want to select. 

When the pointer changes to ÷, click to add the point to the 
selection.
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Alternatively, you can drag a selection rectangle around the points to 
select them.

2. Drag any of the selected points to move them all.

Note: When a list is defined in Lists & Spreadsheet as a formula, the 
movement of points is restricted to positions that satisfy the formula.

Sorting plotted categories
You can sort plotted categories in list order, value order, or alphabetically 
by category name.

1. Click the work area that contains the plotted data.

2. On the Actions menu, select Sort, and select the type of sort.

Note: You can customize the order of the categories by clicking a label 
and dragging it.

Plotting a value
You can plot a value on an existing plot. It displays as a vertical line in the 
work area.

1. From the Analyze menu, select Plot Value. 

Months listed chronologically but plotted by value 
(amount of rain)
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A text box with a default expression opens in the work area.

2. Type the value you want to plot, and press ·. In this example, the 
value is v1:= mean(cost). 

The line is drawn at that value, perpendicular to the axis. If you have 
multiple plots on the work area, a plot value segment displays for 
each plot.

Note: If you use a frequency table to generate a histogram, reference 
the frequency list in your expression. For example, type the 
expression ”v1:= mean(cost, frequency)” in the plot value entry box.

3. Click the line to display the value. 

Note: Double-click the value to edit the expression.

You can use Plot value for a single number or any expression that 
evaluates to a number. If the value is dependent on the data, like 
mean, when you drag a point or make changes in the 
Lists & Spreadsheet application, the line updates to reflect the 
change, allowing for investigation of the influence of points on the 
calculation.

Plot value 
entry box

Plot value line with value displayed
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Removing a plotted value
1. Select the plotted value line.

2. From the Actions menu, select Remove Plotted Value.

Changing the plot type
You can change the plot type, to view different representations of data.

On the Plot Type menu, select a new plot type. Only the supported 
plot types are available. For example, only univariate plot types are 
available when a single variable plotted on an axis.

The data representation changes to the new plot format.

Note: Options are unavailable on the menu if the plotted data 
cannot be represented by the plot type. For example, if a scatter plot 
is displayed in the work area, you cannot create a box plot without 
first removing the variable from the y-axis. 

Rescaling a graph
You can change the scale of the axes by using translation and Dilation

The cursor changes to indicate whether translation (ö) or Dilation (ô) is 
available in zones on the axes.

Translation
A translation slides a set of axes a fixed distance in a given direction. The 
original axes have the same shape and size.

1. Position the cursor over a tic mark or label in the middle third of the 
axis. The cursor changes to ö.

Dilation region

Dilation 
region

Translation region

Translation 
region

Dilation region
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2. Click to grab. The cursor changes to ù. Drag the cursor to the desired 
position and release.

Dilation
Dilation retains the shape of the axes, but enlarges or reduces the size.

1. Position the cursor over a tic mark or label near the ends of the axis. 
The cursor changes to ó on the vertical axis or ô on the horizontal 
axis.

2. Click to grab. The cursor changes to ÷. Drag the cursor to the desired 
position and release.

Adding a movable line
You can add a movable line to a plot. Moving and rotating the line on 
the work area changes the function that describes it. 

From the Analyze menu, select Add Movable Line. 
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The movable line displays and is labeled with a function that 
describes it. For this example, Data & Statistics stores the expression 
for the movable line in the variable m1.

Rotating a movable line
1. Click and grab on either end of the line.

The cursor changes to é.

2. Drag to rotate and change the slope of the line.

The function m1(x) is updated for the changes in the position of the 
movable line.

Changing the intercept
1. Click in the middle of the movable line.

The cursor changes to ö.

2. Drag to change the intercept.
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The number at the end of the equation changes to show the change 
in the intercept.

Note: The movable line is stored as a function that can be used for 
prediction in the Calculator application.

Locking the intercept at zero
You can lock the intercept of the movable line at zero. 

From the Analyze menu, select Lock Intercept at Zero.

You can unlock the intercept by choosing Unlock Movable Line 
Intercept on the Analyze menu. 

Tracing a movable line
You can trace a movable line to predict and analyze values. 

1. Click the line.

The cursor changes.

2. From the Analyze menu, select Graph Trace to enable Trace mode for 
the line. Rotation of the line is not supported in Trace mode.

3. Press ¡ or ¢ (left or right arrow keys) to trace the movable line. 

If the plotted variables change, points on the graph and the line are 
updated automatically.

Showing a line of regression
You can show a line of regression when you have a scatter plot or an X-Y 
line plot on the work area. Studying the line of regression can help you 
understand the relationship between two variables. 
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1. With a scatter plot or X-Y line plot of two variables on the work area, 
select the Analyze menu, choose Regression and view the list of 
regressions.

2. Click the type of regression line to show. For example, choose Show 
Linear (mx+b) to plot a linear regression line as shown in the 
following example. 

When the line of regression is selected, the expression for the line 
displays.

Showing residual squares
You can display residual squares on a plot. Residual squares can help you 
assess the appropriateness of the model for your data.

Note: This tool is only available when a regression or movable line is 
present in the work area.

From the Analyze menu, select Residuals > Show Residual Squares.

The sum of squares is updated as the line or data changes.
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Showing a residual plot
You can show a residual plot to determine how well a line fits data. The 
work area must include a scatter plot and one or more movable lines, 
regressions, or plotted functions for Show Residual Plot to be available.

With a scatter plot, line of regression, and/or movable line in the 
work area, select the Analyze menu, and select Show Residual Plot > 
Residuals.

Notes:

• With multiple regressions or functions and movable lines plotted, you 
can select each by clicking the line to show its residual plot. 

• Click and hold a dot on the residual plot to see the residual.

• The residual plot for the selected regression or function displays in 
the work area. 

• For consistency in comparing sets of data, residual plots do not rescale 
when you move from one function or regression to another. 

• Select a function or regression before a showing residual plot. If no 
function or regression is selected and there are several plotted, Data 
& Statistics arbitrarily selects the function or regression for showing 
the residual plot.

• Axes can be adjusted by clicking and dragging.

Removing a residual plot
With a scatter plot, line of regression, and/or movable line in the 
work area, select the Analyze menu, and select Hide Residual Plot.

Using Window/Zoom tools
Use the Window/Zoom tools to redefine the graph to better view points 
of interest. The Window/Zoom tools include:
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• Window Settings: displays a Window Settings dialog that lets you 
enter the x-min, x-max, y-min, and y-max values for the axes. 

• Zoom - Data: adjusts the zoom factor to display all plotted data.

• Zoom - In: lets you to define the center point of the zoom in location. 
The Zoom In factor is approximately 2.

• Zoom - Out: lets you define the center point of the zoom out 
location. The Zoom Out factor is approximately 2.

Using the Window Settings tool
1. On the Window/Zoom menu, select Window Settings.

2. The Window Settings dialog opens. The current values for x-min, 
x-max, y-min, and y-max display in the fields. 

Note: Only the appropriate boxes are editable, depending on 
whether there are one or two axes in the work area.

3. Type the new values over the old values. 

4. Select OK to apply the changes and redraw the plot.

Using the Zoom Data tool
On the Window/Zoom menu, select Zoom Data. 

The work area rescales to display all plotted data.

Using the Zoom In tool
1. On the Window/Zoom menu, select Zoom In. 

2. In the work area, click the center point of the area of interest. This 
will be the center of the zoom in action.

The plot redraws to focus and enlarge the portion of the plot 
centered about the point you selected in the previous step.

Using the Zoom Out tool
1. On the Window/Zoom menu, select Zoom Out. 

2. In the work area, click the center point of the area of interest. This 
will be the center of the zoom out action.

The plot redraws to display a larger portion of the plot, centered 
about the point you selected in the previous step.

Graphing Functions
You can graph functions by typing them in Data & Statistics, or you can 
graph functions defined in other applications.
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Graphing functions using the Plot Function tool
You can use the Plot Function tool to plot functions in a work area that 
already includes a plot on the axes. Plot Function lets you specify and 
graph a function for comparison to an existing plot. 

To use the Plot Function tool:

1. Create or open a problem that includes variables (from Lists & 
Spreadsheet) that are plotted on a Data & Statistics work area. Ensure 
that your work area contains both a horizontal axis and a vertical axis 
scale.

2. From the Analyze menu, select Plot Function.

A function entry field displays in the work area.

Note: You can edit the function’s expression typed in the entry field. 
However, the function graphed in Data & Statistics cannot be 
manipulated or moved around the work area. To do that, use Graphs 
& Geometry. 

3. Type the function in the entry field, and press ·. 

Note: You can rename the function by typing over f1(x): with another 
name, if you choose.

The function graphs in the work area and is saved as a variable for 
use in other applications. 

Plot Function 
entry field

Plot from 
variables
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Entering functions from other applications
You can enter a function that has been defined as a variable in another 
application, such as Lists & Spreadsheet, Graphs & Geometry or 
Calculator.

1. Add a variable to each axis. You can access any variables defined in a 
Lists & Spreadsheet or Calculator application in your problem from 
the variable list.

2. From the Analyze menu, select Plot Function.

A function entry field displays in the work area. 

3. Click h.

A list of variables available in the problem displays.

4. Click to select the variable containing the function you want to plot.

In the example below, the variable a contains the function f(x)=x2.

Function 
graph

Function 
equation
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5. Press ·.

The function plots in the work area. 

Editing a function 
You can edit a function and update it on the work area.

1. You can edit a function by double-clicking the equation and then 
making changes as required.

2. Press · after making all changes and the updates display in the 
work area. 

Using Data & Statistics functions in other applications
Data & Statistics functions are stored as variables, and may be used in 
other applications, in the same manner as any other variable. Support for 
all function types is included.

Note: Function numbers increment to use the next available. If you have 
defined f1(x) and f2(x) in Graphs & Geometry, the first function you 
create in Data & Statistics will be f3(x).

Using Show Normal PDF
You can approximate data plotted in the Data & Statistics work area 
against the normal probability density function. The tool overlays the 
normal probability density function using the mean and the standard 
deviation of the data in the histogram.

To show the normal probability density function for plotted data:

1. Add a variable to the x-axis.

2. On the Plot Types menu, select Histogram.
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Note: Show Normal PDF is available only when histogram is the plot 
type.

3. From the Analyze menu, select Show Normal PDF.

The normal PDF for the graph plots in the work area. The expression 
used to calculate the PDF displays when selected. 

You can select Hide Normal PDF on the Analyze menu to remove the 
PDF.

Using Shade Under Function
Use Shade Under Function to find the area of a selected region under a 
function graphed in the work area.

1. Select any function graphed in the Data & Statistics work area. For 
example, select a previously graphed normal PDF.

2. From the Analyze menu, select Shade Under Function. 

The cursor becomes a dotted vertical line and the boundary +/- ˆ 
displays when you position the mouse near the boundary on the left 
or right. You can click when ˆ displays to set it as a boundary.
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3. Select a point on the curve and click to indicate where to start 
shading under the function. The direction in which you move next 
determines whether the region shaded is on the left, right, or center 
of the curve.

4. Select a point on the curve and click to indicate the end boundary of 
the shaded area. A region under the function is shaded based on the 
points you selected. 

You can work with Shade Under Function in the following ways: 

– Select the region to display the values for data points in the 
shaded area. 

– To remove the shading, right-click or /-click the shaded region 
and choose Remove Shaded Region.

– To change the fill color of the shaded area, right-click or /-click 
the shaded region, choose Color, choose Fill, and click a color.

– Use plot value to set the boundary to an exact number. When a 
boundary for shading is set to a plotted value, you can change the 
plotted value to update the shading.

– Edit a shaded region by clicking and dragging the edge at the 
starting or ending boundary.

Using Graph Trace
Graph Trace lets you move from one point on a graph to another in order 
to analyze variations in the data. You can use Graph Trace mode to 
explore the data for the following graphs.

• Graphs from Plot Function and Show Normal PDF

• Distribution curves (created in the Lists & Spreadsheet application)

• Movable Lines
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• Regressions

• Case plots

• Dot plots

• Scatter plots and X-Y line plots

• Box plots

• Histograms

• Bar charts

• Pie charts

1. From the Analyze menu, select Graph Trace.

2. Press ¡ or ¢ to move across the plot.

The data representations enlarge and display with a bold outline as 
you move across them in Trace mode.

Customizing your workspace

Working with color 
All data points for a plotted variable display in the same color to 
distinguish them from the data points of other variables. Data plotted by 
category and split plots automatically display in different colors to help 
you distinguish the data.

To emphasize or distinguish certain parts of your work, you can change 
the default color for a variable’s data.

• Apply fill colors to objects, such as shading, or change the color for a 
variable’s data points. 

• Apply color to plotted lines (such as lines of regression) or movable 
lines.

TI-Nspire™ handhelds without color show color objects in shades of gray. 
The color information is preserved in the document unless you change 
color from the handheld. If you choose to, you can work in grayscale 
mode to view objects in the desktop software similarly to how they 
appear on the handheld. 

Inserting a background image
When using the computer software, you can insert an image as a 
background for a Data & Statistics page. The file format of the image can 
be .bmp, .jpg, or .png.

1. From the Insert menu, select Image.
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2. Navigate to the image that you want to insert.

3. Select it, and then click Open.

The image is inserted as a background.

For more information, refer to the Working with Images chapter.

Working with text
The Insert Text tool lets you type text to describe details related to plots 
on the work area.

1. From the Actions menu, select Insert Text.

A text box displays. 

2. Type notes or descriptions in the text box.

3. Customize the text to suit your needs.

– Move the cursor over the edges of the text box to drag the 
borders and change the width or height.

– Click and grab the text box to move it near objects that relate to 
the text.

– Scroll to view additional text in a box by clicking the arrows at the 
top and bottom edge.

– Click outside of the text entry box to exit the Text tool.

– Hide text by selecting the Actions menu and choosing Hide Text.

– Change the color of text.

Adjusting variable values with a slider
A slider lets you easily explore the effects of adjusting a numeric variable 
through a range of values. You can control a slider's location and visual 
appearance, and its adjustment range and step size.
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À Horizontal slider showing variable name, current value, and range.

Á Vertical slider

Â Slider “thumb” that you can drag to adjust the current value of the 
variable

Ã Slider track

Ä Minimized sliders with arrows to adjust the variable’s current value

Inserting a slider
You can insert sliders on a Graphs page, a Geometry page, or a 
Data & Statistics page.

1. From the Actions menu, select Insert Slider. 

A gray image of a horizontal slider with default settings attaches 
itself to the pointer.

2. Drag to position the slider, and click to release it.

3. Press · to accept the default name (such as V1), or type the name 

of a numeric variable that you want to assign and then press ·.

Â

À

Á

Ã

Ä
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Setting up the slider
You can change many slider settings, such as Minimum and Maximum, by 
clicking parts of the slider. Some settings, such as Step Size, are accessible 
only through the Slider Settings dialog.

1. Right-click in the slider to display its context menu, and select 
Settings to display the Slider Settings dialog. 

Handheld: Point to the slider, press / b, and select Settings. 

2. Use the Slider Settings dialog to enter settings for the slider. Each 
setting is described below. Settings that accept a numeric value also 
accept an expression that evaluates to a numeric value.

Variable Specifies which variable is assigned to the slider. 
Type an available numeric variable name, or click 
the drop-down arrow and select a name from the 
list.

Value Sets the current value of the variable.

Minimum Sets the lowest value in the slider range (left or 
bottom end point on the track).

Maximum Sets the highest value in the slider range (right or 
top end point on the track).

Step Size Sets the size of the increment between values. The 
default setting is Automatic. To enter a specific 
size, click the drop-down arrow, select Enter Size, 
and type a positive numeric value.

Style Click the drop-down arrow to choose Horizontal or 
Vertical.

Display Digits Specifies the display format of the variable’s current 
value. Choose Auto to display the value according 
to the Document Settings option. Click the drop-
down arrow to choose from floating-point or fixed 
formats.

Show Variable Shows or hides the variable name in the slider.

Show Scale Shows or hides the scale in a maximized slider.
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Adjusting a slider variable’s current value
After setting up a slider, use one of these methods to adjust the 
current value:

– Grab the slider thumb ( or ) and drag it.

– Click the slider thumb, and then press 9, :, 7, or 8.

– Click after the “=” or press e as necessary to select the current 
value, and type a numeric value.

– Click a new position on the track.

Note: Any time the variable’s current value is outside the slider’s 
defined range, the thumb is not displayed. To bring the value 
inside the slider’s range, click the slider track or arrows.

Repositioning a slider on the page
Grab and drag any empty space in the slider’s selection rectangle, or 
click an empty space in the slider and then press 9, :, 7, or 8.

Mimimizing a slider
To minimize a slider and display only the variable name, current 
value, and direction arrows, access the slider’s context menu and 
select Minimize.

To further minimize a slider and show only the arrows, access its 
context menu and uncheck Show Variable.

Stretching a slider
Grab the Minimum or Maximum end point on the track, and drag it.

Note: Stretching or shrinking a slider affects only the length of the 
track. The Minimum and Maximum values do not change.
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Animating a slider
An animated slider steps repeatedly through its range, using the slider’s 
Step Size.

Access the slider’s context Menu and select Animate.

Note: To stop the animation, click Stop Animate. Animation also 
stops if you lock the slider’s associated variable.

Removing a slider
Removing a slider does not delete the variable associated with the slider.

1. Click in the slider’s selection rectangle to select it.

2. Press ..

Tips for using sliders

Use multiple sliders for a variable
• You can assign the same variable to multiple sliders. This lets you see 

the effect of adjusting a variable by different step sizes or through 
different ranges. 

Deselect a slider

• To deselect a slider, click another part of the work area, press d, or 

press e e to move to another element in the work area.

Associate a different variable with a slider
• Click the text box for the variable name and type the name of the 

numeric variable to use. 

• With the slider active, click the h button to select a variable from 
the list.

Inferential Statistics
You can explore hypothesis tests and probability distributions in the 
Data & Statistics application after entering the data on a 
Lists & Spreadsheet page.

Drawing inferential statistics plots
The following example uses the Draw option of the normCdf() function 
to plot a distribution model. 

1. On a Lists & Spreadsheet page, select the column-formula cell (second 
cell from the top) in column A. 



Using Data & Statistics 641

2. From the Statistics menu, select Distributions, and select 
Normal Cdf. 

3. Enter the plot parameters into the Normal Cdf wizard.

4. Click the Draw check box to see the distribution plotted and shaded 
in Data & Statistics. 

Note: The Draw option is not available for all distributions.

5. Select OK.
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Exploring inferential statistics plots
After drawing the plot in the previous example, you can explore the 
effect of changing the upper bound.

On the Data & Statistics plot, drag the vertical line that represents the 
upper bound toward the left or right.

As you drag, the formula is updated and the shaded area is 
recalculated.
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Using Notes

The Notes application lets you create and share text documents using the 
TI-Nspire™ handheld and computer software. Use Notes to:

• Create study notes to reinforce learning, demonstrate your 
understanding of classroom concepts, and to review for exams.

• Edit collaboratively by assigning different roles to individuals using 
your document so that any edits appear in a different text format.

• Create math expressions.

• Perform calculations using math expression boxes.

Getting started with the Notes application
To add a blank Notes page to an existing or new document:

• In a new document, select Add Notes from the menu.

• In an existing document, select Notes from the Insert menu

• From a handheld, click  to open a new document with a notes 
page or add a notes page to an open document.

The Notes work area is displayed in Default mode.

Using the Notes menu
Options on the Notes menu enable you to:

• Perform actions such as evalulate and approximate expressions

• Select a template:

– Q&A for questions and answers

– Proof for an outline structure containing statements and reasons
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– Default for freeform text entry

• Insert math expressions, shapes, comments, or images

• Format the text in a note

• Customize a math expression 

• Perform calculations

Opening Notes
On your desktop, the Notes menu icons are displayed in Documents 

Toolbox panel. With the Notes application active, click  to open the 
Notes menu.

On a handheld, press b to open the Notes menu.
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À Notes tool menu – This menu is available anytime you are in the Notes 
work area.

Á Notes work area -- The area where you enter and format text.

Using templates
Use the options on the Templates menu to select a format for your Notes 
page. 

Menu 
Name

Menu Option Function

 2: Templates

 1: Q&A
Creates a template to enter 
question and answer text.

 2: Proof
Creates a template to enter 
statement and reason text.

 3: Default
Lets you enter freeform text.

4:Hide Answer (Q&A)
Toggles to show or hide the 
Answer in a Q&A format.

À

Á
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Selecting a template
Complete the following steps to select and apply a template:

1. From the Notes menu, click .

2. From the drop-down menu, select the template you want to apply.

Handheld: From the Notes work area, press b, then press ¢ to 
display the menu options.

The Notes page is displayed in the format you selected.

Using the Q&A template
Use the Q&A template to create questions and answers. You can show or 
hide the answer so you can create questions for review and hide the 
answers. When you use the document as a study aid, you can verify that 
your answers are correct.

Press e to move the text cursor between the Question and Answer 
areas of the template.

Using the proof template
The proof template provides an outline structure for statements and 
corresponding reasons.

Press e to move the text cursor between the Statements and Reasons 
areas of the template.
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Formatting text in Notes
Use the formatting tools on the Text options menu to specify bold, italic, 
underlined, subscript, or superscript text.

Menu 
Name

Menu Option Function

4: Format

2: Bold
Toggles the selected text between 
bold and not bold, and removes all 
other formatting.

3: Italic
Toggles the selected text between 
italic and not italic, and removes all 
other formatting.

4: Underline
Toggles the selected text between 
underlined and not underlined, and 
removes all other formatting.

5: Subscript
Toggles the selected text between 
subscripted and not subscripted, and 
removes all other formatting.

6: Superscript
Toggles the selected text between 
superscripted and not superscripted, 
and removes all other formatting.
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Selecting text
Select the text.

– Drag from the starting point to the ending point to select the text.

– Handheld: If you are using the Q&A or Proof template, press e 
to place the cursor in the area containing the text. Use the 
touchpad to place the cursor at the start or end of the text to be 
selected. Hold down g, and use the touchpad to select the 
text.

Applying a text format
To apply a text format, select the text in the Notes work area, then do 
the following:

– On the Format menu, select the name of the format to apply.

– Handheld: Press b to display the Notes menu. On the Format 
menu, select the name of the format to apply.

Note: You can restore the text to normal by reapplying the same 
format.

Using color in Notes

When working in the Notes application on a desktop, use the  (fill 

color) or the  (text color) options on the Documents workspace tool 
bar to emphasize words, calculations, and formulas.

You can also apply color to text when working in the Notes application 
on the TI-Nspire™ CX handheld.

Note: If you transfer a document that contains color to a TI-Nspire™ 
handheld, the colors are converted to gray scale.
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Changing text colors
By default, Notes text is black. Complete the following steps to change 
the color of the text.

1. Select the text you want to change to another color. You can select a 
sentence, a phrase, a word, or a single letter. You can also select a 
calculation or a formula.

2. From the Documents workspace tool bar, click .

From a handheld, press ~, then select Edit > Text Color.

3. When the Text Color palette is displayed, click a color to apply it to 
the selected text.

Applying a background color
Use a background color to emphasize text in a note by using the fill color 
tool to apply a background color. Complete the following steps to apply 
a background color.

1. Select the text you want to highlight with a background color.

2. From the Documents workspace tool bar, click .

From a handheld, press ~, then select Edit > Fill Color.

3. When the Fill Color palette is displayed, click a color to apply it to the 
selected area.

Inserting Images
When working in the Notes application on a desktop, use the Images 
option on the Insert menu to add an image to a Notes page.

Note: The option for inserting an image is not available when working 
on a handheld. However, you can transfer a file containing an image 
from your computer to a TI-Nspire™ CX handheld and colors are 
retained. If transferred to a TI-Nspire™ handheld, the colors in the image 
are converted to gray scale.

1. Select Insert > Image from the Documents workspace tool bar. The 
Insert Image window opens.

2. Navigate to the folder where the image is located.

3. Select the image, then click Open to insert the image into the Notes 
work area. Valid files types are .jpg, .png, or .bmp.

4. To type text around the image, place the cursor in front of the image 
or after the image, then type the text.
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Resizing an image
Complete the following steps to resize an image.

1. Click on the image to select it.

2. Move the mouse pointer to the edge of the image. The pointer 
changes to a left-right arrow symbol.

3. Click the mouse and hold to enable the { tool, then drag the image 
to make it smaller or larger.

4. Release the mouse button when the image is sized correctly.

For detailed information about inserting images, refer to the Using 
Images chapter.

Inserting math expressions, shapes, or comments
When working with the Notes application on a handheld, open the Insert 
menu to insert a math expression, shape, or a comment.

Inserting comments
You can insert Teacher or Reviewer comments into a Notes application. 
Comments are easy to distinguish from the original text.

1. Define the type of comments you’re inserting (Teacher or Reviewer):

– On the Insert menu, select Comment, and then select Teacher or 
Reviewer.

Menu 
Name

Menu Option Function

3: Insert

1: Math Box - / M
Lets you insert a math 
expression.

2: Shape
Marks the selected text as an 
angle, triangle, circle, line, 
segment, ray, or vector.

3: Comment
Lets you enter text that is 
italicized and prefaced with 
Teacher or Reviewer.
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– Handheld: While in the Notes work area, press b to display the 
Notes menu. Press Insert > Comment, and then either Teacher or 
Reviewer.

2. Enter your text.

Text that you enter appears in italics.

Inserting geometric shape symbols
You can use geometric shape symbols to designate selected text as 
geometric objects, such as an angle, circle, or line segment.

To insert a shape symbol, position the cursor where you want it, then 
do the following:

– On the Insert menu, select Shapes, and then select the shape to 
apply.

– Handheld: Press b to display the Notes menu. On the Insert 
menu, select Shapes, and then select the shape to apply.
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Entering math expressions
You can include math expressions in Notes text, using the same tools as in 
other TI-Nspire™ applications. 

Math expression boxes have attributes that allow you to control how the 
expression displays.

Entering an expression
1. In the Notes work area, place the cursor where you want the 

expression. Then do the following:

– Windows®: On the Insert menu, select Math Expression Box or 
Ctrl + M.

– Macintosh®: Press ì“+ M.

Menu 
Name

Menu Option Function

 5: Math Box Options

1: Math Box Attributes

When a math box is selected, 
this option opens a dialog box 
allowing you to customize the 
math box. You can hide or 
show input or output, turn off 
calculation for the box, insert 
symbols, change display and 
angle settings, and allow or 
disallow the wrapping of 
expressions and the display of 
warning indicator after they 
have been dismissed. You can 
change the attributes of 
multiple selected math boxes 
at the same time.

2: Show Warning Info
Displays a warning indicator 
after the warning has been 
dismissed.

3: Show Error
Displays an error after the 
error has been dismissed.
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– Handheld: Press b to display the Notes menu. On the Insert 
menu, select Math Expression Box.

2. Type the expression. You can use the Catalog, if necessary, to insert a 
function, command, symbol, or expression template.

Evaluating and approximating math expressions
You can evaluate or approximate one or more expressions and display 
the results. You can also convert selected text and multiple math 
expression boxes into a single math expression box. Notes automatically 
updates expressions and any variables used.

Evaluating or approximating an expression
To evaluate or approximate an expression, place the cursor anywhere 
in the math expression box and then do the following:

– Windows®: On the Actions menu, select Evaluate or 
Approximate. You can also use Enter to evaluate or Ctrl + Enter 
to approximate. 

– Macintosh®: Press “ + Enter to approximate.

Menu 
Name

Menu Option Function

 1: Actions

 1: Evaluate - ·
Evaluates the expression.

2: Approximate / · Approximates the expression.

 3: Evaluate and replace
Replaces the selected part of 
the expression with the result.

4: Deactivate
Deactivates the current or 
selected item (box or boxes)

 5: Deactivate All
Deactivates all boxes in the 
current Notes application.

 6: Activate Activates the current or 
selected previously 
deactivated item.

7: Activate All
Activates all boxes in the 
current Notes application.
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– Handheld: Press b to display the Notes menu. On the Actions 
menu, select Evaluate.

The result replaces the expression. 

Evaluating part of an expression
To evaluate part of an expression, select the text or part of the math 
expression. Then do the following:

– On the Actions menu, select Evaluate and Replace.

– Handheld: Press b to display the Notes menu. On the Actions 
menu, select Evaluate Selection.

The result replaces the selected part only.

Breaking long calculations
Some calculations may take a long time. Notes indicates that the 
handheld is performing a long calculation by displaying a busy icon. If a 
calculation is taking more time than you want to spend, you can end the 
calculation. 

To stop the function or program in progress, do the following:

– Windows®: Hold down the F12 key and press Enter repeatedly.

– Macintosh®: Hold down the F5 key and press Enter repeatedly.

– Handheld: Hold down the c key and press · repeatedly.

Showing warnings and errors
If a calculation in Notes results in a warning or error, you can view the 
warning or error again even after you have dismissed the dialog box.

To display a warning or error in Notes after you have dismissed the dialog 
box, do one of the following:

– Windows®: Right-click and select Show warning info or Show 
error.

– Macintosh®: ì“ + click and select Show warning info or Show 
error.

Note: You can change your settings so that warnings do not appear at 
all. The showing of warning indicators is controlled by the Math Box 
Attributes dialog box. See Changing the attributes of math expression 
boxes.
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Converting selected items to math expression boxes
To convert items to math expression boxes, first select the text, or 
combination of text and existing math expression box, to evaluate. 
Then do the following:

– On the Actions menu, select Convert to Math Expression Box. Or 
right-click and select Convert to Math Expression Box.

– Handheld: Press b to display the Notes menu, and then press 
Actions > Convert to Math Expression Box.

The result replaces the selected part only.

Deactivating math expression boxes
Calculations are by default activated, which means that results 
automatically update when you evaluate or approximate an expression. 
If you don’t want results to automatically update, you can deactivate a 
math expression box, group of boxes, or the entire application.

Deactivating a box or a group of boxes
To deactivate a box or a group of boxes, do the following:

1. Select the box or boxes that you want to deactivate.

2. Deactivate the selected box or boxes:

– Windows®: Select Actions > Deactivate or right-click and select 
Actions > Deactivate.

– Macintosh®: Select Actions > Deactivate or ì“ + click and select 
Actions > Deactivate.

– Handheld: Press b to display the Notes menu. On the Actions 
menu, select Deactivate.

Note: You can manually update a deactivated box or boxes by 
selecting the box or boxes and using the process described in 
Evaluating and approximating math expressions.

Deactivating all boxes in the Notes application
To deactivate all boxes in the Notes application, do the following:

With a document open, place your cursor in the Notes application 
that you want to deactivate and select Deactivate All.

– Windows®: Select Actions > Deactivate All or right-click and 
select Actions > Deactivate All.

– Macintosh®: Select Actions > Deactivate or ì“+ click and select 
Actions > Deactivate.
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– Handheld: Press b to display the Notes menu. On the Actions 
menu, select Deactivate.

Note: When you use this option in Q&A and Proof templates, 
Deactivate All deactivates only the math boxes in the current work 
area.

Changing the attributes of math expression boxes
You can change attributes in one or more math expression boxes at the 
same time. Controlling the attributes in math expression boxes allows 
you to do the following:

• Show or hide the input or output, or prevent calculation in the 
box.

• Select a symbol separator using Insert Symbol.

• Choose the number of digits to display in the output of a math 
expression.

• Select angle settings so you can use both radian/degree and 
gradian angle measures in the same Notes application.

• Select whether to allow math expressions to wrap.

• Select whether to show or hide warning indicators.

To change the attributes of one or more boxes, do the following:

1. Select the box or boxes that you want to change.

2. On the Math Box Options menu, select Math Box Attributes.

3. Use the drop-down menus or selection boxes to make your selections.

4. Click OK to save or Cancel to abandon the change.

Note: Math expression boxes recalculate automatically after you have 
made attribute changes and saved the changes.

Undoing changes to math expression boxes
To undo changes you have made to a math expression box, click 
/ Z.

Using calculations in Notes
In the Notes application, the options on the Calculations menu enable 
you to perform calculations. The calculations are described in the 
following table.
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Important information to know
• Notes does not support editing programs. Use Program Editor 

instead.

• Notes does not support executing Lock or Unlock commands. Use 
Calculator instead.

• Notes does not display intermediate results obtained via "Disp" 
command. Use Calculator instead.

• Notes does not support user-defined dialog boxes obtained via 
"Request," "RequestStr," or "Text" commands. Use Calculator 
instead.

• Notes does not support the execution of multiple statistics commands 
that produce stat. variables.

Menu 
Name

Menu Option Function

 6: Calculations

1: Define Variables
Define a variable in a Note 
using the Calculator 
application.

2: Number
Use tools from the Calculator 
Number menu, including 
Convert to Decimal, 
Approximate to Fraction, 
Factor, Least Common 
Multiple, Greatest Common 
Divisor, Remainder, Fraction 
Tools, Number Tools, and 
Complex Number Tools.

3: Algebra
Use tools from the Calculator 
Algebra menu, including 
Numerical Solve, Solve System 
of Linear Equations, 
Polynomial Tools.
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4: Calculus
Use tools from the Calculus 
menu including Numerical 
Derivative at a Point, 
Numerical Definite Integral, 
Sum, Product, Numerical 
Function Minimum, and 
Numerical Function 
Maximum.

3 (CAS): Algebra
Use tools from the Calculator 
Algebra menu, including 
Solve, Factor, Expand, Zeros, 
Numerical Solve, Solve System 
of Equations, Polynomial 
Tools, Fraction Tools, Convert 
Expressions, Trigonometry, 
Complex, and Extract.

4 (CAS): Calculus
Use tools from the Calculus 
menu including Derivative, 
Derivative at a Point, Integral, 
Limit, Sum, Product, Function 
Minimum, Function 
Maximum, Tangent Line, 
Normal Line, Arc Length, 
Series, Differential Equation 
Solver, Implicit 
Differentiation, and 
Numerical Calculations

5: Probability
Use tools from the Calculator 
Probability menu, including 
Factorial, Permutations, 
Combinations, Random, and 
Distributions.

6: Statistics
Use tools from the Calculator 
Statistics menu, including Stat 
Calculations, Stat Results, List 
Math, List Operations, and 
others.



Using Notes 659

Using hints on the handheld
On the handheld, use the Hints option to access quick tips for performing 
tasks.

1. From the Notes application, press b, then select Hints. The Hints 
dialog box opens.

2. Use the scroll bar to move through the hints.

3. Click OK to close the dialog box.

Exploring Notes with examples
This section shows you how the Notes application works with other 
applications to automatically update results.

7: Matrix & Vector
Use tools from the Calculator 
Matrix & Vector menu, 
including Create, Transpose, 
Determinant, Row-Echelon 
Form, Reduced Row-Echelon 
Form, Simultaneous, and 
others.

8: Finance
Use tools from the Calculator 
Finance menu, including 
Finance Solver, TVM 
Functions, Amortization, Cash 
Flows, Interest Conversions, 
and Days between Dates.

Note: For more information about performing Calculator 
functions, please see the topics in the Calculator 
documentation.
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Example #1: Using Notes to explore roots of a quadratic 
function
1. Open a new document and start the Notes application.

2. Define a function in a math box, evaluate, and hide the output using 
the Math Box attributes.

3. Type some more text; for example: “Real Roots of f1(x) are:”

4. In a new math box, type: polyRoots(f1(x),x).

5. Press · and hide the input of this math box by using the Math Box 
attributes dialog box.

6. Use the Page Layout toolbar icon to select the split layout.

7. Add the Graph application and plot f1(x).
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See how the roots of f1 change when the function is modified in 
Graph.

Example #2: Using Notes to explore data sampling
In this example, we create a sampling distribution of sample means 
drawn from a given population. We will be able to watch the sampling 
distribution take shape for a given sample size and describe its 
characteristics. You can change the population and the sample size.

1. Set up the population and the sample size.

a) Type "Create sample data:"

b) Insert a math expression box and define the population. For 
example, type "population:=seq(n,n,1,50)".

c) Press · and hide the output using the Math Expression Box 
Attributes dialog box.

d) Insert a math expression box and define the sample size. For 
example, type "size:=5".

e) Press · and hide the output using the Math Expression Box 
Attributes dialog box.

2. Set up the initialization.

a) Type "Start taking samples:"

b) Insert a math expression box and set the initial values for the 
number of samples (num) and the list of sample means 
(sampmeans). Type:

"num:=0:sampmeans:={}"

c) Press · and hide the output using the Math Expression Box 
Attributes dialog box.



662 Using Notes

d) Deactivate the math expression box using Actions > Deactivate. 
The deactivation will prevent the content of that math box from 
being overwritten when the values for num and sampmeans 
change. The deactivated math box will be shown with the light 
color background.

3. Set up Data & Statistics for the sampling.

a) Change the page layout and insert Data & Statistics.

b) Click on the horizontal axis and add sampmeans list.

c) Change the window setting: XMins=1 and XMax = 50.

d) You can also set up the plot of the mean of sample means using 
Analyze > Plot Value.

4. Enter the instructions to add data.

a) Type "Create new samples:"

b) Insert a math expression to define the sample (sample) and 
update the number of samples and the list of sample means. Type: 

"num:=num+1:sample:=randsamp(population,size):
sampmeans:=augment(sampmeans,{mean(sample)})"

c) Press ·, hide the output, and turn off the expression wrapping 
using the Math Expression Box Attributes dialog box.

d) Deactivate the math expression box using Actions > Deactivate to 
prevent the content of the math box to be overwritten when num 
and sampmeans values are reinitialized.
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e) Create math expression boxes that display the current number of 
experiments (num), sample (sample), and the list of sample means 
(sampmeans).

5. Now you are ready to explore. Add more samples by simply pressing 
· when you are in the math expression box in the "Create new 
samples" section.

Note: You can also automate the sampling process by using a 
For ... EndFor loop.
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You can also change the sample size and restart the sampling.
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Libraries

What is a library?
A library is a TI-Nspire™ document that contains a collection of variables, 
functions, and/or programs that have been defined as library objects. 

Unlike ordinary variables, functions, and programs, which can be used 
only within a single problem (the problem in which they are defined), 
library objects are accessible from any document. You can even create 
public library objects that appear in the TI-Nspire™ Catalog.

For example, suppose you have created library document matrix 
containing public library function diagwithtrace() and a private library 
function errmsg(). 

Function diagwithtrace() displays the diagonal of a square matrix and 
calculates the trace of the matrix. If its input is not a square matrix, the 
function calls errmsg(), which should then return an appropriate error 
string.

You could then use the following syntax to display the diagonal and 
calculate the trace of matrix m defined in the current problem: 

matrix\diagwithtrace(m)
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Creating libraries and library objects
A document is regarded as a library when it is saved or copied to the 
designated library folder. The default location is:

• Windows®: My Documents\TI-Nspire\MyLib.

• Macintosh®: Documents/TI-Nspire/MyLib.

• Handheld: MyLib

If the folder has been inadvertently deleted, you must create it before 
attempting to use libraries.

You can define library objects using either the Program Editor or the 
Calculator application. Library objects must be defined with a Define 
command and must reside in the first problem of a library document.

Note: If you use the Program Editor to define a library function or 
program, you must store the object and also save the document. Saving 
the document does not automatically store the object. For more 
information, see the “Programming” section of the documentation.

Naming restrictions apply to library documents and library objects.

• A library document name must be a valid variable name between 1 
and 16 characters long, and it must not contain a period or begin 
with an underscore.

• A library object name must be a valid variable name between 1 and 
15 characters long. It must not contain a period and must not begin 
with an underscore.

Private and Public library objects
When you define a library object, you designate it as private (LibPriv) or 
public (LibPub).

Define a=5
a is not a library object.

Define LibPriv b={1,2,3}
b is a private library object.

Define LibPub func1(x)=x^2 - 1
func1 is a public library object.
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A Private library object does not appear in the Catalog, but you can 
access it by typing its name. Private objects serve well as building blocks 
that perform basic, low-level tasks. Typically, private library objects are 
called upon by the public functions and programs.

A Public library object appears in the Catalog’s library tab after you 
refresh the libraries. You can access a public library object through the 
Catalog or by typing its name.

Macintosh® only: In version 1.4 of the software, a library document 
name cannot contain extended characters, such as Ö, á, or ñ.

Note: In library programs and functions defined as public, a comment 
line (©) immediately following the Prgm or Func line is automatically 
displayed as help in the Catalog. You could, for example, show a syntax 
reminder there.

Using short and long names
Anytime you are in the same problem where an object is defined, you 
can access it by entering its short name (the name given in the object’s 
Define command). This is the case for all defined objects, including 
private, public, and non-library objects.

You can access a library object from any document by typing the object’s 
long name. A long name consists of the name of the object’s library 
document followed by a backslash “\” followed by the name of the 
object. For example, the long name of the object defined as func1 in the 
library document lib1 is lib1\func1. To type the “\” character on the 
handheld, press g p.

Note: If you cannot remember the exact name or the order of arguments 
required for a private library object, you can open the library document 
or use the Program Editor to view the object. You also can use 
getVarInfo to view a list of objects in a library.

Using library objects
Before using a library variable, function, or program, make sure that 
these steps have been followed:

• The object has been defined with the Define command, and the 
command specifies either the LibPriv or LibPub attribute.

• The object resides in the first problem of a library document. The 
document must reside in the designated library folder and must meet 
the naming requirements.

• If you defined the object using the Program Editor, it has been stored 
using Check Syntax & Store from the Program Editor menu.
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• The libraries have been refreshed.

Refreshing the libraries
Refresh libraries to make the library objects available to your 
documents.

– From the Tools menu, select Refresh Libraries.

Handheld: Press / b and select Refresh Libraries.

Using a public library object
1. Refresh the libraries.

2. Open the TI-Nspire™ application in which you want to use the 
variable, function or program.

Note: All applications can evaluate functions, but only the Calculator 
and Notes applications can run programs.

3. Open the Catalog and use the library tab to find and insert the object.

4. If arguments are required, type them inside the parentheses.

Using a private library object
1. Refresh the libraries.

2. Open the TI-Nspire™ application in which you want to use the 
variable, function or program.

Note: All applications can evaluate functions, but only the Calculator 
and Notes applications can run programs.

3. Type the name of the object, such as lib1\func1(). 

In case of a function or program, always follow the name with 
parentheses. To type the “\” character on the handheld, press 
g p.

4. If arguments are required, type them inside the parentheses.

Creating shortcuts to library objects
You can make the objects in a library more easily accessible by using 
libShortcut() to create shortcuts to them. This creates a variable group in 
the current problem that contains references to all the objects in the 
specified library document. You can choose to include or exclude the 
private library objects.
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For example, suppose the library document linalg contains functions 
named clearmat, cofactor, gausstep, help, inversestep, kernelbasis, rank, 
and simultstep. Executing libShortcut(“linalg”,“la”) would create a 
variable group containing the following members:

la.clearmat
la.cofactor
la.gausstep
la.help
la.inversestep
la.kernelbasis
la.rank
la.simultstep

You can refer to those library objects from within the current problem by 
typing their variable names or by selecting them from the Variables 
menu.

For details and an example of using libShortcut(), refer to the Reference 
Guide.

Included libraries
To help you get started with libraries, the TI-Nspire™ Software 
installation includes a library document with useful Linear Algebra 
functions. The library is named linalg or linalgCAS and is installed in the 
designated library folder.

Note: Updating the handheld’s operating system or reinstalling the 
computer software places all included libraries in the default folder. If 
you have edited an object in an included library or replaced an included 
library with your own document of the same name, updating or 
reinstalling will overwrite your changes. This could also happen after 
batteries are replaced or the handheld system is reset.

Restoring an included library
If you inadvertently delete or overwrite an included library, you can 
restore it from the installation DVD.

1. Open the DVD, and navigate to the libs folder.

2. Identify the library file to restore, such as linalg.tns or linalgCAS.tns 
for the linear algebra library.

3. Copy the file.

– Windows®: Copy the file to your designated library folder. The 
default location is My Documents\TI-Nspire\MyLib.
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– Macintosh®: Copy the file to your designated library folder. The 
default location is Documents/TI-Nspire/MyLib.

– Handheld: Connect the handheld to your computer, open the 
TI-Nspire™ Computer Link Software, and copy the library file to 
the handheld’s MyLib folder.

4. Activate the new library objects.

– From the TI-Nspire™ Software Tools menu, select Refresh 
Libraries.

Handheld: Press / b, and select Refresh Libraries.

Changing the library folder location (computer 
only)
You can change the location of the designated library folder from the 
default MyLib folder to any folder on your local drive or network.

1. On the File menu, select Settings > Keypad Options. 
(For TI-Nspire™ Teacher Software, click File > Settings > 
SmartView Options.)

2. In the Options dialog box, click Browse, and then navigate to the 
folder that you want to designate.

3. Select the folder, and then click OK.

4. In the Options dialog box, click OK to change to the selected folder.

Notes: 

• Changing the designated folder does not automatically move the 
library documents to the new folder. To make the objects in your 
library documents accessible, you must move the documents into the 
new folder and then refresh the libraries.
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• The location of the designated folder is determined during software 
installation. By default, this folder is:

– Windows®: My Documents\TI-Nspire\MyLib.

– Macintosh®: Documents/TI-Nspire/MyLib.
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Programming

You can create user-defined functions or programs by typing definition 
statements on the Calculator entry line or by using the Program Editor. 
The Program Editor offers some advantages, and it is covered in this 
section. For information on defining programs and functions in 
Calculator, see the “Calculator” chapter.

Overview of the Program Editor
The Program Editor helps you define, edit, and manage user-defined 
functions and programs. 

• The editor has programming templates and dialog boxes to help you 
define functions and programs using correct syntax.

• The editor lets you enter multiple-line programming statements 
without requiring a special key sequence to add each line.

• You can easily create private and public library objects (variables, 
functions, and programs). For details, see the “Libraries” chapter.

• The editor is accessible from the main Insert menu as well as from the 
Calculator’s Functions & Programs menu.

À Program Editor menu – This menu is available anytime you are in the 
Program Editor work area using the Normal view mode. On the 
handheld, press b to display the menu.

Á

Â

À
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Á Program Editor work area

Â Status line shows line number information and the name of the 
function or program being edited. An asterisk (*) indicates that this 
function is “dirty,” which means that it has changed since the last 
time its syntax has been checked and it has been stored.

Program Editor menu

Actions

New Displays a dialog box for defining a new 
function or program.

Open Lets you open an existing library function 
or program for editing.

Import Imports a program or function from a 
library.

View Lets you view (and optionally, edit) an 
existing library function or program.

Create Copy Lets you copy the current function or 
program.

Rename Lets you rename the current function or 
program.

Change Library Access Lets you change the access level of a 
library object to private (LibPriv), public 
(LibPub), or none.

Insert Comment Inserts a comment (©) at the cursor 
position.

Find Displays a dialog box for text search.

Find and Replace Lets you find and, optionally, replace 
occurrences of specified text.

Go to Line Moves the cursor to a specified line 
number.

Go Back Lets you easily return from the Program 
Editor to the Calculator or Notes 
application after a runtime error occurs.

Close Closes the current function or program.
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Check Syntax & 
Store

Check Syntax & Store Finds syntax errors and tries to put the 
cursor near the first error. If no errors, 
stores current function or program.

Check Syntax Finds syntax errors and tries to put the 
cursor near the first error.

Define Variables

Local Inserts Local.

Define Inserts Define.

Delete Variable Inserts DelVar.

Func...EndFunc Inserts Func...EndFunc template.

Prgm...EndPrgm Inserts Prgm...EndPrgm template.

Lock Inserts Lock, unLock, or getLockInfo().

Control

If Inserts If statement.

If...Then...EndIf Inserts If...Then...EndIf template.

If...Then...Else...EndIf Inserts If...Then...Else...EndIf template.

ElseIf...Then Inserts ElseIf...Then template.

For...EndFor Inserts For...EndFor template.

While...EndWhile Inserts While...EndWhile

template.

Loop...EndLoop Inserts Loop...EndLoop

template.

Try...Else...EndTry Inserts Try...Else...EndTry template.

ClrErr Inserts ClrErr.

PassErr Inserts PassErr.
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Inserts variable name .

Inserts ().

Transfer

Return Inserts return().

Cycle Inserts Cycle.

Exit Inserts Exit.

Lbl Inserts Lbl (label).

Go to Lbl Inserts Goto.

Stop Inserts Stop.

Input/Output

Disp Inserts the Disp (display) command.

Inserts the  command.

Inserts the  command.

Inserts the  command.

Mode

Display Digits Lets you select from several Float and Fix 
settings.

Angle Lets you select Degrees, Radians, or 
Gradians.

Exponential Format Lets you select Normal, Scientific, or 
Engineering.

Real or Complex Lets you select Real, Rectangular, or Polar.

Auto or Approx CAS: Lets you select Auto, Approximate, 
or Exact results.

Control
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Defining a program or function

Starting a new Program Editor
1. To start the editor from a Calculator page,

– From the Insert menu, select Program Editor, and select New.

Handheld: Press b 9 1 1.

2. To start the editor when not on a Calculator page,

– From the Insert menu, select Program Editor, and select New.

Handheld: Press / b 4 8 1.

3. Type a name for the function or program you are defining.

4. Select the Type (Program or Function).

5. Set the Library Access:

– To use the function or program only from the current document 
and problem, select None.

– To make the function or program accessible from any document 
but not visible in the Catalog, select LibPriv.

Vector Format Lets you select Rectangular, Cylindrical, or 
Spherical.

Base Lets you select Decimal, Hex, or Binary.

CAS: Unit System Lets you select SI or Eng/US.

GetMode Inserts getMode().

Get Language Info Inserts getLangInfo().

Mode
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– To make the function or program accessible from any document 
and also visible in the Catalog, select LibPub (Show in Catalog). 
For details, see the “Libraries” chapter.

6. Click OK.

A new instance of the Program Editor opens, with a template 
matching the selections you made.

Entering lines into a function or program
The Program Editor does not execute the commands or evaluate 
expressions as you enter them. They are executed only when you 
evaluate the function or run the program.

1. If your function or program will require the user to supply arguments, 
type parameter names in the parentheses that follow the name. 
Separate parameters with a comma.

2. Between the Func and EndFunc (or Prgm and EndPrgm) lines, enter 
the lines of statements that make up your function or program.

– You can either type the names of functions and commands or 
insert them from the Catalog. 

– A line can be longer than the width of the screen; if so, you might 
have to scroll to view the entire statement.
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– After typing each line, press ·. This inserts a new blank line 
and lets you continue entering another line. 

– Use the ¡, ¢, £, and ¤ arrow keys to scroll through the function 
or program for entering or editing commands.

Inserting comments
A comment symbol (©) lets you enter a remark. Comments can be useful 
to someone viewing or editing the program. Comments do not display 
when the program runs, and they have no effect on program flow.

À Comment showing required syntax. Because this library object is 
public and this comment is the first line in a Func or Prgm block, the 
comment displays in the Catalog as help. For details, see the 
“Libraries” chapter.

To insert a comment:

1. Position the cursor at the end of the line where you want to insert a 
comment.

2. From the Actions menu, select Insert Comment.

3. Type the text of the comment after the © symbol.

Checking syntax
The Program Editor lets you check the function or program for correct 
syntax.

From the Check Syntax & Store menu, select Check Syntax.

If the syntax checker finds any syntax errors, it displays an error 
message and tries to position the cursor near the first error so you can 
correct it.

Define LibPub volcyl(ht,r) =
Prgm
©volcyl(ht,r) => volume of cylinder À 
Disp “Volume =”, approx(p ¦ r2 ¦ ht)

©This is another comment.
EndPrgm
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Storing the function or program
You must store your function or program to make it accessible. The 
Program Editor automatically checks the syntax before storing.

An asterisk (*) is displayed in the upper left corner of the Program Editor 
to indicate that the function or program has not been stored.

From the Check Syntax & Store menu, select Check Syntax & Store.

If the syntax checker finds any syntax errors, it displays an error 
message and tries to position the cursor near the first error.

If no syntax errors are found, the message “Stored successfully“ is 
displayed in the status line at the top of the Program Editor.

Note: If the function or program is defined as a library object, you must 
also save the document in the designated library folder and refresh 
libraries to make the object accessible to other documents. For details, 
see the “Libraries” chapter.

Viewing a program or function
1. From the Actions menu, select View.

2. If the function or program is a library object, select its library from the 
Location list.

3. Select the function or program name from the Name list.
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The function or program displays in a viewer.

4. Use the arrow keys to view the function or program.

5. If you want to edit the program, click Edit.

Note: The Edit selection is available only for functions and programs 
defined in the current problem. To edit a library object, you must first 
open its library document.

Opening a function or program for editing
You can open a function or program from the current problem only.

Note: You cannot modify a locked program or function. To unlock the 
object, go to a Calculator page and use the unLock command.

1. Display the list of available functions and programs.

– From the Actions menu, select Open.

2. Select the item to open.

Importing a program from a library
You can import a function or program defined as a library object into a 
Program Editor within the current problem. The imported copy is not 
locked, even if the original is locked.

1. From the Actions menu, select Import.
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2. Select the Library Name.

3. Select the Name of the object.

4. If you want the imported object to have a different name, type the 
name under Import As.

Creating a copy of a function or program
When creating a new function or program, you might find it easier to 
start with a copy of the current one. The copy that you create is not 
locked, even if the original is locked.

1. From the Actions menu, select Create Copy.

2. Type a new name, or click OK to accept the proposed name.

3. If you want to change the access level, select Library Access, and 
select a new level.

Renaming a program or function
You can rename and (optionally) change the access level of the current 
function or program.

1. From the Actions menu, select Rename.

2. Type a new name, or click OK to accept the proposed name.
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3. If you want to change the access level, select Library Access, and 
select a new level.

Changing the library access level
1. From the Actions menu, select Change Library Access.

2. Select the Library Access:

– To use the function or program only from the current Calculator 
problem, select None.

– To make function or program accessible from any document but 
not visible in the Catalog, select LibPriv.

– To make the function or program accessible from any document 
and also visible in the Catalog, select LibPub.

Finding text
1. From the Actions menu, select Find.

2. Type the text that you want to find, and click OK.

– If the text is found, it is highlighted in the program.

– If the text is not found, a notification message displays.

Finding and replacing text
1. From the Actions menu, select Find and Replace.
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2. Type the text that you want to find.

3. Type the replacement text.

4. Click Replace to replace the first occurrence after the cursor position, 
or click Replace All to replace every occurrence.

Note: If the text is found in a math template, a message is displayed 
to warn you that your replacement text will replace the whole 
template—not just the found text.

Closing the current function or program
From the Actions menu, select Close.

If the function or program has unstored changes, you are prompted 
to check syntax and store before closing.

Running programs and evaluating functions
After defining and storing a function or program, you can use it from an 
application. All the applications can evaluate functions, but only the 
Calculator and Notes applications can run programs.

The program statements are executed in sequential order (although 
some commands alter the program flow). The output, if any, is displayed 
in the application’s work area.

• Program execution continues until it reaches the last statement or a 
Stop command.

• Function execution continues until it reaches a Return command.

• To stop a program or function manually, 

– Windows®: Hold down the F12 key and press Enter repeatedly.

– Macintosh®: Hold down the F5 key and press Enter repeatedly. 

– Handheld: Hold down the c key and press · repeatedly. 
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Using short and long names
Anytime you are in the same problem where an object is defined, you 
can access it by entering its short name (the name given in the object’s 
Define command). This is the case for all defined objects, including 
private, public, and non-library objects.

You can access a library object from any document by typing the object’s 
long name. A long name consists of the name of the object’s library 
document followed by a backslash “\” followed by the name of the 
object. For example, the long name of the object defined as func1 in the 
library document lib1 is lib1\func1. To type the “\” character on the 
handheld, press g p.

Note: If you cannot remember the exact name or the order of arguments 
required for a private library object, you can open the library document 
or use the Program Editor to view the object. You also can use 
getVarInfo to view a list of objects in a library.

Using a Public library function or program
1. Make sure you have defined the object in the document’s first 

problem, stored the object, saved the library document in the MyLib 
folder, and refreshed the libraries.

2. Open the TI-Nspire™ application in which you want to use the 
function or program.

Note: All applications can evaluate functions, but only the Calculator 
and Notes applications can run programs.

3. Open the Catalog and use the library tab to find and insert the object.

- or -

Type the name of the object. In the case of a function or program, 
always follow the name with parentheses. 

4. If the program requires you to supply one or more arguments, type 
the values or variable names inside the parentheses.

5. Press ·.

libs2\func1()

libs2\func1(34,power)
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Using a Private library function or program
To use a Private library object, you must know its long name. For 
example, the long name of the object defined as func1 in the library 
document lib1 is lib1\func1.

Note: If you cannot remember the exact name or the order of arguments 
required for a private library object, you can open the library document 
or use the Program Editor to view the object.

1. Make sure you have defined the object in the document’s first 
problem, stored the object, saved the library document in the MyLib 
folder, and refreshed the libraries.

2. Open the TI-Nspire™ application in which you want to use the 
function or program.

Note: All applications can evaluate functions, but only the Calculator 
and Notes applications can run programs.

3. Type the name of the object. In the case of a function or program, 
always follow the name with parentheses.

4. If the object requires you to supply one or more arguments, type the 
values or variable names inside the parentheses.

5. Press ·.

Running a non-library program or function
1. Make sure you are in the same problem in which the function or 

program is defined.

2. Type the name of the function or program on the entry line, or press 
h to select the name from a list.

You must always include a set of parentheses after the name.

If the function or program requires you to supply one or more 
arguments, type the values or variable names inside the parentheses.

3. Press ·.

libs2\func1()

libs2\func1(34,power)

prog1()

prog1(34,power)
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Interrupting a running program

While a function or program is running, the busy pointer } displays.

To stop the function or program,

– Windows®: Hold down the F12 key and press Enter repeatedly.

– Macintosh®: Hold down the F5 key and press Enter repeatedly. 

– Handheld: Hold down the c key and press · repeatedly. 

A message displays. To edit the function or program in the Program 
Editor, select Go To. The cursor appears at the command where the 
break occurred.

Getting values into a program
You can choose from several methods to supply the values that a 
function or program uses in calculations.

Embedding the values within the program or function
This method is useful primarily for values that must be the same each 
time the program or function is used.

1. Define the program.

2. Run the program.

Letting the user assign the values to variables
A program or function can refer to variables created beforehand. This 
method requires users to remember the variable names and to assign 
values to them before using the object.

1. Define the program.
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2. Supply the variables, and then run the program.

Letting the user supply the values as arguments
This method lets users pass one or more values as arguments within the 
expression that calls the program or function. 

The following program, , calculates the volume of a cylinder. It requires 
the user to supply two values: height and radius of the cylinder.

1. Define the  program.

2. Run the program to display the volume of a cylinder with a height of 
34 mm and a radius of 5 mm.

Note: You do not have to use the parameter names when you run the  
program, but you must supply two arguments (as values, variables, or 
expressions). The first must represent the height, and the second must 
represent the radius.

Requesting the values from the user (programs only)
You can use the  and  commands in a program to make the program 
pause and display a dialog box prompting the user for information. This 
method does not require users to remember variable names or the order 
in which they are needed.

You cannot use the  or command in a function.

1. Define the program.

 (height,radius) =

 "Volume =", (p ¦ radius2 ¦ height)

(34,5) Volume = 534.071

 "Width: ",
 "Height: ",
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2. Run the program and respond to the requests.

Use  instead of  when you want the program to interpret the user’s 
response as a character string rather than a math expression. This avoids 
requiring the user to enclose the response in quotation marks (““).

Displaying information
A running function or program does not display intermediate calculated 
results unless you include a command to display them. This is an 
important difference between performing a calculation on the entry line 
and performing it in a function or program.

The following calculations, for example, do not display a result in a 
function or program (although they do from the entry line).

Displaying information in the history
You can use the  command in a program or function to display 
information, including intermediate results, in the history.

Displaying information in a dialog box
You can use the  command to pause a running program and display 
information in a dialog box. The user selects  to continue or selects  to 
stop the program. 

You cannot use the  command in a function.

Width: 3 (3 entered as a response)
Height: 23.64 (23.64 entered as a response)

©
:=12¦6
(p/4) ©

©
 12¦6
 "Result:",(p/4)
©

©
 "Area=" & 
©
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Note: Displaying a result with  or  does not store that result. If you 
expect to refer later to a result, store it to a global variable.

Using local variables
A local variable is a temporary variable that exists only while a user-
defined function is being evaluated or a user-defined program is 
running.

Example of a local variable
The following program segment shows a For...EndFor loop (which is 
discussed later in this module). The variable i is the loop counter. In most 
cases, the variable i is used only while the program is running.

À Declares variable i as local.

Note: When possible, declare as local any variable that is used only 
within the program and does not need to be available after the program 
stops.

What causes an undefined variable error message?
An Undefined variable error message displays when you evaluate a user-
defined function or run a user-defined program that references a local 
variable that is not initialized (assigned a value). 

For example:

À Local variable m is not assigned an initial value.

©
(p/4)&maximum
 maximum
©

Local i À 
For i,0,5,1
Disp i

EndFor
Disp i

Define fact(n)=Func
Local m À 
While n>1

n¦m&m: n–1&n
EndWhile
Return m
 EndFunc
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Initialize local variables
All local variables must be assigned an initial value before they are 
referenced.

À 1 is stored as the initial value for m.

Note (CAS): Functions and programs cannot use a local variable to 
perform symbolic calculations.

CAS: Performing symbolic calculations
If you want a function or program to perform symbolic calculations, you 
must use a global variable instead of a local. However, you must be 
certain that the global variable does not already exist outside of the 
program. The following methods can help.

• Refer to a global variable name, typically with two or more 
characters, that is not likely to exist outside of the function or 
program.

• Include DelVar within a program to delete the global variable, if it 
exists, before referring to it. (DelVar does not delete locked or linked 
variables.)

Differences between functions and programs
A function defined in the Program Editor is similar to the functions built 
into the TI-Nspire™ Software.

• Functions must return a result, which can be graphed or entered in a 
table. Programs cannot return a result.

• You can use a function (but not a program) within an expression. For 
example: 3 ¦ func1(3) is valid, but not 3 ¦ prog1(3).

• You can run programs from Calculator and Notes applications only. 
However, you can evaluate functions in Calculator, Notes, Lists & 
Spreadsheet, Graphs & Geometry, and Data & Statistics.

Define fact(n)=Func
Local m: 1&m À 
While n>1

n¦m&m: n–1&n
EndWhile
Return m
EndFunc
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• A function can refer to any variable; however, it can store a value to a 
local variable only. Programs can store to local and global variables.

Note: Arguments used to pass values to a function are treated as 
local variables automatically. If you want to store to any other 
variables, you must declare them as Local from within the function.

• A function cannot call a program as a subroutine, but it can call 
another user-defined function.

• You cannot define a program within a function.

• A function cannot define a global function, but it can define a local 
function.

Calling one program from another
One program can call another program as a subroutine. The subroutine 
can be external (a separate program) or internal (included in the main 
program). Subroutines are useful when a program needs to repeat the 
same group of commands at several different places.

Calling a separate program
To call a separate program, use the same syntax that you use to run the 
program from the entry line.

Defining and calling an internal subroutine
To define an internal subroutine, use the Define command with 
Prgm...EndPrgm. Because a subroutine must be defined before it can be 
called, it is a good practice to define subroutines at the beginning of the 
main program.

An internal subroutine is called and executed in the same way as a 
separate program.

Define subtest1()=
Prgm
For i,1,4,1

subtest2(i,i¦1000)
EndFor

EndPrgm 

Define subtest2(x,y)=
Prgm

Disp x,y
EndPrgm 
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À Declares the subroutine as a local variable.

Á Defines the subroutine.

Â Calls the subroutine.

Note: Use the Program Editor’s Var menu to enter the Define and 
Prgm...EndPrgm commands.

Notes about using subroutines
At the end of a subroutine, execution returns to the calling program. To 
exit a subroutine at any other time, use Return with no argument.

A subroutine cannot access local variables declared in the calling 
program. Likewise, the calling program cannot access local variables 
declared in a subroutine.

Lbl commands are local to the programs in which they are located. 
Therefore, a Goto command in the calling program cannot branch to a 
label in a subroutine or vice versa.

Avoiding circular-definition errors
When evaluating a user-defined function or running a program, you can 
specify an argument that includes the same variable that was used to 
define the function or create the program. However, to avoid circular-
definition errors, you must assign a value for variables that are used in 
evaluating the function or running the program. For example:

– or –

Define subtest1()=
Prgm
local subtest2 À 
Define subtest2(x,y)= Á 
Prgm

Disp x,y
EndPrgm
©Beginning of main program
For i,1,4,1

subtest2(i,I*1000) Â 
EndFor
EndPrgm

x+1&x À 
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À Causes a Circular definition error message if x or i does not have a 
value. The error does not occur if x or i has already been assigned a 
value.

Controlling the flow of a function or program
When you run a program or evaluate a function, the program lines are 
executed in sequential order. However, some commands alter the 
program flow. For example:

• Control structures such as If...EndIf commands use a conditional test 
to decide which part of a program to execute.

• Loop commands such as For...EndFor repeat a group of commands.

Using If, Lbl, and Goto to control program flow
The If command and several If...EndIf structures let you execute a 
statement or block of statements conditionally, that is, based on the 
result of a test (such as x>5). Lbl (label) and Goto commands let you 
branch, or jump, from one place to another in a function or program.

The If command and several If...EndIf structures reside on the Program 
Editor’s Control menu.

When you insert a structure such as If...Then...EndIf, a template is 
inserted at the cursor location. The cursor is positioned so that you can 
enter a conditional test.

If command
To execute a single command when a conditional test is true, use the 
general form:

À Executed only if x>5; otherwise, skipped.

Á Always displays the value of x.

In this example, you must store a value to x before executing the 
If command.

For i,i,10,1
Disp i À 

EndFor

If x>5
Disp "x is greater than 5" À 

Disp x Á 
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If...Then...EndIf structures
To execute one group of commands if a conditional test is true, use the 
structure:

À Executed only if x>5. 

Á Displays the value of:
2x if x>5
x if x{5

Note: EndIf marks the end of the Then block that is executed if the 
condition is true.

If...Then...Else...EndIf structures
To execute one group of commands if a conditional test is true and a 
different group if the condition is false, use this structure:

À Executed only if x>5.

Á Executed only if x{5.

Â Displays value of:
2x if x>5 
5x if x{5

If...Then...ElseIf... EndIf structures
A more complex form of the If command lets you test for multiple 
conditions. Suppose you want a program to test a user-supplied 
argument that signifies one of four options. 

If x>5 Then
Disp "x is greater than 5" À 
2¦x&x À 

EndIf
Disp x Á 

If x>5 Then
Disp "x is greater than 5" À 
2¦x&x À 

Else
Disp "x is less than or equal to 5" Á 
5¦x&x Á 

EndIf
Disp x Â 
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To test for each option (If Choice=1, If Choice=2, and so on), use the 
If...Then...ElseIf...EndIf structure.

Lbl and Goto commands
You can also control the flow by using Lbl (label) and Goto commands. 
These commands reside on the Program Editor’s Transfers menu.

Use the Lbl command to label (assign a name to) a particular location in 
the function or program.

You can then use the Goto command at any point in the function or 
program to branch to the location that corresponds to the specified 
label.

Because a Goto command is unconditional (it always branches to the 
specified label), it is often used with an If command so that you can 
specify a conditional test. For example:

À If x>5, branches directly to label GT5. 

Á For this example, the program must include commands (such as Stop) 
that prevent Lbl GT5 from being executed if x{5.

Using loops to repeat a group of commands
To repeat the same group of commands successively, use one of the loop 
structures. Several types of loops are available. Each type gives you a 
different way to exit the loop, based on a conditional test.

Lbl  labelName
name to assign to this location (use the 
same naming convention as a variable 
name)

Goto labelName

specifies which Lbl command to 
branch to

If x>5
Goto GT5 À 

Disp x
--------
-------- Á 
Lbl GT5
Disp "The number was > 5"
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Loop and loop-related commands reside on the Program Editor’s Control 
and Transfers menus.

When you insert one of the loop structures, its template is inserted at the 
cursor location. You can then begin entering the commands that will be 
executed within the loop.

For...EndFor loops
A For...EndFor loop uses a counter to control the number of times the 
loop is repeated. The syntax of the For command is: 

Note: The ending value can be less than the beginning value, provided 
the increment is negative.

For variable, begin, end [, increment]

À Variable used as a counter

Á Counter value used the first time For is executed

Â Exits the loop when variable exceeds this value

Ã Added to the counter each subsequent time For is executed (If this 
optional value is omitted, the increment is 1.)

When For is executed, the variable value is compared to the end value. If 
variable does not exceed end, the loop is executed; otherwise, control 
jumps to the command following EndFor.

Note: The For command automatically increments the counter variable 
so that the function or program can exit the loop after a certain number 
of repetitions.

At the end of the loop (EndFor), control jumps back to the For command, 
where the variable is incremented and compared to end.

For example:

À Á Â Ã

i > 5
i { 5

For i,0,5,1
--------
--------
EndFor
--------
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À Displays 0, 1, 2, 3, 4, and 5.

Á Displays 6. When variable increments to 6, the loop is not executed.

Note: You can declare the counter variable as local if it does not need to 
be saved after the function or program stops.

While...EndWhile loops
A While...EndWhile loop repeats a block of commands as long as a 
specified condition is true. The syntax of the While command is: 

While condition

When While is executed, condition is evaluated. If condition is true, the 
loop is executed; otherwise, control jumps to the command following 
EndWhile.

Note: The While command does not automatically change the condition. 
You must include commands that allow the function or program to exit 
the loop.

At the end of the loop (EndWhile), control jumps back to the While 
command, where condition is re-evaluated.

To execute the loop the first time, the condition must initially be true.

• Any variables referenced in the condition must be set before the 
While command. (You can build the values into the function or 
program, or you can prompt the user to enter the values.)

• The loop must contain commands that change the values in the 
condition, eventually causing it to be false. Otherwise, the condition 
is always true and the function or program cannot exit the loop 
(called an infinite loop).

For example:

For i,0,5,1
Disp i À 

EndFor
Disp i Á 

x | 5
x < 5

While x<5
--------
--------
EndWhile
--------
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À Initially sets x.

Á Displays 0, 1, 2, 3, and 4.

Â Increments x.

Ã Displays 5. When x increments to 5, the loop is not executed.

Loop...EndLoop loops
A Loop...EndLoop creates an infinite loop, which is repeated endlessly. 
The Loop command does not have any arguments.

Typically, you insert commands in the loop that let the program exit from 
the loop. Commonly used commands are: If, Exit, Goto, and Lbl (label). 
For example:

À An If command checks the condition.

Á Exits the loop and jumps to here when x increments to 6.

Note: The Exit command exits from the current loop.

0&x À 
While x<5
Disp x Á 
x+1&x Â 

EndWhile
Disp x Ã 

Loop
--------
--------
EndLoop
--------

0&x
Loop
Disp x
x+1&x
If x>5 À 

Exit
EndLoop
Disp x Á 



700 Programming

In this example, the If command can be anywhere in the loop.

The If command could also use a Goto command to transfer program 
control to a specified Lbl (label) command.

Repeating a loop immediately
The Cycle command immediately transfers program control to the next 
iteration of a loop (before the current iteration is complete). This 
command works with For...EndFor, While...EndWhile, and 
Loop...EndLoop.

Lbl and Goto loops
Although the Lbl (label) and Goto commands are not strictly loop 
commands, they can be used to create an infinite loop. For example:

As with Loop...EndLoop, the loop should contain commands that let the 
function or program exit from the loop.

Changing mode settings
Functions and programs can use the setMode() function to temporarily 
set specific calculation or result modes. The Program Editor’s Mode menu 
makes it easy to enter the correct syntax without requiring you to 
memorize numeric codes.

Note: Mode changes made within a function or program definition do 
not persist outside the function or program.

Setting a mode
1. Position the cursor where you want to insert the setMode function.

2. From the Mode menu, select the mode to change, and select the new 
setting.

The correct syntax is inserted at the cursor location. For example:

When the If command is: The loop is:

At the beginning of the loop Executed only if the condition is true.

At the end of the loop Executed at least once and repeated 
only if the condition is true.

Lbl START
--------
--------
Goto START
--------
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Debugging programs and handling errors
After you write a function or program, you can use several techniques to 
find and correct errors. You can also build an error-handling command 
into the function or program itself.

If your function or program allows the user to select from several 
options, be sure to run it and test each option.

Techniques for debugging
Run-time error messages can locate syntax errors but not errors in 
program logic. The following techniques may be useful.

• Temporarily insert Disp commands to display the values of critical 
variables.

• To confirm that a loop is executed the correct number of times, use 
Disp to display the counter variable or the values in the conditional 
test.

• To confirm that a subroutine is executed, use Disp to display 
messages such as “Entering subroutine” and “Exiting subroutine” at 
the beginning and end of the subroutine.

• To stop a program or function manually, 

– Windows®: Hold down the F12 key and press Enter repeatedly.

– Macintosh®: Hold down the F5 key and press Enter repeatedly. 

– Handheld: Hold down the c key and press · repeatedly. 

Error-handling commands

Command Description

Try...EndTry Defines a block that lets a function or program execute 
a command and, if necessary, recover from an error 
generated by that command.

Clears the error status and sets system variable  to zero. 
For an example of using , see the  command in the 
Reference Guide.

PassErr Passes an error to the next level of the Try...EndTry 
block.
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Data Collection and Analysis

The Vernier DataQuest™ application enables you to collect, view, and 
analyze real-world data. 

To use the Vernier DataQuest™ application, your TI-Nspire™ software 
must be 3.0 or higher. Visit education.ti.com if an update is needed.

This chapter introduces you to the Vernier DataQuest™ application 
starting with opening the program, showing the navigation, examining 
the menus, showing common screen structures, and providing 
instructions for completing often used tasks. This chapter covers 
instructions for using the Vernier DataQuest™ application in the 
TI-Nspire™ software including:

• TI-Nspire™ Teacher Software

• TI-Nspire™ Student Software

• TI-Nspire™ CAS Teacher Software

• TI-Nspire™ CAS Student Software

• TI-Nspire™ Navigator™ Teacher Software

• TI-Nspire™ Navigator™ Teacher Software for Networked Computers

Chapter organization
This chapter is organized using the following sections:

• Introduction and navigation

This is section you are in now. Use this section to orient yourself to the 
Vernier DataQuest™ application.

• Performing an experiment

This section is a “quick step” list on how to perform most types of 
experiments.

• Experiment details

Experiment details provides more detail on steps described in the 
Performing an experiment section.

• Working with data and Graph View

These are procedures primarily used in Graph View that were not 
covered in the Performing an experiment or the Experiment details 
sections.
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• Working with data and Table View

There are procedures primarily used in Table View that were not 
covered in the Performing an experiment or the Experiment details 
sections.

• Using advanced data collection options

This section provides information about using other data collection 
methods such as remote data collection with the TI-Nspire™ Lab 
Cradle.

• Working with advanced analysis features

This section describes additional analysis features not covered in the 
Performing an experiment or Experiment details sections.

• Printing data views

How to use printing options with the Vernier DataQuest™ 
application.

• Using sensors and data with other apps

This section has information about using the Sensor Console, a 
specialized view of the Vernier DataQuest™ application designed for 
using sensors with other TI-Nspire™ applications.

• Reference of menus

The reference is a listing of the Vernier DataQuest™ menus with a 
brief description. 

Note: You can use the menu term under Data Collection in the index 
to find where the option is explained.

Introduction and navigation
This section in to introduce you to the Vernier DataQuest™ application 
and explain terms used, special instructions for the type of device your 
are using (computer or handheld), and provide some early navigation of 
the screens.

This section includes:

• Using a computer or handheld

• Navigating the screens

• Selecting views
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Using a computer or handheld
The Vernier DataQuest™ application can be accessed and used from a 
TI-Nspire™ handheld or from your computer desktop when using 
TI-Nspire™ software. Unless otherwise specified, the screens and 
instructions for the Vernier DataQuest™ application are the same 
regardless of the TI-Nspire™ software or handheld you are using.

Besides the main application menus (and their submenus) the Vernier 
DataQuest™ application also includes context menus. The context menu 
provides access to the tools most commonly used with the selected 
object. The context menu displays different options depending on the 
active object and the task you are performing.

Note: To help illustrate how the Vernier DataQuest™ application looks 
and works the same throughout the TI-Nspire™ product line, images 
shown in this chapter are from a mixture of the software listed and are 
also from the computer and handheld.

Special instructions for PC users
To access a Vernier DataQuest™ context menu, move the cursor to the 
desired object, and right-click the object.

Special instructions for Macintosh® users
To access a Vernier DataQuest™ context menu, move the cursor to the 
desired object, hold “ and click the object.

Special instructions for handheld users
• To move the cursor, use the Touchpad.

• To use the “hand” option to grab an item (like the edge of a box), 
follow these steps:

– Use the Touchpad to move over the item. Hover until the cursor 

changes to .

– Press / and click or press x and hold. The cursor changes to . 

Move the cursor to the desired location. Press d to release. The 

cursor changes back to .

• To access the Vernier DataQuest™ Application menus press b. 

• To access a Vernier DataQuest™ context menu, move the cursor to 
the desired object and press / b.

You can also use menu item numbered shortcuts when available.
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When there are special instructions or exceptions to these methods, they 
will be indicated.

Navigating the screens
Complete one of the following steps to open the Vernier DataQuest™ 
application.

From Document workspace menu bar, select Insert > Vernier 

DataQuest or select  from the Welcome screen.

From a handheld, select  from the Home screen.

or

Press ~ and select Insert > Vernier DataQuest from an open 
document.

The Vernier DataQuest™ application opens. 

Understanding the computer view
This is a general overview of the parts of the computer view. 

An examination of the application screen sections will follow later.

The Document Toolbox:

À Document Toolbox

Á Application

Â Status bar

À

Á

Â
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Close-up of the status bar

Understanding the handheld view
This is a general view of the Vernier DataQuest™ application opened on 
a handheld. There are more possible icons on the handheld menu bar 
than shown here. See the Getting Started with the TI-Nspire™ handheld 
or the Getting Started with the TI-Nspire™ CX handheld for more 
information. 

An examination of the application screen sections will follow later.

À
Click  to activate the handheld view. When activated, the 
screen display emulates the display as shown on a handheld. 
(Illustrated in Understanding the handheld view.)

Á
Click  to activate the computer view. When activated, the 
screen displays the default view for the computer.

Â The slider bolds the view when the computer view is active. The 
slider scales the view when the handheld view is activated.

À Á Â
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Close-up of the handheld menu bar

À Handheld menu bar

Á Application

À Page scrolling arrows and page tab - Use the 
Touchpad and the arrows to scroll through 
the pages in a document. The page tab(s) 
indicates the problem number followed by 
the page number.

Á Document name - This shows the current 
document name. You can click here to access 
the Document menu. An asterisk by the 
document name indicates changes were 
made since the document was last saved.

Â Status and Settings - The battery level is 
shown here. You can hover for the 
percentage value. You can click on the icon 
for additional options.

Ã Close document - Click here to close the 
current document.

À

Á

À Á Â Ã
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Understanding the Application screen sections
The Vernier DataQuest™ application screen is identical for the computer 
and handheld. The following is a general examination of the sections of 
the application screen.

À Vernier DataQuest™ application view tabs - There are 
three selectable views: Meter, Graph, and Table. In this 
example the Graph View is displayed.

Á Data Set selection tool - This tool displays in the Graph 
View only. This tool allows you to choose which data set is 
graphed.

Â View Details area - This area contains information about 
the data appropriate for the current view.

Ã Data display area -The primary display of the data. The type 
of data displayed depends on the view. Examples of each 
view will be covered later in this document. 

Ä Data collection controls - Use these buttons to start and 
stop collections, store data sets, and capture data points.

À

Á

Â

Ã

Ä
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Selecting views
In the Vernier DataQuest™ application, you can choose from three views:

• Meter

• Graph

• Table

The Vernier DataQuest™ application view tabs.

You can switch from one view to another at any time. 

Selecting Meter View
When you first open the application, Vernier DataQuest™ is in Meter 
View. If one or more sensors are attached, a meter is displayed for each.

Select View > Meter or click .

The Meter View displays.

Selecting Graph View
The Graph view is where you can visualize your data and use analysis 
tools.

Select View > Graph or click .

The Graph View window is displayed.
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.

Selecting Table View
The Table view displays tabular data using columns, rows, and cells.

Select View > Table or click .

The Table View window is displayed.

Performing an experiment
This section provides an overview of the typical process for performing 
an experiment. The steps are brief with more detail on parameters and 
steps to follow later in the Experiment details section.

Note: If you are reading this in the abbreviated application installed 
help, please see the full reference guide Data Collection and Analysis 
chapter to access the additional sections referred to in these steps for 
more information. 
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1. Start with a new document.

When possible, start from a new document or new problem within an 
existing document. This ensures the Vernier DataQuest™ application 
is set to the default values. See Starting a new document or problem. 

Note: It is also recommended to have only one document open 
because the system may not know which document to assign the 
sensor.

2. Connect your data collection device. The sensor is displayed in your 
Vernier DataQuest™ document.

Auto launch will open the application on the current page if the page 
is not split and there is no application already on the page. 
Otherwise, a new full page is inserted immediately after the current 
page with the Vernier DataQuest™ application.

See Data collection devices for more information about the different 
data collection options.

3. Select Experiment > New Experiment to reset sensor defaults.

This ensures the default data collection mode and the settings are set 
for the connected sensors and it removes any existing data. 

Important: This step is extremely important when you are not 
starting from a new document or problem.

4. (Optional) Modify the data collection mode and data collection 
settings.

If desired, you can modify the default mode and settings to match the 
experiment you are performing. 

• To change the mode and settings select Experiment > Collection 
Mode.

• Set the desired data collection mode for your experiment. 

See Setting and using a collection mode.

5. (Optional) Modify the sensor settings

If desired, you can modify how the sensor values are displayed and 
stored in the application. You can change units, modify the sensor 
calibrations, and change the displayed precision of the data.

See Modifying sensor settings.

6. Start the Data Collection by selecting Experiment > Start Collection 

or click .
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If in Meter View, the Vernier DataQuest™ application changes to 
Graph View and the recording of sensor data is enabled. The graph is 
updated to show the collected data as it is occurring.

Important: When using data modes Events with Entry or Selected 
Events, data points are not recorded until you select Experiment > 

Keep or click .

See Using the Keep option.

7. (Optional unless event-based) Stop data collection.

For most data collection modes, the collection will end automatically. 
You can stop the collection early if desired. However, you must stop a 
collection manually when using event-based data collections.

To stop a collection, select Experiment > Stop Collection or click .

8. Analyze the collected data. 

There are many tools you can use to analyze your data. See the 
following sections in this document for more information.

• Analyzing data to review common analysis features. 

• Working with advanced analysis features for additional analysis 
options.

Important: Some information may be shown only in the All Details 
for Graph dialog box. See Examining the View Details area data. 

9. (Optional) Perform additional data collection runs.

For most experiments it is desirable to perform multiple trials (runs). 
You can store the data set from the latest run before performing a 
new run. Storing the data set retains the data from the previous run 
by creating a new data set for your next run. If you do not need to 
retain the data from the previous run, you can overwrite the data set 
by starting another collection without storing.

To store the data set, select Experiment > Store Data Set or click 

.

Important: You must save the document (File> Save) if you want to 
keep the data after the application has been closed.

10. (Optional) Save the data by saving the document.

To save the document, choose the document to save and select File > 
Save Document or press Ctrl + S.
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Handheld: Press ~ then select File > Save or press / + S.

Saving your document retains all of your data collection settings and 
data for use at another time.

Save the document as a TI-Nspire™ document (.tns file) or as a 
TI-Nspire™ PublishView™ document (.tnsp).

Important: PublishView™ is a special application of TI-Nspire™ that 
is only available on the computer software.

11. (Optional) Print the document if desired.

See Printing data views.

Experiment Details
This section provides more detail to the procedure steps given in 
Performing an experiment.

This section includes:

• Starting a new document of problem

• Connecting a sensor

• Data collection devices

• Setting and using a collection mode

• Modifying sensor settings

• Starting a data collection

• Using the keep option

• Stopping a collection

• Examining data points

• Data analysis options

• Examining the View Details area

• Showing and hiding details

• Storing data

• Saving an experiment

Starting a new document or problem
Starting a new document or problem ensures all Vernier DataQuest™ 
values and settings are set back to the defaults.
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Starting a new document
1. Best practices recommend closing all open documents. Save any open 

documents, if desired, by selecting the document to be saved and 
selecting File > Save Document or press Ctrl + S.

Handheld: Press ~ then select File > Save or press / + S.

Save the document as a TI-Nspire™ document (.tns file) or as a 
TI-Nspire™ PublishView™ document (.tnsp).

Important: PublishView™ is a special application of TI-Nspire™ that 
is only available on the computer software.

Important: The handheld can only have one document open. If you 
do not save you will be asked if you want to save before creating a 
new document.

2. Select File > New TI-Nspire Document or press Ctrl + N.

Handheld: Press c then select New Document.

3. Select the Vernier DataQuest™ application from the menu.

A new document is opened.

Adding a problem
You can add a new problem to an existing document. The new problem 
page starts with the Vernier DataQuest™ default values and settings, 
ensuring a “clean” start for this new problem.

1. Select Insert > Problem.

Handheld: Press ~ then select Insert > Problem.

2. Select the Vernier DataQuest™ application from the menu.
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A new problem document is created.

Connecting a sensor
Attach your sensor to the sensor interface, then attach your interface to 
the computer or handheld. 

Direct-connect USB sensors such as the Vernier Go!Temp® temperature 
probe (for computers) or the Vernier EasyLink® temperature probe (for 
handhelds) connect directly to the computer or handheld and do not 
need a sensor interface.

Data collection devices
There are a variety of sensors and interfaces that can be used with your 
TI-Nspire™ software running the Vernier DataQuest™ application.

Sensor Interfaces:
• Texas Instruments TI-Nspire™ Lab Cradle - a multi-channel sensor 

interface for use with handhelds or computers.

• Vernier EasyLink® - a single-channel sensor interface for use with 
handhelds.
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• Vernier GO!Link® - a single-channel sensor interface for use with 
computers.

Sensors
• Analog Sensors - sensors such as temperature, light, pH, and voltage 

probes are analog sensors. These sensors require a sensor interface.

• Digital Sensors - sensors such as motion detectors, photogates, 
radiation monitors, and drop counters are digital sensors. These 
sensors can only be used with the TI-Nspire™ Lab Cradle.

Direct-Connect USB Sensors
These sensors connect directly to a handheld or computer and do not 
require a sensor interface.

For Handhelds:

• Texas Instruments CBR 2™

• Vernier EasyTemp® temperature probe
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For Computers:

• Vernier Go!Temp® temperature probe

• Vernier Go!Motion® motion detector

Setting and using a collection mode
Use the Collection Mode option to assign the mode to use for collections. 
The default collection mode is Time Based. If you have unsaved data, you 
will be warned that changing modes will clear your data.

This section examines the procedures for the collection modes. Your 
options are:

• Time Based - The default for a new experiment.

• Events with Entry

• Selected Events

• Photogate timing - Only used with the Vernier Photogate sensor.

• Drop Counting - Only used with the Vernier Drop Count sensor.
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Setting a Time Based collection mode
The Time Based option captures data with respect to time. This is the 
default mode for new experiments.

To set the collection mode as Time Based: 

1. Select Experiment > Collection Mode > Time Based.

The Configure Time Based Data Collection dialog box opens with 
either Interval or Rate selected. (It uses your previous settings as the 
opening value.)

2. Select Rate or Interval mode from the drop-down menu. 

Rate and Interval are used to determine how often data points are 
collected. For convenience, you have two methods in which to enter 
this information. Rate and Interval are simply reciprocals of each 
other.

• Rate (samples/second): Enter the number of samples per second. 
The interval is calculated. 

• Interval (seconds per sample): Enter the number of seconds per 
sample. The rate is calculated. 

3. Enter the rest of values in the Configure Time Based Data Collection 
dialog box.

• Duration (seconds): Enter the duration that the data collection 
should last. 

• Number of points: This is a calculated field. Review this value to 
ensure your rate and duration are reasonable. This value is 
determined by the formula, Rate * Duration + 1.

Important: Collecting too many data points impacts system 
performance.

or

Rate (samples/second) Interval (seconds/sample)
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• Strip Chart (Optional): Strip Chart will continuously collect 
samples but only retain the last x data points collected. (“x” 
represents the number of points defined in Number of Points.)

• Data Marker (Optional): Selecting this option places  in the 
Data collection controls area. Click the Add Data Marker icon 
while collecting in time base mode to emphasize specific points.

Use this option to identify points of interest, such as an observed 
change or when changing the conditions, while collecting data. 
For example: Ice begins to form, began stirring, or added a 
chemical.

4. Click OK to save your entries.

Your settings are saved for use on your next run.

Using Time Based collection mode
Use this procedure only after assigning Time Based as the collection 
mode.

To use after setting Time Based as the collection mode:

1. Connect a sensor.

2. Select Experiment > Start Collection or click .
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Setting Events with Entry 
This collection mode allows you to capture samples manually. Events with 
Entry and Selected Events are similar. The difference is that Selected 
Events numbers the dependent column (1,2,3,...) where Events with Entry 
ask you to define the independent value for each point you collect.

To set the collection mode as Events with Entry:

1. Select Experiment > Collection Mode > Events with Entry.

The Events with Entry Setup dialog box opens.

2. Enter a new name and (Optional) units for the independent variable 
for your collection.

3. (Optional) Select Average over 10 s (seconds).

Use this option when sensor values fluctuate. Ten seconds of data are 
collected and the average reading is retained.

4. Click OK to save your entries.

Your settings are saved for use on your next run. The Keep current 

reading icon  now appears (inactive) in Data collection controls.

Using Events with Entry
Use this procedure only after assigning Events with Entry as the collection 
mode.

To use the Events with Entry collection mode:

1. Connect a sensor.

2. Select Experiment > Start Collection or click .

The Keep current reading icon  becomes active. The sensor shows 
the data point in the center of the screen. 
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3. When ready, click . One of the following dialog boxes opens.

• If you selected “Average over 10 s,” the Averaging dialog box 
opens with a count down displayed. When the seconds reaches 
zero, it will record the data point in the appropriate location on 
the graph.

• If you did not select “Average over 10 s”, the Events with Entry 
dialog box is opened. 

– Manually enter the value of your data point.

– Click OK.

The data point is saved in the appropriate location on the graph. 
The next point appears in the center of the graph.

4. Repeat step three until all your desired data points are captured.

5. Stop the collection.

Setting Selected Events
This collection mode allows you to capture samples manually. Events with 
Entry and Selected Events are similar. The difference is that Selected 
Events numbers the dependent column (1,2,3,...) where Events with Entry 
ask you to define the independent value for each point you collect.

To set the collection mode as Selected Events:

1. Select Experiment > Collection Mode > Selected Events.

The Events with Entry Setup dialog box opens.
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2. Enter a new name and (optional) units.

These are labels. Use any meaningful values.

3. (Optional) Select Average over 10 s.

4. Click OK to save your entries.

Your settings are saved for use on your next run. Keep current 

reading  now appears (inactive) in Data collection controls.

Using Selected Events
Use this procedure only after setting Selected Event as the collection 
mode.

To use the Selected Events collection mode:

1. Connect a sensor.

2. Select Experiment > Start Collection or click .

Keep current reading becomes active. The sensor shows the data 
point in the center of the screen when in Graph View. 

3. When ready, click . 

The data point is saved in the appropriate location on the graph. The 
next point appears in the center of the graph.

4. Repeat step three until all your desired data points are captured.

5. Stop the collection.

Your data set run is complete.

Using Photogate Timing
Select this mode only if using the Vernier Photogate. See sensor 
specifications for information to help you choose your collection mode 
options.
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Using Drop Counting
Select this mode only if using the Vernier Drop Counter. See sensor 
specifications for information to help you choose your collection mode 
options.

Modifying sensor settings
Use this option to modify the values returned by a sensor. For example, 
when using a temperature probe, you can change the units from 
Centigrade to Fahrenheit. 

Changing sensor units
Default units and available options to change the units vary depending 
on the selected sensor. For example, options for the Vernier Go!Temp® 
Temperature probe are Fahrenheit, Celsius, and Kelvin. Options for the 
Vernier Hand Dynamometer (a specialized force sensor) are Newton, 
Pound, and Kilogram.

To change a sensor’s unit of measure:

1. Select Experiment > Set Up Sensors > Change Units.

2. Select the sensor you want to change the units.

Available sensor(s) are dependent on attached and offline sensor(s) 
selected.

3. Select the unit type from the menu associated with the sensor.

The measurement unit is changed.

Note: You can change the units before or after the data has been 
collected. The collected data will reflect the new units.
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Calibrating a sensor
When a sensor is detected, it automatically loads a calibration for that 
sensor. You have the option of calibrating sensors. Some sensors cannot 
be calibrated, while other sensors, such as the Colorimeter and the 
Dissolved Oxygen Probe must be calibrated to be useful. 

There are three options when calibrating a sensor:

• Manual Entry

• Two Point

• Single Point

See your sensor’s specifications for information on the calibration values 
and procedures to change. 

Zeroing a sensor
Not all sensors can be zeroed. Sensors where relative measurements are 
common, such as Force, Motion, and Pressure, can be zeroed. Sensors 
designed to measure specific environmental conditions, such as 
Temperature, PH, and CO2 cannot be zeroed.

To set the standing value to zero:

Select Experiment > Set Up Sensor > Zero.

The sensor value is now at zero.

If more than one attached sensor can be zeroed, you will see a list of 
sensors to chose from along with an option to zero all sensors.

Reversing a sensor
Use this feature to change the display of the reading.

By default, pulling with a force sensor produces a positive force and 
pushing produces a negative force. Reversing the sensor allows you to 
display pushing as a positive force.

If more than one sensor can be reversed, choose the one to reverse from 
the provided list.

To reverse the sign of the sensor reading:

Select Experiment > Set Up Sensor > Reverse.

The sensor sign is now reversed. If you are in Meter View, you can see 

the reverse indicator “ ” after the sensor name.
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Starting a data collection
Use this method to start a collection. If you already have a collection you 
must decide if you want to overwrite the existing data or store it. 

If you do not need to save the data from the previous run, you can 
overwrite the data set by performing the following step.

If you want to store your existing data set and not overwrite the data, 
see Storing data before performing this step.

Start the Data Collection by selecting Experiment > Start Collection 

or click .

If in Meter View, the Vernier DataQuest™ application changes to 
Graph View and the recording of sensor data is enabled. The graph is 
updated to show the collected data as it is occurring.

Important: When using data modes Events with Entry or Selected 
Events, data points are not recorded until you select Experiment > 

Keep or click .

See Using the Keep option.

Using the Keep option
Use the Keep option to store the connected sensor’s values. 

Note: See Setting and using a collection mode to assign the entry name 
and unit labels.

Using Keep stores a specific data point. This option is available when the 
Collection Mode specified is "Events with Entry" or "Selected Events." 

If the Collection Mode is "Events with Entry," you must assign the 
independent value that corresponds to the dependent variable.
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Defining Collection Mode as Selected Events
To set collection mode to Selected Events:

1. Select Experiment > Start Collection or click .

2. Select Experiment > Keep or click  for each data point you want 
to keep. 

3. Repeat step two until all data points you want to collect are selected.

4. Select Experiment > Stop or click  after all points are selected.

The data point is captured for each selection. Data is visible in the 
Graph and Table views.

Defining Collection Mode as Events with Entry
To set collection mode to Events with Entry:

1. Select Experiment > Start Collection or click .

2. Select Experiment > Keep or click  for each data point you want 
to keep. 

The Events with Entry dialog box opens.

3. Enter the independent value in the “Enter Value” field.

Note: Value is typically numeric, but you can also use text.

4. Click OK to continue.

5. Repeat steps two through four until all data points you want to 
collect are selected.

6. Select Experiment > Stop or click  after all points are selected.

The data point is captured for each selection. Data is visible in the 
Graph and Table views.
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Stopping a collection
You can stop a data collection before the data set’s run is expired. 

To stop a collection:

Select Experiment > Stop Collection or click .

The current run is stopped.

Analyzing data 
Analyzing data in the Vernier DataQuest™ application is done from the 
Graph View. Start by setting up graphs and then use analysis tools such as 
integral, statistics, and curve fit to investigate the mathematical nature 
of your data.

This section includes:

• Examining data points

– Interpolate

– Tangent

– Examine Settings

• Data analysis calculations

– Integral

– Statistics

– Curve Fit

– Model

See Working with data and Graph View.

Also see, Working with advanced analysis features.

Important: The Graph menu and Analyze menu items are only available 
when working in Graph View.

Examining data points
The following provides information about the methods available for 
examining data points in the Vernier DataQuest™ application.

Interpolate
Use Interpolate to estimate the value between two data points and to 
determine the value of a Curve Fit between and beyond data points. 
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The examine line moves from data point to data point. When Interpolate 
is on, the examine line moves between and beyond data points.

To turn Interpolate on and off:

Select Analyze > Interpolate.

When Interpolate is on, a check mark appears in the menu next to the 
option.

To use Interpolate:

1. When Interpolate is on, move the cursor over the graph and click 
once. The examine indicator is drawn to the nearest data point.

The values of the plotted data are shown in the View details area and 
the All Details for Graph dialog box.

2. You can move the examine line by moving the cursor with your arrow 
keys or clicking on another data point.

Tangent
Tangent is used to display a measure of the rate at which the data is 
changing at the point you are examining. The rate value is displayed in 
the View Details area and in the All Details for Graph dialog box. The 
value is labeled “Slope.”

To turn Tangent on and off:

1. Select Analyze > Tangent.

When Tangent is on, a check mark appears in the menu next to the 
option.

2. When Tangent is on, move the cursor over the graph and click once. 
The examine indicator is drawn to the nearest data point.

The values of the plotted data are shown in the View details area and 
the All Details for Graph dialog box.

3. You can move the examine line by moving the cursor with your arrow 
keys or clicking on another data point.
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Examine Settings
This option allows you to select which of the plotted columns and curve 
fit you would like to trace when examining the data. Values are 
displayed in the View details area and in the All Details for Graph dialog 
box.

You can also show cursor position and delta values as you examine the 
data by selecting the Position and Delta option. The values are displayed 
below the graph.

To examine settings:

1. Select Analyze > Examine Settings.

The Examine dialog box opens. The default is to have all “Show 
Examine” items selected. In this example, there is one sensor column 
and a curve fit with both selected.
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2. Choose your options.

• Position and Delta - Show the cursor position and delta values

The Position and Delta tool is used in the following ways:

Position - The cursor’s pixel coordinates will show under the 
graph so you can determine the coordinates of a point on the 
screen between and beyond data points without using interpolate 
mode or doing a curve fit.

Delta - This is used to determine changes in x and y between two 
points (the coordinate of the start and graph points of a selected 
region). This can be used to answer a question like “How much did 
the temperature drop, and how long did it take?”

• Plotted column name (in this example Pressure) - Show the 
value and units of the displayed column.

3. If examining the position and delta, you may also select a region.

To select a region, place your cursor at the start of the area. Click and 
drag across the graph to the end of your selected region. The selected 
area is indicated by gray shading. (See a following example that 
shows Position and Delta for an illustration.)

The following are examples of the Examine dialog box and the Graph 
View (with data) when both the Show Examine and Position and Delta 
options are unselected.

The following are examples of the Examine dialog box and the Graph 
View (with data) when only the Show Examine option is selected. Notice 
the value and units of Pressure is shown.
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The following are example screens of the Examine dialog box and the 
Graph View (with data) when both the Examine options and Position and 
Delta are selected. This example also shows a selected range. (See 
Selecting a range for instructions on how to select a range.)

Notice that the value and units are shown, and now position and delta 
values are also shown under the graph.

Data analysis calculations

Integral
Use Integral to determine the area under a data plot. You can find the 
area under all of the data or a selected region of the data. The value is 
displayed in the View Details area and in the All Details for Graph dialog 
box.

x-axis range

y-axis 
range
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To view integral:

1. Leave the graph unselected to examine all the data, or select a range 
to examine a specific area.

See Selecting a range for instructions on how to select a range.

2. Select Analyze > Integral.

3. Select plotted column name if you have more than a single column.

The following is an example with an area selected.

Statistics
Use this option to determine the statistics associated with the plotted 
data. Minimum, maximum, mean, standard deviation, and number of 
samples are calculated. You can find the statistics for all the data or a 
selected region of data. The values are displayed in the View details area 
and in the All Details for Graph dialog box.

To generate statistics:

1. Leave the graph unselected to examine all the data, or select a range 
to examine a specific area.

See Selecting a range for instructions on how to select a range.

2. Select Analyze > Statistics.

3. If you have more than a single column, select the plotted column 
name (example: run1.Pressure) which you want to examine.
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The statistics dialog box open. 

4. Review the data and click OK when done.

Curve Fit
Find a best curve fit to match your data. Select all of the data or a 
selected region of data. The curve is drawn on the graph and the 
equation information is displayed in the View details area and in the All 
Details for Graph dialog box.

To generate curve fit:

1. Leave the graph unselected to examine all the data, or select a range 
to examine a specific area.

See Selecting a range for instructions on how to select a range.

2. Select Analyze > Curve Fit.

3. Select the curve fit option from the menu.
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The curve fit details dialog box opens.

4. Review the data and click OK when done.

The following image is an example of curve fit (Quadratic).

Curve fit option Calculated in the form:

Linear y = m*x + b

Quadratic y = a*x^2 + b*x + c

Cubic y = a*x^3 + b*x^2 + c*x + d

Quartic y = a*x^4 + b*x^3 + c*x^2 + d*x + e

Power (ax^b) y = a*x^b

Exponential 
(ab^x)

y = a*b^x

Logarithmic y = a + b*ln(x)

Sinusoidal y = a*sin(b*x + c) + d

Logistic (d  0) y = c/(1 + a*e^(-bx)) + d

Natural 
Exponential

y = a*e^(-c*x)

Proportional y = a*x
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Model
This option provides a manual method of plotting a function to fit data. 
Use one of the predefined models or enter your own.

To generate the model:

1. Select Analyze > Model.

2. Enter your own function or select from drop-down menu.

Example manually entered function:

3. Click OK.

4. Set the coefficient and increment values.

These are the initial values. You can also adjust these values later with 
the “sliders,” also called “spinners,” in the View Details area.
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5. Click OK.

The model is shown on the graph with adjustment options in the 
View Details area and in the All Details for Graph dialog box.

Notice that the screen’s minimum and maximum axis are too large for 
this particular example.

6. (Optional) Adjust the window setting for minimum and maximum 
axis by clicking on the y and x minimum and maximum values directly 
on the screen to change, or select Graph > Window Settings. Click 
OK when done. See Setting Min and Max axis ranges.
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7. Make any desired adjustments to the coefficients by clicking on  or 
clicking directly on the value in the View Details area.

Example of a value entered directly:

Example model with values adjusted:
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Removing analysis options
Use to clear previous analyzed data from the graph and the View Details 
area. You can choose to clear all or a specific data display. This option can 
also remove any generated models.

Use this menu to remove the following items:

• Integral

• Statistics

• Curve Fit

• Model

Select Analyze > Remove.

When there is only one item to remove, the Remove option will 
include the name of the item available to be removed or the curve fit. 
For example, “Remove Cubic.”

When there is more than one item, select the item to remove from 
the list provided.

Examining the View Details area data
When you are performing analysis options such as statistics, the All 
Details for Graph dialog box opens. You can examine the details and click 
OK to close the box. You can reopen this dialog box manually. See 
Opening a View Details area dialog box.
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The detail information is shown in the View Details area even when the 
dialog box is closed. 

You can open a dialog box to show the data detail. Alternatively, you can 
expand the View Details area to have more space to display information.

Important: Some information is only shown in the view details dialog 
box.

Opening a View Details area dialog box
You can open a dialog box to see the data included in the View Details 
area.

1. Open the context menu in the View Detail area.

2. Select Details > All Details.

The All Details for Graph dialog box opens. 

Use the scroll bar to see the rest of the data.

Other menu options under Detail context menu may be available. These 
are subsets you can select if you only want part of the details.

Expanding the View Details area
Use this procedure to expand the View Detail area. By increasing its 
screen “real estate” you reduce the space for the graph. You can use this 
same procedure to constrict the View Details area.

In this example, tangent line and statistics are displayed.
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1. Place your cursor at the edge of the View Details area and hover until 

the cursor changes to .

2. Click and hold until cursor changes to .

3. Drag until it is the size you desire.

In this sample the View Details area is resized.
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Showing and hiding details
You can hide parts of the screen to provide more screen “real estate.” 

The following are example screens with the details shown.

To hide details:

Select Options > Hide Details.

The menu changes from Hide Details to Show Details.

The following parts of the screen are hidden:

• Vernier DataQuest™ application view tabs

• View Details area

• Data collection controls

The following are example screens with the details hidden.
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To show details:

Options > Show Details.

Storing data
When data is present, use the Store Data Set option to create a new 
data set for subsequent data collections so data already collected is not 
overwritten. The data set is not saved outside the currently running 
application until you save the data set as a TI-Nspire™ or PublishView™ 
document. 

To store a data set:

Select Experiment > Store Data Set or click .

The first data set is stored as "Run 1" by default and "Run 2" opens 
for collecting additional data. The data set names can be changed.

Saving an experiment
Save the document as a TI-Nspire™ document (.tns file) or as a 
TI-Nspire™ PublishView™ document (.tnsp).

Important: PublishView™ is a special application of TI-Nspire™ that 
is only available on the computer software.

1. Select the document to be saved.

2. Select File > Save Document or press Ctrl + S.

Handheld: Press ~ then select File > Save or press / +S.

Working with data and Graph View
Use the Graph View to visualize your data and for analysis. This section 
shows how to view multiple graphs, select the plotted data to be 
displayed, change the x and y axis ranges, and zoom in and out of your 
graph.

Important: The Graph menu and Analyze menu items are only active 
when working in Graph View.
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This section’s topics include:

• Showing graphs

• Adding a title to a graph

• Selecting a data set to plot

• Setting min and max axis ranges

• Selecting a Data Set to plot

• Using autoscale

• Using zoom in and zoom out

• Selecting a range

• Setting the point display

• Selecting an independent variable column

• Selecting a dependent variable column

Showing graphs
The Show Graph menu option is used to show separate graphs when you:

• Have a sensor that plots more than one column of data.

• When multiple sensors having different defined units are used at the 
same time. 

You can select to show the top graph, bottom graph, or both. In these 
conditions, the default is to show both graphs.

In this example, two sensors (the Gas Pressure sensor and the Hand 
Dynamometer) were used in the same run. The following image shows 
the columns Time, Force, and Pressure in the Table View to illustrate why 
two graphs are shown. 
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1. Select View > Graph or click .

In this example, both graphs are shown by default.

Showing Graph 1
Continuing with the same example as Showing Graphs, this process 
shows how to display only Graph 1.

Select Graph > Show Graph > Graph 1.

Only Graph 1 is displayed. Graph 1 is the top graph when both graphs 
are displayed.
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Showing Graph 2
Continuing with the same example as Showing Graphs, this process 
shows how to display only Graph 2.

Select Graph > Show Graph > Graph 2.

Only Graph 2 is displayed. Graph 2 is the bottom graph when both 
graphs are displayed.

Showing both graphs 
Continuing with the same example as Showing Graphs, this process 
shows how to display both graphs if you have previously selected to 
show only Graph 1 or Graph 2.

Select Graph > Show Graph > Both.

Both graphs are displayed.
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Adding a title to a graph
You can add a title to your graph. The title displays in the View Details 
area and is printed with your graph.

1. Select Graph > Graph Title.

The Graph Title dialog box is opened.

When you have two graphs, the dialog box has two title options. 

2. Enter the name of your title.

3. Select Enable to show the title.

Note: With the Enable option you can enter a graph name and turn it 
on or off as your needs change.

4. Click Ok.

If enabled, the title is shown.



748 Data Collection and Analysis

Setting min and max axis ranges
You can modify the minimum and maximum range for the x and y axis 
using these procedures.

Setting the axis range using the menu
1. Select Graph > Window Setting.

The Windows Setting dialog box opens.

When you have two graphs there are two y axis minimum and 
maximum values to enter but only one set of minimum and maximum 
values for the x axis.
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2. Edit the values you want to change.

The application will use these new values for the graphs visual range 
until you modify or change data sets.

Setting the axis range from the window
You can modify the minimum and maximum range for the x and y axis 
from the window.
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Select one or more values to change by highlighting the text and 
typing a new value.

Handheld: 

• Place your cursor over the value until the cursor changes to an I-

beam . 

• Click the text to highlight and type your new value.

• Press ·.

Handheld example screens: 
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Selecting a Data Set to plot
Select which data set to plot when there is more than one data set 
available.

1. Select Graph > Select Data Set or click on the Data Set selection tool.

The list of available data sets opens.

2. Select one of the following:

• Data Set name - plot one data set

• All - plot all data sets

• More - Choose a combination of data sets to plot. Click OK when 
Done.

When using the More option, if you select more than one data set 
and less than all, the Data Set selection tool will read “Custom.”
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Using autoscale
You can use the autoscale option anytime to change the screen view to 
accommodate all available points. You can also define the system’s 
automatic autoscale behavior to be used during and after a collection.

Using autoscale now
Use autoscale at anytime to restore the graph to show all the points 
plotted. Autoscale Now is very useful after changing the x and y axis 
range and after a zoom in or out.

Autoscale Now using the menu
Select Graph > Autoscale Now.

The graph now displays all the points plotted.

Autoscale Now using the window (context menu)
1. Open the context menu in the graph area.

2. Select Window/Zoom > Autoscale Now.

The graph now displays all the points plotted.

Defining autoscale during a collection
You have two options for the system’s automatic autoscaling that occurs 
during a collection. Use this procedure to set your choice.

1. Select Options > Autoscale Settings.

2. Click the During Collection drop-down list and select one:

• Autoscale Larger - This option expands the graph as needed to 
show all points as they are collected. 

• Do Not Autoscale - With this option selected, the graph window 
is not changed during a collection.

Defining autoscale after a collection
You have three options for the system’s automatic autoscaling that 
occurs after a collection. Use this procedure to set your choice.

1. Select Options > Autoscale Settings.

2. Click the After Collection drop-down list and select one:

• Autoscale to Data - With this option selected, the system expands 
the graph as needed to show all data points. This is the default 
mode.

• Autoscale From Zero - This option modifies the graph so all data 
points are displayed as well as the origin point.
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• Do Not Autoscale - The graph window settings are not changed.

Using zoom in and zoom out
You can zoom in to a subset of the collected points. You can also zoom 
out from a previous zoom or to expand the graph window beyond the 
data points collected.

Zoom In
1. Select the area range you want to zoom in or use your current view.

See Selecting a range for instructions on how to select a range.

2. Select Graph > Zoom In or open the context menu on the graph and 
select Windows/Zoom > Zoom In.

The graph window is now adjusted to only display your selected area. 

The selected x range will be used as the new x range. The y range will 
autoscale to show all graphed data points in the selected range.

The following images show an original (autoscale) view and zoom in 
performed multiple times (or as a selected region).

Zoom Out
1. Select Graph > Zoom Out or open the context menu on the graph 

and select Windows/Zoom > Zoom Out.

The graph window is now expanded.

If a zoom in preceded a zoom out, it will return the settings prior to 
the zoom in. 

For example, if you zoomed in twice the first zoom out would return 
the window to the state of the first zoom in. To get back to the full 
graph (showing all data points) quickly from multiple zoom ins, use 
Autoscale Now.
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Selecting a range
Selecting a range on the graph is useful in several situations, such as 
when zooming, striking and unstriking data, and examining settings.

To select a range:

1. Place your cursor at the start of the area. Click and drag across the 
graph to the end of your selected region. The selected area is 
indicated by gray shading.

Handheld:

• Place you cursor at the starting point and click x (center of the 
Touchpad). 

The cursor changes to  (double-headed arrow).

• Move the cursor to the end of your selection. 

• Press d. 

The cursor returns to å (single-headed arrow).

2. Perform your action (such as zooming).
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Setting the point display
You can adjust the way points are displayed on your graphs.

Point Options
Use this procedure to determine how often marks appear on the graph 
and whether to use a connecting line.

1. Select Options > Point Options.

The Point Options dialog box opens.

2. Select your Mark option from the drop-down box.

• None - No point protectors.

• Regional - Periodic point protectors.

• All - Display every data point as a point protector.

3. Select or deselect Connect Data Points.

Selecting Connect Data Points displays a line between points.

The following shows examples of some of the point Mark options.

Regional

Connect Data Points - Selected

All 

Connect Data Points - not selected

None

Connect Data Points - Selected
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Point Colors
Use this procedure to set the color of the marks different than the 
system’s settings.

Note: On a non-color handheld, the “color” is represented by different 
shades of gray.

1. Open the context menu in the Graph and select Color from the menu.

Note: The Color option is often preceded by the data set name and 
column name. 

2. Select the column variable to change.

3. Select the color to set.

In this example, Force was selected and green was the color chosen.



Data Collection and Analysis 757

Point Markers
Use this procedure to change the symbols used for your point markers.

1. Open the context menu in the Graph and select Point Marker from 
the menu.

Note: If there is only one dependent variable column, the Point 
Maker option is preceded by the data set name and column name. 
Otherwise, the Point Marker option has a menu.

2. Select the column variable to change.

3. Select the point marker to set.

In this example, Pressure was selected and the inverted fill triangle 
was the point chosen.
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Selecting an independent variable column
The option Select X-axis Column allows you to select the column used as 
the independent variable when graphing the data. This column is used 
for all graphs.

Select Graph > Select X-axis Column and choose from available 
variables.

The x-axis label on the graph changes and your graph is reordered 
using the new independent variable for graphing the data.

Selecting a dependent variable column
The option Select Y-axis Column allows you to select which dependent 
variable columns to plot on the displayed graph(s). 

1. Select Graph > Select Y-axis Column.

2. Select one of the following:

• A variable from the list.

The list is a combination of your dependent variables and the 
number of data sets. 

• More

Selecting More opens the Select dialog box. Use this when you 
want to select a combination of data set variables to display.
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Working with data and Table View
This section primarily involves working with your data sets in Table View.

This section’s topics include:

• Defining column options

• Changing a data set name

• Adding a new manual column

• Adding a calculated column

• Creating a new data set

Defining column options
Set the column name, units, and precision here. All existing columns are 
listed.

To define the column:

1. Select View > Table or click .

You can be in the Meter, Graph, or Table views and still perform these 
steps. The results will still be visible. 

The Table View is displayed. In this example, no data sets have been 
run and the Vernier Gas Pressure Sensor is attached.
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2. Select Data > Column Options and the column you want to define,

for example, the Pressure column.

The Column Options menu opens.

3. Enter the values you want to edit. The fields are populated but allow 
editing.

• Name: Enter the long name for the column.

• Short Name: The preferred abbreviation for a column where the 
column has not been expanded large enough to show the full 
name.

• Units: Enter the unit label. The label is used when values from this 
column are displayed in graphs and detail boxes.

• Displayed Precision: Specifies the number of decimal places or 
significant values. This default precision is related to the precision 
of the sensor.

• Link to List: Allows the system to link columns to the symbol 
table and make the variable (such as run1.x) available to other 
TI-Nspire™ applications outside of the Vernier DataQuest™ 
application. Linking is the default for most sensors.

Note: Heart rate and blood pressure sensors require a 
tremendous amount of data to be useful, and the default for 
these sensors is to be unlinked to improve system performance. 

• Apply changes to all Data Sets: Allows you to apply the settings 
to all data sets or just to the latest data set.
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In this example, the name was changed to “Pressure Ex01a” and the 
displayed precision was set to “4.”

4. Click OK.

The column settings are now defined with your new values.

The following example shows some views after a data collection. 
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Changing a data set name
Defining Column Options explained how to change the column 
headings. This section shows you how to change the Data Set name 
above the column headings (also in the Data Set selection tool and the 
Details View area).

1. Select View > Table or click .

2. Open the context menu for the table’s data set name, for example, 
Run1.

3. Select Options (preceded by the data set name).

The Data Set Options dialog box opens.

4. Change the name.

Note: The maximum character limit is 30 and the name cannot 
contain commas.

The data set name is now changed.
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Adding a new manual column
You can add a column for manual entry of data. Sensor columns cannot 
be modified, but manual column data and entry data may be edited.

1. Select Data > New Manual Column.

The Column Options dialog box opens.

2. Enter the values you want to edit. Most fields are populated but still 
allow editing.

• Name: Enter the long name for the column.

• Short Name: The preferred abbreviation for a column where the 
column has not been expanded large enough to show the full 
name.

• Units: Enter the unit label. The label is used when values from this 
column are displayed in graphs and detail boxes.

Table View Graph View
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• Displayed Precision / Significant Figures: Specifies the number 
of decimal places or significant values. The default precision is 
related to the precision of the sensor.

• Apply changes to all Data Sets: Allows you to apply the settings 
to all data sets or just to the latest data set.

• Generate Values: This option box allows you to automatically 
populate the manual column’s rows. You can enter a starting 
value, an ending value, and an increment value. The number of 
points is calculated for you.

• Link from List: Allows you to link (which acts like a copy and 
paste - not automatically updated) to data held by another 
TI-Nspire™ application on an additional page, such as List & 
Spreadsheets. The list is only populated when data exists in the 
other application and includes a column label.

• Link to List: Allows the system to link columns to the symbol 
table and make the variable (such as run1.x) available to other 
TI-Nspire™ applications outside of the Vernier DataQuest™ 
application. Linking is the default for most sensors.

Note: Heart rate and blood pressure sensors require a 
tremendous amount of data to be useful, and the default for 
these sensors is to be unlinked to improve system performance. 

3. Click OK.

A new column is added to the table. This column can be edited.

Adding a calculated column
You can add an additional column to the data set where the values are 
calculated from an expression using at least one of the existing columns.

1. Select Data > New Calculated Column.
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The Column Options dialog box opens.

2. Enter the values you want to edit. Most fields are populated but still 
allow editing.

• Name: Enter the long name for the column.

• Short Name: The preferred abbreviation for a column where the 
column has not been expanded large enough to show the full 
name.

• Units: Enter the unit label. The label is used when values from this 
column are displayed in graphs and detail boxes.

• Displayed Precision / Significant Figures: Specifies the number 
of decimal places or significant values. 

• Expression: Enter an expression that includes one of the column 
names provided. The system provided column names are 
dependent on the sensor(s) selected and any changes made to the 
name field in Column Options.

Important: The Expression field is case-sensitive. (Example: 
“Pressure” is not the same is “pressure.”)

• Link to List: Allows the system to link columns to the symbol 
table and make the variable (such as run1.x) available to other 
TI-Nspire™ applications outside of the Vernier DataQuest™ 
application. Linking is the default for most sensors.
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Note: Heart rate and blood pressure sensors require a 
tremendous amount of data to be useful, and the default for 
these sensors is to be unlinked to improve system performance. 

Example with fields.

3. Click OK.

The new calculated column is created.
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Creating a new data set
You can create a new data set that has the same columns as the existing 
data set(s). Column definitions from the latest data set are applied to the 
new data set.

Select Data > New Data Set.

An empty data set is created with the same column definitions as the 
existing data set.

Using advanced data collection options
This section covers setting up more advanced data collection options.

This section’s topics include:

• Setting up an offline sensor

• Selecting a remote collection unit

• Collecting remote data

• Retrieving remote data

• Setting up triggering

Setting up an offline sensor
The Add Offline Sensor option provides you with a method of setting 
collection parameters and changing units for a sensor that is not 
currently attached. 

You cannot use an offline sensor but you can prepare it for use before it 
is attached. This is useful to help speed up a lesson or lab when there are 
not enough sensors for everyone, and the students are waiting for their 
turn to use the sensor.

1. Select Experiment > Advanced Set Up > Configure Sensor > Add 
Offline Sensor.

2. Select a sensor from the drop-down menu.
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The sensor is displayed in the Meter View and is available for set up 
options.

The following is an example of an offline motion detector sensor in 
Meter View.

Selecting a remote collection unit
Only the TI-Nspire™ Lab Cradle, TI CBR 2™, and Vernier Go!Motion® 
support remote data collection.

Parameters for collection setup will use current values. Desired edits must 
be performed before this procedure. See Setting and using a collection 
mode.

To select the collection unit:

1. Set up your experiment for data collection.

2. Select Experiment > Advanced Set Up > Remote Collection.

3. Select the data collection device you want to use from the drop-down 
list.
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The Remote Setup Details dialog box appears.

The following is an example dialog when the TI-Nspire™ Lab Cradle 
was selected.

Other remote collection devices include The Texas Instruments 
CRB 2™ and the Vernier Go!Motion®.

4. (Optional) Enter your delay value.

Setting the delay at zero allows you to use the manual trigger button 
on the lab cradle to start your collection. See Using the manual 
trigger to start the collection.

5. Click OK.

6. When ready, the Remote Setup dialog box is opened. A message 
informs you how to start the collection and that it is safe to 
disconnect the data collection device.

The following is an example message with the delay set to zero.

The following are example messages with the delay set to 11 seconds.
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Collecting remote data
This section describes the procedures for collecting remote data using the 
TI-Nspire™ Lab Cradle. While you can use the lab cradle simply as a 
sensor interface that allows you to use many sensors at one time, the 
TI-Nspire™ Lab Cradle is also a data collection device. 

The lab cradle can be used in conjunction with: 

• TI-Nspire™ handhelds

• TI-Nspire™ software for computers

• As a stand-alone tool. 

To use as a stand-alone collection tool for remote collection, the data 
collection parameters must first be set in the Vernier DataQuest™ 
application as described in Setting up the lab cradle for remote 
collection. 

Note: See the "TI-Nspire™ Lab Cradle Guide" included with the lab 
cradle for more information. (If you do not have the TI-Nspire™ Lab 
Cradle, go to education.ti.com to learn more and how to purchase.)

Setting up the lab cradle for remote collection
Use one of the two following methods for the remote collection:

• Using the manual trigger on the TI-Nspire™ Lab Cradle or a sensor 
with a trigger to start the collection

• Using a delay to start the collection 
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Using the manual trigger to start the collection
1. Save and close any open documents.

When performing experiments it is recommended that you have only 
one document open. The system cannot determine which of the 
documents to use with the sensor if multiple documents are open.

2. Attach a sensor to the TI-Nspire™ Lab Cradle.

3. Attach the TI-Nspire™ Lab Cradle to the computer or handheld.

4. Set up your experiment as desired.

5. Navigate to Experiment > Advanced Set Up > Remote Collection 
> TI-Nspire Lab Cradle.

6. Review the settings. Verify the delay is at zero (no delay). 

Setting the delay at zero allows you to use the manual trigger button 
on the lab cradle to start your collection.

7. Select OK.

A message displays stating the device is ready for remote collection. 
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8. Disconnect the cradle before pressing the OK in the message box.

9. When the TI-Nspire™ Lab Cradle is disconnected from the handheld 
or computer, verify the status. When the LED transfer is blinking 
amber it is ready and waiting.

10. When you are at the site to collect the data, click the trigger button 
on the lab cradle. The data collection will start immediately.

After you have collected your data see Retrieving data from remote 
data collection.

Using a delay to start the collection
1. Save and close any open documents.

When performing experiments it is recommended that you have only 
one document open. The system cannot determine which of the 
documents to use with the sensor if multiple documents are open.

2. Attach sensor to the TI-Nspire™ Lab Cradle.

3. Attach the TI-Nspire™ Lab Cradle to the computer or handheld.

4. Set up your experiment as desired.

5. Navigate to Experiment > Advanced Set Up > Remote Collection 
> TI-Nspire Lab Cradle.

6. Review the settings. Specify the time (in seconds) to delay the start of 
the collection. 
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When you use a delay, the manual trigger button on the TI-Nspire™ 
Lab Cradle has no impact on the start of the collection.

7. Select OK.

A messages displays informing you it will use your delay value to start 
the collection.

8. Select OK when you are ready to begin the countdown.

A message displays stating the countdown has begun. 

9. Disconnect the cradle.

10. Proceed to collect your data.

11. At some point after the collection, click OK on the Remote Setup 
dialog box.

After you have collected your data see Retrieving remote data.

Retrieving remote data
Use this procedure for retrieving the remote data collection.
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Follow these steps after you collected your data with the TI-Nspire™ Lab 
Cradle. 

1. Open the Vernier DataQuest™ application.

2. Attach the TI-Nspire™ Lab Cradle to the handheld or computer.

3. Shortly, the Remote Data Detected message box displays: "The 
connected device has remote data. Do you wish to import or discard 
the data?" 

4. Select Import.

The data is now in the Vernier DataQuest™ application.

Setting up Triggering
Data collection can be set to start based on a specific sensor reading. This 
functionality is only available when using the TI-Nspire™ Lab Cradle.

Setting up the sensor for triggering
Set the sensor and the threshold type for the system to use when 
analyzing when the trigger is reached so it can start the data collection.

You must have the TI-Nspire™ Lab Cradle and sensor connected to 
perform this procedure.

1. Select Experiment > Advanced Set up > Triggering > Set Up.

The Configure Trigger dialog box is opened.
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2. Enter desired values.

• Select the sensor to use as trigger. - The drop-down menu 
displays the sensors connected to the TI-Nspire™ Lab Cradle. 
Select the sensor you want to use.

• Select the type of trigger to use. - Select one of the following 
from the drop-down menu:

– Increasing through threshold - Use this option when you 
want the trigger on increasing values.

– Decreasing through threshold - Use this option when you 
want the trigger on decreasing values.

• Enter the trigger threshold in units of the selected sensor. - 
When entering the value to start the trigger, enter a value within 
the range of your sensor. The value should be in regards to the 
current sensor units you are using. 

If you change the unit type after setting the threshold the value 
will automatically be updated.

For example, if using the Vernier Gas Pressure sensors units with 
the units as atm and you later change the units to kPa, the 
settings are updated. 

• Enter the percentage of the points to keep prior to the trigger 
event. - You can specify a percentage amount of data points to 
keep before the trigger value occurs.

3. Click OK.
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The trigger is now set and enabled if valued values were entered. You 
can select Experiment > Advanced Set up > Triggering to verify the 
active indicator is set to Enabled.

Important: When the Trigger is enabled, it stays active until it is disabled 
or a new experiment is started.

Enabling the trigger
If you have previously set the trigger values in the current experiment 
and have it disabled, you can enable the trigger.

Select Experiment > Advanced Set Up > Triggering > Enable.

The trigger is now active.

Disabling the trigger
You can disable the active trigger.

Select Experiment > Advanced Set Up > Triggering > Disable.

The trigger is no longer active.

Working with advanced analysis features
This section examines features not as commonly used when performing 
experiments but are valuable to know about and use when applicable.

This section’s topics include:

• Replaying the data collection

• Striking and restoring data

• Adjusting derivative settings

• Drawing a predictive plot

• Using Motion Match

• Examining graphs using Page Layout
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Replaying the data collection
Use the Replay option to playback the experiment’s data collection. This 
option enables you to: 

• Pause the playback.

• Advance one point.

• Adjust the playback rate.

• Repeat the playback. 

Starting the playback
To start a data set’s playback:

Select Experiment > Replay > Start Playback.

Playback of the data set run starts, and the Data Collection Control 
buttons change to Stop Playback, Pause, and Advance by One Point. 
The Advanced by One Point button (and menu item) is inactive until 
you pause the replay.

Pausing and resuming the playback
To pause the playback:

Select Experiment > Replay > Pause or click .

The following events occur:

• The playback is paused.

• The menu option changes to "Resume." 

• The button changes to .

• The menu option Advance by One Point and the button  
become active.

To restart the playback after pausing: 

Select Experiment > Replay > Resume or click  to restart the 
playback.



778 Data Collection and Analysis

The playback resumes.

Advancing the playback by one point
This option enables you to advance the playback point by point. The 
playback must be active and paused for this option to be available. 

To advance the paused playback:

Select Experiment > Replay > Advance One or click .

The playback advances by one point until the last point is reached. 

Adjusting the playback rate and repeating the playback
1. Select Experiment > Replay > Playback Rate.

The Playback Rate dialog box opens.

2. In the Playback Rate field, click ¤ to open the drop-down menu.

3. Select the rate at which the playback will play.

Normal speed is 1.00. Less is slower, higher is faster.

4. Decide whether you want to repeat the playback. 

5. Select one of the following:

• Click Start to start the playback and save your settings.

• Click OK to save you settings for use on your next playback.

Selecting a data set to replay
You can only replay one data set at a time. By default, the latest data set 
plays using the first column as the base column (example: time 
reference). 

If you have multiple data sets, and want a different data set or base 
column than the default, use this procedure to select which data set to 
run and to select your base column.

To select the data set to replay:
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1. Select Experiment > Replay > Advanced Settings.

The Advanced Replay Settings dialog box is opened.

2. Select which data set to replay from the Data Set drop-down menu.

3. (Optional) Select a new value from the Base Column list.

The selected column will act as the “Time” column for the replay.

Note: The base column should be a strictly increasing list of numbers.

4. Select one of the following:

• Click Start to start the playback and save your settings.

• Click OK to save your settings for use on your next playback.

Note: Data Set and Base Column options are dynamic depending on 
number of stored runs and sensor type used.

Note: Changing the run in the Data Set selection tool  will not affect 
the playback choice. You must specify which data set in 
Experiment > Replay > Advanced Settings.

Data Set selection tool:

If you set the replay for run2 and switch to run1, you will not see the 
data replayed.

Striking and restoring data
Data that is struck is not deleted and can be restored. Struck data is 
temporarily ignored when graphing data or performing computations. 
Struck data is shown in the table with a single line through the value. On 
the graph, the struck data points are not visible. At least one point must 
be selected from a table or graph to strike data.
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Data can be struck in Graph View or Table View. You can strike data in 
one view and review it in another (between Graph and Table views). You 
cannot see struck data in Meter View.

Striking data in Graph View
1. To start this procedure, open a data set that contains data to be 

struck.

The following is an example graph with all data unstruck (before any 
strike was performed):

2. Select View > Graph or click .

3. With your graph displayed, select the region you want to strike or to 
protect from the strike. (See Selecting a range for instructions on how 
to select a range.)

Note: You have the option to strike all data in the selected region or 
strike all data outside the selected region.

4. Select Data > Strike Data or open the context menu in the graph and 
select Strike Data.

Handheld: Click b and select Data > Strike Data or click 

/ + b and select Strike Data.

5. Select one of the following:

• In Selected Region: Strike the data from the area you selected.

• Outside Selected Region: Strike all data except the area you 
selected.

6. Click on the graph, off the selected area to remove the gray shading.
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Striking data in Table View
1. To start this procedure, open the data run that contains the data to 

be struck.

2. Select View > Table or click .

3. Select your starting row and scroll to your ending point. To select the 
region: 

Strike results -

In Selected Region 
selected.

Strike results -

Outside Selected 
Region selected.
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Hold the right-button on the mouse down and drag your cursor to 
the bottom or top of the screen (depending on the direction of your 
selection). This “pushes” the cursor to select the area out of your 
immediate view. It will scroll the screen so you can see the selection.

Handheld:

• Select the first cell by clicking with the Touchpad and holding until 
the cell is filled. 

• Release and move your cursor across cells until the row is selected.

• Move your cursor to the bottom or top of the screen to select the 
rest of your region.

In this example, row 21 is selected as the beginning area and row 147 
as the end.

4. Select Data > Strike Data or open the context menu in the table and 
select Edit > Strike Data.

Handheld: Select b then Data > Strike Data or / + b then 
Edit > Strike Data.

5. Select one of the following:

• In Selected Region: Strike the data from the area you selected.

Beginning of 
selections

End of selection.
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• Outside Selected Region: Strike all data except the area you 
selected.

You can switch views and still see the results.

Strike results -

In Selected Region 
selected.

Strike results -

Outside Selected 
Region selected.
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Restoring struck data
You can restore previously struck data in any view.

1. Select the range of data to restore or if restoring all struck data, start 
at step two.

See Selecting a range for instructions on how to select a range.

2. Select Data > Restore Data or from the context menu select Edit > 
Restore Data.

3. Select one of the following:

• In Selected Region - Restore data in your selected area.

• Outside Selected Region - Restore data outside your selected 
area.

All Data - Restore all data. No selection necessary.

Adjusting derivative settings
Use this option to select the number of points used in derivative 
calculations. This value affects the tangent tool, velocity, and 
acceleration values.

1. Select Options > Derivative Settings.

Strike results -

In Selected Region 
selected.

Strike results -

Outside Selected 
Region selected.
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2. Select the number of points from the drop-down menu.

3. Click OK.

Drawing a predictive plot
Use this option to draw the predicted outcome of an experiment by 
adding points to your graph.

Drawing the prediction
To draw the prediction:

1. Select Analyze > Draw Prediction > Draw.

2. Move your cursor over the graph, clicking at each area you want to 
place the point. 

3. Click the Esc key to release.

Handheld: Press d to release.

The following image is an example of a drawn prediction.

Clearing the prediction
To clear the drawn prediction:

Select Analyze > Draw Prediction > Clear.
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Using Motion Match
Use this option to create a randomly generated plot on position vs. time 
or velocity vs. time graphs.

This feature is only available when using a motion detector like the 
CBR 2™ sensor or the Go!Motion® sensor. 

Generating a Motion Match plot
To generate a plot:

1. Attach the motion detector.

2. Select View > Graph or click .

3. Select Analyze > Motion Match.

4. Select one of the following:

• New Position Match - Generates a random position plot.

• New Velocity Match - Generates a random velocity plot.

The following image is an example of the Motion Match (New 
Velocity Match) generated plot:

Note: You can keep selecting a new position or a new velocity match to 
generate a new random plot without removing the existing plot.

Removing a Motion Match plot
To remove the generated plot:

Select Analyze > Motion Match > Remove Match.
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Examining graphs using Page Layout
You can use the Page layout functionality when Show Graph is not the 
appropriate solution for showing more than one graph.

The Show Graph option is not applicable when:

• You have multiple runs using a singe sensor.

• When using two or more of the same sensors.

• When you have multiple sensors that use the same column(s) of data.

In these situations the Page Layout functionality is useful.

Note: See the chapter, Using multiple applications on a page, for more 
information about Page Layout.

To use Page Layout:

1. Open the original data set you want to see in two graph windows.

In this example, the data set is using two of the same sensors.

2. Select Edit > Page Layout > Selected Layout or click .

Handheld: Press ~ and select Page Layout > Select Layout.

3. Select the type of page layout you would like. 

In this example, the top and bottom  page symbol was selected.
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4. Click inside the window that reads, “Click here to add an 
application.”

Handheld: The text reads “Press Menu”. Click in the window and 
press b.

5. Select Add Vernier DataQuest from the drop-down menu.

This example screen shows two running Vernier DataQuest™ 
applications.

6. To see separate views, click the view you want to change and select 

View > Table (or the view you want) or click .

The window displays your change.
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7. To show the same view, click the view to change, then select View > 

Graph (or the view you want) or click .

The window displays your change.

To show the plots separately: 

8. Click the top graph to select it.

9. Select Graph > Select Y-axis Columns.

10. Select the first Pressure value (or unit you are working with).

Note:

Selection 
in one 
view is 
reflected 
in the 
other
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The graph now displays only one of the columns.

11. Select the bottom application and repeat steps nine and ten but 
select the second data value.

The application shows the changes.
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Note: You could also use the same procedure for graphs with 
multiple runs. 

To use procedure for multiple runs:

• Repeat steps one through seven. 

• Set the Data Set selection tool for the runs on each graph.

Your window will look similar to the window is the following 
example.
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Printing data views
This section includes printing information when using the Vernier 
DataQuest™ application.

This section includes:

• Selecting Print All options

• Printing

You can print any active view when selecting to print the viewable 
screen, however, with the Print All option you can print one data view, all 
of the data views, or a combination of the data views when printing.

Select Options > Print All Settings to determine which view(s) will be 
printed when you select Print All as your print selection. By default, if not 
set, only the displayed view will be printed. 

The Print All option has no affect in applications outside of the Vernier 
DataQuest™ application.

Handheld: You can use this option to set the printing options for when 
Print All is selected, but printing can only be performed from the 
computer.

Setting Print All options
1. Select Options > Print All Settings.

Run1

Run2
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2. Select one of the following:

• Print Current View

When printing, the current view is sent to the printer.

No other steps needed for setup.

• Print All Views

When printing, all three views (Meter, Graph, & Table) are sent to 
the printer.

No other steps needed for setup.

• More

When printing, only the views selected are sent to the printer.

If More is selected:

– Activate the option boxes of the views to print.

– Click OK.

The Print All settings are now complete and can be used when 
printing.

The following image is an example of the More setting. In this 
example, the Graph and Table view are set to print when Print All is 
selected and the print command is executed.

Printing
Printing can only be performed on the computer.

1. Select File > Print.

2. Select Print All from the Print What drop-down menu.

3. Complete any additional printing options you desire.

See the chapter Working with TI-Nspire™ Documents for information 
about the other options.

4. Click Print.

The following example shows the print dialog box with Print All selected.
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Using sensors and data with other Apps
Predominantly, you want to perform all your data collection and analysis 
in the Vernier DataQuest™ application because it is the most feature rich 
for data collection. However, for times when you need to examine data 
or use sensors with other TI-Nspire™ applications, use the Sensor Console 
function.

The Sensor Console is a specialized view of the Vernier DataQuest™ 
application designed for using sensors with other TI-Nspire™ 
applications such as Graphs & Geometry and Data & Statistics.

Sensor Console works with the following applications: 

• Graphs

• Geometry

• Data & Statistics

• Lists & Spreadsheet 

When performing experiments it is recommended that you have only 
one document open. The system cannot determine which of the 
documents to use with the sensor if multiple documents are open.

This section’s topics include:

• Collecting data in other applications

• Opening the Sensor Console application menu
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• Opening the Sensor Console context menu

• Viewing existing data

• Special steps for Data and Statistics

Collecting data in other applications
Use the Sensor Console to collect data using a sensor in another 
TI-Nspire™ application.

To use Sensor Console with a sensor:

1. Open the application you want to use to capture the data.

Example: Graphs

2. Click Insert > Sensor Console or click anywhere in the application 
and press Ctrl + D.

Handheld: Press b + Insert > Sensor Console or /  + D.

3. Attach the sensor to use if not already attached. Wait a moment for 
the Sensor Console area to appear active.

4. Click Collect Data > Start Collections or click .

5. Wait for the data set to end or stop the collection.

Computer: To stop collection: Collect Data > Stop Collection or click 

.

Handheld: To stop collection: Press b and select Collect Data > 

Stop Collection or click .

6. Click Collect Data > Close Console or click .

The data collection is available for use in the current application. 

Opening the Sensor Console application menu
The Sensor Console menus are a subset of the Vernier DataQuest™ 
application menus previously covered in this document. 

Example Sensor Console area with the Gas Pressure sensor 
attached.
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Accessing the menu on the computer
To Access the Sensor Console menu from an application running Sensor 
Console:

1. Click anywhere on the Sensor Console bar to see the Sensor Console 

Menu (  Collect Data).

2. Select Collect Data.

The Sensor Console application menu opens.

Accessing the menu on the handheld

1. Click anywhere on the Sensor Console area and click b to see the 

Sensor Console menu (  Collect Data).

2. Select Collect Data.

The Sensor Console application menu opens.
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Opening the Sensor Console context menu
The Sensor Console menus are a subset of the Vernier DataQuest™ 
application menus previously covered in this document. 

Accessing the context menu on the computer

To Access the Sensor Console context menu from an application running 
Sensor Console:

Right click the Sensor Console bar.

The Sensor Console context menu opens.

Accessing the context menu on the handheld

To Access the Sensor Console context menu from an application running 
Sensor Console:

1. Click on the Sensor Console bar.

2. Press / b.

The Sensor Console context menu is opened.
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Viewing existing data
You can view data collected from a different TI-Nspire™ application in 
your current application. 

1. Open the document with your captured data set.

For example, open the Graphs application.

2. Select Insert > [your other application].

For example, insert Lists and Spreadsheet.

Your selected application opens.

3. Select Insert > Sensor Console.

The Sensor Console area is opened at the bottom of the application.

In this example a sensor is attached, but it doesn’t have any affect on 
this procedure.
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4. Select Collect Data > View Data in Apps on Current Page or Open 
the context menu in the Sensor Console area.

Handheld: Click in the Sensor Console area.

Press b then Collect Data > View Data in Apps on Current Page 

or click in the Sensor Console area and click / + b and then 
select View Data in Apps on Current Page.

Wait until the data is populated. After a few moments, the data is 
displayed.

5. Select Collect Data > Close Console.
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You can now work with the data in the current application.

Special steps for Data and Statistics
When opening existing data in the TI-Nspire™ Data and Statistics 
application, the data first displays as a Dot Point graph. There are 
additional steps required to organize the points.

The following image is an example of existing data opened as a Dot 
Point graph in the Data and Statistics application:

This procedure assumes you have already collected data in another 
application. 

1. Open the Data and Statistics application with the existing data.

2. Click on the y-axis side of the text on the screen “Click to add 
variable.”

3. Select the variable.

4. Click on the x-axis side of the text on the screen “Click to variable.”
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5. Select the variable.

The data is replotted.

Reference of Menus

Vernier DataQuest™ application menus
The following is a list of the Vernier DataQuest™ application menus and 
a brief explanation of their functions for your reference. 
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Experiment menus

Menu - Experiment  Description 

New Experiment Starts a new experiment, resetting 
defaults (such as units, sampling rate, 
and mode). New Experiment also 
removes any previous data sets.

Start / Stop Collection Starts or stops the collecting of data. 

Store Data Set Creates a new data set for 
subsequent data collections so 
collected data is not overwritten. This 
is only available when data is present. 
The data set is not saved permanently 
until you save the document file. 

Keep Stores the current connected sensor’s 
values. Keep stores a specific data 
point. This option is available when 
Events with Entry or Selected Events 
is specified for the Collection Mode 
option. 

Extend Collection (value s) Extend Collection (value s) “value” 
represents the new data collection 
duration after the extend has been 
selected. “s” represents the time unit, 
“seconds.” This option extends the 
duration of an active experiment. It is 
only enabled for time-graph modes. 

Replay Replays the experiment’s data 
collection. 

Start Playback Start the collection playback.

Pause / Resume Pause and/or resume playback of the 
data collection. 

Advance One Advance one point. Playback must be 
active and paused for this option to 
be available. 

Playback Rate Specify speed and whether to repeat 
the playback.
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Advanced Settings Select which data set to replay and 
the Base Column.

Collection Mode Select the mode of collection. The 
default is Time based.

Time Based Capture data with respect to time.

Events with Entry Capture samples manually every time 

"Keep current reading"  is 
selected from the Graph View data 
collections controls area. In Events 
with Entry, you define the value. 

Selected Events Capture samples manually every time 

"Keep current reading"  is 
selected from the Graph View data 
collections controls area. In Selected 
Events, the "x" value will 
automatically be the sample number.

Photogate Timing Used only with a Photogate sensor.

Drop Counting Used only with Drop Counter sensor.

Collection Setup Configure the data collection. 

Setup Sensors Use to modify the values returned by 
the sensor. 

Change Units Units are variable depending on the 
sensors.

Menu - Experiment  Description 
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Calibrate When a sensor is detected, it 
automatically loads a calibration for 
that sensor. If you wish to edit a 
sensor’s calibration, you can do so by 
manually entering new calibration 
values or by using either a single-
point or two-point calibration 
procedure. Note: Some sensors 
cannot be calibrated while other 
sensors, such as the Colorimeter and 
the Dissolved Oxygen Probe, must be 
calibrated to be useful. 

Zero Change the standing value in meter 
view to zero.

Reverse Changes the sign of sensor reading. 
This only available for sensors where 
direction is relevant (for example, 
motion detectors and force sensors).

Advanced Setup Set up more advanced data collection 
options including remote collection 
and triggering.

Remote Collection Set up supported data collection 
devices for data collection without a 
handheld or computer.

Supported devices: TI-Nspire™ Lab 
Cradle, TI CBR 2™, and Vernier 
Go!Motion®.

Triggering Data collection can be set to start 
based on a specific sensor reading. 
This functionality is only available 
when using the TI-Nspire™ Lab 
Cradle.

Configure Sensor Set up sensors that are not 
automatically identified or not 
available when creating a data 
collection document.

Menu - Experiment  Description 
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Add Offline Sensor The offline option provides the 
teacher or student with a method of 
setting up the sensor without actually 
having to attach the sensor. 

Menu - Experiment  Description 
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Data menus

Menu - Data  Description 

Column Options Set the column name, units, and 
precision. All existing data columns 
are listed.

New Manual Column Add a column for manual entry of 
data. Manual columns include a 
Generate Values option for quickly 
adding sequential data. Manual 
columns can also be linked to list data 
that was created outside of the 
Vernier DataQuest™ application.

New Calculated Column Add an additional column to the data 
set where the values are calculated 
from an expression using at least one 
of the existing columns.

New Data Set Create a new data set having the 
same columns as the existing data 
set(s). Column definitions from the 
latest data set are applied to the new 
data set.

Strike Data Mark data that should be ignored 
when graphing data or performing 
computations. 

In Selected Region The data that is in the selected region 
will be struck.

Outside Select Region The data that is not currently selected 
will be struck.

Restore Data Restores previously struck data. 

In Selected Region Restores any selected struck data.

Outside Selected Region Restores any struck data that is not 
currently selected.

All Data Restore all struck data. No selection 
needed.
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Graph menus

Menu - Graph  Description 

Note: The Graph menu is only 
available when in the Graph View.

Show Graph The application has the option to 
display one or two graphs in the 
Graph View. Use this option to 
determine which graph(s) to display.

Graph 1 Show one graph, Graph 1 (top 
graph). Graph 1 is always shown by 
default.

Graph 2 Show one graph, Graph 2 (bottom 
graph).

Both Show both Graph 1 and Graph 2. 
Both graphs are shown by default for 
sensors that plot more than one 
column of data, or when multiple 
sensors have defined units that are 
different are used at the same time.

Graph Title Add a title to the displayed graph(s).

Select X-axis Column Select the column used as the 
independent variable when graphing 
the data. 

Note: This column is used for all 
graphs.

Select Y-axis Column Select which dependent variable 
columns to plot on the displayed 
graph(s).

Select Data Set Select which data set is plotted when 
there is more than one date sets 
available.

Run1 (or other data set 
name)

Selecting a specific data set will 
display data from only that data set 
on the graph(s).

All Select data from all runs to be 
displayed on the graph(s). 
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More Use this option to select two or more 
data sets from which to plot the data 
on the graph(s). Not all data sets are 
required to be selected. 

Window Settings Modify minimum and maximum 
range for x and y axes. Displays values 
for all active graphs.

Autoscale Now Rescales the graph so that all points 
from the plotted y-scale columns will 
be displayed on the graph. Available 
anytime there is data on the graph.

Zoom in Zoom in view. If a region of the graph 
is selected, the selected x range will 
be used as the new x-range. The y- 
will autoscale to show all graphed 
data points in the selected range.

Zoom Out Zoom Out view. If Zoom In precedes a 
Zoom Out, Zoom out will return the 
window settings prior to the Zoom In.

Menu - Graph  Description 
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Analyze menus

Menu - Analyze  

Note: The Analyze menu is only 
available when in the Graph View.

Interpolate Use to estimate the value between 
two data points. Use to determine 
the value of a Curve Fit between and 
beyond data points.

Tangent Use to determine the rate at which 
the data is changing at a given point. 
The value is displayed in the View 
detail area and in the All Details for 
Graph dialog box.

Examine Settings Allows you to select which of the 
plotted columns and curve fit you 
would like to trace when examining 
the data. Values are displayed in the 
View details area.

You can also show cursor position and 
delta values as you examine the data 
by selecting the Position and Delta 
option. The values are displayed 
below the graph.

Integral Use to determine the area under a 
data plot. You can find the area 
under all of the data or a selected 
region of data. The value is displayed 
in the View details area and in the All 
Details for Graph dialog box.

Statistics Use to determine the statistics 
associated with the plotted data. 
Minimum, maximum, mean, standard 
deviation, and number of samples are 
calculated. You can find the statistics 
for all the data or a selected region of 
data. The values are displayed in the 
View details area and in the All 
Details for Graph dialog box.
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Curve Fit Find a best fit curve to match your 
data. Fit all of the data or a selected 
region of data. The curve is drawn on 
the graph and the equation 
information is displayed in the View 
detail area and in the All Details for 
Graph dialog box.

Linear This fit is calculated in the form of 
y = m*x + b.

Quadratic This fit is calculated in the form of 
y = a*x^2 + b*x + c.

Cubic This fit is calculated in the form of 
y = a*x^3 + b*x^2 + c*x + d.

Quartic This fit is calculated in the form of 
y = a*x^4 + b*x^3 + c*x^2 + d*x + e.

Power (ax^b) This fit is calculated in the form of 
y = a*x^b. 

Exponential (ab^x) This fit is calculated in the form of 
y = a*b^x.

Logarithmic This fit is calculated in the form of 
y = a + b*ln(x).

Sinusoidal This fit is calculated in the form of 
y = a*sin(b*x + c) + d.

Logistic (d  0) This fix is calculated in the form of 
y = c/(1 + a*e^(-bx)) + d.

Natural Exponential This fit is calculated in the form of 
y = a*e^(-c*x).

Proportional This fit is calculated in the form of 
y = a*x.

Model This option provides a manual 
method of plotting a function to fit 
data. Use one of the predefined 
models or enter your own.

Menu - Analyze  
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Remove Clears previous analyzed data from 
the graph, the View Details area and 
the All Details for Graph dialog box. 
You can choose to clear all or select 
specific data to clear.

Draw Prediction Predict the outcome of an 
experiment by adding points to your 
graph.

Draw Manually set data points. Line 
appears between data points.

Clear Clears data points and lines created.

Motion Match Creates a randomly generated plot 
on position vs. time or velocity vs. 
time graphs.

Only available when using a motion 
detector like the CBR 2™ sensor or 
the Go!Motion® sensor. 

Remove Match Remove motion match plots.

New Position Match Add a motion match plot to the 
position vs. time graph.

New Velocity Match Add a motion match plot to the 
velocity vs. time graph.

Menu - Analyze  
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View menus

Options menus

Menu - View  Description 

Meter Displays the Meter view of the 
Vernier DataQuest™ application. 

Graph Displays the Graph view of the 
Vernier DataQuest™ application.

Table Displays the Table view of the Vernier 
DataQuest™ application. 

Menu - Options  Description 

Point Options Change the way your points are 
plotted on your graphs.

Autoscale Settings Set autoscale behavior during and 
after data collection.

Derivative Settings Select the number of points used in 
derivative calculations. This value 
affects the tangent tool, velocity, and 
acceleration values.

Print All Settings Use to determine which Vernier 
DataQuest™ view(s) will be printed 
when Print All is selected within the 
TI-Nspire™ software. 

Note: Specifying the print settings 
can be done from the computer or 
handheld, however, printing is only 
available from a computer.

Print Current View Print the current view (Meter, Graph, 
or Table).

Print All Views Print all views as previously set in the 
More settings.

More Specify the views that apply when 
"Print All" is selected. 
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Sensor Console application menu options

This is the menu you see when selecting Collect Data. 

Show/Hide Meters Modify which columns display a 
meter in the Meter View.

Show/Hide Details Show or Hide the Detail View. 

Menu -  Collect Data Description 

New Experiment Starts a new experiment, resetting 
defaults (such as units, sampling rate, 
and mode). New Experiment also 
removes any previous data sets.

Start/Stop Collection Starts or stops the collecting of data. 

Store Data Set Creates a new data set for 
subsequent data collections so 
collected data is not overwritten. This 
is only available when data is present. 
The data set is not saved permanently 
until you save the document file. 

Keep Stores the current connected sensor’s 
values. Keep stores a specific data 
point. This option is available when 
Events with Entry or Selected Events 
is specified for the Collection Mode 
option. 

Replay Replays the experiment’s data 
collection.

Start Playback Start the collection playback.

Pause/Resume Pause and/or resume playback of the 
data collection.

Advance One Advance one point. Playback must be 
active and paused for this option to 
be available.

Menu - Options  Description 
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Sensor Console context menu options
This is the menu you see when accessing the Sensor Console context 
menu.

Playback Rate Specify speed and whether to repeat 
the playback.

Advanced Settings Select which data set to replay and 
the Base Column.

Collection Mode Select the mode of collection. The 
default is Time based.

Time Based Capture data with respect to time.

Events with Entry Capture samples manually every time 

"Keep current reading"  is 
selected.

Selected Events Capture samples manually every time 

"Keep current reading"  is 
selected.

Photogate Timing Used only with a Photogate sensor.

Drop Counting Used only with Drop Counter sensor.

Collection Setup Configure the data collection.

Set Up Sensors Use to modify the values returned by 
the sensor. 

View Data in Apps on Current 
Page

View existing data in the current 
application.

Close Console Close the Sensor Console application.

Menu - Sensor Console Con-
text menu

Description 

Change Units Units are variable depending on the 
sensors.

Menu -  Collect Data Description 
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Calibrate Enter manual calibration to override 
the sensors automatic calibration 
when the sensor is attached. 

Manual Entry Manually enter known calibration 
equation values.

Two Point Create a linear calibration curve using 
two known points. This method 
adjusts both slope and intercept of 
the calibration equation.

Single Point Modify the calibration equation 
using a single reference point. Only 
the intercept of the calibration 
equation is modified using this 
method.

Zero Change the standing value in meter 
view to zero.

Meter Display Displays the values to appear in the 
Sensor Console view of the meter 
such as Name, Unit, and the displayed 
precision.

Collection Settings Displays the data collection 
parameters for the current mode.

This option also provides buttons for 
you to configure the data collection 
parameters such as Mode, Rate, 
Interval, and Duration.

View Data In Apps on Current 
Page

Displays the data previously collected 
in a different application in the 
current application. Works with 
Graphs, Geometry, Data & Statistics, 
and Lists & Spreadsheet applications.

Close Console Closes the Sensor Console.

All Details Displays the data collection 
parameters for the current mode.

Same menu as Collection Settings.

Menu - Sensor Console Con-
text menu

Description 
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Using the TI-SmartView™ emulator

The TI-SmartView™ panel enables you to emulate the TI-Nspire™ CX, 
TI-Nspire™ with Touchpad, and the TI-Nspire™ with Clickpad handhelds 
in the following TI-Nspire™ software:

• TI-Nspire™ Teacher Software

• TI-Nspire™ CAS Teacher Software

• TI-Nspire™ Student Software

• TI-Nspire™ CAS Student Software

• TI-Nspire™ Navigator™ Teacher Software

With three layout options to choose from, teachers will find that the 
emulator facilitates classroom presentations. In the teacher software, 
layout options are:

• Handheld only

• Keypad plus side screen

• Handheld plus side screen

In the student software, the TI-SmartView™ emulates the keypad, which 
along with the handheld view, gives students the ability to drive the 
software as if using a handheld.

Opening the TI-SmartView™ emulator 
The TI-SmartView™ emulator is located in the Documents Workspace. To 
open the emulator view:

1. Open the Documents Workspace.

2. Click , which is located in the Documents Toolbox.

In the teacher software, the handheld is displayed with Handheld and 
SideScreen panels open in computer mode as shown in the following 
illustration. You can use the keypad on the emulated handheld, but 
the document won’t appear on the emulated handheld screen until 
you switch to Handheld mode.
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In the student software, the TI-Nspire™ CX keypad is displayed with the 
side screen open in computer mode. You can use the keypad on the 
emulated handheld, but the document won’t appear on the emulated 
handheld screen until you switch to Handheld mode.

3. Select View > Handheld or click  in the status bar to switch to 
handheld mode. 
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Choosing a keypad
An open document is not affected by changing the keypad. You can 
switch between keypads anytime you want. To select a keypad: 

1. In the emulator panel, click  to open the drop-down menu and 
select one of the following options:

• TI-Nspire™ CX

• TI-Nspire™ with Touchpad

• TI-Nspire™ with Clickpad

2. Click ¢ to select a faceplate option:

• Normal

• High Contrast

• Outline 

Choosing a display option
In the teacher software, use this option to choose how to display the 
emulator in the software window.

1. In the emulator panel, click  or select File > 
Settings > TI-SmartView™ from the menu bar to open the drop- 
down menu.

2. Select one of the following options:

• Handheld Only - displays the emulated handheld and hides the 
work space and other panels.

Note: To keep the Handheld Only display in front of other 
application windows, click Always in Front at the top right of the 
TI-SmartView™ panel.

• Keypad + SideScreen - opens a larger view of the keypad along 
with the side screen.

• Handheld + SideScreen - opens the entire emulated handheld 
along with the side screen.

Changing the size of the TI-SmartView™ panel 
and side screen

Changing the width of the TI-SmartView™ panel
To change the width of the TI-SmartView™ emulator panel:
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Click the right edge of the panel and drag it until it is the width you 
want.

Changing the size of the screen in the workspace
When in handheld mode, use the Scale to change the size of the screen.

Drag the slider to the appropriate scale percentage. The scale slider is 
located on the far right side of the status bar, at the bottom of the 
TI-Nspire™ window. Scale percentages range from 100% to 200%. 
The default scale is 150%. 

Note: If computer mode is selected, you cannot change the size of the 
workspace.

Working with the emulated handheld
To input data and work with files on the emulator, you can use the 
computer keyboard, TI-SmartView™ keypad, TI-Nspire™ menus and 
icons, or any combination of these. 

Note: Within one command, you cannot use a combination of both the 
keypad and the keyboard. For example, you cannot press Ctrl on the 
keyboard and click b on the emulator to open a context menu. 

For the most part, you can perform any function in the TI-SmartView™ 
emulator that you can perform on the handheld. Keys and applications 
operate the same way. 

Note: If you switch to Computer mode, you can still use most of the keys 
on the emulated handheld or keypad and all keystrokes are reflected in 
the work space. However, some key combinations may only work in 
Handheld mode.

As you click keys on the emulator or press keys on the keyboard that 
activate keys on the emulator, those keys change color, making it easy for 
your audience to follow along. The last key selected stays highlighted.

In the teacher software, the emulator screen and the side screen are both 
interactive. You can click on icons and menu items on both screens. You 
can also right-click to display menus on both screens.

All handheld shortcuts and arrow functionality work from the computer 
keyboard. For example, to save a document, you can click / S on the 
emulator keypad or you can press Ctrl + S on the computer keyboard. 
When using a Macintosh®, press “ + S.
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Using the Touchpad
You can operate the touchpad on the TI-Nspire™ Touchpad keypad using 
either the touchpad on a laptop or by using the mouse to click the 
Touchpad. Areas of the Touchpad are highlighted as you click the arrow 
zones. 

• Clicking the ¡, ¢, £, or ¤ keys on the Touchpad moves through 
menus one item at a time.

• Clicking and holding down an arrow on the Touchpad causes 
continual movement in the selected direction.

• Clicking and sliding the mouse across the Touchpad area enables you 
to move the mouse pointer.

• Clicking the middle of the Touchpad selects the highlighted menu 
option.

Using the Clickpad
You can use the Clickpad on the TI-Nspire™ Clickpad keypad using either 
the touchpad on a laptop or by using the mouse to click the Clickpad. 
Areas of the Clickpad are highlighted as you click the arrow zones.

• Clicking the ¡, ¢, £, or ¤ keys on the Clickpad moves through menus 
one item at a time.

• Clicking and holding down an arrow on the Clickpad causes continual 
movement in the selected direction.

• Clicking the middle of the Clickpad selects the highlighted menu 
option.

An arrow is highlighted when 
you click or tap it.
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Using settings and status
When working with the TI-SmartView™ emulator, you can change 
General Settings and Document Settings. See Using the Documents 
Workspace for information about changing these settings.

You can view all other settings, but you cannot change them in the 
TI-SmartView™ emulator. However, the ability to view these options 
provides teachers with an instructional tool when they need to show 
students how to set up a handheld.

To view settings and status:

1. Click c to access the Home screen.

2. Click Settings. 

Changing TI-SmartView™ options
You can change the emulator options, even when the emulator panel is 
closed. 

1. In the teacher software, select File > Settings > TI-SmartView™ 
Options. 
The TI-SmartView™ Options dialog box opens.

Setting or 
Settings

Description

Language You can open the languages drop-down menu and 
select a language, but you cannot save changes. To 
change the language, use the TI-Nspire™ menu 
File > Settings > Change Language.

Handheld Setup You can open the drop-down menus and select 
items to demonstrate which items to choose, but 
you cannot save any changes.

Handheld Status You can access the screen. The # symbol replaces 
any numerical values that would be displayed on the 
handheld.

About You can open the About screen and view the 
software version. Other information that pertains 
only to the handheld hardware is marked as "Not 
Applicable."

Login You can display the Login to Class screen and type 
in the User Name and Password fields. Login is not 
available. 
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In the student software, select File > Settings > Keypad Options.
The Keypad Options dialog box opens.

2. Click Browse to change the folder where documents are saved and 
accessed in the My Documents folder when using the emulator.

3. Click ¤ to open the drop-down menu and select a keypad.

4. Click ¤ to open the drop-down menu and select a faceplate.

5. In the teacher software, click ¤ to open the drop-down menu and 
select a view. If selecting Handheld only, check Always in Front to 
keep this window on top of all other open applications.

Working with documents
You can open multiple documents in the workspace by selecting 
File > Open Document from the menu or using keyboard shortcuts. 
When you switch between these documents, the emulated handheld 
shows only the current document. You can insert pages and problems 
using either the TI-Nspire™ menus or icons, keyboard shortcuts, or 
TI-SmartView™ menus or shortcuts.

Opening a document
You can open a document by navigating to it on the emulator, the same 
way you open a document on the handheld, or you click 
File > Open Document.
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When you open a document using the emulator, you can only open 
documents that are in the folder displayed on the emulator (usually the 
My Documents folder, unless you specified a different folder in your 
TI-SmartView™ settings). When you open a document using the menu 
path, you can browse to find any TI-Nspire™ document on your 
computer or network. If you open a document using the emulated 
handheld, it replaces the document that was previously open.

Note: If the number of characters in the document’s file path name 
exceeds 256 characters, the document cannot be opened and an error 
message is displayed. To avoid this error, keep file and folder names short 
or move files up in the file path.

Saving a document
When you save a document using the File > Save Document menu or 
icon, keyboard shortcuts, keypad shortcuts, or emulator menus, the 
document is saved in the same location where the file was opened. To 
save the file in another location or with a different name, click 
File > Save As.

Using Screen Capture
To capture the current page, press Ctrl + J (Macintosh®: ì“ + J) on your 
keyboard or on the emulated handheld. The image is automatically 
placed in the clipboard and in the TI-Nspire™ Screen Capture window. 
You can paste the image into another application without having to take 
additional steps. This feature is only available when the TI-SmartView™ 
panel is active and the work space is in Handheld mode.

All other screen capture features work the same way they do in other 
areas of TI-Nspire™ software. For more information, please see the Using 
the Documents Workspace.
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Regulatory Information

FCC Statement
Note: This equipment has been tested and found to comply with the 
limits for a Class B digital device, pursuant to Part 15 of the FCC Rules. 
These limits are designed to provide reasonable protection against 
harmful interference in a residential installation. This equipment 
generates, uses and can radiate radio frequency energy and, if not 
installed and used in accordance with the instructions, may cause 
harmful interference to radio communications. However, there is no 
guarantee that interference will not occur in a particular installation.

If this equipment does cause harmful interference to radio or television 
reception, which can be determined by turning the equipment off and 
on, the user is encouraged to try to correct the interference by one or 
more of the following measures:

• Reorient or relocate the receiving antenna.

• Increase the separation between the equipment and receiver.

• Connect the equipment into an outlet on a circuit different from that 
to which the receiver is connected.

• Consult the dealer or an experienced radio/TV technician for help.

USA FCC Information Concerning Radio Frequency 
Interference

Product Name: 
TI-Nspire™ Navigator™ Cradle

FCC ID: V7R-TINAVWC2

Product Name: 
TI-Navigator™ Access Point

Model Number/Name: NAV-AP-US

FCC ID: V7R-TINAVAP

Product Name: 
TI-Nspire™ CX Wireless Network 
Adapter

FCC ID: 
V7R-TINAVWNA
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Federal Communication Commission Interference 
Statement
This equipment has been tested and found to comply with the limits for a 
Class B digital device, pursuant to Part 15 of the FCC Rules. These limits 
are designed to provide reasonable protection against harmful 
interference in a residential installation. This equipment generates, uses, 
and can radiate radio frequency energy and, if not installed and used in 
accordance with the instructions, may cause harmful interference to 
radio communications. However, there is no guarantee that interference 
will not occur in a particular installation. If this equipment does cause 
harmful interference to radio or television reception, which can be 
determined by turning the equipment off and on, the user is encouraged 
to try to correct the interference by one or more of the following 
measures:

• Reorient or relocate the receiving antenna.

• Increase the separation between the equipment and receiver.

• Connect the equipment into an outlet on a circuit different from that 
to which the receiver is connected.

• Consult the dealer or an experienced radio/TV technician for help.

FCC Caution: The TI-Navigator™ Access Point, TI-Nspire™ Navigator™ 
Cradle, and TI-Nspire™ CX Wireless Network Adapter comply with Part 
15 of the FCC Rules. Operation is subject to the following two conditions: 
(1) These devices may not cause harmful interference, and (2) these 
devices must accept any interference received, including interference 
that may cause undesired operation.

RF Radiation Exposure and Hazard Statement:
To ensure compliance with FCC RF exposure requirements, the 
TI-Navigator™ access point must be installed in a location such that the 
antenna of the device will be greater than 20 cm (7.9 inches) away from 
all persons. Using higher gain antennas and types of antennas not 
covered under the FCC certification of this product is not allowed. 
Installers of the radio and end users of the product must adhere to the 
installation instructions provided in this manual.

This transmitter must not be co-located or operating in conjunction with 
any other antenna or transmitter.
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Non-modification Statement:
Use only the integral antenna supplied by the manufacturer when 
operating these devices. Unauthorized antennas, modifications, or 
attachments could damage the TI-Navigator™ Access Point, TI-Nspire™ 
CX Wireless Network Adapter, or TI-Nspire™ Navigator™ Cradle and 
violate FCC regulations. Any changes or modifications not expressly 
approved by the party responsible for compliance could void the user's 
authority to operate this equipment.

Deployment Statement:
This product is certified for indoor deployment only. Do not install or use 
this product outdoors.

Canadian IC Information

Industry Canada Statement:
Operation is subject to the following two conditions in Canada:

1. these devices may not cause interference, and

2. these devices must accept any interference, including interference 
that may cause undesired operation of the device

To prevent radio interference to the licensed service (i.e. co-channel 
Mobile Satellite systems) these devices areintended to be operated 
indoors and away from windows to provide maximum shielding. 
Equipment (or its transmit antenna) that is installed outdoors is subject 
to licensing and not supported by the  Access Point, CX Wireless Network 
Adapter, or  Cradle.

European Union and European Free Trade Association 
(EFTA) Regulatory Compliance
This equipment may be operated in the countries that comprise the 
member countries of the European Union and the European Free Trade 
Association. These countries, listed in the following paragraph, are 
referred to as The European Community throughout this document:

Product Name: 
 Cradle

Product Name: 
 Access Point

Model Number/Name: NAV-AP-US

Product Name: 
 Wireless Network Adapter
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AUSTRIA, DENMARK, FINLAND, FRANCE, GERMANY, ITALY, 
NETHERLANDS, PORTUGAL, SPAIN, SWEDEN, UNITED KINGDOM,  
NORWAY, SWITZERLAND

The TI-Navigator™ access point communicates with either a 
TI-Navigator™ network hub, TI-Nspire™ Navigator™ wireless cradle, or 
TI-Nspire™ CX Wireless Network Adapter via a wireless 802.11b/g link to 
provide wireless local area networking (WLAN) capabilities and with a 
personal computer using a standard USB cable. The TI-Navigator™ access 
point includes one 802.11a and one 802.11b/g radio. In the current 
model, NAV-AP-US, the 802.11a radio is disabled at the factory and via 
software preventing it from being configured and used when installed at 
an end user facility.

Declaration of Conformity
Marking by this symbol:

indicates compliance with the Essential Requirements of the R&TTE 
Directive of the European Union (1999/5/EC).

This equipment meets the following conformance standards:

Safety: EN 60950-1:2001 + A11:2004

EMC: EN 55022:2006, EN 55024:1998 + A1:2001 + A2:2003, EN 301-489-1 
v1.7.1, EN 301-489-17 v1.3.2, CISPR22:1997, CISPR24

Including: EN 61000-3-2, -3-3, -4-2, -4-3, -4-4, -4-5, -4-6 and -4-11. The 
product is also licensed as required for additional country specific 
standards as required for the International Marketplace.

Radio: EN 300-328 v.1.7.1 (2006-10)

Electromagnetic compatibility and Radio spectrum Matters (ERM); 
Wideband transmission systems; Data transmission equipment operating 
in the 2,4 GHz ISM band and using wide band modulation techniques. 
Certifications are harmonized to the EN standards covering essential 
requirements under article 3.2 of the R&TTE Directive. Compliance 
includes testing with the supplied integral antenna.

SAR: EN 50385:2002
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European Community Declaration of Conformity
Hereby, Texas Instruments declares that the TI-Navigator™ access point, 
TI-Nspire™ Navigator™ wireless cradle, and TI-Nspire™ CX Wireless 
Network Adapter are in compliance with the essential requirements and 
other relevant provisions of Directive 1999/5/EC.

English Hereby, Texas Instruments declares that the 
TI-Navigator™ access point, TI-Nspire™ 
Navigator™ wireless cradle, and TI-Nspire™ CX 
Wireless Network Adapter are in compliance 
with the essential requirements and other 
relevant provisions of Directive 1999/5/EC.

The Declaration of Conformity may be consulted 
in the Product Stewardship page at 
education.ti.com.

Dansk Texas Instruments erklærer hermed, at 
TI-Navigator™ adgangspunktet, den trådløse 
TI-Nspire™ Navigator™ holder og den trådløse 
TI-Nspire™ CX netværksadapter er i 
overensstemmelse med de essentielle krav og 
andre relevante bestemmelser i direktiv 
1999/5/EF.

Du kan læse overensstemmelseserklæringen på 
produktforvaltningssiden på education.ti.com.

Norsk Texas Instruments erklærer herved at 
TI-Navigator™ tilgangspunkt, TI-Nspire™ 
Navigator™ trådløs bordholder og TI-Nspire™ 
CX Wireless Network Adapter overholder de 
vesentlige kravene og andre relevante 
bestemmelser i direktivet 1999/5/EC.

Samsvarserklæringen kan leses på siden 
Produktforvaltning på education.ti.com.

Suomi Texas Instruments vakuuttaa, että 
TI-Navigator™-liityntäpiste, langaton TI-Nspire™ 
Navigator™-kelkka ja TI-Nspire™ CX Wireless 
Network Adapter täyttävät direktiivin 1999/5/EY 
oleelliset vaatimukset ja ja muut asianmukaiset 
ehdot.

Vaatimustenmukaisuusvakuutus on 
tarkasteltavissa tuotevastuusivulla osoitteessa 
education.ti.com.
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Français Texas Instruments déclare que le point d’accès 
TI-Navigator™, le socle de synchronisation 
TI-Nspire™ Navigator‚™ et l’adaptateur de 
réseau sans fil TI-Nspire™ CX sont conformes aux 
exigences essentielles et aux autres clauses 
applicables de la Directive 1999/5/CE.

La Déclaration de conformité peut être consultée 
à la page Gérance du produit à 
education.ti.com.

Deutsch Texas Instruments erklärt hiermit, dass der 
TI-Navigator™ Zugangspunkt, die drahtlose 
TI-Nspire™ Navigator™ Basisstation und der 
drahtlose TI-Nspire™ CX Netzwerkadapter mit 
den wesentlichen Anforderungen und anderen 
relevanten Bestimmungen der Richtlinie 
1999/5/EG konform sind.

Die Konformitätserklärung kann auf der Seite 
“Engagement für die Umwelt” unter 
education.ti.com angezeigt werden.

Italiano Con la presente, Texas Instruments dichiara che il 
punto di accesso TI-Navigator™, la base di 
ricarica wireless TI-Nspire™ Navigator™ e la 
basetta wireless TI-Nspire™ CX  sono conformi ai 
requisiti fondamentali e ad altri provvedimenti 
della Direttiva 1999/5/CE.

È possibile consultare la Dichiarazione di 
conformità alla pagina Product Stewardship 
(Gestione responsabile del prodotto), 
all’indirizzo education.ti.com.

Nederlands Hierbij verklaart Texas Instruments dat het 
TI-Navigator™ accesspoint, de TI-Nspire™ 
Navigator™ draadloze slede en de TI-Nspire™ CX 
draadloze netwerkadapter voldoen aan de 
essentiële vereisten en andere relevante 
bepalingen van Richtlijn 1999/5/EC.

De verklaring van overeenstemming kan worden 
geraadpleegd op de pagina Product Stewardship 
(Productbeheer) op education.ti.com.
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Português A Texas Instruments declara, pela presente, que o 
ponto de acesso TI-Navigator™, a base sem fios 
TI-Nspire™ Navigator™, e o adaptador de rede 
sem fios TI-Nspire™ CX estão em conformidade 
com os requisitos essenciais e outras disposições 
relevantes da Directiva 1999/5/CE.

A Declaração de Conformidade pode ser 
consultada na página Administração do Produto 
em education.ti.com.

Español Mediante el presente documento, Texas 
Instruments declara que el punto de acceso 
TI-Navigator™, el soporte inalámbrico 
TI-Nspire™ Navigator™ y el adaptador de red 
inalámbrica TI-Nspire™ CX cumplen con los 
requisitos esenciales y otras disposiciones 
relevantes de la directiva 1999/5/CE.

Puede consultar la declaración de conformidad 
en la página Administración de producto en 
education.ti.com.

Svenska Texas Instruments deklarerar härmed att 
TI-Navigator™ anslutningspunkt, TI-Nspire™ 
Navigator™ trådlös tillkopplingsenhet och 
TI-Nspire™ CX trådlös nätverksadapter uppfyller 
de väsentliga kraven och övriga relevanta 
bestämmelser enligt direktivet 1999/5/EG.

Deklarationen om överensstämmelse kan läsas 
på sidan Produktansvar på webbplatsen 
education.ti.com.
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Countries of Operation and Restrictions of Use in the 
European Community

Operation Using the 2.400 to 2.4835 GHz Channels in the 
European Community
The installer and/or end user should use the configuration utility 
provided with this product to verify the current channel of operation, the 
expected transmit power level, and to confirm that the device is 
operating in conformance with the spectrum usage rules for the selected 
European Community country. If operation is occurring outside of 
the allowable channels as indicated in this guide, then operation 
of the product must cease immediately and the installer must 
consult with the local technical support staff responsible for the 
wireless network.

These devices are intended to be operated in all countries of the 
European Community. Additional restrictions of use for the 
TI-Navigator™ access point within the European Community countries in 
the 2.400 to 2.4835 GHz band are listed below.

• The frequencies associated with channels 1 to 13 in the 2.400 to 
2.4835 GHz band are allowed to be used either indoors or outdoors in 
all countries of the European Community, except where noted below:

• In Greece, Italy, Latvia, and Spain the end-user must apply for a 
license from the national spectrum authority to operate this device 
outdoors. Please consult the TI-Nspire™ Navigator™ Teacher 
Software Guidebook for further information regarding restrictions 
and operating conditions for outdoor configurations.

• In France, the following operation is permitted:

– Outdoor operation is only permitted using the 2.400 - 2.454 GHz 
band, which includes channels 1 to 7, at a maximum EIRP of 100 
mW (20 dBm).

– Outdoor operation is permitted in the 2.400 to 2.4835 GHz band 
on channels 1 to 13 at a maximum EIRP of 10 mW (10 dBm).

– Indoor operation is permitted in the 2.400 to 2.4835 GHz band on 
channels 1 to 13 at a maximum EIRP of 100 mW (20 dBm).

Warning Statements
Warning! Install the TI-Navigator™ Access Point in such a manner as to 
maintain a minimum of 20 cm (7.9 inches) separation distance between 
the radiating element(s) and all persons. This safety warning conforms to 
FCC radio frequency exposure limits.
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Warning! Do not touch or move the TI-Navigator™ Access Point when 
the antennas are transmitting or receiving.

Warning! The TI-Navigator™ Access Point, TI-Nspire™ Navigator™ 
Cradle, and TI-Nspire™ CX Wireless Network Adapter are intended for 
indoor use only. Do not install the device nor operate it outdoors.

Warning! Intentional radiators, such as the TI-Navigator™ Access Point, 
TI-Nspire™ Navigator™ Cradle, and TI-Nspire™ CX Wireless Network 
Adapter are not intended to be operated with any antenna(s) other than 
those furnished by Texas Instruments. An intentional radiator may only 
be operated with the antenna(s) with which it is authorized.

Warning! The TI-Navigator™ Access Point radio(s) are disabled by 
default and can be enabled only by the system administrator using the 
Management software application.

Warning! The radio frequency band, operating channels, and transmit 
power depend on the country of operation specified by the system 
administrator during setup and configuration using the Management 
software.

Warning! Only qualified personnel must perform installation. Read and 
follow all warning notices and instructions marked on the product or 
included in the documentation.
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Texas Instruments Support and Service

For U.S. and Canada:

For general information 

For product (hardware) service
Customers in the U.S., Canada, Mexico, Puerto Rico and Virgin 
Islands: Always contact Texas Instruments Customer Support before 
returning a product for service.

For all other countries:

For general information 

For more information about TI products and services, contact TI by e-mail 
or visit the TI Internet address.

Service and warranty information
For information about the length and terms of the warranty or about 
product service, refer to the warranty statement enclosed with this 
product or contact your local Texas Instruments retailer/distributor.

Home Page: education.ti.com

KnowledgeBase and 
e-mail inquiries:

education.ti.com/support

Phone: (800) TI-CARES / (800) 842-2737
For U.S., Canada, Mexico, Puerto Rico, and 
Virgin Islands only

International 
information:

education.ti.com/international

E-mail inquiries: ti-cares@ti.com

Home Page: education.ti.com

http://education.ti.com
http://education.ti.com/support
http://education.ti.com/support
http://education.ti.com/international
http://education.ti.com/support
http://education.ti.com
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Symbols
.tilb file 60, 103
©, comment 679

Numerics
3D functions

graphing 533
3D graph

animating 538
defining 533
displaying context menu for 533
editing 534
setting colors of 534

3D graphs
showing and hiding 536
tracing 537

3D view
customizing 536
rotating 537

A
About documents 119
About PublishView™ documents 

179
access point

activating 8
Accessing Screen Capture 147
account, teacher 20
activities

copying 47
filtering 45
keyword search 45
opening 46
saving 46
send to handhelds 47

adapter 1, 4
adding to network 12, 13
connecting to handhelds 14
removing from network 14

adding
(x,y) numerical input questions 

301
a Calculator to a page 404
classes 246

drop points questions 302
equation questions 299
files to transfer list 76
lists questions 304
Master Document 373
Notes to a page 645
open response questions 298
questions 295, 296
students to classes 249
teacher data to responses 351

adding a copyright 145
Adding a problem

PublishView(TM) 198
adding an application to a problem 

194
Adding color from a list 140
Adding color from a palette 140
adding hyperlink 210
adding images 212
Adding multiple applications to a 

page 131
adding problem to a document 134
Adding text

PublishView(TM) 205
adding text and numbers to a 

Graphs & Geometry page 521
adjacent cells

filling 553
adjusting a variable with a slider 465
adjusting histogram scale 608
adjusting variable values with a 

slider 636
algebra

menu in the Calculator 399
alphanumerics

adding to a Graphs & Geometry 
page 521

analytic and geometric work areas 
(Graphs & Geometry) 496

analytic/geometric work area 
differences 460

angle
finding the measure of 516

Angle Bisector tool 527
Angle tool 516
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angles
bisecting 527

animating
a 3D graph 538

animating a point on an object 530
animating objects 530
animation 530

changing speed of 532
pausing and resuming 532
resetting 532
starting 530
stopping 532

animation control panel (Graphs & 
Geometry) 531

animation values
capturing from Graphs & 

Geometry 566
capturing with Lists & 

Spreadsheet 566
answer

using last answer 436
answering

questions 307
appearance of work area, 

customizing 462
application

Calculator 397
Program Editor 673

applications 128
deleting 134
grouping 134
Question 291
swapping 132
using multiple 131

applications that accept images 169
Data & Statistics 169
Geometry 169
Graphs 169
Notes 169
Question 169

Applying a background color 649
Applying a text format 648
approximate results 404
approximating expressions 653

area
of a circle 516
of a polygon 516
of a rectangle 516
of a triangle 516

Area tool 516
arranging captured screens 154
arranging seating chart 254
assignments pane 364
assignments summary 364, 365
attach (Graphs & Geometry) 451
Attribute tool 458, 459, 530
attributes

changing appearance 458
frameborder 224
height 224
iframes 223
scrolling 224
width 224

attributes (Graphs & Geometry) 459
Automatically creating variables in 

Lists & Spreadsheet 429
auto-refresh screen capture feature 

155
axes

changing appearance 463
showing and hiding 462

B
background image 464, 635
bar chart data

organizing 341
bar charts

creating comparative 616
batteries

charging 5
beginning class sessions 252
bisecting a segment 526
bisecting an angle 527
BMP 171
borders

show and hide 202
box plot
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split by cagtegory 606
breaking long calculations 654
BUSY indicator 687

C
Calculate output option 570
Calculate tool 521
calculations

breaking 654
Calculator

adding to a page 404
getting started with 397

Calculator history 421
viewing 389, 421

Calculator toolbar 398
Calculator toolbar, using 404
calculus

menu in the Calculator 400
caption, clicking to see variable 

names for case plot (Data & 
Statistics) 598

Capture Class 147
printing screens 159
saving screens 158
using 148
view options 153

Capture Page 147, 160
capture pages

saving 143
Capture Selected Handheld 147, 161
captured screens

rearranging 154
refreshing 155

capturing
Graphs & Geometry data 566

Capturing a page 141, 160
Capturing a student handheld 148
capturing pages 141
Catalog 385

converting measurement units 
412

inserting items from 139, 385, 
387, 405, 408, 552, 569

catalog 137
categorical variable (Data & 

Statistics) 594
categories

sorting 621
splitting numeric plot 617

cell references
absolute and relative 551
using in a formula 552

cells
copying in a table 552
filling adjacent 553
linking to a variable 431, 554
selecting a block of 552
sharing table cells 553

changing 369
final scores 370
language 31
scores 369

Changing text colors 649
character strings

storing as variables 426
charging

batteries 5
cradles 5

charts
comparative bar chart 616

chi-square goodness of fit test 585
choosing a folder for 

PublishView(TM) objects 216
choosing a working TI-Nspire(TM) 

document
PublishView(TM) 196

circle
finding perimeter of 515
finding the area of 516

Circular definition error 693
Class Record

canceling file transfers 270
checking file transfers status 269
removing items 270
viewing file properties 271

class sessions
beginning 252
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ending 252
Class workspace 245

menu 273
classes

adding 246
adding students 249
changing for students 255
changing view 253
copying students 259
creating 246
moving students to 258
removing 249
removing students from 251

clear
error, ClrErr 701

clearing
data from columns 556
Live Presenter keypress history 

288
the Calculator history 390, 423

Clipboard with images 173
closing

Live Presenter 290
Transfer Tool 81

ClrErr, clear error 701
code snippet 233

creating 238
edit 238

collecting files 263, 374
color 648

adding 140
setting, 3D graph 534

color in Data & Statistics 635
color in Lists & Spreadsheet 455, 551
colors

changing text 649
using in documents 140

column
clearing data from 556
inserting into a matrix 408

column actions 365
columns

based on other columns 558
copying in a table 555

deleting from a table 555
generating data in tables 557
inserting in a table 555
linking to a list variable 547
moving in a table 556
resizing 554
selecting in a table 554
sharing table column as a list 546

comment, © 679
comments 650

inserting in Notes application 
650

comparative bar chart, creating 616
comparing screens 157
configure

plot list 339
connected handheld 124
connected handhelds 38
connecting

handhelds to cradles 16
handhelds to wireless adapters 

14
Construction Menu tools (Graphs & 

Geometry) 448
contact information 835
content

transferring 63
viewing 49

content pane 38
content toolbar 39
Content Workspace 35, 38

connected handhelds 38
links 37
local content 37
toolbar 35, 63
Web content 38

Content workspace
menus 63

context menu
displaying for 3D graph 533
opening 130

context menus
PublishView(TM) 187
PublishView(TM) objects 187
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TI-Nspire(TM) applications 187
control panel, animation 531
Convert to analytic on context menu 

(Graphs & Geometry) 451
Convert to geometric on context 

menu (Graphs & Geometry) 451
converting

measurement units 412
converting PublishView(TM) 

documents 216
converting text to a hyperlink 211
copying

items from Calculator history 
390, 421, 422

Live Presenter keypress history 
287

table cells 552
table data 564
table rows or columns 555

copying a screen 166
Copying and pasting a screen 166
copying and pasting problems 135
copying students 259
Copying supported files and folders 

126
copyright 144

adding information to 
documents 145

copyright information 144
copyright statement ii
correct

responses 347
cradles

adding to network 12
charging 5
checking LEDs 5
connecting to handhelds 16
removing from network 14

creating
a system of equations 411
classes 246
code snippet 238
folders 126
functions and programs 414

lists from a table column 546
matrices 407
piecewise functions 410
user-defined units 413
variables 425

Creating a new PublishView(TM) 
document 178

Creating a new TI-Nspire(TM) 
document 120

creating a point 500
creating a point on an object 500
creating a shape 511
Creating a variable from a Graphs & 

Geometry value 428
Creating a variable from a Lists & 

Spreadsheet cell value 430
creating a web page 233
creating linear objects

line 504
parallel line 506
perpendicular line 507
ray 504
segment 505
segment with midpoint 505
tangent line 509
vector 508

creating midpoints 505
creating objects 509
creating parallel lines 506
creating perpendicular lines 507
creating points and lines (Graphs & 

Geometry) 499
creating segments 505
creating shapes 509
creating tangents 509
creating vectors 508
customer support and service 835
customizing 462

3D view 536
customizing an embedded TI-

Nspire(TM) Document Player 229
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D
data

capturing from Graphs & 
Geometry 566

clearing from columns 556
generating columns of 557
graphing table data 561
raw and summary overview 601
sorting in a table 557
sorting plotted categories 621
view from Data View pane 337
view from Student pane 337

Data & Statistics 169
getting started with 591
plotting data from Lists & 

Spreadsheet 617
Data & Statistics menu 592
Data Collection 703

add offline sensor 767, 805
advance one 778, 802
advanced settings, playback 778, 

803
advanced setup 776, 804
all

all (select data set) 751, 807
all data (restore) 784, 806

autoscale now 752, 808
autoscale settings (before/after) 

752, 812
both, graph 746, 807
calibrate 725, 804
change data set name 762
change units 724, 803
collect data (Sensor Console) 813
collection

mode 718, 803
setup 803

column options 759, 806
configure sensor 767, 804
curve fit 734, 810
derivative settings 784, 812
draw prediction 785, 811
drop counting 724, 803

events with entry 721, 803
examine settings 730, 809
graph

graph 1 745, 807
graph 2 746, 807
graph title 747, 807
view 710, 812

in selected region 779, 806
restore 784, 806

integral 732, 809
interpolate 728, 809
keep 726, 802
menu

Analyze 809
Data 806
Experiment 802
Graph 807
View 812

meter 710, 812
model 736, 810
more (select data set) 751
more, select data set 808
motion match 786, 811
new

calculated column 764, 806
data set 767, 806
experiment 802
manual column 763, 806

outside selected region 779, 806
restore 784, 806

pause/resume 777, 802
performing an experiment 711
photogate timing 723, 803
playback rate 778, 802
point options 755, 812

color 756
mark 755
marker 757

print all settings 792, 812
remote collection 804

collecting data 770
retrieving data 773
selecting unit 768
using delay 772
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using manual trigger 771
remove (analysis options) 739, 

811
replay 777, 802
restore data 784, 806
reverse 725, 804
run1 (or other data set name) 

751, 807
select

data set 751, 807
x-axis column 758, 807
y-axis column 758, 807

selected events 722, 803
Sensor Console 794

menu ref 813

context menu 814
setup sensors 724, 803
show

graph 744, 807
show graph using Page

Layout 787
show/hide

details 742, 813
meters 813

start playback 777, 802
start/stop collection 726, 728, 802
statistics 733, 809
store data set 743, 802
strike data 779, 806
table 710, 812
tangent 729, 809
time based 719, 803
triggering 774, 804
using a computer or handheld 

705
window settings 749, 808
with other apps 794
zero 725, 804
zoom

in 753, 808
out 753, 808

data types
variables 426

Data View pane 332
hiding responses 345
live results 332
view data 337

deactivating math expression boxes 
655

dedicating TI-Nspire(TM) Document 
Player window 242

deferring evaluation in Calculator 
411

define work area window (Data & 
Statistics) 597

defined function
recalling 418

defining
3D graph 533
functions and programs 414
internal subroutine 692
multiple-line functions 414, 416
piecewise functions 410
units 413

defining an intersection point 501
delete a hyperlink 211
delete image 175
deleting

an element from a list in Lists & 
Spreadsheet 548

an entry from the Calculator 
history 422

applications 134
contents of table cells 552
files 79
files from Portfolio 375
keypress history in Live Presenter 

288
pages 134
part of an expression 419
problems 135
table rows and columns 555
variable, DelVar 691
variables 437

Deleting a problem
PublishView(TM) 199

deleting a text box 192
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deleting functions 488
deleting images 175, 214
DelVar, delete variable 691
derivative

finding the 492
Destination folder

editing 78
differential equations, graphing 480
dilating an object 525
Dilation tool 526
Disp, for debugging 701
display

Disp command 689
displaying the teacher handheld 152
document

create 120
settings 93

document properties 144
documents

closing 128
colors 140
comverting 216
deleting 126
making read-only 145
open for review 335, 336
open in Review workspace 335
printing 143, 219
protecting 145
saving 121, 183
send to class 61
sharing 239
sharing offline 242
sharing online 239
storing 239
TI-SmartView(tm) emulator 823

documents in tiled view 127
Documents Toolbox

PublishView(TM) 184
Documents workspace 83

menu 106
draw option, example 640
Draw output option 570
drop points questions

adding 302

E
edit mode

PublishView(TM) 207
Edit Relation on context menu 

(Graphs & Geometry) 451
editing

a 3D graph 534
Destination folder 78
math expressions 390, 418
scores 369
values in a list 547

editing a hyperlink 210
editing code snippets 238
editing functions 486
editing text

PublishView(TM) 207
else if, ElseIf 695
else, Else 695
ElseIf, else if 695
embedded document

view source code 233
embedded TI-Nspire(TM) Document 

Player 229
embedded web pages 221
embedding documents in web pages 

221
emulator, see

TI-SmartView(tm) emulator 817
end

for, EndFor 694, 697
if, EndIf 694
loop, EndLoop 699
try, EndTry 701
while, EndWhile 698

end values
showing and hiding 462

EndFor, end for 694, 697
EndIf, end if 694
ending class sessions 252
EndLoop, end loop 699
EndTry, end try 701
EndWhile, end while 698



845

You should upgrade your computer software and calculator OS 
regularly to take advantage of all the newest features and 
functionality.

entering math expressions 384, 404, 
652

entry line
showing and hiding 462

equation questions
adding 299

equations
identifying 513
labeling 513

equivalency
organizing 343

errors
showing 654

errors and troubleshooting
Circular definition 693
clear error, ClrErr 701
pass error, PassErr 701
programs 701

evaluating
math expressions 384, 404

evaluating a math expression 386, 
407

evaluating math expressions 404
exchanging table data 564
execute program, Prgm 692
exploring

Live Presenter 282
Exploring the Documents Toolbox 

184
Exploring the web page 228
export

generate HTML code 233
Export HTML to Clipboard 233
Export options 233
Export Web Page 233
exporting

results from Portfolio 371
exporting HTML to the clipboard 238
Exporting to a web page 233
expression templates

using 139, 405, 552
expressions 652

approximating 653

copying from Calculator history 
390, 421, 422

deleting part of 419
editing 390, 418
entering and evaluating 384, 404
entering from a template 386, 

407
entering in a table 549
entering with a wizard 387, 408, 

569
evaluating 653
selecting in Calculator 390, 419
variables 426

F
FCC statement 825
file properties 271
File transfers

stopping 81
file transfers

canceling 270
checking status 269

Files
deleting 79

files
adding to transfer list 76
canceling transfers 270
collecting 263, 374
removing from Transfer List 77
selecting for a lesson bundle 56
sending 261, 375
types you can transfer 124
using My Files to move 125
video 214
viewing properties 271

filling adjacent cells 553
filtering activities 45
final score

changing 370
finance 419
finance functions 420
finance solver 419
finding
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text in Program Editor 683
finding and replacing

text in Program Editor 683
finding points of interest 492, 522
finding the derivative (slope) of a 

function 492
folder

Publishview(TM) objects 216
folders

creating 126
footers

inserting text 201
for, For 694, 697
format text 648
formatting text

PublishView(TM) 207
frequency plot 562
function definition

recalling 418
function, y= 484
functions

creating 414
creating piecewise 410
defining multiple-line 414, 416
deleting 488
editing 486
entering (Graphs & Geometry) 

470, 475
graphing 3D 533
renaming 485
storing as variables 426
user-defined 691
working with (Graphs & 

Geometry) 470

G
Gallery view 153
generating

data in tables 557
generating HTML source code 233
Geometry 169
global variables 691
go to, Goto 693, 696, 700

grading questions 369
Graph Trace tool (Data & Statistics) 

597
Graph Type Menu tools (Graphs & 

Geometry) 443
graphing

3D functions 533
differential equations 480
table data 561

graphing inequalities 485
Graphs 169
Graphs & Geometry

variables, creating 428
work area 452

grid
showing and hiding 462
spacing 463

group
objects (Graphs & Geometry) 498

grouping applications 134
grouping objects (Graphs & 

Geometry) 451

H
handheld

capturing 148, 161
opening handheld documents 

on the computer 125
OS update 105
saving a document to 124

handhelds
connecting to adapters 14
connecting to cradles 16
Content Workspace 38
locating using Identify Selected 

51
renaming 53
send activities 47
software 6
viewing content on connected 

49
headers

inserting text 201
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Help menu 32
hide student names 149
Hide/Show Axes tool 463
hiding

3D graphs 536
handheld display in Live 

Presenter 285
Live Presenter keypress history 

287
presenter handheld 285
responses 343
responses from Data View pane 

345
responses from Student pane 

344
student names in Live Presenter 

284
Hiding problem breaks

PublishView(TM) 199
histogram

properties of 608
histogram scale, adjusting 608
history

deleting Calculator history 390, 
423

in Calculator 421
viewing Calculator 389, 421

history, Calculator
copying from 390, 421, 422

HTML
exporting to clipboard 238
generate code 233

HTML code for iframes 223
HTML document 233
HTML inline frames 222
hyperlink

adding 210
editing 210
remove 211

hyperlinks in PublishView(TM) 207

I
icons

Review workspace 355
Identify Selected 51
identifying an equation 513
if, If 694, 695
iframe

frameborder 224
height 224
scrolling 224
width 224

iframe attributes 224
source 223

iframe source code 222
iframe tags 223
Iframe tags and attributes 223
iframes 222
image

inserting in Data & Statistics 635
inserting in Graphs & Geometry 

464
Image types 171

bmp 171
jpg 171
png 171

images
deleting 214
inserting 649
moving 213
PublishView(TM) 212
resizing 214

images, working with
applications 169
Clipboard 173
context menu 173
delete 175
image types 171
maximum color depth 176
maximum memory 176
maximum number 176
maximum pixel size 176
moving 175
pasting 173
resize 175
selecting 174

importing
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items to Portfolio workspace 368
incorrect

responses 347
individualize student responses 340
inequalities

graphing 485
inferential statistics

calculating test results 
(Calculate) 570

drawing plots 640
graphing test results (Draw) 570
input descriptions table 570
pooled option 588

inline frames 222
insert page

PublishView(TM) 194
inserting

a Calculator on a page 404
a row or column in a table 555
a row or column into a matrix 

408
an element in a list in Lists & 

Spreadsheet 548
an image in Data & Statistics 635
an image in Graphs & Geometry 

464
comments in Notes application 

650
Notes on a page 645

inserting a link to video files 214
inserting a text box

PublishView(TM) 189
inserting an image 171

Clipboard 173
context menu 173
Insert command 172
original image is replaced 171
pasting 173

Inserting Images 649
inserting images 212
inserting items from the Catalog 385
Inserting math expressions, shapes, 

or comments 650
inserting text (Data & Statistics) 595

inserting text in headers and footers 
201

inserting text into a text box 205
installing handheld software 6
intercept

changing for a line 625
Intersection Point tool 501
intersection points

defining 501
inventory 2
invT (inverse Student T distribution) 

579
items

insert from catalog 385

J
Java applets 238
JPG 171

K
keypress history

copying 287
hiding in Live Presenter 287
Live Presenter 284
showing in Live Presenter 287
viewing in Live Presenter 286

keyword search 45

L
label, Lbl 693, 696, 700
labeling an equation 513
language

changing 31
lanuching a dedicated TI-Nspire(TM) 

Document Player window 242
last answer

using 436
launching edit mode

PublishView(TM) 207
launching TI-Nspire(TM) Document 

Player 226
LED
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cradles 5, 20
status on cradles 5

length
labeling 513
measuring 513

Length tool 514, 515
lesson bundle 53, 102

add files 101
adding files 54
creating 54
e-mailing 61, 104
managing 104
managing files 58
opening files 57
packaging 103
selecting files 56
sending to connected handhelds 

105
lesson bundles

packaging 60
libraries 138, 665
library objects

using 667
line

finding the slope of 517
Line tool 504
lines

creating 499
lines of regression 627
lines, creating 504
linking

table cell to a variable 431, 554
table column to a list 547
values 425

linking to a web site 210
linking to video files 214
linking variables 431
links 41

adding 42
editing 43
moving 43
removing 43
removing linked variables 437

links toolbar 41

list data
organizing 341

lists
capturing Graphs & Geometry 

data 566
deleting elements in a table 548
inserting elements in a table 548
sharing table columns as 546
storing as variables 426
viewing and editing 547

Lists & Spreadsheet
adding to a page 546
getting started with 541
variables 430, 431, 433

Lists & Spreadsheet toolbar 542
lists questions

adding 304
live activities 325, 340
Live Presenter 160, 281

clearing keypress history 288
copying keypress history 287
Display pane 283
exploring 282
Handheld pane 283
hiding keypress history 287
hiding presenter handheld 285
hiding student names 284
hiding the handheld display 285
keypress history 284
Menu bar 283
playing a recording 290
recording the live presentation 

289
requirements 281
save recording 289
sharing recordings 290
showing keypress history 287
showing presenter handheld 285
showing student names 284
showing the handheld 286
showing the handheld screen 

288
start recording 289
starting 281
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starting from Class Screen 
capture 281

stop recording 289
stopping 290
Tool bar 283
View options 284
viewing keypress history 286

Live Presenter keypress history
clearing 288

live results 332
local variable, Local 690
locking

measurements 459
points 459

locking the intercept of movable line 
at zero 626

locus
creating 528

Locus tool 528, 529
logging in to network 24
login status 254
loop, Loop 699

M
Make Presenter 157
managing problem breaks

PublishView(TM) 199
Managing TI-Nspire™ documents 

120
Master Document

adding 373
opening 373

math expression boxes
attributes 656
converting to 655
deactivating 655

math expressions 650
editing 390, 418
entering and evaluating 384, 404
entering in a table 549
selecting in Calculator 390, 419
with multiple statements 432

math operators 138

math templates 136
using 139, 405, 552

matrices
creating 407
storing as variables 426

matrix
inserting a row or column 408

maxima
finding 492, 522

Measurement Menu tools (Graphs & 
Geometry) 447

measurement units, converting 412
measurements

finding angle 516
storing as variables 426
transferring onto objects 518

measuring length 513
Menu

Data & Statistics 592
menu

context 130, 533
Documents workspace 106
Screen Capture 150

menus
Content workspace 63
options and functions for Class 

workspace 273
Portfolio workspace 376
PublishView(TM) 186
Review workspace 355
TI-Nspire(TM) Screen Capture 

window 163
Midpoint tool 505
minima

finding 492, 522
modes

setting in programs 700
modify

nspirefile parameter 240
modifying the nspirefile parameter 

240
movable line

adding to a plot 624
locking intercept at zero 626
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tracing 626
movable line, adding (Data & 

Statistics) 595
movalble line

rotating 625
move image 175
moving

rows and columns in a table 556
vector 509

moving a text box
PublishView(TM) 191

moving images 175, 213
moving multiple points in Data & 

Statistics 620
moving pages with the Page Sorter 

132
moving students 258
multiple applications 131
multiple cells

selecting 552
multiple choice questions

adding 296
multiple documents

working with 127
multiple documents in tiled view 127
multiple-line functions

defining 414, 416
multiple-statement expressions 432
My Files

moving files and folders 125

N
names

changing 257
naming

table columns 546
naming objects during construction 

503
naming variables

preventing name conflicts 554
navigating in a table 546
network

logging in 24

setting up 8
normal probability

creating plot 609
Normal Probability plot (Data & 

Statistics) 592
Notes 169

adding to a page 645
inserting comments in 650
PublishView(TM) 205
selecting text 648
toolbar 645

nspirefile parameter 223
numeric plot, splitting by categories 

617
numerical input questions

adding 301

O
object

finding perimeter of 515
objects

creating 509
dilating 525
naming while constructing 503
PublishView(TM) 216
reflecting 523
rotating 525
symmetry of 523
translating 524

ODEs (ordinary differential 
equations) 480

offline
sharing files 242
storing files 242

online storage sites 229
open

documents for review 335
open response questions

adding 298
opening

files 122
Master Document 373
Portfolio item 372
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Quick Poll 316
Transfer Tool 75

Opening Content Explorer 122
Opening Context menus 130
Opening Notes 644
Opening the application menu 129
organize

bar chart data 341
by equivalency 343
list data 341
responses 339

OS
handheld 105

overview
software 29
TI-Nspire(TM) Navigator(TM) 

Teacher Software 29

P
packaging lesson bundles 60
page

multiple applications 131
Page Sorter 132

moving pages 133
rearranging pages 133

pages 134
adding 135
adding a Lists & Spreadsheet 

application 546
adding to a problem 135
capturing 141
deleting 134
multiple applications 131
saving captured 143
ungroup 134
using the page sorter 133

panning views 462
Parallel (Line) tool 506
parameters

nspirefile 223, 240
pass error, PassErr 701
passwords

changing for teacher 22

resetting for students 271
pasting

table data 564
pasting a screen 166
pasting images 173
pasting problems 135
pause, Pause 701
performing an experiment 711
perimeter

finding 515
Perpendicular (Line) tool 507
Perpendicular Bisector tool 526
picture as background 464, 635
piecewise functions

creating 410
pinning objects (Graphs & 

Geometry) 451, 498
playing

Live Presenter recording 290
plot

a value on existing plot 621
summary 562

plot list
configure 339

plot mean (Data & Statistics) 596
plot standard deviation (Data & 

Statistics) 596
plot type

changing 623
Plot types menu (Data & Statitics) 

592
plot value tool (Data & Statistics) 596
plotting

table data 561
PNG 171
Point On tool 500
Point tool 500
points

creating 499, 500
moving in Data & Statistics 620
redefining 503
selecting multiple in Data & 

Statistics 620
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Points and Lines Menu tools (Graphs 
& Geometry) 446

points of interest, finding 492, 522
points on

creating 500
polling students 318
polls

responding to 321
stopping 318
viewing results 319

polygon
finding perimeter of 515
finding the area of 516

pooled option 588
Portfolio

adding Master Document 373
assignments pane 364
assignments summary 364
column actions 365
editing scores 369
exporting results 371
Master Document 373
opening an item 372
redistributing an item 374
removing items 375
renaming an item 375
saving documents 367
sorting 371
workspace 363

Portfolio workspace
menu 376
save Review documents 354

precision of results 404
pre-defined measurement units 412
preview pane 39
printing

previewing 144
printing captured screens 159
Printing documents 143
printing PublishView(TM) 

documents 219
probability

creating plot 609
problem

adding to PublishView(TM) 194
problems 134

adding pages 135
adding to documents 134
copying 135
deleting 135
pasting 135
PublishView(TM) 198
renaming 135

Program Editor
overview 673

programs
creating 414

programs and programming
arguments 688
branching 694, 696
calling another program 692
clear error, ClrErr 701
comment, © 679
debugging 701
Disp 689
else if, ElseIf 695
else, Else 695
end for, EndFor 694, 697
end if, EndIf 694, 695
end loop, EndLoop 699
end try, EndTry 701
end while, EndWhile 698
for, For 694, 697
functions 691
go to, Goto 693, 696, 700
if, If 694, 695
label, Lbl 693, 696, 700
local, Local 690
loop, Loop 699
looping 694, 697, 698
pass error, PassErr 701
passing values 688
return, Return 693
running 684
stopping 687
subroutines 692
Then, Then 695
try, Try 701
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while, While 698
Proof template 646
properties of files 271
protecting a document 145
PubishView(TM)

hiding problem breaks 199
publishing documents as web pages 

221
PublishView

inserting text 205
show and hide borders 202

PublishView(TM)
add text 205
adding a problem 198
adding an application 194
contect menus 187
convert text to hyperlink 211
converting documents 216
delete images 214
deleting a problem 199
deleting a text box 192
Documents Toolbox 184
edit a hyperlink 210
hyperlinks 207
images 212
inserting a text box 189
inserting headers and footers 

201
inserting images 212
launching edit mode 207
linking to a web site 210
managing problem breaks 199
menus 186
moving text box 191
new document 178
printing documents 219
problems 198
remove hyperlinks 211
renaming a problem 199
resize text box 190
showing problem breaks 199
software requirements 177
status bar 182
toolbar 186

using Notes 205
video console 215
video file links 214
video files 214
working document 196

PublishView(TM) documents 179
PublishView™ documents 119
PublishView™ feature 177

Q
Q & A template 646
Question 169

answering questions 307
navigating the application 306
toolbar 305

questions
(x,y) numerical input 301
adding 295
drop points 302
equation 299
lists 304
multiple choice 296
open response 298
using the Question application 

291
Questions - students

accessing toolbar 305
checking you answer 307
coordinate points 311
drop points 312
equation 309
how to answer 307
list 312
multiple choice 308
navigating 306
open response 309
toolbar options 305
types of 306

Quick Graph, using 561
Quick Poll

opening 316
polling students 318
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responding to polls (students) 
321

stopping polls 318
viewing results 319

R
randomize screen option 152
raw data 601

adjusting histogram scale 608
ray

finding the slopeof 517
Ray tool 504
rays

creating 504
read-only documents 145
rearranging captured screens 154
rearranging pages 133
recalling

a function definition 418
recording

Live Presenter presentation 289
starting Live Presenter recording 

289
rectangle

finding perimeter of 515
finding the area of 516

Redefine tool 503
redefining a point 503
reflecting an object 523
Reflection tool 523
refreshing captured screens 155
regression

showing lines of 627
regression line

requirements for 626
regression tools (Data & Statistics) 

596
removing

classes 249
files from Portfolio 375
students from classes 251
variables 437

removing a hyperlink 211

removing adapters or cradles from 
network 14

removing files from Transfer list 77
renaming

problems 135
Renaming a problem

PublishView(TM) 199
renaming functions 485
renaming Portfolio items 375
replacing

text in Program Editor 683
repositioning a measured value 517
requirements

Live Presenter 281
viewing embedded web pages 

221
rescaling a graph

dilation 624
translation 623

rescaling the work area 463
resetting student passwords 271
residuals tools (Data & Statistics) 596
resize image 175
resizing

table rows and columns 554
vector 509

resizing a text box
PublishView(TM) 190

resizing image 175
resizing images 214
responding to polls 321
responses

add teacher data 351
hiding 343
individualize 340
mark correct or incorrect 347
organize 339
show 346

results
approximating 404
copying from Calculator history 

390, 421, 422
deferring in Calculator 411
using last answer 436
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return, Return 693
reusing

items from Calculator history 
390, 421, 422

last answer in Calculator 436
Review toolbox 327
Review workspace

live activities 325
menus 355

rotating an object 525
rotating the 3D view 537
row

inserting into a matrix 408
rows

copying in a table 555
deleting from a table 555
inserting in a table 555
moving in a table 556
resizing 554
selecting in a table 554

S
save

Review documents to Portfolio 
workspace 354

saving
documents 121, 183
items to Portfolio workspace 367
Live Presenter recording 289

saving a document to a connected 
handheld 124

Saving captured pages 143
saving captured pages 165
Saving handheld documents in the 

software 126
saving handheld screens 165
saving Scratchpad contents 396
Saving screens using Capture Class 

158
Saving TI-Nspire(TM) documents 121
scale indicator

showing and hiding 462
scaling 94

science
data collection 703
performing an experiment 711

scores 369
changing 369, 370

scoring questions 369
Scratchpad

saving 396
Screen Capture 141

Accessing 147
Capture Class 147
Capture Page 147, 160
Capture Selected Handheld 161
Capture Selected Handhelds 147
copy 166
Gallery view 153
hide student names 149
menu 150
paste 166
show student names 149
Teacher Preferences 152
Tiled view 153
tool bar 150
zoom in 156
zoom out 156

screen capture
auto-refresh 155
comparing screens 157
Make Presenter 157
zoom percentage 156

Screen Capture tool
Live Presenter 160

screens
comparing 157

scrolling
a table 546

seating chart
arranging 254
changing class view 253

segment
bisecting 526
finding the slope of 517

Segment tool 505
selecting
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a block of table cells 552
expressions in Calculator 390, 

419
multiple points in Data & 

Statistics 620
table rows or columns 554
text in Notes application 648

Selecting a template 646
selecting images 174
Selecting pages in the Page Sorter 

133
selecting pages with the Page Sorter 

132
self-check

document types 294
send to class

documents 61
sending

files 261, 375
Sensor Console. See Data Collection
sequence

plotting (Graphs & Geometry) 
476

sequences
generating in a table column 559

service and support 835
set axes min and max (Data & 

Statistics) 597
setting a zoom percentage 156
setting up network 8
settings

TI-SmartView(tm) emulator 822
Shape tool 511
shapes 650

adding in Notes 651
creating 509, 511

Shapes Menu tools (Graphs & 
Geometry) 447

sharing
a table column as a list 546
Live Presenter recording 290
table column as a list 546
table-cell values 553

sharing documents 239

sharing documents online 239
sharing files offline 242
shortcuts 41

adding 41
deleting 41

Show Normal PDF (Data & Statistics) 
597

Show Student Names 149
showing

3D graphs 536
handheld in Live Presenter 286
Live Presenter handheld screen 

288
Live Presenter keypress history 

287
presenter handheld 285
responses 346
student names in Live Presenter 

284
student responses 346

showing and hiding borders
PublishView(TM) 202

showing problem breaks
PublishView(TM) 199

showing warnings and errors 654
slider

animating a 3D graph 538
using to adjust a variable 465

sliders 636
sliders (Data & Statisitcs) 595
slope

finding the derivative of a 
function 492

of a line 517
of a ray 517
of a segment 517
of a vector 517

slope fields 480
Slope tool 517
software

overview 29
upgrading 25

Software fequirements
PublishView(TM) 177
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sorting
Portfolio items 371
student information 255
table data 557

sorting plotted categories 621
source attribute 223
source code

iframes 222
viewing 233

source code template 234
splitting

numeric plot by categories 617
splitting a categorical plot 616
spreadsheet applications, 

exchanging data with 564
Starting

Live Presenter from Class Screen 
Capture 281

starting
Live Presenter 281
Live Presenter recordings 289
transfer 80

statistics
drawing plots 640

status bar
Class workspace 246
Documents workspace 84, 93
Review workspace 325

status of file transfers 269
stopping

file transfers 81
Live Presenter 290
Live Presenter recording 289

stopping polls 318
storage site

online 229
stored variables

linking to 431
storing document 239
storing file offline 242
strings

storing as variables 426
student handheld

capturing 148

student information, sorting 255
student list

changing class view 253
Student pane

hiding responses 344
viewing data 337

student pane
Review workspace 329

student responses
hiding 343
individualize 340
organizing 339
show 346

students
adding to classes 249
arranging in seating chart 254
changing classes 255
changing names 257
checking login status 254
copying 259
moving 258
polling 318
removing from classes 251
resetting passwords 271
responding to polls 321

substituting a value for a variable 
437

summary data 601
Summary Plot 561
summary plot 562
support and service 835
symbols 137
symmetry 523
Symmetry tool 523
syntax

using to prevent naming 
conflicts 554

system of equations 411

T
table data

exchanging with other 
applications 564
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graphing 561
sorting 557

table data use in statistical analysis 
(Lists & Spreadsheet) 569

tables
capturing Graphs & Geometry 

data 566
copying a row or column 555
deleting contents of cells 552
deleting list elements in 548
deleting rows and columns 555
generating column data 557
getting started with 541
inserting a row or column 555
inserting list elements 548
linking a column to a list 547
moving a row or column 556
navigating in 546
selecting a row or column 554
sharing a column as a list 546
working with cells 551

tags
iframes 223

Tangent tool 509
teacher

add to classroom view 21
teacher account 20

changing password 22
changing user name 23

teacher data
adding to responses 351

teacher handheld
displaying 152

Teacher Preferences 152
Teacher Tool Palette 293
template

selecting 646
source code 234

templates
Proof 646
Q & A 646
using 386, 407

text

add to PublishView(TM) 
document 205

adding to a Graphs & Geometry 
page 521

convert to hyperlink 211
editing and formatting 207
finding and replacing in Program 

Editor 683
finding in Program Editor 683
formatting in Notes 647
headers and footers 201
selecting in Notes application 

648
text box

delete 192
inserting text 205
moving 191
resize 190

text colors 649
text editor 238
text formats 648
Text tool 452, 484
text, converting (Graphs & 

Geometry) 453
Then, Then 695
TI Connect, exchanging data with 

564
tic marks

spacing 463
Tiled view 153
tiled view 127
time plot

sequence (Graphs & Geometry) 
476

TI-Nspire(TM) Document Player 226
customizing 229

TI-Nspire(TM) Document Player tool 
bar 229

TI-Nspire(TM) Navigator(TM) 
Teacher Software
overview 29

TI-Nspire(TM) Screen Capture 
Window
zoom in and out 164
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TI-Nspire(TM) Screen Capture 
window 162
menu 163

TI-Nspire(TM) window
tool bar 163

TI-Nspire™ CX Wireless Network 
Adapter 1, 4
adding to network 12, 13
connecting to handhelds 14
removing from network 14

TI-Nspire™ Document Player
description 169

TI-Nspire™ documents 119
TI-Nspire™ Navigator™ Cradle

adding to network 12
checking the LED 5
removing from network 14

TI-SmartView(tm) emulator 817, 820
capturing screens 824
opening 817
options 822
settings 822
sizing 819
working with documents 823

title, clicking to see variable names 
(Data & Statistics) 598

tool bar
Screen Capture 150

tool bars
TI-Nspire(TM) Document Player 

229
TI-Nspire(TM) Screen Capture 

window 163
toolbar

Content Workspace 35, 63
Documents workspace 106
links 41
Notes 645
PublishView(TM) 186
Review workspace 355
using in Calculator 404

toolbars
Calculator 398
Lists & Spreadsheet 542

toolbox
Review workspace 327

Tools
Angle 516
Angle Bisector 527
Area 516
Attributes 458, 459, 530
Calculate 521
Dilation 526
Hide/Show Axes 463
Intersection Point 501
Length 514, 515
Line 504
Locus 528, 529
Midpoint 505
Parallel 506
Perpendicular 507
Perpendicular Bisector 526
Point 500
Point On 500
Ray 504
Redefine 503
Reflection 523
Segment 505
Shape 511
Slope 517
Symmetry 523
Tangent 509
Text 452, 484
Trace 469, 470
Translate 524
Vector 508

tools
variable

variable

tool 431
tools menu 30
trace distribution curve (Data & 

Statistics) 597
trace plotted function (Data & 

Statistics) 597
trace regression (Data & Statistics) 

597
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Trace tool 469, 470
Tracing

3D view 537
Transfer

starting 80
Transfer List

removing files 77
Transfer Tool 73

adding files 76
closing 81
interface 73
opening 75
removing files 77

transferring a measurement onto a 
circle 520

transferring measurements 518
transfers

canceling 270
Transformation Menu tools (Graphs 

& Geometry) 449
Translate tool 524
translating an object 524
triangle

finding perimeter of 515
finding the area of 516

try, Try 701

U
unattach (Graphs & Geometry) 451
underscore symbol in conversions 

412
Ungroup objects (Graphs & 

Geometry) 498
ungroup pages 134
ungrouping objects (Graphs & 

Geometry) 451
unit conversions 138
units

converting measurement uints 
412

creating user-defined 413
unpinning objects (Graphs & 

Geometry) 451, 498

user name, changing for teacher 23
user-defined functions 691
using

TI-Nspire(TM) Document Player 
226

Using Capture Class 148
Using color in notes 648
Using Content Explorer to locate 

files 122
using export to generate HTML 

source code 233
using hyperlinks 207
Using Screen Capture 141
Using templates 645
Using the Clickpad 821
Using the menus and toolbar 186
Using the status bar in 

PublishView(TM) 182
utilities 136

catalog 137
inserting items 139
libraries 138
math operators 138
math templates 136
symbols 137
unit conversions 138
wizards 139

V
values

assigning to variables 425
variable, adjusting value with a 

slider 465
variables 411

adjusting value with a slider 636
checking in Calculator 427
creating 425
creating from table cells 553
delete, DelVar 691
Graphs & Geometry values 428
linking 425, 431
linking table column to a list 547
linking to 431, 554
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Lists & Spreadsheet cells 430, 433
local, Local 690
preventing naming conflicts 554
removing 437
sharing table column as a list 546
sharing with other applications 

425
substituting a value for 437
types 426
updating in Calculator 436
using 425
using in a calculation 432

vector
finding the slope of 517
moving 509
resizing 509

Vector tool 508
Vernier DataQuest™. See Data 

Collection
video console 215
view

data 337
view options

Capture Class 153
Live Presenter 284

view, changing for class 253
viewing

data 337
embedded PublishView(TM) 

documents 221
embedded TI-Nspire(TM) 

documents 221
Live Presenter keypress history 

286
poll results 319
values in a list 547

viewing captured screens 162
viewing copyright information 144
Viewing document properties 144
viewing embedded PublishView(TM) 

documents 221
viewing embedded TI-Nspire(TM) 

documents 221
viewing embedded web pages

requirements 221
viewing the source code 233
views 462

in Graphs & Geometry 460

W
warnings

showing 654
Web Content 44
web page

create 233
explore 228
view source code 233

web plot
sequence (Graphs & Geometry) 

476
Welcome Screen 27

navigating 28
opening 29

while, While 698
window

TI-Nspire(TM) Document Player 
242

Window Menu tools (Graphs & 
Geometry) 443

Window Settings tool 463
windows

TI-Nspire(TM) Screen Capture 
162

wireless adapter 1, 4
adding to network 12, 13
connecting to handhelds 14
removing from network 14

wizard
entering expressions with 387, 

408, 569
network setup 8

wizards, using in utilities 139
work area

customizing 462
Graphs & Geometry 452
zooming or rescaling 463

work areas
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multiple 131
working document

PublishView(TM) 196
working folder 193
working with context menus 187
working with functions (Graphs & 

Geometry) 470
working with images 212
Working with problems 198
Working with problems and pages 

134
Working with PublishView(TM) 

documents 177
working with PublishView(TM) 

documents 179
working with video files 214
workspaces 30, 31

Class 245
Content 35
Documents 83
Portfolio 363
Review 325

Y
y= functions, graphing 484

Z
zeroes

finding 492, 522
zoom in 156, 164
zoom out 156, 164
zoom percentage 156
zoom, adjusting (Data & Statistics) 

597
zooming the work area 463
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